All Classes (XWork: Core 2.1.6 API)

 All Classes
AbstractFieldValidatorDescription
AbstractInterceptor
AbstractMatcher
AbstractRangeValidator
Action
ActionAutowiringInterceptor
ActionChainResult
ActionConfig
ActionConfig.Builder
ActionConfigMatcher
ActionContext
ActionEventListener
ActionInvocation
ActionProxy
ActionProxyFactory
ActionSupport
ActionValidatorManager
After
AliasInterceptor
Allowed
AnnotationActionValidatorManager
AnnotationParameterFilterIntereptor
AnnotationUtils
AnnotationValidationConfigurationBuilder
AnnotationWorkflowInterceptor
AnnotationXWorkConverter
ArrayUtils
Before
BeforeResult
BlockByDefault
Blocked
ChainingInterceptor
ClassFinder
ClassFinder.Info
ClassLoaderInterface
ClassLoaderInterfaceDelegate
ClassLoaderUtil
ClassPathFinder
ClearableValueStack
CommonsLogger
CommonsLoggerFactory
CompositeTextProvider
CompoundRoot
CompoundRootAccessor
ConditionalVisitorFieldValidator
ConditionalVisitorFieldValidator
Configuration
ConfigurationException
ConfigurationManager
ConfigurationProvider
ConfigurationUtil
Container
ContainerBuilder
ContainerBuilder.Command
ContainerProvider
Context
Conversion
ConversionDescription
ConversionErrorFieldValidator
ConversionErrorFieldValidator
ConversionErrorFieldValidatorDescription
ConversionErrorInterceptor
ConversionRule
ConversionType
CreateIfNull
CustomValidator
DateRangeFieldValidator
DateRangeFieldValidator
DateRangeFieldValidatorDescription
DefaultActionInvocation
DefaultActionProxy
DefaultActionProxyFactory
DefaultActionValidatorManager
DefaultConfiguration
DefaultObjectTypeDeterminer
DefaultTextProvider
DefaultTypeConverter
DefaultUnknownHandlerManager
DefaultValidatorFactory
DefaultValidatorFileParser
DefaultWorkflowInterceptor
DelegatingValidatorContext
DependencyException
DomHelper
DomHelper.DOMBuilder
DomHelper.StartHandler
DoubleRangeFieldValidator
DoubleRangeFieldValidator
DoubleRangeFieldValidatorDescription
Element
EmailValidator
EmailValidator
EmailValidatorDescription
EnumTypeConverter
ExceptionHolder
ExceptionMappingConfig
ExceptionMappingConfig.Builder
ExceptionMappingInterceptor
ExpressionValidator
ExpressionValidator
ExpressionValidatorDescription
Factory
FieldExpressionValidator
FieldExpressionValidator
FieldExpressionValidatorDescription
FieldValidator
FieldValidatorSupport
FileManager
FileResourceStore
FinalizablePhantomReference
FinalizableSoftReference
FinalizableWeakReference
Function
GenericsObjectTypeDeterminer
I18nInterceptor
Inject
InputConfig
InstantiatingNullHandler
Interceptor
InterceptorBuilder
InterceptorConfig
InterceptorConfig.Builder
InterceptorListHolder
InterceptorLocator
InterceptorMapping
InterceptorStackConfig
InterceptorStackConfig.Builder
IntRangeFieldValidator
IntRangeFieldValidator
IntRangeFieldValidatorDescription
InvalidMetadataException
JarResourceStore
JdkLogger
JdkLoggerFactory
Key
KeyProperty
LocaleProvider
LocalizedTextUtil
Locatable
LocatableConstantFactory
LocatableFactory
LocatableProperties
Located
Location
LocationAttributes
LocationAttributes.Pipe
LocationImpl
LocationUtils
LocationUtils.LocationFinder
Logger
LoggerFactory
LoggerUtils
LoggingInterceptor
LongRangeFieldValidator
MemberAccessValueStack
MethodFilterInterceptor
MethodFilterInterceptorUtil
MockActionInvocation
MockActionInvocation
MockActionProxy
MockConfiguration
MockInterceptor
MockObjectTypeDeterminer
MockResult
ModelDriven
ModelDrivenInterceptor
ModelDrivenInterceptor.RefreshModelBeforeResult
NamedVariablePatternMatcher
NamedVariablePatternMatcher.CompiledPattern
NamespaceMatch
NamespaceMatcher
NoParameters
NullHandler
ObjectAccessor
ObjectFactory
ObjectProfiler
ObjectProxy
ObjectProxyPropertyAccessor
ObjectTypeDeterminer
OgnlNullHandlerWrapper
OgnlReflectionContextFactory
OgnlReflectionProvider
OgnlTypeConverterWrapper
OgnlUtil
OgnlValueStack
OgnlValueStackFactory
PackageConfig
PackageConfig.Builder
PackageProvider
ParameterFilterInterceptor
Parameterizable
ParameterNameAware
ParameterRemoverInterceptor
ParametersInterceptor
PatternMatcher
PrefixMethodInvocationUtil
Preparable
PrepareInterceptor
PreResultListener
ProfilingTimerBean
PropertiesReader
ReferenceCache
ReferenceMap
ReferenceMap.Strategy
ReferenceResolverException
ReferenceType
ReflectionContextFactory
ReflectionContextState
ReflectionException
ReflectionExceptionHandler
ReflectionProvider
ReflectionProviderFactory
RegexFieldValidator
RegexFieldValidator
ReloadingClassLoader
RepopulateConversionErrorFieldValidatorSupport
RequiredFieldValidator
RequiredFieldValidator
RequiredFieldValidatorDescription
RequiredStringValidator
RequiredStringValidator
RequiredStringValidatorDescription
ResolverUtil
ResolverUtil.AnnotatedWith
ResolverUtil.ClassTest
ResolverUtil.IsA
ResolverUtil.NameEndsWith
ResolverUtil.NameIs
ResolverUtil.ResourceTest
ResolverUtil.Test
ResourceBundleTextProvider
ResourceFinder
ResourceStore
ResourceStoreClassLoader
Result
ResultConfig
ResultConfig.Builder
ResultTypeConfig
ResultTypeConfig.Builder
RuntimeConfiguration
Scope
Scope.Strategy
Scoped
ScopedModelDriven
ScopedModelDrivenInterceptor
SecurityMemberAccess
ShortCircuitableValidator
ShortRangeFieldValidator
SpringObjectFactory
SpringProxyableObjectFactory
StaticParametersInterceptor
StringLengthFieldValidator
StringLengthFieldValidator
StringLengthFieldValidatorDescription
Strings
StubConfigurationProvider
Test
TestNGXWorkTestCase
TextParseUtil
TextParseUtil.ParsedValueEvaluator
TextProvider
TextProviderFactory
TextProviderSupport
TimerInterceptor
TypeConversion
TypeConversionException
TypeConverter
Unchainable
UnknownHandler
UnknownHandlerConfig
UnknownHandlerManager
UrlSet
URLUtil
UrlValidator
URLValidator
URLValidatorDescription
UtilTimerStack
UtilTimerStack.ProfilingBlock
Validateable
Validation
ValidationAware
ValidationAwareSupport
ValidationException
ValidationInterceptor
ValidationParameter
Validations
ValidationWorkflowAware
Validator
ValidatorConfig
ValidatorConfig.Builder
ValidatorContext
ValidatorDescription
ValidatorFactory
ValidatorFileParser
ValidatorSupport
ValidatorType
ValueStack
ValueStackFactory
VisitorFieldValidator
VisitorFieldValidator
VisitorFieldValidator.AppendingValidatorContext
VisitorFieldValidatorDescription
WildcardHelper
XmlConfigurationProvider
XmlHelper
XWork
XWorkBasicConverter
XWorkCollectionPropertyAccessor
XWorkConfigurationProvider
XWorkConverter
XWorkEnumerationAccessor
XWorkException
XWorkIteratorPropertyAccessor
XWorkList
XWorkListPropertyAccessor
XWorkMapPropertyAccessor
XWorkMessages
XWorkMethodAccessor
XWorkObjectPropertyAccessor
XWorkTestCase
XWorkTestCaseHelper
XWorkTypeConverterWrapper


Constant Field Values (XWork: Core 2.1.6 API)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES

Constant Field Values

Contents
  • com.opensymphony.*
com.opensymphony.*

com.opensymphony.xwork2.Action
public static final String | ERROR | "error"
public static final String | INPUT | "input"
public static final String | LOGIN | "login"
public static final String | NONE | "none"
public static final String | SUCCESS | "success"

com.opensymphony.xwork2.ActionChainResult
public static final String | DEFAULT_PARAM | "actionName"
public static final String | SKIP_ACTIONS_PARAM | "skipActions"

com.opensymphony.xwork2.ActionContext
public static final String | ACTION_INVOCATION | "com.opensymphony.xwork2.ActionContext.actionInvocation"
public static final String | ACTION_NAME | "com.opensymphony.xwork2.ActionContext.name"
public static final String | APPLICATION | "com.opensymphony.xwork2.ActionContext.application"
public static final String | CONTAINER | "com.opensymphony.xwork2.ActionContext.container"
public static final String | CONVERSION_ERRORS | "com.opensymphony.xwork2.ActionContext.conversionErrors"
public static final String | LOCALE | "com.opensymphony.xwork2.ActionContext.locale"
public static final String | PARAMETERS | "com.opensymphony.xwork2.ActionContext.parameters"
public static final String | SESSION | "com.opensymphony.xwork2.ActionContext.session"
public static final String | TYPE_CONVERTER | "com.opensymphony.xwork2.ActionContext.typeConverter"
public static final String | VALUE_STACK | "com.opensymphony.xwork2.util.ValueStack.ValueStack"

com.opensymphony.xwork2.XWorkMessages
public static final String | ACTION_EXECUTION_ERROR | "xwork.error.action.execution"
public static final String | DEFAULT_INVALID_FIELDVALUE | "xwork.default.invalid.fieldvalue"
public static final String | MISSING_ACTION_EXCEPTION | "xwork.exception.missing-action"
public static final String | MISSING_PACKAGE_ACTION_EXCEPTION | "xwork.exception.missing-package-action"

com.opensymphony.xwork2.config.entities.ActionConfig
public static final String WILDCARD "*"

com.opensymphony.xwork2.conversion.TypeConverter
public static final String TYPE_CONVERTER_CONTEXT_KEY "_typeConverter"

com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer
public static final String | CREATE_IF_NULL_PREFIX | "CreateIfNull_"
public static final String | DEPRECATED_ELEMENT_PREFIX | "Collection_"
public static final String | ELEMENT_PREFIX | "Element_"
public static final String | KEY_PREFIX | "Key_"
public static final String | KEY_PROPERTY_PREFIX | "KeyProperty_"

com.opensymphony.xwork2.conversion.impl.InstantiatingNullHandler
public static final String CREATE_NULL_OBJECTS "xwork.NullHandler.createNullObjects"

com.opensymphony.xwork2.conversion.impl.XWorkConverter
public static final String | CONVERSION_COLLECTION_PREFIX | "Collection_"
public static final String | CONVERSION_ERROR_PROPERTY_PREFIX | "invalid.fieldvalue."
public static final String | CONVERSION_PROPERTY_FULLNAME | "conversion.property.fullName"
public static final String | LAST_BEAN_CLASS_ACCESSED | "last.bean.accessed"
public static final String | LAST_BEAN_PROPERTY_ACCESSED | "last.property.accessed"
public static final String | MESSAGE_INDEX_BRACKET_PATTERN | "[\\[\\]\\.]"
public static final String | MESSAGE_INDEX_PATTERN | "\\[\\d+\\]\\."
public static final String | PERIOD | "."
public static final String | REPORT_CONVERSION_ERRORS | "report.conversion.errors"

com.opensymphony.xwork2.conversion.metadata.ConversionDescription
public static final String | DEPRECATED_ELEMENT_PREFIX | "Collection_"
public static final String | ELEMENT_PREFIX | "Element_"
public static final String | KEY_PREFIX | "Key_"
public static final String | KEY_PROPERTY_PREFIX | "KeyProperty_"

com.opensymphony.xwork2.inject.Container
public static final String DEFAULT_NAME "default"

com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor
public static final String ORIGINAL_PROPERTY_OVERRIDE "original.property.override"

com.opensymphony.xwork2.interceptor.I18nInterceptor
public static final String | DEFAULT_PARAMETER | "request_locale"
public static final String | DEFAULT_REQUESTONLY_PARAMETER | "request_only_locale"
public static final String | DEFAULT_SESSION_ATTRIBUTE | "WW_TRANS_I18N_LOCALE"

com.opensymphony.xwork2.mock.MockInterceptor
public static final String DEFAULT_FOO_VALUE "fooDefault"

com.opensymphony.xwork2.ognl.accessor.XWorkCollectionPropertyAccessor
public static final String KEY_PROPERTY_FOR_CREATION "makeNew"

com.opensymphony.xwork2.ognl.accessor.XWorkMethodAccessor
public static final String | DENY_INDEXED_ACCESS_EXECUTION | "xwork.IndexedPropertyAccessor.denyMethodExecution"
public static final String | DENY_METHOD_EXECUTION | "xwork.MethodAccessor.denyMethodExecution"

com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor
public static final String APPLICATION_CONTEXT "com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor.applicationContext"

com.opensymphony.xwork2.util.DomHelper
public static final String XMLNS_URI "http://www.w3.org/2000/xmlns/"

com.opensymphony.xwork2.util.URLUtil
public static final String | JBOSS5_VFSMEMORY | "vfsmemory"
public static final String | JBOSS5_VFSZIP | "vfszip"

com.opensymphony.xwork2.util.ValueStack
public static final String | REPORT_ERRORS_ON_NO_PROP | "com.opensymphony.xwork2.util.ValueStack.ReportErrorsOnNoProp"
public static final String | VALUE_STACK | "com.opensymphony.xwork2.util.ValueStack.ValueStack"

com.opensymphony.xwork2.util.WildcardHelper
protected static final int | MATCH_BEGIN | -4
protected static final int | MATCH_END | -3
protected static final int | MATCH_FILE | -1
protected static final int | MATCH_PATH | -2
protected static final int | MATCH_THEEND | -5

com.opensymphony.xwork2.util.finder.ClassLoaderInterface
public static final String CLASS_LOADER_INTERFACE "__current_class_loader_interface"

com.opensymphony.xwork2.util.location.LocationAttributes
public static final String | COL_ATTR | "column"
public static final String | LINE_ATTR | "line"
public static final String | PREFIX | "loc"
public static final String | Q_COL_ATTR | "loc:column"
public static final String | Q_LINE_ATTR | "loc:line"
public static final String | Q_SRC_ATTR | "loc:src"
public static final String | SRC_ATTR | "src"
public static final String | URI | "http://opensymphony.com/xwork/location"

com.opensymphony.xwork2.util.location.LocationUtils
public static final String UNKNOWN_STRING "[unknown location]"

com.opensymphony.xwork2.util.profiling.UtilTimerStack
public static final String | ACTIVATE_PROPERTY | "xwork.profile.activate"
public static final String | MIN_TIME | "xwork.profile.mintime"

com.opensymphony.xwork2.util.reflection.ReflectionContextState
public static final String | CREATE_NULL_OBJECTS | "xwork.NullHandler.createNullObjects"
public static final String | CURRENT_PROPERTY_PATH | "current.property.path"
public static final String | DENY_INDEXED_ACCESS_EXECUTION | "xwork.IndexedPropertyAccessor.denyMethodExecution"
public static final String | DENY_METHOD_EXECUTION | "xwork.MethodAccessor.denyMethodExecution"
public static final String | FULL_PROPERTY_PATH | "current.property.path"

com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
protected static final String VALIDATION_CONFIG_SUFFIX "-validation.xml"

com.opensymphony.xwork2.validator.DefaultActionValidatorManager
protected static final String VALIDATION_CONFIG_SUFFIX "-validation.xml"

com.opensymphony.xwork2.validator.validators.EmailValidator
public static final String emailAddressPattern "\\b(^[\'_A-Za-z0-9-]+(\\.[\'_A-Za-z0-9-]+)*@([A-Za-z0-9-])+(\\.[A-Za-z0-9-]+)*((\\.[A-Za-z0-9]{2,})|(\\.[A-Za-z0-9]{2,}\\.[A-Za-z0-9]{2,}))$)\\b"

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES
Copyright © 2009 OpenSymphony. All Rights Reserved.


Deprecated List (XWork: Core 2.1.6 API)

Deprecated API

Contents
  • Deprecated Classes
  • Deprecated Annotation Types
  • Deprecated Fields
  • Deprecated Methods
  • Deprecated Constructors
Deprecated Classes
com.opensymphony.xwork2.conversion.impl.AnnotationXWorkConverter
Since XWork 2.0.4, the implementation of XWorkConverter handles the processing of annotations.
com.opensymphony.xwork2.conversion.impl.EnumTypeConverter
Since Struts 2.1.0 as enum support is now built into XWork
com.opensymphony.xwork2.conversion.impl.GenericsObjectTypeDeterminer
Use DefaultObjectTypeDeterminer instead. Since XWork 2.0.4 the DefaultObjectTypeDeterminer handles the annotation processing.
com.opensymphony.xwork2.MockActionInvocation
Please use @see com.opensymphony.xwork2.mock.MockActionInvocation instead

Deprecated Annotation Types
com.opensymphony.xwork2.validator.annotations.Validation
Since Struts 2.1 because it isn't necessary anymore

Deprecated Fields
com.opensymphony.xwork2.conversion.impl.InstantiatingNullHandler.CREATE_NULL_OBJECTS
Use ReflectionContextState.CREATE_NULL_OBJECTS instead
com.opensymphony.xwork2.ognl.accessor.XWorkMethodAccessor.DENY_INDEXED_ACCESS_EXECUTION
Use ReflectionContextState.DENY_INDEXED_ACCESS_EXECUTION instead
com.opensymphony.xwork2.ognl.accessor.XWorkMethodAccessor.DENY_METHOD_EXECUTION
Use ReflectionContextState.DENY_METHOD_EXECUTION instead

Deprecated Methods
com.opensymphony.xwork2.config.ConfigurationManager.addConfigurationProvider(ConfigurationProvider)
Since 2.1, use #addContainerProvider()
com.opensymphony.xwork2.config.ConfigurationManager.clearConfigurationProviders()
Since 2.1, use ConfigurationManager.clearContainerProviders()
com.opensymphony.xwork2.ActionProxyFactory.createActionProxy(String, String, Map)
Since 2.1.1, use instead
com.opensymphony.xwork2.ActionProxyFactory.createActionProxy(String, String, Map, boolean, boolean)
Since 2.1.1, use ActionProxyFactory.createActionProxy(String,String,String,Map,boolean,boolean) instead
com.opensymphony.xwork2.util.AnnotationUtils.findAnnotatedMethods(Class, Class)
since 2.0.4 use getAnnotatedMethods
com.opensymphony.xwork2.util.AnnotationUtils.findRecursively(Class, Class, List)
since 2.0.4 use getAnnotatedMethods
com.opensymphony.xwork2.config.entities.ResultTypeConfig.getClazz()
Since 2.1, use ResultTypeConfig.getClassName() instead
com.opensymphony.xwork2.config.ConfigurationManager.getConfigurationProviders()
Since 2.1, use ConfigurationManager.getContainerProviders()
com.opensymphony.xwork2.ActionSupport.getErrorMessages()
Use ActionSupport.getActionErrors().
com.opensymphony.xwork2.ActionSupport.getErrors()
Use ActionSupport.getFieldErrors().
com.opensymphony.xwork2.ObjectFactory.getObjectFactory()
Since 2.1
com.opensymphony.xwork2.XWorkException.getThrowable()
Use Throwable.getCause()
com.opensymphony.xwork2.spring.SpringObjectFactory.initObjectFactory()
Since 2.1 as it isn't necessary
com.opensymphony.xwork2.config.Configuration.reload(List)
Since 2.1
com.opensymphony.xwork2.config.ConfigurationManager.setConfigurationProviders(List)
Since 2.1, use #setContainerProvider()

Deprecated Constructors
com.opensymphony.xwork2.config.impl.ActionConfigMatcher(Map)
Since 2.1, use ActionConfigMatcher.ActionConfigMatcher(PatternMatcher, Map, boolean) instead
com.opensymphony.xwork2.config.impl.ActionConfigMatcher(Map, boolean)
Since 2.1, use ActionConfigMatcher.ActionConfigMatcher(PatternMatcher, Map, boolean) instead

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


API Help (XWork: Core 2.1.6 API)

How This API Document Is Organized

This API (Application Programming Interface) document has pages corresponding to the items in the navigation bar, described as follows.

Overview

The Overview page is the front page of this API document and provides a list of all packages with a summary for each. This page can also contain an overall description of the set of packages.

Package

Each package has a page that contains a list of its classes and interfaces, with a summary for each. This page can contain four categories:

  • Interfaces (italic)
  • Classes
  • Enums
  • Exceptions
  • Errors
  • Annotation Types

Class/Interface

Each class, interface, nested class and nested interface has its own separate page. Each of these pages has three sections consisting of a class/interface description, summary tables, and detailed member descriptions:

  • Class inheritance diagram
  • Direct Subclasses
  • All Known Subinterfaces
  • All Known Implementing Classes
  • Class/interface declaration
  • Class/interface description

  • Nested Class Summary
  • Field Summary
  • Constructor Summary
  • Method Summary

  • Field Detail
  • Constructor Detail
  • Method Detail
Each summary entry contains the first sentence from the detailed description for that item. The summary entries are alphabetical, while the detailed descriptions are in the order they appear in the source code. This preserves the logical groupings established by the programmer.

Annotation Type

Each annotation type has its own separate page with the following sections:

  • Annotation Type declaration
  • Annotation Type description
  • Required Element Summary
  • Optional Element Summary
  • Element Detail

Enum

Each enum has its own separate page with the following sections:

  • Enum declaration
  • Enum description
  • Enum Constant Summary
  • Enum Constant Detail

Use

Each documented package, class and interface has its own Use page. This page describes what packages, classes, methods, constructors and fields use any part of the given class or package. Given a class or interface A, its Use page includes subclasses of A, fields declared as A, methods that return A, and methods and constructors with parameters of type A. You can access this page by first going to the package, class or interface, then clicking on the "Use" link in the navigation bar.

Tree (Class Hierarchy)

There is a Class Hierarchy page for all packages, plus a hierarchy for each package. Each hierarchy page contains a list of classes and a list of interfaces. The classes are organized by inheritance structure starting with java.lang.Object. The interfaces do not inherit from java.lang.Object.
  • When viewing the Overview page, clicking on "Tree" displays the hierarchy for all packages.
  • When viewing a particular package, class or interface page, clicking "Tree" displays the hierarchy for only that package.

Deprecated API

The Deprecated API page lists all of the API that have been deprecated. A deprecated API is not recommended for use, generally due to improvements, and a replacement API is usually given. Deprecated APIs may be removed in future implementations.

Index

The Index contains an alphabetic list of all classes, interfaces, constructors, methods, and fields.

Prev/Next

These links take you to the next or previous class, interface, package, or related page.

Frames/No Frames

These links show and hide the HTML frames. All pages are available with or without frames.

Serialized Form

Each serializable or externalizable class has a description of its serialization fields and methods. This information is of interest to re-implementors, not to developers using the API. While there is no link in the navigation bar, you can get to this information by going to any serialized class and clicking "Serialized Form" in the "See also" section of the class description.

Constant Field Values

The Constant Field Values page lists the static final fields and their values.

This help file applies to API documentation generated using the standard doclet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


XWork: Core 2.1.6 API

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link toNon-frame version.


Index (XWork: Core 2.1.6 API)

A B C D E F G H I J K L M N O P Q R S T U V W X

A

AbstractFieldValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
AbstractFieldValidatorDescription
AbstractFieldValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
AbstractFieldValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.
AbstractInterceptor - Class in com.opensymphony.xwork2.interceptor
Provides default implementations of optional lifecycle methods
AbstractInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.AbstractInterceptor
AbstractMatcher<E> - Class in com.opensymphony.xwork2.config.impl
Matches patterns against pre-compiled wildcard expressions pulled from target objects.
AbstractMatcher(PatternMatcher<?>) - Constructor for class com.opensymphony.xwork2.config.impl.AbstractMatcher
AbstractRangeValidator - Class in com.opensymphony.xwork2.validator.validators
Base class for range based validators.
AbstractRangeValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
acceptableName(String) - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
acceptableParameterName(String) - Method in interface com.opensymphony.xwork2.interceptor.ParameterNameAware
Tests if the the action will accept the parameter with the given name.
Action - Interface in com.opensymphony.xwork2
All actions may implement this interface, which exposes the execute() method.
action - Variable in class com.opensymphony.xwork2.DefaultActionInvocation
action - Variable in class com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor.RefreshModelBeforeResult
ACTION_EXECUTION_ERROR - Static variable in interface com.opensymphony.xwork2.XWorkMessages
ACTION_INVOCATION - Static variable in class com.opensymphony.xwork2.ActionContext
Constant for the action's invocation context.
ACTION_NAME - Static variable in class com.opensymphony.xwork2.ActionContext
Constant for the name of the action being executed.
ActionAutowiringInterceptor - Class in com.opensymphony.xwork2.spring.interceptor
TODO: Give a description of the Interceptor.
ActionAutowiringInterceptor() - Constructor for class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor
ActionChainResult - Class in com.opensymphony.xwork2
This result invokes an entire other action, complete with it's own interceptor stack and result.
ActionChainResult() - Constructor for class com.opensymphony.xwork2.ActionChainResult
ActionChainResult(String, String, String) - Constructor for class com.opensymphony.xwork2.ActionChainResult
ActionChainResult(String, String, String, String) - Constructor for class com.opensymphony.xwork2.ActionChainResult
ActionConfig - Class in com.opensymphony.xwork2.config.entities
Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.
ActionConfig(String, String, String) - Constructor for class com.opensymphony.xwork2.config.entities.ActionConfig
ActionConfig(ActionConfig) - Constructor for class com.opensymphony.xwork2.config.entities.ActionConfig
Clones an ActionConfig, copying data into new maps and lists
ActionConfig.Builder - Class in com.opensymphony.xwork2.config.entities
The builder for this object.
ActionConfig.Builder(ActionConfig) - Constructor for class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
ActionConfig.Builder(String, String, String) - Constructor for class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
ActionConfigMatcher - Class in com.opensymphony.xwork2.config.impl
Matches paths against pre-compiled wildcard expressions pulled from action configs.
ActionConfigMatcher(Map<String, ActionConfig>) - Constructor for class com.opensymphony.xwork2.config.impl.ActionConfigMatcher
Deprecated. Since 2.1, use ActionConfigMatcher.ActionConfigMatcher(PatternMatcher, Map, boolean) instead
ActionConfigMatcher(Map<String, ActionConfig>, boolean) - Constructor for class com.opensymphony.xwork2.config.impl.ActionConfigMatcher
Deprecated. Since 2.1, use ActionConfigMatcher.ActionConfigMatcher(PatternMatcher, Map, boolean) instead
ActionConfigMatcher(PatternMatcher<?>, Map<String, ActionConfig>, boolean) - Constructor for class com.opensymphony.xwork2.config.impl.ActionConfigMatcher
Finds and precompiles the wildcard patterns from the ActionConfig "path" attributes.
ActionContext - Class in com.opensymphony.xwork2
The ActionContext is the context in which an Action is executed.
ActionContext(Map<String, Object>) - Constructor for class com.opensymphony.xwork2.ActionContext
Creates a new ActionContext initialized with another context.
ActionEventListener - Interface in com.opensymphony.xwork2
Provides hooks for handling key action events
actionEventListener - Variable in class com.opensymphony.xwork2.DefaultActionInvocation
actionEventListener - Variable in class com.opensymphony.xwork2.DefaultActionProxy
ActionInvocation - Interface in com.opensymphony.xwork2
An ActionInvocation represents the execution state of an Action.
actionName - Variable in class com.opensymphony.xwork2.DefaultActionProxy
ActionProxy - Interface in com.opensymphony.xwork2
ActionProxy is an extra layer between XWork and the action so that different proxies are possible.
ActionProxyFactory - Interface in com.opensymphony.xwork2
The ActionProxyFactory is used to create ActionProxys to be executed.
actionProxyFactory - Variable in class com.opensymphony.xwork2.TestNGXWorkTestCase
actionProxyFactory - Variable in class com.opensymphony.xwork2.XWorkTestCase
ActionSupport - Class in com.opensymphony.xwork2
Provides a default implementation for the most common actions.
ActionSupport() - Constructor for class com.opensymphony.xwork2.ActionSupport
ActionValidatorManager - Interface in com.opensymphony.xwork2.validator
ActionValidatorManager is the main interface for validation managers (regular and annotation based).
ACTIVATE_PROPERTY - Static variable in class com.opensymphony.xwork2.util.profiling.UtilTimerStack
System property that controls whether this timer should be used or not.
add(int, Object) - Method in class com.opensymphony.xwork2.util.XWorkList
Inserts the specified element at the specified position in this list.
add(Object) - Method in class com.opensymphony.xwork2.util.XWorkList
Appends the specified element to the end of this list.
addAction(Element, PackageConfig.Builder) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
addActionConfig(String, ActionConfig) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
addActionError(String) - Method in class com.opensymphony.xwork2.ActionSupport
addActionError(String) - Method in interface com.opensymphony.xwork2.ValidationAware
Add an Action-level error message to this Action.
addActionError(String) - Method in class com.opensymphony.xwork2.ValidationAwareSupport
addActionError(String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
addActionError(Object) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError(String) - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext
addActionMessage(String) - Method in class com.opensymphony.xwork2.ActionSupport
addActionMessage(String) - Method in interface com.opensymphony.xwork2.ValidationAware
Add an Action-level message to this Action.
addActionMessage(String) - Method in class com.opensymphony.xwork2.ValidationAwareSupport
addActionMessage(String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
addAll(Collection) - Method in class com.opensymphony.xwork2.util.XWorkList
Appends all of the elements in the specified Collection to the end of this list, in the order that they are returned by the specified Collection's Iterator.
addAll(int, Collection) - Method in class com.opensymphony.xwork2.util.XWorkList
Inserts all of the elements in the specified Collection into this list, starting at the specified position.
addAllFields(Class, Class, List<Field>) - Static method in class com.opensymphony.xwork2.util.AnnotationUtils
Adds all fields with the specified Annotation of class clazz and its superclasses to allFields
addAllInterfaces(Class, List<Class>) - Static method in class com.opensymphony.xwork2.util.AnnotationUtils
addAllMethods(Class, Class, List<Method>) - Static method in class com.opensymphony.xwork2.util.AnnotationUtils
Adds all methods with the specified Annotation of class clazz and its superclasses to allFields
addAllowedMethod(String) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
addAllowedMethod(Collection<String>) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
addChild(ProfilingTimerBean) - Method in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean
addConfigurationProvider(ConfigurationProvider) - Method in class com.opensymphony.xwork2.config.ConfigurationManager
Deprecated. Since 2.1, use #addContainerProvider()
addContainerProvider(ContainerProvider) - Method in class com.opensymphony.xwork2.config.ConfigurationManager
adds a configuration provider to the List of ConfigurationProviders.
addConverterMapping(Map<String, Object>, Class) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
Looks for converter mappings for the specified class and adds it to an existing map.
addDefaultResourceBundle(String) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Add's the bundle to the internal list of default bundles.
addExceptionMapping(ExceptionMappingConfig) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
addExceptionMappingConfig(ExceptionMappingConfig) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
addExceptionMappings(Collection<? extends ExceptionMappingConfig>) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
addFieldError(String, String) - Method in class com.opensymphony.xwork2.ActionSupport
addFieldError(String, String) - Method in interface com.opensymphony.xwork2.ValidationAware
Add an error message for a given field.
addFieldError(String, String) - Method in class com.opensymphony.xwork2.ValidationAwareSupport
addFieldError(String, String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
addFieldError(String, Object) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addFieldError(String, String) - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext
addFinder(LocationUtils.LocationFinder) - Static method in class com.opensymphony.xwork2.util.location.LocationUtils
Add a LocationUtils.LocationFinder to the list of finders that will be queried for an object's location by LocationUtils.getLocation(Object, String).
addGlobalExceptionMappingConfigs(List<ExceptionMappingConfig>) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
addGlobalResultConfig(ResultConfig) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
addGlobalResultConfigs(Map<String, ResultConfig>) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
addIfMatching(ResolverUtil.Test, String) - Method in class com.opensymphony.xwork2.util.ResolverUtil
Add the class designated by the fully qualified class name provided to the set of resolved classes if and only if it is approved by the Test supplied.
addInterceptor(InterceptorMapping) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
addInterceptor(InterceptorMapping) - Method in interface com.opensymphony.xwork2.config.entities.InterceptorListHolder
addInterceptor(InterceptorMapping) - Method in class com.opensymphony.xwork2.config.entities.InterceptorStackConfig.Builder
Add an InterceptorMapping object.
addInterceptorConfig(InterceptorConfig) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
addInterceptors(List<InterceptorMapping>) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
addInterceptors(List<InterceptorMapping>) - Method in interface com.opensymphony.xwork2.config.entities.InterceptorListHolder
addInterceptors(List<InterceptorMapping>) - Method in class com.opensymphony.xwork2.config.entities.InterceptorStackConfig.Builder
Add a List of InterceptorMapping objects.
addInterceptorStackConfig(InterceptorStackConfig) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
addLocationAttributes(Locator, Attributes) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Add location attributes to a set of SAX attributes.
addPackage(Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
Create a PackageConfig from an XML element representing it.
addPackageConfig(String, PackageConfig) - Method in interface com.opensymphony.xwork2.config.Configuration
addPackageConfig(String, PackageConfig) - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
addPackageConfig(String, PackageConfig) - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration
addParam(String, String) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
addParam(String, String) - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig.Builder
addParam(String, String) - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig.Builder
addParam(String, String) - Method in interface com.opensymphony.xwork2.config.entities.Parameterizable
addParam(String, String) - Method in class com.opensymphony.xwork2.config.entities.ResultConfig.Builder
addParam(String, String) - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig.Builder
addParam(String, String) - Method in class com.opensymphony.xwork2.validator.ValidatorConfig.Builder
addParametersToContext(ActionContext, Map<String, Object>) - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
Adds the parameters into context's ParameterMap
addParametersToContext(ActionContext, Map<String, ?>) - Method in class com.opensymphony.xwork2.interceptor.StaticParametersInterceptor
Adds the parameters into context's ParameterMap.
addParams(Map<String, String>) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
addParams(Map<String, String>) - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig.Builder
addParams(Map<String, String>) - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig.Builder
addParams(Map<String, String>) - Method in class com.opensymphony.xwork2.config.entities.ResultConfig.Builder
addParams(Map<String, String>) - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig.Builder
addParams(Map<String, String>) - Method in class com.opensymphony.xwork2.validator.ValidatorConfig.Builder
addParent(PackageConfig) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
addParent(ProfilingTimerBean) - Method in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean
addParents(List<PackageConfig>) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
addPattern(String, E, boolean) - Method in class com.opensymphony.xwork2.config.impl.AbstractMatcher
Finds and precompiles the wildcard patterns.
addPreResultListener(PreResultListener) - Method in interface com.opensymphony.xwork2.ActionInvocation
Register a PreResultListener to be notified after the Action is executed and before the Result is executed.
addPreResultListener(PreResultListener) - Method in class com.opensymphony.xwork2.DefaultActionInvocation
Register a com.opensymphony.xwork2.interceptor.PreResultListener to be notified after the Action is executed and before the Result is executed.
addPreResultListener(PreResultListener) - Method in class com.opensymphony.xwork2.mock.MockActionInvocation
addResourceStore(ResourceStore) - Method in class com.opensymphony.xwork2.util.classloader.ReloadingClassLoader
addResultConfig(ResultConfig) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
addResultConfigs(Collection<ResultConfig>) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
addResultConfigs(Map<String, ResultConfig>) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
addResultTypeConfig(ResultTypeConfig) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
addResultTypes(PackageConfig.Builder, Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
After - Annotation Type in com.opensymphony.xwork2.interceptor.annotations
Marks a action method that needs to be called after the main action method and the result was executed.
alias(Class<T>, String) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to alias(type, Container.DEFAULT_NAME, type).
alias(Class<T>, String, String) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps an existing factory to a new name.
aliasesKey - Variable in class com.opensymphony.xwork2.interceptor.AliasInterceptor
AliasInterceptor - Class in com.opensymphony.xwork2.interceptor
The aim of this Interceptor is to alias a named parameter to a different named parameter.
AliasInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.AliasInterceptor
Allowed - Annotation Type in com.opensymphony.xwork2.interceptor.annotations
Declares that it is permitted for the field be mutated through a HttpRequest parameter.
allowedMethods - Variable in class com.opensymphony.xwork2.config.entities.ActionConfig
AnnotationActionValidatorManager - Class in com.opensymphony.xwork2.validator
AnnotationActionValidatorManager is the entry point into XWork's annotations-based validator framework.
AnnotationActionValidatorManager() - Constructor for class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
AnnotationActionValidatorManager.InternalValidatorContextWrapper - Class in com.opensymphony.xwork2.validator
An ValidatorContext wrapper that returns the full field name AbstractActionValidatorManager.InternalValidatorContextWrapper by consulting it's parent if its an VisitorFieldValidator.AppendingValidatorContext.
AnnotationParameterFilterIntereptor - Class in com.opensymphony.xwork2.interceptor.annotations
Annotation based version of ParameterFilterInterceptor.
AnnotationParameterFilterIntereptor() - Constructor for class com.opensymphony.xwork2.interceptor.annotations.AnnotationParameterFilterIntereptor
AnnotationUtils - Class in com.opensymphony.xwork2.util
AnnotationUtils Various utility methods dealing with annotations
AnnotationUtils() - Constructor for class com.opensymphony.xwork2.util.AnnotationUtils
AnnotationValidationConfigurationBuilder - Class in com.opensymphony.xwork2.validator
AnnotationValidationConfigurationBuilder
AnnotationValidationConfigurationBuilder(ValidatorFactory) - Constructor for class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder
AnnotationWorkflowInterceptor - Class in com.opensymphony.xwork2.interceptor.annotations
AnnotationWorkflowInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor
AnnotationXWorkConverter - Class in com.opensymphony.xwork2.conversion.impl
Deprecated. Since XWork 2.0.4, the implementation of XWorkConverter handles the processing of annotations.
AnnotationXWorkConverter() - Constructor for class com.opensymphony.xwork2.conversion.impl.AnnotationXWorkConverter
Deprecated.
appContext - Variable in class com.opensymphony.xwork2.spring.SpringObjectFactory
appendPrefix - Variable in class com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription
APPLICATION - Static variable in class com.opensymphony.xwork2.ActionContext
Constant for the action's application context.
APPLICATION_CONTEXT - Static variable in class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor
apply(F) - Method in interface com.opensymphony.xwork2.inject.util.Function
Applies the function to an object of type F, resulting in an object of type T.
applyInterceptor(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
applyMethod(Set<String>, Set<String>, String) - Static method in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptorUtil
Static method to decide if the specified method should be apply (not filtered) depending on the set of excludeMethods and includeMethods.
applyMethod(String, String, String) - Static method in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptorUtil
Same as MethodFilterInterceptorUtil.applyMethod(Set, Set, String), except that excludeMethods and includeMethods are supplied as comma separated string.
ArrayUtils - Class in com.opensymphony.xwork2.util
ArrayUtils() - Constructor for class com.opensymphony.xwork2.util.ArrayUtils
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
Returns the validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.URLValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription
Returns the validator XML definition.
asProperty() - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
Returns the conversion description as property entry.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.URLValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription
Returns the validator XML definition.
asXml() - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Returns the validator XML definition.
asXml() - Method in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription
asXml() - Method in interface com.opensymphony.xwork2.validator.metadata.ValidatorDescription
Returns the validator XML definition.
attributeName - Variable in class com.opensymphony.xwork2.interceptor.I18nInterceptor
autoWireBean(Object) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
autoWireBean(Object, AutowireCapableBeanFactory) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
autowireStrategy - Variable in class com.opensymphony.xwork2.spring.SpringObjectFactory
autoWiringFactory - Variable in class com.opensymphony.xwork2.spring.SpringObjectFactory

B

Before - Annotation Type in com.opensymphony.xwork2.interceptor.annotations
Marks a action method that needs to be executed before the main action method.
beforeResult(ActionInvocation, String) - Method in class com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor
Invokes any @BeforeResult annotated methods
BeforeResult - Annotation Type in com.opensymphony.xwork2.interceptor.annotations
Marks a action method that needs to be executed before the result.
beforeResult(ActionInvocation, String) - Method in class com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor.RefreshModelBeforeResult
beforeResult(ActionInvocation, String) - Method in interface com.opensymphony.xwork2.interceptor.PreResultListener
This callback method will be called after the Action execution and before the Result execution.
bigDecValue(Object) - Static method in class com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
Evaluates the given object as a BigDecimal.
bigIntValue(Object) - Static method in class com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
Evaluates the given object as a BigInteger.
BlockByDefault - Annotation Type in com.opensymphony.xwork2.interceptor.annotations
Declares that by default fields on the Action class are NOT permitted to be set from HttpRequest parameters.
Blocked - Annotation Type in com.opensymphony.xwork2.interceptor.annotations
Declares that the given field should NOT be able to be mutated through a HttpRequest parameter.
booleanValue(Object) - Static method in class com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
Evaluates the given object as a boolean: if it is a Boolean object, it's easy; if it's a Number or a Character, returns true for non-zero objects; and otherwise returns true for non-null objects.
build() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
build() - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig.Builder
build() - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig.Builder
build() - Method in class com.opensymphony.xwork2.config.entities.InterceptorStackConfig.Builder
build() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
build() - Method in class com.opensymphony.xwork2.config.entities.ResultConfig.Builder
build() - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig.Builder
build() - Method in class com.opensymphony.xwork2.DefaultUnknownHandlerManager
Builds a list of UnknowHandlers in the order specified by the configured "unknown-handler-stack".
build(ContainerBuilder) - Method in interface com.opensymphony.xwork2.inject.ContainerBuilder.Command
Contributes factories to the given builder.
build() - Method in class com.opensymphony.xwork2.validator.ValidatorConfig.Builder
buildAction(String, String, ActionConfig, Map<String, Object>) - Method in class com.opensymphony.xwork2.ObjectFactory
Build an instance of the action class to handle a particular request (eg.
buildAnnotationClassValidatorConfigs(Class) - Method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder
buildBean(Class, Map<String, Object>) - Method in class com.opensymphony.xwork2.ObjectFactory
Build a generic Java object of the given type.
buildBean(String, Map<String, Object>) - Method in class com.opensymphony.xwork2.ObjectFactory
Build a generic Java object of the given type.
buildBean(String, Map<String, Object>, boolean) - Method in class com.opensymphony.xwork2.ObjectFactory
Build a generic Java object of the given type.
buildBean(String, Map<String, Object>, boolean) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
Looks up beans using Spring's application context before falling back to the method defined in the ObjectFactory.
buildBean(Class, Map<String, Object>) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
buildBean(String, Map<String, Object>) - Method in class com.opensymphony.xwork2.spring.SpringProxyableObjectFactory
buildClassValidatorConfigs(Class, boolean) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
buildConverterFilename(Class) - Static method in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
buildConverterMapping(Class) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
Looks for converter mappings for the specified class, traversing up its class hierarchy and interfaces and adding any additional mappings it may find.
buildExceptionMappings(Element, PackageConfig.Builder) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
Build a map of ResultConfig objects from below a given XML element.
buildInterceptor(InterceptorConfig, Map<String, String>) - Method in class com.opensymphony.xwork2.ObjectFactory
Builds an Interceptor from the InterceptorConfig and the Map of parameters from the interceptor reference.
buildInterceptorList(Element, PackageConfig.Builder) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
buildPackageContext(Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
This method builds a package context by looking for the parents of this new package.
buildParentsFromString(Configuration, String) - Static method in class com.opensymphony.xwork2.config.ConfigurationUtil
buildResult(ResultConfig, Map<String, Object>) - Method in class com.opensymphony.xwork2.ObjectFactory
Build a Result using the type in the ResultConfig and set the parameters in the ResultConfig.
buildResults(Element, PackageConfig.Builder) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
Build a map of ResultConfig objects from below a given XML element.
buildRuntimeConfiguration() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
This builds the internal runtime configuration used by Xwork for finding and configuring Actions from the programmatic configuration data structures.
buildRuntimeConfiguration() - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration
buildValidator(String, Map<String, String>, Map<String, Object>) - Method in class com.opensymphony.xwork2.ObjectFactory
Build a Validator of the given type and set the parameters on it
buildValidatorKey(Class) - Static method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
Builds a key for validators - used when caching validators.
buildValidatorKey(Class, String) - Static method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
Builds a key for validators - used when caching validators.

C

callMethod(Map, Object, String, Object[]) - Method in class com.opensymphony.xwork2.ognl.accessor.CompoundRootAccessor
callMethod(Map, Object, String, Object[]) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkMethodAccessor
callStaticMethod(Map, Class, String, Object[]) - Method in class com.opensymphony.xwork2.ognl.accessor.CompoundRootAccessor
callStaticMethod(Map, Class, String, Object[]) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkMethodAccessor
cancel() - Method in class com.opensymphony.xwork2.inject.util.ReferenceCache
Cancels the current ReferenceCache.create(Object).
capitalize(String) - Static method in class com.opensymphony.xwork2.inject.util.Strings
Returns a string that is equivalent to the specified string with its first character converted to uppercase as by String.toUpperCase(java.util.Locale).
capitalizeMethodName(String) - Static method in class com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil
This method capitalized the first character of methodName.
categoryLogger - Variable in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
categoryLogger - Variable in class com.opensymphony.xwork2.interceptor.TimerInterceptor
ChainingInterceptor - Class in com.opensymphony.xwork2.interceptor
An interceptor that copies all the properties of every object in the value stack to the currently executing object, except for any object that implements Unchainable.
ChainingInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.ChainingInterceptor
characters(char[], int, int) - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
characters(char[], int, int) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler
characters(char[], int, int) - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe
CLASS_LOADER_INTERFACE - Static variable in interface com.opensymphony.xwork2.util.finder.ClassLoaderInterface
ClassFinder - Class in com.opensymphony.xwork2.util.finder
ClassFinder searches the classpath of the specified ClassLoaderInterface for packages, classes, constructors, methods, or fields with specific annotations.
ClassFinder(ClassLoaderInterface) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder
Creates a ClassFinder that will search the urls in the specified ClassLoaderInterface excluding the urls in the ClassLoaderInterface's parent.
ClassFinder(ClassLoaderInterface, boolean) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder
Creates a ClassFinder that will search the urls in the specified ClassLoaderInterface.
ClassFinder(ClassLoaderInterface, ClassLoaderInterface) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder
Creates a ClassFinder that will search the urls in the specified classloader excluding the urls in the 'exclude' ClassLoaderInterface.
ClassFinder(ClassLoaderInterface, URL) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder
ClassFinder(ClassLoaderInterface, String...) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder
ClassFinder(ClassLoaderInterface, Collection<URL>) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder
ClassFinder(ClassLoaderInterface, Collection<URL>, boolean) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder
ClassFinder(ClassLoaderInterface, Collection<URL>, boolean, Set<String>) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder
ClassFinder(Class...) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder
ClassFinder(List<Class>) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder
ClassFinder.Annotatable - Class in com.opensymphony.xwork2.util.finder
ClassFinder.Annotatable(AnnotatedElement) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder.Annotatable
ClassFinder.Annotatable() - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder.Annotatable
ClassFinder.AnnotationInfo - Class in com.opensymphony.xwork2.util.finder
ClassFinder.AnnotationInfo(Annotation) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder.AnnotationInfo
ClassFinder.AnnotationInfo(Class<? extends Annotation>) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder.AnnotationInfo
ClassFinder.AnnotationInfo(String) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder.AnnotationInfo
ClassFinder.ClassInfo - Class in com.opensymphony.xwork2.util.finder
ClassFinder.ClassInfo(Class) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder.ClassInfo
ClassFinder.ClassInfo(String, String) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder.ClassInfo
ClassFinder.FieldInfo - Class in com.opensymphony.xwork2.util.finder
ClassFinder.FieldInfo(ClassFinder.ClassInfo, Field) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder.FieldInfo
ClassFinder.FieldInfo(ClassFinder.ClassInfo, String, String) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder.FieldInfo
ClassFinder.Info - Interface in com.opensymphony.xwork2.util.finder
ClassFinder.InfoBuildingVisitor - Class in com.opensymphony.xwork2.util.finder
ClassFinder.InfoBuildingVisitor() - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder.InfoBuildingVisitor
ClassFinder.InfoBuildingVisitor(ClassFinder.Info) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder.InfoBuildingVisitor
ClassFinder.MethodInfo - Class in com.opensymphony.xwork2.util.finder
ClassFinder.MethodInfo(ClassFinder.ClassInfo, Constructor) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder.MethodInfo
ClassFinder.MethodInfo(ClassFinder.ClassInfo, Method) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder.MethodInfo
ClassFinder.MethodInfo(ClassFinder.ClassInfo, String, String) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder.MethodInfo
ClassFinder.PackageInfo - Class in com.opensymphony.xwork2.util.finder
ClassFinder.PackageInfo(Package) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder.PackageInfo
ClassFinder.PackageInfo(String) - Constructor for class com.opensymphony.xwork2.util.finder.ClassFinder.PackageInfo
classForName(String, Map) - Method in class com.opensymphony.xwork2.ognl.accessor.CompoundRootAccessor
ClassLoaderInterface - Interface in com.opensymphony.xwork2.util.finder
Classes implementing this interface can find resources and load classes, usually delegating to a class loader
ClassLoaderInterfaceDelegate - Class in com.opensymphony.xwork2.util.finder
Default implementation of ClassLoaderInterface, which delegates to an actual ClassLoader
ClassLoaderInterfaceDelegate(ClassLoader) - Constructor for class com.opensymphony.xwork2.util.finder.ClassLoaderInterfaceDelegate
ClassLoaderUtil - Class in com.opensymphony.xwork2.util
This class is extremely useful for loading resources and classes in a fault tolerant manner that works across different applications servers.
ClassLoaderUtil() - Constructor for class com.opensymphony.xwork2.util.ClassLoaderUtil
className(String) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
className - Variable in class com.opensymphony.xwork2.config.entities.ActionConfig
className(String) - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig.Builder
className(String) - Method in class com.opensymphony.xwork2.config.entities.ResultConfig.Builder
className(String) - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig.Builder
ClassPathFinder - Class in com.opensymphony.xwork2.util
This class is an utility class that will search through the classpath for files whose names match the given pattern.
ClassPathFinder() - Constructor for class com.opensymphony.xwork2.util.ClassPathFinder
cleanupContext - Variable in class com.opensymphony.xwork2.DefaultActionProxy
clear() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
clear(Map<String, Object>) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
ClearableValueStack - Interface in com.opensymphony.xwork2.util
ValueStacks implementing this interface provide a way to remove values from their contexts.
clearActionErrors() - Method in class com.opensymphony.xwork2.ActionSupport
Clears action errors.
clearActionErrors() - Method in class com.opensymphony.xwork2.ValidationAwareSupport
Clears action errors list.
clearAssertionStatus() - Method in class com.opensymphony.xwork2.util.classloader.ReloadingClassLoader
clearBundle(String) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Removes the bundle from any cached "misses"
clearConfigurationProviders() - Method in class com.opensymphony.xwork2.config.ConfigurationManager
Deprecated. Since 2.1, use ConfigurationManager.clearContainerProviders()
clearContainerProviders() - Method in class com.opensymphony.xwork2.config.ConfigurationManager
clearContextValues() - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
clearContextValues() - Method in interface com.opensymphony.xwork2.util.ClearableValueStack
Remove all values from the context
clearCurrentPropertyPath(Map<String, Object>) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
clearDefaultResourceBundles() - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Clears the internal list of resource bundles.
clearErrors() - Method in class com.opensymphony.xwork2.ActionSupport
Clears all errors.
clearErrors() - Method in class com.opensymphony.xwork2.ValidationAwareSupport
Clears all error list/maps.
clearErrorsAndMessages() - Method in class com.opensymphony.xwork2.ActionSupport
Clears all errors and messages.
clearErrorsAndMessages() - Method in class com.opensymphony.xwork2.ValidationAwareSupport
Clears all error and messages list/maps.
clearFieldErrors() - Method in class com.opensymphony.xwork2.ActionSupport
Clears field errors.
clearFieldErrors() - Method in class com.opensymphony.xwork2.ValidationAwareSupport
Clears field errors map.
clearMessages() - Method in class com.opensymphony.xwork2.ActionSupport
Clears messages.
clearMessages() - Method in class com.opensymphony.xwork2.ValidationAwareSupport
Clears messages list.
clone() - Method in class com.opensymphony.xwork2.ActionSupport
COL_ATTR - Static variable in class com.opensymphony.xwork2.util.location.LocationAttributes
Attribute name for the column number
com.opensymphony.xwork2 - package com.opensymphony.xwork2
Main XWork interfaces and classes.
com.opensymphony.xwork2.config - package com.opensymphony.xwork2.config
Configuration core classes.
com.opensymphony.xwork2.config.entities - package com.opensymphony.xwork2.config.entities
Configuration entity classes.
com.opensymphony.xwork2.config.impl - package com.opensymphony.xwork2.config.impl
Configuration implementation classes.
com.opensymphony.xwork2.config.providers - package com.opensymphony.xwork2.config.providers
Configuration provider classes.
com.opensymphony.xwork2.conversion - package com.opensymphony.xwork2.conversion
com.opensymphony.xwork2.conversion.annotations - package com.opensymphony.xwork2.conversion.annotations
Type conversion annotations.
com.opensymphony.xwork2.conversion.impl - package com.opensymphony.xwork2.conversion.impl
com.opensymphony.xwork2.conversion.metadata - package com.opensymphony.xwork2.conversion.metadata
Type conversion meta data classes.
com.opensymphony.xwork2.inject - package com.opensymphony.xwork2.inject
Guice (pronounced "juice").
com.opensymphony.xwork2.inject.util - package com.opensymphony.xwork2.inject.util
Guice util classes.
com.opensymphony.xwork2.interceptor - package com.opensymphony.xwork2.interceptor
Interceptor classes.
com.opensymphony.xwork2.interceptor.annotations - package com.opensymphony.xwork2.interceptor.annotations
Interceptor annotations.
com.opensymphony.xwork2.mock - package com.opensymphony.xwork2.mock
XWork specific mock classes.
com.opensymphony.xwork2.ognl - package com.opensymphony.xwork2.ognl
com.opensymphony.xwork2.ognl.accessor - package com.opensymphony.xwork2.ognl.accessor
com.opensymphony.xwork2.spring - package com.opensymphony.xwork2.spring
Spring ObjectFactory classes.
com.opensymphony.xwork2.spring.interceptor - package com.opensymphony.xwork2.spring.interceptor
Spring specific interceptor classes.
com.opensymphony.xwork2.test - package com.opensymphony.xwork2.test
com.opensymphony.xwork2.util - package com.opensymphony.xwork2.util
XWork util classes.
com.opensymphony.xwork2.util.classloader - package com.opensymphony.xwork2.util.classloader
com.opensymphony.xwork2.util.finder - package com.opensymphony.xwork2.util.finder
com.opensymphony.xwork2.util.location - package com.opensymphony.xwork2.util.location
Classes and utilities used to track location information.
com.opensymphony.xwork2.util.logging - package com.opensymphony.xwork2.util.logging
com.opensymphony.xwork2.util.logging.commons - package com.opensymphony.xwork2.util.logging.commons
com.opensymphony.xwork2.util.logging.jdk - package com.opensymphony.xwork2.util.logging.jdk
com.opensymphony.xwork2.util.profiling - package com.opensymphony.xwork2.util.profiling
Classes to enable profiling of action execution.
com.opensymphony.xwork2.util.reflection - package com.opensymphony.xwork2.util.reflection
com.opensymphony.xwork2.validator - package com.opensymphony.xwork2.validator
XWork validation subsystem.
com.opensymphony.xwork2.validator.annotations - package com.opensymphony.xwork2.validator.annotations
Validator annotations.
com.opensymphony.xwork2.validator.metadata - package com.opensymphony.xwork2.validator.metadata
Validator meta data classes.
com.opensymphony.xwork2.validator.validators - package com.opensymphony.xwork2.validator.validators
XWork default validator classes.
commaDelimitedStringToSet(String) - Static method in class com.opensymphony.xwork2.util.TextParseUtil
Returns a set from comma delimted Strings.
CommonsLogger - Class in com.opensymphony.xwork2.util.logging.commons
Simple logger that delegates to commons logging
CommonsLogger(Log) - Constructor for class com.opensymphony.xwork2.util.logging.commons.CommonsLogger
CommonsLoggerFactory - Class in com.opensymphony.xwork2.util.logging.commons
Creates commons-logging-backed loggers
CommonsLoggerFactory() - Constructor for class com.opensymphony.xwork2.util.logging.commons.CommonsLoggerFactory
comparePriorities(int, int) - Static method in class com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor
compareTo(Object) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
compile(String) - Method in class com.opensymphony.xwork2.ognl.OgnlUtil
compilePattern(String) - Method in class com.opensymphony.xwork2.util.NamedVariablePatternMatcher
Compiles the pattern.
compilePattern(String) - Method in interface com.opensymphony.xwork2.util.PatternMatcher
Translate the given String into an object representing the pattern matchable by this class.
compilePattern(String) - Method in class com.opensymphony.xwork2.util.WildcardHelper
Translate the given String into a int [] representing the pattern matchable by this class.
CompositeTextProvider - Class in com.opensymphony.xwork2
This is a composite TextProvider that takes in an array or List of TextProviders, it will consult each of them in order to get a composite result.
CompositeTextProvider(List<TextProvider>) - Constructor for class com.opensymphony.xwork2.CompositeTextProvider
Instantiates a CompositeTextProvider with some predefined textProviders.
CompositeTextProvider(TextProvider[]) - Constructor for class com.opensymphony.xwork2.CompositeTextProvider
Instantiates a CompositeTextProvider with some predefined textProviders.
CompoundRoot - Class in com.opensymphony.xwork2.util
A Stack that is implemented using a List.
CompoundRoot() - Constructor for class com.opensymphony.xwork2.util.CompoundRoot
CompoundRoot(List) - Constructor for class com.opensymphony.xwork2.util.CompoundRoot
CompoundRootAccessor - Class in com.opensymphony.xwork2.ognl.accessor
A stack that is able to call methods on objects in the stack.
CompoundRootAccessor() - Constructor for class com.opensymphony.xwork2.ognl.accessor.CompoundRootAccessor
conditionalParse(String) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
Parse expression passed in against value stack.
conditionalReload() - Method in class com.opensymphony.xwork2.config.ConfigurationManager
Reloads the Configuration files if the configuration files indicate that they need to be reloaded.
ConditionalVisitorFieldValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
The validator allows you to forward validator to object properties of your action using the objects own validator files.
ConditionalVisitorFieldValidator - Class in com.opensymphony.xwork2.validator.validators
ConditionalVisitorFieldValidator <field name="colleaguePosition"> <field-validator type="fieldexpression" short-circuit="true"> reason == 'colleague' and colleaguePositionID == '_CHOOSE_' <message>You must choose a position where you worked with this person, or choose "Other..."</message> </field-validator> <field-validator type="conditionalvisitor"> reason == 'colleague' and colleaguePositionID == 'OTHER' <message/> </field-validator> </field>
ConditionalVisitorFieldValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.ConditionalVisitorFieldValidator
config - Variable in class com.opensymphony.xwork2.DefaultActionProxy
Configuration - Interface in com.opensymphony.xwork2.config
XWork configuration.
configuration - Variable in class com.opensymphony.xwork2.config.ConfigurationManager
configuration - Variable in class com.opensymphony.xwork2.DefaultActionProxy
configuration - Variable in class com.opensymphony.xwork2.TestNGXWorkTestCase
configuration - Variable in class com.opensymphony.xwork2.XWorkTestCase
ConfigurationException - Exception in com.opensymphony.xwork2.config
ConfigurationException
ConfigurationException() - Constructor for exception com.opensymphony.xwork2.config.ConfigurationException
Constructs a ConfigurationException with no detail message.
ConfigurationException(String) - Constructor for exception com.opensymphony.xwork2.config.ConfigurationException
Constructs a ConfigurationException with the specified detail message.
ConfigurationException(String, Object) - Constructor for exception com.opensymphony.xwork2.config.ConfigurationException
Constructs a ConfigurationException with the specified detail message.
ConfigurationException(Throwable) - Constructor for exception com.opensymphony.xwork2.config.ConfigurationException
Constructs a ConfigurationException with no detail message.
ConfigurationException(Throwable, Object) - Constructor for exception com.opensymphony.xwork2.config.ConfigurationException
Constructs a ConfigurationException with no detail message.
ConfigurationException(String, Throwable) - Constructor for exception com.opensymphony.xwork2.config.ConfigurationException
Constructs a ConfigurationException with the specified detail message.
ConfigurationException(String, Throwable, Object) - Constructor for exception com.opensymphony.xwork2.config.ConfigurationException
Constructs a ConfigurationException with the specified detail message.
ConfigurationManager - Class in com.opensymphony.xwork2.config
ConfigurationManager - central for XWork Configuration management, including its ConfigurationProvider.
ConfigurationManager() - Constructor for class com.opensymphony.xwork2.config.ConfigurationManager
ConfigurationManager(String) - Constructor for class com.opensymphony.xwork2.config.ConfigurationManager
configurationManager - Variable in class com.opensymphony.xwork2.TestNGXWorkTestCase
configurationManager - Variable in class com.opensymphony.xwork2.XWorkTestCase
ConfigurationProvider - Interface in com.opensymphony.xwork2.config
Interface to be implemented by all forms of XWork configuration classes.
ConfigurationUtil - Class in com.opensymphony.xwork2.config
ConfigurationUtil
constant(String, String) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a constant value to the given name.
constant(String, int) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a constant value to the given name.
constant(String, long) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a constant value to the given name.
constant(String, boolean) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a constant value to the given name.
constant(String, double) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a constant value to the given name.
constant(String, float) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a constant value to the given name.
constant(String, short) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a constant value to the given name.
constant(String, char) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a constant value to the given name.
constant(String, Class) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a class to the given name.
constant(String, E) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps an enum to the given name.
constructInterceptorReference(InterceptorLocator, String, Map<String, String>, Location, ObjectFactory) - Static method in class com.opensymphony.xwork2.config.providers.InterceptorBuilder
Builds a list of interceptors referenced by the refName in the supplied PackageConfig (InterceptorMapping object).
CONTAINER - Static variable in class com.opensymphony.xwork2.ActionContext
Constant for the container
container - Variable in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
container - Variable in class com.opensymphony.xwork2.DefaultActionInvocation
container - Variable in class com.opensymphony.xwork2.DefaultActionProxyFactory
Container - Interface in com.opensymphony.xwork2.inject
Injects dependencies into constructors, methods and fields annotated with Inject.
container - Variable in class com.opensymphony.xwork2.TestNGXWorkTestCase
container - Variable in class com.opensymphony.xwork2.XWorkTestCase
ContainerBuilder - Class in com.opensymphony.xwork2.inject
Builds a dependency injection Container.
ContainerBuilder() - Constructor for class com.opensymphony.xwork2.inject.ContainerBuilder
Constructs a new builder.
ContainerBuilder.Command - Interface in com.opensymphony.xwork2.inject
Implemented by classes which participate in building a container.
ContainerProvider - Interface in com.opensymphony.xwork2.config
Provides beans and constants/properties for the Container
contains(Class<?>, String) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Returns true if this builder contains a mapping for the given type and name.
contains(Class<?>) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to contains(type, Container.DEFAULT_NAME).
contains(char[], char) - Method in class com.opensymphony.xwork2.util.PropertiesReader
Checks if the object is in the given array.
contains(Object) - Method in class com.opensymphony.xwork2.util.XWorkList
containsKey(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
containsValue(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
Context - Interface in com.opensymphony.xwork2.inject
Context of the current injection.
context - Variable in class com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription
Conversion - Annotation Type in com.opensymphony.xwork2.conversion.annotations

A marker annotation for type conversions at Type level.

CONVERSION_COLLECTION_PREFIX - Static variable in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
CONVERSION_ERROR_PROPERTY_PREFIX - Static variable in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
CONVERSION_ERRORS - Static variable in class com.opensymphony.xwork2.ActionContext
Constant for the map of type conversion errors.
CONVERSION_PROPERTY_FULLNAME - Static variable in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
ConversionDescription - Class in com.opensymphony.xwork2.conversion.metadata
ConversionDescription
ConversionDescription() - Constructor for class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
ConversionDescription(String) - Constructor for class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
Creates an ConversionDescription with the specified property name.
ConversionErrorFieldValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator checks if there are any conversion errors for a field and applies them if they exist.
ConversionErrorFieldValidator - Class in com.opensymphony.xwork2.validator.validators
Field Validator that checks if a conversion error occured for this field.
ConversionErrorFieldValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.ConversionErrorFieldValidator
ConversionErrorFieldValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
ConversionErrorFieldValidatorDescription
ConversionErrorFieldValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription
ConversionErrorFieldValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.
ConversionErrorInterceptor - Class in com.opensymphony.xwork2.interceptor
ConversionErrorInterceptor adds conversion errors from the ActionContext to the Action's field errors.
ConversionErrorInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor
ConversionRule - Enum in com.opensymphony.xwork2.conversion.annotations
ConversionRule
ConversionType - Enum in com.opensymphony.xwork2.conversion.annotations
ConversionType
convert(String, E, Map<String, String>) - Method in class com.opensymphony.xwork2.config.impl.AbstractMatcher
Clones the target object and its children, replacing various properties with the values of the wildcard-matched strings.
convert(String, ActionConfig, Map<String, String>) - Method in class com.opensymphony.xwork2.config.impl.ActionConfigMatcher
Clones the ActionConfig and its children, replacing various properties with the values of the wildcard-matched strings.
convert(String, NamespaceMatch, Map<String, String>) - Method in class com.opensymphony.xwork2.config.impl.NamespaceMatcher
convertFromString(String, Class) - Method in class com.opensymphony.xwork2.conversion.impl.EnumTypeConverter
Deprecated. Converts one or more String values to the specified class.
convertParam(String, Map<String, String>) - Method in class com.opensymphony.xwork2.config.impl.AbstractMatcher
Inserts into a value wildcard-matched strings where specified with the {x} syntax.
convertValue(Map<String, Object>, Object, Class) - Method in class com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
convertValue(Map<String, Object>, Object, Member, String, Object, Class) - Method in class com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
convertValue(Object, Class) - Method in class com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
Returns the value converted numerically to the given class type This method also detects when arrays are being converted and converts the components of one array to the type of the other.
convertValue(Map<String, Object>, Object, Class) - Method in class com.opensymphony.xwork2.conversion.impl.EnumTypeConverter
Deprecated. Converts the given object to a given type.
convertValue(Map<String, Object>, Object, Member, String, Object, Class) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkBasicConverter
convertValue(Map<String, Object>, Object, Class) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
convertValue(Map<String, Object>, Object, Member, String, Object, Class) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
Convert value from one form to another.
convertValue(Map<String, Object>, Object, Member, String, Object, Class) - Method in interface com.opensymphony.xwork2.conversion.TypeConverter
Converts the given value to a given type.
convertValue(Map, Object, Member, String, Object, Class) - Method in class com.opensymphony.xwork2.ognl.OgnlTypeConverterWrapper
convertValue(Map, Object, Member, String, Object, Class) - Method in class com.opensymphony.xwork2.ognl.XWorkTypeConverterWrapper
copy(Object, Object, Map<String, Object>, Collection<String>, Collection<String>) - Method in class com.opensymphony.xwork2.ognl.OgnlReflectionProvider
copy(Object, Object, Map<String, Object>, Collection<String>, Collection<String>) - Method in class com.opensymphony.xwork2.ognl.OgnlUtil
Copies the properties in the object "from" and sets them in the object "to" using specified type converter, or XWorkConverter if none is specified.
copy(Object, Object, Map<String, Object>) - Method in class com.opensymphony.xwork2.ognl.OgnlUtil
Copies the properties in the object "from" and sets them in the object "to" using specified type converter, or XWorkConverter if none is specified.
copy(InputStream, OutputStream) - Static method in class com.opensymphony.xwork2.util.classloader.JarResourceStore
copy(Object, Object, Map<String, Object>, Collection<String>, Collection<String>) - Method in interface com.opensymphony.xwork2.util.reflection.ReflectionProvider
Copies the properties in the object "from" and sets them in the object "to" using specified type converter, or XWorkConverter if none is specified.
create(Context) - Method in class com.opensymphony.xwork2.config.impl.LocatableConstantFactory
create(Context) - Method in class com.opensymphony.xwork2.config.impl.LocatableFactory
create(boolean) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Creates a Container instance.
create(Context) - Method in interface com.opensymphony.xwork2.inject.Factory
Creates an object to be injected.
create(K) - Method in class com.opensymphony.xwork2.inject.util.ReferenceCache
Override to lazy load values.
CREATE_IF_NULL_PREFIX - Static variable in class com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer
CREATE_NULL_OBJECTS - Static variable in class com.opensymphony.xwork2.conversion.impl.InstantiatingNullHandler
Deprecated. Use ReflectionContextState.CREATE_NULL_OBJECTS instead
CREATE_NULL_OBJECTS - Static variable in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
createAction(Map<String, Object>) - Method in class com.opensymphony.xwork2.DefaultActionInvocation
createActionProxy(String, String, Map<String, Object>) - Method in interface com.opensymphony.xwork2.ActionProxyFactory
Deprecated. Since 2.1.1, use instead
createActionProxy(String, String, String, Map<String, Object>) - Method in interface com.opensymphony.xwork2.ActionProxyFactory
Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.
createActionProxy(String, String, Map<String, Object>, boolean, boolean) - Method in interface com.opensymphony.xwork2.ActionProxyFactory
Deprecated. Since 2.1.1, use ActionProxyFactory.createActionProxy(String,String,String,Map,boolean,boolean) instead
createActionProxy(String, String, String, Map<String, Object>, boolean, boolean) - Method in interface com.opensymphony.xwork2.ActionProxyFactory
Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.
createActionProxy(ActionInvocation, String, String, String, boolean, boolean) - Method in interface com.opensymphony.xwork2.ActionProxyFactory
Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including passed ActionInvocation instance.
createActionProxy(String, String, Map<String, Object>) - Method in class com.opensymphony.xwork2.DefaultActionProxyFactory
createActionProxy(String, String, String, Map<String, Object>) - Method in class com.opensymphony.xwork2.DefaultActionProxyFactory
createActionProxy(String, String, Map<String, Object>, boolean, boolean) - Method in class com.opensymphony.xwork2.DefaultActionProxyFactory
createActionProxy(String, String, String, Map<String, Object>, boolean, boolean) - Method in class com.opensymphony.xwork2.DefaultActionProxyFactory
createActionProxy(ActionInvocation, String, String, boolean, boolean) - Method in class com.opensymphony.xwork2.DefaultActionProxyFactory
createActionProxy(ActionInvocation, String, String, String, boolean, boolean) - Method in class com.opensymphony.xwork2.DefaultActionProxyFactory
createBootstrapContainer() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
createContextMap() - Method in class com.opensymphony.xwork2.DefaultActionInvocation
createDefaultContext(Object) - Method in class com.opensymphony.xwork2.ognl.OgnlReflectionContextFactory
createDefaultContext(Object) - Method in interface com.opensymphony.xwork2.util.reflection.ReflectionContextFactory
Creates and returns a new standard naming context for evaluating an OGNL expression.
CreateIfNull - Annotation Type in com.opensymphony.xwork2.util

Sets the CreateIfNull for type conversion.

createInstance(Class, LocaleProvider) - Method in class com.opensymphony.xwork2.TextProviderFactory
createInstance(ResourceBundle, LocaleProvider) - Method in class com.opensymphony.xwork2.TextProviderFactory
createResult() - Method in class com.opensymphony.xwork2.DefaultActionInvocation
createValueStack() - Method in class com.opensymphony.xwork2.ognl.OgnlValueStackFactory
createValueStack(ValueStack) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStackFactory
createValueStack() - Method in interface com.opensymphony.xwork2.util.ValueStackFactory
Get a new instance of ValueStack
createValueStack(ValueStack) - Method in interface com.opensymphony.xwork2.util.ValueStackFactory
Get a new instance of ValueStack
current - Static variable in class com.opensymphony.xwork2.util.profiling.UtilTimerStack
CURRENT_PROPERTY_PATH - Static variable in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
CustomValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This annotation can be used for custom validators.
cutStack(int) - Method in class com.opensymphony.xwork2.util.CompoundRoot

D

DateRangeFieldValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator checks that a date field has a value within a specified range.
DateRangeFieldValidator - Class in com.opensymphony.xwork2.validator.validators
Field Validator that checks if the date supplied is within a specific range.
DateRangeFieldValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator
DateRangeFieldValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
DateRangeFieldValidatorDescription
DateRangeFieldValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription
DateRangeFieldValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.
debug(String, String...) - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLogger
debug(String, Throwable, String...) - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLogger
debug(String, String...) - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLogger
debug(String, Throwable, String...) - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLogger
debug(String, String...) - Method in interface com.opensymphony.xwork2.util.logging.Logger
debug(String, Throwable, String...) - Method in interface com.opensymphony.xwork2.util.logging.Logger
DEFAULT_FOO_VALUE - Static variable in class com.opensymphony.xwork2.mock.MockInterceptor
DEFAULT_INVALID_FIELDVALUE - Static variable in interface com.opensymphony.xwork2.XWorkMessages
DEFAULT_NAME - Static variable in interface com.opensymphony.xwork2.inject.Container
Default dependency name.
DEFAULT_PARAM - Static variable in class com.opensymphony.xwork2.ActionChainResult
The result parameter name to set the name of the action to chain to.
DEFAULT_PARAMETER - Static variable in class com.opensymphony.xwork2.interceptor.I18nInterceptor
DEFAULT_REQUESTONLY_PARAMETER - Static variable in class com.opensymphony.xwork2.interceptor.I18nInterceptor
DEFAULT_SESSION_ATTRIBUTE - Static variable in class com.opensymphony.xwork2.interceptor.I18nInterceptor
DefaultActionInvocation - Class in com.opensymphony.xwork2
The Default ActionInvocation implementation
DefaultActionInvocation(Map<String, Object>, boolean) - Constructor for class com.opensymphony.xwork2.DefaultActionInvocation
DefaultActionProxy - Class in com.opensymphony.xwork2
The Default ActionProxy implementation
DefaultActionProxy(ActionInvocation, String, String, String, boolean, boolean) - Constructor for class com.opensymphony.xwork2.DefaultActionProxy
This constructor is private so the builder methods (create*) should be used to create an DefaultActionProxy.
DefaultActionProxyFactory - Class in com.opensymphony.xwork2
Default factory for ActionProxyFactory.
DefaultActionProxyFactory() - Constructor for class com.opensymphony.xwork2.DefaultActionProxyFactory
defaultActionRef(String) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
DefaultActionValidatorManager - Class in com.opensymphony.xwork2.validator
This is the entry point into XWork's rule-based validation framework.
DefaultActionValidatorManager() - Constructor for class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
DefaultActionValidatorManager.InternalValidatorContextWrapper - Class in com.opensymphony.xwork2.validator
An ValidatorContext wrapper that returns the full field name DefaultActionValidatorManager.InternalValidatorContextWrapper.getFullFieldName(String) by consulting it's parent if its an VisitorFieldValidator.AppendingValidatorContext.
defaultClassName(String) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
defaultClassRef(String) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
DefaultConfiguration - Class in com.opensymphony.xwork2.config.impl
DefaultConfiguration
DefaultConfiguration() - Constructor for class com.opensymphony.xwork2.config.impl.DefaultConfiguration
DefaultConfiguration(String) - Constructor for class com.opensymphony.xwork2.config.impl.DefaultConfiguration
defaultFrameworkBeanName - Variable in class com.opensymphony.xwork2.config.ConfigurationManager
defaultFrameworkBeanName - Variable in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
defaultInterceptorRef(String) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
defaultMappings - Variable in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
Record class and its type converter mapping.
defaultMessage(String) - Method in class com.opensymphony.xwork2.validator.ValidatorConfig.Builder
defaultMessage - Variable in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
DefaultObjectTypeDeterminer - Class in com.opensymphony.xwork2.conversion.impl
This ObjectTypeDeterminer looks at the Class-conversion.properties for entries that indicated what objects are contained within Maps and Collections.
DefaultObjectTypeDeterminer(XWorkConverter, ReflectionProvider) - Constructor for class com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer
defaultResultParam(String) - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig.Builder
defaultResultType(String) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
sets the default Result type for this package
DefaultTextProvider - Class in com.opensymphony.xwork2
DefaultTextProvider gets texts from only the default resource bundles associated with the LocalizedTextUtil.
DefaultTextProvider() - Constructor for class com.opensymphony.xwork2.DefaultTextProvider
DefaultTypeConverter - Class in com.opensymphony.xwork2.conversion.impl
Default type conversion.
DefaultTypeConverter() - Constructor for class com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
DefaultUnknownHandlerManager - Class in com.opensymphony.xwork2
Default implementation of UnknownHandlerManager
DefaultUnknownHandlerManager() - Constructor for class com.opensymphony.xwork2.DefaultUnknownHandlerManager
DefaultValidatorFactory - Class in com.opensymphony.xwork2.validator
Default validator factory
DefaultValidatorFactory(ObjectFactory, ValidatorFileParser) - Constructor for class com.opensymphony.xwork2.validator.DefaultValidatorFactory
DefaultValidatorFileParser - Class in com.opensymphony.xwork2.validator
Parse the validation file.
DefaultValidatorFileParser() - Constructor for class com.opensymphony.xwork2.validator.DefaultValidatorFileParser
DefaultWorkflowInterceptor - Class in com.opensymphony.xwork2.interceptor

An interceptor that makes sure there are not validation errors before allowing the interceptor chain to continue.

DefaultWorkflowInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor
DelegatingValidatorContext - Class in com.opensymphony.xwork2.validator
A default implementation of the ValidatorContext interface.
DelegatingValidatorContext(ValidationAware, TextProvider, LocaleProvider) - Constructor for class com.opensymphony.xwork2.validator.DelegatingValidatorContext
Creates a new validation context given a ValidationAware object, and a text and locale provider.
DelegatingValidatorContext(Object) - Constructor for class com.opensymphony.xwork2.validator.DelegatingValidatorContext
Creates a new validation context given an object - usually an Action.
DelegatingValidatorContext(Class) - Constructor for class com.opensymphony.xwork2.validator.DelegatingValidatorContext
Create a new validation context given a Class definition.
DENY_INDEXED_ACCESS_EXECUTION - Static variable in class com.opensymphony.xwork2.ognl.accessor.XWorkMethodAccessor
Deprecated. Use ReflectionContextState.DENY_INDEXED_ACCESS_EXECUTION instead
DENY_INDEXED_ACCESS_EXECUTION - Static variable in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
DENY_METHOD_EXECUTION - Static variable in class com.opensymphony.xwork2.ognl.accessor.XWorkMethodAccessor
Deprecated. Use ReflectionContextState.DENY_METHOD_EXECUTION instead
DENY_METHOD_EXECUTION - Static variable in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
DependencyException - Exception in com.opensymphony.xwork2.inject
Thrown when a dependency is misconfigured.
DependencyException(String) - Constructor for exception com.opensymphony.xwork2.inject.DependencyException
DependencyException(String, Throwable) - Constructor for exception com.opensymphony.xwork2.inject.DependencyException
DependencyException(Throwable) - Constructor for exception com.opensymphony.xwork2.inject.DependencyException
DEPRECATED_ELEMENT_PREFIX - Static variable in class com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer
DEPRECATED_ELEMENT_PREFIX - Static variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
destroy() - Method in interface com.opensymphony.xwork2.config.Configuration
Allow the Configuration to clean up any resources that have been used.
destroy() - Method in interface com.opensymphony.xwork2.config.ContainerProvider
Called before removed from the configuration manager
destroy() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
Allows the configuration to clean up any resources used
destroy() - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration
destroy() - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
destroy() - Method in class com.opensymphony.xwork2.config.providers.XWorkConfigurationProvider
destroy() - Method in class com.opensymphony.xwork2.interceptor.AbstractInterceptor
Does nothing
destroy() - Method in class com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor
destroy() - Method in interface com.opensymphony.xwork2.interceptor.Interceptor
Called to let an interceptor clean up any resources it has allocated.
destroy() - Method in class com.opensymphony.xwork2.mock.MockInterceptor
Called to let an interceptor clean up any resources it has allocated.
destroy() - Method in class com.opensymphony.xwork2.test.StubConfigurationProvider
destroyConfiguration() - Method in class com.opensymphony.xwork2.config.ConfigurationManager
Destroy its managing Configuration instance
doBeforeInvocation(ActionInvocation) - Method in class com.opensymphony.xwork2.validator.ValidationInterceptor
Gets the current action and its context and delegates to ActionValidatorManager proper validate method.
doDefault() - Method in class com.opensymphony.xwork2.ActionSupport
doesMatchClass() - Method in class com.opensymphony.xwork2.util.ResolverUtil.ClassTest
doesMatchClass() - Method in class com.opensymphony.xwork2.util.ResolverUtil.ResourceTest
doesMatchClass() - Method in interface com.opensymphony.xwork2.util.ResolverUtil.Test
doesMatchResource() - Method in class com.opensymphony.xwork2.util.ResolverUtil.ClassTest
doesMatchResource() - Method in class com.opensymphony.xwork2.util.ResolverUtil.ResourceTest
doesMatchResource() - Method in interface com.opensymphony.xwork2.util.ResolverUtil.Test
doIntercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor
Intercept ActionInvocation and returns a inputResultName when action / field errors is found registered.
doIntercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
Subclasses must override to implement the interceptor logic.
doIntercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
doIntercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.PrepareInterceptor
doIntercept(ActionInvocation) - Method in class com.opensymphony.xwork2.validator.ValidationInterceptor
doLog(Logger, Exception) - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
Performs the actual logging.
doLog(Logger, String) - Method in class com.opensymphony.xwork2.interceptor.TimerInterceptor
Performs the actual logging.
DomHelper - Class in com.opensymphony.xwork2.util
Helper class to create and retrieve information from location-enabled DOM-trees.
DomHelper() - Constructor for class com.opensymphony.xwork2.util.DomHelper
DomHelper.DOMBuilder - Class in com.opensymphony.xwork2.util
The DOMBuilder is a utility class that will generate a W3C DOM Document from SAX events.
DomHelper.DOMBuilder() - Constructor for class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
Construct a new instance of this DOMBuilder.
DomHelper.DOMBuilder(SAXTransformerFactory) - Constructor for class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
Construct a new instance of this DOMBuilder.
DomHelper.DOMBuilder(Node) - Constructor for class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
Constructs a new instance that appends nodes to the given parent node.
DomHelper.DOMBuilder(SAXTransformerFactory, Node) - Constructor for class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
Construct a new instance of this DOMBuilder.
DomHelper.StartHandler - Class in com.opensymphony.xwork2.util
DomHelper.StartHandler(ContentHandler, Map<String, String>) - Constructor for class com.opensymphony.xwork2.util.DomHelper.StartHandler
Create a filter that is chained to another handler.
doProfiling() - Method in interface com.opensymphony.xwork2.util.profiling.UtilTimerStack.ProfilingBlock
Method that execute the code subjected to profiling.
DoubleRangeFieldValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator checks that a double field has a value within a specified range.
DoubleRangeFieldValidator - Class in com.opensymphony.xwork2.validator.validators
Field Validator that checks if the double specified is within a certain range.
DoubleRangeFieldValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator
DoubleRangeFieldValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
DoubleRangeFieldValidatorDescription
DoubleRangeFieldValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription
DoubleRangeFieldValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription
Creates an DoubleRangeFieldValidatorDescription with the specified field name.
doubleValue(Object) - Static method in class com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
Evaluates the given object as a double-precision floating-point number.
doValidate(Object) - Method in class com.opensymphony.xwork2.validator.validators.ConversionErrorFieldValidator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
doValidate(Object) - Method in class com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport

E

Element - Annotation Type in com.opensymphony.xwork2.util

Sets the Element for type conversion.

ELEMENT_PREFIX - Static variable in class com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer
ELEMENT_PREFIX - Static variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
emailAddressPattern - Static variable in class com.opensymphony.xwork2.validator.validators.EmailValidator
EmailValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator checks that a field is a valid e-mail address if it contains a non-empty String.
EmailValidator - Class in com.opensymphony.xwork2.validator.validators
EmailValidator checks that a given String field, if not empty, is a valid email address.
EmailValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.EmailValidator
EmailValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
EmailValidatorDescription
EmailValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription
EmailValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.
endDocument() - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
endDocument() - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler
endDocument() - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe
endElement(String, String, String) - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
endElement(String, String, String) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler
endElement(String, String, String) - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe
endPrefixMapping(String) - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
endPrefixMapping(String) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler
endPrefixMapping(String) - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe
entrySet() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
Returns an unmodifiable set view of the entries in this map.
EnumTypeConverter - Class in com.opensymphony.xwork2.conversion.impl
Deprecated. Since Struts 2.1.0 as enum support is now built into XWork
EnumTypeConverter() - Constructor for class com.opensymphony.xwork2.conversion.impl.EnumTypeConverter
Deprecated.
enumValue(Class, Object) - Method in class com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
equals(Object) - Method in class com.opensymphony.xwork2.ActionChainResult
equals(Object) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig
equals(Object) - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig
equals(Object) - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig
equals(Object) - Method in class com.opensymphony.xwork2.config.entities.InterceptorMapping
equals(Object) - Method in class com.opensymphony.xwork2.config.entities.InterceptorStackConfig
An InterceptorStackConfig object is equals with o only if o is an InterceptorStackConfig object both names are equals all of their InterceptorMappings are equals
equals(Object) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
equals(Object) - Method in class com.opensymphony.xwork2.config.entities.ResultConfig
equals(Object) - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig
equals(Object) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
equals(Object) - Method in class com.opensymphony.xwork2.mock.MockInterceptor
equals(Object) - Method in class com.opensymphony.xwork2.mock.MockResult
equals(Object) - Method in class com.opensymphony.xwork2.util.location.LocationImpl
ERROR - Static variable in interface com.opensymphony.xwork2.Action
The action execution was a failure.
error(SAXParseException) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler
error(String, String...) - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLogger
error(String, Throwable, String...) - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLogger
error(String, String...) - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLogger
error(String, Throwable, String...) - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLogger
error(String, String...) - Method in interface com.opensymphony.xwork2.util.logging.Logger
error(String, Throwable, String...) - Method in interface com.opensymphony.xwork2.util.logging.Logger
evaluate(Object) - Method in interface com.opensymphony.xwork2.util.TextParseUtil.ParsedValueEvaluator
Evaluated the value parsed by Ognl value stack.
exceptionClassName(String) - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig.Builder
ExceptionHolder - Class in com.opensymphony.xwork2.interceptor
A simple wrapper around an exception, providing an easy way to print out the stack trace of the exception as well as a way to get a handle on the exception itself.
ExceptionHolder(Exception) - Constructor for class com.opensymphony.xwork2.interceptor.ExceptionHolder
Holds the given exception
ExceptionMappingConfig - Class in com.opensymphony.xwork2.config.entities
Configuration for exception mapping.
ExceptionMappingConfig(String, String, String) - Constructor for class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig
ExceptionMappingConfig(ExceptionMappingConfig) - Constructor for class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig
ExceptionMappingConfig.Builder - Class in com.opensymphony.xwork2.config.entities
The builder for this object.
ExceptionMappingConfig.Builder(ExceptionMappingConfig) - Constructor for class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig.Builder
ExceptionMappingConfig.Builder(String, String, String) - Constructor for class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig.Builder
ExceptionMappingInterceptor - Class in com.opensymphony.xwork2.interceptor
This interceptor forms the core functionality of the exception handling feature.
ExceptionMappingInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
exceptionMappings(Collection<? extends ExceptionMappingConfig>) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
exceptionMappings - Variable in class com.opensymphony.xwork2.config.entities.ActionConfig
exclude(UrlSet) - Method in class com.opensymphony.xwork2.util.finder.UrlSet
exclude(ClassLoaderInterface) - Method in class com.opensymphony.xwork2.util.finder.UrlSet
exclude(File) - Method in class com.opensymphony.xwork2.util.finder.UrlSet
exclude(String) - Method in class com.opensymphony.xwork2.util.finder.UrlSet
excludeJavaEndorsedDirs() - Method in class com.opensymphony.xwork2.util.finder.UrlSet
Calls excludePaths(System.getProperty("java.endorsed.dirs"))
excludeJavaExtDirs() - Method in class com.opensymphony.xwork2.util.finder.UrlSet
Calls excludePaths(System.getProperty("java.ext.dirs"))
excludeJavaHome() - Method in class com.opensymphony.xwork2.util.finder.UrlSet
excludeMethods - Variable in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
excludePaths(String) - Method in class com.opensymphony.xwork2.util.finder.UrlSet
excludes - Variable in class com.opensymphony.xwork2.interceptor.ChainingInterceptor
execute() - Method in interface com.opensymphony.xwork2.Action
Where the logic of the action is executed.
execute(ActionInvocation) - Method in class com.opensymphony.xwork2.ActionChainResult
execute() - Method in interface com.opensymphony.xwork2.ActionProxy
Execute this ActionProxy.
execute() - Method in class com.opensymphony.xwork2.ActionSupport
A default implementation that does nothing an returns "success".
execute() - Method in class com.opensymphony.xwork2.DefaultActionProxy
execute(ReferenceMap, Object, Object) - Method in interface com.opensymphony.xwork2.inject.util.ReferenceMap.Strategy
execute() - Method in class com.opensymphony.xwork2.mock.MockActionProxy
execute(ActionInvocation) - Method in class com.opensymphony.xwork2.mock.MockResult
execute(ActionInvocation) - Method in interface com.opensymphony.xwork2.Result
Represents a generic interface for all action execution results.
executeAction(String, String, String) - Method in class com.opensymphony.xwork2.XWork
Executes an action
executeAction(String, String, String, Map<String, Object>) - Method in class com.opensymphony.xwork2.XWork
Executes an action with extra context information
executed - Variable in class com.opensymphony.xwork2.DefaultActionInvocation
executeResult - Variable in class com.opensymphony.xwork2.DefaultActionProxy
explicitResult - Variable in class com.opensymphony.xwork2.DefaultActionInvocation
expression - Variable in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription
expression - Variable in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
ExpressionValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This non-field level validator validates a supplied regular expression.
ExpressionValidator - Class in com.opensymphony.xwork2.validator.validators
A Non-Field Level validator that validates based on regular expression supplied.
ExpressionValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.ExpressionValidator
ExpressionValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
ExpressionValidatorDescription
ExpressionValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription
extraContext - Variable in class com.opensymphony.xwork2.DefaultActionInvocation

F

factory(Class<T>, String, Factory<? extends T>, Scope) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a factory to a given dependency type and name.
factory(Class<T>, Factory<? extends T>, Scope) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, scope).
factory(Class<T>, String, Factory<? extends T>) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to factory(type, name, factory, Scope.DEFAULT).
factory(Class<T>, Factory<? extends T>) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, Scope.DEFAULT).
factory(Class<T>, String, Class<? extends T>, Scope) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps an implementation class to a given dependency type and name.
factory(Class<T>, String, Class<? extends T>) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps an implementation class to a given dependency type and name.
factory(Class<T>, Class<? extends T>) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, implementation).
factory(Class<T>) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, type).
factory(Class<T>, String) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to factory(type, name, type).
factory(Class<T>, Class<? extends T>, Scope) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, implementation, scope).
factory(Class<T>, Scope) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, type, scope).
factory(Class<T>, String, Scope) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to factory(type, name, type, scope).
Factory<T> - Interface in com.opensymphony.xwork2.inject
A custom factory.
FACTORY - Static variable in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
The default transformer factory shared by all instances
factory - Variable in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
The transformer factory
fatal(String, String...) - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLogger
fatal(String, Throwable, String...) - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLogger
fatal(String, String...) - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLogger
fatal(String, Throwable, String...) - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLogger
fatal(String, String...) - Method in interface com.opensymphony.xwork2.util.logging.Logger
fatal(String, Throwable, String...) - Method in interface com.opensymphony.xwork2.util.logging.Logger
fatalError(SAXParseException) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler
FieldExpressionValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator uses an OGNL expression to perform its validator.
FieldExpressionValidator - Class in com.opensymphony.xwork2.validator.validators
Validates a field using an OGNL expression.
FieldExpressionValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.FieldExpressionValidator
FieldExpressionValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
FieldExpressionValidatorDescription
FieldExpressionValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
FieldExpressionValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.
fieldName - Variable in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
FieldValidator - Interface in com.opensymphony.xwork2.validator
The FieldValidator interface defines the methods to be implemented by FieldValidators.
FieldValidatorSupport - Class in com.opensymphony.xwork2.validator.validators
Base class for field validators.
FieldValidatorSupport() - Constructor for class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
FileManager - Class in com.opensymphony.xwork2.util
FileManager

This class was brought in from oscore trunk revision 147.

fileNeedsReloading(String, Class) - Static method in class com.opensymphony.xwork2.util.FileManager
fileNeedsReloading(String) - Static method in class com.opensymphony.xwork2.util.FileManager
FileResourceStore - Class in com.opensymphony.xwork2.util.classloader
Reads a class from disk class taken from Apache JCI
FileResourceStore(File) - Constructor for class com.opensymphony.xwork2.util.classloader.FileResourceStore
FinalizablePhantomReference<T> - Class in com.opensymphony.xwork2.inject.util
Phantom reference with a finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent.
FinalizablePhantomReference(T) - Constructor for class com.opensymphony.xwork2.inject.util.FinalizablePhantomReference
FinalizableSoftReference<T> - Class in com.opensymphony.xwork2.inject.util
Soft reference with a finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent.
FinalizableSoftReference(T) - Constructor for class com.opensymphony.xwork2.inject.util.FinalizableSoftReference
FinalizableWeakReference<T> - Class in com.opensymphony.xwork2.inject.util
Weak reference with a finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent.
FinalizableWeakReference(T) - Constructor for class com.opensymphony.xwork2.inject.util.FinalizableWeakReference
find(Class, String) - Static method in class com.opensymphony.xwork2.util.AnnotationUtils
Retrieves all classes within a packages.
find(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
find(ResolverUtil.Test, String...) - Method in class com.opensymphony.xwork2.util.ResolverUtil
Attempts to discover classes that pass the test.
findAll(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
findAllClasses(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Executes findAllStrings assuming the strings are the names of a classes that should be loaded and returned.
findAllImplementations(Class) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Assumes the class specified points to a file in the classpath that contains the name of a class that implements or is a subclass of the specfied class.
findAllProperties(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Finds the corresponding resources and reads them in as a properties files

Any URL that cannot be read in as a properties file will cause an exception to be thrown.

findAllStrings(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Reads the contents of the found URLs as a list of String's and returns them.
findAnnotated(Class<? extends Annotation>, String...) - Method in class com.opensymphony.xwork2.util.ResolverUtil
Attempts to discover classes that are annotated with to the annotation.
findAnnotatedClasses(Class<? extends Annotation>) - Method in class com.opensymphony.xwork2.util.finder.ClassFinder
findAnnotatedConstructors(Class<? extends Annotation>) - Method in class com.opensymphony.xwork2.util.finder.ClassFinder
findAnnotatedFields(Class<? extends Annotation>) - Method in class com.opensymphony.xwork2.util.finder.ClassFinder
findAnnotatedMethods(Class, Class<? extends Annotation>) - Static method in class com.opensymphony.xwork2.util.AnnotationUtils
Deprecated. since 2.0.4 use getAnnotatedMethods
findAnnotatedMethods(Class<? extends Annotation>) - Method in class com.opensymphony.xwork2.util.finder.ClassFinder
findAnnotatedPackages(Class<? extends Annotation>) - Method in class com.opensymphony.xwork2.util.finder.ClassFinder
findAutoWiringBeanFactory(ApplicationContext) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
If the given context is assignable to AutowireCapbleBeanFactory or contains a parent or a factory that is, then set the autoWiringFactory appropriately.
findAvailableClasses(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Executes findAvailableStrings assuming the strings are the names of a classes that should be loaded and returned.
findAvailableImplementations(Class) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Assumes the class specified points to a file in the classpath that contains the name of a class that implements or is a subclass of the specfied class.
findAvailableProperties(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Finds the corresponding resources and reads them in as a properties files

Any URL that cannot be read in as a properties file will be added to the 'resourcesNotLoaded' collection.

findAvailableStrings(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Reads the contents of the found URLs as a Strings and returns them.
findClass(String) - Method in class com.opensymphony.xwork2.util.classloader.ResourceStoreClassLoader
findClass(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Executes ResourceFinder.findString(String) assuming the contents URL found is the name of a class that should be loaded and returned.
findClasses(Test<ClassFinder.ClassInfo>) - Method in class com.opensymphony.xwork2.util.finder.ClassFinder
findClasses() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder
findClassesInPackage(String, boolean) - Method in class com.opensymphony.xwork2.util.finder.ClassFinder
findDefaultText(String, Locale) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Returns a localized message for the specified key, aTextName.
findDefaultText(String, Locale, Object[]) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Returns a localized message for the specified key, aTextName, substituting variables from the array of params into the message.
findImplementation(Class) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Assumes the class specified points to a file in the classpath that contains the name of a class that implements or is a subclass of the specfied class.
findImplementations(Class, String...) - Method in class com.opensymphony.xwork2.util.ResolverUtil
Attempts to discover classes that are assignable to the type provided.
findInPackage(ResolverUtil.Test, String) - Method in class com.opensymphony.xwork2.util.ResolverUtil
Scans for classes starting at the package provided and descending into subpackages.
findInRequest(Class<T>, String, Callable<? extends T>) - Method in interface com.opensymphony.xwork2.inject.Scope.Strategy
Finds an object for the given type and name in the request scope.
findInSession(Class<T>, String, Callable<? extends T>) - Method in interface com.opensymphony.xwork2.inject.Scope.Strategy
Finds an object for the given type and name in the session scope.
findInWizard(Class<T>, String, Callable<? extends T>) - Method in interface com.opensymphony.xwork2.inject.Scope.Strategy
Finds an object for the given type and name in the wizard scope.
findMatches() - Method in class com.opensymphony.xwork2.util.ClassPathFinder
Builds a Vector containing Strings which each name a file who's name matches the pattern set by setPattern(String).
findNamedResource(String, String...) - Method in class com.opensymphony.xwork2.util.ResolverUtil
findPackages(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Gets a list of subpckages from jars or dirs
findPackagesMap(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Gets a list of subpckages from jars or dirs
findProperties(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Finds the corresponding resource and reads it in as a properties file

Example classpath:

META-INF/widget.properties

ResourceFinder finder = new ResourceFinder("META-INF/"); Properties widgetProps = finder.findProperties("widget.properties");

findRecursively(Class, Class<? extends Annotation>, List<Method>) - Static method in class com.opensymphony.xwork2.util.AnnotationUtils
Deprecated. since 2.0.4 use getAnnotatedMethods
findResourceBundle(String, Locale) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Finds the given resorce bundle by it's name.
findResultFromExceptions(List<ExceptionMappingConfig>, Throwable) - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
findString(String) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
findString(String, boolean) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
findString(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Reads the contents of the URL as a String's and returns it.
findString(String) - Method in interface com.opensymphony.xwork2.util.ValueStack
findString(String, boolean) - Method in interface com.opensymphony.xwork2.util.ValueStack
findSuffix(String, String...) - Method in class com.opensymphony.xwork2.util.ResolverUtil
Attempts to discover classes who's name ends with the provided suffix.
findText(Class, String, Locale) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Calls LocalizedTextUtil.findText(Class aClass, String aTextName, Locale locale, String defaultMessage, Object[] args) with aTextName as the default message.
findText(Class, String, Locale, String, Object[]) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Finds a localized text message for the given key, aTextName.
findText(Class, String, Locale, String, Object[], ValueStack) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Finds a localized text message for the given key, aTextName.
findText(ResourceBundle, String, Locale) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Finds a localized text message for the given key, aTextName, in the specified resource bundle with aTextName as the default message.
findText(ResourceBundle, String, Locale, String, Object[]) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Finds a localized text message for the given key, aTextName, in the specified resource bundle.
findText(ResourceBundle, String, Locale, String, Object[], ValueStack) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Finds a localized text message for the given key, aTextName, in the specified resource bundle.
findValue(String, boolean) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
findValue(String) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
findValue(String, Class, boolean) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
findValue(String, Class) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
findValue(String) - Method in interface com.opensymphony.xwork2.util.ValueStack
Find a value by evaluating the given expression against the stack in the default search order.
findValue(String, boolean) - Method in interface com.opensymphony.xwork2.util.ValueStack
findValue(String, Class) - Method in interface com.opensymphony.xwork2.util.ValueStack
Find a value by evaluating the given expression against the stack in the default search order.
findValue(String, Class, boolean) - Method in interface com.opensymphony.xwork2.util.ValueStack
format(String, String...) - Static method in class com.opensymphony.xwork2.util.logging.LoggerUtils
Formats messages using parameters.
freeze() - Method in class com.opensymphony.xwork2.config.impl.AbstractMatcher
FULL_PROPERTY_PATH - Static variable in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
fullQualifiedClassName - Variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
Function<F,T> - Interface in com.opensymphony.xwork2.inject.util
A Function provides a transformation on an object and returns the resulting object.

G

GenericsObjectTypeDeterminer - Class in com.opensymphony.xwork2.conversion.impl
Deprecated. Use DefaultObjectTypeDeterminer instead. Since XWork 2.0.4 the DefaultObjectTypeDeterminer handles the annotation processing.
GenericsObjectTypeDeterminer(XWorkConverter, XWorkBasicConverter, ReflectionProvider) - Constructor for class com.opensymphony.xwork2.conversion.impl.GenericsObjectTypeDeterminer
Deprecated.
get(String) - Method in class com.opensymphony.xwork2.ActionContext
Returns a value that is stored in the current ActionContext by doing a lookup using the value's key.
get(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceCache
If this map does not contain an entry for the given key and ReferenceCache.create(Object) has been overridden, this method will create a new value, put it in the map, and return it.
get(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
get() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.ClassInfo
get() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.PackageInfo
get(Location) - Static method in class com.opensymphony.xwork2.util.location.LocationImpl
Obtain a LocationImpl from a Location.
get(int) - Method in class com.opensymphony.xwork2.util.XWorkList
Returns the element at the specified position in this list.
getAction() - Method in interface com.opensymphony.xwork2.ActionInvocation
Get the Action associated with this ActionInvocation.
getAction() - Method in interface com.opensymphony.xwork2.ActionProxy
Gets the Action instance for this Proxy.
getAction() - Method in class com.opensymphony.xwork2.DefaultActionInvocation
getAction() - Method in class com.opensymphony.xwork2.DefaultActionProxy
getAction() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation
getAction() - Method in class com.opensymphony.xwork2.mock.MockActionProxy
getActionConfig(String, String) - Method in interface com.opensymphony.xwork2.config.RuntimeConfiguration
get the fully expanded ActionConfig for a specified namespace and (action) name
getActionConfigs() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
getActionConfigs() - Method in interface com.opensymphony.xwork2.config.RuntimeConfiguration
returns a Map of all the registered ActionConfigs.
getActionErrors() - Method in class com.opensymphony.xwork2.ActionSupport
getActionErrors() - Method in interface com.opensymphony.xwork2.ValidationAware
Get the Collection of Action-level error messages for this action.
getActionErrors() - Method in class com.opensymphony.xwork2.ValidationAwareSupport
getActionErrors() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
getActionEventListener() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation
getActionInvocation() - Method in class com.opensymphony.xwork2.ActionContext
Gets the action invocation (the execution state).
getActionMessages() - Method in class com.opensymphony.xwork2.ActionSupport
getActionMessages() - Method in interface com.opensymphony.xwork2.ValidationAware
Get the Collection of Action-level messages for this action.
getActionMessages() - Method in class com.opensymphony.xwork2.ValidationAwareSupport
getActionMessages() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
getActionName() - Method in interface com.opensymphony.xwork2.ActionProxy
Gets the alias name this ActionProxy is mapped to.
getActionName() - Method in class com.opensymphony.xwork2.DefaultActionProxy
getActionName() - Method in class com.opensymphony.xwork2.mock.MockActionProxy
getAllActionConfigs() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
returns the Map of all the ActionConfigs available in the current package.
getAllExceptionMappingConfigs() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
returns the List of all the ExceptionMappingConfigs available in the current package.
getAllGlobalResults() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
returns the Map of all the global ResultConfigs available in the current package.
getAllInterceptorConfigs() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
returns the Map of all InterceptorConfigs and InterceptorStackConfigs available in the current package.
getAllowedCollection() - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor
getAllowedMethods() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig
getAllowStaticMethodAccess() - Method in class com.opensymphony.xwork2.ognl.SecurityMemberAccess
getAllResultTypeConfigs() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
returns the Map of all the ResultTypeConfigs available in the current package.
getAnnotatedMethods(Class, Class<? extends Annotation>...) - Static method in class com.opensymphony.xwork2.util.AnnotationUtils
For the given Class get a collection of the the AnnotatedElements that match the given annotations or if no annotations are specified then return all of the annotated elements of the given Class.
getAnnotation(Class, String, Class<T>) - Method in class com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer
Retrieves an annotation for the specified property of field, setter or getter.
getAnnotations() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.Annotatable
getAnnotations() - Method in interface com.opensymphony.xwork2.util.finder.ClassFinder.Info
getApplication() - Method in class com.opensymphony.xwork2.ActionContext
Returns a Map of the ServletContext when in a servlet environment or a generic application level Map otherwise.
getApplicationContext() - Method in class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor
getApplicationContext(Map<String, Object>) - Method in class com.opensymphony.xwork2.spring.SpringProxyableObjectFactory
Subclasses may override this to return a different application context.
getAutowireStrategy() - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
getBeanInfo(Object) - Method in class com.opensymphony.xwork2.ognl.OgnlUtil
Get's the java bean info for the given source object.
getBeanInfo(Class) - Method in class com.opensymphony.xwork2.ognl.OgnlUtil
Get's the java bean info for the given source.
getBeanMap(Object) - Method in class com.opensymphony.xwork2.ognl.OgnlReflectionProvider
getBeanMap(Object) - Method in class com.opensymphony.xwork2.ognl.OgnlUtil
Creates a Map with read properties for the given source object.
getBeanMap(Object) - Method in interface com.opensymphony.xwork2.util.reflection.ReflectionProvider
Creates a Map with read properties for the given source object.
getBlockedCollection() - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor
getChainHistory() - Static method in class com.opensymphony.xwork2.ActionChainResult
Get the XWork chain history.
getClasses() - Method in class com.opensymphony.xwork2.util.ResolverUtil
Provides access to the classes discovered so far.
getClassesNotLoaded() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder
Returns a list of classes that could not be loaded in last invoked findAnnotated* method.
getClassInstance(String) - Method in class com.opensymphony.xwork2.ObjectFactory
Utility method to obtain the class matched to className.
getClassInstance(String) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
getClassLoader() - Method in class com.opensymphony.xwork2.util.ResolverUtil
Returns the classloader that will be used for scanning for classes.
getClassName() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig
getClassName() - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig
getClassName() - Method in class com.opensymphony.xwork2.config.entities.ResultConfig
getClassName() - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig
getClazz() - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig
Deprecated. Since 2.1, use ResultTypeConfig.getClassName() instead
getColumn(Attributes) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the column number of an element (SAX flavor)
getColumn(Element) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the column number of an element (DOM flavor)
getColumnNumber() - Method in interface com.opensymphony.xwork2.util.location.Location
Get the column number of this location
getColumnNumber() - Method in class com.opensymphony.xwork2.util.location.LocationImpl
Get the column number of this location
getCommentLines() - Method in class com.opensymphony.xwork2.util.PropertiesReader
Returns the comment lines that have been read for the last property.
getConfig() - Method in interface com.opensymphony.xwork2.ActionProxy
Gets the ActionConfig this ActionProxy is built from.
getConfig() - Method in class com.opensymphony.xwork2.DefaultActionProxy
getConfig() - Method in class com.opensymphony.xwork2.mock.MockActionProxy
getConfiguration() - Method in class com.opensymphony.xwork2.config.ConfigurationManager
Get the current XWork configuration object.
getConfigurationProviders() - Method in class com.opensymphony.xwork2.config.ConfigurationManager
Deprecated. Since 2.1, use ConfigurationManager.getContainerProviders()
getConfigurationUrls(String) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
getConstructors() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.ClassInfo
getContainer() - Method in class com.opensymphony.xwork2.ActionContext
Sets the container for this request
getContainer() - Method in interface com.opensymphony.xwork2.config.Configuration
getContainer() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
getContainer() - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration
getContainer() - Method in interface com.opensymphony.xwork2.inject.Context
Gets the Container.
getContainerProviders() - Method in class com.opensymphony.xwork2.config.ConfigurationManager
Get the current list of ConfigurationProviders.
getContent(Element) - Static method in class com.opensymphony.xwork2.config.providers.XmlHelper
This method will return the content of this particular element.
getContext() - Static method in class com.opensymphony.xwork2.ActionContext
Returns the ActionContext specific to the current thread.
getContext() - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
getContext() - Method in interface com.opensymphony.xwork2.util.ValueStack
Gets the context for this value stack.
getContext() - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator
getContextMap() - Method in class com.opensymphony.xwork2.ActionContext
Gets the context map.
getConversionErrorMessage(String, ValueStack) - Static method in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
getConversionErrors() - Method in class com.opensymphony.xwork2.ActionContext
Gets the map of conversion errors which occurred when executing the action.
getConverter(Class, String) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
getCurrentPropertyPath(Map<String, Object>) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
Gets the current property path but not completely.
getDeclaringClass() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.FieldInfo
getDeclaringClass() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.MethodInfo
getDefaultActionRef() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
getDefaultClassRef() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
getDefaultClassRef() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
getDefaultInterceptorRef() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
getDefaultMessage() - Method in interface com.opensymphony.xwork2.validator.Validator
Gets the default message used for validation failures
getDefaultMessage() - Method in class com.opensymphony.xwork2.validator.ValidatorConfig
getDefaultMessage() - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
getDefaultResultParam() - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig
getDefaultResultType() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
Returns the default result type for this package.
getDepth(String, Throwable) - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
Return the depth to the superclass matching.
getDescription() - Method in interface com.opensymphony.xwork2.util.location.Location
Get the description of this location
getDescription() - Method in class com.opensymphony.xwork2.util.location.LocationImpl
Get the description of this location
getDocument() - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
Return the newly built Document.
getDtdMappings() - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
Returns an unmodifiable map of DTD mappings
getElementClass(Class, String, Object) - Method in class com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer
Determines the element class by looking for the value of @Element annotation for the given class.
getElementClass(Class, String, Object) - Method in interface com.opensymphony.xwork2.conversion.ObjectTypeDeterminer
getElementClass(Class, String, Object) - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer
getElementClass() - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer
getErrorMessages() - Method in class com.opensymphony.xwork2.ActionSupport
Deprecated. Use ActionSupport.getActionErrors().
getErrors() - Method in class com.opensymphony.xwork2.ActionSupport
Deprecated. Use ActionSupport.getFieldErrors().
getException() - Method in class com.opensymphony.xwork2.interceptor.ExceptionHolder
Gets the holded exception
getExceptionClassName() - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig
getExceptionMappings() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig
getExceptionStack() - Method in class com.opensymphony.xwork2.interceptor.ExceptionHolder
Gets the holded exception stacktrace using Throwable.printStackTrace().
getExcludeMethodsSet() - Method in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
getExcludeParamsSet() - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
Gets a set of regular expressions of parameters to remove from the parameter map
getExcludes() - Method in class com.opensymphony.xwork2.interceptor.ChainingInterceptor
Gets list of parameter names to exclude
getExecuteResult() - Method in interface com.opensymphony.xwork2.ActionProxy
Gets the status of whether the ActionProxy is set to execute the Result after the Action is executed.
getExecuteResult() - Method in class com.opensymphony.xwork2.DefaultActionProxy
getExecuteResult() - Method in class com.opensymphony.xwork2.mock.MockActionProxy
getExpectedFoo() - Method in class com.opensymphony.xwork2.mock.MockInterceptor
getExpression() - Method in class com.opensymphony.xwork2.validator.validators.ConditionalVisitorFieldValidator
getExpression() - Method in class com.opensymphony.xwork2.validator.validators.ExpressionValidator
getExpression() - Method in class com.opensymphony.xwork2.validator.validators.FieldExpressionValidator
getExpression() - Method in class com.opensymphony.xwork2.validator.validators.RegexFieldValidator
getExprOverrides() - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
getExprOverrides() - Method in interface com.opensymphony.xwork2.util.ValueStack
Gets the override map if anyone exists.
getField(Class, String) - Method in class com.opensymphony.xwork2.ognl.OgnlReflectionProvider
getField(Class, String) - Method in interface com.opensymphony.xwork2.util.reflection.ReflectionProvider
getFieldErrors() - Method in class com.opensymphony.xwork2.ActionSupport
getFieldErrors() - Method in interface com.opensymphony.xwork2.ValidationAware
Get the field specific errors associated with this action.
getFieldErrors() - Method in class com.opensymphony.xwork2.ValidationAwareSupport
getFieldErrors() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
getFieldName() - Method in interface com.opensymphony.xwork2.validator.FieldValidator
Gets the field name to be validated
getFieldName() - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Sets the field name for this validator rule.
getFieldName() - Method in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription
Returns the field name to create the validation rule for.
getFieldName() - Method in interface com.opensymphony.xwork2.validator.metadata.ValidatorDescription
Returns the field name to create the validation rule for.
getFieldName() - Method in class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFields() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.ClassInfo
getFieldValue(String, Object) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
Return the field value named name from object, object should have the appropriate getter/setter.
getFoo() - Method in class com.opensymphony.xwork2.mock.MockInterceptor
getFullDefaultActionRef() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
gets the default action-ref name.
getFullDefaultInterceptorRef() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
gets the default interceptor-ref name.
getFullDefaultResultType() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
getFullDefaultResultType() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
Returns the default result type for this package.
getFullFieldName(String) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager.InternalValidatorContextWrapper
Get the full field name by consulting the parent, so that when we are using nested visitors ( visitor nested inside visitor etc.) we still get the full field name including its parents.
getFullFieldName(String) - Method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager.InternalValidatorContextWrapper
Get the full field name by consulting the parent, so that when we are using nested visitors ( visitor nested inside visitor etc.) we still get the full field name including its parents.
getFullFieldName(String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
getFullFieldName(String) - Method in interface com.opensymphony.xwork2.validator.ValidatorContext
Translates a simple field name into a full field name in OGNL syntax.
getFullFieldName(String) - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext
Translates a simple field name into a full field name in Ognl syntax
getFullFieldNameFromParent(String) - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext
getFullPropertyPath(Map<String, Object>) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
getFullQualifiedClassName() - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
Returns the fullQualifiedClassName attribute is used to create the special conversion.properties file name.
getGetMethod(Class, String) - Method in class com.opensymphony.xwork2.ognl.OgnlReflectionProvider
getGetMethod(Class, String) - Method in interface com.opensymphony.xwork2.util.reflection.ReflectionProvider
getGlobalExceptionMappingConfigs() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
gets the ExceptionMappingConfigs local to this package
getGlobalResultConfigs() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
gets the global ResultConfigs local to this package
getIncludeMethodsSet() - Method in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
getIncludes() - Method in class com.opensymphony.xwork2.interceptor.ChainingInterceptor
Gets list of parameter names to include
getInputResultName() - Method in interface com.opensymphony.xwork2.interceptor.ValidationWorkflowAware
getInstance(Class<T>) - Method in class com.opensymphony.xwork2.ActionContext
getInstance(Class<T>, String) - Method in interface com.opensymphony.xwork2.inject.Container
Gets an instance of the given dependency which was declared in ContainerBuilder.
getInstance(Class<T>) - Method in interface com.opensymphony.xwork2.inject.Container
Convenience method. Equivalent to getInstance(type, DEFAULT_NAME).
getInstance() - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionProviderFactory
getInstanceNames(Class<?>) - Method in interface com.opensymphony.xwork2.inject.Container
Gets a set of all registered names for the given type
getInterceptor() - Method in class com.opensymphony.xwork2.config.entities.InterceptorMapping
getInterceptorConfig(String) - Method in interface com.opensymphony.xwork2.config.entities.InterceptorLocator
Gets an interceptor configuration object.
getInterceptorConfig(String) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
getInterceptorConfig(String) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
getInterceptorConfigs() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
gets the InterceptorConfigs and InterceptorStackConfigs local to this package
getInterceptors() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig
getInterceptors() - Method in class com.opensymphony.xwork2.config.entities.InterceptorStackConfig
Returns a Collection of InterceptorMapping objects.
getInterfaces() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.ClassInfo
getInvocation() - Method in interface com.opensymphony.xwork2.ActionProxy
Gets the ActionInvocation associated with this ActionProxy.
getInvocation() - Method in class com.opensymphony.xwork2.DefaultActionProxy
getInvocation() - Method in class com.opensymphony.xwork2.mock.MockActionProxy
getInvocationContext() - Method in interface com.opensymphony.xwork2.ActionInvocation
Gets the ActionContext associated with this ActionInvocation.
getInvocationContext() - Method in class com.opensymphony.xwork2.DefaultActionInvocation
getInvocationContext() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation
getKeyClass(Class, String) - Method in class com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer
Determines the key class by looking for the value of @Key annotation for the given class.
getKeyClass(Class, String) - Method in interface com.opensymphony.xwork2.conversion.ObjectTypeDeterminer
getKeyClass(Class, String) - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer
getKeyClass() - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer
getKeyProperty(Class, String) - Method in class com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer
Determines the key property for a Collection by getting it from the @KeyProperty annotation.
getKeyProperty(Class, String) - Method in interface com.opensymphony.xwork2.conversion.ObjectTypeDeterminer
getKeyProperty(Class, String) - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer
getKeyProperty() - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer
getLastBeanClassAccessed(Map<String, Object>) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
getLastBeanPropertyAccessed(Map<String, Object>) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
getLastClassAccessed() - Method in class com.opensymphony.xwork2.ognl.ObjectProxy
getLastPropertyAccessed() - Method in class com.opensymphony.xwork2.ognl.ObjectProxy
getLine(Attributes) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the line number of an element (SAX flavor)
getLine(Element) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the line number of an element (DOM flavor)
getLineNumber() - Method in interface com.opensymphony.xwork2.util.location.Location
Get the line number of this location
getLineNumber() - Method in class com.opensymphony.xwork2.util.location.LocationImpl
Get the line number of this location
getLoadedFileNames() - Method in interface com.opensymphony.xwork2.config.Configuration
getLoadedFileNames() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
getLoadedFileNames() - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration
getLoadOrder(Document) - Static method in class com.opensymphony.xwork2.config.providers.XmlHelper
Return the value of the "order" attribute from the root element
getLocale() - Method in class com.opensymphony.xwork2.ActionContext
Gets the Locale of the current action.
getLocale() - Method in class com.opensymphony.xwork2.ActionSupport
getLocale() - Method in interface com.opensymphony.xwork2.LocaleProvider
Gets the provided locale.
getLocale() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
getLocation() - Method in interface com.opensymphony.xwork2.util.location.Locatable
Get the location of this object
getLocation() - Method in class com.opensymphony.xwork2.util.location.LocatableProperties
getLocation() - Method in class com.opensymphony.xwork2.util.location.Located
Get the location of this object
getLocation(Attributes, String) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the Location of an element (SAX flavor).
getLocation(Element, String) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the Location of an element (DOM flavor).
getLocation(Element) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Same as getLocation(elem, null).
getLocation(Object) - Static method in class com.opensymphony.xwork2.util.location.LocationUtils
Get the location of an object.
getLocation(Object, String) - Static method in class com.opensymphony.xwork2.util.location.LocationUtils
Get the location of an object.
getLocation(Object, String) - Method in interface com.opensymphony.xwork2.util.location.LocationUtils.LocationFinder
Get the location of an object
getLocation() - Method in exception com.opensymphony.xwork2.XWorkException
Gets the location of the error, if available
getLocationObject(Element) - Static method in class com.opensymphony.xwork2.util.DomHelper
getLocationString(Attributes) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the location of an element (SAX flavor).
getLocationString(Element) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the location of an element that has been processed by this pipe (DOM flavor).
getLogCategory() - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
getLogCategory() - Method in class com.opensymphony.xwork2.interceptor.TimerInterceptor
getLogger(Class<?>) - Static method in class com.opensymphony.xwork2.util.logging.LoggerFactory
getLogger(String) - Static method in class com.opensymphony.xwork2.util.logging.LoggerFactory
getLoggerFactory() - Static method in class com.opensymphony.xwork2.util.logging.LoggerFactory
getLoggerImpl(Class<?>) - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLoggerFactory
getLoggerImpl(String) - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLoggerFactory
getLoggerImpl(Class<?>) - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLoggerFactory
getLoggerImpl(String) - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLoggerFactory
getLoggerImpl(Class<?>) - Method in class com.opensymphony.xwork2.util.logging.LoggerFactory
getLoggerImpl(String) - Method in class com.opensymphony.xwork2.util.logging.LoggerFactory
getLoggerToUse() - Method in class com.opensymphony.xwork2.interceptor.TimerInterceptor
Get's the logger to use.
getLogLevel() - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
getLogLevel() - Method in class com.opensymphony.xwork2.interceptor.TimerInterceptor
getMax() - Method in class com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator
getMax() - Method in class com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator
getMax() - Method in class com.opensymphony.xwork2.validator.validators.LongRangeFieldValidator
getMax() - Method in class com.opensymphony.xwork2.validator.validators.ShortRangeFieldValidator
getMaxComparatorValue() - Method in class com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
getMaxComparatorValue() - Method in class com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator
getMaxComparatorValue() - Method in class com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator
getMaxComparatorValue() - Method in class com.opensymphony.xwork2.validator.validators.LongRangeFieldValidator
getMaxComparatorValue() - Method in class com.opensymphony.xwork2.validator.validators.ShortRangeFieldValidator
getMaxExclusive() - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator
getMaxInclusive() - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator
getMaxLength() - Method in class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator
getMember() - Method in interface com.opensymphony.xwork2.inject.Context
Gets the field, method or constructor which is being injected.
getMessage(Object) - Method in interface com.opensymphony.xwork2.validator.Validator
Gets the validation failure message for the given object
getMessage(Object) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
getMessageKey() - Method in interface com.opensymphony.xwork2.validator.Validator
Gets the resource bundle key used for lookup of validation failure message
getMessageKey() - Method in class com.opensymphony.xwork2.validator.ValidatorConfig
getMessageKey() - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
getMessageParameters() - Method in interface com.opensymphony.xwork2.validator.Validator
Gets the messsage parameters to be used when parsing i18n messages
getMessageParameters() - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
getMessageParams() - Method in class com.opensymphony.xwork2.validator.ValidatorConfig
getMethod() - Method in interface com.opensymphony.xwork2.ActionProxy
Gets the method name to execute, or null if no method has been specified (meaning execute will be invoked).
getMethod() - Method in class com.opensymphony.xwork2.DefaultActionProxy
getMethod() - Method in class com.opensymphony.xwork2.mock.MockActionProxy
getMethodName() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig
Returns name of the action method
getMethods() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.ClassInfo
getMin() - Method in class com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator
getMin() - Method in class com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator
getMin() - Method in class com.opensymphony.xwork2.validator.validators.LongRangeFieldValidator
getMin() - Method in class com.opensymphony.xwork2.validator.validators.ShortRangeFieldValidator
getMinComparatorValue() - Method in class com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
getMinComparatorValue() - Method in class com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator
getMinComparatorValue() - Method in class com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator
getMinComparatorValue() - Method in class com.opensymphony.xwork2.validator.validators.LongRangeFieldValidator
getMinComparatorValue() - Method in class com.opensymphony.xwork2.validator.validators.ShortRangeFieldValidator
getMinExclusive() - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator
getMinInclusive() - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator
getMinLength() - Method in class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator
getModel() - Method in interface com.opensymphony.xwork2.ModelDriven
Gets the model to be pushed onto the ValueStack instead of the Action itself.
getMultiTextvalueSeparator() - Method in class com.opensymphony.xwork2.validator.DefaultValidatorFileParser
getName() - Method in class com.opensymphony.xwork2.ActionContext
Gets the name of the current Action.
getName() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig
getName() - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig
getName() - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig
getName() - Method in class com.opensymphony.xwork2.config.entities.InterceptorMapping
getName() - Method in class com.opensymphony.xwork2.config.entities.InterceptorStackConfig
Get the name of this interceptor stack configuration.
getName() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
getName() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
getName() - Method in class com.opensymphony.xwork2.config.entities.ResultConfig
getName() - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig
getName() - Method in class com.opensymphony.xwork2.config.entities.UnknownHandlerConfig
getName() - Method in interface com.opensymphony.xwork2.inject.Context
Gets the name of the injection specified by Inject.value().
getName() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.AnnotationInfo
getName() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.ClassInfo
getName() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.FieldInfo
getName() - Method in interface com.opensymphony.xwork2.util.finder.ClassFinder.Info
getName() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.MethodInfo
getName() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.PackageInfo
getNamespace() - Method in interface com.opensymphony.xwork2.ActionProxy
Gets the namespace the ActionConfig for this ActionProxy is mapped to.
getNamespace() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
getNamespace() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
getNamespace() - Method in class com.opensymphony.xwork2.DefaultActionProxy
getNamespace() - Method in class com.opensymphony.xwork2.mock.MockActionProxy
getObjectFactory() - Static method in class com.opensymphony.xwork2.ObjectFactory
Deprecated. Since 2.1
getOrderedComparator() - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
Gets an instance of the comparator to use for the ordered sorting.
getOverrideExpr(ActionInvocation, Object) - Method in class com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor
getPackageConfig(String) - Method in interface com.opensymphony.xwork2.config.Configuration
getPackageConfig(String) - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
getPackageConfig(String) - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration
getPackageConfigNames() - Method in interface com.opensymphony.xwork2.config.Configuration
getPackageConfigNames() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
getPackageConfigNames() - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration
getPackageConfigs() - Method in interface com.opensymphony.xwork2.config.Configuration
getPackageConfigs() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
getPackageConfigs() - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration
getPackageName() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig
getPackageName() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.ClassInfo
getParameterAnnotations() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.MethodInfo
getParameterAnnotations(int) - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.MethodInfo
getParameters() - Method in class com.opensymphony.xwork2.ActionContext
Returns a Map of the HttpServletRequest parameters when in a servlet environment or a generic Map of parameters otherwise.
getParams() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig
getParams() - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig
getParams() - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig
getParams() - Method in interface com.opensymphony.xwork2.config.entities.Parameterizable
getParams() - Method in class com.opensymphony.xwork2.config.entities.ResultConfig
getParams() - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig
getParams(Element) - Static method in class com.opensymphony.xwork2.config.providers.XmlHelper
This method will find all the parameters under this paramsElement and return them as Map.
getParams() - Method in class com.opensymphony.xwork2.validator.ValidatorConfig
getParent() - Method in interface com.opensymphony.xwork2.util.finder.ClassLoaderInterface
getParent() - Method in class com.opensymphony.xwork2.util.finder.ClassLoaderInterfaceDelegate
getParent() - Method in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean
getParents() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
getParse() - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
getPattern() - Method in class com.opensymphony.xwork2.config.impl.NamespaceMatch
getPattern() - Method in class com.opensymphony.xwork2.util.ClassPathFinder
retrieves the pattern in use
getPattern() - Method in class com.opensymphony.xwork2.util.NamedVariablePatternMatcher.CompiledPattern
getPrefixedMethod(String[], String, Object) - Static method in class com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil
This method returns a Method in action.
getPrintable(long) - Method in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean
Get a formatted string representing all the methods that took longer than a specified time.
getPrintable(String, long) - Method in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean
getProfiledObject(Class, Object) - Static method in class com.opensymphony.xwork2.util.profiling.ObjectProfiler
Given a class, and an interface that it implements, return a proxied version of the class that implements the interface.
getProperty(Map, Object, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.CompoundRootAccessor
getProperty(Map, Object, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.ObjectAccessor
getProperty(Map, Object, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.ObjectProxyPropertyAccessor
getProperty(Map, Object, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkCollectionPropertyAccessor
Gets the property of a Collection by indexing the collection based on a key property.
getProperty(Map, Object, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkListPropertyAccessor
getProperty(Map, Object, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkMapPropertyAccessor
getProperty(Map, Object, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkObjectPropertyAccessor
getPropertyDescriptor(Class, String) - Method in class com.opensymphony.xwork2.ognl.OgnlReflectionProvider
getPropertyDescriptor(Class, String) - Method in interface com.opensymphony.xwork2.util.reflection.ReflectionProvider
This method returns a PropertyDescriptor for the given class and property name using a Map lookup (using getPropertyDescriptorsMap()).
getPropertyDescriptors(Object) - Method in class com.opensymphony.xwork2.ognl.OgnlReflectionProvider
getPropertyDescriptors(Object) - Method in class com.opensymphony.xwork2.ognl.OgnlUtil
Get's the java beans property descriptors for the given source.
getPropertyDescriptors(Class) - Method in class com.opensymphony.xwork2.ognl.OgnlUtil
Get's the java beans property descriptors for the given class.
getPropertyDescriptors(Object) - Method in interface com.opensymphony.xwork2.util.reflection.ReflectionProvider
Get's the java beans property descriptors for the given source.
getPropertyLocation(String) - Method in class com.opensymphony.xwork2.util.location.LocatableProperties
getPropertyName() - Method in class com.opensymphony.xwork2.util.PropertiesReader
Returns the name of the last read property.
getPropertyThroughIteration(Map, Collection, String, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkCollectionPropertyAccessor
getPropertyValue() - Method in class com.opensymphony.xwork2.util.PropertiesReader
Returns the value of the last read property.
getProxy() - Method in class com.opensymphony.xwork2.ActionChainResult
getProxy() - Method in interface com.opensymphony.xwork2.ActionInvocation
Get the ActionProxy holding this ActionInvocation.
getProxy() - Method in class com.opensymphony.xwork2.DefaultActionInvocation
getProxy() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation
getPutStrategy() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
getRealTarget(String, Map<String, Object>, Object) - Method in class com.opensymphony.xwork2.ognl.OgnlReflectionProvider
getRealTarget(String, Map<String, Object>, Object) - Method in class com.opensymphony.xwork2.ognl.OgnlUtil
Looks for the real target with the specified property given a root Object which may be a CompoundRoot.
getRealTarget(String, Map<String, Object>, Object) - Method in interface com.opensymphony.xwork2.util.reflection.ReflectionProvider
Looks for the real target with the specified property given a root Object which may be a CompoundRoot.
getRepopulateField() - Method in class com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport
getResource(String) - Method in class com.opensymphony.xwork2.util.classloader.ReloadingClassLoader
getResource(String, Class) - Static method in class com.opensymphony.xwork2.util.ClassLoaderUtil
Load a given resource.
getResource(String) - Method in interface com.opensymphony.xwork2.util.finder.ClassLoaderInterface
getResource(String) - Method in class com.opensymphony.xwork2.util.finder.ClassLoaderInterfaceDelegate
getResource() - Method in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean
getResourceAsStream(String) - Method in class com.opensymphony.xwork2.util.classloader.ReloadingClassLoader
getResourceAsStream(String, Class) - Static method in class com.opensymphony.xwork2.util.ClassLoaderUtil
This is a convenience method to load a resource as a stream.
getResourceAsStream(String) - Method in interface com.opensymphony.xwork2.util.finder.ClassLoaderInterface
getResourceAsStream(String) - Method in class com.opensymphony.xwork2.util.finder.ClassLoaderInterfaceDelegate
getResources(String, Class, boolean) - Static method in class com.opensymphony.xwork2.util.ClassLoaderUtil
Load all resources with a given name, potentially aggregating all results from the searched classloaders.
getResources(String) - Method in interface com.opensymphony.xwork2.util.finder.ClassLoaderInterface
getResources(String) - Method in class com.opensymphony.xwork2.util.finder.ClassLoaderInterfaceDelegate
getResources() - Method in class com.opensymphony.xwork2.util.ResolverUtil
getResourcesMap(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
getResourcesNotLoaded() - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Returns a list of resources that could not be loaded in the last invoked findAvailable* or mapAvailable* methods.
getResult() - Method in interface com.opensymphony.xwork2.ActionInvocation
If the ActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned.
getResult() - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig
getResult() - Method in class com.opensymphony.xwork2.DefaultActionInvocation
If the DefaultActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned.
getResult() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation
getResultCode() - Method in interface com.opensymphony.xwork2.ActionInvocation
Gets the result code returned from this ActionInvocation.
getResultCode() - Method in class com.opensymphony.xwork2.DefaultActionInvocation
getResultCode() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation
getResults() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig
getResultType(String) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
getResultTypeConfigs() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
gets the ResultTypeConfigs local to this package
getReturnType() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.MethodInfo
getRoot() - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
getRoot() - Method in interface com.opensymphony.xwork2.util.ValueStack
Get the CompoundRoot which holds the objects pushed onto the stack
getRuntimeConfiguration() - Method in interface com.opensymphony.xwork2.config.Configuration
The current runtime configuration.
getRuntimeConfiguration() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
getRuntimeConfiguration() - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration
getScopeKey() - Method in interface com.opensymphony.xwork2.interceptor.ScopedModelDriven
Gets the key under which the model is stored
getScopeStrategy() - Method in interface com.opensymphony.xwork2.inject.Context
Gets the current scope strategy.
getSession() - Method in class com.opensymphony.xwork2.ActionContext
Gets the Map of HttpSession values when in a servlet environment or a generic session map otherwise.
getSetMap(Map<String, Object>, String) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
getSetMethod(Class, String) - Method in class com.opensymphony.xwork2.ognl.OgnlReflectionProvider
getSetMethod(Class, String) - Method in interface com.opensymphony.xwork2.util.reflection.ReflectionProvider
getSnippet(int) - Method in interface com.opensymphony.xwork2.util.location.Location
Gets a source code snippet with the default padding
getSnippet(int) - Method in class com.opensymphony.xwork2.util.location.LocationImpl
Gets a source code snippet with the default padding
getSourceAccessor(OgnlContext, Object, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.CompoundRootAccessor
Used by OGNl to generate bytecode
getSourceAccessor(OgnlContext, Object, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.ObjectProxyPropertyAccessor
Used by OGNl to generate bytecode
getSourceSetter(OgnlContext, Object, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.CompoundRootAccessor
Used by OGNl to generate bytecode
getSourceSetter(OgnlContext, Object, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.ObjectProxyPropertyAccessor
Used by OGNl to generate bytecode
getStack() - Method in interface com.opensymphony.xwork2.ActionInvocation
Gets the ValueStack associated with this ActionInvocation.
getStack() - Method in class com.opensymphony.xwork2.DefaultActionInvocation
getStack() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation
getSuperInterfaces() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.ClassInfo
getSuperType() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.ClassInfo
getTarget() - Method in class com.opensymphony.xwork2.ognl.OgnlTypeConverterWrapper
getText(String) - Method in class com.opensymphony.xwork2.ActionSupport
getText(String, String) - Method in class com.opensymphony.xwork2.ActionSupport
getText(String, String, String) - Method in class com.opensymphony.xwork2.ActionSupport
getText(String, List<Object>) - Method in class com.opensymphony.xwork2.ActionSupport
getText(String, String[]) - Method in class com.opensymphony.xwork2.ActionSupport
getText(String, String, List<Object>) - Method in class com.opensymphony.xwork2.ActionSupport
getText(String, String, String[]) - Method in class com.opensymphony.xwork2.ActionSupport
getText(String, String, List<Object>, ValueStack) - Method in class com.opensymphony.xwork2.ActionSupport
getText(String, String, String[], ValueStack) - Method in class com.opensymphony.xwork2.ActionSupport
getText(String) - Method in class com.opensymphony.xwork2.CompositeTextProvider
It will consult each TextProviders and return the first valid message for this key
getText(String, String) - Method in class com.opensymphony.xwork2.CompositeTextProvider
It will consult each TextProviders and return the first valid message for this key before returning defaultValue if every else fails.
getText(String, String, String) - Method in class com.opensymphony.xwork2.CompositeTextProvider
It will consult each TextProviders and return the first valid message for this key, before returining defaultValue if every else fails.
getText(String, List<Object>) - Method in class com.opensymphony.xwork2.CompositeTextProvider
It will consult each TextProviders and return the first valid message for this key.
getText(String, String[]) - Method in class com.opensymphony.xwork2.CompositeTextProvider
It will consult each TextProviders and return the first valid message for this key.
getText(String, String, List<Object>) - Method in class com.opensymphony.xwork2.CompositeTextProvider
It will consult each TextProviders and return the first valid message for this key, before returining defaultValue
getText(String, String, String[]) - Method in class com.opensymphony.xwork2.CompositeTextProvider
It will consult each TextProviders and return the first valid message for this key, before returining defaultValue.
getText(String, String, List<Object>, ValueStack) - Method in class com.opensymphony.xwork2.CompositeTextProvider
It will consult each TextProviders and return the first valid message for this key, before returining defaultValue
getText(String, String, String[], ValueStack) - Method in class com.opensymphony.xwork2.CompositeTextProvider
It will consult each TextProviders and return the first valid message for this key, before returining defaultValue
getText(String) - Method in class com.opensymphony.xwork2.DefaultTextProvider
getText(String, String) - Method in class com.opensymphony.xwork2.DefaultTextProvider
getText(String, List<Object>) - Method in class com.opensymphony.xwork2.DefaultTextProvider
getText(String, String[]) - Method in class com.opensymphony.xwork2.DefaultTextProvider
getText(String, String, List<Object>) - Method in class com.opensymphony.xwork2.DefaultTextProvider
getText(String, String, String[]) - Method in class com.opensymphony.xwork2.DefaultTextProvider
getText(String, String, String) - Method in class com.opensymphony.xwork2.DefaultTextProvider
getText(String, String, List<Object>, ValueStack) - Method in class com.opensymphony.xwork2.DefaultTextProvider
getText(String, String, String[], ValueStack) - Method in class com.opensymphony.xwork2.DefaultTextProvider
getText(String) - Method in interface com.opensymphony.xwork2.TextProvider
Gets a message based on a message key, or null if no message is found.
getText(String, String) - Method in interface com.opensymphony.xwork2.TextProvider
Gets a message based on a key, or, if the message is not found, a supplied default value is returned.
getText(String, String, String) - Method in interface com.opensymphony.xwork2.TextProvider
Gets a message based on a key using the supplied obj, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
getText(String, List<Object>) - Method in interface com.opensymphony.xwork2.TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
getText(String, String[]) - Method in interface com.opensymphony.xwork2.TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
getText(String, String, List<Object>) - Method in interface com.opensymphony.xwork2.TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
getText(String, String, String[]) - Method in interface com.opensymphony.xwork2.TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
getText(String, String, List<Object>, ValueStack) - Method in interface com.opensymphony.xwork2.TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
getText(String, String, String[], ValueStack) - Method in interface com.opensymphony.xwork2.TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
getText(String) - Method in class com.opensymphony.xwork2.TextProviderSupport
Get a text from the resource bundles associated with this action.
getText(String, String) - Method in class com.opensymphony.xwork2.TextProviderSupport
Get a text from the resource bundles associated with this action.
getText(String, String, String) - Method in class com.opensymphony.xwork2.TextProviderSupport
Get a text from the resource bundles associated with this action.
getText(String, List<Object>) - Method in class com.opensymphony.xwork2.TextProviderSupport
Get a text from the resource bundles associated with this action.
getText(String, String[]) - Method in class com.opensymphony.xwork2.TextProviderSupport
Get a text from the resource bundles associated with this action.
getText(String, String, List<Object>) - Method in class com.opensymphony.xwork2.TextProviderSupport
Get a text from the resource bundles associated with this action.
getText(String, String, String[]) - Method in class com.opensymphony.xwork2.TextProviderSupport
Get a text from the resource bundles associated with this action.
getText(String, String, List<Object>, ValueStack) - Method in class com.opensymphony.xwork2.TextProviderSupport
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
getText(String, String, String[], ValueStack) - Method in class com.opensymphony.xwork2.TextProviderSupport
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
getText(String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
getText(String, String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
getText(String, String, String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
getText(String, List<Object>) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
getText(String, String[]) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
getText(String, String, List<Object>) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
getText(String, String, String[]) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
getText(String, String, List<Object>, ValueStack) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
getText(String, String, String[], ValueStack) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
getTextProvider() - Method in class com.opensymphony.xwork2.TextProviderFactory
getTextProvider() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
getTexts() - Method in class com.opensymphony.xwork2.ActionSupport
getTexts(String) - Method in class com.opensymphony.xwork2.ActionSupport
getTexts(String) - Method in class com.opensymphony.xwork2.CompositeTextProvider
It will consult each TextProviders and return the first non-null ResourceBundle.
getTexts() - Method in class com.opensymphony.xwork2.CompositeTextProvider
It will consult each TextProviders and return the first non-null ResourceBundle.
getTexts(String) - Method in class com.opensymphony.xwork2.DefaultTextProvider
getTexts() - Method in class com.opensymphony.xwork2.DefaultTextProvider
getTexts(String) - Method in interface com.opensymphony.xwork2.TextProvider
Get the named bundle, such as "com/acme/Foo".
getTexts() - Method in interface com.opensymphony.xwork2.TextProvider
Get the resource bundle associated with the implementing class (usually an action).
getTexts(String) - Method in class com.opensymphony.xwork2.TextProviderSupport
Get the named bundle.
getTexts() - Method in class com.opensymphony.xwork2.TextProviderSupport
Get the resource bundle associated with this action.
getTexts(String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
getTexts() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
getTextValue(Element) - Method in class com.opensymphony.xwork2.validator.DefaultValidatorFileParser
Extract trimmed text value from the given DOM element, ignoring XML comments.
getThrowable() - Method in exception com.opensymphony.xwork2.XWorkException
Deprecated. Use Throwable.getCause()
getTrim() - Method in class com.opensymphony.xwork2.validator.validators.RequiredStringValidator
getTrim() - Method in class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator
getTrimmedClassName(Method) - Static method in class com.opensymphony.xwork2.util.profiling.ObjectProfiler
Given a method, get the Method name, with no package information.
getType() - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
getType() - Method in interface com.opensymphony.xwork2.inject.Context
Gets the type of the field or parameter which is being injected.
getType() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.FieldInfo
getType() - Method in class com.opensymphony.xwork2.validator.ValidatorConfig
getTypeConverter(Map<String, Object>) - Method in class com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
getUnknownHandlers() - Method in class com.opensymphony.xwork2.DefaultUnknownHandlerManager
getUnknownHandlers() - Method in interface com.opensymphony.xwork2.UnknownHandlerManager
getUnknownHandlerStack() - Method in interface com.opensymphony.xwork2.config.Configuration
getUnknownHandlerStack() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
getUnknownHandlerStack() - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration
getURI() - Method in interface com.opensymphony.xwork2.util.location.Location
Get the URI of this location
getURI(Attributes) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the URI of an element (SAX flavor)
getURI(Element) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the URI of an element (DOM flavor)
getURI() - Method in class com.opensymphony.xwork2.util.location.LocationImpl
Get the URI of this location
getUrls() - Method in class com.opensymphony.xwork2.util.finder.UrlSet
getValidationAware() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
getValidator(ValidatorConfig) - Method in class com.opensymphony.xwork2.validator.DefaultValidatorFactory
getValidator(ValidatorConfig) - Method in interface com.opensymphony.xwork2.validator.ValidatorFactory
Get a Validator that matches the given configuration.
getValidatorContext() - Method in interface com.opensymphony.xwork2.validator.Validator
Gets the validation context used
getValidatorContext() - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
getValidators(Class, String, String) - Method in interface com.opensymphony.xwork2.validator.ActionValidatorManager
Returns a list of validators for the given class, context, and method.
getValidators(Class, String) - Method in interface com.opensymphony.xwork2.validator.ActionValidatorManager
Returns a list of validators for the given class and context.
getValidators(Class, String) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
getValidators(Class, String, String) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
getValidators(Class, String) - Method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
getValidators(Class, String, String) - Method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
getValidatorType() - Method in interface com.opensymphony.xwork2.validator.Validator
Gets the vaildator type used (see class javadoc).
getValidatorType() - Method in class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getValidatorType() - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
getValue() - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
getValue() - Method in class com.opensymphony.xwork2.ognl.ObjectProxy
getValue(String, Map<String, Object>, Object) - Method in class com.opensymphony.xwork2.ognl.OgnlReflectionProvider
getValue(String, Map<String, Object>, Object) - Method in class com.opensymphony.xwork2.ognl.OgnlUtil
getValue(String, Map<String, Object>, Object, Class) - Method in class com.opensymphony.xwork2.ognl.OgnlUtil
getValue(String, Map<String, Object>, Object) - Method in interface com.opensymphony.xwork2.util.reflection.ReflectionProvider
Evaluates the given OGNL expression to extract a value from the given root object in a given context
getValueStack() - Method in class com.opensymphony.xwork2.ActionContext
Gets the OGNL value stack.
getVariableNames() - Method in class com.opensymphony.xwork2.util.NamedVariablePatternMatcher.CompiledPattern
getVariables() - Method in class com.opensymphony.xwork2.config.impl.NamespaceMatch
guessResultType(String) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

H

handle(ReflectionException) - Method in interface com.opensymphony.xwork2.util.reflection.ReflectionExceptionHandler
Handles a reflection exception
handleConversionException(Map<String, Object>, String, Object, Object) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
handleException(Throwable, ValueStack) - Method in interface com.opensymphony.xwork2.ActionEventListener
Called when an exception is thrown by the action
handleLogging(Exception) - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
Handles the logging of the exception.
handleUnknownAction(String, String) - Method in class com.opensymphony.xwork2.DefaultUnknownHandlerManager
Iterate over UnknownHandlers and return the result of the first one that can handle it
handleUnknownAction(String, String) - Method in interface com.opensymphony.xwork2.UnknownHandler
Handles the case when an action configuration is unknown.
handleUnknownAction(String, String) - Method in interface com.opensymphony.xwork2.UnknownHandlerManager
handleUnknownActionMethod(Object, String) - Method in interface com.opensymphony.xwork2.UnknownHandler
Handles the case when an action method cannot be found.
handleUnknownMethod(Object, String) - Method in class com.opensymphony.xwork2.DefaultUnknownHandlerManager
Iterate over UnknownHandlers and return the result of the first one that can handle it
handleUnknownMethod(Object, String) - Method in interface com.opensymphony.xwork2.UnknownHandlerManager
handleUnknownResult(ActionContext, String, ActionConfig, String) - Method in class com.opensymphony.xwork2.DefaultUnknownHandlerManager
Iterate over UnknownHandlers and return the result of the first one that can handle it
handleUnknownResult(ActionContext, String, ActionConfig, String) - Method in interface com.opensymphony.xwork2.UnknownHandler
Handles the case when a result cannot be found for an action and result code.
handleUnknownResult(ActionContext, String, ActionConfig, String) - Method in interface com.opensymphony.xwork2.UnknownHandlerManager
hasActionErrors() - Method in class com.opensymphony.xwork2.ActionSupport
hasActionErrors() - Method in interface com.opensymphony.xwork2.ValidationAware
Check whether there are any Action-level error messages.
hasActionErrors() - Method in class com.opensymphony.xwork2.ValidationAwareSupport
hasActionErrors() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
hasActionMessages() - Method in class com.opensymphony.xwork2.ActionSupport
hasActionMessages() - Method in interface com.opensymphony.xwork2.ValidationAware
Checks whether there are any Action-level messages.
hasActionMessages() - Method in class com.opensymphony.xwork2.ValidationAwareSupport
hasActionMessages() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
hasErrors() - Method in class com.opensymphony.xwork2.ActionSupport
hasErrors() - Method in interface com.opensymphony.xwork2.ValidationAware
Checks whether there are any action errors or field errors.
hasErrors() - Method in class com.opensymphony.xwork2.ValidationAwareSupport
hasErrors() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
hasFieldErrors() - Method in class com.opensymphony.xwork2.ActionSupport
hasFieldErrors() - Method in interface com.opensymphony.xwork2.ValidationAware
Check whether there are any field errors associated with this action.
hasFieldErrors() - Method in class com.opensymphony.xwork2.ValidationAwareSupport
hasFieldErrors() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
hashCode() - Method in class com.opensymphony.xwork2.ActionChainResult
hashCode() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig
hashCode() - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig
hashCode() - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig
hashCode() - Method in class com.opensymphony.xwork2.config.entities.InterceptorMapping
hashCode() - Method in class com.opensymphony.xwork2.config.entities.InterceptorStackConfig
Generate hashcode based on InterceptorStackConfig's name and its InterceptorMappings.
hashCode() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
hashCode() - Method in class com.opensymphony.xwork2.config.entities.ResultConfig
hashCode() - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig
hashCode() - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
hashCode() - Method in class com.opensymphony.xwork2.mock.MockInterceptor
hashCode() - Method in class com.opensymphony.xwork2.mock.MockResult
hashCode() - Method in class com.opensymphony.xwork2.util.location.LocationImpl
hasKey(String) - Method in class com.opensymphony.xwork2.ActionSupport
hasKey(String) - Method in class com.opensymphony.xwork2.CompositeTextProvider
hasKey(String) - Method in class com.opensymphony.xwork2.DefaultTextProvider
hasKey(String) - Method in interface com.opensymphony.xwork2.TextProvider
Checks if a message key exists.
hasKey(String) - Method in class com.opensymphony.xwork2.TextProviderSupport
Checks if a key is available in the resource bundles associated with this action.
hasKey(String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
hasUnknownHandlers() - Method in class com.opensymphony.xwork2.DefaultUnknownHandlerManager
hasUnknownHandlers() - Method in interface com.opensymphony.xwork2.UnknownHandlerManager

I

I18nInterceptor - Class in com.opensymphony.xwork2.interceptor
An interceptor that handles setting the locale specified in a session as the locale for the current action request.
I18nInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.I18nInterceptor
ignorableWhitespace(char[], int, int) - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
ignorableWhitespace(char[], int, int) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler
ignorableWhitespace(char[], int, int) - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe
include(UrlSet) - Method in class com.opensymphony.xwork2.util.finder.UrlSet
includeClassesUrl(ClassLoaderInterface) - Method in class com.opensymphony.xwork2.util.finder.UrlSet
Try to find a classes directory inside a war file add its normalized url to this set
includeMethods - Variable in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
includes - Variable in class com.opensymphony.xwork2.interceptor.ChainingInterceptor
indexOfArray(int[], int, int, char[], int) - Method in class com.opensymphony.xwork2.util.WildcardHelper
Get the offset of a part of an int array within a char array.
info(String, String...) - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLogger
info(String, Throwable, String...) - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLogger
info(String, String...) - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLogger
info(String, Throwable, String...) - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLogger
info(String, String...) - Method in interface com.opensymphony.xwork2.util.logging.Logger
info(String, Throwable, String...) - Method in interface com.opensymphony.xwork2.util.logging.Logger
init(ActionProxy) - Method in interface com.opensymphony.xwork2.ActionInvocation
init(Configuration) - Method in interface com.opensymphony.xwork2.config.ContainerProvider
Initializes with the configuration
init(Configuration) - Method in interface com.opensymphony.xwork2.config.PackageProvider
Initializes with the configuration
init(Configuration) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
init(Configuration) - Method in class com.opensymphony.xwork2.config.providers.XWorkConfigurationProvider
init(ActionProxy) - Method in class com.opensymphony.xwork2.DefaultActionInvocation
init() - Method in class com.opensymphony.xwork2.interceptor.AbstractInterceptor
Does nothing
init() - Method in class com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor
init() - Method in interface com.opensymphony.xwork2.interceptor.Interceptor
Called after an interceptor is created, but before any requests are processed using intercept , giving the Interceptor a chance to initialize any needed resources.
init(ActionProxy) - Method in class com.opensymphony.xwork2.mock.MockActionInvocation
init() - Method in class com.opensymphony.xwork2.mock.MockInterceptor
Called after an Interceptor is created, but before any requests are processed using the intercept() methodName.
init(Configuration) - Method in class com.opensymphony.xwork2.test.StubConfigurationProvider
initObjectFactory() - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
Deprecated. Since 2.1 as it isn't necessary
inject(Object) - Method in interface com.opensymphony.xwork2.inject.Container
Injects dependencies into the fields and methods of an existing object.
inject(Class<T>) - Method in interface com.opensymphony.xwork2.inject.Container
Creates and injects a new instance of type implementation.
Inject - Annotation Type in com.opensymphony.xwork2.inject
Annotates members and parameters which should have their value[s] injected.
injectInternalBeans(Object) - Method in class com.opensymphony.xwork2.ObjectFactory
injectStatics(Class<?>...) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Upon creation, the Container will inject static fields and methods into the given classes.
INPUT - Static variable in interface com.opensymphony.xwork2.Action
The action execution require more input in order to succeed.
input() - Method in class com.opensymphony.xwork2.ActionSupport
InputConfig - Annotation Type in com.opensymphony.xwork2.interceptor.annotations
Marks a action method that if it's not validated by ValidationInterceptor then execute input method or input result.
InstantiatingNullHandler - Class in com.opensymphony.xwork2.conversion.impl
Provided that the key ReflectionContextState.CREATE_NULL_OBJECTS is in the action context with a value of true (this key is set only during the execution of the ParametersInterceptor), OGNL expressions that have caused a NullPointerException will be temporarily stopped for evaluation while the system automatically tries to solve the null references by automatically creating the object.
InstantiatingNullHandler() - Constructor for class com.opensymphony.xwork2.conversion.impl.InstantiatingNullHandler
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.AbstractInterceptor
Override to handle interception
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.AliasInterceptor
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.annotations.AnnotationParameterFilterIntereptor
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor
Discovers annotated methods on the action and calls them according to the workflow
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.ChainingInterceptor
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.I18nInterceptor
intercept(ActionInvocation) - Method in interface com.opensymphony.xwork2.interceptor.Interceptor
Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the ActionInvocation or to short-circuit the processing and just return a String return code.
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.LoggingInterceptor
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor
Decide if the parameter should be removed from the parameter map based on paramNames and paramValues.
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.StaticParametersInterceptor
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.TimerInterceptor
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.mock.MockInterceptor
Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the DefaultActionInvocation or to short-circuit the processing and just return a String return code.
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor
Looks for the ApplicationContext under the attribute that the Spring listener sets in the servlet context.
Interceptor - Interface in com.opensymphony.xwork2.interceptor

An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.

InterceptorBuilder - Class in com.opensymphony.xwork2.config.providers
Builds a list of interceptors referenced by the refName in the supplied PackageConfig.
InterceptorBuilder() - Constructor for class com.opensymphony.xwork2.config.providers.InterceptorBuilder
InterceptorConfig - Class in com.opensymphony.xwork2.config.entities
Configuration for Interceptors.
InterceptorConfig(String, String) - Constructor for class com.opensymphony.xwork2.config.entities.InterceptorConfig
InterceptorConfig(InterceptorConfig) - Constructor for class com.opensymphony.xwork2.config.entities.InterceptorConfig
InterceptorConfig.Builder - Class in com.opensymphony.xwork2.config.entities
The builder for this object.
InterceptorConfig.Builder(String, String) - Constructor for class com.opensymphony.xwork2.config.entities.InterceptorConfig.Builder
InterceptorConfig.Builder(InterceptorConfig) - Constructor for class com.opensymphony.xwork2.config.entities.InterceptorConfig.Builder
InterceptorListHolder - Interface in com.opensymphony.xwork2.config.entities
InterceptorListHolder
InterceptorLocator - Interface in com.opensymphony.xwork2.config.entities
Defines an object that can be used to retrieve interceptor configuration
InterceptorMapping - Class in com.opensymphony.xwork2.config.entities
InterceptorMapping
InterceptorMapping(String, Interceptor) - Constructor for class com.opensymphony.xwork2.config.entities.InterceptorMapping
interceptors(List<InterceptorMapping>) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
interceptors - Variable in class com.opensymphony.xwork2.config.entities.ActionConfig
interceptors - Variable in class com.opensymphony.xwork2.DefaultActionInvocation
InterceptorStackConfig - Class in com.opensymphony.xwork2.config.entities
Configuration for InterceptorStack.
InterceptorStackConfig() - Constructor for class com.opensymphony.xwork2.config.entities.InterceptorStackConfig
Creates an InterceptorStackConfig object.
InterceptorStackConfig(InterceptorStackConfig) - Constructor for class com.opensymphony.xwork2.config.entities.InterceptorStackConfig
Creates an InterceptorStackConfig object with a particular name.
InterceptorStackConfig.Builder - Class in com.opensymphony.xwork2.config.entities
The builder for this object.
InterceptorStackConfig.Builder(String) - Constructor for class com.opensymphony.xwork2.config.entities.InterceptorStackConfig.Builder
IntRangeFieldValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator checks that a numeric field has a value within a specified range.
IntRangeFieldValidator - Class in com.opensymphony.xwork2.validator.validators
Field Validator that checks if the integer specified is within a certain range.
IntRangeFieldValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator
IntRangeFieldValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
IntRangeFieldValidatorDescription
IntRangeFieldValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription
IntRangeFieldValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.
InvalidMetadataException - Exception in com.opensymphony.xwork2
InvalidMetadataException
InvalidMetadataException(String) - Constructor for exception com.opensymphony.xwork2.InvalidMetadataException
Create a new InvalidMetadataException with the supplied error message.
invocation - Variable in class com.opensymphony.xwork2.DefaultActionProxy
invocationContext - Variable in class com.opensymphony.xwork2.DefaultActionInvocation
invoke() - Method in interface com.opensymphony.xwork2.ActionInvocation
Invokes the next step in processing this ActionInvocation.
invoke() - Method in class com.opensymphony.xwork2.DefaultActionInvocation
invoke() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation
invokeAction(Object, ActionConfig) - Method in class com.opensymphony.xwork2.DefaultActionInvocation
invokeActionOnly() - Method in interface com.opensymphony.xwork2.ActionInvocation
Invokes only the Action (not Interceptors or Results).
invokeActionOnly() - Method in class com.opensymphony.xwork2.DefaultActionInvocation
invokeActionOnly() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation
invokePrefixMethod(ActionInvocation, String[]) - Static method in class com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil
This method will prefix actionInvocation's ActionProxy's method with prefixes before invoking the prefixed method.
invokeUnderTiming(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.TimerInterceptor
Is called to invoke the action invocation and time the execution time.
isAbstract(boolean) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
isAbstract() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
isAcceptableProperty(String) - Method in class com.opensymphony.xwork2.ognl.SecurityMemberAccess
isAccepted(String) - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
isAccepted(String) - Method in class com.opensymphony.xwork2.ognl.SecurityMemberAccess
isAccepted(String) - Method in class com.opensymphony.xwork2.util.classloader.ReloadingClassLoader
isAccessible(Map, Object, Member, String) - Method in class com.opensymphony.xwork2.ognl.SecurityMemberAccess
isActive() - Static method in class com.opensymphony.xwork2.util.profiling.UtilTimerStack
Determine if profiling is being activated, by searching for a system property 'xwork.profile.activate', default to false (profiling is off).
isAllowedMethod(String) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig
isAnnotatedBy(AnnotatedElement, Class<? extends Annotation>...) - Static method in class com.opensymphony.xwork2.util.AnnotationUtils
Varargs version of AnnotatedElement.isAnnotationPresent()
isAnnotationPresent(Class<? extends Annotation>) - Method in class com.opensymphony.xwork2.util.finder.ClassFinder
isAppendPrefix() - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator
Flags whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs.
isCaseSensitive() - Method in class com.opensymphony.xwork2.validator.validators.RegexFieldValidator
isCreatingNullObjects(Map<String, Object>) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
isDebugEnabled() - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLogger
isDebugEnabled() - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLogger
isDebugEnabled() - Method in interface com.opensymphony.xwork2.util.logging.Logger
isDefaultBlock() - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor
isDenyMethodExecution(Map<String, Object>) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
isEmpty() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
isEmpty(Object[]) - Static method in class com.opensymphony.xwork2.util.ArrayUtils
isErrorEnabled() - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLogger
isErrorEnabled() - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLogger
isErrorEnabled() - Method in interface com.opensymphony.xwork2.util.logging.Logger
isExcluded(String) - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
isExcluded(String) - Method in class com.opensymphony.xwork2.ognl.SecurityMemberAccess
isExecuted() - Method in interface com.opensymphony.xwork2.ActionInvocation
Gets whether this ActionInvocation has executed before.
isExecuted() - Method in class com.opensymphony.xwork2.DefaultActionInvocation
isExecuted() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation
isExecuted() - Method in class com.opensymphony.xwork2.mock.MockInterceptor
isExecutedCalled() - Method in class com.opensymphony.xwork2.mock.MockActionProxy
isFatalEnabled() - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLogger
isFatalEnabled() - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLogger
isFatalEnabled() - Method in interface com.opensymphony.xwork2.util.logging.Logger
isGettingByKeyProperty(Map<String, Object>) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
isInfoEnabled() - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLogger
isInfoEnabled() - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLogger
isInfoEnabled() - Method in interface com.opensymphony.xwork2.util.logging.Logger
isInRange(Number, String, Class) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkBasicConverter
isIntegerType(Class) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkBasicConverter
isJarURL(URL) - Static method in class com.opensymphony.xwork2.util.URLUtil
Check if given URL is matching Jar pattern for different servers
isJBoss5Url(URL) - Static method in class com.opensymphony.xwork2.util.URLUtil
Check if given URL is pointing to JBoss 5 VFS resource
isKnown(Location) - Static method in class com.opensymphony.xwork2.util.location.LocationUtils
Checks if a location is known, i.e.
isLiteral(String) - Method in class com.opensymphony.xwork2.util.NamedVariablePatternMatcher
isLiteral(String) - Method in interface com.opensymphony.xwork2.util.PatternMatcher
Determines if the pattern is a simple literal string or contains wildcards that will need to be processed
isLiteral(String) - Method in class com.opensymphony.xwork2.util.WildcardHelper
Determines if the pattern contains any * characters
isLogEnabled() - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
isNeedsRefresh() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
isNeedsRefresh() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
isNoArgConstructorRequired() - Method in class com.opensymphony.xwork2.ObjectFactory
Allows for ObjectFactory implementations that support Actions without no-arg constructors.
isNoArgConstructorRequired() - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
Allows for ObjectFactory implementations that support Actions without no-arg constructors.
isNotEmpty(Object[]) - Static method in class com.opensymphony.xwork2.util.ArrayUtils
isOrdered() - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
Whether to order the parameters or not
isReloadingConfigs() - Static method in class com.opensymphony.xwork2.util.FileManager
isReportingConversionErrors(Map<String, Object>) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
isShortCircuit() - Method in interface com.opensymphony.xwork2.validator.ShortCircuitableValidator
Gets whether this field validator should short circuit the validator queue it's in if validation fails.
isShortCircuit() - Method in class com.opensymphony.xwork2.validator.ValidatorConfig
isShortCircuit() - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
isShouldCreateIfNew() - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer
isSimpleValidator() - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
isSimpleValidator() - Method in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription
isSimpleValidator() - Method in interface com.opensymphony.xwork2.validator.metadata.ValidatorDescription
isTraceEnabled() - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLogger
isTraceEnabled() - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLogger
isTraceEnabled() - Method in interface com.opensymphony.xwork2.util.logging.Logger
isTrimed() - Method in class com.opensymphony.xwork2.validator.validators.RegexFieldValidator
isUnknown(Location) - Static method in class com.opensymphony.xwork2.util.location.LocationUtils
Checks if a location is unknown, i.e.
isValidateAnnotatedMethodOnly() - Method in class com.opensymphony.xwork2.validator.ValidationInterceptor
Gets if validate() should always be called or only per annotated method.
isWarnEnabled() - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLogger
isWarnEnabled() - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLogger
isWarnEnabled() - Method in interface com.opensymphony.xwork2.util.logging.Logger

J

JarResourceStore - Class in com.opensymphony.xwork2.util.classloader
Read resources from a jar file
JarResourceStore(File) - Constructor for class com.opensymphony.xwork2.util.classloader.JarResourceStore
JBOSS5_VFSMEMORY - Static variable in class com.opensymphony.xwork2.util.URLUtil
JBOSS5_VFSZIP - Static variable in class com.opensymphony.xwork2.util.URLUtil
Prefix for Jar files in JBoss Virtual File System
JdkLogger - Class in com.opensymphony.xwork2.util.logging.jdk
Delegates to jdk logger.
JdkLogger(Logger) - Constructor for class com.opensymphony.xwork2.util.logging.jdk.JdkLogger
JdkLoggerFactory - Class in com.opensymphony.xwork2.util.logging.jdk
Creates jdk loggers
JdkLoggerFactory() - Constructor for class com.opensymphony.xwork2.util.logging.jdk.JdkLoggerFactory

K

Key - Annotation Type in com.opensymphony.xwork2.util

Sets the Key for type conversion.

key - Variable in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
key - Variable in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription
key - Variable in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
KEY_PREFIX - Static variable in class com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer
KEY_PREFIX - Static variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
KEY_PROPERTY_FOR_CREATION - Static variable in class com.opensymphony.xwork2.ognl.accessor.XWorkCollectionPropertyAccessor
KEY_PROPERTY_PREFIX - Static variable in class com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer
KEY_PROPERTY_PREFIX - Static variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
KeyProperty - Annotation Type in com.opensymphony.xwork2.util

Sets the KeyProperty for type conversion.

keySet() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
Returns an unmodifiable set view of the keys in this map.

L

LAST_BEAN_CLASS_ACCESSED - Static variable in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
LAST_BEAN_PROPERTY_ACCESSED - Static variable in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
lastIndexOfArray(int[], int, int, char[], int) - Method in class com.opensymphony.xwork2.util.WildcardHelper
Get the offset of a last occurance of an int array within a char array.
LINE_ATTR - Static variable in class com.opensymphony.xwork2.util.location.LocationAttributes
Attribute name for the line number
link(Map<String, Object>, Class, String) - Static method in class com.opensymphony.xwork2.ognl.OgnlValueStack
load(InputStream) - Method in class com.opensymphony.xwork2.util.location.LocatableProperties
loadButAdd(Class<?>, Object) - Method in class com.opensymphony.xwork2.XWorkTestCase
loadButAdd(Class<?>, String, Object) - Method in class com.opensymphony.xwork2.XWorkTestCase
loadClass(String) - Method in class com.opensymphony.xwork2.util.classloader.ReloadingClassLoader
loadClass(String, boolean) - Method in class com.opensymphony.xwork2.util.classloader.ResourceStoreClassLoader
loadClass(String, Class) - Static method in class com.opensymphony.xwork2.util.ClassLoaderUtil
Load a class with a given name.
loadClass(String) - Method in interface com.opensymphony.xwork2.util.finder.ClassLoaderInterface
loadClass(String) - Method in class com.opensymphony.xwork2.util.finder.ClassLoaderInterfaceDelegate
loadConfigurationProviders(ConfigurationProvider...) - Method in class com.opensymphony.xwork2.TestNGXWorkTestCase
loadConfigurationProviders(ConfigurationManager, ConfigurationProvider...) - Static method in class com.opensymphony.xwork2.util.XWorkTestCaseHelper
loadConfigurationProviders(ConfigurationProvider...) - Method in class com.opensymphony.xwork2.XWorkTestCase
loadConversionProperties(String) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
loadConversionProperties(String, boolean) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
loadDefaultActionRef(PackageConfig.Builder, Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
loadDefaultClassRef(PackageConfig.Builder, Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
loadDefaultInterceptorRef(PackageConfig.Builder, Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
loadedFileNames - Variable in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
loadExtraConfiguration(Document) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
Allows subclasses to load extra information from the document
loadFile(String, Class) - Static method in class com.opensymphony.xwork2.util.FileManager
Loads opens the named file and returns the InputStream
loadFile(URL) - Static method in class com.opensymphony.xwork2.util.FileManager
Loads opens the named file and returns the InputStream
loadFile(URL, boolean) - Static method in class com.opensymphony.xwork2.util.FileManager
Loads opens the named file and returns the InputStream
loadGlobalResults(PackageConfig.Builder, Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
Load all of the global results for this package from the XML element.
loadGobalExceptionMappings(PackageConfig.Builder, Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
Load all of the global results for this package from the XML element.
loadInterceptors(PackageConfig.Builder, Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
loadInterceptorStack(Element, PackageConfig.Builder) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
loadInterceptorStacks(Element, PackageConfig.Builder) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
loadPackages() - Method in interface com.opensymphony.xwork2.config.PackageProvider
Loads the packages for the configuration.
loadPackages() - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
loadPackages() - Method in class com.opensymphony.xwork2.config.providers.XWorkConfigurationProvider
loadPackages() - Method in class com.opensymphony.xwork2.test.StubConfigurationProvider
LOCALE - Static variable in class com.opensymphony.xwork2.ActionContext
Constant for the action's locale.
localeFromString(String, Locale) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Builds a Locale from a String of the form en_US_foo into a Locale with language "en", country "US" and variant "foo".
LocaleProvider - Interface in com.opensymphony.xwork2
Indicates that the implementing class can provide its own Locale.
LocalizedTextUtil - Class in com.opensymphony.xwork2.util
Provides support for localization in XWork.
LocalizedTextUtil() - Constructor for class com.opensymphony.xwork2.util.LocalizedTextUtil
Locatable - Interface in com.opensymphony.xwork2.util.location
A interface that should be implemented by objects knowning their location (i.e.
LocatableConstantFactory<T> - Class in com.opensymphony.xwork2.config.impl
Factory that remembers where a constant came from
LocatableConstantFactory(T, Object) - Constructor for class com.opensymphony.xwork2.config.impl.LocatableConstantFactory
LocatableFactory<T> - Class in com.opensymphony.xwork2.config.impl
Attaches location information to the factory.
LocatableFactory(String, Class, Class, Scope, Object) - Constructor for class com.opensymphony.xwork2.config.impl.LocatableFactory
LocatableProperties - Class in com.opensymphony.xwork2.util.location
Properties implementation that remembers the location of each property.
LocatableProperties() - Constructor for class com.opensymphony.xwork2.util.location.LocatableProperties
LocatableProperties(Location) - Constructor for class com.opensymphony.xwork2.util.location.LocatableProperties
Located - Class in com.opensymphony.xwork2.util.location
Base class for location aware objects
Located() - Constructor for class com.opensymphony.xwork2.util.location.Located
location(Location) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
location(Location) - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig.Builder
location(Location) - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig.Builder
location(Location) - Method in class com.opensymphony.xwork2.config.entities.InterceptorStackConfig.Builder
location(Location) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
location(Location) - Method in class com.opensymphony.xwork2.config.entities.ResultConfig.Builder
location(Location) - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig.Builder
location - Variable in class com.opensymphony.xwork2.util.location.Located
Location - Interface in com.opensymphony.xwork2.util.location
A location in a resource.
location(Location) - Method in class com.opensymphony.xwork2.validator.ValidatorConfig.Builder
LocationAttributes - Class in com.opensymphony.xwork2.util.location
A class to handle location information stored in attributes.
LocationAttributes.Pipe - Class in com.opensymphony.xwork2.util.location
A SAX filter that adds the information available from the Locator as attributes.
LocationAttributes.Pipe() - Constructor for class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe
Create a filter.
LocationAttributes.Pipe(ContentHandler) - Constructor for class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe
Create a filter that is chained to another handler.
LocationImpl - Class in com.opensymphony.xwork2.util.location
A simple immutable and serializable implementation of Location.
LocationImpl(String, String) - Constructor for class com.opensymphony.xwork2.util.location.LocationImpl
Build a location for a given URI, with unknown line and column numbers.
LocationImpl(String, String, int, int) - Constructor for class com.opensymphony.xwork2.util.location.LocationImpl
Build a location for a given URI and line and column numbers.
LocationImpl(Location) - Constructor for class com.opensymphony.xwork2.util.location.LocationImpl
Copy constructor.
LocationImpl(String, Location) - Constructor for class com.opensymphony.xwork2.util.location.LocationImpl
Create a location from an existing one, but with a different description
LocationUtils - Class in com.opensymphony.xwork2.util.location
Location-related utility methods.
LocationUtils.LocationFinder - Interface in com.opensymphony.xwork2.util.location
An finder or object locations
LOG - Static variable in class com.opensymphony.xwork2.ActionSupport
LOG - Static variable in class com.opensymphony.xwork2.config.ConfigurationManager
LOG - Static variable in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
LOG - Static variable in class com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer
LOG - Static variable in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
log - Static variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
Jakarta commons-logging reference.
LOG - Static variable in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
LOG - Static variable in class com.opensymphony.xwork2.interceptor.I18nInterceptor
log - Variable in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
LOG - Static variable in class com.opensymphony.xwork2.interceptor.TimerInterceptor
log - Static variable in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Jakarta commons-logging reference.
log - Variable in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
logCategory - Variable in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
logCategory - Variable in class com.opensymphony.xwork2.interceptor.TimerInterceptor
logEnabled - Variable in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
Logger - Interface in com.opensymphony.xwork2.util.logging
Main logger interface for logging things
LoggerFactory - Class in com.opensymphony.xwork2.util.logging
Creates loggers.
LoggerFactory() - Constructor for class com.opensymphony.xwork2.util.logging.LoggerFactory
LoggerUtils - Class in com.opensymphony.xwork2.util.logging
Logging utility methods
LoggerUtils() - Constructor for class com.opensymphony.xwork2.util.logging.LoggerUtils
LoggingInterceptor - Class in com.opensymphony.xwork2.interceptor
This interceptor logs the start and end of the execution an action (in English-only, not internationalized).
LoggingInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.LoggingInterceptor
LOGIN - Static variable in interface com.opensymphony.xwork2.Action
The action could not execute, since the user most was not logged in.
logLevel - Variable in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
logLevel - Variable in class com.opensymphony.xwork2.interceptor.TimerInterceptor
LongRangeFieldValidator - Class in com.opensymphony.xwork2.validator.validators
Field Validator that checks if the long specified is within a certain range.
LongRangeFieldValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.LongRangeFieldValidator
longValue(Object) - Static method in class com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
Evaluates the given object as a long integer.
lookup(String) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
Looks for a TypeConverter in the default mappings.
lookup(Class) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
Looks for a TypeConverter in the default mappings.
lookupRegisteredValidatorType(String) - Method in class com.opensymphony.xwork2.validator.DefaultValidatorFactory
lookupRegisteredValidatorType(String) - Method in interface com.opensymphony.xwork2.validator.ValidatorFactory
Lookup to get the FQ classname of the given validator name.

M

makeLocaleProvider(Object) - Static method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
makeTextProvider(Object, LocaleProvider) - Static method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
makeValidationAware(Object) - Static method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
mapAllClasses(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Executes mapAllStrings assuming the value of each entry in the map is the name of a class that should be loaded.
mapAllImplementations(Class) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Assumes the class specified points to a directory in the classpath that holds files containing the name of a class that implements or is a subclass of the specfied class.
mapAllProperties(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Finds the corresponding resources and reads them in as a properties files

Any URL that cannot be read in as a properties file will cause an exception to be thrown.

mapAllStrings(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Reads the contents of all non-directory URLs immediately under the specified location and returns them in a map keyed by the file name.
mapAvailableClasses(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Executes mapAvailableStrings assuming the value of each entry in the map is the name of a class that should be loaded.
mapAvailableImplementations(Class) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Assumes the class specified points to a directory in the classpath that holds files containing the name of a class that implements or is a subclass of the specfied class.
mapAvailableProperties(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Finds the corresponding resources and reads them in as a properties files

Any URL that cannot be read in as a properties file will be added to the 'resourcesNotLoaded' collection.

mapAvailableStrings(String) - Method in class com.opensymphony.xwork2.util.finder.ResourceFinder
Reads the contents of all non-directory URLs immediately under the specified location and returns them in a map keyed by the file name.
mappings - Variable in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
Target class conversion Mappings.
match(String) - Method in class com.opensymphony.xwork2.config.impl.AbstractMatcher
Matches the path against the compiled wildcard patterns.
match(Map<String, String>, String, NamedVariablePatternMatcher.CompiledPattern) - Method in class com.opensymphony.xwork2.util.NamedVariablePatternMatcher
Tries to process the data against the compiled expression.
match(Map<String, String>, String, E) - Method in interface com.opensymphony.xwork2.util.PatternMatcher
Match a pattern against a string
match(Map<String, String>, String, int[]) - Method in class com.opensymphony.xwork2.util.WildcardHelper
Match a pattern agains a string and isolates wildcard replacement into a Stack.
MATCH_BEGIN - Static variable in class com.opensymphony.xwork2.util.WildcardHelper
The int representing begin in the pattern int [].
MATCH_END - Static variable in class com.opensymphony.xwork2.util.WildcardHelper
The int value that terminates the pattern int [].
MATCH_FILE - Static variable in class com.opensymphony.xwork2.util.WildcardHelper
The int representing '*' in the pattern int [].
MATCH_PATH - Static variable in class com.opensymphony.xwork2.util.WildcardHelper
The int representing '**' in the pattern int [].
MATCH_THEEND - Static variable in class com.opensymphony.xwork2.util.WildcardHelper
The int representing end in pattern int [].
matchArray(int[], int, int, char[], int) - Method in class com.opensymphony.xwork2.util.WildcardHelper
Matches elements of array r from rpos to rend with array d, starting from dpos.
matches(Class) - Method in class com.opensymphony.xwork2.util.ResolverUtil.AnnotatedWith
Returns true if the type is annotated with the class provided to the constructor.
matches(URL) - Method in class com.opensymphony.xwork2.util.ResolverUtil.ClassTest
matches(Class) - Method in class com.opensymphony.xwork2.util.ResolverUtil.IsA
Returns true if type is assignable to the parent type supplied in the constructor.
matches(Class) - Method in class com.opensymphony.xwork2.util.ResolverUtil.NameEndsWith
Returns true if type name ends with the suffix supplied in the constructor.
matches(URL) - Method in class com.opensymphony.xwork2.util.ResolverUtil.NameIs
matches(Class) - Method in class com.opensymphony.xwork2.util.ResolverUtil.ResourceTest
matches(Class) - Method in interface com.opensymphony.xwork2.util.ResolverUtil.Test
Will be called repeatedly with candidate classes.
matches(URL) - Method in interface com.opensymphony.xwork2.util.ResolverUtil.Test
matching(String) - Method in class com.opensymphony.xwork2.util.finder.UrlSet
max - Variable in class com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription
max - Variable in class com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription
max - Variable in class com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription
maxLength - Variable in class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription
MemberAccessValueStack - Interface in com.opensymphony.xwork2.util
ValueStacks implementing this interface provide a way to remove block or allow access to properties using regular expressions
message - Variable in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
message - Variable in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription
message - Variable in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
MESSAGE_INDEX_BRACKET_PATTERN - Static variable in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
MESSAGE_INDEX_PATTERN - Static variable in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
messageIndexPattern - Static variable in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
messageKey(String) - Method in class com.opensymphony.xwork2.validator.ValidatorConfig.Builder
messageKey - Variable in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
messageParams(String[]) - Method in class com.opensymphony.xwork2.validator.ValidatorConfig.Builder
method - Variable in class com.opensymphony.xwork2.DefaultActionProxy
MethodFilterInterceptor - Class in com.opensymphony.xwork2.interceptor
MethodFilterInterceptor is an abstract Interceptor used as a base class for interceptors that will filter execution based on method names according to specified included/excluded method lists.
MethodFilterInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
MethodFilterInterceptorUtil - Class in com.opensymphony.xwork2.interceptor
Utility class contains common methods used by MethodFilterInterceptor.
MethodFilterInterceptorUtil() - Constructor for class com.opensymphony.xwork2.interceptor.MethodFilterInterceptorUtil
methodName(String) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
methodName - Variable in class com.opensymphony.xwork2.config.entities.ActionConfig
min - Variable in class com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription
min - Variable in class com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription
min - Variable in class com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription
MIN_TIME - Static variable in class com.opensymphony.xwork2.util.profiling.UtilTimerStack
System property that controls the min time, that if exceeded will cause a log (at INFO level) to be created.
minLength - Variable in class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription
MISSING_ACTION_EXCEPTION - Static variable in interface com.opensymphony.xwork2.XWorkMessages
MISSING_PACKAGE_ACTION_EXCEPTION - Static variable in interface com.opensymphony.xwork2.XWorkMessages
MockActionInvocation - Class in com.opensymphony.xwork2.mock
Mock for an ActionInvocation.
MockActionInvocation() - Constructor for class com.opensymphony.xwork2.mock.MockActionInvocation
MockActionInvocation - Class in com.opensymphony.xwork2
Deprecated. Please use @see com.opensymphony.xwork2.mock.MockActionInvocation instead
MockActionInvocation() - Constructor for class com.opensymphony.xwork2.MockActionInvocation
Deprecated.
MockActionProxy - Class in com.opensymphony.xwork2.mock
Mock for an ActionProxy.
MockActionProxy() - Constructor for class com.opensymphony.xwork2.mock.MockActionProxy
MockConfiguration - Class in com.opensymphony.xwork2.config.impl
Simple configuration used for unit testing
MockConfiguration() - Constructor for class com.opensymphony.xwork2.config.impl.MockConfiguration
MockInterceptor - Class in com.opensymphony.xwork2.mock
Mock for an Interceptor.
MockInterceptor() - Constructor for class com.opensymphony.xwork2.mock.MockInterceptor
MockObjectTypeDeterminer - Class in com.opensymphony.xwork2.mock
Mocks the function of an ObjectTypeDeterminer for testing purposes.
MockObjectTypeDeterminer() - Constructor for class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer
MockObjectTypeDeterminer(Class, Class, String, boolean) - Constructor for class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer
MockResult - Class in com.opensymphony.xwork2.mock
Mock for a Result.
MockResult() - Constructor for class com.opensymphony.xwork2.mock.MockResult
ModelDriven<T> - Interface in com.opensymphony.xwork2
ModelDriven Actions provide a model object to be pushed onto the ValueStack in addition to the Action itself, allowing a FormBean type approach like Struts.
ModelDrivenInterceptor - Class in com.opensymphony.xwork2.interceptor
Watches for ModelDriven actions and adds the action's model on to the value stack.
ModelDrivenInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor
ModelDrivenInterceptor.RefreshModelBeforeResult - Class in com.opensymphony.xwork2.interceptor
Refreshes the model instance on the value stack, if it has changed
ModelDrivenInterceptor.RefreshModelBeforeResult(ModelDriven, Object) - Constructor for class com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor.RefreshModelBeforeResult

N

name(String) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
name - Variable in class com.opensymphony.xwork2.config.entities.ActionConfig
name(String) - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig.Builder
name(String) - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig.Builder
name(String) - Method in class com.opensymphony.xwork2.config.entities.InterceptorStackConfig.Builder
name(String) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
name(String) - Method in class com.opensymphony.xwork2.config.entities.ResultConfig.Builder
name(String) - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig.Builder
NamedVariablePatternMatcher - Class in com.opensymphony.xwork2.util
An implementation of a pattern matcher that uses simple named wildcards.
NamedVariablePatternMatcher() - Constructor for class com.opensymphony.xwork2.util.NamedVariablePatternMatcher
NamedVariablePatternMatcher.CompiledPattern - Class in com.opensymphony.xwork2.util
Stores the compiled pattern and the variable names matches will correspond to.
NamedVariablePatternMatcher.CompiledPattern(Pattern, List<String>) - Constructor for class com.opensymphony.xwork2.util.NamedVariablePatternMatcher.CompiledPattern
namespace(String) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
namespace - Variable in class com.opensymphony.xwork2.DefaultActionProxy
NamespaceMatch - Class in com.opensymphony.xwork2.config.impl
Represents a match from a namespace pattern matching.
NamespaceMatch(String, Map<String, String>) - Constructor for class com.opensymphony.xwork2.config.impl.NamespaceMatch
NamespaceMatcher - Class in com.opensymphony.xwork2.config.impl
Matches namespace strings against a wildcard pattern matcher
NamespaceMatcher(PatternMatcher<?>, Set<String>) - Constructor for class com.opensymphony.xwork2.config.impl.NamespaceMatcher
needsRefresh(boolean) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
needsReload() - Method in interface com.opensymphony.xwork2.config.ContainerProvider
Tells whether the ContainerProvider should reload its configuration
needsReload() - Method in interface com.opensymphony.xwork2.config.PackageProvider
Tells whether the PackageProvider should reload its configuration
needsReload() - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
Tells whether the ConfigurationProvider should reload its configuration.
needsReload() - Method in class com.opensymphony.xwork2.config.providers.XWorkConfigurationProvider
needsReload() - Method in class com.opensymphony.xwork2.test.StubConfigurationProvider
nextHandler - Variable in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
nextProperty() - Method in class com.opensymphony.xwork2.util.PropertiesReader
Parses the next property from the input stream and stores the found name and value in internal fields.
NO_CONVERSION_POSSIBLE - Static variable in interface com.opensymphony.xwork2.conversion.TypeConverter
noMapping - Variable in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
Unavailable target class conversion mappings, serves as a simple cache.
NONE - Static variable in interface com.opensymphony.xwork2.Action
The action execution was successful but do not show a view.
NoParameters - Interface in com.opensymphony.xwork2.interceptor
Marker interface to incidate no auto setting of parameters.
normalizeToFileProtocol(URL) - Static method in class com.opensymphony.xwork2.util.URLUtil
Convert URLs to URLs with "file" protocol
NullHandler - Interface in com.opensymphony.xwork2.conversion
Interface for handling null results from Chains.
nullMethodResult(Map<String, Object>, Object, String, Object[]) - Method in class com.opensymphony.xwork2.conversion.impl.InstantiatingNullHandler
nullMethodResult(Map<String, Object>, Object, String, Object[]) - Method in interface com.opensymphony.xwork2.conversion.NullHandler
Method called on target returned null.
nullMethodResult(Map, Object, String, Object[]) - Method in class com.opensymphony.xwork2.ognl.OgnlNullHandlerWrapper
nullPropertyValue(Map<String, Object>, Object, Object) - Method in class com.opensymphony.xwork2.conversion.impl.InstantiatingNullHandler
nullPropertyValue(Map<String, Object>, Object, Object) - Method in interface com.opensymphony.xwork2.conversion.NullHandler
Property in target evaluated to null.
nullPropertyValue(Map, Object, Object) - Method in class com.opensymphony.xwork2.ognl.OgnlNullHandlerWrapper

O

ObjectAccessor - Class in com.opensymphony.xwork2.ognl.accessor
ObjectAccessor() - Constructor for class com.opensymphony.xwork2.ognl.accessor.ObjectAccessor
objectFactory - Variable in class com.opensymphony.xwork2.DefaultActionInvocation
objectFactory - Variable in class com.opensymphony.xwork2.DefaultActionProxy
ObjectFactory - Class in com.opensymphony.xwork2
ObjectFactory is responsible for building the core framework objects.
ObjectFactory() - Constructor for class com.opensymphony.xwork2.ObjectFactory
ObjectFactory(ReflectionProvider) - Constructor for class com.opensymphony.xwork2.ObjectFactory
objectFactory - Variable in class com.opensymphony.xwork2.validator.DefaultValidatorFactory
ObjectProfiler - Class in com.opensymphony.xwork2.util.profiling
ObjectProfiler() - Constructor for class com.opensymphony.xwork2.util.profiling.ObjectProfiler
ObjectProxy - Class in com.opensymphony.xwork2.ognl
An Object to use within OGNL to proxy other Objects usually Collections that you set in a different place on the ValueStack but want to retain the context information about where they previously were.
ObjectProxy() - Constructor for class com.opensymphony.xwork2.ognl.ObjectProxy
ObjectProxyPropertyAccessor - Class in com.opensymphony.xwork2.ognl.accessor
Is able to access (set/get) properties on a given object.
ObjectProxyPropertyAccessor() - Constructor for class com.opensymphony.xwork2.ognl.accessor.ObjectProxyPropertyAccessor
ObjectTypeDeterminer - Interface in com.opensymphony.xwork2.conversion
Determines what the key and and element class of a Map or Collection should be.
of(ReferenceType, ReferenceType, Function<? super K, ? extends V>) - Static method in class com.opensymphony.xwork2.inject.util.ReferenceCache
Returns a ReferenceCache delegating to the specified function.
OgnlNullHandlerWrapper - Class in com.opensymphony.xwork2.ognl
OgnlNullHandlerWrapper(NullHandler) - Constructor for class com.opensymphony.xwork2.ognl.OgnlNullHandlerWrapper
OgnlReflectionContextFactory - Class in com.opensymphony.xwork2.ognl
OgnlReflectionContextFactory() - Constructor for class com.opensymphony.xwork2.ognl.OgnlReflectionContextFactory
OgnlReflectionProvider - Class in com.opensymphony.xwork2.ognl
OgnlReflectionProvider() - Constructor for class com.opensymphony.xwork2.ognl.OgnlReflectionProvider
OgnlTypeConverterWrapper - Class in com.opensymphony.xwork2.ognl
Wraps an XWork type conversion class for as an OGNL TypeConverter
OgnlTypeConverterWrapper(TypeConverter) - Constructor for class com.opensymphony.xwork2.ognl.OgnlTypeConverterWrapper
OgnlUtil - Class in com.opensymphony.xwork2.ognl
Utility class that provides common access to the Ognl APIs for setting and getting properties from objects (usually Actions).
OgnlUtil() - Constructor for class com.opensymphony.xwork2.ognl.OgnlUtil
OgnlValueStack - Class in com.opensymphony.xwork2.ognl
Ognl implementation of a value stack that allows for dynamic Ognl expressions to be evaluated against it.
OgnlValueStack(XWorkConverter, CompoundRootAccessor, TextProvider, boolean) - Constructor for class com.opensymphony.xwork2.ognl.OgnlValueStack
OgnlValueStack(ValueStack, XWorkConverter, CompoundRootAccessor, boolean) - Constructor for class com.opensymphony.xwork2.ognl.OgnlValueStack
OgnlValueStackFactory - Class in com.opensymphony.xwork2.ognl
Creates an Ognl value stack
OgnlValueStackFactory() - Constructor for class com.opensymphony.xwork2.ognl.OgnlValueStackFactory
ORIGINAL_PROPERTY_OVERRIDE - Static variable in class com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor

P

PackageConfig - Class in com.opensymphony.xwork2.config.entities
Configuration for Package.
PackageConfig(String) - Constructor for class com.opensymphony.xwork2.config.entities.PackageConfig
PackageConfig(PackageConfig) - Constructor for class com.opensymphony.xwork2.config.entities.PackageConfig
PackageConfig.Builder - Class in com.opensymphony.xwork2.config.entities
The builder for this object.
PackageConfig.Builder(String) - Constructor for class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
PackageConfig.Builder(PackageConfig) - Constructor for class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
packageContexts - Variable in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
packageName(String) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig.Builder
packageName - Variable in class com.opensymphony.xwork2.config.entities.ActionConfig
PackageProvider - Interface in com.opensymphony.xwork2.config
Provides configuration packages.
ParameterFilterInterceptor - Class in com.opensymphony.xwork2.interceptor
The Parameter Filter Interceptor blocks parameters from getting to the rest of the stack or your action.
ParameterFilterInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor
Parameterizable - Interface in com.opensymphony.xwork2.config.entities

Actions implementing Parameterizable will receive a map of the static parameters defined in the action configuration.

parameterName - Variable in class com.opensymphony.xwork2.interceptor.I18nInterceptor
ParameterNameAware - Interface in com.opensymphony.xwork2.interceptor
This interface is implemented by actions that want to declare acceptable parameters.
ParameterRemoverInterceptor - Class in com.opensymphony.xwork2.interceptor
This is a simple XWork interceptor that allows parameters (matching one of the paramNames attribute csv value) to be removed from the parameter map if they match a certain value (matching one of the paramValues attribute csv value), before they are set on the action.
ParameterRemoverInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor
PARAMETERS - Static variable in class com.opensymphony.xwork2.ActionContext
Constant for the action's parameters.
ParametersInterceptor - Class in com.opensymphony.xwork2.interceptor
This interceptor sets all parameters on the value stack.
ParametersInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.ParametersInterceptor
params - Variable in class com.opensymphony.xwork2.config.entities.ActionConfig
parentNode - Variable in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
The parentNode
parse(InputSource) - Static method in class com.opensymphony.xwork2.util.DomHelper
Creates a W3C Document that remembers the location of each element in the source file.
parse(InputSource, Map<String, String>) - Static method in class com.opensymphony.xwork2.util.DomHelper
Creates a W3C Document that remembers the location of each element in the source file.
parse(String) - Static method in class com.opensymphony.xwork2.util.location.LocationUtils
Parse a location string of the form "uri:line:column" (e.g.
parseActionValidatorConfigs(ValidatorFactory, InputStream, String) - Method in class com.opensymphony.xwork2.validator.DefaultValidatorFileParser
parseActionValidatorConfigs(ValidatorFactory, InputStream, String) - Method in interface com.opensymphony.xwork2.validator.ValidatorFileParser
Parse resource for a list of ValidatorConfig objects (configuring which validator(s) are being applied to a particular field etc.)
parseValidatorDefinitions(Map<String, String>, InputStream, String) - Method in class com.opensymphony.xwork2.validator.DefaultValidatorFileParser
parseValidatorDefinitions(Map<String, String>, InputStream, String) - Method in interface com.opensymphony.xwork2.validator.ValidatorFileParser
Parses validator definitions (register various validators with XWork).
PatternMatcher<E> - Interface in com.opensymphony.xwork2.util
Compiles and matches a pattern against a value
pause(String) - Method in class com.opensymphony.xwork2.ActionSupport
Stops the action invocation immediately (by throwing a PauseException) and causes the action invocation to return the specified result, such as Action.SUCCESS, Action.INPUT, etc.
peek() - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
peek() - Method in class com.opensymphony.xwork2.util.CompoundRoot
peek() - Method in interface com.opensymphony.xwork2.util.ValueStack
Get the object on the top of the stack without changing the stack.
PERIOD - Static variable in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
pop() - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
pop() - Method in class com.opensymphony.xwork2.util.CompoundRoot
pop(String) - Static method in class com.opensymphony.xwork2.util.profiling.UtilTimerStack
End a preformance profiling with the name given.
pop() - Method in interface com.opensymphony.xwork2.util.ValueStack
Get the object on the top of the stack and remove it from the stack.
PREFIX - Static variable in class com.opensymphony.xwork2.util.location.LocationAttributes
Prefix for the location namespace
PrefixMethodInvocationUtil - Class in com.opensymphony.xwork2.interceptor
A utility class for invoking prefixed methods in action class.
PrefixMethodInvocationUtil() - Constructor for class com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil
Preparable - Interface in com.opensymphony.xwork2
Preparable Actions will have their prepare() method called if the PrepareInterceptor is applied to the ActionConfig.
prepare(Object, ValueStack) - Method in interface com.opensymphony.xwork2.ActionEventListener
Called after an action has been created.
prepare() - Method in class com.opensymphony.xwork2.DefaultActionProxy
prepare() - Method in class com.opensymphony.xwork2.mock.MockActionProxy
prepare() - Method in interface com.opensymphony.xwork2.Preparable
This method is called to allow the action to prepare itself.
PrepareInterceptor - Class in com.opensymphony.xwork2.interceptor
This interceptor calls prepare() on actions which implement Preparable.
PrepareInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.PrepareInterceptor
PreResultListener - Interface in com.opensymphony.xwork2.interceptor
PreResultListeners may be registered with an ActionInvocation to get a callback after the Action has been executed but before the Result is executed.
preResultListeners - Variable in class com.opensymphony.xwork2.DefaultActionInvocation
processingInstruction(String, String) - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
processingInstruction(String, String) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler
processingInstruction(String, String) - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe
profile(String, UtilTimerStack.ProfilingBlock<T>) - Static method in class com.opensymphony.xwork2.util.profiling.UtilTimerStack
A convenience method that allows block of code subjected to profiling to be executed and avoid the need of coding boiler code that does pushing (UtilTimeBean.push(...)) and poping (UtilTimerBean.pop(...)) in a try ...
profiledInvoke(Method, Object, Object[]) - Static method in class com.opensymphony.xwork2.util.profiling.ObjectProfiler
A profiled call Method.invoke(java.lang.Object, java.lang.Object[]).
ProfilingTimerBean - Class in com.opensymphony.xwork2.util.profiling
Bean to contain information about the pages profiled
ProfilingTimerBean(String) - Constructor for class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean
PropertiesReader - Class in com.opensymphony.xwork2.util
This class is used to read properties lines.
PropertiesReader(Reader) - Constructor for class com.opensymphony.xwork2.util.PropertiesReader
Constructor.
PropertiesReader(Reader, char) - Constructor for class com.opensymphony.xwork2.util.PropertiesReader
Creates a new instance of PropertiesReader and sets the underlaying reader and the list delimiter.
property - Variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
providerLock - Variable in class com.opensymphony.xwork2.config.ConfigurationManager
proxy - Variable in class com.opensymphony.xwork2.DefaultActionInvocation
publishException(ActionInvocation, ExceptionHolder) - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
Default implementation to handle ExceptionHolder publishing.
push(Object) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
push(Object) - Method in class com.opensymphony.xwork2.util.CompoundRoot
push(String) - Static method in class com.opensymphony.xwork2.util.profiling.UtilTimerStack
Create and start a performance profiling with the name given.
push(Object) - Method in interface com.opensymphony.xwork2.util.ValueStack
Put this object onto the top of the stack
pushAction - Variable in class com.opensymphony.xwork2.DefaultActionInvocation
put(String, Object) - Method in class com.opensymphony.xwork2.ActionContext
Stores a value in the current ActionContext.
put(K, V) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
putAll(Map<? extends K, ? extends V>) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
putIfAbsent(K, V) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
putIfAbsentStrategy() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
putStrategy() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

Q

Q_COL_ATTR - Static variable in class com.opensymphony.xwork2.util.location.LocationAttributes
Attribute qualified name for the column number
Q_LINE_ATTR - Static variable in class com.opensymphony.xwork2.util.location.LocationAttributes
Attribute qualified name for the line number
Q_SRC_ATTR - Static variable in class com.opensymphony.xwork2.util.location.LocationAttributes
Attribute qualified name for the location URI

R

read(String) - Method in class com.opensymphony.xwork2.util.classloader.FileResourceStore
read(String) - Method in class com.opensymphony.xwork2.util.classloader.JarResourceStore
read(String) - Method in interface com.opensymphony.xwork2.util.classloader.ResourceStore
readProperty() - Method in class com.opensymphony.xwork2.util.PropertiesReader
Reads a property line.
rebuildRuntimeConfiguration() - Method in interface com.opensymphony.xwork2.config.Configuration
rebuildRuntimeConfiguration() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
rebuildRuntimeConfiguration() - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration
ReferenceCache<K,V> - Class in com.opensymphony.xwork2.inject.util
Extends ReferenceMap to support lazy loading values by overriding ReferenceCache.create(Object).
ReferenceCache(ReferenceType, ReferenceType) - Constructor for class com.opensymphony.xwork2.inject.util.ReferenceCache
ReferenceCache() - Constructor for class com.opensymphony.xwork2.inject.util.ReferenceCache
Equivalent to new ReferenceCache(STRONG, STRONG).
ReferenceMap<K,V> - Class in com.opensymphony.xwork2.inject.util
Concurrent hash map that wraps keys and/or values in soft or weak references.
ReferenceMap(ReferenceType, ReferenceType) - Constructor for class com.opensymphony.xwork2.inject.util.ReferenceMap
Concurrent hash map that wraps keys and/or values based on specified reference types.
ReferenceMap.Strategy - Interface in com.opensymphony.xwork2.inject.util
ReferenceResolverException - Exception in com.opensymphony.xwork2.config
Exception when a reference can't be resolved.
ReferenceResolverException() - Constructor for exception com.opensymphony.xwork2.config.ReferenceResolverException
ReferenceResolverException(String) - Constructor for exception com.opensymphony.xwork2.config.ReferenceResolverException
ReferenceResolverException(String, Throwable) - Constructor for exception com.opensymphony.xwork2.config.ReferenceResolverException
ReferenceResolverException(Throwable) - Constructor for exception com.opensymphony.xwork2.config.ReferenceResolverException
ReferenceType - Enum in com.opensymphony.xwork2.inject.util
Reference type.
ReflectionContextFactory - Interface in com.opensymphony.xwork2.util.reflection
ReflectionContextState - Class in com.opensymphony.xwork2.util.reflection
Manages variables in the reflection context and returns values to be used by the application.
ReflectionContextState() - Constructor for class com.opensymphony.xwork2.util.reflection.ReflectionContextState
ReflectionException - Exception in com.opensymphony.xwork2.util.reflection
ReflectionException() - Constructor for exception com.opensymphony.xwork2.util.reflection.ReflectionException
ReflectionException(String) - Constructor for exception com.opensymphony.xwork2.util.reflection.ReflectionException
ReflectionException(String, Object) - Constructor for exception com.opensymphony.xwork2.util.reflection.ReflectionException
ReflectionException(Throwable) - Constructor for exception com.opensymphony.xwork2.util.reflection.ReflectionException
ReflectionException(Throwable, Object) - Constructor for exception com.opensymphony.xwork2.util.reflection.ReflectionException
ReflectionException(String, Throwable) - Constructor for exception com.opensymphony.xwork2.util.reflection.ReflectionException
ReflectionException(String, Throwable, Object) - Constructor for exception com.opensymphony.xwork2.util.reflection.ReflectionException
ReflectionExceptionHandler - Interface in com.opensymphony.xwork2.util.reflection
Declares a class that wants to handle its own reflection exceptions
reflectionProvider - Variable in class com.opensymphony.xwork2.interceptor.ChainingInterceptor
reflectionProvider - Variable in class com.opensymphony.xwork2.ObjectFactory
ReflectionProvider - Interface in com.opensymphony.xwork2.util.reflection
ReflectionProviderFactory - Class in com.opensymphony.xwork2.util.reflection
ReflectionProviderFactory() - Constructor for class com.opensymphony.xwork2.util.reflection.ReflectionProviderFactory
refreshModelBeforeResult - Variable in class com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor
RegexFieldValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
Validates a string field using a regular expression.
RegexFieldValidator - Class in com.opensymphony.xwork2.validator.validators
Validates a string field using a regular expression.
RegexFieldValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.RegexFieldValidator
register(ContainerBuilder, LocatableProperties) - Method in interface com.opensymphony.xwork2.config.ContainerProvider
Registers beans and properties for the Container
register(ContainerBuilder, LocatableProperties) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
register(ContainerBuilder, LocatableProperties) - Method in class com.opensymphony.xwork2.config.providers.XWorkConfigurationProvider
register(ContainerBuilder, LocatableProperties) - Method in class com.opensymphony.xwork2.test.StubConfigurationProvider
registerConverter(String, TypeConverter) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
registerConverterNotFound(String) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
registerValidator(String, String) - Method in class com.opensymphony.xwork2.validator.DefaultValidatorFactory
registerValidator(String, String) - Method in interface com.opensymphony.xwork2.validator.ValidatorFactory
Registers the given validator to the existing map of validators.
relative(File) - Method in class com.opensymphony.xwork2.util.finder.UrlSet
reload(List<ConfigurationProvider>) - Method in interface com.opensymphony.xwork2.config.Configuration
Deprecated. Since 2.1
reload() - Method in class com.opensymphony.xwork2.config.ConfigurationManager
reload(List<ConfigurationProvider>) - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
Calls the ConfigurationProviderFactory.getConfig() to tell it to reload the configuration and then calls buildRuntimeConfiguration().
reload(List<ConfigurationProvider>) - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration
reload() - Method in class com.opensymphony.xwork2.util.classloader.ReloadingClassLoader
reloadContainer(List<ContainerProvider>) - Method in interface com.opensymphony.xwork2.config.Configuration
reloadContainer(List<ContainerProvider>) - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
Calls the ConfigurationProviderFactory.getConfig() to tell it to reload the configuration and then calls buildRuntimeConfiguration().
reloadContainer(List<ContainerProvider>) - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration
ReloadingClassLoader - Class in com.opensymphony.xwork2.util.classloader
The ReloadingClassLoader uses a delegation mechanism to allow classes to be reloaded.
ReloadingClassLoader(ClassLoader) - Constructor for class com.opensymphony.xwork2.util.classloader.ReloadingClassLoader
reloadingConfigs - Static variable in class com.opensymphony.xwork2.util.FileManager
remove(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
remove(Object, Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
remove(Element, boolean) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Remove the location attributes from a DOM element.
removePackageConfig(String) - Method in interface com.opensymphony.xwork2.config.Configuration
Removes a package from the the list of packages.
removePackageConfig(String) - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
removePackageConfig(String) - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration
removeParam(String) - Method in class com.opensymphony.xwork2.validator.ValidatorConfig.Builder
removeResourceStore(ResourceStore) - Method in class com.opensymphony.xwork2.util.classloader.ReloadingClassLoader
removeScopeStrategy() - Method in interface com.opensymphony.xwork2.inject.Container
Removes the scope strategy for the current thread.
replace(K, V, V) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
replace(K, V) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
replaceParameters(Map<String, String>, Map<String, String>) - Method in class com.opensymphony.xwork2.config.impl.AbstractMatcher
Replaces parameter values
replaceStrategy() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
RepopulateConversionErrorFieldValidatorSupport - Class in com.opensymphony.xwork2.validator.validators
An abstract base class that adds in the capability to populate the stack with a fake parameter map when a conversion error has occurred and the 'repopulateField' property is set to "true".
RepopulateConversionErrorFieldValidatorSupport() - Constructor for class com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport
repopulateField(Object) - Method in class com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport
REPORT_CONVERSION_ERRORS - Static variable in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
REPORT_ERRORS_ON_NO_PROP - Static variable in interface com.opensymphony.xwork2.util.ValueStack
requestOnlyParameterName - Variable in class com.opensymphony.xwork2.interceptor.I18nInterceptor
RequiredFieldValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator checks that a field is non-null.
RequiredFieldValidator - Class in com.opensymphony.xwork2.validator.validators
RequiredFieldValidator checks if the specified field is not null.
RequiredFieldValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.RequiredFieldValidator
RequiredFieldValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
RequiredFieldValidatorDescription
RequiredFieldValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription
RequiredFieldValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.
RequiredStringValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator checks that a String field is not empty (i.e.
RequiredStringValidator - Class in com.opensymphony.xwork2.validator.validators
RequiredStringValidator checks that a String field is non-null and has a length > 0.
RequiredStringValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.RequiredStringValidator
RequiredStringValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
RequiredStringValidatorDescription
RequiredStringValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription
RequiredStringValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.
reset() - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Clears all the internal lists.
resolveEntity(String, String) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler
resolveModel(ObjectFactory, ActionContext, String, String, String) - Method in class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor
resolvePropertyName(Method) - Static method in class com.opensymphony.xwork2.util.AnnotationUtils
Returns the property name for a method.
resolvePropertyName(Method) - Method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder
Returns the property name for a method.
ResolverUtil<T> - Class in com.opensymphony.xwork2.util
ResolverUtil is used to locate classes that are available in the/a class path and meet arbitrary conditions.
ResolverUtil() - Constructor for class com.opensymphony.xwork2.util.ResolverUtil
ResolverUtil.AnnotatedWith - Class in com.opensymphony.xwork2.util
A Test that checks to see if each class is annotated with a specific annotation.
ResolverUtil.AnnotatedWith(Class<? extends Annotation>) - Constructor for class com.opensymphony.xwork2.util.ResolverUtil.AnnotatedWith
Construts an AnnotatedWith test for the specified annotation type.
ResolverUtil.ClassTest - Class in com.opensymphony.xwork2.util
ResolverUtil.ClassTest() - Constructor for class com.opensymphony.xwork2.util.ResolverUtil.ClassTest
ResolverUtil.IsA - Class in com.opensymphony.xwork2.util
A Test that checks to see if each class is assignable to the provided class.
ResolverUtil.IsA(Class) - Constructor for class com.opensymphony.xwork2.util.ResolverUtil.IsA
Constructs an IsA test using the supplied Class as the parent class/interface.
ResolverUtil.NameEndsWith - Class in com.opensymphony.xwork2.util
A Test that checks to see if each class name ends with the provided suffix.
ResolverUtil.NameEndsWith(String) - Constructor for class com.opensymphony.xwork2.util.ResolverUtil.NameEndsWith
Constructs a NameEndsWith test using the supplied suffix.
ResolverUtil.NameIs - Class in com.opensymphony.xwork2.util
ResolverUtil.NameIs(String) - Constructor for class com.opensymphony.xwork2.util.ResolverUtil.NameIs
ResolverUtil.ResourceTest - Class in com.opensymphony.xwork2.util
ResolverUtil.ResourceTest() - Constructor for class com.opensymphony.xwork2.util.ResolverUtil.ResourceTest
ResolverUtil.Test - Interface in com.opensymphony.xwork2.util
A simple interface that specifies how to test classes to determine if they are to be included in the results produced by the ResolverUtil.
ResourceBundleTextProvider - Interface in com.opensymphony.xwork2
Extension Interface for TextProvider to help supporting ResourceBundles.
ResourceFinder - Class in com.opensymphony.xwork2.util.finder
ResourceFinder(URL...) - Constructor for class com.opensymphony.xwork2.util.finder.ResourceFinder
ResourceFinder(String) - Constructor for class com.opensymphony.xwork2.util.finder.ResourceFinder
ResourceFinder(String, URL...) - Constructor for class com.opensymphony.xwork2.util.finder.ResourceFinder
ResourceFinder(String, ClassLoaderInterface) - Constructor for class com.opensymphony.xwork2.util.finder.ResourceFinder
ResourceFinder(String, ClassLoaderInterface, URL...) - Constructor for class com.opensymphony.xwork2.util.finder.ResourceFinder
ResourceStore - Interface in com.opensymphony.xwork2.util.classloader
*interface taken from Apache JCI
ResourceStoreClassLoader - Class in com.opensymphony.xwork2.util.classloader
class taken from Apache JCI
ResourceStoreClassLoader(ClassLoader, ResourceStore[]) - Constructor for class com.opensymphony.xwork2.util.classloader.ResourceStoreClassLoader
result(String) - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig.Builder
result - Variable in class com.opensymphony.xwork2.DefaultActionInvocation
Result - Interface in com.opensymphony.xwork2
All results (except for Action.NONE) of an Action are mapped to a View implementation.
result - Variable in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
The result
resultCode - Variable in class com.opensymphony.xwork2.DefaultActionInvocation
ResultConfig - Class in com.opensymphony.xwork2.config.entities
Configuration for Result.
ResultConfig(String, String) - Constructor for class com.opensymphony.xwork2.config.entities.ResultConfig
ResultConfig(ResultConfig) - Constructor for class com.opensymphony.xwork2.config.entities.ResultConfig
ResultConfig.Builder - Class in com.opensymphony.xwork2.config.entities
The builder for this object.
ResultConfig.Builder(String, String) - Constructor for class com.opensymphony.xwork2.config.entities.ResultConfig.Builder
ResultConfig.Builder(ResultConfig) - Constructor for class com.opensymphony.xwork2.config.entities.ResultConfig.Builder
results - Variable in class com.opensymphony.xwork2.config.entities.ActionConfig
ResultTypeConfig - Class in com.opensymphony.xwork2.config.entities
Configuration class for result types.
ResultTypeConfig(String, String) - Constructor for class com.opensymphony.xwork2.config.entities.ResultTypeConfig
ResultTypeConfig(ResultTypeConfig) - Constructor for class com.opensymphony.xwork2.config.entities.ResultTypeConfig
ResultTypeConfig.Builder - Class in com.opensymphony.xwork2.config.entities
The builder for this object.
ResultTypeConfig.Builder(String, String) - Constructor for class com.opensymphony.xwork2.config.entities.ResultTypeConfig.Builder
ResultTypeConfig.Builder(ResultTypeConfig) - Constructor for class com.opensymphony.xwork2.config.entities.ResultTypeConfig.Builder
retrieveParameters(ActionContext) - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
Gets the parameter map to apply from wherever appropriate
retrieveParameters(ActionContext) - Method in class com.opensymphony.xwork2.interceptor.StaticParametersInterceptor
rule - Variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
runtimeConfiguration - Variable in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
RuntimeConfiguration - Interface in com.opensymphony.xwork2.config
RuntimeConfiguration

S

saveLocale(ActionInvocation, Locale) - Method in class com.opensymphony.xwork2.interceptor.I18nInterceptor
Save the given locale to the ActionInvocation.
Scope - Enum in com.opensymphony.xwork2.inject
Scope of an injected objects.
Scope.Strategy - Interface in com.opensymphony.xwork2.inject
Pluggable scoping strategy.
Scoped - Annotation Type in com.opensymphony.xwork2.inject
Annotates a scoped implementation class.
ScopedModelDriven<T> - Interface in com.opensymphony.xwork2.interceptor
Adds the ability to set a model, probably retrieved from a given state.
ScopedModelDrivenInterceptor - Class in com.opensymphony.xwork2.interceptor
An interceptor that enables scoped model-driven actions.
ScopedModelDrivenInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor
SecurityMemberAccess - Class in com.opensymphony.xwork2.ognl
Allows access decisions to be made on the basis of whether a member is static or not.
SecurityMemberAccess(boolean) - Constructor for class com.opensymphony.xwork2.ognl.SecurityMemberAccess
selfRegister() - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration
SESSION - Static variable in class com.opensymphony.xwork2.ActionContext
Constant for the action's session.
set(String, Object) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
set(String, Object) - Method in interface com.opensymphony.xwork2.util.ValueStack
Sets an object on the stack with the given key so it is retrievable by ValueStack.findValue(String), ValueStack.findValue(String, Class)
set(int, Object) - Method in class com.opensymphony.xwork2.util.XWorkList
Replaces the element at the specified position in this list with the specified element.
setAccepClasses(Set<Pattern>) - Method in class com.opensymphony.xwork2.util.classloader.ReloadingClassLoader
setAcceptParamNames(String) - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
setAcceptProperties(Set<Pattern>) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
setAcceptProperties(Set<Pattern>) - Method in class com.opensymphony.xwork2.ognl.SecurityMemberAccess
setAcceptProperties(Set<Pattern>) - Method in interface com.opensymphony.xwork2.util.MemberAccessValueStack
setAction(Object) - Method in class com.opensymphony.xwork2.mock.MockActionInvocation
setAction(Object) - Method in class com.opensymphony.xwork2.mock.MockActionProxy
setActionErrors(Collection<String>) - Method in class com.opensymphony.xwork2.ActionSupport
setActionErrors(Collection<String>) - Method in interface com.opensymphony.xwork2.ValidationAware
Set the Collection of Action-level String error messages.
setActionErrors(Collection<String>) - Method in class com.opensymphony.xwork2.ValidationAwareSupport
setActionErrors(Collection<String>) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
setActionEventListener(ActionEventListener) - Method in interface com.opensymphony.xwork2.ActionInvocation
Sets the action event listener to respond to key action events.
setActionEventListener(ActionEventListener) - Method in class com.opensymphony.xwork2.DefaultActionInvocation
setActionEventListener(ActionEventListener) - Method in class com.opensymphony.xwork2.DefaultActionProxy
setActionEventListener(ActionEventListener) - Method in class com.opensymphony.xwork2.mock.MockActionInvocation
setActionInvocation(ActionInvocation) - Method in class com.opensymphony.xwork2.ActionContext
Sets the action invocation (the execution state).
setActionMessages(Collection<String>) - Method in class com.opensymphony.xwork2.ActionSupport
setActionMessages(Collection<String>) - Method in interface com.opensymphony.xwork2.ValidationAware
Set the Collection of Action-level String messages (not errors).
setActionMessages(Collection<String>) - Method in class com.opensymphony.xwork2.ValidationAwareSupport
setActionMessages(Collection<String>) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
setActionName(String) - Method in class com.opensymphony.xwork2.ActionChainResult
Set the action name.
setActionName(String) - Method in class com.opensymphony.xwork2.mock.MockActionProxy
setActionProxyFactory(ActionProxyFactory) - Method in class com.opensymphony.xwork2.ActionChainResult
setActionValidatorManager(ActionValidatorManager) - Method in class com.opensymphony.xwork2.validator.ValidationInterceptor
setActionValidatorManager(ActionValidatorManager) - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator
setActive(boolean) - Static method in class com.opensymphony.xwork2.util.profiling.UtilTimerStack
Turn profiling on or off.
setAliasesKey(String) - Method in class com.opensymphony.xwork2.interceptor.AliasInterceptor
Sets the name of the action parameter to look for the alias map.
setAllowDuplicates(boolean) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
setAllowed(String) - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor
setAllowedCollection(Collection<String>) - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor
setAllowStaticMethodAccess(String) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStackFactory
setAllowStaticMethodAccess(boolean) - Method in class com.opensymphony.xwork2.ognl.SecurityMemberAccess
setAlwaysInvokePrepare(String) - Method in class com.opensymphony.xwork2.interceptor.PrepareInterceptor
Sets if the preapare method should always be executed.
setAlwaysInvokeValidate(String) - Method in class com.opensymphony.xwork2.validator.ValidationInterceptor
Determines if Validateable's validate() should always be invoked.
setAlwaysRespectAutowireStrategy(boolean) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
Determines if the autowire strategy is always followed when creating beans
setAppendPrefix(boolean) - Method in class com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription
setAppendPrefix(boolean) - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator
Sets whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs.
setApplication(Map<String, Object>) - Method in class com.opensymphony.xwork2.ActionContext
Sets the action's application context.
setApplicationContext(ApplicationContext) - Method in class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor
setApplicationContext(ApplicationContext) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
Set the Spring ApplicationContext that should be used to look beans up with.
setApplicationContextPath(String) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
setAttributeName(String) - Method in class com.opensymphony.xwork2.interceptor.I18nInterceptor
setAutowireStrategy(Integer) - Method in class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor
setAutowireStrategy(int) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
Sets the autowiring strategy
setBlocked(String) - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor
setBlockedCollection(Collection<String>) - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor
setBundle(ResourceBundle) - Method in interface com.opensymphony.xwork2.ResourceBundleTextProvider
Set the resource bundle to use.
setBundle(ResourceBundle) - Method in class com.opensymphony.xwork2.TextProviderSupport
setCaseSensitive(boolean) - Method in class com.opensymphony.xwork2.validator.validators.RegexFieldValidator
Sets whether the expression should be matched against in a case-sensitive way.
setClassAssertionStatus(String, boolean) - Method in class com.opensymphony.xwork2.util.classloader.ReloadingClassLoader
setClassLoader(ClassLoader) - Method in class com.opensymphony.xwork2.ObjectFactory
setClassLoader(ClassLoader) - Method in class com.opensymphony.xwork2.util.ResolverUtil
Sets an explicit ClassLoader that should be used when scanning for classes.
setClassName(String) - Method in class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor
setClazz(Class) - Method in interface com.opensymphony.xwork2.ResourceBundleTextProvider
Set the class to use for reading the resource bundle.
setClazz(Class) - Method in class com.opensymphony.xwork2.TextProviderSupport
setConfig(ActionConfig) - Method in class com.opensymphony.xwork2.mock.MockActionProxy
setConfiguration(Configuration) - Method in class com.opensymphony.xwork2.config.ConfigurationManager
setConfiguration(Configuration) - Method in class com.opensymphony.xwork2.DefaultActionInvocation
setConfiguration(Configuration) - Method in class com.opensymphony.xwork2.DefaultActionProxy
setConfiguration(Configuration) - Method in class com.opensymphony.xwork2.DefaultUnknownHandlerManager
setConfigurationProviders(List<ConfigurationProvider>) - Method in class com.opensymphony.xwork2.config.ConfigurationManager
Deprecated. Since 2.1, use #setContainerProvider()
setContainer(Container) - Method in class com.opensymphony.xwork2.ActionContext
Gets the container for this request
setContainer(Container) - Method in class com.opensymphony.xwork2.DefaultActionInvocation
setContainer(Container) - Method in class com.opensymphony.xwork2.DefaultActionProxyFactory
setContainer(Container) - Method in class com.opensymphony.xwork2.DefaultUnknownHandlerManager
setContainer(Container) - Method in class com.opensymphony.xwork2.ObjectFactory
setContainer(Container) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStackFactory
setContainerProviders(List<ContainerProvider>) - Method in class com.opensymphony.xwork2.config.ConfigurationManager
Set the list of configuration providers
setContext(ActionContext) - Static method in class com.opensymphony.xwork2.ActionContext
Sets the action context for the current thread.
setContext(Container) - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
setContext(String) - Method in class com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription
setContext(String) - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator
setContextMap(Map<String, Object>) - Method in class com.opensymphony.xwork2.ActionContext
Sets the action's context map.
setConversionErrors(Map<String, Object>) - Method in class com.opensymphony.xwork2.ActionContext
Sets conversion errors which occurred when executing the action.
setCreatingNullObjects(Map<String, Object>, boolean) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
setDeclarative(boolean) - Method in class com.opensymphony.xwork2.validator.ValidationInterceptor
Determines if validation based on annotations or xml should be performed.
setDefaultAssertionStatus(boolean) - Method in class com.opensymphony.xwork2.util.classloader.ReloadingClassLoader
setDefaultBlock(boolean) - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor
setDefaultMessage(String) - Method in interface com.opensymphony.xwork2.validator.Validator
Sets the default message to use for validation failure
setDefaultMessage(String) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
setDefaultResultParam(String) - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig
setDefaultType(Class) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
setDefaultType(Class) - Method in interface com.opensymphony.xwork2.util.ValueStack
Sets the default type to convert to if no type is provided when getting a value.
setDefaultTypeConverter(XWorkBasicConverter) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
setDelegatedClassLoader(ClassLoader) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Sets a ClassLoader to look up the bundle from if none can be found on the current thread's classloader
setDenyMethodExecution(Map<String, Object>, boolean) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
setDevMode(String) - Static method in class com.opensymphony.xwork2.interceptor.AliasInterceptor
setDevMode(String) - Static method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
setDevMode(String) - Static method in class com.opensymphony.xwork2.interceptor.StaticParametersInterceptor
setDevMode(String) - Static method in class com.opensymphony.xwork2.ognl.accessor.CompoundRootAccessor
setDevMode(String) - Static method in class com.opensymphony.xwork2.ognl.OgnlUtil
setDevMode(String) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
setDocumentLocator(Locator) - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
setDocumentLocator(Locator) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler
setDocumentLocator(Locator) - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe
setDtdMappings(Map<String, String>) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
setElementClass(Class) - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer
setEnableExpressionCache(String) - Static method in class com.opensymphony.xwork2.ognl.OgnlUtil
setEndTime() - Method in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean
setExcludeMethods(String) - Method in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
setExcludeParams(String) - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
Sets a comma-delimited list of regular expressions to match parameters that should be removed from the parameter map.
setExcludeProperties(Set<Pattern>) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
setExcludeProperties(Set<Pattern>) - Method in class com.opensymphony.xwork2.ognl.SecurityMemberAccess
setExcludeProperties(Set<Pattern>) - Method in interface com.opensymphony.xwork2.util.MemberAccessValueStack
setExcludes(Collection<String>) - Method in class com.opensymphony.xwork2.interceptor.ChainingInterceptor
Sets the list of parameter names to exclude from copying (all others will be included).
setExecuteResult(boolean) - Method in interface com.opensymphony.xwork2.ActionProxy
Sets whether this ActionProxy should also execute the Result after executing the Action.
setExecuteResult(boolean) - Method in class com.opensymphony.xwork2.DefaultActionProxy
setExecuteResult(boolean) - Method in class com.opensymphony.xwork2.mock.MockActionProxy
setExpectedFoo(String) - Method in class com.opensymphony.xwork2.mock.MockInterceptor
setExpression(String) - Method in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription
setExpression(String) - Method in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
setExpression(String) - Method in class com.opensymphony.xwork2.validator.validators.ConditionalVisitorFieldValidator
setExpression(String) - Method in class com.opensymphony.xwork2.validator.validators.ExpressionValidator
setExpression(String) - Method in class com.opensymphony.xwork2.validator.validators.FieldExpressionValidator
setExpression(String) - Method in class com.opensymphony.xwork2.validator.validators.RegexFieldValidator
Sets the regular expression to be matched.
setExprOverrides(Map<Object, Object>) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
setExprOverrides(Map<Object, Object>) - Method in interface com.opensymphony.xwork2.util.ValueStack
Set a override map containing key -> values that takes precedent when doing find operations on the ValueStack.
setFieldErrors(Map<String, List<String>>) - Method in class com.opensymphony.xwork2.ActionSupport
setFieldErrors(Map<String, List<String>>) - Method in interface com.opensymphony.xwork2.ValidationAware
Set the field error map of fieldname (String) to Collection of String error messages.
setFieldErrors(Map<String, List<String>>) - Method in class com.opensymphony.xwork2.ValidationAwareSupport
setFieldErrors(Map<String, List<String>>) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
setFieldName(String) - Method in interface com.opensymphony.xwork2.validator.FieldValidator
Sets the field name to validate with this FieldValidator
setFieldName(String) - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Sets the field name for this validator rule.
setFieldName(String) - Method in class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
setFoo(String) - Method in class com.opensymphony.xwork2.mock.MockInterceptor
setFullPropertyPath(Map<String, Object>, String) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
setFullQualifiedClassName(String) - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
The fullQualifiedClassName attribute is used to create the special conversion.properties file name.
setGettingByKeyProperty(Map<String, Object>, boolean) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
setIncludeMethods(String) - Method in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
setIncludes(Collection<String>) - Method in class com.opensymphony.xwork2.interceptor.ChainingInterceptor
Sets the list of parameter names to include when copying (all others will be excluded).
setInputResultName(String) - Method in class com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor
Set the inputResultName (result name to be returned when a action / field error is found registered).
setInvocation(ActionInvocation) - Method in class com.opensymphony.xwork2.mock.MockActionProxy
setInvocationContext(ActionContext) - Method in class com.opensymphony.xwork2.mock.MockActionInvocation
setKey(String) - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Sets the I18N message key.
setKey(String) - Method in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription
setKey(String) - Method in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
setKey(String) - Method in interface com.opensymphony.xwork2.validator.metadata.ValidatorDescription
Sets the I18N message key.
setKeyClass(Class) - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer
setKeyProperty(String) - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer
setLastBeanClassAccessed(Map<String, Object>, Class) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
setLastBeanPropertyAccessed(Map<String, Object>, String) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
setLastClassAccessed(Class) - Method in class com.opensymphony.xwork2.ognl.ObjectProxy
setLastPropertyAccessed(String) - Method in class com.opensymphony.xwork2.ognl.ObjectProxy
setLocale(Locale) - Method in class com.opensymphony.xwork2.ActionContext
Sets the Locale for the current action.
setLocaleProvider(LocaleProvider) - Method in interface com.opensymphony.xwork2.ResourceBundleTextProvider
Set the LocaleProvider to use.
setLocaleProvider(LocaleProvider) - Method in class com.opensymphony.xwork2.TextProviderSupport
setLocation(Location) - Method in class com.opensymphony.xwork2.util.location.Located
Set the location of this object
setLogCategory(String) - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
setLogCategory(String) - Method in class com.opensymphony.xwork2.interceptor.TimerInterceptor
setLogEnabled(boolean) - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
setLoggerFactory(LoggerFactory) - Static method in class com.opensymphony.xwork2.util.logging.LoggerFactory
setLoggerFactory(LoggerFactory) - Method in class com.opensymphony.xwork2.XWork
setLogLevel(String) - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
setLogLevel(String) - Method in class com.opensymphony.xwork2.interceptor.TimerInterceptor
setLogMissingProperties(String) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
setMax(String) - Method in class com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription
setMax(String) - Method in class com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription
setMax(String) - Method in class com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription
setMax(Date) - Method in class com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator
setMax(Integer) - Method in class com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator
setMax(Long) - Method in class com.opensymphony.xwork2.validator.validators.LongRangeFieldValidator
setMax(Short) - Method in class com.opensymphony.xwork2.validator.validators.ShortRangeFieldValidator
setMaxExclusive(String) - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator
setMaxInclusive(String) - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator
setMaxLength(String) - Method in class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription
setMaxLength(int) - Method in class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator
setMerge(String) - Method in class com.opensymphony.xwork2.interceptor.StaticParametersInterceptor
setMessage(String) - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Sets the default validator failure message.
setMessage(String) - Method in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription
setMessage(String) - Method in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
setMessage(String) - Method in interface com.opensymphony.xwork2.validator.metadata.ValidatorDescription
Sets the default validator failure message.
setMessageKey(String) - Method in interface com.opensymphony.xwork2.validator.Validator
Sets a resource bundle key to be used for lookup of validation failure message
setMessageKey(String) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
setMessageParameters(String[]) - Method in interface com.opensymphony.xwork2.validator.Validator
Sets the messsage parameters to be used when parsing i18n messages
setMessageParameters(String[]) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
setMethod(String) - Method in class com.opensymphony.xwork2.ActionChainResult
setMethod(String) - Method in class com.opensymphony.xwork2.mock.MockActionProxy
setMin(String) - Method in class com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription
setMin(String) - Method in class com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription
setMin(String) - Method in class com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription
setMin(Date) - Method in class com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator
setMin(Integer) - Method in class com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator
setMin(Long) - Method in class com.opensymphony.xwork2.validator.validators.LongRangeFieldValidator
setMin(Short) - Method in class com.opensymphony.xwork2.validator.validators.ShortRangeFieldValidator
setMinExclusive(String) - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator
setMinInclusive(String) - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator
setMinLength(String) - Method in class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription
setMinLength(int) - Method in class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator
setModel(T) - Method in interface com.opensymphony.xwork2.interceptor.ScopedModelDriven
Sets the model
setMultiTextvalueSeparator(String) - Method in class com.opensymphony.xwork2.validator.DefaultValidatorFileParser
setName(String) - Method in class com.opensymphony.xwork2.ActionContext
Sets the name of the current Action in the ActionContext.
setName(String) - Method in class com.opensymphony.xwork2.config.entities.UnknownHandlerConfig
setName(String) - Method in class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor
setNamespace(String) - Method in class com.opensymphony.xwork2.ActionChainResult
sets the namespace of the Action that we're chaining to.
setNamespace(String) - Method in class com.opensymphony.xwork2.mock.MockActionProxy
setObjectFactory(ObjectFactory) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
setObjectFactory(ObjectFactory) - Method in class com.opensymphony.xwork2.conversion.impl.InstantiatingNullHandler
setObjectFactory(ObjectFactory) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkBasicConverter
setObjectFactory(ObjectFactory) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
setObjectFactory(ObjectFactory) - Method in class com.opensymphony.xwork2.DefaultActionInvocation
setObjectFactory(ObjectFactory) - Method in class com.opensymphony.xwork2.DefaultActionProxy
setObjectFactory(ObjectFactory) - Method in class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor
setObjectFactory(ObjectFactory) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkCollectionPropertyAccessor
setObjectFactory(ObjectFactory) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkListPropertyAccessor
setObjectFactory(ObjectFactory) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkMapPropertyAccessor
setObjectFactory(ObjectFactory) - Method in class com.opensymphony.xwork2.validator.DefaultValidatorFileParser
setObjectTypeDeterminer(ObjectTypeDeterminer) - Method in class com.opensymphony.xwork2.conversion.impl.InstantiatingNullHandler
setObjectTypeDeterminer(ObjectTypeDeterminer) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkBasicConverter
setObjectTypeDeterminer(ObjectTypeDeterminer) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkCollectionPropertyAccessor
setObjectTypeDeterminer(ObjectTypeDeterminer) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkListPropertyAccessor
setObjectTypeDeterminer(ObjectTypeDeterminer) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkMapPropertyAccessor
setOgnlUtil(OgnlUtil) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkListPropertyAccessor
setOgnlUtil(OgnlUtil) - Method in class com.opensymphony.xwork2.ognl.OgnlReflectionProvider
setOgnlUtil(OgnlUtil) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
setOrdered(boolean) - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
Set whether to order the parameters by object depth or not
setOverwrite(String) - Method in class com.opensymphony.xwork2.interceptor.StaticParametersInterceptor
Overwrites already existing parameters from other sources.
setPackageAssertionStatus(String, boolean) - Method in class com.opensymphony.xwork2.util.classloader.ReloadingClassLoader
setParameterName(String) - Method in class com.opensymphony.xwork2.interceptor.I18nInterceptor
setParameters(Map<String, Object>) - Method in class com.opensymphony.xwork2.ActionContext
Sets the action parameters.
setParameters(Object, ValueStack, Map<String, Object>) - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
setParamNames(String) - Method in class com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor
Allows paramNames attribute to be set as comma-separated-values (csv).
setParams(Map<String, String>) - Method in interface com.opensymphony.xwork2.config.entities.Parameterizable
setParamValues(String) - Method in class com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor
Allows paramValues attribute to be set as a comma-separated-values (csv).
setParse(String) - Method in class com.opensymphony.xwork2.interceptor.StaticParametersInterceptor
setParse(boolean) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
setPattern(String) - Method in class com.opensymphony.xwork2.util.ClassPathFinder
sets the String pattern for comparing filenames
setPatternMatcher(PatternMatcher<int[]>) - Method in class com.opensymphony.xwork2.util.ClassPathFinder
sets the PatternMatcher implementation to use when comparing filenames
setProgrammatic(boolean) - Method in class com.opensymphony.xwork2.validator.ValidationInterceptor
Determines if Validateable's validate() should be called, as well as methods whose name that start with "validate".
setProperties(Map<String, String>, Object, Map<String, Object>) - Method in class com.opensymphony.xwork2.ognl.OgnlReflectionProvider
setProperties(Map<String, String>, Object, Map<String, Object>, boolean) - Method in class com.opensymphony.xwork2.ognl.OgnlReflectionProvider
setProperties(Map<String, String>, Object) - Method in class com.opensymphony.xwork2.ognl.OgnlReflectionProvider
setProperties(Map<String, ?>, Object, Map<String, Object>) - Method in class com.opensymphony.xwork2.ognl.OgnlUtil
Sets the object's properties using the default type converter, defaulting to not throw exceptions for problems setting the properties.
setProperties(Map<String, ?>, Object, Map<String, Object>, boolean) - Method in class com.opensymphony.xwork2.ognl.OgnlUtil
Sets the object's properties using the default type converter.
setProperties(Map<String, ?>, Object) - Method in class com.opensymphony.xwork2.ognl.OgnlUtil
Sets the properties on the object using the default context, defaulting to not throwing exceptions for problems setting the properties.
setProperties(Map<String, ?>, Object, boolean) - Method in class com.opensymphony.xwork2.ognl.OgnlUtil
Sets the properties on the object using the default context.
setProperties(Map<String, String>, Object, Map<String, Object>) - Method in interface com.opensymphony.xwork2.util.reflection.ReflectionProvider
Sets the object's properties using the default type converter, defaulting to not throw exceptions for problems setting the properties.
setProperties(Map<String, String>, Object, Map<String, Object>, boolean) - Method in interface com.opensymphony.xwork2.util.reflection.ReflectionProvider
Sets the object's properties using the default type converter.
setProperties(Map<String, String>, Object) - Method in interface com.opensymphony.xwork2.util.reflection.ReflectionProvider
Sets the properties on the object using the default context, defaulting to not throwing exceptions for problems setting the properties.
setProperty(String) - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
Sets the property name to be inserted into the related conversion.properties file.
Note: Do not add COLLECTION_PREFIX or MAP_PREFIX keys to property names.
setProperty(Map, Object, Object, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.CompoundRootAccessor
setProperty(Map, Object, Object, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.ObjectAccessor
setProperty(Map, Object, Object, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.ObjectProxyPropertyAccessor
setProperty(Map, Object, Object, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkCollectionPropertyAccessor
setProperty(Map, Object, Object, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkEnumerationAccessor
setProperty(Map, Object, Object, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkIteratorPropertyAccessor
setProperty(Map, Object, Object, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkListPropertyAccessor
setProperty(Map, Object, Object, Object) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkMapPropertyAccessor
setProperty(String, Object, Object, Map<String, Object>) - Method in class com.opensymphony.xwork2.ognl.OgnlReflectionProvider
setProperty(String, Object, Object, Map<String, Object>, boolean) - Method in class com.opensymphony.xwork2.ognl.OgnlReflectionProvider
setProperty(String, Object, Object, Map<String, Object>) - Method in class com.opensymphony.xwork2.ognl.OgnlUtil
Sets the named property to the supplied value on the Object, defaults to not throwing property exceptions.
setProperty(String, Object, Object, Map<String, Object>, boolean) - Method in class com.opensymphony.xwork2.ognl.OgnlUtil
Sets the named property to the supplied value on the Object.
setProperty(String, String, Object) - Method in class com.opensymphony.xwork2.util.location.LocatableProperties
setProperty(String, Object, Object, Map<String, Object>, boolean) - Method in interface com.opensymphony.xwork2.util.reflection.ReflectionProvider
Sets the named property to the supplied value on the Object,
setProperty(String, Object, Object, Map<String, Object>) - Method in interface com.opensymphony.xwork2.util.reflection.ReflectionProvider
Sets the named property to the supplied value on the Object, defaults to not throwing property exceptions.
setProxy(ActionProxy) - Method in class com.opensymphony.xwork2.mock.MockActionInvocation
setReflectionProvider(ReflectionProvider) - Method in class com.opensymphony.xwork2.conversion.impl.InstantiatingNullHandler
setReflectionProvider(ReflectionProvider) - Method in class com.opensymphony.xwork2.interceptor.ChainingInterceptor
setReflectionProvider(ReflectionProvider) - Method in class com.opensymphony.xwork2.ObjectFactory
setRefreshModelBeforeResult(boolean) - Method in class com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor
setReloadBundles(boolean) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Should resorce bundles be reloaded.
setReloadingConfigs(boolean) - Static method in class com.opensymphony.xwork2.util.FileManager
setRepopulateField(String) - Method in class com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport
setReportingConversionErrors(Map<String, Object>, boolean) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
setRequestOnlyParameterName(String) - Method in class com.opensymphony.xwork2.interceptor.I18nInterceptor
setResult(Result) - Method in class com.opensymphony.xwork2.mock.MockActionInvocation
setResultCode(String) - Method in interface com.opensymphony.xwork2.ActionInvocation
Sets the result code, possibly overriding the one returned by the action.
setResultCode(String) - Method in class com.opensymphony.xwork2.DefaultActionInvocation
setResultCode(String) - Method in class com.opensymphony.xwork2.mock.MockActionInvocation
setReturnedResult(String) - Method in class com.opensymphony.xwork2.mock.MockActionProxy
setRoot(XWorkConverter, CompoundRootAccessor, CompoundRoot, boolean) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
setRule(String) - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
Sets the rule prefix for COLLECTION_PREFIX or MAP_PREFIX key.
setScope(String) - Method in class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor
setScopeKey(String) - Method in interface com.opensymphony.xwork2.interceptor.ScopedModelDriven
Sets the key under which the model is stored
setScopeStrategy(Scope.Strategy) - Method in interface com.opensymphony.xwork2.inject.Container
Sets the scope strategy for the current thread.
setSession(Map<String, Object>) - Method in class com.opensymphony.xwork2.ActionContext
Sets a map of action session values.
setSetMap(Map<String, Object>, Map<Object, Object>, String) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
setShortCircuit(boolean) - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Set the shortCircuit flag.
setShortCircuit(boolean) - Method in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription
setShortCircuit(boolean) - Method in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
setShortCircuit(boolean) - Method in interface com.opensymphony.xwork2.validator.metadata.ValidatorDescription
Set the shortCircuit flag.
setShortCircuit(boolean) - Method in interface com.opensymphony.xwork2.validator.ShortCircuitableValidator
Sets whether this field validator should short circuit the validator queue it's in if validation fails.
setShortCircuit(boolean) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
setShouldCreateIfNew(boolean) - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer
setSimpleValidator(boolean) - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
setSkipActions(String) - Method in class com.opensymphony.xwork2.ActionChainResult
Set the list of actions to skip.
setStack(ValueStack) - Method in class com.opensymphony.xwork2.mock.MockActionInvocation
setStartTime() - Method in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean
setTextProvider(TextProvider) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStackFactory
setTextProvider(TextProvider) - Method in class com.opensymphony.xwork2.TextProviderFactory
setTextProvider(TextProvider) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
setThrowExceptionOnDuplicateBeans(boolean) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
setTrim(boolean) - Method in class com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription
setTrim(boolean) - Method in class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription
setTrim(boolean) - Method in class com.opensymphony.xwork2.validator.validators.RegexFieldValidator
Sets whether the expression should be trimed before matching.
setTrim(boolean) - Method in class com.opensymphony.xwork2.validator.validators.RequiredStringValidator
setTrim(boolean) - Method in class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator
setType(String) - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
setTypeConverter(String) - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
Sets the class name of the type converter to be used.
setUnknownHandler(UnknownHandlerManager) - Method in class com.opensymphony.xwork2.DefaultActionProxy
setUnknownHandlerManager(UnknownHandlerManager) - Method in class com.opensymphony.xwork2.DefaultActionInvocation
setUnknownHandlerStack(List<UnknownHandlerConfig>) - Method in interface com.opensymphony.xwork2.config.Configuration
setUnknownHandlerStack(List<UnknownHandlerConfig>) - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
setUnknownHandlerStack(List<UnknownHandlerConfig>) - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration
setUp() - Method in class com.opensymphony.xwork2.TestNGXWorkTestCase
setUp() - Static method in class com.opensymphony.xwork2.util.XWorkTestCaseHelper
setUp() - Method in class com.opensymphony.xwork2.XWorkTestCase
setUseClassCache(boolean) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
Enable / disable caching of classes loaded by Spring.
setValidateAnnotatedMethodOnly(boolean) - Method in class com.opensymphony.xwork2.validator.ValidationInterceptor
Determine if validate() should always be called or only per annotated method.
setValidationAware(ValidationAware) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext
setValidatorContext(ValidatorContext) - Method in interface com.opensymphony.xwork2.validator.Validator
This method will be called before validate with a non-null ValidatorContext.
setValidatorContext(ValidatorContext) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
setValidatorFactory(ValidatorFactory) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
setValidatorFactory(ValidatorFactory) - Method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
setValidatorFileParser(ValidatorFileParser) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
setValidatorFileParser(ValidatorFileParser) - Method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
setValidatorType(String) - Method in interface com.opensymphony.xwork2.validator.Validator
Sets the validator type to use (see class javadoc).
setValidatorType(String) - Method in class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
setValidatorType(String) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
setValue(String) - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
setValue(Object) - Method in class com.opensymphony.xwork2.ognl.ObjectProxy
setValue(String, Map<String, Object>, Object, Object) - Method in class com.opensymphony.xwork2.ognl.OgnlReflectionProvider
setValue(String, Map<String, Object>, Object, Object) - Method in class com.opensymphony.xwork2.ognl.OgnlUtil
Wrapper around Ognl.setValue() to handle type conversion for collection elements.
setValue(String, Object) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
setValue(String, Object, boolean) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
setValue(String, Map<String, Object>, Object, Object) - Method in interface com.opensymphony.xwork2.util.reflection.ReflectionProvider
Evaluates the given OGNL expression to insert a value into the object graph rooted at the given root object given the context.
setValue(String, Object) - Method in interface com.opensymphony.xwork2.util.ValueStack
Attempts to set a property on a bean in the stack with the given expression using the default search order.
setValue(String, Object, boolean) - Method in interface com.opensymphony.xwork2.util.ValueStack
Attempts to set a property on a bean in the stack with the given expression using the default search order.
setValueStack(ValueStack) - Method in class com.opensymphony.xwork2.ActionContext
Sets the OGNL value stack.
setValueStack(ValueStack) - Method in interface com.opensymphony.xwork2.validator.Validator
Sets the value stack to use to resolve values and parameters
setValueStack(ValueStack) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
setValueStackFactory(ValueStackFactory) - Method in class com.opensymphony.xwork2.DefaultActionInvocation
setValueStackFactory(ValueStackFactory) - Method in class com.opensymphony.xwork2.interceptor.AliasInterceptor
setValueStackFactory(ValueStackFactory) - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
setValueStackFactory(ValueStackFactory) - Method in class com.opensymphony.xwork2.interceptor.StaticParametersInterceptor
setXWorkCollectionPropertyAccessor(PropertyAccessor) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkListPropertyAccessor
setXWorkConverter(XWorkConverter) - Method in class com.opensymphony.xwork2.conversion.impl.XWorkBasicConverter
setXWorkConverter(XWorkConverter) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkCollectionPropertyAccessor
setXWorkConverter(XWorkConverter) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkListPropertyAccessor
setXWorkConverter(XWorkConverter) - Method in class com.opensymphony.xwork2.ognl.accessor.XWorkMapPropertyAccessor
setXWorkConverter(XWorkConverter) - Method in class com.opensymphony.xwork2.ognl.OgnlUtil
setXWorkConverter(XWorkConverter) - Method in class com.opensymphony.xwork2.ognl.OgnlValueStackFactory
shortCircuit - Variable in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
shortCircuit - Variable in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription
shortCircuit - Variable in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
shortCircuit(boolean) - Method in class com.opensymphony.xwork2.validator.ValidatorConfig.Builder
ShortCircuitableValidator - Interface in com.opensymphony.xwork2.validator
This interface should be implemented by validators that can short-circuit the validator queue that it is in.
ShortRangeFieldValidator - Class in com.opensymphony.xwork2.validator.validators
Field Validator that checks if the short specified is within a certain range.
ShortRangeFieldValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.ShortRangeFieldValidator
shouldAddError(String, Object) - Method in class com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor
shouldCreateIfNew(Class, String, Object, String, boolean) - Method in class com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer
Determines the createIfNull property for a Collection or Map by getting it from the @CreateIfNull annotation.
shouldCreateIfNew(Class, String, Object, String, boolean) - Method in interface com.opensymphony.xwork2.conversion.ObjectTypeDeterminer
shouldCreateIfNew(Class, String, Object, String, boolean) - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer
shouldLog() - Method in class com.opensymphony.xwork2.interceptor.TimerInterceptor
Determines if we should log the time.
simpleValidator - Variable in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
size() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
size() - Method in class com.opensymphony.xwork2.ognl.OgnlValueStack
size() - Method in interface com.opensymphony.xwork2.util.ValueStack
Get the number of objects in the stack
SKIP_ACTIONS_PARAM - Static variable in class com.opensymphony.xwork2.ActionChainResult
The result parameter name to set the name of the action to chain to.
skippedEntity(String) - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
skippedEntity(String) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler
skippedEntity(String) - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe
SpringObjectFactory - Class in com.opensymphony.xwork2.spring
Simple implementation of the ObjectFactory that makes use of Spring's application context if one has been configured, before falling back on the default mechanism of instantiating a new class using the class name.
SpringObjectFactory() - Constructor for class com.opensymphony.xwork2.spring.SpringObjectFactory
SpringProxyableObjectFactory - Class in com.opensymphony.xwork2.spring
SpringProxyableObjectFactory.
SpringProxyableObjectFactory() - Constructor for class com.opensymphony.xwork2.spring.SpringProxyableObjectFactory
SRC_ATTR - Static variable in class com.opensymphony.xwork2.util.location.LocationAttributes
Attribute name for the location URI
stack - Variable in class com.opensymphony.xwork2.DefaultActionInvocation
startDocument() - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
startDocument() - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler
startDocument() - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe
startElement(String, String, String, Attributes) - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
startElement(String, String, String, Attributes) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler
startElement(String, String, String, Attributes) - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe
startPrefixMapping(String, String) - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
startPrefixMapping(String, String) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler
startPrefixMapping(String, String) - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe
StaticParametersInterceptor - Class in com.opensymphony.xwork2.interceptor
This interceptor populates the action with the static parameters defined in the action configuration.
StaticParametersInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.StaticParametersInterceptor
StringLengthFieldValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator checks that a String field is of the right length.
StringLengthFieldValidator - Class in com.opensymphony.xwork2.validator.validators
StringLengthFieldValidator checks that a String field is of a certain length.
StringLengthFieldValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator
StringLengthFieldValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
StringLengthFieldValidatorDescription
StringLengthFieldValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription
StringLengthFieldValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.
Strings - Class in com.opensymphony.xwork2.inject.util
String utilities.
Strings() - Constructor for class com.opensymphony.xwork2.inject.util.Strings
stringValue(Object, boolean) - Static method in class com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
Evaluates the given object as a String and trims it if the trim flag is true.
stringValue(Object) - Static method in class com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
Evaluates the given object as a String.
StubConfigurationProvider - Class in com.opensymphony.xwork2.test
StubConfigurationProvider() - Constructor for class com.opensymphony.xwork2.test.StubConfigurationProvider
SUCCESS - Static variable in interface com.opensymphony.xwork2.Action
The action execution was successful.

T

tearDown() - Method in class com.opensymphony.xwork2.TestNGXWorkTestCase
tearDown(ConfigurationManager) - Static method in class com.opensymphony.xwork2.util.XWorkTestCaseHelper
tearDown() - Method in class com.opensymphony.xwork2.XWorkTestCase
Test<T> - Interface in com.opensymphony.xwork2.util.finder
This is the testing interface that is used to accept or reject resources.
test(T) - Method in interface com.opensymphony.xwork2.util.finder.Test
The test method.
TestNGXWorkTestCase - Class in com.opensymphony.xwork2
Base test class for TestNG unit tests.
TestNGXWorkTestCase() - Constructor for class com.opensymphony.xwork2.TestNGXWorkTestCase
TextParseUtil - Class in com.opensymphony.xwork2.util
Utility class for text parsing.
TextParseUtil() - Constructor for class com.opensymphony.xwork2.util.TextParseUtil
TextParseUtil.ParsedValueEvaluator - Interface in com.opensymphony.xwork2.util
A parsed value evaluator for TextParseUtil.
TextProvider - Interface in com.opensymphony.xwork2
Provides access to ResourceBundles and their underlying text messages.
TextProviderFactory - Class in com.opensymphony.xwork2
This factory enables users to provide and correctly initialize a custom TextProvider.
TextProviderFactory() - Constructor for class com.opensymphony.xwork2.TextProviderFactory
TextProviderSupport - Class in com.opensymphony.xwork2
Default TextProvider implementation.
TextProviderSupport() - Constructor for class com.opensymphony.xwork2.TextProviderSupport
Default constructor
TextProviderSupport(Class, LocaleProvider) - Constructor for class com.opensymphony.xwork2.TextProviderSupport
Constructor.
TextProviderSupport(ResourceBundle, LocaleProvider) - Constructor for class com.opensymphony.xwork2.TextProviderSupport
Constructor.
TimerInterceptor - Class in com.opensymphony.xwork2.interceptor
This interceptor logs the amount of time in milliseconds.
TimerInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.TimerInterceptor
toString() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig
toString() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig.Builder
toString() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
toString() - Method in class com.opensymphony.xwork2.config.impl.LocatableConstantFactory
toString() - Method in class com.opensymphony.xwork2.config.impl.LocatableFactory
toString() - Method in enum com.opensymphony.xwork2.conversion.annotations.ConversionRule
toString() - Method in enum com.opensymphony.xwork2.conversion.annotations.ConversionType
toString() - Method in class com.opensymphony.xwork2.util.classloader.FileResourceStore
toString() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.AnnotationInfo
toString() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.ClassInfo
toString() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.FieldInfo
toString() - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.MethodInfo
toString() - Method in class com.opensymphony.xwork2.util.location.LocationImpl
toString(Location) - Static method in class com.opensymphony.xwork2.util.location.LocationUtils
Builds a string representation of a location, in the "descripton - uri:line:column" format (e.g.
toString() - Method in class com.opensymphony.xwork2.util.ResolverUtil.AnnotatedWith
toString() - Method in class com.opensymphony.xwork2.util.ResolverUtil.IsA
toString() - Method in class com.opensymphony.xwork2.util.ResolverUtil.NameEndsWith
toString() - Method in class com.opensymphony.xwork2.util.ResolverUtil.NameIs
toString() - Method in enum com.opensymphony.xwork2.validator.annotations.ValidatorType
toString() - Method in exception com.opensymphony.xwork2.XWorkException
Returns a short description of this throwable object, including the location.
trace(String, String...) - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLogger
trace(String, Throwable, String...) - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLogger
trace(String, String...) - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLogger
trace(String, Throwable, String...) - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLogger
trace(String, String...) - Method in interface com.opensymphony.xwork2.util.logging.Logger
trace(String, Throwable, String...) - Method in interface com.opensymphony.xwork2.util.logging.Logger
translateVariables(String, ValueStack) - Static method in class com.opensymphony.xwork2.util.TextParseUtil
Converts all instances of ${...}, and %{...} in expression to the value returned by a call to ValueStack.findValue(java.lang.String).
translateVariables(String, ValueStack, TextParseUtil.ParsedValueEvaluator) - Static method in class com.opensymphony.xwork2.util.TextParseUtil
Function similarly as TextParseUtil.translateVariables(char, String, ValueStack) except for the introduction of an additional evaluator that allows the parsed value to be evaluated by the evaluator.
translateVariables(char, String, ValueStack) - Static method in class com.opensymphony.xwork2.util.TextParseUtil
Converts all instances of ${...} in expression to the value returned by a call to ValueStack.findValue(java.lang.String).
translateVariables(char, String, ValueStack, Class) - Static method in class com.opensymphony.xwork2.util.TextParseUtil
Converted object from variable translation.
translateVariables(char, String, ValueStack, Class, TextParseUtil.ParsedValueEvaluator) - Static method in class com.opensymphony.xwork2.util.TextParseUtil
Converted object from variable translation.
translateVariables(char[], String, ValueStack, Class, TextParseUtil.ParsedValueEvaluator) - Static method in class com.opensymphony.xwork2.util.TextParseUtil
Converted object from variable translation.
translateVariables(char, String, ValueStack, Class, TextParseUtil.ParsedValueEvaluator, int) - Static method in class com.opensymphony.xwork2.util.TextParseUtil
Converted object from variable translation.
translateVariables(char[], String, ValueStack, Class, TextParseUtil.ParsedValueEvaluator, int) - Static method in class com.opensymphony.xwork2.util.TextParseUtil
Converted object from variable translation.
trim - Variable in class com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription
trim - Variable in class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription
type - Variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
TYPE_CONVERTER - Static variable in class com.opensymphony.xwork2.ActionContext
Constant for the action's type converter.
TYPE_CONVERTER_CONTEXT_KEY - Static variable in interface com.opensymphony.xwork2.conversion.TypeConverter
TypeConversion - Annotation Type in com.opensymphony.xwork2.conversion.annotations

This annotation is used for class and application wide conversion rules.

TypeConversionException - Exception in com.opensymphony.xwork2.conversion
TypeConversionException should be thrown by any TypeConverters which fail to convert values
TypeConversionException() - Constructor for exception com.opensymphony.xwork2.conversion.TypeConversionException
Constructs a XWorkException with no detail message.
TypeConversionException(String) - Constructor for exception com.opensymphony.xwork2.conversion.TypeConversionException
Constructs a XWorkException with the specified detail message.
TypeConversionException(Throwable) - Constructor for exception com.opensymphony.xwork2.conversion.TypeConversionException
Constructs a XWorkException with no detail message.
TypeConversionException(String, Throwable) - Constructor for exception com.opensymphony.xwork2.conversion.TypeConversionException
Constructs a XWorkException with the specified detail message.
typeConverter - Variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
TypeConverter - Interface in com.opensymphony.xwork2.conversion
Interface for accessing the type conversion facilities within a context.

U

Unchainable - Interface in com.opensymphony.xwork2
Simple marker interface to indicate an object should not have its properties copied during chaining.
unescapeJava(String, char) - Static method in class com.opensymphony.xwork2.util.PropertiesReader
Unescapes any Java literals found in the String to a Writer.
unescapeJava(String) - Static method in class com.opensymphony.xwork2.util.PropertiesReader
Unescapes any Java literals found in the String.
unescapeJava(Writer, String) - Static method in class com.opensymphony.xwork2.util.PropertiesReader
Unescapes any Java literals found in the String to a Writer.
UNKNOWN - Static variable in interface com.opensymphony.xwork2.util.location.Location
Constant for unknown locations.
UNKNOWN_STRING - Static variable in class com.opensymphony.xwork2.util.location.LocationUtils
The string representation of an unknown location: "[unknown location]".
UnknownHandler - Interface in com.opensymphony.xwork2
Handles cases when the result or action is unknown.
UnknownHandlerConfig - Class in com.opensymphony.xwork2.config.entities
UnknownHandlerConfig(String) - Constructor for class com.opensymphony.xwork2.config.entities.UnknownHandlerConfig
unknownHandlerManager - Variable in class com.opensymphony.xwork2.DefaultActionInvocation
unknownHandlerManager - Variable in class com.opensymphony.xwork2.DefaultActionProxy
UnknownHandlerManager - Interface in com.opensymphony.xwork2
An unknown handler manager contains a list of UnknownHandler and iterates on them by order
unknownHandlers - Variable in class com.opensymphony.xwork2.DefaultUnknownHandlerManager
unknownHandlerStack - Variable in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
unknownHandlerStack - Variable in class com.opensymphony.xwork2.config.impl.MockConfiguration
unknownMappings - Variable in class com.opensymphony.xwork2.conversion.impl.XWorkConverter
Record classes that doesn't have conversion mapping defined.
updateCurrentPropertyPath(Map<String, Object>, Object) - Static method in class com.opensymphony.xwork2.util.reflection.ReflectionContextState
URI - Static variable in class com.opensymphony.xwork2.util.location.LocationAttributes
Namespace URI for location attributes
UrlSet - Class in com.opensymphony.xwork2.util.finder
Use with ClassFinder to filter the Urls to be scanned, example:
UrlSet(ClassLoaderInterface) - Constructor for class com.opensymphony.xwork2.util.finder.UrlSet
UrlSet(ClassLoaderInterface, Set<String>) - Constructor for class com.opensymphony.xwork2.util.finder.UrlSet
UrlSet(URL...) - Constructor for class com.opensymphony.xwork2.util.finder.UrlSet
UrlSet(Collection<URL>) - Constructor for class com.opensymphony.xwork2.util.finder.UrlSet
Ignores all URLs that are not "jar" or "file"
URLUtil - Class in com.opensymphony.xwork2.util
Helper class to extract file paths from different urls
URLUtil() - Constructor for class com.opensymphony.xwork2.util.URLUtil
UrlValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator checks that a field is a valid URL.
URLValidator - Class in com.opensymphony.xwork2.validator.validators
URLValidator checks that a given field is a String and a valid URL

fieldName - The field name this validator is validating.

URLValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.URLValidator
URLValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
URLValidatorDescription
URLValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.URLValidatorDescription
URLValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.URLValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified aliasNames.
UtilTimerStack - Class in com.opensymphony.xwork2.util.profiling
A timer stack.
UtilTimerStack() - Constructor for class com.opensymphony.xwork2.util.profiling.UtilTimerStack
UtilTimerStack.ProfilingBlock<T> - Interface in com.opensymphony.xwork2.util.profiling
A callback interface where code subjected to profile is to be executed.

V

validate() - Method in class com.opensymphony.xwork2.ActionSupport
A default implementation that validates nothing.
validate() - Method in interface com.opensymphony.xwork2.Validateable
Performs validation.
validate(Object, String) - Method in interface com.opensymphony.xwork2.validator.ActionValidatorManager
Validates the given object using action and its context.
validate(Object, String, ValidatorContext) - Method in interface com.opensymphony.xwork2.validator.ActionValidatorManager
Validates an action give its context and a validation context.
validate(Object, String, String) - Method in interface com.opensymphony.xwork2.validator.ActionValidatorManager
Validates the given object using an action, its context, and the name of the method being invoked on the action.
validate(Object, String, ValidatorContext, String) - Method in interface com.opensymphony.xwork2.validator.ActionValidatorManager
Validates an action give its context and a validation context.
validate(Object, String) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
validate(Object, String, String) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
validate(Object, String, ValidatorContext) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
validate(Object, String, ValidatorContext, String) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
validate(Object, String) - Method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
validate(Object, String, String) - Method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
validate(Object, String, ValidatorContext) - Method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
validate(Object, String, ValidatorContext, String) - Method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
validate(Object) - Method in interface com.opensymphony.xwork2.validator.Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.ConditionalVisitorFieldValidator
If expression evaluates to true, invoke visitor validation.
validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator
validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.ExpressionValidator
validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.FieldExpressionValidator
validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.RegexFieldValidator
validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport
validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.RequiredFieldValidator
validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.RequiredStringValidator
validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator
validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.URLValidator
validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator
Validateable - Interface in com.opensymphony.xwork2
Provides an interface in which a call for a validation check can be done.
validateExpression(Object) - Method in class com.opensymphony.xwork2.validator.validators.ConditionalVisitorFieldValidator
Validate the expression contained in the "expression" paramter.
Validation - Annotation Type in com.opensymphony.xwork2.validator.annotations
Deprecated. Since Struts 2.1 because it isn't necessary anymore
VALIDATION_CONFIG_SUFFIX - Static variable in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
The file suffix for any validation file.
VALIDATION_CONFIG_SUFFIX - Static variable in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
The file suffix for any validation file.
ValidationAware - Interface in com.opensymphony.xwork2
ValidationAware classes can accept Action (class level) or field level error messages.
ValidationAwareSupport - Class in com.opensymphony.xwork2
Provides a default implementation of ValidationAware.
ValidationAwareSupport() - Constructor for class com.opensymphony.xwork2.ValidationAwareSupport
ValidationException - Exception in com.opensymphony.xwork2.validator
ValidationException.
ValidationException() - Constructor for exception com.opensymphony.xwork2.validator.ValidationException
Constructs an Exception with no specified detail message.
ValidationException(String) - Constructor for exception com.opensymphony.xwork2.validator.ValidationException
Constructs an Exception with the specified detail message.
ValidationInterceptor - Class in com.opensymphony.xwork2.validator
This interceptor runs the action through the standard validation framework, which in turn checks the action against any validation rules (found in files such as ActionClass-validation.xml) and adds field-level and action-level error messages (provided that the action implements ValidationAware).
ValidationInterceptor() - Constructor for class com.opensymphony.xwork2.validator.ValidationInterceptor
ValidationParameter - Annotation Type in com.opensymphony.xwork2.validator.annotations
The ValidationParameter annotation is used as a parameter for CustomValidators.
Validations - Annotation Type in com.opensymphony.xwork2.validator.annotations
ValidationWorkflowAware - Interface in com.opensymphony.xwork2.interceptor
ValidationWorkflowAware
Validator<T> - Interface in com.opensymphony.xwork2.validator
ValidatorConfig - Class in com.opensymphony.xwork2.validator
Holds the necessary information for configuring an instance of a Validator.
ValidatorConfig(String) - Constructor for class com.opensymphony.xwork2.validator.ValidatorConfig
ValidatorConfig(ValidatorConfig) - Constructor for class com.opensymphony.xwork2.validator.ValidatorConfig
ValidatorConfig.Builder - Class in com.opensymphony.xwork2.validator
Builds a ValidatorConfig
ValidatorConfig.Builder(String) - Constructor for class com.opensymphony.xwork2.validator.ValidatorConfig.Builder
ValidatorConfig.Builder(ValidatorConfig) - Constructor for class com.opensymphony.xwork2.validator.ValidatorConfig.Builder
ValidatorContext - Interface in com.opensymphony.xwork2.validator
The context for validation.
ValidatorDescription - Interface in com.opensymphony.xwork2.validator.metadata
ValidatorDescription
ValidatorFactory - Interface in com.opensymphony.xwork2.validator
ValidatorFactory
validatorFileParser - Variable in class com.opensymphony.xwork2.validator.DefaultValidatorFactory
ValidatorFileParser - Interface in com.opensymphony.xwork2.validator
This class serves 2 purpose : Parse the validation config file.
validators - Variable in class com.opensymphony.xwork2.validator.DefaultValidatorFactory
ValidatorSupport - Class in com.opensymphony.xwork2.validator.validators
Abstract implementation of the Validator interface suitable for subclassing.
ValidatorSupport() - Constructor for class com.opensymphony.xwork2.validator.validators.ValidatorSupport
ValidatorType - Enum in com.opensymphony.xwork2.validator.annotations
ValidatorType
value - Variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
VALUE_STACK - Static variable in class com.opensymphony.xwork2.ActionContext
Constant for the OGNL value stack.
VALUE_STACK - Static variable in interface com.opensymphony.xwork2.util.ValueStack
valueOf(String) - Static method in enum com.opensymphony.xwork2.conversion.annotations.ConversionRule
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.opensymphony.xwork2.conversion.annotations.ConversionType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.opensymphony.xwork2.inject.Scope
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.opensymphony.xwork2.inject.util.ReferenceType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.opensymphony.xwork2.validator.annotations.ValidatorType
Returns the enum constant of this type with the specified name.
values() - Static method in enum com.opensymphony.xwork2.conversion.annotations.ConversionRule
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum com.opensymphony.xwork2.conversion.annotations.ConversionType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum com.opensymphony.xwork2.inject.Scope
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
Returns an unmodifiable set view of the values in this map.
values() - Static method in enum com.opensymphony.xwork2.inject.util.ReferenceType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum com.opensymphony.xwork2.validator.annotations.ValidatorType
Returns an array containing the constants of this enum type, in the order they are declared.
ValueStack - Interface in com.opensymphony.xwork2.util
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.
valueStackFactory - Variable in class com.opensymphony.xwork2.DefaultActionInvocation
valueStackFactory - Variable in class com.opensymphony.xwork2.interceptor.AliasInterceptor
ValueStackFactory - Interface in com.opensymphony.xwork2.util
Factory that creates a value stack, defaulting to the OgnlValueStackFactory
verifyAction(String, String, Location) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
verifyResultType(String, Location) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
verifyUrl(String) - Static method in class com.opensymphony.xwork2.util.URLUtil
Verify That the given String is in valid URL format.
visit(int, int, String, String, String, String[]) - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.InfoBuildingVisitor
visitAnnotation(String, boolean) - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.InfoBuildingVisitor
visitField(int, String, String, String, Object) - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.InfoBuildingVisitor
visitMethod(int, String, String, String, String[]) - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.InfoBuildingVisitor
VisitorFieldValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
The validator allows you to forward validator to object properties of your action using the objects own validator files.
VisitorFieldValidator - Class in com.opensymphony.xwork2.validator.validators
The VisitorFieldValidator allows you to forward validation to object properties of your action using the object's own validation files.
VisitorFieldValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator
VisitorFieldValidator.AppendingValidatorContext - Class in com.opensymphony.xwork2.validator.validators
VisitorFieldValidator.AppendingValidatorContext(ValidatorContext, Object, String, String) - Constructor for class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext
VisitorFieldValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
VisitorFieldValidatorDescription
VisitorFieldValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription
VisitorFieldValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.
visitParameterAnnotation(int, String, boolean) - Method in class com.opensymphony.xwork2.util.finder.ClassFinder.InfoBuildingVisitor

W

warn(String, String...) - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLogger
warn(String, Throwable, String...) - Method in class com.opensymphony.xwork2.util.logging.commons.CommonsLogger
warn(String, String...) - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLogger
warn(String, Throwable, String...) - Method in class com.opensymphony.xwork2.util.logging.jdk.JdkLogger
warn(String, String...) - Method in interface com.opensymphony.xwork2.util.logging.Logger
warn(String, Throwable, String...) - Method in interface com.opensymphony.xwork2.util.logging.Logger
warning(SAXParseException) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler
WILDCARD - Static variable in class com.opensymphony.xwork2.config.entities.ActionConfig
WildcardHelper - Class in com.opensymphony.xwork2.util
This class is an utility class that perform wilcard-patterns matching and isolation taken from Apache Cocoon.
WildcardHelper() - Constructor for class com.opensymphony.xwork2.util.WildcardHelper
write(String, byte[]) - Method in class com.opensymphony.xwork2.util.classloader.FileResourceStore
write(String, byte[]) - Method in class com.opensymphony.xwork2.util.classloader.JarResourceStore
write(String, byte[]) - Method in interface com.opensymphony.xwork2.util.classloader.ResourceStore

X

XmlConfigurationProvider - Class in com.opensymphony.xwork2.config.providers
Looks in the classpath for an XML file, "xwork.xml" by default, and uses it for the XWork configuration.
XmlConfigurationProvider() - Constructor for class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
XmlConfigurationProvider(String) - Constructor for class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
XmlConfigurationProvider(String, boolean) - Constructor for class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
XmlHelper - Class in com.opensymphony.xwork2.config.providers
XML utilities.
XmlHelper() - Constructor for class com.opensymphony.xwork2.config.providers.XmlHelper
XMLNS_URI - Static variable in class com.opensymphony.xwork2.util.DomHelper
XWork - Class in com.opensymphony.xwork2
Simple facade to make using XWork standalone easier
XWork() - Constructor for class com.opensymphony.xwork2.XWork
XWork(ConfigurationManager) - Constructor for class com.opensymphony.xwork2.XWork
XWorkBasicConverter - Class in com.opensymphony.xwork2.conversion.impl

XWork will automatically handle the most common type conversion for you.

XWorkBasicConverter() - Constructor for class com.opensymphony.xwork2.conversion.impl.XWorkBasicConverter
XWorkCollectionPropertyAccessor - Class in com.opensymphony.xwork2.ognl.accessor
XWorkCollectionPropertyAccessor() - Constructor for class com.opensymphony.xwork2.ognl.accessor.XWorkCollectionPropertyAccessor
XWorkConfigurationProvider - Class in com.opensymphony.xwork2.config.providers
XWorkConfigurationProvider() - Constructor for class com.opensymphony.xwork2.config.providers.XWorkConfigurationProvider
XWorkConverter - Class in com.opensymphony.xwork2.conversion.impl
XWorkConverter is a singleton used by many of the Struts 2's Ognl extention points, such as InstantiatingNullHandler, XWorkListPropertyAccessor etc to do object conversion.
XWorkConverter() - Constructor for class com.opensymphony.xwork2.conversion.impl.XWorkConverter
XWorkEnumerationAccessor - Class in com.opensymphony.xwork2.ognl.accessor
XWorkEnumerationAccessor() - Constructor for class com.opensymphony.xwork2.ognl.accessor.XWorkEnumerationAccessor
XWorkException - Exception in com.opensymphony.xwork2
A generic runtime exception that optionally contains Location information
XWorkException() - Constructor for exception com.opensymphony.xwork2.XWorkException
Constructs a XWorkException with no detail message.
XWorkException(String) - Constructor for exception com.opensymphony.xwork2.XWorkException
Constructs a XWorkException with the specified detail message.
XWorkException(String, Object) - Constructor for exception com.opensymphony.xwork2.XWorkException
Constructs a XWorkException with the specified detail message and target.
XWorkException(Throwable) - Constructor for exception com.opensymphony.xwork2.XWorkException
Constructs a XWorkException with the root cause
XWorkException(Throwable, Object) - Constructor for exception com.opensymphony.xwork2.XWorkException
Constructs a XWorkException with the root cause and target
XWorkException(String, Throwable) - Constructor for exception com.opensymphony.xwork2.XWorkException
Constructs a XWorkException with the specified detail message and exception cause.
XWorkException(String, Throwable, Object) - Constructor for exception com.opensymphony.xwork2.XWorkException
Constructs a XWorkException with the specified detail message, cause, and target
XWorkIteratorPropertyAccessor - Class in com.opensymphony.xwork2.ognl.accessor
XWorkIteratorPropertyAccessor() - Constructor for class com.opensymphony.xwork2.ognl.accessor.XWorkIteratorPropertyAccessor
XWorkList - Class in com.opensymphony.xwork2.util
A simple list that guarantees that inserting and retrieving objects will always work regardless of the current size of the list.
XWorkList(ObjectFactory, XWorkConverter, Class) - Constructor for class com.opensymphony.xwork2.util.XWorkList
XWorkList(ObjectFactory, XWorkConverter, Class, int) - Constructor for class com.opensymphony.xwork2.util.XWorkList
XWorkListPropertyAccessor - Class in com.opensymphony.xwork2.ognl.accessor
Overrides the list property accessor so in the case of trying to add properties of a given bean and the JavaBean is not present, this class will create the necessary blank JavaBeans.
XWorkListPropertyAccessor() - Constructor for class com.opensymphony.xwork2.ognl.accessor.XWorkListPropertyAccessor
XWorkMapPropertyAccessor - Class in com.opensymphony.xwork2.ognl.accessor
Implementation of PropertyAccessor that sets and gets properties by storing and looking up values in Maps.
XWorkMapPropertyAccessor() - Constructor for class com.opensymphony.xwork2.ognl.accessor.XWorkMapPropertyAccessor
XWorkMessages - Interface in com.opensymphony.xwork2
Contains constants for some default XWork messages.
XWorkMethodAccessor - Class in com.opensymphony.xwork2.ognl.accessor
Allows methods to be executed under normal cirumstances, except when ReflectionContextState.DENY_METHOD_EXECUTION is in the action context with a value of true.
XWorkMethodAccessor() - Constructor for class com.opensymphony.xwork2.ognl.accessor.XWorkMethodAccessor
XWorkObjectPropertyAccessor - Class in com.opensymphony.xwork2.ognl.accessor
XWorkObjectPropertyAccessor() - Constructor for class com.opensymphony.xwork2.ognl.accessor.XWorkObjectPropertyAccessor
XWorkTestCase - Class in com.opensymphony.xwork2
Base JUnit TestCase to extend for XWork specific JUnit tests.
XWorkTestCase() - Constructor for class com.opensymphony.xwork2.XWorkTestCase
XWorkTestCaseHelper - Class in com.opensymphony.xwork2.util
Generic test setup methods to be used with any unit testing framework.
XWorkTestCaseHelper() - Constructor for class com.opensymphony.xwork2.util.XWorkTestCaseHelper
XWorkTypeConverterWrapper - Class in com.opensymphony.xwork2.ognl
Wraps an OGNL TypeConverter as an XWork TypeConverter
XWorkTypeConverterWrapper(TypeConverter) - Constructor for class com.opensymphony.xwork2.ognl.XWorkTypeConverterWrapper
A B C D E F G H I J K L M N O P Q R S T U V W X
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Overview List (XWork: Core 2.1.6 API)

All Classes

Packages
com.opensymphony.xwork2
com.opensymphony.xwork2.config
com.opensymphony.xwork2.config.entities
com.opensymphony.xwork2.config.impl
com.opensymphony.xwork2.config.providers
com.opensymphony.xwork2.conversion
com.opensymphony.xwork2.conversion.annotations
com.opensymphony.xwork2.conversion.impl
com.opensymphony.xwork2.conversion.metadata
com.opensymphony.xwork2.inject
com.opensymphony.xwork2.inject.util
com.opensymphony.xwork2.interceptor
com.opensymphony.xwork2.interceptor.annotations
com.opensymphony.xwork2.mock
com.opensymphony.xwork2.ognl
com.opensymphony.xwork2.ognl.accessor
com.opensymphony.xwork2.spring
com.opensymphony.xwork2.spring.interceptor
com.opensymphony.xwork2.test
com.opensymphony.xwork2.util
com.opensymphony.xwork2.util.classloader
com.opensymphony.xwork2.util.finder
com.opensymphony.xwork2.util.location
com.opensymphony.xwork2.util.logging
com.opensymphony.xwork2.util.logging.commons
com.opensymphony.xwork2.util.logging.jdk
com.opensymphony.xwork2.util.profiling
com.opensymphony.xwork2.util.reflection
com.opensymphony.xwork2.validator
com.opensymphony.xwork2.validator.annotations
com.opensymphony.xwork2.validator.metadata
com.opensymphony.xwork2.validator.validators


Overview (XWork: Core 2.1.6 API)

XWork: Core 2.1.6 API

XWork Packages
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.conversion |
com.opensymphony.xwork2.conversion.annotations | Type conversion annotations.
com.opensymphony.xwork2.conversion.impl |
com.opensymphony.xwork2.conversion.metadata | Type conversion meta data classes.
com.opensymphony.xwork2.inject | Guice (pronounced "juice").
com.opensymphony.xwork2.inject.util | Guice util classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.interceptor.annotations | Interceptor annotations.
com.opensymphony.xwork2.mock | XWork specific mock classes.
com.opensymphony.xwork2.ognl |
com.opensymphony.xwork2.ognl.accessor |
com.opensymphony.xwork2.spring | Spring ObjectFactory classes.
com.opensymphony.xwork2.spring.interceptor | Spring specific interceptor classes.
com.opensymphony.xwork2.test |
com.opensymphony.xwork2.util | XWork util classes.
com.opensymphony.xwork2.util.classloader |
com.opensymphony.xwork2.util.finder |
com.opensymphony.xwork2.util.location | Classes and utilities used to track location information.
com.opensymphony.xwork2.util.logging |
com.opensymphony.xwork2.util.logging.commons |
com.opensymphony.xwork2.util.logging.jdk |
com.opensymphony.xwork2.util.profiling | Classes to enable profiling of action execution.
com.opensymphony.xwork2.util.reflection |
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.annotations | Validator annotations.
com.opensymphony.xwork2.validator.metadata | Validator meta data classes.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For All Packages

Package Hierarchies:
com.opensymphony.xwork2, com.opensymphony.xwork2.config, com.opensymphony.xwork2.config.entities, com.opensymphony.xwork2.config.impl, com.opensymphony.xwork2.config.providers, com.opensymphony.xwork2.conversion, com.opensymphony.xwork2.conversion.annotations, com.opensymphony.xwork2.conversion.impl, com.opensymphony.xwork2.conversion.metadata, com.opensymphony.xwork2.inject, com.opensymphony.xwork2.inject.util, com.opensymphony.xwork2.interceptor, com.opensymphony.xwork2.interceptor.annotations, com.opensymphony.xwork2.mock, com.opensymphony.xwork2.ognl, com.opensymphony.xwork2.ognl.accessor, com.opensymphony.xwork2.spring, com.opensymphony.xwork2.spring.interceptor, com.opensymphony.xwork2.test, com.opensymphony.xwork2.util, com.opensymphony.xwork2.util.classloader, com.opensymphony.xwork2.util.finder, com.opensymphony.xwork2.util.location, com.opensymphony.xwork2.util.logging, com.opensymphony.xwork2.util.logging.commons, com.opensymphony.xwork2.util.logging.jdk, com.opensymphony.xwork2.util.profiling, com.opensymphony.xwork2.util.reflection, com.opensymphony.xwork2.validator, com.opensymphony.xwork2.validator.annotations, com.opensymphony.xwork2.validator.metadata, com.opensymphony.xwork2.validator.validators

Class Hierarchy

  • java.lang.Object
    • java.util.AbstractCollection<E> (implements java.util.Collection<E>)
      • java.util.AbstractList<E> (implements java.util.List<E>)
        • java.util.ArrayList<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
          • com.opensymphony.xwork2.util.CompoundRoot
          • com.opensymphony.xwork2.util.XWorkList
    • com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription (implements com.opensymphony.xwork2.validator.metadata.ValidatorDescription)
      • com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.URLValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription
    • com.opensymphony.xwork2.interceptor.AbstractInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
      • com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor (implements org.springframework.context.ApplicationContextAware)
      • com.opensymphony.xwork2.interceptor.AliasInterceptor
      • com.opensymphony.xwork2.interceptor.annotations.AnnotationParameterFilterIntereptor
      • com.opensymphony.xwork2.interceptor.ChainingInterceptor
      • com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor
      • com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
      • com.opensymphony.xwork2.interceptor.I18nInterceptor
      • com.opensymphony.xwork2.interceptor.LoggingInterceptor
      • com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
        • com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor
        • com.opensymphony.xwork2.interceptor.ParametersInterceptor
        • com.opensymphony.xwork2.interceptor.PrepareInterceptor
        • com.opensymphony.xwork2.validator.ValidationInterceptor
      • com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor
      • com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor
      • com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor
      • com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor
      • com.opensymphony.xwork2.interceptor.StaticParametersInterceptor
      • com.opensymphony.xwork2.interceptor.TimerInterceptor
    • com.opensymphony.xwork2.config.impl.AbstractMatcher<E> (implements java.io.Serializable)
      • com.opensymphony.xwork2.config.impl.ActionConfigMatcher (implements java.io.Serializable)
      • com.opensymphony.xwork2.config.impl.NamespaceMatcher
    • com.opensymphony.xwork2.ActionChainResult (implements com.opensymphony.xwork2.Result)
    • com.opensymphony.xwork2.config.entities.ActionConfig.Builder (implements com.opensymphony.xwork2.config.entities.InterceptorListHolder)
    • com.opensymphony.xwork2.ActionContext (implements java.io.Serializable)
    • com.opensymphony.xwork2.ActionSupport (implements com.opensymphony.xwork2.Action, com.opensymphony.xwork2.LocaleProvider, java.io.Serializable, com.opensymphony.xwork2.TextProvider, com.opensymphony.xwork2.Validateable, com.opensymphony.xwork2.ValidationAware)
    • com.opensymphony.xwork2.validator.AnnotationActionValidatorManager (implements com.opensymphony.xwork2.validator.ActionValidatorManager)
    • com.opensymphony.xwork2.validator.AnnotationActionValidatorManager.InternalValidatorContextWrapper
    • com.opensymphony.xwork2.util.AnnotationUtils
    • com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder
    • com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor, com.opensymphony.xwork2.interceptor.PreResultListener)
    • com.opensymphony.xwork2.util.ArrayUtils
    • junit.framework.Assert
      • junit.framework.TestCase (implements junit.framework.Test)
        • com.opensymphony.xwork2.XWorkTestCase
    • com.opensymphony.xwork2.util.finder.ClassFinder
    • com.opensymphony.xwork2.util.finder.ClassFinder.Annotatable
      • com.opensymphony.xwork2.util.finder.ClassFinder.AnnotationInfo (implements com.opensymphony.xwork2.util.finder.ClassFinder.Info)
      • com.opensymphony.xwork2.util.finder.ClassFinder.ClassInfo (implements com.opensymphony.xwork2.util.finder.ClassFinder.Info)
      • com.opensymphony.xwork2.util.finder.ClassFinder.FieldInfo (implements com.opensymphony.xwork2.util.finder.ClassFinder.Info)
      • com.opensymphony.xwork2.util.finder.ClassFinder.MethodInfo (implements com.opensymphony.xwork2.util.finder.ClassFinder.Info)
      • com.opensymphony.xwork2.util.finder.ClassFinder.PackageInfo (implements com.opensymphony.xwork2.util.finder.ClassFinder.Info)
    • java.lang.ClassLoader
      • com.opensymphony.xwork2.util.classloader.ReloadingClassLoader
      • com.opensymphony.xwork2.util.classloader.ResourceStoreClassLoader
    • com.opensymphony.xwork2.util.finder.ClassLoaderInterfaceDelegate (implements com.opensymphony.xwork2.util.finder.ClassLoaderInterface)
    • com.opensymphony.xwork2.util.ClassLoaderUtil
    • com.opensymphony.xwork2.util.ClassPathFinder
    • com.opensymphony.xwork2.util.logging.commons.CommonsLogger (implements com.opensymphony.xwork2.util.logging.Logger)
    • com.opensymphony.xwork2.CompositeTextProvider (implements com.opensymphony.xwork2.TextProvider)
    • com.opensymphony.xwork2.ognl.accessor.CompoundRootAccessor (implements ognl.ClassResolver, ognl.MethodAccessor, ognl.PropertyAccessor)
    • com.opensymphony.xwork2.config.ConfigurationManager
    • com.opensymphony.xwork2.config.ConfigurationUtil
    • com.opensymphony.xwork2.inject.ContainerBuilder
    • com.opensymphony.xwork2.conversion.metadata.ConversionDescription
    • com.opensymphony.xwork2.DefaultActionInvocation (implements com.opensymphony.xwork2.ActionInvocation)
    • com.opensymphony.xwork2.DefaultActionProxy (implements com.opensymphony.xwork2.ActionProxy, java.io.Serializable)
    • com.opensymphony.xwork2.DefaultActionProxyFactory (implements com.opensymphony.xwork2.ActionProxyFactory)
    • com.opensymphony.xwork2.validator.DefaultActionValidatorManager (implements com.opensymphony.xwork2.validator.ActionValidatorManager)
    • com.opensymphony.xwork2.validator.DefaultActionValidatorManager.InternalValidatorContextWrapper
    • com.opensymphony.xwork2.config.impl.DefaultConfiguration (implements com.opensymphony.xwork2.config.Configuration)
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • com.opensymphony.xwork2.util.DomHelper.StartHandler
    • ognl.DefaultMemberAccess (implements ognl.MemberAccess)
      • com.opensymphony.xwork2.ognl.SecurityMemberAccess
    • com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer (implements com.opensymphony.xwork2.conversion.ObjectTypeDeterminer)
      • com.opensymphony.xwork2.conversion.impl.GenericsObjectTypeDeterminer
    • com.opensymphony.xwork2.DefaultTextProvider (implements java.io.Serializable, com.opensymphony.xwork2.TextProvider, com.opensymphony.xwork2.Unchainable)
    • com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter (implements com.opensymphony.xwork2.conversion.TypeConverter)
      • com.opensymphony.xwork2.conversion.impl.EnumTypeConverter
      • com.opensymphony.xwork2.conversion.impl.XWorkBasicConverter
      • com.opensymphony.xwork2.conversion.impl.XWorkConverter
        • com.opensymphony.xwork2.conversion.impl.AnnotationXWorkConverter
    • com.opensymphony.xwork2.DefaultUnknownHandlerManager (implements com.opensymphony.xwork2.UnknownHandlerManager)
    • com.opensymphony.xwork2.validator.DefaultValidatorFactory (implements com.opensymphony.xwork2.validator.ValidatorFactory)
    • com.opensymphony.xwork2.validator.DefaultValidatorFileParser (implements com.opensymphony.xwork2.validator.ValidatorFileParser)
    • com.opensymphony.xwork2.validator.DelegatingValidatorContext (implements com.opensymphony.xwork2.validator.ValidatorContext)
      • com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext
    • java.util.Dictionary<K,V>
      • java.util.Hashtable<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • java.util.Properties
          • com.opensymphony.xwork2.util.location.LocatableProperties (implements com.opensymphony.xwork2.util.location.Locatable)
    • com.opensymphony.xwork2.util.DomHelper
    • com.opensymphony.xwork2.util.DomHelper.DOMBuilder (implements org.xml.sax.ContentHandler)
    • org.objectweb.asm.commons.EmptyVisitor (implements org.objectweb.asm.AnnotationVisitor, org.objectweb.asm.ClassVisitor, org.objectweb.asm.FieldVisitor, org.objectweb.asm.MethodVisitor)
      • com.opensymphony.xwork2.util.finder.ClassFinder.InfoBuildingVisitor
    • com.opensymphony.xwork2.interceptor.ExceptionHolder (implements java.io.Serializable)
    • com.opensymphony.xwork2.config.entities.ExceptionMappingConfig.Builder
    • com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription (implements com.opensymphony.xwork2.validator.metadata.ValidatorDescription)
    • com.opensymphony.xwork2.util.FileManager
    • com.opensymphony.xwork2.util.classloader.FileResourceStore (implements com.opensymphony.xwork2.util.classloader.ResourceStore)
    • com.opensymphony.xwork2.conversion.impl.InstantiatingNullHandler (implements com.opensymphony.xwork2.conversion.NullHandler)
    • com.opensymphony.xwork2.config.providers.InterceptorBuilder
    • com.opensymphony.xwork2.config.entities.InterceptorConfig.Builder
    • com.opensymphony.xwork2.config.entities.InterceptorMapping (implements java.io.Serializable)
    • com.opensymphony.xwork2.config.entities.InterceptorStackConfig.Builder (implements com.opensymphony.xwork2.config.entities.InterceptorListHolder)
    • com.opensymphony.xwork2.util.classloader.JarResourceStore (implements com.opensymphony.xwork2.util.classloader.ResourceStore)
    • com.opensymphony.xwork2.util.logging.jdk.JdkLogger (implements com.opensymphony.xwork2.util.logging.Logger)
    • com.opensymphony.xwork2.util.LocalizedTextUtil
    • com.opensymphony.xwork2.util.location.Located (implements com.opensymphony.xwork2.util.location.Locatable)
      • com.opensymphony.xwork2.config.entities.ActionConfig (implements java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.ExceptionMappingConfig (implements java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.InterceptorConfig (implements java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.InterceptorStackConfig (implements java.io.Serializable)
      • com.opensymphony.xwork2.config.impl.LocatableConstantFactory<T> (implements com.opensymphony.xwork2.inject.Factory<T>)
      • com.opensymphony.xwork2.config.impl.LocatableFactory<T> (implements com.opensymphony.xwork2.inject.Factory<T>)
      • com.opensymphony.xwork2.config.entities.PackageConfig (implements java.lang.Comparable<T>, com.opensymphony.xwork2.config.entities.InterceptorLocator, java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.ResultConfig (implements java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.ResultTypeConfig (implements java.io.Serializable)
      • com.opensymphony.xwork2.validator.ValidatorConfig
    • com.opensymphony.xwork2.util.location.LocationAttributes
    • com.opensymphony.xwork2.util.location.LocationAttributes.Pipe (implements org.xml.sax.ContentHandler)
    • com.opensymphony.xwork2.util.location.LocationImpl (implements com.opensymphony.xwork2.util.location.Location, java.io.Serializable)
    • com.opensymphony.xwork2.util.location.LocationUtils
    • com.opensymphony.xwork2.util.logging.LoggerFactory
      • com.opensymphony.xwork2.util.logging.commons.CommonsLoggerFactory
      • com.opensymphony.xwork2.util.logging.jdk.JdkLoggerFactory
    • com.opensymphony.xwork2.util.logging.LoggerUtils
    • ognl.MapPropertyAccessor (implements ognl.PropertyAccessor)
      • com.opensymphony.xwork2.ognl.accessor.XWorkMapPropertyAccessor
    • com.opensymphony.xwork2.interceptor.MethodFilterInterceptorUtil
    • com.opensymphony.xwork2.mock.MockActionInvocation (implements com.opensymphony.xwork2.ActionInvocation)
      • com.opensymphony.xwork2.MockActionInvocation
    • com.opensymphony.xwork2.mock.MockActionProxy (implements com.opensymphony.xwork2.ActionProxy)
    • com.opensymphony.xwork2.config.impl.MockConfiguration (implements com.opensymphony.xwork2.config.Configuration)
    • com.opensymphony.xwork2.mock.MockInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
    • com.opensymphony.xwork2.mock.MockObjectTypeDeterminer (implements com.opensymphony.xwork2.conversion.ObjectTypeDeterminer)
    • com.opensymphony.xwork2.mock.MockResult (implements com.opensymphony.xwork2.Result)
    • com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor.RefreshModelBeforeResult (implements com.opensymphony.xwork2.interceptor.PreResultListener)
    • com.opensymphony.xwork2.util.NamedVariablePatternMatcher (implements com.opensymphony.xwork2.util.PatternMatcher<E>)
    • com.opensymphony.xwork2.util.NamedVariablePatternMatcher.CompiledPattern
    • com.opensymphony.xwork2.config.impl.NamespaceMatch
    • com.opensymphony.xwork2.ObjectFactory (implements java.io.Serializable)
      • com.opensymphony.xwork2.spring.SpringObjectFactory (implements org.springframework.context.ApplicationContextAware)
        • com.opensymphony.xwork2.spring.SpringProxyableObjectFactory
    • ognl.ObjectMethodAccessor (implements ognl.MethodAccessor)
      • com.opensymphony.xwork2.ognl.accessor.XWorkMethodAccessor
    • com.opensymphony.xwork2.util.profiling.ObjectProfiler
    • ognl.ObjectPropertyAccessor (implements ognl.PropertyAccessor)
      • ognl.EnumerationPropertyAccessor (implements ognl.PropertyAccessor)
        • com.opensymphony.xwork2.ognl.accessor.XWorkEnumerationAccessor
      • ognl.IteratorPropertyAccessor (implements ognl.PropertyAccessor)
        • com.opensymphony.xwork2.ognl.accessor.XWorkIteratorPropertyAccessor
      • ognl.ListPropertyAccessor (implements ognl.PropertyAccessor)
        • com.opensymphony.xwork2.ognl.accessor.XWorkListPropertyAccessor
      • com.opensymphony.xwork2.ognl.accessor.ObjectAccessor
      • ognl.SetPropertyAccessor (implements ognl.PropertyAccessor)
        • com.opensymphony.xwork2.ognl.accessor.XWorkCollectionPropertyAccessor
      • com.opensymphony.xwork2.ognl.accessor.XWorkObjectPropertyAccessor
    • com.opensymphony.xwork2.ognl.ObjectProxy
    • com.opensymphony.xwork2.ognl.accessor.ObjectProxyPropertyAccessor (implements ognl.PropertyAccessor)
    • com.opensymphony.xwork2.ognl.OgnlNullHandlerWrapper (implements ognl.NullHandler)
    • com.opensymphony.xwork2.ognl.OgnlReflectionContextFactory (implements com.opensymphony.xwork2.util.reflection.ReflectionContextFactory)
    • com.opensymphony.xwork2.ognl.OgnlReflectionProvider (implements com.opensymphony.xwork2.util.reflection.ReflectionProvider)
    • com.opensymphony.xwork2.ognl.OgnlTypeConverterWrapper (implements ognl.TypeConverter)
    • com.opensymphony.xwork2.ognl.OgnlUtil
    • com.opensymphony.xwork2.ognl.OgnlValueStack (implements com.opensymphony.xwork2.util.ClearableValueStack, com.opensymphony.xwork2.util.MemberAccessValueStack, java.io.Serializable, com.opensymphony.xwork2.util.ValueStack)
    • com.opensymphony.xwork2.ognl.OgnlValueStackFactory (implements com.opensymphony.xwork2.util.ValueStackFactory)
    • com.opensymphony.xwork2.config.entities.PackageConfig.Builder (implements com.opensymphony.xwork2.config.entities.InterceptorLocator)
    • com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil
    • com.opensymphony.xwork2.util.profiling.ProfilingTimerBean (implements java.io.Serializable)
    • java.io.Reader (implements java.io.Closeable, java.lang.Readable)
      • java.io.BufferedReader
        • java.io.LineNumberReader
          • com.opensymphony.xwork2.util.PropertiesReader
    • java.lang.ref.Reference<T>
      • java.lang.ref.PhantomReference<T>
        • com.opensymphony.xwork2.inject.util.FinalizablePhantomReference<T>
      • java.lang.ref.SoftReference<T>
        • com.opensymphony.xwork2.inject.util.FinalizableSoftReference<T>
      • java.lang.ref.WeakReference<T>
        • com.opensymphony.xwork2.inject.util.FinalizableWeakReference<T>
    • com.opensymphony.xwork2.inject.util.ReferenceMap<K,V> (implements java.util.Map<K,V>, java.io.Serializable)
      • com.opensymphony.xwork2.inject.util.ReferenceCache<K,V>
    • com.opensymphony.xwork2.util.reflection.ReflectionContextState
    • com.opensymphony.xwork2.util.reflection.ReflectionProviderFactory
    • com.opensymphony.xwork2.util.ResolverUtil<T>
    • com.opensymphony.xwork2.util.ResolverUtil.ClassTest (implements com.opensymphony.xwork2.util.ResolverUtil.Test)
      • com.opensymphony.xwork2.util.ResolverUtil.AnnotatedWith
      • com.opensymphony.xwork2.util.ResolverUtil.IsA
      • com.opensymphony.xwork2.util.ResolverUtil.NameEndsWith
    • com.opensymphony.xwork2.util.ResolverUtil.ResourceTest (implements com.opensymphony.xwork2.util.ResolverUtil.Test)
      • com.opensymphony.xwork2.util.ResolverUtil.NameIs
    • com.opensymphony.xwork2.util.finder.ResourceFinder
    • com.opensymphony.xwork2.config.entities.ResultConfig.Builder
    • com.opensymphony.xwork2.config.entities.ResultTypeConfig.Builder
    • com.opensymphony.xwork2.inject.util.Strings
    • com.opensymphony.xwork2.test.StubConfigurationProvider (implements com.opensymphony.xwork2.config.ConfigurationProvider)
    • com.opensymphony.xwork2.TestNGXWorkTestCase
    • com.opensymphony.xwork2.util.TextParseUtil
    • com.opensymphony.xwork2.TextProviderFactory
    • com.opensymphony.xwork2.TextProviderSupport (implements com.opensymphony.xwork2.ResourceBundleTextProvider)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.opensymphony.xwork2.inject.DependencyException
          • com.opensymphony.xwork2.InvalidMetadataException
          • com.opensymphony.xwork2.XWorkException (implements com.opensymphony.xwork2.util.location.Locatable)
            • com.opensymphony.xwork2.config.ConfigurationException
            • com.opensymphony.xwork2.config.ReferenceResolverException
            • com.opensymphony.xwork2.util.reflection.ReflectionException
            • com.opensymphony.xwork2.conversion.TypeConversionException
        • com.opensymphony.xwork2.validator.ValidationException
    • com.opensymphony.xwork2.config.entities.UnknownHandlerConfig
    • com.opensymphony.xwork2.util.finder.UrlSet
    • com.opensymphony.xwork2.util.URLUtil
    • com.opensymphony.xwork2.util.profiling.UtilTimerStack
    • com.opensymphony.xwork2.ValidationAwareSupport (implements java.io.Serializable, com.opensymphony.xwork2.ValidationAware)
    • com.opensymphony.xwork2.validator.ValidatorConfig.Builder
    • com.opensymphony.xwork2.validator.validators.ValidatorSupport (implements com.opensymphony.xwork2.validator.ShortCircuitableValidator, com.opensymphony.xwork2.validator.Validator<T>)
      • com.opensymphony.xwork2.validator.validators.ExpressionValidator
      • com.opensymphony.xwork2.validator.validators.FieldValidatorSupport (implements com.opensymphony.xwork2.validator.FieldValidator)
        • com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
          • com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator
          • com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator
          • com.opensymphony.xwork2.validator.validators.LongRangeFieldValidator
          • com.opensymphony.xwork2.validator.validators.ShortRangeFieldValidator
        • com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator
        • com.opensymphony.xwork2.validator.validators.FieldExpressionValidator
        • com.opensymphony.xwork2.validator.validators.RegexFieldValidator
          • com.opensymphony.xwork2.validator.validators.EmailValidator
        • com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport
          • com.opensymphony.xwork2.validator.validators.ConversionErrorFieldValidator
        • com.opensymphony.xwork2.validator.validators.RequiredFieldValidator
        • com.opensymphony.xwork2.validator.validators.RequiredStringValidator
        • com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator
        • com.opensymphony.xwork2.validator.validators.URLValidator
        • com.opensymphony.xwork2.validator.validators.VisitorFieldValidator
          • com.opensymphony.xwork2.validator.validators.ConditionalVisitorFieldValidator
    • com.opensymphony.xwork2.util.WildcardHelper (implements com.opensymphony.xwork2.util.PatternMatcher<E>)
    • com.opensymphony.xwork2.config.providers.XmlConfigurationProvider (implements com.opensymphony.xwork2.config.ConfigurationProvider)
    • com.opensymphony.xwork2.config.providers.XmlHelper
    • com.opensymphony.xwork2.XWork
    • com.opensymphony.xwork2.config.providers.XWorkConfigurationProvider (implements com.opensymphony.xwork2.config.ConfigurationProvider)
    • com.opensymphony.xwork2.util.XWorkTestCaseHelper
    • com.opensymphony.xwork2.ognl.XWorkTypeConverterWrapper (implements com.opensymphony.xwork2.conversion.TypeConverter)

Interface Hierarchy

  • com.opensymphony.xwork2.Action
  • com.opensymphony.xwork2.ActionEventListener
  • com.opensymphony.xwork2.ActionProxy
  • com.opensymphony.xwork2.ActionProxyFactory
  • com.opensymphony.xwork2.validator.ActionValidatorManager
  • com.opensymphony.xwork2.util.finder.ClassFinder.Info
  • com.opensymphony.xwork2.util.finder.ClassLoaderInterface
  • com.opensymphony.xwork2.util.ClearableValueStack
  • com.opensymphony.xwork2.inject.ContainerBuilder.Command
  • com.opensymphony.xwork2.config.ContainerProvider
    • com.opensymphony.xwork2.config.ConfigurationProvider (also extends com.opensymphony.xwork2.config.PackageProvider)
  • com.opensymphony.xwork2.inject.Context
  • com.opensymphony.xwork2.inject.Factory<T>
  • com.opensymphony.xwork2.inject.util.Function<F,T>
  • com.opensymphony.xwork2.config.entities.InterceptorListHolder
  • com.opensymphony.xwork2.config.entities.InterceptorLocator
  • com.opensymphony.xwork2.LocaleProvider
    • com.opensymphony.xwork2.validator.ValidatorContext (also extends com.opensymphony.xwork2.TextProvider, com.opensymphony.xwork2.ValidationAware)
  • com.opensymphony.xwork2.util.location.Locatable
  • com.opensymphony.xwork2.util.location.Location
  • com.opensymphony.xwork2.util.location.LocationUtils.LocationFinder
  • com.opensymphony.xwork2.util.logging.Logger
  • com.opensymphony.xwork2.util.MemberAccessValueStack
  • com.opensymphony.xwork2.ModelDriven<T>
    • com.opensymphony.xwork2.interceptor.ScopedModelDriven<T>
  • com.opensymphony.xwork2.interceptor.NoParameters
  • com.opensymphony.xwork2.conversion.NullHandler
  • com.opensymphony.xwork2.conversion.ObjectTypeDeterminer
  • com.opensymphony.xwork2.config.PackageProvider
    • com.opensymphony.xwork2.config.ConfigurationProvider (also extends com.opensymphony.xwork2.config.ContainerProvider)
  • com.opensymphony.xwork2.config.entities.Parameterizable
  • com.opensymphony.xwork2.interceptor.ParameterNameAware
  • com.opensymphony.xwork2.util.PatternMatcher<E>
  • com.opensymphony.xwork2.Preparable
  • com.opensymphony.xwork2.interceptor.PreResultListener
  • com.opensymphony.xwork2.inject.util.ReferenceMap.Strategy
  • com.opensymphony.xwork2.util.reflection.ReflectionContextFactory
  • com.opensymphony.xwork2.util.reflection.ReflectionExceptionHandler
  • com.opensymphony.xwork2.util.reflection.ReflectionProvider
  • com.opensymphony.xwork2.util.ResolverUtil.Test
  • com.opensymphony.xwork2.util.classloader.ResourceStore
  • com.opensymphony.xwork2.inject.Scope.Strategy
  • java.io.Serializable
    • com.opensymphony.xwork2.ActionInvocation
    • com.opensymphony.xwork2.config.Configuration
    • com.opensymphony.xwork2.inject.Container
    • com.opensymphony.xwork2.interceptor.Interceptor
    • com.opensymphony.xwork2.Result
    • com.opensymphony.xwork2.config.RuntimeConfiguration
  • com.opensymphony.xwork2.validator.ShortCircuitableValidator
  • com.opensymphony.xwork2.util.finder.Test<T>
  • com.opensymphony.xwork2.util.TextParseUtil.ParsedValueEvaluator
  • com.opensymphony.xwork2.TextProvider
    • com.opensymphony.xwork2.ResourceBundleTextProvider
    • com.opensymphony.xwork2.validator.ValidatorContext (also extends com.opensymphony.xwork2.LocaleProvider, com.opensymphony.xwork2.ValidationAware)
  • com.opensymphony.xwork2.conversion.TypeConverter
  • com.opensymphony.xwork2.Unchainable
  • com.opensymphony.xwork2.UnknownHandler
  • com.opensymphony.xwork2.UnknownHandlerManager
  • com.opensymphony.xwork2.util.profiling.UtilTimerStack.ProfilingBlock<T>
  • com.opensymphony.xwork2.Validateable
  • com.opensymphony.xwork2.ValidationAware
    • com.opensymphony.xwork2.validator.ValidatorContext (also extends com.opensymphony.xwork2.LocaleProvider, com.opensymphony.xwork2.TextProvider)
  • com.opensymphony.xwork2.interceptor.ValidationWorkflowAware
  • com.opensymphony.xwork2.validator.Validator<T>
    • com.opensymphony.xwork2.validator.FieldValidator
  • com.opensymphony.xwork2.validator.metadata.ValidatorDescription
  • com.opensymphony.xwork2.validator.ValidatorFactory
  • com.opensymphony.xwork2.validator.ValidatorFileParser
  • com.opensymphony.xwork2.util.ValueStack
  • com.opensymphony.xwork2.util.ValueStackFactory
  • com.opensymphony.xwork2.XWorkMessages

Annotation Type Hierarchy

  • com.opensymphony.xwork2.conversion.annotations.TypeConversion (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.conversion.annotations.Conversion (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.inject.Scoped (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.inject.Inject (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.interceptor.annotations.InputConfig (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.interceptor.annotations.Blocked (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.interceptor.annotations.BlockByDefault (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.interceptor.annotations.BeforeResult (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.interceptor.annotations.Before (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.interceptor.annotations.Allowed (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.interceptor.annotations.After (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.util.KeyProperty (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.util.Key (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.util.Element (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.util.CreateIfNull (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.VisitorFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.Validations (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.ValidationParameter (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.Validation (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.UrlValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.StringLengthFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.RequiredStringValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.RequiredFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.RegexFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.IntRangeFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.FieldExpressionValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.ExpressionValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.EmailValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.DoubleRangeFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.DateRangeFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.CustomValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.ConversionErrorFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.ConditionalVisitorFieldValidator (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.opensymphony.xwork2.conversion.annotations.ConversionType
      • com.opensymphony.xwork2.conversion.annotations.ConversionRule
      • com.opensymphony.xwork2.inject.Scope
      • com.opensymphony.xwork2.inject.util.ReferenceType
      • com.opensymphony.xwork2.validator.annotations.ValidatorType
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Serialized Form (XWork: Core 2.1.6 API)

Serialized Form

Package com.opensymphony.xwork2

Class com.opensymphony.xwork2.ActionChainResult extends Object implements Serializable

Serialized Fields

proxy

ActionProxy proxy

actionName

String actionName

namespace

String namespace

methodName

String methodName

skipActions

String skipActions
The list of actions to skip.

actionProxyFactory

ActionProxyFactory actionProxyFactory

Class com.opensymphony.xwork2.ActionContext extends Object implements Serializable

Serialized Fields

context

Map<K,V> context

Class com.opensymphony.xwork2.ActionSupport extends Object implements Serializable

Serialized Fields

validationAware

ValidationAwareSupport validationAware

Class com.opensymphony.xwork2.DefaultActionInvocation extends Object implements Serializable

serialVersionUID: -585293628862447329L

Serialized Fields

action

Object action

proxy

ActionProxy proxy

preResultListeners

List<E> preResultListeners

extraContext

Map<K,V> extraContext

invocationContext

ActionContext invocationContext

interceptors

Iterator<E> interceptors

stack

ValueStack stack

result

Result result

explicitResult

Result explicitResult

resultCode

String resultCode

executed

boolean executed

pushAction

boolean pushAction

objectFactory

ObjectFactory objectFactory

actionEventListener

ActionEventListener actionEventListener

valueStackFactory

ValueStackFactory valueStackFactory

container

Container container

configuration

Configuration configuration

unknownHandlerManager

UnknownHandlerManager unknownHandlerManager

Class com.opensymphony.xwork2.DefaultActionProxy extends Object implements Serializable

serialVersionUID: 3293074152487468527L

Serialized Fields

configuration

Configuration configuration

config

ActionConfig config

invocation

ActionInvocation invocation

unknownHandlerManager

UnknownHandlerManager unknownHandlerManager

actionName

String actionName

namespace

String namespace

method

String method

executeResult

boolean executeResult

cleanupContext

boolean cleanupContext

objectFactory

ObjectFactory objectFactory

actionEventListener

ActionEventListener actionEventListener

Class com.opensymphony.xwork2.DefaultTextProvider extends Object implements Serializable

Class com.opensymphony.xwork2.InvalidMetadataException extends RuntimeException implements Serializable

Class com.opensymphony.xwork2.MockActionInvocation extends MockActionInvocation implements Serializable

Class com.opensymphony.xwork2.ObjectFactory extends Object implements Serializable

Serialized Fields

container

Container container

reflectionProvider

ReflectionProvider reflectionProvider

Class com.opensymphony.xwork2.ValidationAwareSupport extends Object implements Serializable

Serialized Fields

actionErrors

Collection<E> actionErrors

actionMessages

Collection<E> actionMessages

fieldErrors

Map<K,V> fieldErrors

Class com.opensymphony.xwork2.XWorkException extends RuntimeException implements Serializable

Serialized Fields

location

Location location
Package com.opensymphony.xwork2.config

Class com.opensymphony.xwork2.config.ConfigurationException extends XWorkException implements Serializable

Class com.opensymphony.xwork2.config.ReferenceResolverException extends XWorkException implements Serializable

Package com.opensymphony.xwork2.config.entities

Class com.opensymphony.xwork2.config.entities.ActionConfig extends Located implements Serializable

Serialized Fields

interceptors

List<E> interceptors

params

Map<K,V> params

results

Map<K,V> results

exceptionMappings

List<E> exceptionMappings

className

String className

methodName

String methodName

packageName

String packageName

name

String name

allowedMethods

Set<E> allowedMethods

Class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig extends Located implements Serializable

Serialized Fields

name

String name

exceptionClassName

String exceptionClassName

result

String result

params

Map<K,V> params

Class com.opensymphony.xwork2.config.entities.InterceptorConfig extends Located implements Serializable

Serialized Fields

params

Map<K,V> params

className

String className

name

String name

Class com.opensymphony.xwork2.config.entities.InterceptorMapping extends Object implements Serializable

Serialized Fields

name

String name

interceptor

Interceptor interceptor

Class com.opensymphony.xwork2.config.entities.InterceptorStackConfig extends Located implements Serializable

serialVersionUID: 2897260918170270343L

Serialized Fields

interceptors

List<E> interceptors
A list of InterceptorMapping object

name

String name

Class com.opensymphony.xwork2.config.entities.PackageConfig extends Located implements Serializable

Serialized Fields

actionConfigs

Map<K,V> actionConfigs

globalResultConfigs

Map<K,V> globalResultConfigs

interceptorConfigs

Map<K,V> interceptorConfigs

resultTypeConfigs

Map<K,V> resultTypeConfigs

globalExceptionMappingConfigs

List<E> globalExceptionMappingConfigs

parents

List<E> parents

defaultInterceptorRef

String defaultInterceptorRef

defaultActionRef

String defaultActionRef

defaultResultType

String defaultResultType

defaultClassRef

String defaultClassRef

name

String name

namespace

String namespace

isAbstract

boolean isAbstract

needsRefresh

boolean needsRefresh

Class com.opensymphony.xwork2.config.entities.ResultConfig extends Located implements Serializable

Serialized Fields

params

Map<K,V> params

className

String className

name

String name

Class com.opensymphony.xwork2.config.entities.ResultTypeConfig extends Located implements Serializable

Serialized Fields

className

String className

name

String name

defaultResultParam

String defaultResultParam

params

Map<K,V> params
Package com.opensymphony.xwork2.config.impl

Class com.opensymphony.xwork2.config.impl.AbstractMatcher extends Object implements Serializable

Serialized Fields

wildcard

PatternMatcher<E> wildcard

Handles all wildcard pattern matching.

compiledPatterns

List<E> compiledPatterns

The compiled patterns and their associated target objects

Class com.opensymphony.xwork2.config.impl.ActionConfigMatcher extends AbstractMatcher<ActionConfig> implements Serializable

Class com.opensymphony.xwork2.config.impl.DefaultConfiguration extends Object implements Serializable

Serialized Fields

packageContexts

Map<K,V> packageContexts

runtimeConfiguration

RuntimeConfiguration runtimeConfiguration

container

Container container

defaultFrameworkBeanName

String defaultFrameworkBeanName

loadedFileNames

Set<E> loadedFileNames

unknownHandlerStack

List<E> unknownHandlerStack

objectFactory

ObjectFactory objectFactory

Class com.opensymphony.xwork2.config.impl.MockConfiguration extends Object implements Serializable

Serialized Fields

packages

Map<K,V> packages

loadedFiles

Set<E> loadedFiles

container

Container container

unknownHandlerStack

List<E> unknownHandlerStack

builder

ContainerBuilder builder

Class com.opensymphony.xwork2.config.impl.NamespaceMatcher extends AbstractMatcher<NamespaceMatch> implements Serializable

Package com.opensymphony.xwork2.conversion

Class com.opensymphony.xwork2.conversion.TypeConversionException extends XWorkException implements Serializable

Package com.opensymphony.xwork2.inject

Class com.opensymphony.xwork2.inject.DependencyException extends RuntimeException implements Serializable

Package com.opensymphony.xwork2.inject.util

Class com.opensymphony.xwork2.inject.util.ReferenceCache extends ReferenceMap<K,V> implements Serializable

serialVersionUID: 0L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException

Class com.opensymphony.xwork2.inject.util.ReferenceMap extends Object implements Serializable

serialVersionUID: 0L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Throws:
IOException
Serialized Fields

keyReferenceType

ReferenceType keyReferenceType

valueReferenceType

ReferenceType valueReferenceType
Package com.opensymphony.xwork2.interceptor

Class com.opensymphony.xwork2.interceptor.AbstractInterceptor extends Object implements Serializable

Class com.opensymphony.xwork2.interceptor.AliasInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

aliasesKey

String aliasesKey

valueStackFactory

ValueStackFactory valueStackFactory

Class com.opensymphony.xwork2.interceptor.ChainingInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

excludes

Collection<E> excludes

includes

Collection<E> includes

reflectionProvider

ReflectionProvider reflectionProvider

Class com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor extends AbstractInterceptor implements Serializable

Class com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor extends MethodFilterInterceptor implements Serializable

serialVersionUID: 7563014655616490865L

Serialized Fields

inputResultName

String inputResultName

Class com.opensymphony.xwork2.interceptor.ExceptionHolder extends Object implements Serializable

Serialized Fields

exception

Exception exception

Class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

categoryLogger

Logger categoryLogger

logEnabled

boolean logEnabled

logCategory

String logCategory

logLevel

String logLevel

Class com.opensymphony.xwork2.interceptor.I18nInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

parameterName

String parameterName

requestOnlyParameterName

String requestOnlyParameterName

attributeName

String attributeName

Class com.opensymphony.xwork2.interceptor.LoggingInterceptor extends AbstractInterceptor implements Serializable

Class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

excludeMethods

Set<E> excludeMethods

includeMethods

Set<E> includeMethods

Class com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

refreshModelBeforeResult

boolean refreshModelBeforeResult

Class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

allowed

Collection<E> allowed

blocked

Collection<E> blocked

includesExcludesMap

Map<K,V> includesExcludesMap

defaultBlock

boolean defaultBlock

Class com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor extends AbstractInterceptor implements Serializable

serialVersionUID: 1L

Serialized Fields

paramNames

Set<E> paramNames

paramValues

Set<E> paramValues

Class com.opensymphony.xwork2.interceptor.ParametersInterceptor extends MethodFilterInterceptor implements Serializable

Serialized Fields

ordered

boolean ordered

excludeParams

Set<E> excludeParams

acceptParams

Set<E> acceptParams

acceptedParamNames

String acceptedParamNames

acceptedPattern

Pattern acceptedPattern

valueStackFactory

ValueStackFactory valueStackFactory

Class com.opensymphony.xwork2.interceptor.PrepareInterceptor extends MethodFilterInterceptor implements Serializable

serialVersionUID: -5216969014510719786L

Serialized Fields

alwaysInvokePrepare

boolean alwaysInvokePrepare

Class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

scope

String scope

name

String name

className

String className

objectFactory

ObjectFactory objectFactory

Class com.opensymphony.xwork2.interceptor.StaticParametersInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

parse

boolean parse

overwrite

boolean overwrite

merge

boolean merge

valueStackFactory

ValueStackFactory valueStackFactory

Class com.opensymphony.xwork2.interceptor.TimerInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

categoryLogger

Logger categoryLogger

logCategory

String logCategory

logLevel

String logLevel
Package com.opensymphony.xwork2.interceptor.annotations

Class com.opensymphony.xwork2.interceptor.annotations.AnnotationParameterFilterIntereptor extends AbstractInterceptor implements Serializable

Class com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor extends Object implements Serializable

Package com.opensymphony.xwork2.mock

Class com.opensymphony.xwork2.mock.MockActionInvocation extends Object implements Serializable

Serialized Fields

action

Object action

invocationContext

ActionContext invocationContext

actionEventListener

ActionEventListener actionEventListener

proxy

ActionProxy proxy

result

Result result

resultCode

String resultCode

stack

ValueStack stack

preResultListeners

List<E> preResultListeners

Class com.opensymphony.xwork2.mock.MockInterceptor extends Object implements Serializable

serialVersionUID: 2692551676567227756L

Serialized Fields

expectedFoo

String expectedFoo

foo

String foo

executed

boolean executed

Class com.opensymphony.xwork2.mock.MockResult extends Object implements Serializable

Package com.opensymphony.xwork2.ognl

Class com.opensymphony.xwork2.ognl.OgnlValueStack extends Object implements Serializable

serialVersionUID: 370737852934925530L

Serialization Methods

readResolve

private Object readResolve()
Serialized Fields

devMode

boolean devMode

logMissingProperties

boolean logMissingProperties

root

CompoundRoot root

defaultType

Class<T> defaultType

overrides

Map<K,V> overrides
Package com.opensymphony.xwork2.spring

Class com.opensymphony.xwork2.spring.SpringObjectFactory extends ObjectFactory implements Serializable

Serialized Fields

appContext

ApplicationContext appContext

autoWiringFactory

AutowireCapableBeanFactory autoWiringFactory

autowireStrategy

int autowireStrategy

classes

Map<K,V> classes

useClassCache

boolean useClassCache

alwaysRespectAutowireStrategy

boolean alwaysRespectAutowireStrategy

Class com.opensymphony.xwork2.spring.SpringProxyableObjectFactory extends SpringObjectFactory implements Serializable

Serialized Fields

skipBeanNames

List<E> skipBeanNames
Package com.opensymphony.xwork2.spring.interceptor

Class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

initialized

boolean initialized

context

ApplicationContext context

factory

SpringObjectFactory factory

autowireStrategy

Integer autowireStrategy
Package com.opensymphony.xwork2.util

Class com.opensymphony.xwork2.util.CompoundRoot extends ArrayList implements Serializable

Class com.opensymphony.xwork2.util.XWorkList extends ArrayList implements Serializable

Serialized Fields

clazz

Class<T> clazz

conv

XWorkConverter conv

objectFactory

ObjectFactory objectFactory
Package com.opensymphony.xwork2.util.location

Class com.opensymphony.xwork2.util.location.LocatableProperties extends Properties implements Serializable

Serialized Fields

location

Location location

propLocations

Map<K,V> propLocations

Class com.opensymphony.xwork2.util.location.LocationImpl extends Object implements Serializable

Serialization Methods

readResolve

private Object readResolve()
Ensure serialized unknown location resolve to Location.UNKNOWN.

Serialized Fields

uri

String uri

line

int line

column

int column

description

String description
Package com.opensymphony.xwork2.util.profiling

Class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean extends Object implements Serializable

serialVersionUID: -6180672043920208784L

Serialized Fields

children

List<E> children

parent

ProfilingTimerBean parent

resource

String resource

startTime

long startTime

totalTime

long totalTime
Package com.opensymphony.xwork2.util.reflection

Class com.opensymphony.xwork2.util.reflection.ReflectionException extends XWorkException implements Serializable

Package com.opensymphony.xwork2.validator

Class com.opensymphony.xwork2.validator.ValidationException extends Exception implements Serializable

Class com.opensymphony.xwork2.validator.ValidationInterceptor extends MethodFilterInterceptor implements Serializable

Serialized Fields

validateAnnotatedMethodOnly

boolean validateAnnotatedMethodOnly

actionValidatorManager

ActionValidatorManager actionValidatorManager

alwaysInvokeValidate

boolean alwaysInvokeValidate

programmatic

boolean programmatic

declarative

boolean declarative

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Action (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface Action

All Known Implementing Classes:
ActionSupport
public interface Action

All actions may implement this interface, which exposes the execute() method.

However, as of XWork 1.1, this is not required and is only here to assist users. You are free to create POJOs that honor the same contract defined by this interface without actually implementing the interface.

Field Summary
static String | ERROR The action execution was a failure.
static String | INPUT The action execution require more input in order to succeed.
static String | LOGIN The action could not execute, since the user most was not logged in.
static String | NONE The action execution was successful but do not show a view.
static String | SUCCESS The action execution was successful.
Method Summary
 String execute()
Where the logic of the action is executed.

Field Detail

SUCCESS

static final String SUCCESS
The action execution was successful. Show result view to the end user.

See Also:
Constant Field Values

NONE

static final String NONE
The action execution was successful but do not show a view. This is useful for actions that are handling the view in another fashion like redirect.

See Also:
Constant Field Values

ERROR

static final String ERROR
The action execution was a failure. Show an error view, possibly asking the user to retry entering data.

See Also:
Constant Field Values

INPUT

static final String INPUT
The action execution require more input in order to succeed. This result is typically used if a form handling action has been executed so as to provide defaults for a form. The form associated with the handler should be shown to the end user.

This result is also used if the given input params are invalid, meaning the user should try providing input again.

See Also:
Constant Field Values

LOGIN

static final String LOGIN
The action could not execute, since the user most was not logged in. The login view should be shown.

See Also:
Constant Field Values
Method Detail

execute

String execute()
               throws Exception
Where the logic of the action is executed.

Returns:
a string representing the logical result of the execution. See constants in this interface for a list of standard result values.
Throws:
Exception - thrown if a system level exception occurs. Note: Application level exceptions should be handled by returning an error value, such as Action.ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ActionChainResult (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class ActionChainResult

java.lang.Object
    extended by  com.opensymphony.xwork2.ActionChainResult
All Implemented Interfaces:
Result, Serializable
public class ActionChainResult
extends Object
implements Result

This result invokes an entire other action, complete with it's own interceptor stack and result. This result type takes the following parameters:

  • actionName (default) - the name of the action that will be chained to
  • namespace - used to determine which namespace the Action is in that we're chaining. If namespace is null, this defaults to the current namespace
  • method - used to specify another method on target action to be invoked. If null, this defaults to execute method
  • skipActions - (optional) the list of comma separated action names for the actions that could be chained to
Example:

 <package name="public" extends="struts-default">
     <!-- Chain creatAccount to login, using the default parameter -->
     <action name="createAccount" class="...">
         <result type="chain">login</result>
     </action>

     <action name="login" class="...">
         <!-- Chain to another namespace -->
         <result type="chain">
             <param name="actionName">dashboard</param>
             <param name="namespace">/secure</param>
         </result>
     </action>
 </package>

 <package name="secure" extends="struts-default" namespace="/secure">
     <action name="dashboard" class="...">
         <result>dashboard.jsp</result>
     </action>
 </package>

Author:
Alexandru Popescu
See Also:
Serialized Form

Field Summary
static String | DEFAULT_PARAM The result parameter name to set the name of the action to chain to.
static String | SKIP_ACTIONS_PARAM The result parameter name to set the name of the action to chain to.
Constructor Summary
ActionChainResult()
ActionChainResult(String namespace, String actionName, String methodName)
ActionChainResult(String namespace, String actionName, String methodName, String skipActions)
Method Summary
boolean | equals(Object o)
void | execute(ActionInvocation invocation) Represents a generic interface for all action execution results.
static LinkedList<String> | getChainHistory() Get the XWork chain history.
ActionProxy | getProxy()
int | hashCode()
void | setActionName(String actionName) Set the action name.
void | setActionProxyFactory(ActionProxyFactory actionProxyFactory)
void | setMethod(String method)
void | setNamespace(String namespace) sets the namespace of the Action that we're chaining to.
void | setSkipActions(String actions) Set the list of actions to skip.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_PARAM

public static final String DEFAULT_PARAM
The result parameter name to set the name of the action to chain to.

See Also:
Constant Field Values

SKIP_ACTIONS_PARAM

public static final String SKIP_ACTIONS_PARAM
The result parameter name to set the name of the action to chain to.

See Also:
Constant Field Values
Constructor Detail

ActionChainResult

public ActionChainResult()

ActionChainResult

public ActionChainResult(String namespace,
                         String actionName,
                         String methodName)

ActionChainResult

public ActionChainResult(String namespace,
                         String actionName,
                         String methodName,
                         String skipActions)
Method Detail

setActionProxyFactory

public void setActionProxyFactory(ActionProxyFactory actionProxyFactory)
Parameters:
actionProxyFactory - the actionProxyFactory to set

setActionName

public void setActionName(String actionName)
Set the action name.

Parameters:
actionName - The action name.

setNamespace

public void setNamespace(String namespace)
sets the namespace of the Action that we're chaining to. if namespace is null, this defaults to the current namespace.

Parameters:
namespace - the name of the namespace we're chaining to

setSkipActions

public void setSkipActions(String actions)
Set the list of actions to skip. To test if an action should not throe an infinite recursion, only the action name is used, not the namespace.

Parameters:
actions - The list of action name separated by a white space.

setMethod

public void setMethod(String method)

getProxy

public ActionProxy getProxy()

getChainHistory

public static LinkedList<String> getChainHistory()
Get the XWork chain history. The stack is a list of namespace/action!method keys.

execute

public void execute(ActionInvocation invocation)
             throws Exception
Description copied from interface: Result
Represents a generic interface for all action execution results. Whether that be displaying a webpage, generating an email, sending a JMS message, etc.

Specified by:
execute in interface Result
Parameters:
invocation - the DefaultActionInvocation calling the action call stack
Throws:
Exception - can be thrown.

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionContext (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class ActionContext

java.lang.Object
    extended by  com.opensymphony.xwork2.ActionContext
All Implemented Interfaces:
Serializable
public class ActionContext
extends Object
implements Serializable

The ActionContext is the context in which an Action is executed. Each context is basically a container of objects an action needs for execution like the session, parameters, locale, etc.

The ActionContext is thread local which means that values stored in the ActionContext are unique per thread. See the ThreadLocal class for more information. The benefit of this is you don't need to worry about a user specific action context, you just get it:

    ActionContext context = ActionContext.getContext();

Finally, because of the thread local usage you don't need to worry about making your actions thread safe.

Author:
Patrick Lightbody, Bill Lynch (docs)
See Also:
Serialized Form

Field Summary
static String | ACTION_INVOCATION Constant for the action's invocation context.
static String | ACTION_NAME Constant for the name of the action being executed.
static String | APPLICATION Constant for the action's application context.
static String | CONTAINER Constant for the container
static String | CONVERSION_ERRORS Constant for the map of type conversion errors.
static String | LOCALE Constant for the action's locale.
static String | PARAMETERS Constant for the action's parameters.
static String | SESSION Constant for the action's session.
static String | TYPE_CONVERTER Constant for the action's type converter.
static String | VALUE_STACK Constant for the OGNL value stack.
Constructor Summary
ActionContext(Map<String,Object> context)
Creates a new ActionContext initialized with another context.
Method Summary
 Object get(String key)
Returns a value that is stored in the current ActionContext by doing a lookup using the value's key.
 ActionInvocation getActionInvocation()
Gets the action invocation (the execution state).
 Map<String,Object> getApplication()
Returns a Map of the ServletContext when in a servlet environment or a generic application level Map otherwise.
 Container getContainer()
Sets the container for this request
static ActionContext getContext()
Returns the ActionContext specific to the current thread.
 Map<String,Object> getContextMap()
Gets the context map.
 Map<String,Object> getConversionErrors()
Gets the map of conversion errors which occurred when executing the action.
<T> T
getInstance(Class<T> type)
 Locale getLocale()
Gets the Locale of the current action.
 String getName()
Gets the name of the current Action.
 Map<String,Object> getParameters()
Returns a Map of the HttpServletRequest parameters when in a servlet environment or a generic Map of parameters otherwise.
 Map<String,Object> getSession()
Gets the Map of HttpSession values when in a servlet environment or a generic session map otherwise.
 ValueStack getValueStack()
Gets the OGNL value stack.
 void put(String key, Object value)
Stores a value in the current ActionContext.
 void setActionInvocation(ActionInvocation actionInvocation)
Sets the action invocation (the execution state).
 void setApplication(Map<String,Object> application)
Sets the action's application context.
 void setContainer(Container cont)
Gets the container for this request
static void setContext(ActionContext context)
Sets the action context for the current thread.
 void setContextMap(Map<String,Object> contextMap)
Sets the action's context map.
 void setConversionErrors(Map<String,Object> conversionErrors)
Sets conversion errors which occurred when executing the action.
 void setLocale(Locale locale)
Sets the Locale for the current action.
 void setName(String name)
Sets the name of the current Action in the ActionContext.
 void setParameters(Map<String,Object> parameters)
Sets the action parameters.
 void setSession(Map<String,Object> session)
Sets a map of action session values.
 void setValueStack(ValueStack stack)
Sets the OGNL value stack.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ACTION_NAME

public static final String ACTION_NAME
Constant for the name of the action being executed.

See Also:
Constant Field Values

VALUE_STACK

public static final String VALUE_STACK
Constant for the OGNL value stack.

See Also:
Constant Field Values

SESSION

public static final String SESSION
Constant for the action's session.

See Also:
Constant Field Values

APPLICATION

public static final String APPLICATION
Constant for the action's application context.

See Also:
Constant Field Values

PARAMETERS

public static final String PARAMETERS
Constant for the action's parameters.

See Also:
Constant Field Values

LOCALE

public static final String LOCALE
Constant for the action's locale.

See Also:
Constant Field Values

TYPE_CONVERTER

public static final String TYPE_CONVERTER
Constant for the action's type converter.

See Also:
Constant Field Values

ACTION_INVOCATION

public static final String ACTION_INVOCATION
Constant for the action's invocation context.

See Also:
Constant Field Values

CONVERSION_ERRORS

public static final String CONVERSION_ERRORS
Constant for the map of type conversion errors.

See Also:
Constant Field Values

CONTAINER

public static final String CONTAINER
Constant for the container

See Also:
Constant Field Values
Constructor Detail

ActionContext

public ActionContext(Map<String,Object> context)
Creates a new ActionContext initialized with another context.

Parameters:
context - a context map.
Method Detail

setActionInvocation

public void setActionInvocation(ActionInvocation actionInvocation)
Sets the action invocation (the execution state).

Parameters:
actionInvocation - the action execution state.

getActionInvocation

public ActionInvocation getActionInvocation()
Gets the action invocation (the execution state).

Returns:
the action invocation (the execution state).

setApplication

public void setApplication(Map<String,Object> application)
Sets the action's application context.

Parameters:
application - the action's application context.

getApplication

public Map<String,Object> getApplication()
Returns a Map of the ServletContext when in a servlet environment or a generic application level Map otherwise.

Returns:
a Map of ServletContext or generic application level Map

setContext

public static void setContext(ActionContext context)
Sets the action context for the current thread.

Parameters:
context - the action context.

getContext

public static ActionContext getContext()
Returns the ActionContext specific to the current thread.

Returns:
the ActionContext for the current thread, is never null.

setContextMap

public void setContextMap(Map<String,Object> contextMap)
Sets the action's context map.

Parameters:
contextMap - the context map.

getContextMap

public Map<String,Object> getContextMap()
Gets the context map.

Returns:
the context map.

setConversionErrors

public void setConversionErrors(Map<String,Object> conversionErrors)
Sets conversion errors which occurred when executing the action.

Parameters:
conversionErrors - a Map of errors which occurred when executing the action.

getConversionErrors

public Map<String,Object> getConversionErrors()
Gets the map of conversion errors which occurred when executing the action.

Returns:
the map of conversion errors which occurred when executing the action or an empty map if there were no errors.

setLocale

public void setLocale(Locale locale)
Sets the Locale for the current action.

Parameters:
locale - the Locale for the current action.

getLocale

public Locale getLocale()
Gets the Locale of the current action. If no locale was ever specified the platform's default locale is used.

Returns:
the Locale of the current action.

setName

public void setName(String name)
Sets the name of the current Action in the ActionContext.

Parameters:
name - the name of the current action.

getName

public String getName()
Gets the name of the current Action.

Returns:
the name of the current action.

setParameters

public void setParameters(Map<String,Object> parameters)
Sets the action parameters.

Parameters:
parameters - the parameters for the current action.

getParameters

public Map<String,Object> getParameters()
Returns a Map of the HttpServletRequest parameters when in a servlet environment or a generic Map of parameters otherwise.

Returns:
a Map of HttpServletRequest parameters or a multipart map when in a servlet environment, or a generic Map of parameters otherwise.

setSession

public void setSession(Map<String,Object> session)
Sets a map of action session values.

Parameters:
session - the session values.

getSession

public Map<String,Object> getSession()
Gets the Map of HttpSession values when in a servlet environment or a generic session map otherwise.

Returns:
the Map of HttpSession values when in a servlet environment or a generic session map otherwise.

setValueStack

public void setValueStack(ValueStack stack)
Sets the OGNL value stack.

Parameters:
stack - the OGNL value stack.

getValueStack

public ValueStack getValueStack()
Gets the OGNL value stack.

Returns:
the OGNL value stack.

setContainer

public void setContainer(Container cont)
Gets the container for this request

Parameters:
cont - The container

getContainer

public Container getContainer()
Sets the container for this request

Returns:
The container

getInstance

public <T> T getInstance(Class<T> type)

get

public Object get(String key)
Returns a value that is stored in the current ActionContext by doing a lookup using the value's key.

Parameters:
key - the key used to find the value.
Returns:
the value that was found using the key or null if the key was not found.

put

public void put(String key,
                Object value)
Stores a value in the current ActionContext. The value can be looked up using the key.

Parameters:
key - the key of the value.
value - the value to be stored.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionEventListener (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface ActionEventListener

public interface ActionEventListener

Provides hooks for handling key action events

Method Summary
String | handleException(Throwable t, ValueStack stack) Called when an exception is thrown by the action
Object | prepare(Object action, ValueStack stack) Called after an action has been created.

Method Detail

prepare

Object prepare(Object action,
               ValueStack stack)
Called after an action has been created.

Parameters:
action - The action
stack - The current value stack
Returns:
The action to use

handleException

String handleException(Throwable t,
                       ValueStack stack)
Called when an exception is thrown by the action

Parameters:
t - The exception/error that was thrown
stack - The current value stack
Returns:
A result code to execute, can be null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionInvocation (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface ActionInvocation

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultActionInvocation, MockActionInvocation, MockActionInvocation
public interface ActionInvocation
extends Serializable

An ActionInvocation represents the execution state of an Action. It holds the Interceptors and the Action instance. By repeated re-entrant execution of the invoke() method, initially by the ActionProxy, then by the Interceptors, the Interceptors are all executed, and then the Action and the Result.

Author:
Jason Carreira
See Also:
ActionProxy

Method Summary
void | addPreResultListener(PreResultListener listener) Register a PreResultListener to be notified after the Action is executed and before the Result is executed.
Object | getAction() Get the Action associated with this ActionInvocation.
ActionContext | getInvocationContext() Gets the ActionContext associated with this ActionInvocation.
ActionProxy | getProxy() Get the ActionProxy holding this ActionInvocation.
Result | getResult() If the ActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned.
String | getResultCode() Gets the result code returned from this ActionInvocation.
ValueStack | getStack() Gets the ValueStack associated with this ActionInvocation.
void | init(ActionProxy proxy)
String | invoke() Invokes the next step in processing this ActionInvocation.
String | invokeActionOnly() Invokes only the Action (not Interceptors or Results).
boolean | isExecuted() Gets whether this ActionInvocation has executed before.
void | setActionEventListener(ActionEventListener listener) Sets the action event listener to respond to key action events.
void | setResultCode(String resultCode) Sets the result code, possibly overriding the one returned by the action.

Method Detail

getAction

Object getAction()
Get the Action associated with this ActionInvocation.

Returns:
the Action

isExecuted

boolean isExecuted()
Gets whether this ActionInvocation has executed before. This will be set after the Action and the Result have executed.

Returns:
true if this ActionInvocation has executed before.

getInvocationContext

ActionContext getInvocationContext()
Gets the ActionContext associated with this ActionInvocation. The ActionProxy is responsible for setting this ActionContext onto the ThreadLocal before invoking the ActionInvocation and resetting the old ActionContext afterwards.

Returns:
the ActionContext.

getProxy

ActionProxy getProxy()
Get the ActionProxy holding this ActionInvocation.

Returns:
the ActionProxy.

getResult

Result getResult()
                 throws Exception
If the ActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned. If the ActionInvocation's result has not been executed before, the Result instance will be created and populated with the result params.

Returns:
the result.
Throws:
Exception - can be thrown.

getResultCode

String getResultCode()
Gets the result code returned from this ActionInvocation.

Returns:
the result code

setResultCode

void setResultCode(String resultCode)
Sets the result code, possibly overriding the one returned by the action.

The "intended" purpose of this method is to allow PreResultListeners to override the result code returned by the Action.

If this method is used before the Action executes, the Action's returned result code will override what was set. However the Action could (if specifically coded to do so) inspect the ActionInvocation to see that someone "upstream" (e.g. an Interceptor) had suggested a value as the result, and it could therefore return the same value itself.

If this method is called between the Action execution and the Result execution, then the value set here will override the result code the action had returned. Creating an Interceptor that implements PreResultListener will give you this oportunity.

If this method is called after the Result has been executed, it will have the effect of raising an IllegalStateException.

Parameters:
resultCode - the result code.
Throws:
IllegalStateException - if called after the Result has been executed.
See Also:
isExecuted()

getStack

ValueStack getStack()
Gets the ValueStack associated with this ActionInvocation.

Returns:
the ValueStack

addPreResultListener

void addPreResultListener(PreResultListener listener)
Register a PreResultListener to be notified after the Action is executed and before the Result is executed.

The ActionInvocation implementation must guarantee that listeners will be called in the order in which they are registered.

Listener registration and execution does not need to be thread-safe.

Parameters:
listener - the listener to add.

invoke

String invoke()
              throws Exception
Invokes the next step in processing this ActionInvocation.

If there are more Interceptors, this will call the next one. If Interceptors choose not to short-circuit ActionInvocation processing and return their own return code, they will call invoke() to allow the next Interceptor to execute. If there are no more Interceptors to be applied, the Action is executed. If the ActionProxy.getExecuteResult() method returns true, the Result is also executed.

Returns:
the return code.
Throws:
Exception - can be thrown.

invokeActionOnly

String invokeActionOnly()
                        throws Exception
Invokes only the Action (not Interceptors or Results).

This is useful in rare situations where advanced usage with the interceptor/action/result workflow is being manipulated for certain functionality.

Returns:
the return code.
Throws:
Exception - can be thrown.

setActionEventListener

void setActionEventListener(ActionEventListener listener)
Sets the action event listener to respond to key action events.

Parameters:
listener - the listener.

init

void init(ActionProxy proxy)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionProxy (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface ActionProxy

All Known Implementing Classes:
DefaultActionProxy, MockActionProxy
public interface ActionProxy

ActionProxy is an extra layer between XWork and the action so that different proxies are possible.

An example of this would be a remote proxy, where the layer between XWork and the action might be RMI or SOAP.

Author:
Jason Carreira

Method Summary
String | execute() Execute this ActionProxy.
Object | getAction() Gets the Action instance for this Proxy.
String | getActionName() Gets the alias name this ActionProxy is mapped to.
ActionConfig | getConfig() Gets the ActionConfig this ActionProxy is built from.
boolean | getExecuteResult() Gets the status of whether the ActionProxy is set to execute the Result after the Action is executed.
ActionInvocation | getInvocation() Gets the ActionInvocation associated with this ActionProxy.
String | getMethod() Gets the method name to execute, or null if no method has been specified (meaning execute will be invoked).
String | getNamespace() Gets the namespace the ActionConfig for this ActionProxy is mapped to.
void | setExecuteResult(boolean executeResult) Sets whether this ActionProxy should also execute the Result after executing the Action.

Method Detail

getAction

Object getAction()
Gets the Action instance for this Proxy.

Returns:
the Action instance

getActionName

String getActionName()
Gets the alias name this ActionProxy is mapped to.

Returns:
the alias name

getConfig

ActionConfig getConfig()
Gets the ActionConfig this ActionProxy is built from.

Returns:
the ActionConfig

setExecuteResult

void setExecuteResult(boolean executeResult)
Sets whether this ActionProxy should also execute the Result after executing the Action.

Parameters:
executeResult - true to also execute the Result.

getExecuteResult

boolean getExecuteResult()
Gets the status of whether the ActionProxy is set to execute the Result after the Action is executed.

Returns:
the status

getInvocation

ActionInvocation getInvocation()
Gets the ActionInvocation associated with this ActionProxy.

Returns:
the ActionInvocation

getNamespace

String getNamespace()
Gets the namespace the ActionConfig for this ActionProxy is mapped to.

Returns:
the namespace

execute

String execute()
               throws Exception
Execute this ActionProxy. This will set the ActionContext from the ActionInvocation into the ActionContext ThreadLocal before invoking the ActionInvocation, then set the old ActionContext back into the ThreadLocal.

Returns:
the result code returned from executing the ActionInvocation
Throws:
Exception - can be thrown.
See Also:
ActionInvocation

getMethod

String getMethod()
Gets the method name to execute, or null if no method has been specified (meaning execute will be invoked).

Returns:
the method to execute
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionProxyFactory (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface ActionProxyFactory

All Known Implementing Classes:
DefaultActionProxyFactory
public interface ActionProxyFactory

The ActionProxyFactory is used to create ActionProxys to be executed.

It is the entry point to XWork that is used by a dispatcher to create an ActionProxy to execute for a particular namespace and action name.

Author:
Jason Carreira
See Also:
DefaultActionProxyFactory

Method Summary
 ActionProxy createActionProxy(ActionInvocation actionInvocation, String namespace, String actionName, String methodName, boolean executeResult, boolean cleanupContext)
Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including passed ActionInvocation instance.
 ActionProxy createActionProxy(String namespace, String actionName, Map<String,Object> extraContext)
Deprecated. Since 2.1.1, use instead
 ActionProxy createActionProxy(String namespace, String actionName, Map<String,Object> extraContext, boolean executeResult, boolean cleanupContext)
Deprecated. Since 2.1.1, use createActionProxy(String,String,String,Map,boolean,boolean) instead
 ActionProxy createActionProxy(String namespace, String actionName, String methodName, Map<String,Object> extraContext)
Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.
 ActionProxy createActionProxy(String namespace, String actionName, String methodName, Map<String,Object> extraContext, boolean executeResult, boolean cleanupContext)
Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.

Method Detail

createActionProxy

@Deprecated
ActionProxy createActionProxy(String namespace,
                                         String actionName,
                                         Map<String,Object> extraContext)
Deprecated. Since 2.1.1, use instead

Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.

Note: This is the most used create method.

Parameters:
namespace - the namespace of the action, can be null
actionName - the name of the action
extraContext - a Map of extra parameters to be provided to the ActionProxy, can be null
Returns:
ActionProxy the created action proxy

createActionProxy

ActionProxy createActionProxy(String namespace,
                              String actionName,
                              String methodName,
                              Map<String,Object> extraContext)
Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.

Note: This is the most used create method.

Parameters:
namespace - the namespace of the action, can be null
actionName - the name of the action
methodName - the name of the method to execute
extraContext - a Map of extra parameters to be provided to the ActionProxy, can be null
Returns:
ActionProxy the created action proxy
Since:
2.1.1

createActionProxy

@Deprecated
ActionProxy createActionProxy(String namespace,
                                         String actionName,
                                         Map<String,Object> extraContext,
                                         boolean executeResult,
                                         boolean cleanupContext)
Deprecated. Since 2.1.1, use createActionProxy(String,String,String,Map,boolean,boolean) instead

Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.

Parameters:
namespace - the namespace of the action, can be null
actionName - the name of the action
extraContext - a Map of extra parameters to be provided to the ActionProxy, can be null
executeResult - flag which tells whether the result should be executed after the action
cleanupContext - flag which tells whether the original context should be preserved during execution of the proxy.
Returns:
ActionProxy the created action proxy

createActionProxy

ActionProxy createActionProxy(String namespace,
                              String actionName,
                              String methodName,
                              Map<String,Object> extraContext,
                              boolean executeResult,
                              boolean cleanupContext)
Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.

Parameters:
namespace - the namespace of the action, can be null
actionName - the name of the action
methodName - the name of the method to execute
extraContext - a Map of extra parameters to be provided to the ActionProxy, can be null
executeResult - flag which tells whether the result should be executed after the action
cleanupContext - flag which tells whether the original context should be preserved during execution of the proxy.
Returns:
ActionProxy the created action proxy
Since:
2.1.1

createActionProxy

ActionProxy createActionProxy(ActionInvocation actionInvocation,
                              String namespace,
                              String actionName,
                              String methodName,
                              boolean executeResult,
                              boolean cleanupContext)
Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including passed ActionInvocation instance.

Parameters:
actionInvocation - the action invocation instance to associate with
namespace - the namespace of the action, can be null
actionName - the name of the action
methodName - the name of the method to execute
executeResult - flag which tells whether the result should be executed after the action
cleanupContext - flag which tells whether the original context should be preserved during execution of the proxy.
Returns:
ActionProxy the created action proxy
Since:
2.1.1
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionSupport (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class ActionSupport

java.lang.Object
    extended by  com.opensymphony.xwork2.ActionSupport
All Implemented Interfaces:
Action, LocaleProvider, TextProvider, Validateable, ValidationAware, Serializable
public class ActionSupport
extends Object
implements Action, Validateable, ValidationAware, TextProvider, LocaleProvider, Serializable

Provides a default implementation for the most common actions. See the documentation for all the interfaces this class implements for more detailed information.

See Also:
Serialized Form

Field Summary
protected static Logger LOG
Fields inherited from interface com.opensymphony.xwork2.Action
ERROR, INPUT, LOGIN, NONE, SUCCESS
Constructor Summary
ActionSupport()
Method Summary
 void addActionError(String anErrorMessage)
Add an Action-level error message to this Action.
 void addActionMessage(String aMessage)
Add an Action-level message to this Action.
 void addFieldError(String fieldName, String errorMessage)
Add an error message for a given field.
 void clearActionErrors()
Clears action errors.
 void clearErrors()
Clears all errors.
 void clearErrorsAndMessages()
Clears all errors and messages.
 void clearFieldErrors()
Clears field errors.
 void clearMessages()
Clears messages.
 Object clone()
 String doDefault()
 String execute()
A default implementation that does nothing an returns "success".
 Collection<String> getActionErrors()
Get the Collection of Action-level error messages for this action.
 Collection<String> getActionMessages()
Get the Collection of Action-level messages for this action.
 Collection<String> getErrorMessages()
Deprecated. Use getActionErrors().
 Map<String,List<String>> getErrors()
Deprecated. Use getFieldErrors().
 Map<String,List<String>> getFieldErrors()
Get the field specific errors associated with this action.
 Locale getLocale()
Gets the provided locale.
 String getText(String aTextName)
Gets a message based on a message key, or null if no message is found.
 String getText(String aTextName, List<Object> args)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
 String getText(String aTextName, String defaultValue)
Gets a message based on a key, or, if the message is not found, a supplied default value is returned.
 String getText(String key, String[] args)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
 String getText(String aTextName, String defaultValue, List<Object> args)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
 String getText(String key, String defaultValue, List<Object> args, ValueStack stack)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
 String getText(String aTextName, String defaultValue, String obj)
Gets a message based on a key using the supplied obj, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
 String getText(String key, String defaultValue, String[] args)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
 String getText(String key, String defaultValue, String[] args, ValueStack stack)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
 ResourceBundle getTexts()
Get the resource bundle associated with the implementing class (usually an action).
 ResourceBundle getTexts(String aBundleName)
Get the named bundle, such as "com/acme/Foo".
 boolean hasActionErrors()
Check whether there are any Action-level error messages.
 boolean hasActionMessages()
Checks whether there are any Action-level messages.
 boolean hasErrors()
Checks whether there are any action errors or field errors.
 boolean hasFieldErrors()
Check whether there are any field errors associated with this action.
 boolean hasKey(String key)
Checks if a message key exists.
 String input()
 void pause(String result)
Stops the action invocation immediately (by throwing a PauseException) and causes the action invocation to return the specified result, such as Action.SUCCESS, Action.INPUT, etc.
 void setActionErrors(Collection<String> errorMessages)
Set the Collection of Action-level String error messages.
 void setActionMessages(Collection<String> messages)
Set the Collection of Action-level String messages (not errors).
 void setFieldErrors(Map<String,List<String>> errorMap)
Set the field error map of fieldname (String) to Collection of String error messages.
 void validate()
A default implementation that validates nothing.
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

protected static Logger LOG
Constructor Detail

ActionSupport

public ActionSupport()
Method Detail

setActionErrors

public void setActionErrors(Collection<String> errorMessages)
Description copied from interface: ValidationAware
Set the Collection of Action-level String error messages.

Specified by:
setActionErrors in interface ValidationAware
Parameters:
errorMessages - Collection of String error messages

getActionErrors

public Collection<String> getActionErrors()
Description copied from interface: ValidationAware
Get the Collection of Action-level error messages for this action. Error messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getActionErrors in interface ValidationAware
Returns:
Collection of String error messages

setActionMessages

public void setActionMessages(Collection<String> messages)
Description copied from interface: ValidationAware
Set the Collection of Action-level String messages (not errors).

Specified by:
setActionMessages in interface ValidationAware
Parameters:
messages - Collection of String messages (not errors).

getActionMessages

public Collection<String> getActionMessages()
Description copied from interface: ValidationAware
Get the Collection of Action-level messages for this action. Messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getActionMessages in interface ValidationAware
Returns:
Collection of String messages

getErrorMessages

@Deprecated
public Collection<String> getErrorMessages()
Deprecated. Use getActionErrors().

getErrors

@Deprecated
public Map<String,List<String>> getErrors()
Deprecated. Use getFieldErrors().

setFieldErrors

public void setFieldErrors(Map<String,List<String>> errorMap)
Description copied from interface: ValidationAware
Set the field error map of fieldname (String) to Collection of String error messages.

Specified by:
setFieldErrors in interface ValidationAware
Parameters:
errorMap - field error map

getFieldErrors

public Map<String,List<String>> getFieldErrors()
Description copied from interface: ValidationAware
Get the field specific errors associated with this action. Error messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getFieldErrors in interface ValidationAware
Returns:
Map with errors mapped from fieldname (String) to Collection of String error messages

getLocale

public Locale getLocale()
Description copied from interface: LocaleProvider
Gets the provided locale.

Specified by:
getLocale in interface LocaleProvider
Returns:
the locale.

hasKey

public boolean hasKey(String key)
Description copied from interface: TextProvider
Checks if a message key exists.

Specified by:
hasKey in interface TextProvider
Returns:
boolean true if key exists, false otherwise.

getText

public String getText(String aTextName)
Description copied from interface: TextProvider
Gets a message based on a message key, or null if no message is found.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
Returns:
the message as found in the resource bundle, or null if none is found.

getText

public String getText(String aTextName,
                      String defaultValue)
Description copied from interface: TextProvider
Gets a message based on a key, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String aTextName,
                      String defaultValue,
                      String obj)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied obj, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
obj - obj to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String aTextName,
                      List<Object> args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
args - a list args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or null if none is found.

getText

public String getText(String key,
                      String[] args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
args - an array args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or null if none is found.

getText

public String getText(String aTextName,
                      String defaultValue,
                      List<Object> args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - a list args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      String[] args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - an array args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      List<Object> args,
                      ValueStack stack)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - a list args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      String[] args,
                      ValueStack stack)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - an array args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getTexts

public ResourceBundle getTexts()
Description copied from interface: TextProvider
Get the resource bundle associated with the implementing class (usually an action).

Specified by:
getTexts in interface TextProvider
Returns:
the bundle

getTexts

public ResourceBundle getTexts(String aBundleName)
Description copied from interface: TextProvider
Get the named bundle, such as "com/acme/Foo".

Specified by:
getTexts in interface TextProvider
Parameters:
aBundleName - the name of the resource bundle, such as "com/acme/Foo".
Returns:
the bundle

addActionError

public void addActionError(String anErrorMessage)
Description copied from interface: ValidationAware
Add an Action-level error message to this Action.

Specified by:
addActionError in interface ValidationAware
Parameters:
anErrorMessage - the error message

addActionMessage

public void addActionMessage(String aMessage)
Description copied from interface: ValidationAware
Add an Action-level message to this Action.

Specified by:
addActionMessage in interface ValidationAware
Parameters:
aMessage - the message

addFieldError

public void addFieldError(String fieldName,
                          String errorMessage)
Description copied from interface: ValidationAware
Add an error message for a given field.

Specified by:
addFieldError in interface ValidationAware
Parameters:
fieldName - name of field
errorMessage - the error message

input

public String input()
             throws Exception
Throws:
Exception

doDefault

public String doDefault()
                 throws Exception
Throws:
Exception

execute

public String execute()
               throws Exception
A default implementation that does nothing an returns "success".

Subclasses should override this method to provide their business logic.

See also Action.execute().

Specified by:
execute in interface Action
Returns:
returns Action.SUCCESS
Throws:
Exception - can be thrown by subclasses.

hasActionErrors

public boolean hasActionErrors()
Description copied from interface: ValidationAware
Check whether there are any Action-level error messages.

Specified by:
hasActionErrors in interface ValidationAware
Returns:
true if any Action-level error messages have been registered

hasActionMessages

public boolean hasActionMessages()
Description copied from interface: ValidationAware
Checks whether there are any Action-level messages.

Specified by:
hasActionMessages in interface ValidationAware
Returns:
true if any Action-level messages have been registered

hasErrors

public boolean hasErrors()
Description copied from interface: ValidationAware
Checks whether there are any action errors or field errors.

Note: that this does not have the same meaning as in WW 1.x.

Specified by:
hasErrors in interface ValidationAware
Returns:
(hasActionErrors() || hasFieldErrors())

hasFieldErrors

public boolean hasFieldErrors()
Description copied from interface: ValidationAware
Check whether there are any field errors associated with this action.

Specified by:
hasFieldErrors in interface ValidationAware
Returns:
whether there are any field errors

clearFieldErrors

public void clearFieldErrors()
Clears field errors. Useful for Continuations and other situations where you might want to clear parts of the state on the same action.

clearActionErrors

public void clearActionErrors()
Clears action errors. Useful for Continuations and other situations where you might want to clear parts of the state on the same action.

clearMessages

public void clearMessages()
Clears messages. Useful for Continuations and other situations where you might want to clear parts of the state on the same action.

clearErrors

public void clearErrors()
Clears all errors. Useful for Continuations and other situations where you might want to clear parts of the state on the same action.

clearErrorsAndMessages

public void clearErrorsAndMessages()
Clears all errors and messages. Useful for Continuations and other situations where you might want to clear parts of the state on the same action.

validate

public void validate()
A default implementation that validates nothing. Subclasses should override this method to provide validations.

Specified by:
validate in interface Validateable

clone

public Object clone()
             throws CloneNotSupportedException
Overrides:
clone in class Object
Throws:
CloneNotSupportedException

pause

public void pause(String result)
Stops the action invocation immediately (by throwing a PauseException) and causes the action invocation to return the specified result, such as Action.SUCCESS, Action.INPUT, etc.

The next time this action is invoked (and using the same continuation ID), the method will resume immediately after where this method was called, with the entire call stack in the execute method restored.

Note: this method can only be called within the execute() method.

Parameters:
result - the result to return - the same type of return value in the execute() method.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CompositeTextProvider (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class CompositeTextProvider

java.lang.Object
    extended by  com.opensymphony.xwork2.CompositeTextProvider
All Implemented Interfaces:
TextProvider
public class CompositeTextProvider
extends Object
implements TextProvider

This is a composite TextProvider that takes in an array or List of TextProviders, it will consult each of them in order to get a composite result. To know how each method behaves, please refer to the javadoc for each methods.

Version:
$Date$ $Id$
Author:
tmjee

Constructor Summary
CompositeTextProvider(List<TextProvider> textProviders)
Instantiates a CompositeTextProvider with some predefined textProviders.
CompositeTextProvider(TextProvider[] textProviders)
Instantiates a CompositeTextProvider with some predefined textProviders.
Method Summary
String | getText(String key) It will consult each TextProviders and return the first valid message for this key
String | getText(String key, List<Object> args) It will consult each TextProviders and return the first valid message for this key.
String | getText(String key, String defaultValue) It will consult each TextProviders and return the first valid message for this key before returning defaultValue if every else fails.
String | getText(String key, String[] args) It will consult each TextProviders and return the first valid message for this key.
String | getText(String key, String defaultValue, List<Object> args) It will consult each TextProviders and return the first valid message for this key, before returining defaultValue
String | getText(String key, String defaultValue, List<Object> args, ValueStack stack) It will consult each TextProviders and return the first valid message for this key, before returining defaultValue
String | getText(String key, String defaultValue, String obj) It will consult each TextProviders and return the first valid message for this key, before returining defaultValue if every else fails.
String | getText(String key, String defaultValue, String[] args) It will consult each TextProviders and return the first valid message for this key, before returining defaultValue.
String | getText(String key, String defaultValue, String[] args, ValueStack stack) It will consult each TextProviders and return the first valid message for this key, before returining defaultValue
ResourceBundle | getTexts() It will consult each TextProviders and return the first non-null ResourceBundle.
ResourceBundle | getTexts(String bundleName) It will consult each TextProviders and return the first non-null ResourceBundle.
boolean | hasKey(String key) Checks if a message key exists.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CompositeTextProvider

public CompositeTextProvider(List<TextProvider> textProviders)
Instantiates a CompositeTextProvider with some predefined textProviders.

Parameters:
textProviders -

CompositeTextProvider

public CompositeTextProvider(TextProvider[] textProviders)
Instantiates a CompositeTextProvider with some predefined textProviders.

Parameters:
textProviders -
Method Detail

hasKey

public boolean hasKey(String key)
Description copied from interface: TextProvider
Checks if a message key exists.

Specified by:
hasKey in interface TextProvider
Parameters:
key - The key to lookup in ressource bundles.
Returns:
true, if the requested key is found in one of the ressource bundles.
See Also:
com.opensymphony.xwork2.TextProvider#hasKey(String)} It will consult each individual {@link TextProvider}s and return true if either one of the {@link TextProvider} has such a key> else false.

getText

public String getText(String key)
It will consult each TextProviders and return the first valid message for this key

Specified by:
getText in interface TextProvider
Parameters:
key - The key to lookup in ressource bundles.
Returns:
The i18n text for the requested key.
See Also:
com.opensymphony.xwork2.TextProvider#getText(String)}

getText

public String getText(String key,
                      String defaultValue)
It will consult each TextProviders and return the first valid message for this key before returning defaultValue if every else fails.

Specified by:
getText in interface TextProvider
Parameters:
key -
defaultValue -
Returns:
See Also:
com.opensymphony.xwork2.TextProvider#getText(String, String)}

getText

public String getText(String key,
                      String defaultValue,
                      String obj)
It will consult each TextProviders and return the first valid message for this key, before returining defaultValue if every else fails.

Specified by:
getText in interface TextProvider
Parameters:
key -
defaultValue -
obj -
Returns:
See Also:
com.opensymphony.xwork2.TextProvider#getText(String, String, String)}

getText

public String getText(String key,
                      List<Object> args)
It will consult each TextProviders and return the first valid message for this key.

Specified by:
getText in interface TextProvider
Parameters:
key -
args -
Returns:
See Also:
com.opensymphony.xwork2.TextProvider#getText(String, java.util.List)}

getText

public String getText(String key,
                      String[] args)
It will consult each TextProviders and return the first valid message for this key.

Specified by:
getText in interface TextProvider
Parameters:
key -
args -
Returns:
See Also:
com.opensymphony.xwork2.TextProvider#getText(String, String[])}

getText

public String getText(String key,
                      String defaultValue,
                      List<Object> args)
It will consult each TextProviders and return the first valid message for this key, before returining defaultValue

Specified by:
getText in interface TextProvider
Parameters:
key -
defaultValue -
args -
Returns:
See Also:
com.opensymphony.xwork2.TextProvider#getText#getText(String, String, java.util.List)}

getText

public String getText(String key,
                      String defaultValue,
                      String[] args)
It will consult each TextProviders and return the first valid message for this key, before returining defaultValue.

Specified by:
getText in interface TextProvider
Parameters:
key -
defaultValue -
args -
Returns:
See Also:
com.opensymphony.xwork2.TextProvider#getText(String, String, String[])}

getText

public String getText(String key,
                      String defaultValue,
                      List<Object> args,
                      ValueStack stack)
It will consult each TextProviders and return the first valid message for this key, before returining defaultValue

Specified by:
getText in interface TextProvider
Parameters:
key -
defaultValue -
args -
stack -
Returns:
See Also:
com.opensymphony.xwork2.TextProvider#getText(String, String, java.util.List, com.opensymphony.xwork2.util.OgnlValueStack)}

getText

public String getText(String key,
                      String defaultValue,
                      String[] args,
                      ValueStack stack)
It will consult each TextProviders and return the first valid message for this key, before returining defaultValue

Specified by:
getText in interface TextProvider
Parameters:
key -
defaultValue -
args -
stack -
Returns:
See Also:
com.opensymphony.xwork2.TextProvider#getText(String, String, String[], com.opensymphony.xwork2.util.ValueStack)}

getTexts

public ResourceBundle getTexts(String bundleName)
It will consult each TextProviders and return the first non-null ResourceBundle.

Specified by:
getTexts in interface TextProvider
Parameters:
bundleName -
Returns:
See Also:
TextProvider#getTexts(String)}

getTexts

public ResourceBundle getTexts()
It will consult each TextProviders and return the first non-null ResourceBundle.

Specified by:
getTexts in interface TextProvider
Returns:
See Also:
TextProvider#getTexts()}
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultActionInvocation (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class DefaultActionInvocation

java.lang.Object
    extended by  com.opensymphony.xwork2.DefaultActionInvocation
All Implemented Interfaces:
ActionInvocation, Serializable
public class DefaultActionInvocation
extends Object
implements ActionInvocation

The Default ActionInvocation implementation

Version:
$Date: 2009-09-16 22:33:36 +0200 (Wed, 16 Sep 2009) $ $Id: DefaultActionInvocation.java 2056 2009-09-16 20:33:36Z rainerh $
Author:
Rainer Hermanns, tmjee
See Also:
DefaultActionProxy, Serialized Form

Field Summary
protected Object | action
protected ActionEventListener | actionEventListener
protected Container | container
protected boolean | executed
protected Result | explicitResult
protected Map<String,Object> | extraContext
protected Iterator<InterceptorMapping> | interceptors
protected ActionContext | invocationContext
protected ObjectFactory | objectFactory
protected List<PreResultListener> | preResultListeners
protected ActionProxy | proxy
protected boolean | pushAction
protected Result | result
protected String | resultCode
protected ValueStack | stack
protected UnknownHandlerManager | unknownHandlerManager
protected ValueStackFactory | valueStackFactory
Constructor Summary
DefaultActionInvocation(Map<String,Object> extraContext, boolean pushAction)
Method Summary
void | addPreResultListener(PreResultListener listener) Register a com.opensymphony.xwork2.interceptor.PreResultListener to be notified after the Action is executed and before the Result is executed.
protected void | createAction(Map<String,Object> contextMap)
protected Map<String,Object> | createContextMap()
Result | createResult()
Object | getAction() Get the Action associated with this ActionInvocation.
ActionContext | getInvocationContext() Gets the ActionContext associated with this ActionInvocation.
ActionProxy | getProxy() Get the ActionProxy holding this ActionInvocation.
Result | getResult() If the DefaultActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned.
String | getResultCode() Gets the result code returned from this ActionInvocation.
ValueStack | getStack() Gets the ValueStack associated with this ActionInvocation.
void | init(ActionProxy proxy)
String | invoke() Invokes the next step in processing this ActionInvocation.
protected String | invokeAction(Object action, ActionConfig actionConfig)
String | invokeActionOnly() Invokes only the Action (not Interceptors or Results).
boolean | isExecuted() Gets whether this ActionInvocation has executed before.
void | setActionEventListener(ActionEventListener listener) Sets the action event listener to respond to key action events.
void | setConfiguration(Configuration configuration)
void | setContainer(Container cont)
void | setObjectFactory(ObjectFactory fac)
void | setResultCode(String resultCode) Sets the result code, possibly overriding the one returned by the action.
void | setUnknownHandlerManager(UnknownHandlerManager unknownHandlerManager)
void | setValueStackFactory(ValueStackFactory fac)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

action

protected Object action

proxy

protected ActionProxy proxy

preResultListeners

protected List<PreResultListener> preResultListeners

extraContext

protected Map<String,Object> extraContext

invocationContext

protected ActionContext invocationContext

interceptors

protected Iterator<InterceptorMapping> interceptors

stack

protected ValueStack stack

result

protected Result result

explicitResult

protected Result explicitResult

resultCode

protected String resultCode

executed

protected boolean executed

pushAction

protected boolean pushAction

objectFactory

protected ObjectFactory objectFactory

actionEventListener

protected ActionEventListener actionEventListener

valueStackFactory

protected ValueStackFactory valueStackFactory

container

protected Container container

unknownHandlerManager

protected UnknownHandlerManager unknownHandlerManager
Constructor Detail

DefaultActionInvocation

public DefaultActionInvocation(Map<String,Object> extraContext,
                               boolean pushAction)
Method Detail

setUnknownHandlerManager

public void setUnknownHandlerManager(UnknownHandlerManager unknownHandlerManager)

setValueStackFactory

public void setValueStackFactory(ValueStackFactory fac)

setConfiguration

public void setConfiguration(Configuration configuration)

setObjectFactory

public void setObjectFactory(ObjectFactory fac)

setContainer

public void setContainer(Container cont)

setActionEventListener

public void setActionEventListener(ActionEventListener listener)
Description copied from interface: ActionInvocation
Sets the action event listener to respond to key action events.

Specified by:
setActionEventListener in interface ActionInvocation
Parameters:
listener - the listener.

getAction

public Object getAction()
Description copied from interface: ActionInvocation
Get the Action associated with this ActionInvocation.

Specified by:
getAction in interface ActionInvocation
Returns:
the Action

isExecuted

public boolean isExecuted()
Description copied from interface: ActionInvocation
Gets whether this ActionInvocation has executed before. This will be set after the Action and the Result have executed.

Specified by:
isExecuted in interface ActionInvocation
Returns:
true if this ActionInvocation has executed before.

getInvocationContext

public ActionContext getInvocationContext()
Description copied from interface: ActionInvocation
Gets the ActionContext associated with this ActionInvocation. The ActionProxy is responsible for setting this ActionContext onto the ThreadLocal before invoking the ActionInvocation and resetting the old ActionContext afterwards.

Specified by:
getInvocationContext in interface ActionInvocation
Returns:
the ActionContext.

getProxy

public ActionProxy getProxy()
Description copied from interface: ActionInvocation
Get the ActionProxy holding this ActionInvocation.

Specified by:
getProxy in interface ActionInvocation
Returns:
the ActionProxy.

getResult

public Result getResult()
                 throws Exception
If the DefaultActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned. If the DefaultActionInvocation's result has not been executed before, the Result instance will be created and populated with the result params.

Specified by:
getResult in interface ActionInvocation
Returns:
a Result instance
Throws:
Exception

getResultCode

public String getResultCode()
Description copied from interface: ActionInvocation
Gets the result code returned from this ActionInvocation.

Specified by:
getResultCode in interface ActionInvocation
Returns:
the result code

setResultCode

public void setResultCode(String resultCode)
Description copied from interface: ActionInvocation
Sets the result code, possibly overriding the one returned by the action.

The "intended" purpose of this method is to allow PreResultListeners to override the result code returned by the Action.

If this method is used before the Action executes, the Action's returned result code will override what was set. However the Action could (if specifically coded to do so) inspect the ActionInvocation to see that someone "upstream" (e.g. an Interceptor) had suggested a value as the result, and it could therefore return the same value itself.

If this method is called between the Action execution and the Result execution, then the value set here will override the result code the action had returned. Creating an Interceptor that implements PreResultListener will give you this oportunity.

If this method is called after the Result has been executed, it will have the effect of raising an IllegalStateException.

Specified by:
setResultCode in interface ActionInvocation
Parameters:
resultCode - the result code.
See Also:
ActionInvocation.isExecuted()

getStack

public ValueStack getStack()
Description copied from interface: ActionInvocation
Gets the ValueStack associated with this ActionInvocation.

Specified by:
getStack in interface ActionInvocation
Returns:
the ValueStack

addPreResultListener

public void addPreResultListener(PreResultListener listener)
Register a com.opensymphony.xwork2.interceptor.PreResultListener to be notified after the Action is executed and before the Result is executed. The ActionInvocation implementation must guarantee that listeners will be called in the order in which they are registered. Listener registration and execution does not need to be thread-safe.

Specified by:
addPreResultListener in interface ActionInvocation
Parameters:
listener -

createResult

public Result createResult()
                    throws Exception
Throws:
Exception

invoke

public String invoke()
              throws Exception
Description copied from interface: ActionInvocation
Invokes the next step in processing this ActionInvocation.

If there are more Interceptors, this will call the next one. If Interceptors choose not to short-circuit ActionInvocation processing and return their own return code, they will call invoke() to allow the next Interceptor to execute. If there are no more Interceptors to be applied, the Action is executed. If the ActionProxy.getExecuteResult() method returns true, the Result is also executed.

Specified by:
invoke in interface ActionInvocation
Returns:
the return code.
Throws:
ConfigurationException - If no result can be found with the returned code
Exception - can be thrown.

invokeActionOnly

public String invokeActionOnly()
                        throws Exception
Description copied from interface: ActionInvocation
Invokes only the Action (not Interceptors or Results).

This is useful in rare situations where advanced usage with the interceptor/action/result workflow is being manipulated for certain functionality.

Specified by:
invokeActionOnly in interface ActionInvocation
Returns:
the return code.
Throws:
Exception - can be thrown.

createAction

protected void createAction(Map<String,Object> contextMap)

createContextMap

protected Map<String,Object> createContextMap()

init

public void init(ActionProxy proxy)
Specified by:
init in interface ActionInvocation

invokeAction

protected String invokeAction(Object action,
                              ActionConfig actionConfig)
                       throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultActionProxy (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class DefaultActionProxy

java.lang.Object
    extended by  com.opensymphony.xwork2.DefaultActionProxy
All Implemented Interfaces:
ActionProxy, Serializable
public class DefaultActionProxy
extends Object
implements ActionProxy, Serializable

The Default ActionProxy implementation

Since:
2005-8-6
Version:
$Date: 2009-05-08 05:54:47 +0200 (Fr, 08 Mai 2009) $ $Id: DefaultActionProxy.java 1991 2009-05-08 03:54:47Z musachy $
Author:
Rainer Hermanns, Revised by Henry Hu, tmjee
See Also:
Serialized Form

Field Summary
protected ActionEventListener | actionEventListener
protected String | actionName
protected boolean | cleanupContext
protected ActionConfig | config
protected Configuration | configuration
protected boolean | executeResult
protected ActionInvocation | invocation
protected String | method
protected String | namespace
protected ObjectFactory | objectFactory
protected UnknownHandlerManager | unknownHandlerManager
Constructor Summary
protected DefaultActionProxy(ActionInvocation inv, String namespace, String actionName, String methodName, boolean executeResult, boolean cleanupContext)
This constructor is private so the builder methods (create*) should be used to create an DefaultActionProxy.
Method Summary
String | execute() Execute this ActionProxy.
Object | getAction() Gets the Action instance for this Proxy.
String | getActionName() Gets the alias name this ActionProxy is mapped to.
ActionConfig | getConfig() Gets the ActionConfig this ActionProxy is built from.
boolean | getExecuteResult() Gets the status of whether the ActionProxy is set to execute the Result after the Action is executed.
ActionInvocation | getInvocation() Gets the ActionInvocation associated with this ActionProxy.
String | getMethod() Gets the method name to execute, or null if no method has been specified (meaning execute will be invoked).
String | getNamespace() Gets the namespace the ActionConfig for this ActionProxy is mapped to.
protected void | prepare()
void | setActionEventListener(ActionEventListener listener)
void | setConfiguration(Configuration config)
void | setExecuteResult(boolean executeResult) Sets whether this ActionProxy should also execute the Result after executing the Action.
void | setObjectFactory(ObjectFactory factory)
void | setUnknownHandler(UnknownHandlerManager unknownHandlerManager)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

configuration

protected Configuration configuration

config

protected ActionConfig config

invocation

protected ActionInvocation invocation

unknownHandlerManager

protected UnknownHandlerManager unknownHandlerManager

actionName

protected String actionName

namespace

protected String namespace

method

protected String method

executeResult

protected boolean executeResult

cleanupContext

protected boolean cleanupContext

objectFactory

protected ObjectFactory objectFactory

actionEventListener

protected ActionEventListener actionEventListener
Constructor Detail

DefaultActionProxy

protected DefaultActionProxy(ActionInvocation inv,
                             String namespace,
                             String actionName,
                             String methodName,
                             boolean executeResult,
                             boolean cleanupContext)
This constructor is private so the builder methods (create*) should be used to create an DefaultActionProxy.

The reason for the builder methods is so that you can use a subclass to create your own DefaultActionProxy instance (like a RMIActionProxy).

Method Detail

setObjectFactory

public void setObjectFactory(ObjectFactory factory)

setConfiguration

public void setConfiguration(Configuration config)

setUnknownHandler

public void setUnknownHandler(UnknownHandlerManager unknownHandlerManager)

setActionEventListener

public void setActionEventListener(ActionEventListener listener)

getAction

public Object getAction()
Description copied from interface: ActionProxy
Gets the Action instance for this Proxy.

Specified by:
getAction in interface ActionProxy
Returns:
the Action instance

getActionName

public String getActionName()
Description copied from interface: ActionProxy
Gets the alias name this ActionProxy is mapped to.

Specified by:
getActionName in interface ActionProxy
Returns:
the alias name

getConfig

public ActionConfig getConfig()
Description copied from interface: ActionProxy
Gets the ActionConfig this ActionProxy is built from.

Specified by:
getConfig in interface ActionProxy
Returns:
the ActionConfig

setExecuteResult

public void setExecuteResult(boolean executeResult)
Description copied from interface: ActionProxy
Sets whether this ActionProxy should also execute the Result after executing the Action.

Specified by:
setExecuteResult in interface ActionProxy
Parameters:
executeResult - true to also execute the Result.

getExecuteResult

public boolean getExecuteResult()
Description copied from interface: ActionProxy
Gets the status of whether the ActionProxy is set to execute the Result after the Action is executed.

Specified by:
getExecuteResult in interface ActionProxy
Returns:
the status

getInvocation

public ActionInvocation getInvocation()
Description copied from interface: ActionProxy
Gets the ActionInvocation associated with this ActionProxy.

Specified by:
getInvocation in interface ActionProxy
Returns:
the ActionInvocation

getNamespace

public String getNamespace()
Description copied from interface: ActionProxy
Gets the namespace the ActionConfig for this ActionProxy is mapped to.

Specified by:
getNamespace in interface ActionProxy
Returns:
the namespace

execute

public String execute()
               throws Exception
Description copied from interface: ActionProxy
Execute this ActionProxy. This will set the ActionContext from the ActionInvocation into the ActionContext ThreadLocal before invoking the ActionInvocation, then set the old ActionContext back into the ThreadLocal.

Specified by:
execute in interface ActionProxy
Returns:
the result code returned from executing the ActionInvocation
Throws:
Exception - can be thrown.
See Also:
ActionInvocation

getMethod

public String getMethod()
Description copied from interface: ActionProxy
Gets the method name to execute, or null if no method has been specified (meaning execute will be invoked).

Specified by:
getMethod in interface ActionProxy
Returns:
the method to execute

prepare

protected void prepare()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultActionProxyFactory (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class DefaultActionProxyFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.DefaultActionProxyFactory
All Implemented Interfaces:
ActionProxyFactory
public class DefaultActionProxyFactory
extends Object
implements ActionProxyFactory

Default factory for ActionProxyFactory.

Author:
Jason Carreira

Field Summary
protected  Container container
Constructor Summary
DefaultActionProxyFactory()
Method Summary
ActionProxy | createActionProxy(ActionInvocation inv, String namespace, String actionName, boolean executeResult, boolean cleanupContext)
ActionProxy | createActionProxy(ActionInvocation inv, String namespace, String actionName, String methodName, boolean executeResult, boolean cleanupContext) Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including passed ActionInvocation instance.
ActionProxy | createActionProxy(String namespace, String actionName, Map<String,Object> extraContext) Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.
ActionProxy | createActionProxy(String namespace, String actionName, Map<String,Object> extraContext, boolean executeResult, boolean cleanupContext) Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.
ActionProxy | createActionProxy(String namespace, String actionName, String methodName, Map<String,Object> extraContext) Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.
ActionProxy | createActionProxy(String namespace, String actionName, String methodName, Map<String,Object> extraContext, boolean executeResult, boolean cleanupContext) Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.
void | setContainer(Container container)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

container

protected Container container
Constructor Detail

DefaultActionProxyFactory

public DefaultActionProxyFactory()
Method Detail

setContainer

public void setContainer(Container container)

createActionProxy

public ActionProxy createActionProxy(String namespace,
                                     String actionName,
                                     Map<String,Object> extraContext)
Description copied from interface: ActionProxyFactory
Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.

Note: This is the most used create method.

Specified by:
createActionProxy in interface ActionProxyFactory
Parameters:
namespace - the namespace of the action, can be null
actionName - the name of the action
extraContext - a Map of extra parameters to be provided to the ActionProxy, can be null
Returns:
ActionProxy the created action proxy

createActionProxy

public ActionProxy createActionProxy(String namespace,
                                     String actionName,
                                     String methodName,
                                     Map<String,Object> extraContext)
Description copied from interface: ActionProxyFactory
Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.

Note: This is the most used create method.

Specified by:
createActionProxy in interface ActionProxyFactory
Parameters:
namespace - the namespace of the action, can be null
actionName - the name of the action
methodName - the name of the method to execute
extraContext - a Map of extra parameters to be provided to the ActionProxy, can be null
Returns:
ActionProxy the created action proxy

createActionProxy

public ActionProxy createActionProxy(String namespace,
                                     String actionName,
                                     Map<String,Object> extraContext,
                                     boolean executeResult,
                                     boolean cleanupContext)
Description copied from interface: ActionProxyFactory
Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.

Specified by:
createActionProxy in interface ActionProxyFactory
Parameters:
namespace - the namespace of the action, can be null
actionName - the name of the action
extraContext - a Map of extra parameters to be provided to the ActionProxy, can be null
executeResult - flag which tells whether the result should be executed after the action
cleanupContext - flag which tells whether the original context should be preserved during execution of the proxy.
Returns:
ActionProxy the created action proxy

createActionProxy

public ActionProxy createActionProxy(String namespace,
                                     String actionName,
                                     String methodName,
                                     Map<String,Object> extraContext,
                                     boolean executeResult,
                                     boolean cleanupContext)
Description copied from interface: ActionProxyFactory
Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.

Specified by:
createActionProxy in interface ActionProxyFactory
Parameters:
namespace - the namespace of the action, can be null
actionName - the name of the action
methodName - the name of the method to execute
extraContext - a Map of extra parameters to be provided to the ActionProxy, can be null
executeResult - flag which tells whether the result should be executed after the action
cleanupContext - flag which tells whether the original context should be preserved during execution of the proxy.
Returns:
ActionProxy the created action proxy

createActionProxy

public ActionProxy createActionProxy(ActionInvocation inv,
                                     String namespace,
                                     String actionName,
                                     boolean executeResult,
                                     boolean cleanupContext)

createActionProxy

public ActionProxy createActionProxy(ActionInvocation inv,
                                     String namespace,
                                     String actionName,
                                     String methodName,
                                     boolean executeResult,
                                     boolean cleanupContext)
Description copied from interface: ActionProxyFactory
Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including passed ActionInvocation instance.

Specified by:
createActionProxy in interface ActionProxyFactory
Parameters:
inv - the action invocation instance to associate with
namespace - the namespace of the action, can be null
actionName - the name of the action
methodName - the name of the method to execute
executeResult - flag which tells whether the result should be executed after the action
cleanupContext - flag which tells whether the original context should be preserved during execution of the proxy.
Returns:
ActionProxy the created action proxy
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultTextProvider (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class DefaultTextProvider

java.lang.Object
    extended by  com.opensymphony.xwork2.DefaultTextProvider
All Implemented Interfaces:
TextProvider, Unchainable, Serializable
public class DefaultTextProvider
extends Object
implements TextProvider, Serializable, Unchainable

DefaultTextProvider gets texts from only the default resource bundles associated with the LocalizedTextUtil.

Author:
Jason Carreira , Rainer Hermanns
See Also:
LocalizedTextUtil.addDefaultResourceBundle(String), Serialized Form

Constructor Summary
DefaultTextProvider()
Method Summary
String | getText(String key) Gets a message based on a message key, or null if no message is found.
String | getText(String key, List<Object> args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
String | getText(String key, String defaultValue) Gets a message based on a key, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String[] args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
String | getText(String key, String defaultValue, List<Object> args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, List<Object> args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, String obj) Gets a message based on a key using the supplied obj, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, String[] args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, String[] args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
ResourceBundle | getTexts() Get the resource bundle associated with the implementing class (usually an action).
ResourceBundle | getTexts(String bundleName) Get the named bundle, such as "com/acme/Foo".
boolean | hasKey(String key) Checks if a message key exists.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultTextProvider

public DefaultTextProvider()
Method Detail

hasKey

public boolean hasKey(String key)
Description copied from interface: TextProvider
Checks if a message key exists.

Specified by:
hasKey in interface TextProvider
Returns:
boolean true if key exists, false otherwise.

getText

public String getText(String key)
Description copied from interface: TextProvider
Gets a message based on a message key, or null if no message is found.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
Returns:
the message as found in the resource bundle, or null if none is found.

getText

public String getText(String key,
                      String defaultValue)
Description copied from interface: TextProvider
Gets a message based on a key, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      List<Object> args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
args - a list args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or null if none is found.

getText

public String getText(String key,
                      String[] args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
args - an array args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or null if none is found.

getText

public String getText(String key,
                      String defaultValue,
                      List<Object> args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - a list args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      String[] args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - an array args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      String obj)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied obj, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
obj - obj to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      List<Object> args,
                      ValueStack stack)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - a list args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      String[] args,
                      ValueStack stack)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - an array args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getTexts

public ResourceBundle getTexts(String bundleName)
Description copied from interface: TextProvider
Get the named bundle, such as "com/acme/Foo".

Specified by:
getTexts in interface TextProvider
Parameters:
bundleName - the name of the resource bundle, such as "com/acme/Foo".
Returns:
the bundle

getTexts

public ResourceBundle getTexts()
Description copied from interface: TextProvider
Get the resource bundle associated with the implementing class (usually an action).

Specified by:
getTexts in interface TextProvider
Returns:
the bundle
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultUnknownHandlerManager (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class DefaultUnknownHandlerManager

java.lang.Object
    extended by  com.opensymphony.xwork2.DefaultUnknownHandlerManager
All Implemented Interfaces:
UnknownHandlerManager
public class DefaultUnknownHandlerManager
extends Object
implements UnknownHandlerManager

Default implementation of UnknownHandlerManager

See Also:
UnknownHandlerManager

Field Summary
protected  ArrayList<UnknownHandler> unknownHandlers
Constructor Summary
DefaultUnknownHandlerManager()
Method Summary
protected void | build() Builds a list of UnknowHandlers in the order specified by the configured "unknown-handler-stack".
List<UnknownHandler> | getUnknownHandlers()
ActionConfig | handleUnknownAction(String namespace, String actionName) Iterate over UnknownHandlers and return the result of the first one that can handle it
Object | handleUnknownMethod(Object action, String methodName) Iterate over UnknownHandlers and return the result of the first one that can handle it
Result | handleUnknownResult(ActionContext actionContext, String actionName, ActionConfig actionConfig, String resultCode) Iterate over UnknownHandlers and return the result of the first one that can handle it
boolean | hasUnknownHandlers()
void | setConfiguration(Configuration configuration)
void | setContainer(Container container)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

unknownHandlers

protected ArrayList<UnknownHandler> unknownHandlers
Constructor Detail

DefaultUnknownHandlerManager

public DefaultUnknownHandlerManager()
Method Detail

setConfiguration

public void setConfiguration(Configuration configuration)

setContainer

public void setContainer(Container container)

build

protected void build()
Builds a list of UnknowHandlers in the order specified by the configured "unknown-handler-stack". If "unknown-handler-stack" was not configured, all UnknowHandlers will be returned, in no specific order

handleUnknownResult

public Result handleUnknownResult(ActionContext actionContext,
                                  String actionName,
                                  ActionConfig actionConfig,
                                  String resultCode)
Iterate over UnknownHandlers and return the result of the first one that can handle it

Specified by:
handleUnknownResult in interface UnknownHandlerManager

handleUnknownMethod

public Object handleUnknownMethod(Object action,
                                  String methodName)
                           throws NoSuchMethodException
Iterate over UnknownHandlers and return the result of the first one that can handle it

Specified by:
handleUnknownMethod in interface UnknownHandlerManager
Throws:
NoSuchMethodException

handleUnknownAction

public ActionConfig handleUnknownAction(String namespace,
                                        String actionName)
Iterate over UnknownHandlers and return the result of the first one that can handle it

Specified by:
handleUnknownAction in interface UnknownHandlerManager
Throws:
NoSuchMethodException

hasUnknownHandlers

public boolean hasUnknownHandlers()
Specified by:
hasUnknownHandlers in interface UnknownHandlerManager

getUnknownHandlers

public List<UnknownHandler> getUnknownHandlers()
Specified by:
getUnknownHandlers in interface UnknownHandlerManager
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InvalidMetadataException (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class InvalidMetadataException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  com.opensymphony.xwork2.InvalidMetadataException
All Implemented Interfaces:
Serializable
public class InvalidMetadataException
extends RuntimeException

InvalidMetadataException

Version:
$Id: InvalidMetadataException.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns
See Also:
Serialized Form

Constructor Summary
InvalidMetadataException(String msg)
Create a new InvalidMetadataException with the supplied error message.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidMetadataException

public InvalidMetadataException(String msg)
Create a new InvalidMetadataException with the supplied error message.

Parameters:
msg - the error message
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocaleProvider (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface LocaleProvider

All Known Subinterfaces:
ValidatorContext
All Known Implementing Classes:
ActionSupport, DelegatingValidatorContext, VisitorFieldValidator.AppendingValidatorContext
public interface LocaleProvider

Indicates that the implementing class can provide its own Locale.

This is useful for when an action may wish override the default locale. All that is needed is to implement this interface and return your own custom locale. The TextProvider interface uses this interface heavily for retrieving internationalized messages from resource bundles.

Author:
Jason Carreira

Method Summary
 Locale getLocale()
Gets the provided locale.

Method Detail

getLocale

Locale getLocale()
Gets the provided locale.

Returns:
the locale.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MockActionInvocation (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class MockActionInvocation

java.lang.Object
    extended by  com.opensymphony.xwork2.mock.MockActionInvocation
        extended by  com.opensymphony.xwork2.MockActionInvocation
All Implemented Interfaces:
ActionInvocation, Serializable
Deprecated. Please use @see com.opensymphony.xwork2.mock.MockActionInvocation instead

@Deprecated
public class MockActionInvocation
extends MockActionInvocation

Mock for an ActionInvocation.

Author:
plightbo
See Also:
Serialized Form

Constructor Summary
MockActionInvocation()
Deprecated.
Method Summary
Methods inherited from class com.opensymphony.xwork2.mock.MockActionInvocation
addPreResultListener, getAction, getActionEventListener, getInvocationContext, getProxy, getResult, getResultCode, getStack, init, invoke, invokeActionOnly, isExecuted, setAction, setActionEventListener, setInvocationContext, setProxy, setResult, setResultCode, setStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MockActionInvocation

public MockActionInvocation()
Deprecated.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ModelDriven (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface ModelDriven<T>

All Known Subinterfaces:
ScopedModelDriven<T>
public interface ModelDriven<T>

ModelDriven Actions provide a model object to be pushed onto the ValueStack in addition to the Action itself, allowing a FormBean type approach like Struts.

Author:
Jason Carreira

Method Summary
 T getModel()
Gets the model to be pushed onto the ValueStack instead of the Action itself.

Method Detail

getModel

T getModel()
Gets the model to be pushed onto the ValueStack instead of the Action itself.

Returns:
the model
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ObjectFactory (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class ObjectFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.ObjectFactory
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
SpringObjectFactory
public class ObjectFactory
extends Object
implements Serializable

ObjectFactory is responsible for building the core framework objects. Users may register their own implementation of the ObjectFactory to control instantiation of these Objects.

This default implementation uses the buildBean method to create all classes (interceptors, actions, results, etc).

Author:
Jason Carreira
See Also:
Serialized Form

Field Summary
protected  ReflectionProvider reflectionProvider
Constructor Summary
ObjectFactory()
ObjectFactory(ReflectionProvider prov)
Method Summary
Object | buildAction(String actionName, String namespace, ActionConfig config, Map<String,Object> extraContext) Build an instance of the action class to handle a particular request (eg.
Object | buildBean(Class clazz, Map<String,Object> extraContext) Build a generic Java object of the given type.
Object | buildBean(String className, Map<String,Object> extraContext) Build a generic Java object of the given type.
Object | buildBean(String className, Map<String,Object> extraContext, boolean injectInternal) Build a generic Java object of the given type.
Interceptor | buildInterceptor(InterceptorConfig interceptorConfig, Map<String,String> interceptorRefParams) Builds an Interceptor from the InterceptorConfig and the Map of parameters from the interceptor reference.
Result | buildResult(ResultConfig resultConfig, Map<String,Object> extraContext) Build a Result using the type in the ResultConfig and set the parameters in the ResultConfig.
Validator | buildValidator(String className, Map<String,String> params, Map<String,Object> extraContext) Build a Validator of the given type and set the parameters on it
Class | getClassInstance(String className) Utility method to obtain the class matched to className.
static ObjectFactory | getObjectFactory() Deprecated. Since 2.1
protected Object | injectInternalBeans(Object obj)
boolean | isNoArgConstructorRequired() Allows for ObjectFactory implementations that support Actions without no-arg constructors.
void | setClassLoader(ClassLoader cl)
void | setContainer(Container container)
void | setReflectionProvider(ReflectionProvider prov)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

reflectionProvider

protected ReflectionProvider reflectionProvider
Constructor Detail

ObjectFactory

public ObjectFactory()

ObjectFactory

public ObjectFactory(ReflectionProvider prov)
Method Detail

setClassLoader

public void setClassLoader(ClassLoader cl)

setReflectionProvider

public void setReflectionProvider(ReflectionProvider prov)

setContainer

public void setContainer(Container container)

getObjectFactory

@Deprecated
public static ObjectFactory getObjectFactory()
Deprecated. Since 2.1

isNoArgConstructorRequired

public boolean isNoArgConstructorRequired()
Allows for ObjectFactory implementations that support Actions without no-arg constructors.

Returns:
true if no-arg constructor is required, false otherwise

getClassInstance

public Class getClassInstance(String className)
                       throws ClassNotFoundException
Utility method to obtain the class matched to className. Caches look ups so that subsequent lookups will be faster.

Parameters:
className - The fully qualified name of the class to return
Returns:
The class itself
Throws:
ClassNotFoundException

buildAction

public Object buildAction(String actionName,
                          String namespace,
                          ActionConfig config,
                          Map<String,Object> extraContext)
                   throws Exception
Build an instance of the action class to handle a particular request (eg. web request)

Parameters:
actionName - the name the action configuration is set up with in the configuration
namespace - the namespace the action is configured in
config - the action configuration found in the config for the actionName / namespace
extraContext - a Map of extra context which uses the same keys as the ActionContext
Returns:
instance of the action class to handle a web request
Throws:
Exception

buildBean

public Object buildBean(Class clazz,
                        Map<String,Object> extraContext)
                 throws Exception
Build a generic Java object of the given type.

Parameters:
clazz - the type of Object to build
extraContext - a Map of extra context which uses the same keys as the ActionContext
Throws:
Exception

injectInternalBeans

protected Object injectInternalBeans(Object obj)
Parameters:
obj -

buildBean

public Object buildBean(String className,
                        Map<String,Object> extraContext)
                 throws Exception
Build a generic Java object of the given type.

Parameters:
className - the type of Object to build
extraContext - a Map of extra context which uses the same keys as the ActionContext
Throws:
Exception

buildBean

public Object buildBean(String className,
                        Map<String,Object> extraContext,
                        boolean injectInternal)
                 throws Exception
Build a generic Java object of the given type.

Parameters:
className - the type of Object to build
extraContext - a Map of extra context which uses the same keys as the ActionContext
Throws:
Exception

buildInterceptor

public Interceptor buildInterceptor(InterceptorConfig interceptorConfig,
                                    Map<String,String> interceptorRefParams)
                             throws ConfigurationException
Builds an Interceptor from the InterceptorConfig and the Map of parameters from the interceptor reference. Implementations of this method should ensure that the Interceptor is parameterized with both the parameters from the Interceptor config and the interceptor ref Map (the interceptor ref params take precedence), and that the Interceptor.init() method is called on the Interceptor instance before it is returned.

Parameters:
interceptorConfig - the InterceptorConfig from the configuration
interceptorRefParams - a Map of params provided in the Interceptor reference in the Action mapping or InterceptorStack definition
Throws:
ConfigurationException

buildResult

public Result buildResult(ResultConfig resultConfig,
                          Map<String,Object> extraContext)
                   throws Exception
Build a Result using the type in the ResultConfig and set the parameters in the ResultConfig.

Parameters:
resultConfig - the ResultConfig found for the action with the result code returned
extraContext - a Map of extra context which uses the same keys as the ActionContext
Throws:
Exception

buildValidator

public Validator buildValidator(String className,
                                Map<String,String> params,
                                Map<String,Object> extraContext)
                         throws Exception
Build a Validator of the given type and set the parameters on it

Parameters:
className - the type of Validator to build
params - property name -> value Map to set onto the Validator instance
extraContext - a Map of extra context which uses the same keys as the ActionContext
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2 (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2
Interfaces
Action
ActionEventListener
ActionInvocation
ActionProxy
ActionProxyFactory
LocaleProvider
ModelDriven
Preparable
ResourceBundleTextProvider
Result
TextProvider
Unchainable
UnknownHandler
UnknownHandlerManager
Validateable
ValidationAware
XWorkMessages
Classes
ActionChainResult
ActionContext
ActionSupport
CompositeTextProvider
DefaultActionInvocation
DefaultActionProxy
DefaultActionProxyFactory
DefaultTextProvider
DefaultUnknownHandlerManager
MockActionInvocation
ObjectFactory
TestNGXWorkTestCase
TextProviderFactory
TextProviderSupport
ValidationAwareSupport
XWork
XWorkTestCase
Exceptions
InvalidMetadataException
XWorkException


com.opensymphony.xwork2 (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2

Main XWork interfaces and classes.

See:
Description

Interface Summary
Action | All actions may implement this interface, which exposes the execute() method.
ActionEventListener | Provides hooks for handling key action events
ActionInvocation | An ActionInvocation represents the execution state of an Action.
ActionProxy | ActionProxy is an extra layer between XWork and the action so that different proxies are possible.
ActionProxyFactory | The ActionProxyFactory is used to create ActionProxys to be executed.
LocaleProvider | Indicates that the implementing class can provide its own Locale.
ModelDriven<T> | ModelDriven Actions provide a model object to be pushed onto the ValueStack in addition to the Action itself, allowing a FormBean type approach like Struts.
Preparable | Preparable Actions will have their prepare() method called if the PrepareInterceptor is applied to the ActionConfig.
ResourceBundleTextProvider | Extension Interface for TextProvider to help supporting ResourceBundles.
Result | All results (except for Action.NONE) of an Action are mapped to a View implementation.
TextProvider | Provides access to ResourceBundles and their underlying text messages.
Unchainable | Simple marker interface to indicate an object should not have its properties copied during chaining.
UnknownHandler | Handles cases when the result or action is unknown.
UnknownHandlerManager | An unknown handler manager contains a list of UnknownHandler and iterates on them by order
Validateable | Provides an interface in which a call for a validation check can be done.
ValidationAware | ValidationAware classes can accept Action (class level) or field level error messages.
XWorkMessages | Contains constants for some default XWork messages.

Class Summary
ActionChainResult | This result invokes an entire other action, complete with it's own interceptor stack and result.
ActionContext | The ActionContext is the context in which an Action is executed.
ActionSupport | Provides a default implementation for the most common actions.
CompositeTextProvider | This is a composite TextProvider that takes in an array or List of TextProviders, it will consult each of them in order to get a composite result.
DefaultActionInvocation | The Default ActionInvocation implementation
DefaultActionProxy | The Default ActionProxy implementation
DefaultActionProxyFactory | Default factory for ActionProxyFactory.
DefaultTextProvider | DefaultTextProvider gets texts from only the default resource bundles associated with the LocalizedTextUtil.
DefaultUnknownHandlerManager | Default implementation of UnknownHandlerManager
MockActionInvocation | Deprecated. Please use @see com.opensymphony.xwork2.mock.MockActionInvocation instead
ObjectFactory | ObjectFactory is responsible for building the core framework objects.
TestNGXWorkTestCase | Base test class for TestNG unit tests.
TextProviderFactory | This factory enables users to provide and correctly initialize a custom TextProvider.
TextProviderSupport | Default TextProvider implementation.
ValidationAwareSupport | Provides a default implementation of ValidationAware.
XWork | Simple facade to make using XWork standalone easier
XWorkTestCase | Base JUnit TestCase to extend for XWork specific JUnit tests.

Exception Summary
InvalidMetadataException | InvalidMetadataException
XWorkException | A generic runtime exception that optionally contains Location information

Package com.opensymphony.xwork2 Description

Main XWork interfaces and classes.

Overview Package Class Use Tree Deprecated Index Help
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.opensymphony.xwork2 Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.ActionChainResult (implements com.opensymphony.xwork2.Result)
    • com.opensymphony.xwork2.ActionContext (implements java.io.Serializable)
    • com.opensymphony.xwork2.ActionSupport (implements com.opensymphony.xwork2.Action, com.opensymphony.xwork2.LocaleProvider, java.io.Serializable, com.opensymphony.xwork2.TextProvider, com.opensymphony.xwork2.Validateable, com.opensymphony.xwork2.ValidationAware)
    • junit.framework.Assert
      • junit.framework.TestCase (implements junit.framework.Test)
        • com.opensymphony.xwork2.XWorkTestCase
    • com.opensymphony.xwork2.CompositeTextProvider (implements com.opensymphony.xwork2.TextProvider)
    • com.opensymphony.xwork2.DefaultActionInvocation (implements com.opensymphony.xwork2.ActionInvocation)
    • com.opensymphony.xwork2.DefaultActionProxy (implements com.opensymphony.xwork2.ActionProxy, java.io.Serializable)
    • com.opensymphony.xwork2.DefaultActionProxyFactory (implements com.opensymphony.xwork2.ActionProxyFactory)
    • com.opensymphony.xwork2.DefaultTextProvider (implements java.io.Serializable, com.opensymphony.xwork2.TextProvider, com.opensymphony.xwork2.Unchainable)
    • com.opensymphony.xwork2.DefaultUnknownHandlerManager (implements com.opensymphony.xwork2.UnknownHandlerManager)
    • com.opensymphony.xwork2.mock.MockActionInvocation (implements com.opensymphony.xwork2.ActionInvocation)
      • com.opensymphony.xwork2.MockActionInvocation
    • com.opensymphony.xwork2.ObjectFactory (implements java.io.Serializable)
    • com.opensymphony.xwork2.TestNGXWorkTestCase
    • com.opensymphony.xwork2.TextProviderFactory
    • com.opensymphony.xwork2.TextProviderSupport (implements com.opensymphony.xwork2.ResourceBundleTextProvider)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.opensymphony.xwork2.InvalidMetadataException
          • com.opensymphony.xwork2.XWorkException (implements com.opensymphony.xwork2.util.location.Locatable)
    • com.opensymphony.xwork2.ValidationAwareSupport (implements java.io.Serializable, com.opensymphony.xwork2.ValidationAware)
    • com.opensymphony.xwork2.XWork

Interface Hierarchy

  • com.opensymphony.xwork2.Action
  • com.opensymphony.xwork2.ActionEventListener
  • com.opensymphony.xwork2.ActionProxy
  • com.opensymphony.xwork2.ActionProxyFactory
  • com.opensymphony.xwork2.LocaleProvider
  • com.opensymphony.xwork2.ModelDriven<T>
  • com.opensymphony.xwork2.Preparable
  • java.io.Serializable
    • com.opensymphony.xwork2.ActionInvocation
    • com.opensymphony.xwork2.Result
  • com.opensymphony.xwork2.TextProvider
    • com.opensymphony.xwork2.ResourceBundleTextProvider
  • com.opensymphony.xwork2.Unchainable
  • com.opensymphony.xwork2.UnknownHandler
  • com.opensymphony.xwork2.UnknownHandlerManager
  • com.opensymphony.xwork2.Validateable
  • com.opensymphony.xwork2.ValidationAware
  • com.opensymphony.xwork2.XWorkMessages
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Package com.opensymphony.xwork2 (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2

Packages that use com.opensymphony.xwork2
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.conversion |
com.opensymphony.xwork2.conversion.impl |
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.interceptor.annotations | Interceptor annotations.
com.opensymphony.xwork2.mock | XWork specific mock classes.
com.opensymphony.xwork2.ognl |
com.opensymphony.xwork2.ognl.accessor |
com.opensymphony.xwork2.spring | Spring ObjectFactory classes.
com.opensymphony.xwork2.spring.interceptor | Spring specific interceptor classes.
com.opensymphony.xwork2.util | XWork util classes.
com.opensymphony.xwork2.util.reflection |
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2
Action
All actions may implement this interface, which exposes the execute() method.
ActionContext
The ActionContext is the context in which an Action is executed.
ActionEventListener
Provides hooks for handling key action events
ActionInvocation
An ActionInvocation represents the execution state of an Action.
ActionProxy
ActionProxy is an extra layer between XWork and the action so that different proxies are possible.
ActionProxyFactory
The ActionProxyFactory is used to create ActionProxys to be executed.
LocaleProvider
Indicates that the implementing class can provide its own Locale.
ObjectFactory
ObjectFactory is responsible for building the core framework objects.
ResourceBundleTextProvider
Extension Interface for TextProvider to help supporting ResourceBundles.
Result
All results (except for Action.NONE) of an Action are mapped to a View implementation.
TextProvider
Provides access to ResourceBundles and their underlying text messages.
Unchainable
Simple marker interface to indicate an object should not have its properties copied during chaining.
UnknownHandler
Handles cases when the result or action is unknown.
UnknownHandlerManager
An unknown handler manager contains a list of UnknownHandler and iterates on them by order
Validateable
Provides an interface in which a call for a validation check can be done.
ValidationAware
ValidationAware classes can accept Action (class level) or field level error messages.
XWorkException
A generic runtime exception that optionally contains Location information

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.config
XWorkException
A generic runtime exception that optionally contains Location information

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.config.impl
ActionContext
The ActionContext is the context in which an Action is executed.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.config.providers
ObjectFactory
ObjectFactory is responsible for building the core framework objects.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.conversion
XWorkException
A generic runtime exception that optionally contains Location information

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.conversion.impl
ObjectFactory
ObjectFactory is responsible for building the core framework objects.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.interceptor
ActionContext
The ActionContext is the context in which an Action is executed.
ActionInvocation
An ActionInvocation represents the execution state of an Action.
ModelDriven
ModelDriven Actions provide a model object to be pushed onto the ValueStack in addition to the Action itself, allowing a FormBean type approach like Struts.
ObjectFactory
ObjectFactory is responsible for building the core framework objects.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.interceptor.annotations
ActionInvocation
An ActionInvocation represents the execution state of an Action.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.mock
ActionContext
The ActionContext is the context in which an Action is executed.
ActionEventListener
Provides hooks for handling key action events
ActionInvocation
An ActionInvocation represents the execution state of an Action.
ActionProxy
ActionProxy is an extra layer between XWork and the action so that different proxies are possible.
Result
All results (except for Action.NONE) of an Action are mapped to a View implementation.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.ognl
TextProvider
Provides access to ResourceBundles and their underlying text messages.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.ognl.accessor
ObjectFactory
ObjectFactory is responsible for building the core framework objects.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.spring
ObjectFactory
ObjectFactory is responsible for building the core framework objects.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.spring.interceptor
ActionInvocation
An ActionInvocation represents the execution state of an Action.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.util
ObjectFactory
ObjectFactory is responsible for building the core framework objects.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.util.reflection
XWorkException
A generic runtime exception that optionally contains Location information

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.validator
ActionInvocation
An ActionInvocation represents the execution state of an Action.
LocaleProvider
Indicates that the implementing class can provide its own Locale.
ObjectFactory
ObjectFactory is responsible for building the core framework objects.
TextProvider
Provides access to ResourceBundles and their underlying text messages.
ValidationAware
ValidationAware classes can accept Action (class level) or field level error messages.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.validator.validators
LocaleProvider
Indicates that the implementing class can provide its own Locale.
TextProvider
Provides access to ResourceBundles and their underlying text messages.
ValidationAware
ValidationAware classes can accept Action (class level) or field level error messages.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Preparable (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface Preparable

public interface Preparable

Preparable Actions will have their prepare() method called if the PrepareInterceptor is applied to the ActionConfig.

Author:
Jason Carreira
See Also:
PrepareInterceptor

Method Summary
 void prepare()
This method is called to allow the action to prepare itself.

Method Detail

prepare

void prepare()
             throws Exception
This method is called to allow the action to prepare itself.

Throws:
Exception - thrown if a system level exception occurs.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResourceBundleTextProvider (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface ResourceBundleTextProvider

All Superinterfaces:
TextProvider
All Known Implementing Classes:
TextProviderSupport
public interface ResourceBundleTextProvider
extends TextProvider

Extension Interface for TextProvider to help supporting ResourceBundles.

Author:
Rene Gielen

Method Summary
void | setBundle(ResourceBundle bundle) Set the resource bundle to use.
void | setClazz(Class clazz) Set the class to use for reading the resource bundle.
void | setLocaleProvider(LocaleProvider localeProvider) Set the LocaleProvider to use.
Methods inherited from interface com.opensymphony.xwork2.TextProvider
getText, getText, getText, getText, getText, getText, getText, getText, getText, getTexts, getTexts, hasKey

Method Detail

setBundle

void setBundle(ResourceBundle bundle)
Set the resource bundle to use.

Parameters:
bundle - the bundle to use.

setClazz

void setClazz(Class clazz)
Set the class to use for reading the resource bundle.

Parameters:
clazz - the class to use for loading.

setLocaleProvider

void setLocaleProvider(LocaleProvider localeProvider)
Set the LocaleProvider to use.

Parameters:
localeProvider - the LocaleProvider to use.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Result (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface Result

All Superinterfaces:
Serializable
All Known Implementing Classes:
ActionChainResult, MockResult
public interface Result
extends Serializable

All results (except for Action.NONE) of an Action are mapped to a View implementation.

Examples of Views might be:

  • SwingPanelView - pops up a new Swing panel
  • ActionChainView - executes another action
  • SerlvetRedirectView - redirects the HTTP response to a URL
  • ServletDispatcherView - dispatches the HTTP response to a URL

Author:
plightbo

Method Summary
 void execute(ActionInvocation invocation)
Represents a generic interface for all action execution results.

Method Detail

execute

void execute(ActionInvocation invocation)
             throws Exception
Represents a generic interface for all action execution results. Whether that be displaying a webpage, generating an email, sending a JMS message, etc.

Parameters:
invocation - the invocation context.
Throws:
Exception - can be thrown.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TestNGXWorkTestCase (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class TestNGXWorkTestCase

java.lang.Object
    extended by  com.opensymphony.xwork2.TestNGXWorkTestCase

public class TestNGXWorkTestCase
extends Object

Base test class for TestNG unit tests. Provides common XWork variables and performs XWork setup and teardown processes

Field Summary
protected ActionProxyFactory | actionProxyFactory
protected Configuration | configuration
protected ConfigurationManager | configurationManager
protected Container | container
Constructor Summary
TestNGXWorkTestCase()
Method Summary
protected void | loadConfigurationProviders(ConfigurationProvider... providers)
protected void | setUp()
protected void | tearDown()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

configurationManager

protected ConfigurationManager configurationManager

configuration

protected Configuration configuration

container

protected Container container

actionProxyFactory

protected ActionProxyFactory actionProxyFactory
Constructor Detail

TestNGXWorkTestCase

public TestNGXWorkTestCase()
Method Detail

setUp

protected void setUp()
              throws Exception
Throws:
Exception

tearDown

protected void tearDown()
                 throws Exception
Throws:
Exception

loadConfigurationProviders

protected void loadConfigurationProviders(ConfigurationProvider... providers)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextProvider (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface TextProvider

All Known Subinterfaces:
ResourceBundleTextProvider, ValidatorContext
All Known Implementing Classes:
ActionSupport, CompositeTextProvider, DefaultTextProvider, DelegatingValidatorContext, TextProviderSupport, VisitorFieldValidator.AppendingValidatorContext
public interface TextProvider

Provides access to ResourceBundles and their underlying text messages. Implementing classes can delegate TextProviderSupport. Messages will be searched in multiple resource bundles, startinag with the one associated with this particular class (action in most cases), continuing to try the message bundle associated with each superclass as well. It will stop once a bundle is found that contains the given text. This gives a cascading style that allow global texts to be defined for an application base class.

You can override LocaleProvider.getLocale() to change the behaviour of how to choose locale for the bundles that are returned. Typically you would use the LocaleProvider interface to get the users configured locale.

Author:
Jason Carreira, Rainer Hermanns
See Also:
LocaleProvider, TextProviderSupport

Method Summary
String | getText(String key) Gets a message based on a message key, or null if no message is found.
String | getText(String key, List<Object> args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
String | getText(String key, String defaultValue) Gets a message based on a key, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String[] args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
String | getText(String key, String defaultValue, List<Object> args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, List<Object> args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, String obj) Gets a message based on a key using the supplied obj, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, String[] args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, String[] args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
ResourceBundle | getTexts() Get the resource bundle associated with the implementing class (usually an action).
ResourceBundle | getTexts(String bundleName) Get the named bundle, such as "com/acme/Foo".
boolean | hasKey(String key) Checks if a message key exists.

Method Detail

hasKey

boolean hasKey(String key)
Checks if a message key exists.

Parameters:
key -
Returns:
boolean true if key exists, false otherwise.

getText

String getText(String key)
Gets a message based on a message key, or null if no message is found.

Parameters:
key - the resource bundle key that is to be searched for
Returns:
the message as found in the resource bundle, or null if none is found.

getText

String getText(String key,
               String defaultValue)
Gets a message based on a key, or, if the message is not found, a supplied default value is returned.

Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

String getText(String key,
               String defaultValue,
               String obj)
Gets a message based on a key using the supplied obj, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
obj - obj to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

String getText(String key,
               List<Object> args)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.

Parameters:
key - the resource bundle key that is to be searched for
args - a list args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or null if none is found.

getText

String getText(String key,
               String[] args)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.

Parameters:
key - the resource bundle key that is to be searched for
args - an array args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or null if none is found.

getText

String getText(String key,
               String defaultValue,
               List<Object> args)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - a list args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

String getText(String key,
               String defaultValue,
               String[] args)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - an array args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

String getText(String key,
               String defaultValue,
               List<Object> args,
               ValueStack stack)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - a list args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

String getText(String key,
               String defaultValue,
               String[] args,
               ValueStack stack)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - an array args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getTexts

ResourceBundle getTexts(String bundleName)
Get the named bundle, such as "com/acme/Foo".

Parameters:
bundleName - the name of the resource bundle, such as "com/acme/Foo".
Returns:
the bundle

getTexts

ResourceBundle getTexts()
Get the resource bundle associated with the implementing class (usually an action).

Returns:
the bundle
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextProviderFactory (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class TextProviderFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.TextProviderFactory

public class TextProviderFactory
extends Object

This factory enables users to provide and correctly initialize a custom TextProvider.

Author:
Oleg Gorobets, Rene Gielen

Constructor Summary
TextProviderFactory()
Method Summary
TextProvider | createInstance(Class clazz, LocaleProvider provider)
TextProvider | createInstance(ResourceBundle bundle, LocaleProvider provider)
protected TextProvider | getTextProvider()
void | setTextProvider(TextProvider textProvider)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextProviderFactory

public TextProviderFactory()
Method Detail

setTextProvider

public void setTextProvider(TextProvider textProvider)

getTextProvider

protected TextProvider getTextProvider()

createInstance

public TextProvider createInstance(Class clazz,
                                   LocaleProvider provider)

createInstance

public TextProvider createInstance(ResourceBundle bundle,
                                   LocaleProvider provider)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextProviderSupport (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class TextProviderSupport

java.lang.Object
    extended by  com.opensymphony.xwork2.TextProviderSupport
All Implemented Interfaces:
ResourceBundleTextProvider, TextProvider
public class TextProviderSupport
extends Object
implements ResourceBundleTextProvider

Default TextProvider implementation.

Author:
Jason Carreira, Rainer Hermanns

Constructor Summary
TextProviderSupport()
Default constructor
TextProviderSupport(Class clazz, LocaleProvider provider)
Constructor.
TextProviderSupport(ResourceBundle bundle, LocaleProvider provider)
Constructor.
Method Summary
String | getText(String key) Get a text from the resource bundles associated with this action.
String | getText(String key, List<Object> args) Get a text from the resource bundles associated with this action.
String | getText(String key, String defaultValue) Get a text from the resource bundles associated with this action.
String | getText(String key, String[] args) Get a text from the resource bundles associated with this action.
String | getText(String key, String defaultValue, List<Object> args) Get a text from the resource bundles associated with this action.
String | getText(String key, String defaultValue, List<Object> args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, String arg) Get a text from the resource bundles associated with this action.
String | getText(String key, String defaultValue, String[] args) Get a text from the resource bundles associated with this action.
String | getText(String key, String defaultValue, String[] args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
ResourceBundle | getTexts() Get the resource bundle associated with this action.
ResourceBundle | getTexts(String aBundleName) Get the named bundle.
boolean | hasKey(String key) Checks if a key is available in the resource bundles associated with this action.
void | setBundle(ResourceBundle bundle) Set the resource bundle to use.
void | setClazz(Class clazz) Set the class to use for reading the resource bundle.
void | setLocaleProvider(LocaleProvider localeProvider) Set the LocaleProvider to use.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextProviderSupport

public TextProviderSupport()
Default constructor

TextProviderSupport

public TextProviderSupport(Class clazz,
                           LocaleProvider provider)
Constructor.

Parameters:
clazz - a clazz to use for reading the resource bundle.
provider - a locale provider.

TextProviderSupport

public TextProviderSupport(ResourceBundle bundle,
                           LocaleProvider provider)
Constructor.

Parameters:
bundle - the resource bundle.
provider - a locale provider.
Method Detail

setBundle

public void setBundle(ResourceBundle bundle)
Description copied from interface: ResourceBundleTextProvider
Set the resource bundle to use.

Specified by:
setBundle in interface ResourceBundleTextProvider
Parameters:
bundle - the resource bundle.

setClazz

public void setClazz(Class clazz)
Description copied from interface: ResourceBundleTextProvider
Set the class to use for reading the resource bundle.

Specified by:
setClazz in interface ResourceBundleTextProvider
Parameters:
clazz - a clazz to use for reading the resource bundle.

setLocaleProvider

public void setLocaleProvider(LocaleProvider localeProvider)
Description copied from interface: ResourceBundleTextProvider
Set the LocaleProvider to use.

Specified by:
setLocaleProvider in interface ResourceBundleTextProvider
Parameters:
localeProvider - a locale provider.

hasKey

public boolean hasKey(String key)
Checks if a key is available in the resource bundles associated with this action. The resource bundles are searched, starting with the one associated with this particular action, and testing all its superclasses' bundles. It will stop once a bundle is found that contains the given text. This gives a cascading style that allow global texts to be defined for an application base class.

Specified by:
hasKey in interface TextProvider
Returns:
boolean true if key exists, false otherwise.

getText

public String getText(String key)
Get a text from the resource bundles associated with this action. The resource bundles are searched, starting with the one associated with this particular action, and testing all its superclasses' bundles. It will stop once a bundle is found that contains the given text. This gives a cascading style that allow global texts to be defined for an application base class.

Specified by:
getText in interface TextProvider
Parameters:
key - name of text to be found
Returns:
value of named text

getText

public String getText(String key,
                      String defaultValue)
Get a text from the resource bundles associated with this action. The resource bundles are searched, starting with the one associated with this particular action, and testing all its superclasses' bundles. It will stop once a bundle is found that contains the given text. This gives a cascading style that allow global texts to be defined for an application base class. If no text is found for this text name, the default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - name of text to be found
defaultValue - the default value which will be returned if no text is found
Returns:
value of named text

getText

public String getText(String key,
                      String defaultValue,
                      String arg)
Get a text from the resource bundles associated with this action. The resource bundles are searched, starting with the one associated with this particular action, and testing all its superclasses' bundles. It will stop once a bundle is found that contains the given text. This gives a cascading style that allow global texts to be defined for an application base class. If no text is found for this text name, the default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - name of text to be found
defaultValue - the default value which will be returned if no text is found
arg - obj to be used in a MessageFormat message
Returns:
value of named text

getText

public String getText(String key,
                      List<Object> args)
Get a text from the resource bundles associated with this action. The resource bundles are searched, starting with the one associated with this particular action, and testing all its superclasses' bundles. It will stop once a bundle is found that contains the given text. This gives a cascading style that allow global texts to be defined for an application base class. If no text is found for this text name, the default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - name of text to be found
args - a List of args to be used in a MessageFormat message
Returns:
value of named text

getText

public String getText(String key,
                      String[] args)
Get a text from the resource bundles associated with this action. The resource bundles are searched, starting with the one associated with this particular action, and testing all its superclasses' bundles. It will stop once a bundle is found that contains the given text. This gives a cascading style that allow global texts to be defined for an application base class. If no text is found for this text name, the default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - name of text to be found
args - an array of args to be used in a MessageFormat message
Returns:
value of named text

getText

public String getText(String key,
                      String defaultValue,
                      List<Object> args)
Get a text from the resource bundles associated with this action. The resource bundles are searched, starting with the one associated with this particular action, and testing all its superclasses' bundles. It will stop once a bundle is found that contains the given text. This gives a cascading style that allow global texts to be defined for an application base class. If no text is found for this text name, the default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - name of text to be found
defaultValue - the default value which will be returned if no text is found
args - a List of args to be used in a MessageFormat message
Returns:
value of named text

getText

public String getText(String key,
                      String defaultValue,
                      String[] args)
Get a text from the resource bundles associated with this action. The resource bundles are searched, starting with the one associated with this particular action, and testing all its superclasses' bundles. It will stop once a bundle is found that contains the given text. This gives a cascading style that allow global texts to be defined for an application base class. If no text is found for this text name, the default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - name of text to be found
defaultValue - the default value which will be returned if no text is found
args - an array of args to be used in a MessageFormat message
Returns:
value of named text

getText

public String getText(String key,
                      String defaultValue,
                      List<Object> args,
                      ValueStack stack)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - a list args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      String[] args,
                      ValueStack stack)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - an array args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getTexts

public ResourceBundle getTexts(String aBundleName)
Get the named bundle.

You can override the getLocale() methodName to change the behaviour of how to choose locale for the bundles that are returned. Typically you would use the TextProvider interface to get the users configured locale, or use your own methodName to allow the user to select the locale and store it in the session (by using the SessionAware interface).

Specified by:
getTexts in interface TextProvider
Parameters:
aBundleName - bundle name
Returns:
a resource bundle

getTexts

public ResourceBundle getTexts()
Get the resource bundle associated with this action. This will be based on the actual subclass that is used.

Specified by:
getTexts in interface TextProvider
Returns:
resouce bundle
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Unchainable (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface Unchainable

All Known Implementing Classes:
DefaultTextProvider
public interface Unchainable

Simple marker interface to indicate an object should not have its properties copied during chaining.

See Also:
ChainingInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnknownHandler (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface UnknownHandler

public interface UnknownHandler

Handles cases when the result or action is unknown.

This allows other classes like Struts plugins to provide intelligent defaults easier.

Method Summary
ActionConfig | handleUnknownAction(String namespace, String actionName) Handles the case when an action configuration is unknown.
Object | handleUnknownActionMethod(Object action, String methodName) Handles the case when an action method cannot be found.
Result | handleUnknownResult(ActionContext actionContext, String actionName, ActionConfig actionConfig, String resultCode) Handles the case when a result cannot be found for an action and result code.

Method Detail

handleUnknownAction

ActionConfig handleUnknownAction(String namespace,
                                 String actionName)
                                 throws XWorkException
Handles the case when an action configuration is unknown. Implementations can return a new ActionConfig to be used to process the request.

Parameters:
namespace - The namespace
actionName - The action name
Returns:
An generated ActionConfig, can return null
Throws:
XWorkException

handleUnknownResult

Result handleUnknownResult(ActionContext actionContext,
                           String actionName,
                           ActionConfig actionConfig,
                           String resultCode)
                           throws XWorkException
Handles the case when a result cannot be found for an action and result code.

Parameters:
actionContext - The action context
actionName - The action name
actionConfig - The action config
resultCode - The returned result code
Returns:
A result to be executed, can return null
Throws:
XWorkException

handleUnknownActionMethod

Object handleUnknownActionMethod(Object action,
                                 String methodName)
                                 throws NoSuchMethodException
Handles the case when an action method cannot be found. This method is responsible both for finding the method and executing it.

Parameters:
action - The action object
methodName - The method name to call
Returns:
The result returned from invoking the action method
Throws:
NoSuchMethodException - If the method cannot be found
Since:
2.1
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnknownHandlerManager (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface UnknownHandlerManager

All Known Implementing Classes:
DefaultUnknownHandlerManager
public interface UnknownHandlerManager

An unknown handler manager contains a list of UnknownHandler and iterates on them by order

See Also:
DefaultUnknownHandlerManager

Method Summary
List<UnknownHandler> | getUnknownHandlers()
ActionConfig | handleUnknownAction(String namespace, String actionName)
Object | handleUnknownMethod(Object action, String methodName)
Result | handleUnknownResult(ActionContext actionContext, String actionName, ActionConfig actionConfig, String resultCode)
boolean | hasUnknownHandlers()

Method Detail

handleUnknownResult

Result handleUnknownResult(ActionContext actionContext,
                           String actionName,
                           ActionConfig actionConfig,
                           String resultCode)

handleUnknownMethod

Object handleUnknownMethod(Object action,
                           String methodName)
                           throws NoSuchMethodException
Throws:
NoSuchMethodException

handleUnknownAction

ActionConfig handleUnknownAction(String namespace,
                                 String actionName)

hasUnknownHandlers

boolean hasUnknownHandlers()

getUnknownHandlers

List<UnknownHandler> getUnknownHandlers()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Validateable (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface Validateable

All Known Implementing Classes:
ActionSupport
public interface Validateable

Provides an interface in which a call for a validation check can be done.

Author:
Jason Carreira
See Also:
ActionSupport, DefaultWorkflowInterceptor

Method Summary
 void validate()
Performs validation.

Method Detail

validate

void validate()
Performs validation.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidationAware (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface ValidationAware

All Known Subinterfaces:
ValidatorContext
All Known Implementing Classes:
ActionSupport, DelegatingValidatorContext, ValidationAwareSupport, VisitorFieldValidator.AppendingValidatorContext
public interface ValidationAware

ValidationAware classes can accept Action (class level) or field level error messages. Action level messages are kept in a Collection. Field level error messages are kept in a Map from String field name to a List of field error msgs.

Author:
plightbo

Method Summary
void | addActionError(String anErrorMessage) Add an Action-level error message to this Action.
void | addActionMessage(String aMessage) Add an Action-level message to this Action.
void | addFieldError(String fieldName, String errorMessage) Add an error message for a given field.
Collection<String> | getActionErrors() Get the Collection of Action-level error messages for this action.
Collection<String> | getActionMessages() Get the Collection of Action-level messages for this action.
Map<String,List<String>> | getFieldErrors() Get the field specific errors associated with this action.
boolean | hasActionErrors() Check whether there are any Action-level error messages.
boolean | hasActionMessages() Checks whether there are any Action-level messages.
boolean | hasErrors() Checks whether there are any action errors or field errors.
boolean | hasFieldErrors() Check whether there are any field errors associated with this action.
void | setActionErrors(Collection<String> errorMessages) Set the Collection of Action-level String error messages.
void | setActionMessages(Collection<String> messages) Set the Collection of Action-level String messages (not errors).
void | setFieldErrors(Map<String,List<String>> errorMap) Set the field error map of fieldname (String) to Collection of String error messages.

Method Detail

setActionErrors

void setActionErrors(Collection<String> errorMessages)
Set the Collection of Action-level String error messages.

Parameters:
errorMessages - Collection of String error messages

getActionErrors

Collection<String> getActionErrors()
Get the Collection of Action-level error messages for this action. Error messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Returns:
Collection of String error messages

setActionMessages

void setActionMessages(Collection<String> messages)
Set the Collection of Action-level String messages (not errors).

Parameters:
messages - Collection of String messages (not errors).

getActionMessages

Collection<String> getActionMessages()
Get the Collection of Action-level messages for this action. Messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Returns:
Collection of String messages

setFieldErrors

void setFieldErrors(Map<String,List<String>> errorMap)
Set the field error map of fieldname (String) to Collection of String error messages.

Parameters:
errorMap - field error map

getFieldErrors

Map<String,List<String>> getFieldErrors()
Get the field specific errors associated with this action. Error messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Returns:
Map with errors mapped from fieldname (String) to Collection of String error messages

addActionError

void addActionError(String anErrorMessage)
Add an Action-level error message to this Action.

Parameters:
anErrorMessage - the error message

addActionMessage

void addActionMessage(String aMessage)
Add an Action-level message to this Action.

Parameters:
aMessage - the message

addFieldError

void addFieldError(String fieldName,
                   String errorMessage)
Add an error message for a given field.

Parameters:
fieldName - name of field
errorMessage - the error message

hasActionErrors

boolean hasActionErrors()
Check whether there are any Action-level error messages.

Returns:
true if any Action-level error messages have been registered

hasActionMessages

boolean hasActionMessages()
Checks whether there are any Action-level messages.

Returns:
true if any Action-level messages have been registered

hasErrors

boolean hasErrors()
Checks whether there are any action errors or field errors.

Note: that this does not have the same meaning as in WW 1.x.

Returns:
(hasActionErrors() || hasFieldErrors())

hasFieldErrors

boolean hasFieldErrors()
Check whether there are any field errors associated with this action.

Returns:
whether there are any field errors
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidationAwareSupport (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class ValidationAwareSupport

java.lang.Object
    extended by  com.opensymphony.xwork2.ValidationAwareSupport
All Implemented Interfaces:
ValidationAware, Serializable
public class ValidationAwareSupport
extends Object
implements ValidationAware, Serializable

Provides a default implementation of ValidationAware. Returns new collections for errors and messages (defensive copy).

Version:
$Date: 2008-06-21 11:29:39 +0200 (Sa, 21 Jun 2008) $ $Id: ValidationAwareSupport.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Jason Carreira, tm_jee
See Also:
Serialized Form

Constructor Summary
ValidationAwareSupport()
Method Summary
void | addActionError(String anErrorMessage) Add an Action-level error message to this Action.
void | addActionMessage(String aMessage) Add an Action-level message to this Action.
void | addFieldError(String fieldName, String errorMessage) Add an error message for a given field.
void | clearActionErrors() Clears action errors list.
void | clearErrors() Clears all error list/maps.
void | clearErrorsAndMessages() Clears all error and messages list/maps.
void | clearFieldErrors() Clears field errors map.
void | clearMessages() Clears messages list.
Collection<String> | getActionErrors() Get the Collection of Action-level error messages for this action.
Collection<String> | getActionMessages() Get the Collection of Action-level messages for this action.
Map<String,List<String>> | getFieldErrors() Get the field specific errors associated with this action.
boolean | hasActionErrors() Check whether there are any Action-level error messages.
boolean | hasActionMessages() Checks whether there are any Action-level messages.
boolean | hasErrors() Checks whether there are any action errors or field errors.
boolean | hasFieldErrors() Check whether there are any field errors associated with this action.
void | setActionErrors(Collection<String> errorMessages) Set the Collection of Action-level String error messages.
void | setActionMessages(Collection<String> messages) Set the Collection of Action-level String messages (not errors).
void | setFieldErrors(Map<String,List<String>> errorMap) Set the field error map of fieldname (String) to Collection of String error messages.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ValidationAwareSupport

public ValidationAwareSupport()
Method Detail

setActionErrors

public void setActionErrors(Collection<String> errorMessages)
Description copied from interface: ValidationAware
Set the Collection of Action-level String error messages.

Specified by:
setActionErrors in interface ValidationAware
Parameters:
errorMessages - Collection of String error messages

getActionErrors

public Collection<String> getActionErrors()
Description copied from interface: ValidationAware
Get the Collection of Action-level error messages for this action. Error messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getActionErrors in interface ValidationAware
Returns:
Collection of String error messages

setActionMessages

public void setActionMessages(Collection<String> messages)
Description copied from interface: ValidationAware
Set the Collection of Action-level String messages (not errors).

Specified by:
setActionMessages in interface ValidationAware
Parameters:
messages - Collection of String messages (not errors).

getActionMessages

public Collection<String> getActionMessages()
Description copied from interface: ValidationAware
Get the Collection of Action-level messages for this action. Messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getActionMessages in interface ValidationAware
Returns:
Collection of String messages

setFieldErrors

public void setFieldErrors(Map<String,List<String>> errorMap)
Description copied from interface: ValidationAware
Set the field error map of fieldname (String) to Collection of String error messages.

Specified by:
setFieldErrors in interface ValidationAware
Parameters:
errorMap - field error map

getFieldErrors

public Map<String,List<String>> getFieldErrors()
Description copied from interface: ValidationAware
Get the field specific errors associated with this action. Error messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getFieldErrors in interface ValidationAware
Returns:
Map with errors mapped from fieldname (String) to Collection of String error messages

addActionError

public void addActionError(String anErrorMessage)
Description copied from interface: ValidationAware
Add an Action-level error message to this Action.

Specified by:
addActionError in interface ValidationAware
Parameters:
anErrorMessage - the error message

addActionMessage

public void addActionMessage(String aMessage)
Description copied from interface: ValidationAware
Add an Action-level message to this Action.

Specified by:
addActionMessage in interface ValidationAware
Parameters:
aMessage - the message

addFieldError

public void addFieldError(String fieldName,
                          String errorMessage)
Description copied from interface: ValidationAware
Add an error message for a given field.

Specified by:
addFieldError in interface ValidationAware
Parameters:
fieldName - name of field
errorMessage - the error message

hasActionErrors

public boolean hasActionErrors()
Description copied from interface: ValidationAware
Check whether there are any Action-level error messages.

Specified by:
hasActionErrors in interface ValidationAware
Returns:
true if any Action-level error messages have been registered

hasActionMessages

public boolean hasActionMessages()
Description copied from interface: ValidationAware
Checks whether there are any Action-level messages.

Specified by:
hasActionMessages in interface ValidationAware
Returns:
true if any Action-level messages have been registered

hasErrors

public boolean hasErrors()
Description copied from interface: ValidationAware
Checks whether there are any action errors or field errors.

Note: that this does not have the same meaning as in WW 1.x.

Specified by:
hasErrors in interface ValidationAware
Returns:
(hasActionErrors() || hasFieldErrors())

hasFieldErrors

public boolean hasFieldErrors()
Description copied from interface: ValidationAware
Check whether there are any field errors associated with this action.

Specified by:
hasFieldErrors in interface ValidationAware
Returns:
whether there are any field errors

clearFieldErrors

public void clearFieldErrors()
Clears field errors map.

Will clear the map that contains field errors.

clearActionErrors

public void clearActionErrors()
Clears action errors list.

Will clear the list that contains action errors.

clearMessages

public void clearMessages()
Clears messages list.

Will clear the list that contains action messages.

clearErrors

public void clearErrors()
Clears all error list/maps.

Will clear the map and list that contain field errors and action errors.

clearErrorsAndMessages

public void clearErrorsAndMessages()
Clears all error and messages list/maps.

Will clear the maps/lists that contain field errors, action errors and action messages.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWork (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class XWork

java.lang.Object
    extended by  com.opensymphony.xwork2.XWork

public class XWork
extends Object

Simple facade to make using XWork standalone easier

Constructor Summary
XWork()
XWork(ConfigurationManager mgr)
Method Summary
void | executeAction(String namespace, String name, String method) Executes an action
void | executeAction(String namespace, String name, String method, Map<String,Object> extraContext) Executes an action with extra context information
void | setLoggerFactory(LoggerFactory factory)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XWork

public XWork()

XWork

public XWork(ConfigurationManager mgr)
Method Detail

setLoggerFactory

public void setLoggerFactory(LoggerFactory factory)

executeAction

public void executeAction(String namespace,
                          String name,
                          String method)
                   throws XWorkException
Executes an action

Parameters:
namespace - The namespace
name - The action name
method - The method name
Throws:
Exception - If anything goes wrong
XWorkException

executeAction

public void executeAction(String namespace,
                          String name,
                          String method,
                          Map<String,Object> extraContext)
                   throws XWorkException
Executes an action with extra context information

Parameters:
namespace - The namespace
name - The action name
method - The method name
extraContext - A map of extra context information
Throws:
Exception - If anything goes wrong
XWorkException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkException (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class XWorkException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  com.opensymphony.xwork2.XWorkException
All Implemented Interfaces:
Locatable, Serializable
Direct Known Subclasses:
ConfigurationException, ReferenceResolverException, ReflectionException, TypeConversionException
public class XWorkException
extends RuntimeException
implements Locatable

A generic runtime exception that optionally contains Location information

Author:
Jason Carreira
See Also:
Serialized Form

Constructor Summary
XWorkException()
Constructs a XWorkException with no detail message.
XWorkException(String s)
Constructs a XWorkException with the specified detail message.
XWorkException(String s, Object target)
Constructs a XWorkException with the specified detail message and target.
XWorkException(String s, Throwable cause)
Constructs a XWorkException with the specified detail message and exception cause.
XWorkException(String s, Throwable cause, Object target)
Constructs a XWorkException with the specified detail message, cause, and target
XWorkException(Throwable cause)
Constructs a XWorkException with the root cause
XWorkException(Throwable cause, Object target)
Constructs a XWorkException with the root cause and target
Method Summary
 Location getLocation()
Gets the location of the error, if available
 Throwable getThrowable()
Deprecated. Use Throwable.getCause()
 String toString()
Returns a short description of this throwable object, including the location.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XWorkException

public XWorkException()
Constructs a XWorkException with no detail message.

XWorkException

public XWorkException(String s)
Constructs a XWorkException with the specified detail message.

Parameters:
s - the detail message.

XWorkException

public XWorkException(String s,
                      Object target)
Constructs a XWorkException with the specified detail message and target.

Parameters:
s - the detail message.
target - the target of the exception.

XWorkException

public XWorkException(Throwable cause)
Constructs a XWorkException with the root cause

Parameters:
cause - The wrapped exception

XWorkException

public XWorkException(Throwable cause,
                      Object target)
Constructs a XWorkException with the root cause and target

Parameters:
cause - The wrapped exception
target - The target of the exception

XWorkException

public XWorkException(String s,
                      Throwable cause)
Constructs a XWorkException with the specified detail message and exception cause.

Parameters:
s - the detail message.
cause - the wrapped exception

XWorkException

public XWorkException(String s,
                      Throwable cause,
                      Object target)
Constructs a XWorkException with the specified detail message, cause, and target

Parameters:
s - the detail message.
cause - The wrapped exception
target - The target of the exception
Method Detail

getThrowable

@Deprecated
public Throwable getThrowable()
Deprecated. Use Throwable.getCause()

Gets the underlying cause

Returns:
the underlying cause, null if no cause

getLocation

public Location getLocation()
Gets the location of the error, if available

Specified by:
getLocation in interface Locatable
Returns:
the location, null if not available

toString

public String toString()
Returns a short description of this throwable object, including the location. If no detailed message is available, it will use the message of the underlying exception if available.

Overrides:
toString in class Throwable
Returns:
a string representation of this Throwable.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkMessages (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface XWorkMessages

public interface XWorkMessages

Contains constants for some default XWork messages.

Author:
Jason Carreira

Field Summary
static String | ACTION_EXECUTION_ERROR
static String | DEFAULT_INVALID_FIELDVALUE
static String | MISSING_ACTION_EXCEPTION
static String | MISSING_PACKAGE_ACTION_EXCEPTION

Field Detail

ACTION_EXECUTION_ERROR

static final String ACTION_EXECUTION_ERROR
See Also:
Constant Field Values

MISSING_ACTION_EXCEPTION

static final String MISSING_ACTION_EXCEPTION
See Also:
Constant Field Values

MISSING_PACKAGE_ACTION_EXCEPTION

static final String MISSING_PACKAGE_ACTION_EXCEPTION
See Also:
Constant Field Values

DEFAULT_INVALID_FIELDVALUE

static final String DEFAULT_INVALID_FIELDVALUE
See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkTestCase (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class XWorkTestCase

java.lang.Object
    extended by  junit.framework.Assert
        extended by  junit.framework.TestCase
            extended by  com.opensymphony.xwork2.XWorkTestCase
All Implemented Interfaces:
junit.framework.Test
public abstract class XWorkTestCase
extends junit.framework.TestCase

Base JUnit TestCase to extend for XWork specific JUnit tests. Uses the generic test setup for logic.

Author:
plightbo

Field Summary
protected ActionProxyFactory | actionProxyFactory
protected Configuration | configuration
protected ConfigurationManager | configurationManager
protected Container | container
Constructor Summary
XWorkTestCase()
Method Summary
protected void | loadButAdd(Class<?> type, Object impl)
protected void | loadButAdd(Class<?> type, String name, Object impl)
protected void | loadConfigurationProviders(ConfigurationProvider... providers)
protected void | setUp()
protected void | tearDown()
Methods inherited from class junit.framework.TestCase
countTestCases, createResult, getName, run, run, runBare, runTest, setName, toString
Methods inherited from class junit.framework.Assert
assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertFalse, assertFalse, assertNotNull, assertNotNull, assertNotSame, assertNotSame, assertNull, assertNull, assertSame, assertSame, assertTrue, assertTrue, fail, fail, failNotEquals, failNotSame, failSame, format
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

configurationManager

protected ConfigurationManager configurationManager

configuration

protected Configuration configuration

container

protected Container container

actionProxyFactory

protected ActionProxyFactory actionProxyFactory
Constructor Detail

XWorkTestCase

public XWorkTestCase()
Method Detail

setUp

protected void setUp()
              throws Exception
Overrides:
setUp in class junit.framework.TestCase
Throws:
Exception

tearDown

protected void tearDown()
                 throws Exception
Overrides:
tearDown in class junit.framework.TestCase
Throws:
Exception

loadConfigurationProviders

protected void loadConfigurationProviders(ConfigurationProvider... providers)

loadButAdd

protected void loadButAdd(Class<?> type,
                          Object impl)

loadButAdd

protected void loadButAdd(Class<?> type,
                          String name,
                          Object impl)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.opensymphony.xwork2.Action (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.Action

Packages that use Action
com.opensymphony.xwork2 Main XWork interfaces and classes.

Uses of Action in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement Action
 class ActionSupport
Provides a default implementation for the most common actions.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ActionChainResult (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ActionChainResult

No usage of com.opensymphony.xwork2.ActionChainResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ActionContext (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ActionContext

Packages that use ActionContext
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.mock | XWork specific mock classes.

Uses of ActionContext in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as ActionContext
protected  ActionContext DefaultActionInvocation.invocationContext

Methods in com.opensymphony.xwork2 that return ActionContext
static ActionContext | ActionContext.getContext() Returns the ActionContext specific to the current thread.
ActionContext | DefaultActionInvocation.getInvocationContext()
ActionContext | ActionInvocation.getInvocationContext() Gets the ActionContext associated with this ActionInvocation.

Methods in com.opensymphony.xwork2 with parameters of type ActionContext
Result | UnknownHandlerManager.handleUnknownResult(ActionContext actionContext, String actionName, ActionConfig actionConfig, String resultCode)
Result | UnknownHandler.handleUnknownResult(ActionContext actionContext, String actionName, ActionConfig actionConfig, String resultCode) Handles the case when a result cannot be found for an action and result code.
Result | DefaultUnknownHandlerManager.handleUnknownResult(ActionContext actionContext, String actionName, ActionConfig actionConfig, String resultCode) Iterate over UnknownHandlers and return the result of the first one that can handle it
static void | ActionContext.setContext(ActionContext context) Sets the action context for the current thread.

Uses of ActionContext in com.opensymphony.xwork2.config.impl

Methods in com.opensymphony.xwork2.config.impl that return ActionContext
protected  ActionContext DefaultConfiguration.setContext(Container cont)

Uses of ActionContext in com.opensymphony.xwork2.interceptor

Methods in com.opensymphony.xwork2.interceptor with parameters of type ActionContext
protected void | StaticParametersInterceptor.addParametersToContext(ActionContext ac, Map<String,?> newParams) Adds the parameters into context's ParameterMap.
protected void | ParametersInterceptor.addParametersToContext(ActionContext ac, Map<String,Object> newParams) Adds the parameters into context's ParameterMap
protected Object | ScopedModelDrivenInterceptor.resolveModel(ObjectFactory factory, ActionContext actionContext, String modelClassName, String modelScope, String modelName)
protected Map<String,String> | StaticParametersInterceptor.retrieveParameters(ActionContext ac)
protected Map<String,Object> | ParametersInterceptor.retrieveParameters(ActionContext ac) Gets the parameter map to apply from wherever appropriate

Uses of ActionContext in com.opensymphony.xwork2.mock

Methods in com.opensymphony.xwork2.mock that return ActionContext
 ActionContext MockActionInvocation.getInvocationContext()

Methods in com.opensymphony.xwork2.mock with parameters of type ActionContext
 void MockActionInvocation.setInvocationContext(ActionContext invocationContext)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.ActionEventListener (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.ActionEventListener

Packages that use ActionEventListener
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.mock | XWork specific mock classes.

Uses of ActionEventListener in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as ActionEventListener
protected ActionEventListener | DefaultActionProxy.actionEventListener
protected ActionEventListener | DefaultActionInvocation.actionEventListener

Methods in com.opensymphony.xwork2 with parameters of type ActionEventListener
void | DefaultActionProxy.setActionEventListener(ActionEventListener listener)
void | DefaultActionInvocation.setActionEventListener(ActionEventListener listener)
void | ActionInvocation.setActionEventListener(ActionEventListener listener) Sets the action event listener to respond to key action events.

Uses of ActionEventListener in com.opensymphony.xwork2.mock

Methods in com.opensymphony.xwork2.mock that return ActionEventListener
 ActionEventListener MockActionInvocation.getActionEventListener()

Methods in com.opensymphony.xwork2.mock with parameters of type ActionEventListener
 void MockActionInvocation.setActionEventListener(ActionEventListener listener)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.ActionInvocation (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.ActionInvocation

Packages that use ActionInvocation
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.interceptor.annotations | Interceptor annotations.
com.opensymphony.xwork2.mock | XWork specific mock classes.
com.opensymphony.xwork2.spring.interceptor | Spring specific interceptor classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.

Uses of ActionInvocation in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement ActionInvocation
 class DefaultActionInvocation
The Default ActionInvocation implementation

Fields in com.opensymphony.xwork2 declared as ActionInvocation
protected  ActionInvocation DefaultActionProxy.invocation

Methods in com.opensymphony.xwork2 that return ActionInvocation
ActionInvocation | ActionContext.getActionInvocation() Gets the action invocation (the execution state).
ActionInvocation | DefaultActionProxy.getInvocation()
ActionInvocation | ActionProxy.getInvocation() Gets the ActionInvocation associated with this ActionProxy.

Methods in com.opensymphony.xwork2 with parameters of type ActionInvocation
ActionProxy | DefaultActionProxyFactory.createActionProxy(ActionInvocation inv, String namespace, String actionName, boolean executeResult, boolean cleanupContext)
ActionProxy | DefaultActionProxyFactory.createActionProxy(ActionInvocation inv, String namespace, String actionName, String methodName, boolean executeResult, boolean cleanupContext)
ActionProxy | ActionProxyFactory.createActionProxy(ActionInvocation actionInvocation, String namespace, String actionName, String methodName, boolean executeResult, boolean cleanupContext) Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including passed ActionInvocation instance.
void | Result.execute(ActionInvocation invocation) Represents a generic interface for all action execution results.
void | ActionChainResult.execute(ActionInvocation invocation)
void | ActionContext.setActionInvocation(ActionInvocation actionInvocation) Sets the action invocation (the execution state).

Constructors in com.opensymphony.xwork2 with parameters of type ActionInvocation
DefaultActionProxy(ActionInvocation inv, String namespace, String actionName, String methodName, boolean executeResult, boolean cleanupContext)
This constructor is private so the builder methods (create*) should be used to create an DefaultActionProxy.

Uses of ActionInvocation in com.opensymphony.xwork2.interceptor

Methods in com.opensymphony.xwork2.interceptor with parameters of type ActionInvocation
protected boolean | MethodFilterInterceptor.applyInterceptor(ActionInvocation invocation)
void | PreResultListener.beforeResult(ActionInvocation invocation, String resultCode) This callback method will be called after the Action execution and before the Result execution.
void | ModelDrivenInterceptor.RefreshModelBeforeResult.beforeResult(ActionInvocation invocation, String resultCode)
String | PrepareInterceptor.doIntercept(ActionInvocation invocation)
String | ParametersInterceptor.doIntercept(ActionInvocation invocation)
protected abstract String | MethodFilterInterceptor.doIntercept(ActionInvocation invocation) Subclasses must override to implement the interceptor logic.
protected String | DefaultWorkflowInterceptor.doIntercept(ActionInvocation invocation) Intercept ActionInvocation and returns a inputResultName when action / field errors is found registered.
protected Object | ConversionErrorInterceptor.getOverrideExpr(ActionInvocation invocation, Object value)
String | TimerInterceptor.intercept(ActionInvocation invocation)
String | StaticParametersInterceptor.intercept(ActionInvocation invocation)
String | ScopedModelDrivenInterceptor.intercept(ActionInvocation invocation)
String | ParameterRemoverInterceptor.intercept(ActionInvocation invocation) Decide if the parameter should be removed from the parameter map based on paramNames and paramValues.
String | ParameterFilterInterceptor.intercept(ActionInvocation invocation)
String | ModelDrivenInterceptor.intercept(ActionInvocation invocation)
String | MethodFilterInterceptor.intercept(ActionInvocation invocation)
String | LoggingInterceptor.intercept(ActionInvocation invocation)
String | Interceptor.intercept(ActionInvocation invocation) Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the ActionInvocation or to short-circuit the processing and just return a String return code.
String | I18nInterceptor.intercept(ActionInvocation invocation)
String | ExceptionMappingInterceptor.intercept(ActionInvocation invocation)
String | ConversionErrorInterceptor.intercept(ActionInvocation invocation)
String | ChainingInterceptor.intercept(ActionInvocation invocation)
String | AliasInterceptor.intercept(ActionInvocation invocation)
abstract String | AbstractInterceptor.intercept(ActionInvocation invocation) Override to handle interception
static void | PrefixMethodInvocationUtil.invokePrefixMethod(ActionInvocation actionInvocation, String[] prefixes) This method will prefix actionInvocation's ActionProxy's method with prefixes before invoking the prefixed method.
protected String | TimerInterceptor.invokeUnderTiming(ActionInvocation invocation) Is called to invoke the action invocation and time the execution time.
protected void | ExceptionMappingInterceptor.publishException(ActionInvocation invocation, ExceptionHolder exceptionHolder) Default implementation to handle ExceptionHolder publishing.
protected void | I18nInterceptor.saveLocale(ActionInvocation invocation, Locale locale) Save the given locale to the ActionInvocation.

Uses of ActionInvocation in com.opensymphony.xwork2.interceptor.annotations

Methods in com.opensymphony.xwork2.interceptor.annotations with parameters of type ActionInvocation
void | AnnotationWorkflowInterceptor.beforeResult(ActionInvocation invocation, String resultCode) Invokes any @BeforeResult annotated methods
String | AnnotationWorkflowInterceptor.intercept(ActionInvocation invocation) Discovers annotated methods on the action and calls them according to the workflow
String | AnnotationParameterFilterIntereptor.intercept(ActionInvocation invocation)

Uses of ActionInvocation in com.opensymphony.xwork2.mock

Classes in com.opensymphony.xwork2.mock that implement ActionInvocation
 class MockActionInvocation
Mock for an ActionInvocation.

Methods in com.opensymphony.xwork2.mock that return ActionInvocation
 ActionInvocation MockActionProxy.getInvocation()

Methods in com.opensymphony.xwork2.mock with parameters of type ActionInvocation
void | MockResult.execute(ActionInvocation invocation)
String | MockInterceptor.intercept(ActionInvocation invocation) Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the DefaultActionInvocation or to short-circuit the processing and just return a String return code.
void | MockActionProxy.setInvocation(ActionInvocation invocation)

Uses of ActionInvocation in com.opensymphony.xwork2.spring.interceptor

Methods in com.opensymphony.xwork2.spring.interceptor with parameters of type ActionInvocation
 String ActionAutowiringInterceptor.intercept(ActionInvocation invocation)
Looks for the ApplicationContext under the attribute that the Spring listener sets in the servlet context.

Uses of ActionInvocation in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type ActionInvocation
protected void | ValidationInterceptor.doBeforeInvocation(ActionInvocation invocation) Gets the current action and its context and delegates to ActionValidatorManager proper validate method.
protected String | ValidationInterceptor.doIntercept(ActionInvocation invocation)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.ActionProxy (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.ActionProxy

Packages that use ActionProxy
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.mock | XWork specific mock classes.

Uses of ActionProxy in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement ActionProxy
 class DefaultActionProxy
The Default ActionProxy implementation

Fields in com.opensymphony.xwork2 declared as ActionProxy
protected  ActionProxy DefaultActionInvocation.proxy

Methods in com.opensymphony.xwork2 that return ActionProxy
 ActionProxy DefaultActionProxyFactory.createActionProxy(ActionInvocation inv, String namespace, String actionName, boolean executeResult, boolean cleanupContext)
 ActionProxy DefaultActionProxyFactory.createActionProxy(ActionInvocation inv, String namespace, String actionName, String methodName, boolean executeResult, boolean cleanupContext)
 ActionProxy ActionProxyFactory.createActionProxy(ActionInvocation actionInvocation, String namespace, String actionName, String methodName, boolean executeResult, boolean cleanupContext)
Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including passed ActionInvocation instance.
 ActionProxy DefaultActionProxyFactory.createActionProxy(String namespace, String actionName, Map<String,Object> extraContext)
 ActionProxy ActionProxyFactory.createActionProxy(String namespace, String actionName, Map<String,Object> extraContext)
Deprecated. Since 2.1.1, use instead
 ActionProxy DefaultActionProxyFactory.createActionProxy(String namespace, String actionName, Map<String,Object> extraContext, boolean executeResult, boolean cleanupContext)
 ActionProxy ActionProxyFactory.createActionProxy(String namespace, String actionName, Map<String,Object> extraContext, boolean executeResult, boolean cleanupContext)
Deprecated. Since 2.1.1, use ActionProxyFactory.createActionProxy(String,String,String,Map,boolean,boolean) instead
 ActionProxy DefaultActionProxyFactory.createActionProxy(String namespace, String actionName, String methodName, Map<String,Object> extraContext)
 ActionProxy ActionProxyFactory.createActionProxy(String namespace, String actionName, String methodName, Map<String,Object> extraContext)
Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.
 ActionProxy DefaultActionProxyFactory.createActionProxy(String namespace, String actionName, String methodName, Map<String,Object> extraContext, boolean executeResult, boolean cleanupContext)
 ActionProxy ActionProxyFactory.createActionProxy(String namespace, String actionName, String methodName, Map<String,Object> extraContext, boolean executeResult, boolean cleanupContext)
Creates an ActionProxy for the given namespace and action name by looking up the configuration.The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.
 ActionProxy DefaultActionInvocation.getProxy()
 ActionProxy ActionInvocation.getProxy()
Get the ActionProxy holding this ActionInvocation.
 ActionProxy ActionChainResult.getProxy()

Methods in com.opensymphony.xwork2 with parameters of type ActionProxy
void | DefaultActionInvocation.init(ActionProxy proxy)
void | ActionInvocation.init(ActionProxy proxy)

Uses of ActionProxy in com.opensymphony.xwork2.mock

Classes in com.opensymphony.xwork2.mock that implement ActionProxy
 class MockActionProxy
Mock for an ActionProxy.

Methods in com.opensymphony.xwork2.mock that return ActionProxy
 ActionProxy MockActionInvocation.getProxy()

Methods in com.opensymphony.xwork2.mock with parameters of type ActionProxy
void | MockActionInvocation.init(ActionProxy proxy)
void | MockActionInvocation.setProxy(ActionProxy proxy)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.ActionProxyFactory (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.ActionProxyFactory

Packages that use ActionProxyFactory
com.opensymphony.xwork2 Main XWork interfaces and classes.

Uses of ActionProxyFactory in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement ActionProxyFactory
 class DefaultActionProxyFactory
Default factory for ActionProxyFactory.

Fields in com.opensymphony.xwork2 declared as ActionProxyFactory
protected ActionProxyFactory | XWorkTestCase.actionProxyFactory
protected ActionProxyFactory | TestNGXWorkTestCase.actionProxyFactory

Methods in com.opensymphony.xwork2 with parameters of type ActionProxyFactory
 void ActionChainResult.setActionProxyFactory(ActionProxyFactory actionProxyFactory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ActionSupport (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ActionSupport

No usage of com.opensymphony.xwork2.ActionSupport

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.CompositeTextProvider (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.CompositeTextProvider

No usage of com.opensymphony.xwork2.CompositeTextProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.DefaultActionInvocation (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.DefaultActionInvocation

No usage of com.opensymphony.xwork2.DefaultActionInvocation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.DefaultActionProxy (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.DefaultActionProxy

No usage of com.opensymphony.xwork2.DefaultActionProxy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.DefaultActionProxyFactory (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.DefaultActionProxyFactory

No usage of com.opensymphony.xwork2.DefaultActionProxyFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.DefaultTextProvider (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.DefaultTextProvider

No usage of com.opensymphony.xwork2.DefaultTextProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.DefaultUnknownHandlerManager (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.DefaultUnknownHandlerManager

No usage of com.opensymphony.xwork2.DefaultUnknownHandlerManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.InvalidMetadataException (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.InvalidMetadataException

No usage of com.opensymphony.xwork2.InvalidMetadataException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.LocaleProvider (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.LocaleProvider

Packages that use LocaleProvider
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Uses of LocaleProvider in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement LocaleProvider
 class ActionSupport
Provides a default implementation for the most common actions.

Methods in com.opensymphony.xwork2 with parameters of type LocaleProvider
TextProvider | TextProviderFactory.createInstance(Class clazz, LocaleProvider provider)
TextProvider | TextProviderFactory.createInstance(ResourceBundle bundle, LocaleProvider provider)
void | TextProviderSupport.setLocaleProvider(LocaleProvider localeProvider)
void | ResourceBundleTextProvider.setLocaleProvider(LocaleProvider localeProvider) Set the LocaleProvider to use.

Constructors in com.opensymphony.xwork2 with parameters of type LocaleProvider
TextProviderSupport(Class clazz, LocaleProvider provider)
Constructor.
TextProviderSupport(ResourceBundle bundle, LocaleProvider provider)
Constructor.

Uses of LocaleProvider in com.opensymphony.xwork2.validator

Subinterfaces of LocaleProvider in com.opensymphony.xwork2.validator
 interface ValidatorContext
The context for validation.

Classes in com.opensymphony.xwork2.validator that implement LocaleProvider
 class DelegatingValidatorContext
A default implementation of the ValidatorContext interface.

Methods in com.opensymphony.xwork2.validator that return LocaleProvider
protected static LocaleProvider DelegatingValidatorContext.makeLocaleProvider(Object object)

Methods in com.opensymphony.xwork2.validator with parameters of type LocaleProvider
static TextProvider DelegatingValidatorContext.makeTextProvider(Object object, LocaleProvider localeProvider)

Constructors in com.opensymphony.xwork2.validator with parameters of type LocaleProvider
DelegatingValidatorContext(ValidationAware validationAware, TextProvider textProvider, LocaleProvider localeProvider)
Creates a new validation context given a ValidationAware object, and a text and locale provider.

Uses of LocaleProvider in com.opensymphony.xwork2.validator.validators

Classes in com.opensymphony.xwork2.validator.validators that implement LocaleProvider
static class VisitorFieldValidator.AppendingValidatorContext

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.MockActionInvocation (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.MockActionInvocation

No usage of com.opensymphony.xwork2.MockActionInvocation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.ModelDriven (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.ModelDriven

Packages that use ModelDriven
com.opensymphony.xwork2.interceptor Interceptor classes.

Uses of ModelDriven in com.opensymphony.xwork2.interceptor

Subinterfaces of ModelDriven in com.opensymphony.xwork2.interceptor
 interface ScopedModelDriven<T>
Adds the ability to set a model, probably retrieved from a given state.

Fields in com.opensymphony.xwork2.interceptor declared as ModelDriven
protected  ModelDriven ModelDrivenInterceptor.RefreshModelBeforeResult.action

Constructors in com.opensymphony.xwork2.interceptor with parameters of type ModelDriven
ModelDrivenInterceptor.RefreshModelBeforeResult(ModelDriven action, Object model)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ObjectFactory (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ObjectFactory

Packages that use ObjectFactory
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.conversion.impl |
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.ognl.accessor |
com.opensymphony.xwork2.spring | Spring ObjectFactory classes.
com.opensymphony.xwork2.util | XWork util classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.

Uses of ObjectFactory in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as ObjectFactory
protected ObjectFactory | DefaultActionProxy.objectFactory
protected ObjectFactory | DefaultActionInvocation.objectFactory

Methods in com.opensymphony.xwork2 that return ObjectFactory
static ObjectFactory ObjectFactory.getObjectFactory()
Deprecated. Since 2.1

Methods in com.opensymphony.xwork2 with parameters of type ObjectFactory
void | DefaultActionProxy.setObjectFactory(ObjectFactory factory)
void | DefaultActionInvocation.setObjectFactory(ObjectFactory fac)

Uses of ObjectFactory in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers with parameters of type ObjectFactory
static List<InterceptorMapping> | InterceptorBuilder.constructInterceptorReference(InterceptorLocator interceptorLocator, String refName, Map<String,String> refParams, Location location, ObjectFactory objectFactory) Builds a list of interceptors referenced by the refName in the supplied PackageConfig (InterceptorMapping object).
void | XmlConfigurationProvider.setObjectFactory(ObjectFactory objectFactory)

Uses of ObjectFactory in com.opensymphony.xwork2.conversion.impl

Methods in com.opensymphony.xwork2.conversion.impl with parameters of type ObjectFactory
void | XWorkConverter.setObjectFactory(ObjectFactory factory)
void | XWorkBasicConverter.setObjectFactory(ObjectFactory fac)
void | InstantiatingNullHandler.setObjectFactory(ObjectFactory fac)

Uses of ObjectFactory in com.opensymphony.xwork2.interceptor

Methods in com.opensymphony.xwork2.interceptor with parameters of type ObjectFactory
protected Object | ScopedModelDrivenInterceptor.resolveModel(ObjectFactory factory, ActionContext actionContext, String modelClassName, String modelScope, String modelName)
void | ScopedModelDrivenInterceptor.setObjectFactory(ObjectFactory factory)

Uses of ObjectFactory in com.opensymphony.xwork2.ognl.accessor

Methods in com.opensymphony.xwork2.ognl.accessor with parameters of type ObjectFactory
void | XWorkMapPropertyAccessor.setObjectFactory(ObjectFactory fac)
void | XWorkListPropertyAccessor.setObjectFactory(ObjectFactory fac)
void | XWorkCollectionPropertyAccessor.setObjectFactory(ObjectFactory fac)

Uses of ObjectFactory in com.opensymphony.xwork2.spring

Subclasses of ObjectFactory in com.opensymphony.xwork2.spring
class | SpringObjectFactory Simple implementation of the ObjectFactory that makes use of Spring's application context if one has been configured, before falling back on the default mechanism of instantiating a new class using the class name.
class | SpringProxyableObjectFactory SpringProxyableObjectFactory.

Uses of ObjectFactory in com.opensymphony.xwork2.util

Constructors in com.opensymphony.xwork2.util with parameters of type ObjectFactory
XWorkList(ObjectFactory fac, XWorkConverter conv, Class clazz)
XWorkList(ObjectFactory fac, XWorkConverter conv, Class clazz, int initialCapacity)

Uses of ObjectFactory in com.opensymphony.xwork2.validator

Fields in com.opensymphony.xwork2.validator declared as ObjectFactory
protected  ObjectFactory DefaultValidatorFactory.objectFactory

Methods in com.opensymphony.xwork2.validator with parameters of type ObjectFactory
 void DefaultValidatorFileParser.setObjectFactory(ObjectFactory fac)

Constructors in com.opensymphony.xwork2.validator with parameters of type ObjectFactory
DefaultValidatorFactory(ObjectFactory objectFactory, ValidatorFileParser parser)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.Preparable (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.Preparable

No usage of com.opensymphony.xwork2.Preparable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.ResourceBundleTextProvider (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.ResourceBundleTextProvider

Packages that use ResourceBundleTextProvider
com.opensymphony.xwork2 Main XWork interfaces and classes.

Uses of ResourceBundleTextProvider in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement ResourceBundleTextProvider
 class TextProviderSupport
Default TextProvider implementation.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.Result (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.Result

Packages that use Result
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.mock | XWork specific mock classes.

Uses of Result in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement Result
 class ActionChainResult
This result invokes an entire other action, complete with it's own interceptor stack and result.

Fields in com.opensymphony.xwork2 declared as Result
protected Result | DefaultActionInvocation.explicitResult
protected Result | DefaultActionInvocation.result

Methods in com.opensymphony.xwork2 that return Result
Result | ObjectFactory.buildResult(ResultConfig resultConfig, Map<String,Object> extraContext) Build a Result using the type in the ResultConfig and set the parameters in the ResultConfig.
Result | DefaultActionInvocation.createResult()
Result | DefaultActionInvocation.getResult() If the DefaultActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned.
Result | ActionInvocation.getResult() If the ActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned.
Result | UnknownHandlerManager.handleUnknownResult(ActionContext actionContext, String actionName, ActionConfig actionConfig, String resultCode)
Result | UnknownHandler.handleUnknownResult(ActionContext actionContext, String actionName, ActionConfig actionConfig, String resultCode) Handles the case when a result cannot be found for an action and result code.
Result | DefaultUnknownHandlerManager.handleUnknownResult(ActionContext actionContext, String actionName, ActionConfig actionConfig, String resultCode) Iterate over UnknownHandlers and return the result of the first one that can handle it

Uses of Result in com.opensymphony.xwork2.mock

Classes in com.opensymphony.xwork2.mock that implement Result
 class MockResult
Mock for a Result.

Methods in com.opensymphony.xwork2.mock that return Result
 Result MockActionInvocation.getResult()

Methods in com.opensymphony.xwork2.mock with parameters of type Result
 void MockActionInvocation.setResult(Result result)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.TestNGXWorkTestCase (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.TestNGXWorkTestCase

No usage of com.opensymphony.xwork2.TestNGXWorkTestCase

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.TextProvider (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.TextProvider

Packages that use TextProvider
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.ognl |
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Uses of TextProvider in com.opensymphony.xwork2

Subinterfaces of TextProvider in com.opensymphony.xwork2
 interface ResourceBundleTextProvider
Extension Interface for TextProvider to help supporting ResourceBundles.

Classes in com.opensymphony.xwork2 that implement TextProvider
class | ActionSupport Provides a default implementation for the most common actions.
class | CompositeTextProvider This is a composite TextProvider that takes in an array or List of TextProviders, it will consult each of them in order to get a composite result.
class | DefaultTextProvider DefaultTextProvider gets texts from only the default resource bundles associated with the LocalizedTextUtil.
class | TextProviderSupport Default TextProvider implementation.

Methods in com.opensymphony.xwork2 that return TextProvider
TextProvider | TextProviderFactory.createInstance(Class clazz, LocaleProvider provider)
TextProvider | TextProviderFactory.createInstance(ResourceBundle bundle, LocaleProvider provider)
protected TextProvider | TextProviderFactory.getTextProvider()

Methods in com.opensymphony.xwork2 with parameters of type TextProvider
 void TextProviderFactory.setTextProvider(TextProvider textProvider)

Constructors in com.opensymphony.xwork2 with parameters of type TextProvider
CompositeTextProvider(TextProvider[] textProviders)
Instantiates a CompositeTextProvider with some predefined textProviders.

Constructor parameters in com.opensymphony.xwork2 with type arguments of type TextProvider
CompositeTextProvider(List<TextProvider> textProviders)
Instantiates a CompositeTextProvider with some predefined textProviders.

Uses of TextProvider in com.opensymphony.xwork2.ognl

Methods in com.opensymphony.xwork2.ognl with parameters of type TextProvider
 void OgnlValueStackFactory.setTextProvider(TextProvider textProvider)

Constructors in com.opensymphony.xwork2.ognl with parameters of type TextProvider
OgnlValueStack(XWorkConverter xworkConverter, CompoundRootAccessor accessor, TextProvider prov, boolean allowStaticAccess)

Uses of TextProvider in com.opensymphony.xwork2.validator

Subinterfaces of TextProvider in com.opensymphony.xwork2.validator
 interface ValidatorContext
The context for validation.

Classes in com.opensymphony.xwork2.validator that implement TextProvider
 class DelegatingValidatorContext
A default implementation of the ValidatorContext interface.

Methods in com.opensymphony.xwork2.validator that return TextProvider
protected TextProvider | DelegatingValidatorContext.getTextProvider()
static TextProvider | DelegatingValidatorContext.makeTextProvider(Object object, LocaleProvider localeProvider)

Methods in com.opensymphony.xwork2.validator with parameters of type TextProvider
protected  void DelegatingValidatorContext.setTextProvider(TextProvider textProvider)

Constructors in com.opensymphony.xwork2.validator with parameters of type TextProvider
DelegatingValidatorContext(ValidationAware validationAware, TextProvider textProvider, LocaleProvider localeProvider)
Creates a new validation context given a ValidationAware object, and a text and locale provider.

Uses of TextProvider in com.opensymphony.xwork2.validator.validators

Classes in com.opensymphony.xwork2.validator.validators that implement TextProvider
static class VisitorFieldValidator.AppendingValidatorContext

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.TextProviderFactory (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.TextProviderFactory

No usage of com.opensymphony.xwork2.TextProviderFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.TextProviderSupport (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.TextProviderSupport

No usage of com.opensymphony.xwork2.TextProviderSupport

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.Unchainable (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.Unchainable

Packages that use Unchainable
com.opensymphony.xwork2 Main XWork interfaces and classes.

Uses of Unchainable in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement Unchainable
 class DefaultTextProvider
DefaultTextProvider gets texts from only the default resource bundles associated with the LocalizedTextUtil.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.UnknownHandler (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.UnknownHandler

Packages that use UnknownHandler
com.opensymphony.xwork2 Main XWork interfaces and classes.

Uses of UnknownHandler in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 with type parameters of type UnknownHandler
protected  ArrayList<UnknownHandler> DefaultUnknownHandlerManager.unknownHandlers

Methods in com.opensymphony.xwork2 that return types with arguments of type UnknownHandler
List<UnknownHandler> | UnknownHandlerManager.getUnknownHandlers()
List<UnknownHandler> | DefaultUnknownHandlerManager.getUnknownHandlers()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.UnknownHandlerManager (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.UnknownHandlerManager

Packages that use UnknownHandlerManager
com.opensymphony.xwork2 Main XWork interfaces and classes.

Uses of UnknownHandlerManager in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement UnknownHandlerManager
 class DefaultUnknownHandlerManager
Default implementation of UnknownHandlerManager

Fields in com.opensymphony.xwork2 declared as UnknownHandlerManager
protected UnknownHandlerManager | DefaultActionProxy.unknownHandlerManager
protected UnknownHandlerManager | DefaultActionInvocation.unknownHandlerManager

Methods in com.opensymphony.xwork2 with parameters of type UnknownHandlerManager
void | DefaultActionProxy.setUnknownHandler(UnknownHandlerManager unknownHandlerManager)
void | DefaultActionInvocation.setUnknownHandlerManager(UnknownHandlerManager unknownHandlerManager)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.Validateable (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.Validateable

Packages that use Validateable
com.opensymphony.xwork2 Main XWork interfaces and classes.

Uses of Validateable in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement Validateable
 class ActionSupport
Provides a default implementation for the most common actions.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.ValidationAware (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.ValidationAware

Packages that use ValidationAware
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Uses of ValidationAware in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement ValidationAware
class | ActionSupport Provides a default implementation for the most common actions.
class | ValidationAwareSupport Provides a default implementation of ValidationAware.

Uses of ValidationAware in com.opensymphony.xwork2.validator

Subinterfaces of ValidationAware in com.opensymphony.xwork2.validator
 interface ValidatorContext
The context for validation.

Classes in com.opensymphony.xwork2.validator that implement ValidationAware
 class DelegatingValidatorContext
A default implementation of the ValidatorContext interface.

Methods in com.opensymphony.xwork2.validator that return ValidationAware
protected ValidationAware | DelegatingValidatorContext.getValidationAware()
protected static ValidationAware | DelegatingValidatorContext.makeValidationAware(Object object)

Methods in com.opensymphony.xwork2.validator with parameters of type ValidationAware
protected  void DelegatingValidatorContext.setValidationAware(ValidationAware validationAware)

Constructors in com.opensymphony.xwork2.validator with parameters of type ValidationAware
DelegatingValidatorContext(ValidationAware validationAware, TextProvider textProvider, LocaleProvider localeProvider)
Creates a new validation context given a ValidationAware object, and a text and locale provider.

Uses of ValidationAware in com.opensymphony.xwork2.validator.validators

Classes in com.opensymphony.xwork2.validator.validators that implement ValidationAware
static class VisitorFieldValidator.AppendingValidatorContext

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ValidationAwareSupport (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ValidationAwareSupport

No usage of com.opensymphony.xwork2.ValidationAwareSupport

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.XWork (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.XWork

No usage of com.opensymphony.xwork2.XWork

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.XWorkException (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.XWorkException

Packages that use XWorkException
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.conversion |
com.opensymphony.xwork2.util.reflection |

Uses of XWorkException in com.opensymphony.xwork2

Methods in com.opensymphony.xwork2 that throw XWorkException
void | XWork.executeAction(String namespace, String name, String method) Executes an action
void | XWork.executeAction(String namespace, String name, String method, Map<String,Object> extraContext) Executes an action with extra context information
ActionConfig | UnknownHandler.handleUnknownAction(String namespace, String actionName) Handles the case when an action configuration is unknown.
Result | UnknownHandler.handleUnknownResult(ActionContext actionContext, String actionName, ActionConfig actionConfig, String resultCode) Handles the case when a result cannot be found for an action and result code.

Uses of XWorkException in com.opensymphony.xwork2.config

Subclasses of XWorkException in com.opensymphony.xwork2.config
class | ConfigurationException ConfigurationException
class | ReferenceResolverException Exception when a reference can't be resolved.

Uses of XWorkException in com.opensymphony.xwork2.conversion

Subclasses of XWorkException in com.opensymphony.xwork2.conversion
 class TypeConversionException
TypeConversionException should be thrown by any TypeConverters which fail to convert values

Uses of XWorkException in com.opensymphony.xwork2.util.reflection

Subclasses of XWorkException in com.opensymphony.xwork2.util.reflection
 class ReflectionException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.XWorkMessages (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.XWorkMessages

No usage of com.opensymphony.xwork2.XWorkMessages

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.XWorkTestCase (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.XWorkTestCase

No usage of com.opensymphony.xwork2.XWorkTestCase

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Configuration (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config
Interface Configuration

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultConfiguration, MockConfiguration
public interface Configuration
extends Serializable

XWork configuration.

Author:
Mike

Method Summary
void | addPackageConfig(String name, PackageConfig packageConfig)
void | destroy() Allow the Configuration to clean up any resources that have been used.
Container | getContainer()
Set<String> | getLoadedFileNames()
PackageConfig | getPackageConfig(String name)
Set<String> | getPackageConfigNames()
Map<String,PackageConfig> | getPackageConfigs()
RuntimeConfiguration | getRuntimeConfiguration() The current runtime configuration.
List<UnknownHandlerConfig> | getUnknownHandlerStack()
void | rebuildRuntimeConfiguration()
void | reload(List<ConfigurationProvider> providers) Deprecated. Since 2.1
List<PackageProvider> | reloadContainer(List<ContainerProvider> containerProviders)
PackageConfig | removePackageConfig(String packageName) Removes a package from the the list of packages.
void | setUnknownHandlerStack(List<UnknownHandlerConfig> unknownHandlerStack)

Method Detail

rebuildRuntimeConfiguration

void rebuildRuntimeConfiguration()

getPackageConfig

PackageConfig getPackageConfig(String name)

getPackageConfigNames

Set<String> getPackageConfigNames()

getPackageConfigs

Map<String,PackageConfig> getPackageConfigs()

getRuntimeConfiguration

RuntimeConfiguration getRuntimeConfiguration()
The current runtime configuration. Currently, if changes have been made to the Configuration since the last time buildRuntimeConfiguration() was called, you'll need to make sure to.

Returns:
the current runtime configuration

addPackageConfig

void addPackageConfig(String name,
                      PackageConfig packageConfig)

removePackageConfig

PackageConfig removePackageConfig(String packageName)
Removes a package from the the list of packages. Changes to the configuration won't take effect until buildRuntimeConfiguration is called.

Parameters:
packageName - the name of the package to remove
Returns:
the package removed (if any)

destroy

void destroy()
Allow the Configuration to clean up any resources that have been used.

reload

@Deprecated
void reload(List<ConfigurationProvider> providers)
            throws ConfigurationException
Deprecated. Since 2.1

Parameters:
providers -
Throws:
ConfigurationException

reloadContainer

List<PackageProvider> reloadContainer(List<ContainerProvider> containerProviders)
                                      throws ConfigurationException
Parameters:
containerProviders -
Throws:
ConfigurationException
Since:
2.1

getContainer

Container getContainer()
Returns:
the container

getLoadedFileNames

Set<String> getLoadedFileNames()

getUnknownHandlerStack

List<UnknownHandlerConfig> getUnknownHandlerStack()
Returns:
list of unknown handlers
Since:
2.1

setUnknownHandlerStack

void setUnknownHandlerStack(List<UnknownHandlerConfig> unknownHandlerStack)
Parameters:
unknownHandlerStack -
Since:
2.1
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ConfigurationException (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config
Class ConfigurationException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  com.opensymphony.xwork2.XWorkException
                    extended by  com.opensymphony.xwork2.config.ConfigurationException
All Implemented Interfaces:
Locatable, Serializable
public class ConfigurationException
extends XWorkException

ConfigurationException

Author:
Jason Carreira
See Also:
Serialized Form

Constructor Summary
ConfigurationException()
Constructs a ConfigurationException with no detail message.
ConfigurationException(String s)
Constructs a ConfigurationException with the specified detail message.
ConfigurationException(String s, Object target)
Constructs a ConfigurationException with the specified detail message.
ConfigurationException(String s, Throwable cause)
Constructs a ConfigurationException with the specified detail message.
ConfigurationException(String s, Throwable cause, Object target)
Constructs a ConfigurationException with the specified detail message.
ConfigurationException(Throwable cause)
Constructs a ConfigurationException with no detail message.
ConfigurationException(Throwable cause, Object target)
Constructs a ConfigurationException with no detail message.
Method Summary
Methods inherited from class com.opensymphony.xwork2.XWorkException
getLocation, getThrowable, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ConfigurationException

public ConfigurationException()
Constructs a ConfigurationException with no detail message.

ConfigurationException

public ConfigurationException(String s)
Constructs a ConfigurationException with the specified detail message.

Parameters:
s - the detail message.

ConfigurationException

public ConfigurationException(String s,
                              Object target)
Constructs a ConfigurationException with the specified detail message.

Parameters:
s - the detail message.

ConfigurationException

public ConfigurationException(Throwable cause)
Constructs a ConfigurationException with no detail message.

ConfigurationException

public ConfigurationException(Throwable cause,
                              Object target)
Constructs a ConfigurationException with no detail message.

ConfigurationException

public ConfigurationException(String s,
                              Throwable cause)
Constructs a ConfigurationException with the specified detail message.

Parameters:
s - the detail message.

ConfigurationException

public ConfigurationException(String s,
                              Throwable cause,
                              Object target)
Constructs a ConfigurationException with the specified detail message.

Parameters:
s - the detail message.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConfigurationManager (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config
Class ConfigurationManager

java.lang.Object
    extended by  com.opensymphony.xwork2.config.ConfigurationManager

public class ConfigurationManager
extends Object

ConfigurationManager - central for XWork Configuration management, including its ConfigurationProvider.

Version:
$Date: 2008-06-21 11:29:39 +0200 (Sa, 21 Jun 2008) $ $Id: ConfigurationManager.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Jason Carreira, tm_jee

Field Summary
protected Configuration | configuration
protected String | defaultFrameworkBeanName
protected static Logger | LOG
protected Lock | providerLock
Constructor Summary
ConfigurationManager()
ConfigurationManager(String name)
Method Summary
 void addConfigurationProvider(ConfigurationProvider provider)
Deprecated. Since 2.1, use #addContainerProvider()
 void addContainerProvider(ContainerProvider provider)
adds a configuration provider to the List of ConfigurationProviders.
 void clearConfigurationProviders()
Deprecated. Since 2.1, use clearContainerProviders()
 void clearContainerProviders()
 void conditionalReload()
Reloads the Configuration files if the configuration files indicate that they need to be reloaded.
 void destroyConfiguration()
Destroy its managing Configuration instance
 Configuration getConfiguration()
Get the current XWork configuration object.
 List<ConfigurationProvider> getConfigurationProviders()
Deprecated. Since 2.1, use getContainerProviders()
 List<ContainerProvider> getContainerProviders()
Get the current list of ConfigurationProviders.
 void reload()
 void setConfiguration(Configuration configuration)
 void setConfigurationProviders(List<ConfigurationProvider> configurationProviders)
Deprecated. Since 2.1, use #setContainerProvider()
 void setContainerProviders(List<ContainerProvider> containerProviders)
Set the list of configuration providers
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

protected static final Logger LOG

configuration

protected Configuration configuration

providerLock

protected Lock providerLock

defaultFrameworkBeanName

protected String defaultFrameworkBeanName
Constructor Detail

ConfigurationManager

public ConfigurationManager()

ConfigurationManager

public ConfigurationManager(String name)
Method Detail

getConfiguration

public Configuration getConfiguration()
Get the current XWork configuration object. By default an instance of DefaultConfiguration will be returned

See Also:
DefaultConfiguration

setConfiguration

public void setConfiguration(Configuration configuration)

getConfigurationProviders

@Deprecated
public List<ConfigurationProvider> getConfigurationProviders()
Deprecated. Since 2.1, use getContainerProviders()

Get the current list of ConfigurationProviders. If no custom ConfigurationProviders have been added, this method will return a list containing only the default ConfigurationProvider, XMLConfigurationProvider. if a custom ConfigurationProvider has been added, then the XmlConfigurationProvider must be added by hand.

WARNING: This returns only ContainerProviders that can be cast into ConfigurationProviders

Returns:
the list of registered ConfigurationProvider objects
See Also:
ConfigurationProvider

getContainerProviders

public List<ContainerProvider> getContainerProviders()
Get the current list of ConfigurationProviders. If no custom ConfigurationProviders have been added, this method will return a list containing only the default ConfigurationProvider, XMLConfigurationProvider. if a custom ConfigurationProvider has been added, then the XmlConfigurationProvider must be added by hand.

TODO: the lazy instantiation of XmlConfigurationProvider should be refactored to be elsewhere. the behavior described above seems unintuitive.

Returns:
the list of registered ConfigurationProvider objects
See Also:
ConfigurationProvider

setConfigurationProviders

@Deprecated
public void setConfigurationProviders(List<ConfigurationProvider> configurationProviders)
Deprecated. Since 2.1, use #setContainerProvider()

Set the list of configuration providers

Parameters:
configurationProviders -

setContainerProviders

public void setContainerProviders(List<ContainerProvider> containerProviders)
Set the list of configuration providers

Parameters:
containerProviders -

addConfigurationProvider

@Deprecated
public void addConfigurationProvider(ConfigurationProvider provider)
Deprecated. Since 2.1, use #addContainerProvider()

adds a configuration provider to the List of ConfigurationProviders. a given ConfigurationProvider may be added more than once

Parameters:
provider - the ConfigurationProvider to register

addContainerProvider

public void addContainerProvider(ContainerProvider provider)
adds a configuration provider to the List of ConfigurationProviders. a given ConfigurationProvider may be added more than once

Parameters:
provider - the ConfigurationProvider to register

clearConfigurationProviders

@Deprecated
public void clearConfigurationProviders()
Deprecated. Since 2.1, use clearContainerProviders()

clears the registered ConfigurationProviders. this method will call destroy() on each of the registered ConfigurationProviders

See Also:
ContainerProvider.destroy()

clearContainerProviders

public void clearContainerProviders()

destroyConfiguration

public void destroyConfiguration()
Destroy its managing Configuration instance

conditionalReload

public void conditionalReload()
Reloads the Configuration files if the configuration files indicate that they need to be reloaded.

reload

public void reload()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConfigurationProvider (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config
Interface ConfigurationProvider

All Superinterfaces:
ContainerProvider, PackageProvider
All Known Implementing Classes:
StubConfigurationProvider, XmlConfigurationProvider, XWorkConfigurationProvider
public interface ConfigurationProvider
extends ContainerProvider, PackageProvider

Interface to be implemented by all forms of XWork configuration classes.

Method Summary
Methods inherited from interface com.opensymphony.xwork2.config.ContainerProvider
destroy, init, needsReload, register
Methods inherited from interface com.opensymphony.xwork2.config.PackageProvider
init, loadPackages, needsReload

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConfigurationUtil (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config
Class ConfigurationUtil

java.lang.Object
    extended by  com.opensymphony.xwork2.config.ConfigurationUtil

public class ConfigurationUtil
extends Object

ConfigurationUtil

Author:
Jason Carreira Created May 23, 2003 11:22:49 PM

Method Summary
static List<PackageConfig> buildParentsFromString(Configuration configuration, String parent)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

buildParentsFromString

public static List<PackageConfig> buildParentsFromString(Configuration configuration,
                                                         String parent)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContainerProvider (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config
Interface ContainerProvider

All Known Subinterfaces:
ConfigurationProvider
All Known Implementing Classes:
StubConfigurationProvider, XmlConfigurationProvider, XWorkConfigurationProvider
public interface ContainerProvider

Provides beans and constants/properties for the Container

Since:
2.1

Method Summary
void | destroy() Called before removed from the configuration manager
void | init(Configuration configuration) Initializes with the configuration
boolean | needsReload() Tells whether the ContainerProvider should reload its configuration
void | register(ContainerBuilder builder, LocatableProperties props) Registers beans and properties for the Container

Method Detail

destroy

void destroy()
Called before removed from the configuration manager

init

void init(Configuration configuration)
          throws ConfigurationException
Initializes with the configuration

Parameters:
configuration - The configuration
Throws:
ConfigurationException - If anything goes wrong

needsReload

boolean needsReload()
Tells whether the ContainerProvider should reload its configuration

Returns:
true, whether the ContainerProvider should reload its configuration, falseotherwise.

register

void register(ContainerBuilder builder,
              LocatableProperties props)
              throws ConfigurationException
Registers beans and properties for the Container

Parameters:
builder - The builder to register beans with
props - The properties to register constants with
Throws:
ConfigurationException - If anything goes wrong
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.config (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.config
Interfaces
Configuration
ConfigurationProvider
ContainerProvider
PackageProvider
RuntimeConfiguration
Classes
ConfigurationManager
ConfigurationUtil
Exceptions
ConfigurationException
ReferenceResolverException


com.opensymphony.xwork2.config (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.config

Configuration core classes.

See:
Description

Interface Summary
Configuration | XWork configuration.
ConfigurationProvider | Interface to be implemented by all forms of XWork configuration classes.
ContainerProvider | Provides beans and constants/properties for the Container
PackageProvider | Provides configuration packages.
RuntimeConfiguration | RuntimeConfiguration

Class Summary
ConfigurationManager | ConfigurationManager - central for XWork Configuration management, including its ConfigurationProvider.
ConfigurationUtil | ConfigurationUtil

Exception Summary
ConfigurationException | ConfigurationException
ReferenceResolverException | Exception when a reference can't be resolved.

Package com.opensymphony.xwork2.config Description

Configuration core classes.

Overview Package Class Use Tree Deprecated Index Help


com.opensymphony.xwork2.config Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.config

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.config.ConfigurationManager
    • com.opensymphony.xwork2.config.ConfigurationUtil
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.opensymphony.xwork2.XWorkException (implements com.opensymphony.xwork2.util.location.Locatable)
            • com.opensymphony.xwork2.config.ConfigurationException
            • com.opensymphony.xwork2.config.ReferenceResolverException

Interface Hierarchy

  • com.opensymphony.xwork2.config.ContainerProvider
    • com.opensymphony.xwork2.config.ConfigurationProvider (also extends com.opensymphony.xwork2.config.PackageProvider)
  • com.opensymphony.xwork2.config.PackageProvider
    • com.opensymphony.xwork2.config.ConfigurationProvider (also extends com.opensymphony.xwork2.config.ContainerProvider)
  • java.io.Serializable
    • com.opensymphony.xwork2.config.Configuration
    • com.opensymphony.xwork2.config.RuntimeConfiguration


Uses of Package com.opensymphony.xwork2.config (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.config

Packages that use com.opensymphony.xwork2.config
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.test |
com.opensymphony.xwork2.util | XWork util classes.

Classes in com.opensymphony.xwork2.config used by com.opensymphony.xwork2
Configuration
XWork configuration.
ConfigurationException
ConfigurationException
ConfigurationManager
ConfigurationManager - central for XWork Configuration management, including its ConfigurationProvider.
ConfigurationProvider
Interface to be implemented by all forms of XWork configuration classes.

Classes in com.opensymphony.xwork2.config used by com.opensymphony.xwork2.config
Configuration
XWork configuration.
ConfigurationException
ConfigurationException
ConfigurationProvider
Interface to be implemented by all forms of XWork configuration classes.
ContainerProvider
Provides beans and constants/properties for the Container
PackageProvider
Provides configuration packages.
RuntimeConfiguration
RuntimeConfiguration

Classes in com.opensymphony.xwork2.config used by com.opensymphony.xwork2.config.impl
Configuration
XWork configuration.
ConfigurationException
ConfigurationException
ConfigurationProvider
Interface to be implemented by all forms of XWork configuration classes.
ContainerProvider
Provides beans and constants/properties for the Container
PackageProvider
Provides configuration packages.
RuntimeConfiguration
RuntimeConfiguration

Classes in com.opensymphony.xwork2.config used by com.opensymphony.xwork2.config.providers
Configuration
XWork configuration.
ConfigurationException
ConfigurationException
ConfigurationProvider
Interface to be implemented by all forms of XWork configuration classes.
ContainerProvider
Provides beans and constants/properties for the Container
PackageProvider
Provides configuration packages.

Classes in com.opensymphony.xwork2.config used by com.opensymphony.xwork2.test
Configuration
XWork configuration.
ConfigurationException
ConfigurationException
ConfigurationProvider
Interface to be implemented by all forms of XWork configuration classes.
ContainerProvider
Provides beans and constants/properties for the Container
PackageProvider
Provides configuration packages.

Classes in com.opensymphony.xwork2.config used by com.opensymphony.xwork2.util
ConfigurationManager
ConfigurationManager - central for XWork Configuration management, including its ConfigurationProvider.
ConfigurationProvider
Interface to be implemented by all forms of XWork configuration classes.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PackageProvider (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config
Interface PackageProvider

All Known Subinterfaces:
ConfigurationProvider
All Known Implementing Classes:
StubConfigurationProvider, XmlConfigurationProvider, XWorkConfigurationProvider
public interface PackageProvider

Provides configuration packages. The separate init and loadPackages calls are due to the need to preserve backwards compatibility with the 2.0 ConfigurationProvider interface

Since:
2.1

Method Summary
void | init(Configuration configuration) Initializes with the configuration
void | loadPackages() Loads the packages for the configuration.
boolean | needsReload() Tells whether the PackageProvider should reload its configuration

Method Detail

init

void init(Configuration configuration)
          throws ConfigurationException
Initializes with the configuration

Parameters:
configuration - The configuration
Throws:
ConfigurationException - If anything goes wrong

needsReload

boolean needsReload()
Tells whether the PackageProvider should reload its configuration

Returns:
true, whether the PackageProvider should reload its configuration, falseotherwise.

loadPackages

void loadPackages()
                  throws ConfigurationException
Loads the packages for the configuration.

Throws:
ConfigurationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReferenceResolverException (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config
Class ReferenceResolverException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  com.opensymphony.xwork2.XWorkException
                    extended by  com.opensymphony.xwork2.config.ReferenceResolverException
All Implemented Interfaces:
Locatable, Serializable
public class ReferenceResolverException
extends XWorkException

Exception when a reference can't be resolved.

Author:
Mike
See Also:
Serialized Form

Constructor Summary
ReferenceResolverException()
ReferenceResolverException(String s)
ReferenceResolverException(String s, Throwable cause)
ReferenceResolverException(Throwable cause)
Method Summary
Methods inherited from class com.opensymphony.xwork2.XWorkException
getLocation, getThrowable, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ReferenceResolverException

public ReferenceResolverException()

ReferenceResolverException

public ReferenceResolverException(String s)

ReferenceResolverException

public ReferenceResolverException(String s,
                                  Throwable cause)

ReferenceResolverException

public ReferenceResolverException(Throwable cause)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RuntimeConfiguration (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config
Interface RuntimeConfiguration

All Superinterfaces:
Serializable
public interface RuntimeConfiguration
extends Serializable

RuntimeConfiguration

Author:
Jason Carreira Created Feb 25, 2003 10:56:02 PM

Method Summary
ActionConfig | getActionConfig(String namespace, String name) get the fully expanded ActionConfig for a specified namespace and (action) name
Map<String,Map<String,ActionConfig>> | getActionConfigs() returns a Map of all the registered ActionConfigs.

Method Detail

getActionConfig

ActionConfig getActionConfig(String namespace,
                             String name)
get the fully expanded ActionConfig for a specified namespace and (action) name

Parameters:
namespace - the namespace of the Action. if this is null, then the empty namespace, "", will be used
name - the name of the Action. may not be null.
Returns:
the requested ActionConfig or null if there was no ActionConfig associated with the specified namespace and name

getActionConfigs

Map<String,Map<String,ActionConfig>> getActionConfigs()
returns a Map of all the registered ActionConfigs. Again, these ActionConfigs are fully expanded so that any inherited interceptors, results, etc. will be included

Returns:
a Map of Map keyed by namespace and name respectively such that
                 ActionConfig config = (ActionConfig)((Map)getActionConfigs.get(namespace)).get(name);
should return a valid config for valid namespace/name pairs
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.opensymphony.xwork2.config.Configuration (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.config.Configuration

Packages that use Configuration
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.test |

Uses of Configuration in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as Configuration
protected Configuration | XWorkTestCase.configuration
protected Configuration | TestNGXWorkTestCase.configuration
protected Configuration | DefaultActionProxy.configuration

Methods in com.opensymphony.xwork2 with parameters of type Configuration
void | DefaultUnknownHandlerManager.setConfiguration(Configuration configuration)
void | DefaultActionProxy.setConfiguration(Configuration config)
void | DefaultActionInvocation.setConfiguration(Configuration configuration)

Uses of Configuration in com.opensymphony.xwork2.config

Fields in com.opensymphony.xwork2.config declared as Configuration
protected  Configuration ConfigurationManager.configuration

Methods in com.opensymphony.xwork2.config that return Configuration
 Configuration ConfigurationManager.getConfiguration()
Get the current XWork configuration object.

Methods in com.opensymphony.xwork2.config with parameters of type Configuration
static List<PackageConfig> | ConfigurationUtil.buildParentsFromString(Configuration configuration, String parent)
void | PackageProvider.init(Configuration configuration) Initializes with the configuration
void | ContainerProvider.init(Configuration configuration) Initializes with the configuration
void | ConfigurationManager.setConfiguration(Configuration configuration)

Uses of Configuration in com.opensymphony.xwork2.config.impl

Classes in com.opensymphony.xwork2.config.impl that implement Configuration
class | DefaultConfiguration DefaultConfiguration
class | MockConfiguration Simple configuration used for unit testing

Uses of Configuration in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers with parameters of type Configuration
void | XWorkConfigurationProvider.init(Configuration configuration)
void | XmlConfigurationProvider.init(Configuration configuration)

Uses of Configuration in com.opensymphony.xwork2.test

Methods in com.opensymphony.xwork2.test with parameters of type Configuration
 void StubConfigurationProvider.init(Configuration configuration)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.ConfigurationException (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.ConfigurationException

Packages that use ConfigurationException
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.test |

Uses of ConfigurationException in com.opensymphony.xwork2

Methods in com.opensymphony.xwork2 that throw ConfigurationException
 Interceptor ObjectFactory.buildInterceptor(InterceptorConfig interceptorConfig, Map<String,String> interceptorRefParams)
Builds an Interceptor from the InterceptorConfig and the Map of parameters from the interceptor reference.

Uses of ConfigurationException in com.opensymphony.xwork2.config

Methods in com.opensymphony.xwork2.config that throw ConfigurationException
void | PackageProvider.init(Configuration configuration) Initializes with the configuration
void | ContainerProvider.init(Configuration configuration) Initializes with the configuration
void | PackageProvider.loadPackages() Loads the packages for the configuration.
void | ContainerProvider.register(ContainerBuilder builder, LocatableProperties props) Registers beans and properties for the Container
void | Configuration.reload(List<ConfigurationProvider> providers) Deprecated. Since 2.1
List<PackageProvider> | Configuration.reloadContainer(List<ContainerProvider> containerProviders)

Uses of ConfigurationException in com.opensymphony.xwork2.config.impl

Methods in com.opensymphony.xwork2.config.impl that throw ConfigurationException
protected  RuntimeConfiguration DefaultConfiguration.buildRuntimeConfiguration()
This builds the internal runtime configuration used by Xwork for finding and configuring Actions from the programmatic configuration data structures.
 void MockConfiguration.reload(List<ConfigurationProvider> providers)
 void DefaultConfiguration.reload(List<ConfigurationProvider> providers)
Calls the ConfigurationProviderFactory.getConfig() to tell it to reload the configuration and then calls buildRuntimeConfiguration().
 List<PackageProvider> MockConfiguration.reloadContainer(List<ContainerProvider> containerProviders)
 List<PackageProvider> DefaultConfiguration.reloadContainer(List<ContainerProvider> providers)
Calls the ConfigurationProviderFactory.getConfig() to tell it to reload the configuration and then calls buildRuntimeConfiguration().

Uses of ConfigurationException in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers that throw ConfigurationException
protected void | XmlConfigurationProvider.addAction(Element actionElement, PackageConfig.Builder packageContext)
protected PackageConfig | XmlConfigurationProvider.addPackage(Element packageElement) Create a PackageConfig from an XML element representing it.
protected List<InterceptorMapping> | XmlConfigurationProvider.buildInterceptorList(Element element, PackageConfig.Builder context)
static List<InterceptorMapping> | InterceptorBuilder.constructInterceptorReference(InterceptorLocator interceptorLocator, String refName, Map<String,String> refParams, Location location, ObjectFactory objectFactory) Builds a list of interceptors referenced by the refName in the supplied PackageConfig (InterceptorMapping object).
void | XWorkConfigurationProvider.init(Configuration configuration)
protected void | XmlConfigurationProvider.loadInterceptors(PackageConfig.Builder context, Element element)
protected InterceptorStackConfig | XmlConfigurationProvider.loadInterceptorStack(Element element, PackageConfig.Builder context)
protected void | XmlConfigurationProvider.loadInterceptorStacks(Element element, PackageConfig.Builder context)
void | XWorkConfigurationProvider.loadPackages()
void | XmlConfigurationProvider.loadPackages()
void | XWorkConfigurationProvider.register(ContainerBuilder builder, LocatableProperties props)
void | XmlConfigurationProvider.register(ContainerBuilder containerBuilder, LocatableProperties props)

Uses of ConfigurationException in com.opensymphony.xwork2.test

Methods in com.opensymphony.xwork2.test that throw ConfigurationException
void | StubConfigurationProvider.init(Configuration configuration)
void | StubConfigurationProvider.loadPackages()
void | StubConfigurationProvider.register(ContainerBuilder builder, LocatableProperties props)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.ConfigurationManager (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.ConfigurationManager

Packages that use ConfigurationManager
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.util | XWork util classes.

Uses of ConfigurationManager in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as ConfigurationManager
protected ConfigurationManager | XWorkTestCase.configurationManager
protected ConfigurationManager | TestNGXWorkTestCase.configurationManager

Constructors in com.opensymphony.xwork2 with parameters of type ConfigurationManager
XWork(ConfigurationManager mgr)

Uses of ConfigurationManager in com.opensymphony.xwork2.util

Methods in com.opensymphony.xwork2.util that return ConfigurationManager
static ConfigurationManager | XWorkTestCaseHelper.loadConfigurationProviders(ConfigurationManager configurationManager, ConfigurationProvider... providers)
static ConfigurationManager | XWorkTestCaseHelper.setUp()

Methods in com.opensymphony.xwork2.util with parameters of type ConfigurationManager
static ConfigurationManager | XWorkTestCaseHelper.loadConfigurationProviders(ConfigurationManager configurationManager, ConfigurationProvider... providers)
static void | XWorkTestCaseHelper.tearDown(ConfigurationManager configurationManager)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.config.ConfigurationProvider (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.config.ConfigurationProvider

Packages that use ConfigurationProvider
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.test |
com.opensymphony.xwork2.util | XWork util classes.

Uses of ConfigurationProvider in com.opensymphony.xwork2

Methods in com.opensymphony.xwork2 with parameters of type ConfigurationProvider
protected void | XWorkTestCase.loadConfigurationProviders(ConfigurationProvider... providers)
protected void | TestNGXWorkTestCase.loadConfigurationProviders(ConfigurationProvider... providers)

Uses of ConfigurationProvider in com.opensymphony.xwork2.config

Methods in com.opensymphony.xwork2.config that return types with arguments of type ConfigurationProvider
 List<ConfigurationProvider> ConfigurationManager.getConfigurationProviders()
Deprecated. Since 2.1, use ConfigurationManager.getContainerProviders()

Methods in com.opensymphony.xwork2.config with parameters of type ConfigurationProvider
 void ConfigurationManager.addConfigurationProvider(ConfigurationProvider provider)
Deprecated. Since 2.1, use #addContainerProvider()

Method parameters in com.opensymphony.xwork2.config with type arguments of type ConfigurationProvider
 void Configuration.reload(List<ConfigurationProvider> providers)
Deprecated. Since 2.1
 void ConfigurationManager.setConfigurationProviders(List<ConfigurationProvider> configurationProviders)
Deprecated. Since 2.1, use #setContainerProvider()

Uses of ConfigurationProvider in com.opensymphony.xwork2.config.impl

Method parameters in com.opensymphony.xwork2.config.impl with type arguments of type ConfigurationProvider
 void MockConfiguration.reload(List<ConfigurationProvider> providers)
 void DefaultConfiguration.reload(List<ConfigurationProvider> providers)
Calls the ConfigurationProviderFactory.getConfig() to tell it to reload the configuration and then calls buildRuntimeConfiguration().

Uses of ConfigurationProvider in com.opensymphony.xwork2.config.providers

Classes in com.opensymphony.xwork2.config.providers that implement ConfigurationProvider
class | XmlConfigurationProvider Looks in the classpath for an XML file, "xwork.xml" by default, and uses it for the XWork configuration.
class | XWorkConfigurationProvider

Uses of ConfigurationProvider in com.opensymphony.xwork2.test

Classes in com.opensymphony.xwork2.test that implement ConfigurationProvider
 class StubConfigurationProvider

Uses of ConfigurationProvider in com.opensymphony.xwork2.util

Methods in com.opensymphony.xwork2.util with parameters of type ConfigurationProvider
static ConfigurationManager XWorkTestCaseHelper.loadConfigurationProviders(ConfigurationManager configurationManager, ConfigurationProvider... providers)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.ConfigurationUtil (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.ConfigurationUtil

No usage of com.opensymphony.xwork2.config.ConfigurationUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.config.ContainerProvider (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.config.ContainerProvider

Packages that use ContainerProvider
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.test |

Uses of ContainerProvider in com.opensymphony.xwork2.config

Subinterfaces of ContainerProvider in com.opensymphony.xwork2.config
 interface ConfigurationProvider
Interface to be implemented by all forms of XWork configuration classes.

Methods in com.opensymphony.xwork2.config that return types with arguments of type ContainerProvider
 List<ContainerProvider> ConfigurationManager.getContainerProviders()
Get the current list of ConfigurationProviders.

Methods in com.opensymphony.xwork2.config with parameters of type ContainerProvider
 void ConfigurationManager.addContainerProvider(ContainerProvider provider)
adds a configuration provider to the List of ConfigurationProviders.

Method parameters in com.opensymphony.xwork2.config with type arguments of type ContainerProvider
List<PackageProvider> | Configuration.reloadContainer(List<ContainerProvider> containerProviders)
void | ConfigurationManager.setContainerProviders(List<ContainerProvider> containerProviders) Set the list of configuration providers

Uses of ContainerProvider in com.opensymphony.xwork2.config.impl

Method parameters in com.opensymphony.xwork2.config.impl with type arguments of type ContainerProvider
 List<PackageProvider> MockConfiguration.reloadContainer(List<ContainerProvider> containerProviders)
 List<PackageProvider> DefaultConfiguration.reloadContainer(List<ContainerProvider> providers)
Calls the ConfigurationProviderFactory.getConfig() to tell it to reload the configuration and then calls buildRuntimeConfiguration().

Uses of ContainerProvider in com.opensymphony.xwork2.config.providers

Classes in com.opensymphony.xwork2.config.providers that implement ContainerProvider
class | XmlConfigurationProvider Looks in the classpath for an XML file, "xwork.xml" by default, and uses it for the XWork configuration.
class | XWorkConfigurationProvider

Uses of ContainerProvider in com.opensymphony.xwork2.test

Classes in com.opensymphony.xwork2.test that implement ContainerProvider
 class StubConfigurationProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.config.PackageProvider (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.config.PackageProvider

Packages that use PackageProvider
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.test |

Uses of PackageProvider in com.opensymphony.xwork2.config

Subinterfaces of PackageProvider in com.opensymphony.xwork2.config
 interface ConfigurationProvider
Interface to be implemented by all forms of XWork configuration classes.

Methods in com.opensymphony.xwork2.config that return types with arguments of type PackageProvider
 List<PackageProvider> Configuration.reloadContainer(List<ContainerProvider> containerProviders)

Uses of PackageProvider in com.opensymphony.xwork2.config.impl

Methods in com.opensymphony.xwork2.config.impl that return types with arguments of type PackageProvider
 List<PackageProvider> MockConfiguration.reloadContainer(List<ContainerProvider> containerProviders)
 List<PackageProvider> DefaultConfiguration.reloadContainer(List<ContainerProvider> providers)
Calls the ConfigurationProviderFactory.getConfig() to tell it to reload the configuration and then calls buildRuntimeConfiguration().

Uses of PackageProvider in com.opensymphony.xwork2.config.providers

Classes in com.opensymphony.xwork2.config.providers that implement PackageProvider
class | XmlConfigurationProvider Looks in the classpath for an XML file, "xwork.xml" by default, and uses it for the XWork configuration.
class | XWorkConfigurationProvider

Uses of PackageProvider in com.opensymphony.xwork2.test

Classes in com.opensymphony.xwork2.test that implement PackageProvider
 class StubConfigurationProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.ReferenceResolverException (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.ReferenceResolverException

No usage of com.opensymphony.xwork2.config.ReferenceResolverException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.config.RuntimeConfiguration (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.config.RuntimeConfiguration

Packages that use RuntimeConfiguration
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.

Uses of RuntimeConfiguration in com.opensymphony.xwork2.config

Methods in com.opensymphony.xwork2.config that return RuntimeConfiguration
 RuntimeConfiguration Configuration.getRuntimeConfiguration()
The current runtime configuration.

Uses of RuntimeConfiguration in com.opensymphony.xwork2.config.impl

Fields in com.opensymphony.xwork2.config.impl declared as RuntimeConfiguration
protected  RuntimeConfiguration DefaultConfiguration.runtimeConfiguration

Methods in com.opensymphony.xwork2.config.impl that return RuntimeConfiguration
protected RuntimeConfiguration | DefaultConfiguration.buildRuntimeConfiguration() This builds the internal runtime configuration used by Xwork for finding and configuring Actions from the programmatic configuration data structures.
RuntimeConfiguration | MockConfiguration.getRuntimeConfiguration()
RuntimeConfiguration | DefaultConfiguration.getRuntimeConfiguration()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ActionConfig (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class ActionConfig

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.config.entities.ActionConfig
All Implemented Interfaces:
Locatable, Serializable
public class ActionConfig
extends Located
implements Serializable

Contains everything needed to configure and execute an action:

  • methodName - the method name to execute on the action. If this is null, the Action will be cast to the Action Interface and the execute() method called
  • clazz - the class name for the action
  • params - the params to be set for this action just before execution
  • results - the result map {String -> View class}
  • resultParameters - params for results {String -> Map}
  • typeConverter - the Ognl TypeConverter to use when getting/setting properties

Version:
$Revision: 1947 $
Author:
Mike, Rainer Hermanns
See Also:
Serialized Form

Nested Class Summary
static class ActionConfig.Builder
The builder for this object.
Field Summary
protected Set<String> | allowedMethods
protected String | className
protected List<ExceptionMappingConfig> | exceptionMappings
protected List<InterceptorMapping> | interceptors
protected String | methodName
protected String | name
protected String | packageName
protected Map<String,String> | params
protected Map<String,ResultConfig> | results
static String | WILDCARD
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
protected | ActionConfig(ActionConfig orig) Clones an ActionConfig, copying data into new maps and lists
protected | ActionConfig(String packageName, String name, String className)
Method Summary
boolean | equals(Object o)
Set<String> | getAllowedMethods()
String | getClassName()
List<ExceptionMappingConfig> | getExceptionMappings()
List<InterceptorMapping> | getInterceptors()
String | getMethodName() Returns name of the action method
String | getName()
String | getPackageName()
Map<String,String> | getParams()
Map<String,ResultConfig> | getResults()
int | hashCode()
boolean | isAllowedMethod(String method)
String | toString()
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

WILDCARD

public static final String WILDCARD
See Also:
Constant Field Values

interceptors

protected List<InterceptorMapping> interceptors

params

protected Map<String,String> params

results

protected Map<String,ResultConfig> results

exceptionMappings

protected List<ExceptionMappingConfig> exceptionMappings

className

protected String className

methodName

protected String methodName

packageName

protected String packageName

name

protected String name

allowedMethods

protected Set<String> allowedMethods
Constructor Detail

ActionConfig

protected ActionConfig(String packageName,
                       String name,
                       String className)

ActionConfig

protected ActionConfig(ActionConfig orig)
Clones an ActionConfig, copying data into new maps and lists

Parameters:
orig - The ActionConfig to clone
Method Detail

getName

public String getName()

getClassName

public String getClassName()

getExceptionMappings

public List<ExceptionMappingConfig> getExceptionMappings()

getInterceptors

public List<InterceptorMapping> getInterceptors()

getAllowedMethods

public Set<String> getAllowedMethods()

getMethodName

public String getMethodName()
Returns name of the action method

Returns:
name of the method to execute

getPackageName

public String getPackageName()
Returns:
Returns the packageName.

getParams

public Map<String,String> getParams()

getResults

public Map<String,ResultConfig> getResults()

isAllowedMethod

public boolean isAllowedMethod(String method)

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ActionConfig.Builder (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class ActionConfig.Builder

java.lang.Object
    extended by  com.opensymphony.xwork2.config.entities.ActionConfig.Builder
All Implemented Interfaces:
InterceptorListHolder
Enclosing class:
ActionConfig
public static class ActionConfig.Builder
extends Object
implements InterceptorListHolder

The builder for this object. An instance of this object is the only way to construct a new instance. The purpose is to enforce the immutability of the object. The methods are structured in a way to support chaining. After setting any values you need, call the build() method to create the object.

Constructor Summary
ActionConfig.Builder(ActionConfig toClone)
ActionConfig.Builder(String packageName, String name, String className)
Method Summary
ActionConfig.Builder | addAllowedMethod(Collection<String> methods)
ActionConfig.Builder | addAllowedMethod(String methodName)
ActionConfig.Builder | addExceptionMapping(ExceptionMappingConfig exceptionMapping)
ActionConfig.Builder | addExceptionMappings(Collection<? extends ExceptionMappingConfig> mappings)
ActionConfig.Builder | addInterceptor(InterceptorMapping interceptor)
ActionConfig.Builder | addInterceptors(List<InterceptorMapping> interceptors)
ActionConfig.Builder | addParam(String name, String value)
ActionConfig.Builder | addParams(Map<String,String> params)
ActionConfig.Builder | addResultConfig(ResultConfig resultConfig)
ActionConfig.Builder | addResultConfigs(Collection<ResultConfig> configs)
ActionConfig.Builder | addResultConfigs(Map<String,ResultConfig> configs)
ActionConfig | build()
ActionConfig.Builder | className(String name)
ActionConfig.Builder | defaultClassName(String name)
ActionConfig.Builder | exceptionMappings(Collection<? extends ExceptionMappingConfig> mappings)
ActionConfig.Builder | interceptors(List<InterceptorMapping> interceptors)
ActionConfig.Builder | location(Location loc)
ActionConfig.Builder | methodName(String method)
ActionConfig.Builder | name(String name)
ActionConfig.Builder | packageName(String name)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ActionConfig.Builder

public ActionConfig.Builder(ActionConfig toClone)

ActionConfig.Builder

public ActionConfig.Builder(String packageName,
                            String name,
                            String className)
Method Detail

packageName

public ActionConfig.Builder packageName(String name)

name

public ActionConfig.Builder name(String name)

className

public ActionConfig.Builder className(String name)

defaultClassName

public ActionConfig.Builder defaultClassName(String name)

methodName

public ActionConfig.Builder methodName(String method)

addExceptionMapping

public ActionConfig.Builder addExceptionMapping(ExceptionMappingConfig exceptionMapping)

addExceptionMappings

public ActionConfig.Builder addExceptionMappings(Collection<? extends ExceptionMappingConfig> mappings)

exceptionMappings

public ActionConfig.Builder exceptionMappings(Collection<? extends ExceptionMappingConfig> mappings)

addInterceptor

public ActionConfig.Builder addInterceptor(InterceptorMapping interceptor)
Specified by:
addInterceptor in interface InterceptorListHolder

addInterceptors

public ActionConfig.Builder addInterceptors(List<InterceptorMapping> interceptors)
Specified by:
addInterceptors in interface InterceptorListHolder

interceptors

public ActionConfig.Builder interceptors(List<InterceptorMapping> interceptors)

addParam

public ActionConfig.Builder addParam(String name,
                                     String value)

addParams

public ActionConfig.Builder addParams(Map<String,String> params)

addResultConfig

public ActionConfig.Builder addResultConfig(ResultConfig resultConfig)

addResultConfigs

public ActionConfig.Builder addResultConfigs(Collection<ResultConfig> configs)

addResultConfigs

public ActionConfig.Builder addResultConfigs(Map<String,ResultConfig> configs)

addAllowedMethod

public ActionConfig.Builder addAllowedMethod(String methodName)

addAllowedMethod

public ActionConfig.Builder addAllowedMethod(Collection<String> methods)

location

public ActionConfig.Builder location(Location loc)

build

public ActionConfig build()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExceptionMappingConfig (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class ExceptionMappingConfig

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.config.entities.ExceptionMappingConfig
All Implemented Interfaces:
Locatable, Serializable
public class ExceptionMappingConfig
extends Located
implements Serializable

Configuration for exception mapping.

Author:
Rainer Hermanns, Matthew E. Porter (matthew dot porter at metissian dot com)
See Also:
Serialized Form

Nested Class Summary
static class ExceptionMappingConfig.Builder
The builder for this object.
Field Summary
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
protected | ExceptionMappingConfig(ExceptionMappingConfig target)
protected | ExceptionMappingConfig(String name, String exceptionClassName, String result)
Method Summary
boolean | equals(Object o)
String | getExceptionClassName()
String | getName()
Map<String,String> | getParams()
String | getResult()
int | hashCode()
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExceptionMappingConfig

protected ExceptionMappingConfig(String name,
                                 String exceptionClassName,
                                 String result)

ExceptionMappingConfig

protected ExceptionMappingConfig(ExceptionMappingConfig target)
Method Detail

getName

public String getName()

getExceptionClassName

public String getExceptionClassName()

getResult

public String getResult()

getParams

public Map<String,String> getParams()

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExceptionMappingConfig.Builder (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class ExceptionMappingConfig.Builder

java.lang.Object
    extended by  com.opensymphony.xwork2.config.entities.ExceptionMappingConfig.Builder
Enclosing class:
ExceptionMappingConfig
public static class ExceptionMappingConfig.Builder
extends Object

The builder for this object. An instance of this object is the only way to construct a new instance. The purpose is to enforce the immutability of the object. The methods are structured in a way to support chaining. After setting any values you need, call the build() method to create the object.

Constructor Summary
ExceptionMappingConfig.Builder(ExceptionMappingConfig toClone)
ExceptionMappingConfig.Builder(String name, String exceptionClassName, String result)
Method Summary
ExceptionMappingConfig.Builder | addParam(String name, String value)
ExceptionMappingConfig.Builder | addParams(Map<String,String> params)
ExceptionMappingConfig | build()
ExceptionMappingConfig.Builder | exceptionClassName(String name)
ExceptionMappingConfig.Builder | location(Location loc)
ExceptionMappingConfig.Builder | name(String name)
ExceptionMappingConfig.Builder | result(String result)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExceptionMappingConfig.Builder

public ExceptionMappingConfig.Builder(ExceptionMappingConfig toClone)

ExceptionMappingConfig.Builder

public ExceptionMappingConfig.Builder(String name,
                                      String exceptionClassName,
                                      String result)
Method Detail

name

public ExceptionMappingConfig.Builder name(String name)

exceptionClassName

public ExceptionMappingConfig.Builder exceptionClassName(String name)

result

public ExceptionMappingConfig.Builder result(String result)

addParam

public ExceptionMappingConfig.Builder addParam(String name,
                                               String value)

addParams

public ExceptionMappingConfig.Builder addParams(Map<String,String> params)

location

public ExceptionMappingConfig.Builder location(Location loc)

build

public ExceptionMappingConfig build()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InterceptorConfig (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class InterceptorConfig

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.config.entities.InterceptorConfig
All Implemented Interfaces:
Locatable, Serializable
public class InterceptorConfig
extends Located
implements Serializable

Configuration for Interceptors.

In the xml configuration file this is defined as the interceptors tag.

Author:
Mike
See Also:
Serialized Form

Nested Class Summary
static class InterceptorConfig.Builder
The builder for this object.
Field Summary
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
protected | InterceptorConfig(InterceptorConfig orig)
protected | InterceptorConfig(String name, String className)
Method Summary
boolean | equals(Object o)
String | getClassName()
String | getName()
Map<String,String> | getParams()
int | hashCode()
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InterceptorConfig

protected InterceptorConfig(String name,
                            String className)

InterceptorConfig

protected InterceptorConfig(InterceptorConfig orig)
Method Detail

getClassName

public String getClassName()

getName

public String getName()

getParams

public Map<String,String> getParams()

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InterceptorConfig.Builder (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class InterceptorConfig.Builder

java.lang.Object
    extended by  com.opensymphony.xwork2.config.entities.InterceptorConfig.Builder
Enclosing class:
InterceptorConfig
public static final class InterceptorConfig.Builder
extends Object

The builder for this object. An instance of this object is the only way to construct a new instance. The purpose is to enforce the immutability of the object. The methods are structured in a way to support chaining. After setting any values you need, call the build() method to create the object.

Constructor Summary
InterceptorConfig.Builder(InterceptorConfig orig)
InterceptorConfig.Builder(String name, String className)
Method Summary
InterceptorConfig.Builder | addParam(String name, String value)
InterceptorConfig.Builder | addParams(Map<String,String> params)
InterceptorConfig | build()
InterceptorConfig.Builder | className(String name)
InterceptorConfig.Builder | location(Location loc)
InterceptorConfig.Builder | name(String name)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InterceptorConfig.Builder

public InterceptorConfig.Builder(String name,
                                 String className)

InterceptorConfig.Builder

public InterceptorConfig.Builder(InterceptorConfig orig)
Method Detail

name

public InterceptorConfig.Builder name(String name)

className

public InterceptorConfig.Builder className(String name)

addParam

public InterceptorConfig.Builder addParam(String name,
                                          String value)

addParams

public InterceptorConfig.Builder addParams(Map<String,String> params)

location

public InterceptorConfig.Builder location(Location loc)

build

public InterceptorConfig build()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InterceptorListHolder (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Interface InterceptorListHolder

All Known Implementing Classes:
ActionConfig.Builder, InterceptorStackConfig.Builder
public interface InterceptorListHolder

InterceptorListHolder

Author:
Jason Carreira Created Jun 1, 2003 1:02:48 AM

Method Summary
InterceptorListHolder | addInterceptor(InterceptorMapping interceptor)
InterceptorListHolder | addInterceptors(List<InterceptorMapping> interceptors)

Method Detail

addInterceptor

InterceptorListHolder addInterceptor(InterceptorMapping interceptor)

addInterceptors

InterceptorListHolder addInterceptors(List<InterceptorMapping> interceptors)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InterceptorLocator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Interface InterceptorLocator

All Known Implementing Classes:
PackageConfig, PackageConfig.Builder
public interface InterceptorLocator

Defines an object that can be used to retrieve interceptor configuration

Method Summary
 Object getInterceptorConfig(String name)
Gets an interceptor configuration object.

Method Detail

getInterceptorConfig

Object getInterceptorConfig(String name)
Gets an interceptor configuration object.

Parameters:
name - The interceptor or interceptor stack name
Returns:
Either an InterceptorConfig or InterceptorStackConfig object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InterceptorMapping (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class InterceptorMapping

java.lang.Object
    extended by  com.opensymphony.xwork2.config.entities.InterceptorMapping
All Implemented Interfaces:
Serializable
public class InterceptorMapping
extends Object
implements Serializable

InterceptorMapping

Version:
$Id: InterceptorMapping.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns
See Also:
Serialized Form

Constructor Summary
InterceptorMapping(String name, Interceptor interceptor)
Method Summary
boolean | equals(Object o)
Interceptor | getInterceptor()
String | getName()
int | hashCode()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InterceptorMapping

public InterceptorMapping(String name,
                          Interceptor interceptor)
Method Detail

getName

public String getName()

getInterceptor

public Interceptor getInterceptor()

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InterceptorStackConfig (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class InterceptorStackConfig

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.config.entities.InterceptorStackConfig
All Implemented Interfaces:
Locatable, Serializable
public class InterceptorStackConfig
extends Located
implements Serializable

Configuration for InterceptorStack.

In the xml configuration file this is defined as the interceptor-stack tag.

Author:
Mike, Rainer Hermanns
See Also:
Serialized Form

Nested Class Summary
static class InterceptorStackConfig.Builder
The builder for this object.
Field Summary
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
protected | InterceptorStackConfig() Creates an InterceptorStackConfig object.
protected | InterceptorStackConfig(InterceptorStackConfig orig) Creates an InterceptorStackConfig object with a particular name.
Method Summary
boolean | equals(Object o) An InterceptorStackConfig object is equals with o only if o is an InterceptorStackConfig object both names are equals all of their InterceptorMappings are equals
Collection<InterceptorMapping> | getInterceptors() Returns a Collection of InterceptorMapping objects.
String | getName() Get the name of this interceptor stack configuration.
int | hashCode() Generate hashcode based on InterceptorStackConfig's name and its InterceptorMappings.
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InterceptorStackConfig

protected InterceptorStackConfig()
Creates an InterceptorStackConfig object.

InterceptorStackConfig

protected InterceptorStackConfig(InterceptorStackConfig orig)
Creates an InterceptorStackConfig object with a particular name.

Parameters:
name -
Method Detail

getInterceptors

public Collection<InterceptorMapping> getInterceptors()
Returns a Collection of InterceptorMapping objects.

Returns:

getName

public String getName()
Get the name of this interceptor stack configuration.

Returns:
String

equals

public boolean equals(Object o)
An InterceptorStackConfig object is equals with o only if
  • o is an InterceptorStackConfig object
  • both names are equals
  • all of their InterceptorMappings are equals

Overrides:
equals in class Object

hashCode

public int hashCode()
Generate hashcode based on InterceptorStackConfig's name and its InterceptorMappings.

Overrides:
hashCode in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InterceptorStackConfig.Builder (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class InterceptorStackConfig.Builder

java.lang.Object
    extended by  com.opensymphony.xwork2.config.entities.InterceptorStackConfig.Builder
All Implemented Interfaces:
InterceptorListHolder
Enclosing class:
InterceptorStackConfig
public static class InterceptorStackConfig.Builder
extends Object
implements InterceptorListHolder

The builder for this object. An instance of this object is the only way to construct a new instance. The purpose is to enforce the immutability of the object. The methods are structured in a way to support chaining. After setting any values you need, call the build() method to create the object.

Constructor Summary
InterceptorStackConfig.Builder(String name)
Method Summary
InterceptorStackConfig.Builder | addInterceptor(InterceptorMapping interceptor) Add an InterceptorMapping object.
InterceptorStackConfig.Builder | addInterceptors(List<InterceptorMapping> interceptors) Add a List of InterceptorMapping objects.
InterceptorStackConfig | build()
InterceptorStackConfig.Builder | location(Location loc)
InterceptorStackConfig.Builder | name(String name)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InterceptorStackConfig.Builder

public InterceptorStackConfig.Builder(String name)
Method Detail

name

public InterceptorStackConfig.Builder name(String name)

addInterceptor

public InterceptorStackConfig.Builder addInterceptor(InterceptorMapping interceptor)
Add an InterceptorMapping object.

Specified by:
addInterceptor in interface InterceptorListHolder

addInterceptors

public InterceptorStackConfig.Builder addInterceptors(List<InterceptorMapping> interceptors)
Add a List of InterceptorMapping objects.

Specified by:
addInterceptors in interface InterceptorListHolder

location

public InterceptorStackConfig.Builder location(Location loc)

build

public InterceptorStackConfig build()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.config.entities (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.config.entities
Interfaces
InterceptorListHolder
InterceptorLocator
Parameterizable
Classes
ActionConfig
ActionConfig.Builder
ExceptionMappingConfig
ExceptionMappingConfig.Builder
InterceptorConfig
InterceptorConfig.Builder
InterceptorMapping
InterceptorStackConfig
InterceptorStackConfig.Builder
PackageConfig
PackageConfig.Builder
ResultConfig
ResultConfig.Builder
ResultTypeConfig
ResultTypeConfig.Builder
UnknownHandlerConfig


com.opensymphony.xwork2.config.entities (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.config.entities

Configuration entity classes.

See:
Description

Interface Summary
InterceptorListHolder | InterceptorListHolder
InterceptorLocator | Defines an object that can be used to retrieve interceptor configuration
Parameterizable | Actions implementing Parameterizable will receive a map of the static parameters defined in the action configuration.

Class Summary
ActionConfig | Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.
ActionConfig.Builder | The builder for this object.
ExceptionMappingConfig | Configuration for exception mapping.
ExceptionMappingConfig.Builder | The builder for this object.
InterceptorConfig | Configuration for Interceptors.
InterceptorConfig.Builder | The builder for this object.
InterceptorMapping | InterceptorMapping
InterceptorStackConfig | Configuration for InterceptorStack.
InterceptorStackConfig.Builder | The builder for this object.
PackageConfig | Configuration for Package.
PackageConfig.Builder | The builder for this object.
ResultConfig | Configuration for Result.
ResultConfig.Builder | The builder for this object.
ResultTypeConfig | Configuration class for result types.
ResultTypeConfig.Builder | The builder for this object.
UnknownHandlerConfig |

Package com.opensymphony.xwork2.config.entities Description

Configuration entity classes. All objects ending in "Config" are immutable and must be constructed using their inner "Builder" class. For example, a PackageConfig object can be created via:

    PackageConfig config = new PackageConfig.Builder("myPackage").build();

The methods on the builder object are chainable to support constructions like this:

    ResultConfig config = new ResultConfig.Builder("success", "myapp.MyResult")
        .addParam("location", "/foo.jsp")
        .build();


com.opensymphony.xwork2.config.entities Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.config.entities

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.config.entities.ActionConfig.Builder (implements com.opensymphony.xwork2.config.entities.InterceptorListHolder)
    • com.opensymphony.xwork2.config.entities.ExceptionMappingConfig.Builder
    • com.opensymphony.xwork2.config.entities.InterceptorConfig.Builder
    • com.opensymphony.xwork2.config.entities.InterceptorMapping (implements java.io.Serializable)
    • com.opensymphony.xwork2.config.entities.InterceptorStackConfig.Builder (implements com.opensymphony.xwork2.config.entities.InterceptorListHolder)
    • com.opensymphony.xwork2.util.location.Located (implements com.opensymphony.xwork2.util.location.Locatable)
      • com.opensymphony.xwork2.config.entities.ActionConfig (implements java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.ExceptionMappingConfig (implements java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.InterceptorConfig (implements java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.InterceptorStackConfig (implements java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.PackageConfig (implements java.lang.Comparable<T>, com.opensymphony.xwork2.config.entities.InterceptorLocator, java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.ResultConfig (implements java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.ResultTypeConfig (implements java.io.Serializable)
    • com.opensymphony.xwork2.config.entities.PackageConfig.Builder (implements com.opensymphony.xwork2.config.entities.InterceptorLocator)
    • com.opensymphony.xwork2.config.entities.ResultConfig.Builder
    • com.opensymphony.xwork2.config.entities.ResultTypeConfig.Builder
    • com.opensymphony.xwork2.config.entities.UnknownHandlerConfig

Interface Hierarchy

  • com.opensymphony.xwork2.config.entities.InterceptorListHolder
  • com.opensymphony.xwork2.config.entities.InterceptorLocator
  • com.opensymphony.xwork2.config.entities.Parameterizable


Uses of Package com.opensymphony.xwork2.config.entities (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.config.entities

Packages that use com.opensymphony.xwork2.config.entities
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.mock | XWork specific mock classes.

Classes in com.opensymphony.xwork2.config.entities used by com.opensymphony.xwork2
ActionConfig
Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.
InterceptorConfig
Configuration for Interceptors.
InterceptorMapping
InterceptorMapping
ResultConfig
Configuration for Result.

Classes in com.opensymphony.xwork2.config.entities used by com.opensymphony.xwork2.config
ActionConfig
Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.
PackageConfig
Configuration for Package.
UnknownHandlerConfig

Classes in com.opensymphony.xwork2.config.entities used by com.opensymphony.xwork2.config.entities
ActionConfig
Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.
ActionConfig.Builder
The builder for this object.
ExceptionMappingConfig
Configuration for exception mapping.
ExceptionMappingConfig.Builder
The builder for this object.
InterceptorConfig
Configuration for Interceptors.
InterceptorConfig.Builder
The builder for this object.
InterceptorListHolder
InterceptorListHolder
InterceptorLocator
Defines an object that can be used to retrieve interceptor configuration
InterceptorMapping
InterceptorMapping
InterceptorStackConfig
Configuration for InterceptorStack.
InterceptorStackConfig.Builder
The builder for this object.
PackageConfig
Configuration for Package.
PackageConfig.Builder
The builder for this object.
ResultConfig
Configuration for Result.
ResultConfig.Builder
The builder for this object.
ResultTypeConfig
Configuration class for result types.
ResultTypeConfig.Builder
The builder for this object.

Classes in com.opensymphony.xwork2.config.entities used by com.opensymphony.xwork2.config.impl
ActionConfig
Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.
PackageConfig
Configuration for Package.
UnknownHandlerConfig

Classes in com.opensymphony.xwork2.config.entities used by com.opensymphony.xwork2.config.providers
ExceptionMappingConfig
Configuration for exception mapping.
InterceptorLocator
Defines an object that can be used to retrieve interceptor configuration
InterceptorMapping
InterceptorMapping
InterceptorStackConfig
Configuration for InterceptorStack.
PackageConfig
Configuration for Package.
PackageConfig.Builder
The builder for this object.
ResultConfig
Configuration for Result.

Classes in com.opensymphony.xwork2.config.entities used by com.opensymphony.xwork2.interceptor
ExceptionMappingConfig
Configuration for exception mapping.

Classes in com.opensymphony.xwork2.config.entities used by com.opensymphony.xwork2.mock
ActionConfig
Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PackageConfig (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class PackageConfig

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.config.entities.PackageConfig
All Implemented Interfaces:
InterceptorLocator, Locatable, Serializable, Comparable
public class PackageConfig
extends Located
implements Comparable, Serializable, InterceptorLocator

Configuration for Package.

In the xml configuration file this is defined as the package tag.

Version:
$Revision: 1833 $
Author:
Rainer Hermanns
See Also:
Serialized Form

Nested Class Summary
static class PackageConfig.Builder
The builder for this object.
Field Summary
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
protected | PackageConfig(PackageConfig orig)
protected | PackageConfig(String name)
Method Summary
int | compareTo(Object o)
boolean | equals(Object o)
Map<String,ActionConfig> | getActionConfigs()
Map<String,ActionConfig> | getAllActionConfigs() returns the Map of all the ActionConfigs available in the current package.
List<ExceptionMappingConfig> | getAllExceptionMappingConfigs() returns the List of all the ExceptionMappingConfigs available in the current package.
Map<String,ResultConfig> | getAllGlobalResults() returns the Map of all the global ResultConfigs available in the current package.
Map<String,Object> | getAllInterceptorConfigs() returns the Map of all InterceptorConfigs and InterceptorStackConfigs available in the current package.
Map<String,ResultTypeConfig> | getAllResultTypeConfigs() returns the Map of all the ResultTypeConfigs available in the current package.
String | getDefaultActionRef()
String | getDefaultClassRef()
String | getDefaultInterceptorRef()
String | getDefaultResultType() Returns the default result type for this package.
String | getFullDefaultActionRef() gets the default action-ref name.
String | getFullDefaultInterceptorRef() gets the default interceptor-ref name.
String | getFullDefaultResultType() Returns the default result type for this package.
List<ExceptionMappingConfig> | getGlobalExceptionMappingConfigs() gets the ExceptionMappingConfigs local to this package
Map<String,ResultConfig> | getGlobalResultConfigs() gets the global ResultConfigs local to this package
Object | getInterceptorConfig(String name) Gets an interceptor configuration object.
Map<String,Object> | getInterceptorConfigs() gets the InterceptorConfigs and InterceptorStackConfigs local to this package
String | getName()
String | getNamespace()
List<PackageConfig> | getParents()
Map<String,ResultTypeConfig> | getResultTypeConfigs() gets the ResultTypeConfigs local to this package
int | hashCode()
boolean | isAbstract()
boolean | isNeedsRefresh()
String | toString()
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

PackageConfig

protected PackageConfig(String name)

PackageConfig

protected PackageConfig(PackageConfig orig)
Method Detail

isAbstract

public boolean isAbstract()

getActionConfigs

public Map<String,ActionConfig> getActionConfigs()

getAllActionConfigs

public Map<String,ActionConfig> getAllActionConfigs()
returns the Map of all the ActionConfigs available in the current package. ActionConfigs defined in ancestor packages will be included in this Map.

Returns:
a Map of ActionConfig Objects with the action name as the key
See Also:
ActionConfig

getAllGlobalResults

public Map<String,ResultConfig> getAllGlobalResults()
returns the Map of all the global ResultConfigs available in the current package. Global ResultConfigs defined in ancestor packages will be included in this Map.

Returns:
a Map of Result Objects with the result name as the key
See Also:
ResultConfig

getAllInterceptorConfigs

public Map<String,Object> getAllInterceptorConfigs()
returns the Map of all InterceptorConfigs and InterceptorStackConfigs available in the current package. InterceptorConfigs defined in ancestor packages will be included in this Map.

Returns:
a Map of InterceptorConfig and InterceptorStackConfig Objects with the ref-name as the key
See Also:
InterceptorConfig, InterceptorStackConfig

getAllResultTypeConfigs

public Map<String,ResultTypeConfig> getAllResultTypeConfigs()
returns the Map of all the ResultTypeConfigs available in the current package. ResultTypeConfigs defined in ancestor packages will be included in this Map.

Returns:
a Map of ResultTypeConfig Objects with the result type name as the key
See Also:
ResultTypeConfig

getAllExceptionMappingConfigs

public List<ExceptionMappingConfig> getAllExceptionMappingConfigs()
returns the List of all the ExceptionMappingConfigs available in the current package. ExceptionMappingConfigs defined in ancestor packages will be included in this list.

Returns:
a List of ExceptionMappingConfigs Objects with the result type name as the key
See Also:
ExceptionMappingConfig

getDefaultInterceptorRef

public String getDefaultInterceptorRef()

getDefaultActionRef

public String getDefaultActionRef()

getDefaultClassRef

public String getDefaultClassRef()

getDefaultResultType

public String getDefaultResultType()
Returns the default result type for this package.

getFullDefaultInterceptorRef

public String getFullDefaultInterceptorRef()
gets the default interceptor-ref name. If this is not set on this PackageConfig, it searches the parent PackageConfigs in order until it finds one.

getFullDefaultActionRef

public String getFullDefaultActionRef()
gets the default action-ref name. If this is not set on this PackageConfig, it searches the parent PackageConfigs in order until it finds one.

getFullDefaultResultType

public String getFullDefaultResultType()
Returns the default result type for this package.

If there is no default result type, but this package has parents - we will try to look up the default result type of a parent.

getGlobalResultConfigs

public Map<String,ResultConfig> getGlobalResultConfigs()
gets the global ResultConfigs local to this package

Returns:
a Map of ResultConfig objects keyed by result name
See Also:
ResultConfig

getInterceptorConfigs

public Map<String,Object> getInterceptorConfigs()
gets the InterceptorConfigs and InterceptorStackConfigs local to this package

Returns:
a Map of InterceptorConfig and InterceptorStackConfig objects keyed by ref-name
See Also:
InterceptorConfig, InterceptorStackConfig

getName

public String getName()

getNamespace

public String getNamespace()

getParents

public List<PackageConfig> getParents()

getResultTypeConfigs

public Map<String,ResultTypeConfig> getResultTypeConfigs()
gets the ResultTypeConfigs local to this package

Returns:
a Map of ResultTypeConfig objects keyed by result name
See Also:
ResultTypeConfig

isNeedsRefresh

public boolean isNeedsRefresh()

getGlobalExceptionMappingConfigs

public List<ExceptionMappingConfig> getGlobalExceptionMappingConfigs()
gets the ExceptionMappingConfigs local to this package

Returns:
a Map of ExceptionMappingConfig objects keyed by result name
See Also:
ExceptionMappingConfig

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object

toString

public String toString()
Overrides:
toString in class Object

compareTo

public int compareTo(Object o)
Specified by:
compareTo in interface Comparable

getInterceptorConfig

public Object getInterceptorConfig(String name)
Description copied from interface: InterceptorLocator
Gets an interceptor configuration object.

Specified by:
getInterceptorConfig in interface InterceptorLocator
Parameters:
name - The interceptor or interceptor stack name
Returns:
Either an InterceptorConfig or InterceptorStackConfig object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PackageConfig.Builder (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class PackageConfig.Builder

java.lang.Object
    extended by  com.opensymphony.xwork2.config.entities.PackageConfig.Builder
All Implemented Interfaces:
InterceptorLocator
Enclosing class:
PackageConfig
public static class PackageConfig.Builder
extends Object
implements InterceptorLocator

The builder for this object. An instance of this object is the only way to construct a new instance. The purpose is to enforce the immutability of the object. The methods are structured in a way to support chaining. After setting any values you need, call the build() method to create the object.

Constructor Summary
PackageConfig.Builder(PackageConfig config)
PackageConfig.Builder(String name)
Method Summary
PackageConfig.Builder | addActionConfig(String name, ActionConfig action)
PackageConfig.Builder | addExceptionMappingConfig(ExceptionMappingConfig exceptionMappingConfig)
PackageConfig.Builder | addGlobalExceptionMappingConfigs(List<ExceptionMappingConfig> exceptionMappingConfigs)
PackageConfig.Builder | addGlobalResultConfig(ResultConfig resultConfig)
PackageConfig.Builder | addGlobalResultConfigs(Map<String,ResultConfig> resultConfigs)
PackageConfig.Builder | addInterceptorConfig(InterceptorConfig config)
PackageConfig.Builder | addInterceptorStackConfig(InterceptorStackConfig config)
PackageConfig.Builder | addParent(PackageConfig parent)
PackageConfig.Builder | addParents(List<PackageConfig> parents)
PackageConfig.Builder | addResultTypeConfig(ResultTypeConfig config)
PackageConfig | build()
PackageConfig.Builder | defaultActionRef(String name)
PackageConfig.Builder | defaultClassRef(String defaultClassRef)
PackageConfig.Builder | defaultInterceptorRef(String name)
PackageConfig.Builder | defaultResultType(String defaultResultType) sets the default Result type for this package
String | getDefaultClassRef()
String | getFullDefaultResultType()
Object | getInterceptorConfig(String name) Gets an interceptor configuration object.
String | getName()
String | getNamespace()
ResultTypeConfig | getResultType(String type)
PackageConfig.Builder | isAbstract(boolean isAbstract)
boolean | isNeedsRefresh()
PackageConfig.Builder | location(Location loc)
PackageConfig.Builder | name(String name)
PackageConfig.Builder | namespace(String namespace)
PackageConfig.Builder | needsRefresh(boolean needsRefresh)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

PackageConfig.Builder

public PackageConfig.Builder(String name)

PackageConfig.Builder

public PackageConfig.Builder(PackageConfig config)
Method Detail

name

public PackageConfig.Builder name(String name)

isAbstract

public PackageConfig.Builder isAbstract(boolean isAbstract)

defaultInterceptorRef

public PackageConfig.Builder defaultInterceptorRef(String name)

defaultActionRef

public PackageConfig.Builder defaultActionRef(String name)

defaultClassRef

public PackageConfig.Builder defaultClassRef(String defaultClassRef)

defaultResultType

public PackageConfig.Builder defaultResultType(String defaultResultType)
sets the default Result type for this package

Parameters:
defaultResultType -

namespace

public PackageConfig.Builder namespace(String namespace)

needsRefresh

public PackageConfig.Builder needsRefresh(boolean needsRefresh)

addActionConfig

public PackageConfig.Builder addActionConfig(String name,
                                             ActionConfig action)

addParents

public PackageConfig.Builder addParents(List<PackageConfig> parents)

addGlobalResultConfig

public PackageConfig.Builder addGlobalResultConfig(ResultConfig resultConfig)

addGlobalResultConfigs

public PackageConfig.Builder addGlobalResultConfigs(Map<String,ResultConfig> resultConfigs)

addExceptionMappingConfig

public PackageConfig.Builder addExceptionMappingConfig(ExceptionMappingConfig exceptionMappingConfig)

addGlobalExceptionMappingConfigs

public PackageConfig.Builder addGlobalExceptionMappingConfigs(List<ExceptionMappingConfig> exceptionMappingConfigs)

addInterceptorConfig

public PackageConfig.Builder addInterceptorConfig(InterceptorConfig config)

addInterceptorStackConfig

public PackageConfig.Builder addInterceptorStackConfig(InterceptorStackConfig config)

addParent

public PackageConfig.Builder addParent(PackageConfig parent)

addResultTypeConfig

public PackageConfig.Builder addResultTypeConfig(ResultTypeConfig config)

location

public PackageConfig.Builder location(Location loc)

isNeedsRefresh

public boolean isNeedsRefresh()

getDefaultClassRef

public String getDefaultClassRef()

getName

public String getName()

getNamespace

public String getNamespace()

getFullDefaultResultType

public String getFullDefaultResultType()

getResultType

public ResultTypeConfig getResultType(String type)

getInterceptorConfig

public Object getInterceptorConfig(String name)
Description copied from interface: InterceptorLocator
Gets an interceptor configuration object.

Specified by:
getInterceptorConfig in interface InterceptorLocator
Parameters:
name - The interceptor or interceptor stack name
Returns:
Either an InterceptorConfig or InterceptorStackConfig object

build

public PackageConfig build()

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Parameterizable (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Interface Parameterizable

public interface Parameterizable

Actions implementing Parameterizable will receive a map of the static parameters defined in the action configuration.

The StaticParametersInterceptor must be in the action's interceptor queue for this to work.

Author:
Jason Carreira

Method Summary
void | addParam(String name, String value)
Map<String,String> | getParams()
void | setParams(Map<String,String> params)

Method Detail

addParam

void addParam(String name,
              String value)

setParams

void setParams(Map<String,String> params)

getParams

Map<String,String> getParams()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResultConfig (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class ResultConfig

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.config.entities.ResultConfig
All Implemented Interfaces:
Locatable, Serializable
public class ResultConfig
extends Located
implements Serializable

Configuration for Result.

In the xml configuration file this is defined as the result tag.

Author:
Mike
See Also:
Serialized Form

Nested Class Summary
static class ResultConfig.Builder
The builder for this object.
Field Summary
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
protected | ResultConfig(ResultConfig orig)
protected | ResultConfig(String name, String className)
Method Summary
boolean | equals(Object o)
String | getClassName()
String | getName()
Map<String,String> | getParams()
int | hashCode()
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResultConfig

protected ResultConfig(String name,
                       String className)

ResultConfig

protected ResultConfig(ResultConfig orig)
Method Detail

getClassName

public String getClassName()

getName

public String getName()

getParams

public Map<String,String> getParams()

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResultConfig.Builder (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class ResultConfig.Builder

java.lang.Object
    extended by  com.opensymphony.xwork2.config.entities.ResultConfig.Builder
Enclosing class:
ResultConfig
public static final class ResultConfig.Builder
extends Object

The builder for this object. An instance of this object is the only way to construct a new instance. The purpose is to enforce the immutability of the object. The methods are structured in a way to support chaining. After setting any values you need, call the build() method to create the object.

Constructor Summary
ResultConfig.Builder(ResultConfig orig)
ResultConfig.Builder(String name, String className)
Method Summary
ResultConfig.Builder | addParam(String name, String value)
ResultConfig.Builder | addParams(Map<String,String> params)
ResultConfig | build()
ResultConfig.Builder | className(String name)
ResultConfig.Builder | location(Location loc)
ResultConfig.Builder | name(String name)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResultConfig.Builder

public ResultConfig.Builder(String name,
                            String className)

ResultConfig.Builder

public ResultConfig.Builder(ResultConfig orig)
Method Detail

name

public ResultConfig.Builder name(String name)

className

public ResultConfig.Builder className(String name)

addParam

public ResultConfig.Builder addParam(String name,
                                     String value)

addParams

public ResultConfig.Builder addParams(Map<String,String> params)

location

public ResultConfig.Builder location(Location loc)

build

public ResultConfig build()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResultTypeConfig (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class ResultTypeConfig

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.config.entities.ResultTypeConfig
All Implemented Interfaces:
Locatable, Serializable
public class ResultTypeConfig
extends Located
implements Serializable

Configuration class for result types.

In the xml configuration file this is defined as the result-type tag.

Author:
Mike, Rainer Hermanns, Neo
See Also:
Serialized Form

Nested Class Summary
static class ResultTypeConfig.Builder
The builder for this object.
Field Summary
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
protected | ResultTypeConfig(ResultTypeConfig orig)
protected | ResultTypeConfig(String name, String className)
Method Summary
 boolean equals(Object o)
 String getClassName()
 String getClazz()
Deprecated. Since 2.1, use getClassName() instead
 String getDefaultResultParam()
 String getName()
 Map<String,String> getParams()
 int hashCode()
 void setDefaultResultParam(String defaultResultParam)
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResultTypeConfig

protected ResultTypeConfig(String name,
                           String className)

ResultTypeConfig

protected ResultTypeConfig(ResultTypeConfig orig)
Method Detail

setDefaultResultParam

public void setDefaultResultParam(String defaultResultParam)

getDefaultResultParam

public String getDefaultResultParam()

getClazz

@Deprecated
public String getClazz()
Deprecated. Since 2.1, use getClassName() instead

getClassName

public String getClassName()

getName

public String getName()

getParams

public Map<String,String> getParams()

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResultTypeConfig.Builder (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class ResultTypeConfig.Builder

java.lang.Object
    extended by  com.opensymphony.xwork2.config.entities.ResultTypeConfig.Builder
Enclosing class:
ResultTypeConfig
public static final class ResultTypeConfig.Builder
extends Object

The builder for this object. An instance of this object is the only way to construct a new instance. The purpose is to enforce the immutability of the object. The methods are structured in a way to support chaining. After setting any values you need, call the build() method to create the object.

Constructor Summary
ResultTypeConfig.Builder(ResultTypeConfig orig)
ResultTypeConfig.Builder(String name, String className)
Method Summary
ResultTypeConfig.Builder | addParam(String name, String value)
ResultTypeConfig.Builder | addParams(Map<String,String> params)
ResultTypeConfig | build()
ResultTypeConfig.Builder | className(String name)
ResultTypeConfig.Builder | defaultResultParam(String defaultResultParam)
ResultTypeConfig.Builder | location(Location loc)
ResultTypeConfig.Builder | name(String name)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResultTypeConfig.Builder

public ResultTypeConfig.Builder(String name,
                                String className)

ResultTypeConfig.Builder

public ResultTypeConfig.Builder(ResultTypeConfig orig)
Method Detail

name

public ResultTypeConfig.Builder name(String name)

className

public ResultTypeConfig.Builder className(String name)

addParam

public ResultTypeConfig.Builder addParam(String name,
                                         String value)

addParams

public ResultTypeConfig.Builder addParams(Map<String,String> params)

defaultResultParam

public ResultTypeConfig.Builder defaultResultParam(String defaultResultParam)

location

public ResultTypeConfig.Builder location(Location loc)

build

public ResultTypeConfig build()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnknownHandlerConfig (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class UnknownHandlerConfig

java.lang.Object
    extended by  com.opensymphony.xwork2.config.entities.UnknownHandlerConfig

public class UnknownHandlerConfig
extends Object

Constructor Summary
UnknownHandlerConfig(String name)
Method Summary
String | getName()
void | setName(String name)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UnknownHandlerConfig

public UnknownHandlerConfig(String name)
Method Detail

getName

public String getName()

setName

public void setName(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.opensymphony.xwork2.config.entities.ActionConfig (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.ActionConfig

Packages that use ActionConfig
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.mock | XWork specific mock classes.

Uses of ActionConfig in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as ActionConfig
protected  ActionConfig DefaultActionProxy.config

Methods in com.opensymphony.xwork2 that return ActionConfig
ActionConfig | DefaultActionProxy.getConfig()
ActionConfig | ActionProxy.getConfig() Gets the ActionConfig this ActionProxy is built from.
ActionConfig | UnknownHandlerManager.handleUnknownAction(String namespace, String actionName)
ActionConfig | UnknownHandler.handleUnknownAction(String namespace, String actionName) Handles the case when an action configuration is unknown.
ActionConfig | DefaultUnknownHandlerManager.handleUnknownAction(String namespace, String actionName) Iterate over UnknownHandlers and return the result of the first one that can handle it

Methods in com.opensymphony.xwork2 with parameters of type ActionConfig
Object | ObjectFactory.buildAction(String actionName, String namespace, ActionConfig config, Map<String,Object> extraContext) Build an instance of the action class to handle a particular request (eg.
Result | UnknownHandlerManager.handleUnknownResult(ActionContext actionContext, String actionName, ActionConfig actionConfig, String resultCode)
Result | UnknownHandler.handleUnknownResult(ActionContext actionContext, String actionName, ActionConfig actionConfig, String resultCode) Handles the case when a result cannot be found for an action and result code.
Result | DefaultUnknownHandlerManager.handleUnknownResult(ActionContext actionContext, String actionName, ActionConfig actionConfig, String resultCode) Iterate over UnknownHandlers and return the result of the first one that can handle it
protected String | DefaultActionInvocation.invokeAction(Object action, ActionConfig actionConfig)

Uses of ActionConfig in com.opensymphony.xwork2.config

Methods in com.opensymphony.xwork2.config that return ActionConfig
 ActionConfig RuntimeConfiguration.getActionConfig(String namespace, String name)
get the fully expanded ActionConfig for a specified namespace and (action) name

Methods in com.opensymphony.xwork2.config that return types with arguments of type ActionConfig
 Map<String,Map<String,ActionConfig>> RuntimeConfiguration.getActionConfigs()
returns a Map of all the registered ActionConfigs.

Uses of ActionConfig in com.opensymphony.xwork2.config.entities

Methods in com.opensymphony.xwork2.config.entities that return ActionConfig
 ActionConfig ActionConfig.Builder.build()

Methods in com.opensymphony.xwork2.config.entities that return types with arguments of type ActionConfig
Map<String,ActionConfig> | PackageConfig.getActionConfigs()
Map<String,ActionConfig> | PackageConfig.getAllActionConfigs() returns the Map of all the ActionConfigs available in the current package.

Methods in com.opensymphony.xwork2.config.entities with parameters of type ActionConfig
 PackageConfig.Builder PackageConfig.Builder.addActionConfig(String name, ActionConfig action)

Constructors in com.opensymphony.xwork2.config.entities with parameters of type ActionConfig
ActionConfig.Builder(ActionConfig toClone)
ActionConfig(ActionConfig orig)
Clones an ActionConfig, copying data into new maps and lists

Uses of ActionConfig in com.opensymphony.xwork2.config.impl

Methods in com.opensymphony.xwork2.config.impl that return ActionConfig
 ActionConfig ActionConfigMatcher.convert(String path, ActionConfig orig, Map<String,String> vars)
Clones the ActionConfig and its children, replacing various properties with the values of the wildcard-matched strings.

Methods in com.opensymphony.xwork2.config.impl with parameters of type ActionConfig
 ActionConfig ActionConfigMatcher.convert(String path, ActionConfig orig, Map<String,String> vars)
Clones the ActionConfig and its children, replacing various properties with the values of the wildcard-matched strings.

Constructor parameters in com.opensymphony.xwork2.config.impl with type arguments of type ActionConfig
ActionConfigMatcher(Map<String,ActionConfig> configs)
Deprecated. Since 2.1, use ActionConfigMatcher.ActionConfigMatcher(PatternMatcher, Map, boolean) instead
ActionConfigMatcher(Map<String,ActionConfig> configs, boolean looseMatch)
Deprecated. Since 2.1, use ActionConfigMatcher.ActionConfigMatcher(PatternMatcher, Map, boolean) instead
ActionConfigMatcher(PatternMatcher<?> patternMatcher, Map<String,ActionConfig> configs, boolean looseMatch)
Finds and precompiles the wildcard patterns from the ActionConfig "path" attributes.

Uses of ActionConfig in com.opensymphony.xwork2.mock

Methods in com.opensymphony.xwork2.mock that return ActionConfig
 ActionConfig MockActionProxy.getConfig()

Methods in com.opensymphony.xwork2.mock with parameters of type ActionConfig
 void MockActionProxy.setConfig(ActionConfig config)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.ActionConfig.Builder (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.ActionConfig.Builder

Packages that use ActionConfig.Builder
com.opensymphony.xwork2.config.entities Configuration entity classes.

Uses of ActionConfig.Builder in com.opensymphony.xwork2.config.entities

Methods in com.opensymphony.xwork2.config.entities that return ActionConfig.Builder
ActionConfig.Builder | ActionConfig.Builder.addAllowedMethod(Collection<String> methods)
ActionConfig.Builder | ActionConfig.Builder.addAllowedMethod(String methodName)
ActionConfig.Builder | ActionConfig.Builder.addExceptionMapping(ExceptionMappingConfig exceptionMapping)
ActionConfig.Builder | ActionConfig.Builder.addExceptionMappings(Collection<? extends ExceptionMappingConfig> mappings)
ActionConfig.Builder | ActionConfig.Builder.addInterceptor(InterceptorMapping interceptor)
ActionConfig.Builder | ActionConfig.Builder.addInterceptors(List<InterceptorMapping> interceptors)
ActionConfig.Builder | ActionConfig.Builder.addParam(String name, String value)
ActionConfig.Builder | ActionConfig.Builder.addParams(Map<String,String> params)
ActionConfig.Builder | ActionConfig.Builder.addResultConfig(ResultConfig resultConfig)
ActionConfig.Builder | ActionConfig.Builder.addResultConfigs(Collection<ResultConfig> configs)
ActionConfig.Builder | ActionConfig.Builder.addResultConfigs(Map<String,ResultConfig> configs)
ActionConfig.Builder | ActionConfig.Builder.className(String name)
ActionConfig.Builder | ActionConfig.Builder.defaultClassName(String name)
ActionConfig.Builder | ActionConfig.Builder.exceptionMappings(Collection<? extends ExceptionMappingConfig> mappings)
ActionConfig.Builder | ActionConfig.Builder.interceptors(List<InterceptorMapping> interceptors)
ActionConfig.Builder | ActionConfig.Builder.location(Location loc)
ActionConfig.Builder | ActionConfig.Builder.methodName(String method)
ActionConfig.Builder | ActionConfig.Builder.name(String name)
ActionConfig.Builder | ActionConfig.Builder.packageName(String name)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.ExceptionMappingConfig

Packages that use ExceptionMappingConfig
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.

Uses of ExceptionMappingConfig in com.opensymphony.xwork2.config.entities

Fields in com.opensymphony.xwork2.config.entities with type parameters of type ExceptionMappingConfig
protected  List<ExceptionMappingConfig> ActionConfig.exceptionMappings

Methods in com.opensymphony.xwork2.config.entities that return ExceptionMappingConfig
 ExceptionMappingConfig ExceptionMappingConfig.Builder.build()

Methods in com.opensymphony.xwork2.config.entities that return types with arguments of type ExceptionMappingConfig
List<ExceptionMappingConfig> | PackageConfig.getAllExceptionMappingConfigs() returns the List of all the ExceptionMappingConfigs available in the current package.
List<ExceptionMappingConfig> | ActionConfig.getExceptionMappings()
List<ExceptionMappingConfig> | PackageConfig.getGlobalExceptionMappingConfigs() gets the ExceptionMappingConfigs local to this package

Methods in com.opensymphony.xwork2.config.entities with parameters of type ExceptionMappingConfig
ActionConfig.Builder | ActionConfig.Builder.addExceptionMapping(ExceptionMappingConfig exceptionMapping)
PackageConfig.Builder | PackageConfig.Builder.addExceptionMappingConfig(ExceptionMappingConfig exceptionMappingConfig)

Method parameters in com.opensymphony.xwork2.config.entities with type arguments of type ExceptionMappingConfig
ActionConfig.Builder | ActionConfig.Builder.addExceptionMappings(Collection<? extends ExceptionMappingConfig> mappings)
PackageConfig.Builder | PackageConfig.Builder.addGlobalExceptionMappingConfigs(List<ExceptionMappingConfig> exceptionMappingConfigs)
ActionConfig.Builder | ActionConfig.Builder.exceptionMappings(Collection<? extends ExceptionMappingConfig> mappings)

Constructors in com.opensymphony.xwork2.config.entities with parameters of type ExceptionMappingConfig
ExceptionMappingConfig.Builder(ExceptionMappingConfig toClone)
ExceptionMappingConfig(ExceptionMappingConfig target)

Uses of ExceptionMappingConfig in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers that return types with arguments of type ExceptionMappingConfig
protected  List<ExceptionMappingConfig> XmlConfigurationProvider.buildExceptionMappings(Element element, PackageConfig.Builder packageContext)
Build a map of ResultConfig objects from below a given XML element.

Uses of ExceptionMappingConfig in com.opensymphony.xwork2.interceptor

Method parameters in com.opensymphony.xwork2.interceptor with type arguments of type ExceptionMappingConfig
protected  String ExceptionMappingInterceptor.findResultFromExceptions(List<ExceptionMappingConfig> exceptionMappings, Throwable t)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig.Builder (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.ExceptionMappingConfig.Builder

Packages that use ExceptionMappingConfig.Builder
com.opensymphony.xwork2.config.entities Configuration entity classes.

Uses of ExceptionMappingConfig.Builder in com.opensymphony.xwork2.config.entities

Methods in com.opensymphony.xwork2.config.entities that return ExceptionMappingConfig.Builder
ExceptionMappingConfig.Builder | ExceptionMappingConfig.Builder.addParam(String name, String value)
ExceptionMappingConfig.Builder | ExceptionMappingConfig.Builder.addParams(Map<String,String> params)
ExceptionMappingConfig.Builder | ExceptionMappingConfig.Builder.exceptionClassName(String name)
ExceptionMappingConfig.Builder | ExceptionMappingConfig.Builder.location(Location loc)
ExceptionMappingConfig.Builder | ExceptionMappingConfig.Builder.name(String name)
ExceptionMappingConfig.Builder | ExceptionMappingConfig.Builder.result(String result)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.InterceptorConfig (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.InterceptorConfig

Packages that use InterceptorConfig
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.

Uses of InterceptorConfig in com.opensymphony.xwork2

Methods in com.opensymphony.xwork2 with parameters of type InterceptorConfig
 Interceptor ObjectFactory.buildInterceptor(InterceptorConfig interceptorConfig, Map<String,String> interceptorRefParams)
Builds an Interceptor from the InterceptorConfig and the Map of parameters from the interceptor reference.

Uses of InterceptorConfig in com.opensymphony.xwork2.config.entities

Methods in com.opensymphony.xwork2.config.entities that return InterceptorConfig
 InterceptorConfig InterceptorConfig.Builder.build()

Methods in com.opensymphony.xwork2.config.entities with parameters of type InterceptorConfig
 PackageConfig.Builder PackageConfig.Builder.addInterceptorConfig(InterceptorConfig config)

Constructors in com.opensymphony.xwork2.config.entities with parameters of type InterceptorConfig
InterceptorConfig.Builder(InterceptorConfig orig)
InterceptorConfig(InterceptorConfig orig)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.InterceptorConfig.Builder (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.InterceptorConfig.Builder

Packages that use InterceptorConfig.Builder
com.opensymphony.xwork2.config.entities Configuration entity classes.

Uses of InterceptorConfig.Builder in com.opensymphony.xwork2.config.entities

Methods in com.opensymphony.xwork2.config.entities that return InterceptorConfig.Builder
InterceptorConfig.Builder | InterceptorConfig.Builder.addParam(String name, String value)
InterceptorConfig.Builder | InterceptorConfig.Builder.addParams(Map<String,String> params)
InterceptorConfig.Builder | InterceptorConfig.Builder.className(String name)
InterceptorConfig.Builder | InterceptorConfig.Builder.location(Location loc)
InterceptorConfig.Builder | InterceptorConfig.Builder.name(String name)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.config.entities.InterceptorListHolder (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.config.entities.InterceptorListHolder

Packages that use InterceptorListHolder
com.opensymphony.xwork2.config.entities Configuration entity classes.

Uses of InterceptorListHolder in com.opensymphony.xwork2.config.entities

Classes in com.opensymphony.xwork2.config.entities that implement InterceptorListHolder
static class | ActionConfig.Builder The builder for this object.
static class | InterceptorStackConfig.Builder The builder for this object.

Methods in com.opensymphony.xwork2.config.entities that return InterceptorListHolder
InterceptorListHolder | InterceptorListHolder.addInterceptor(InterceptorMapping interceptor)
InterceptorListHolder | InterceptorListHolder.addInterceptors(List<InterceptorMapping> interceptors)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.config.entities.InterceptorLocator (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.config.entities.InterceptorLocator

Packages that use InterceptorLocator
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.

Uses of InterceptorLocator in com.opensymphony.xwork2.config.entities

Classes in com.opensymphony.xwork2.config.entities that implement InterceptorLocator
class | PackageConfig Configuration for Package.
static class | PackageConfig.Builder The builder for this object.

Uses of InterceptorLocator in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers with parameters of type InterceptorLocator
static List<InterceptorMapping> InterceptorBuilder.constructInterceptorReference(InterceptorLocator interceptorLocator, String refName, Map<String,String> refParams, Location location, ObjectFactory objectFactory)
Builds a list of interceptors referenced by the refName in the supplied PackageConfig (InterceptorMapping object).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.InterceptorMapping (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.InterceptorMapping

Packages that use InterceptorMapping
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.

Uses of InterceptorMapping in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 with type parameters of type InterceptorMapping
protected  Iterator<InterceptorMapping> DefaultActionInvocation.interceptors

Uses of InterceptorMapping in com.opensymphony.xwork2.config.entities

Fields in com.opensymphony.xwork2.config.entities with type parameters of type InterceptorMapping
protected  List<InterceptorMapping> ActionConfig.interceptors

Methods in com.opensymphony.xwork2.config.entities that return types with arguments of type InterceptorMapping
Collection<InterceptorMapping> | InterceptorStackConfig.getInterceptors() Returns a Collection of InterceptorMapping objects.
List<InterceptorMapping> | ActionConfig.getInterceptors()

Methods in com.opensymphony.xwork2.config.entities with parameters of type InterceptorMapping
InterceptorStackConfig.Builder | InterceptorStackConfig.Builder.addInterceptor(InterceptorMapping interceptor) Add an InterceptorMapping object.
InterceptorListHolder | InterceptorListHolder.addInterceptor(InterceptorMapping interceptor)
ActionConfig.Builder | ActionConfig.Builder.addInterceptor(InterceptorMapping interceptor)

Method parameters in com.opensymphony.xwork2.config.entities with type arguments of type InterceptorMapping
InterceptorStackConfig.Builder | InterceptorStackConfig.Builder.addInterceptors(List<InterceptorMapping> interceptors) Add a List of InterceptorMapping objects.
InterceptorListHolder | InterceptorListHolder.addInterceptors(List<InterceptorMapping> interceptors)
ActionConfig.Builder | ActionConfig.Builder.addInterceptors(List<InterceptorMapping> interceptors)
ActionConfig.Builder | ActionConfig.Builder.interceptors(List<InterceptorMapping> interceptors)

Uses of InterceptorMapping in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers that return types with arguments of type InterceptorMapping
protected List<InterceptorMapping> | XmlConfigurationProvider.buildInterceptorList(Element element, PackageConfig.Builder context)
static List<InterceptorMapping> | InterceptorBuilder.constructInterceptorReference(InterceptorLocator interceptorLocator, String refName, Map<String,String> refParams, Location location, ObjectFactory objectFactory) Builds a list of interceptors referenced by the refName in the supplied PackageConfig (InterceptorMapping object).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.InterceptorStackConfig (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.InterceptorStackConfig

Packages that use InterceptorStackConfig
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.

Uses of InterceptorStackConfig in com.opensymphony.xwork2.config.entities

Methods in com.opensymphony.xwork2.config.entities that return InterceptorStackConfig
 InterceptorStackConfig InterceptorStackConfig.Builder.build()

Methods in com.opensymphony.xwork2.config.entities with parameters of type InterceptorStackConfig
 PackageConfig.Builder PackageConfig.Builder.addInterceptorStackConfig(InterceptorStackConfig config)

Constructors in com.opensymphony.xwork2.config.entities with parameters of type InterceptorStackConfig
InterceptorStackConfig(InterceptorStackConfig orig)
Creates an InterceptorStackConfig object with a particular name.

Uses of InterceptorStackConfig in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers that return InterceptorStackConfig
protected  InterceptorStackConfig XmlConfigurationProvider.loadInterceptorStack(Element element, PackageConfig.Builder context)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.InterceptorStackConfig.Builder (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.InterceptorStackConfig.Builder

Packages that use InterceptorStackConfig.Builder
com.opensymphony.xwork2.config.entities Configuration entity classes.

Uses of InterceptorStackConfig.Builder in com.opensymphony.xwork2.config.entities

Methods in com.opensymphony.xwork2.config.entities that return InterceptorStackConfig.Builder
InterceptorStackConfig.Builder | InterceptorStackConfig.Builder.addInterceptor(InterceptorMapping interceptor) Add an InterceptorMapping object.
InterceptorStackConfig.Builder | InterceptorStackConfig.Builder.addInterceptors(List<InterceptorMapping> interceptors) Add a List of InterceptorMapping objects.
InterceptorStackConfig.Builder | InterceptorStackConfig.Builder.location(Location loc)
InterceptorStackConfig.Builder | InterceptorStackConfig.Builder.name(String name)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.PackageConfig (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.PackageConfig

Packages that use PackageConfig
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.

Uses of PackageConfig in com.opensymphony.xwork2.config

Methods in com.opensymphony.xwork2.config that return PackageConfig
PackageConfig | Configuration.getPackageConfig(String name)
PackageConfig | Configuration.removePackageConfig(String packageName) Removes a package from the the list of packages.

Methods in com.opensymphony.xwork2.config that return types with arguments of type PackageConfig
static List<PackageConfig> | ConfigurationUtil.buildParentsFromString(Configuration configuration, String parent)
Map<String,PackageConfig> | Configuration.getPackageConfigs()

Methods in com.opensymphony.xwork2.config with parameters of type PackageConfig
 void Configuration.addPackageConfig(String name, PackageConfig packageConfig)

Uses of PackageConfig in com.opensymphony.xwork2.config.entities

Methods in com.opensymphony.xwork2.config.entities that return PackageConfig
 PackageConfig PackageConfig.Builder.build()

Methods in com.opensymphony.xwork2.config.entities that return types with arguments of type PackageConfig
 List<PackageConfig> PackageConfig.getParents()

Methods in com.opensymphony.xwork2.config.entities with parameters of type PackageConfig
 PackageConfig.Builder PackageConfig.Builder.addParent(PackageConfig parent)

Method parameters in com.opensymphony.xwork2.config.entities with type arguments of type PackageConfig
 PackageConfig.Builder PackageConfig.Builder.addParents(List<PackageConfig> parents)

Constructors in com.opensymphony.xwork2.config.entities with parameters of type PackageConfig
PackageConfig.Builder(PackageConfig config)
PackageConfig(PackageConfig orig)

Uses of PackageConfig in com.opensymphony.xwork2.config.impl

Fields in com.opensymphony.xwork2.config.impl with type parameters of type PackageConfig
protected  Map<String,PackageConfig> DefaultConfiguration.packageContexts

Methods in com.opensymphony.xwork2.config.impl that return PackageConfig
PackageConfig | MockConfiguration.getPackageConfig(String name)
PackageConfig | DefaultConfiguration.getPackageConfig(String name)
PackageConfig | MockConfiguration.removePackageConfig(String name)
PackageConfig | DefaultConfiguration.removePackageConfig(String packageName)

Methods in com.opensymphony.xwork2.config.impl that return types with arguments of type PackageConfig
Map<String,PackageConfig> | MockConfiguration.getPackageConfigs()
Map<String,PackageConfig> | DefaultConfiguration.getPackageConfigs()

Methods in com.opensymphony.xwork2.config.impl with parameters of type PackageConfig
void | MockConfiguration.addPackageConfig(String name, PackageConfig packageContext)
void | DefaultConfiguration.addPackageConfig(String name, PackageConfig packageContext)

Uses of PackageConfig in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers that return PackageConfig
protected  PackageConfig XmlConfigurationProvider.addPackage(Element packageElement)
Create a PackageConfig from an XML element representing it.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.PackageConfig.Builder (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.PackageConfig.Builder

Packages that use PackageConfig.Builder
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.

Uses of PackageConfig.Builder in com.opensymphony.xwork2.config.entities

Methods in com.opensymphony.xwork2.config.entities that return PackageConfig.Builder
PackageConfig.Builder | PackageConfig.Builder.addActionConfig(String name, ActionConfig action)
PackageConfig.Builder | PackageConfig.Builder.addExceptionMappingConfig(ExceptionMappingConfig exceptionMappingConfig)
PackageConfig.Builder | PackageConfig.Builder.addGlobalExceptionMappingConfigs(List<ExceptionMappingConfig> exceptionMappingConfigs)
PackageConfig.Builder | PackageConfig.Builder.addGlobalResultConfig(ResultConfig resultConfig)
PackageConfig.Builder | PackageConfig.Builder.addGlobalResultConfigs(Map<String,ResultConfig> resultConfigs)
PackageConfig.Builder | PackageConfig.Builder.addInterceptorConfig(InterceptorConfig config)
PackageConfig.Builder | PackageConfig.Builder.addInterceptorStackConfig(InterceptorStackConfig config)
PackageConfig.Builder | PackageConfig.Builder.addParent(PackageConfig parent)
PackageConfig.Builder | PackageConfig.Builder.addParents(List<PackageConfig> parents)
PackageConfig.Builder | PackageConfig.Builder.addResultTypeConfig(ResultTypeConfig config)
PackageConfig.Builder | PackageConfig.Builder.defaultActionRef(String name)
PackageConfig.Builder | PackageConfig.Builder.defaultClassRef(String defaultClassRef)
PackageConfig.Builder | PackageConfig.Builder.defaultInterceptorRef(String name)
PackageConfig.Builder | PackageConfig.Builder.defaultResultType(String defaultResultType) sets the default Result type for this package
PackageConfig.Builder | PackageConfig.Builder.isAbstract(boolean isAbstract)
PackageConfig.Builder | PackageConfig.Builder.location(Location loc)
PackageConfig.Builder | PackageConfig.Builder.name(String name)
PackageConfig.Builder | PackageConfig.Builder.namespace(String namespace)
PackageConfig.Builder | PackageConfig.Builder.needsRefresh(boolean needsRefresh)

Uses of PackageConfig.Builder in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers that return PackageConfig.Builder
protected  PackageConfig.Builder XmlConfigurationProvider.buildPackageContext(Element packageElement)
This method builds a package context by looking for the parents of this new package.

Methods in com.opensymphony.xwork2.config.providers with parameters of type PackageConfig.Builder
protected void | XmlConfigurationProvider.addAction(Element actionElement, PackageConfig.Builder packageContext)
protected void | XmlConfigurationProvider.addResultTypes(PackageConfig.Builder packageContext, Element element)
protected List<ExceptionMappingConfig> | XmlConfigurationProvider.buildExceptionMappings(Element element, PackageConfig.Builder packageContext) Build a map of ResultConfig objects from below a given XML element.
protected List<InterceptorMapping> | XmlConfigurationProvider.buildInterceptorList(Element element, PackageConfig.Builder context)
protected Map<String,ResultConfig> | XmlConfigurationProvider.buildResults(Element element, PackageConfig.Builder packageContext) Build a map of ResultConfig objects from below a given XML element.
protected void | XmlConfigurationProvider.loadDefaultActionRef(PackageConfig.Builder packageContext, Element element)
protected void | XmlConfigurationProvider.loadDefaultClassRef(PackageConfig.Builder packageContext, Element element)
protected void | XmlConfigurationProvider.loadDefaultInterceptorRef(PackageConfig.Builder packageContext, Element element)
protected void | XmlConfigurationProvider.loadGlobalResults(PackageConfig.Builder packageContext, Element packageElement) Load all of the global results for this package from the XML element.
protected void | XmlConfigurationProvider.loadGobalExceptionMappings(PackageConfig.Builder packageContext, Element packageElement) Load all of the global results for this package from the XML element.
protected void | XmlConfigurationProvider.loadInterceptors(PackageConfig.Builder context, Element element)
protected InterceptorStackConfig | XmlConfigurationProvider.loadInterceptorStack(Element element, PackageConfig.Builder context)
protected void | XmlConfigurationProvider.loadInterceptorStacks(Element element, PackageConfig.Builder context)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.config.entities.Parameterizable (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.config.entities.Parameterizable

No usage of com.opensymphony.xwork2.config.entities.Parameterizable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.ResultConfig (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.ResultConfig

Packages that use ResultConfig
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.

Uses of ResultConfig in com.opensymphony.xwork2

Methods in com.opensymphony.xwork2 with parameters of type ResultConfig
 Result ObjectFactory.buildResult(ResultConfig resultConfig, Map<String,Object> extraContext)
Build a Result using the type in the ResultConfig and set the parameters in the ResultConfig.

Uses of ResultConfig in com.opensymphony.xwork2.config.entities

Fields in com.opensymphony.xwork2.config.entities with type parameters of type ResultConfig
protected  Map<String,ResultConfig> ActionConfig.results

Methods in com.opensymphony.xwork2.config.entities that return ResultConfig
 ResultConfig ResultConfig.Builder.build()

Methods in com.opensymphony.xwork2.config.entities that return types with arguments of type ResultConfig
Map<String,ResultConfig> | PackageConfig.getAllGlobalResults() returns the Map of all the global ResultConfigs available in the current package.
Map<String,ResultConfig> | PackageConfig.getGlobalResultConfigs() gets the global ResultConfigs local to this package
Map<String,ResultConfig> | ActionConfig.getResults()

Methods in com.opensymphony.xwork2.config.entities with parameters of type ResultConfig
PackageConfig.Builder | PackageConfig.Builder.addGlobalResultConfig(ResultConfig resultConfig)
ActionConfig.Builder | ActionConfig.Builder.addResultConfig(ResultConfig resultConfig)

Method parameters in com.opensymphony.xwork2.config.entities with type arguments of type ResultConfig
PackageConfig.Builder | PackageConfig.Builder.addGlobalResultConfigs(Map<String,ResultConfig> resultConfigs)
ActionConfig.Builder | ActionConfig.Builder.addResultConfigs(Collection<ResultConfig> configs)
ActionConfig.Builder | ActionConfig.Builder.addResultConfigs(Map<String,ResultConfig> configs)

Constructors in com.opensymphony.xwork2.config.entities with parameters of type ResultConfig
ResultConfig.Builder(ResultConfig orig)
ResultConfig(ResultConfig orig)

Uses of ResultConfig in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers that return types with arguments of type ResultConfig
protected  Map<String,ResultConfig> XmlConfigurationProvider.buildResults(Element element, PackageConfig.Builder packageContext)
Build a map of ResultConfig objects from below a given XML element.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.ResultConfig.Builder (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.ResultConfig.Builder

Packages that use ResultConfig.Builder
com.opensymphony.xwork2.config.entities Configuration entity classes.

Uses of ResultConfig.Builder in com.opensymphony.xwork2.config.entities

Methods in com.opensymphony.xwork2.config.entities that return ResultConfig.Builder
ResultConfig.Builder | ResultConfig.Builder.addParam(String name, String value)
ResultConfig.Builder | ResultConfig.Builder.addParams(Map<String,String> params)
ResultConfig.Builder | ResultConfig.Builder.className(String name)
ResultConfig.Builder | ResultConfig.Builder.location(Location loc)
ResultConfig.Builder | ResultConfig.Builder.name(String name)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.ResultTypeConfig (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.ResultTypeConfig

Packages that use ResultTypeConfig
com.opensymphony.xwork2.config.entities Configuration entity classes.

Uses of ResultTypeConfig in com.opensymphony.xwork2.config.entities

Methods in com.opensymphony.xwork2.config.entities that return ResultTypeConfig
ResultTypeConfig | ResultTypeConfig.Builder.build()
ResultTypeConfig | PackageConfig.Builder.getResultType(String type)

Methods in com.opensymphony.xwork2.config.entities that return types with arguments of type ResultTypeConfig
Map<String,ResultTypeConfig> | PackageConfig.getAllResultTypeConfigs() returns the Map of all the ResultTypeConfigs available in the current package.
Map<String,ResultTypeConfig> | PackageConfig.getResultTypeConfigs() gets the ResultTypeConfigs local to this package

Methods in com.opensymphony.xwork2.config.entities with parameters of type ResultTypeConfig
 PackageConfig.Builder PackageConfig.Builder.addResultTypeConfig(ResultTypeConfig config)

Constructors in com.opensymphony.xwork2.config.entities with parameters of type ResultTypeConfig
ResultTypeConfig.Builder(ResultTypeConfig orig)
ResultTypeConfig(ResultTypeConfig orig)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.ResultTypeConfig.Builder (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.ResultTypeConfig.Builder

Packages that use ResultTypeConfig.Builder
com.opensymphony.xwork2.config.entities Configuration entity classes.

Uses of ResultTypeConfig.Builder in com.opensymphony.xwork2.config.entities

Methods in com.opensymphony.xwork2.config.entities that return ResultTypeConfig.Builder
ResultTypeConfig.Builder | ResultTypeConfig.Builder.addParam(String name, String value)
ResultTypeConfig.Builder | ResultTypeConfig.Builder.addParams(Map<String,String> params)
ResultTypeConfig.Builder | ResultTypeConfig.Builder.className(String name)
ResultTypeConfig.Builder | ResultTypeConfig.Builder.defaultResultParam(String defaultResultParam)
ResultTypeConfig.Builder | ResultTypeConfig.Builder.location(Location loc)
ResultTypeConfig.Builder | ResultTypeConfig.Builder.name(String name)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.UnknownHandlerConfig (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.UnknownHandlerConfig

Packages that use UnknownHandlerConfig
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.

Uses of UnknownHandlerConfig in com.opensymphony.xwork2.config

Methods in com.opensymphony.xwork2.config that return types with arguments of type UnknownHandlerConfig
 List<UnknownHandlerConfig> Configuration.getUnknownHandlerStack()

Method parameters in com.opensymphony.xwork2.config with type arguments of type UnknownHandlerConfig
 void Configuration.setUnknownHandlerStack(List<UnknownHandlerConfig> unknownHandlerStack)

Uses of UnknownHandlerConfig in com.opensymphony.xwork2.config.impl

Fields in com.opensymphony.xwork2.config.impl with type parameters of type UnknownHandlerConfig
protected List<UnknownHandlerConfig> | MockConfiguration.unknownHandlerStack
protected List<UnknownHandlerConfig> | DefaultConfiguration.unknownHandlerStack

Methods in com.opensymphony.xwork2.config.impl that return types with arguments of type UnknownHandlerConfig
List<UnknownHandlerConfig> | MockConfiguration.getUnknownHandlerStack()
List<UnknownHandlerConfig> | DefaultConfiguration.getUnknownHandlerStack()

Method parameters in com.opensymphony.xwork2.config.impl with type arguments of type UnknownHandlerConfig
void | MockConfiguration.setUnknownHandlerStack(List<UnknownHandlerConfig> unknownHandlerStack)
void | DefaultConfiguration.setUnknownHandlerStack(List<UnknownHandlerConfig> unknownHandlerStack)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AbstractMatcher (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.impl
Class AbstractMatcher<E>

java.lang.Object
    extended by  com.opensymphony.xwork2.config.impl.AbstractMatcher<E>
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ActionConfigMatcher, NamespaceMatcher
public abstract class AbstractMatcher<E>
extends Object
implements Serializable

Matches patterns against pre-compiled wildcard expressions pulled from target objects. It uses the wildcard matcher from the Apache Cocoon project. Patterns will be matched in the order they were added. The first match wins, so more specific patterns should be defined before less specific patterns.

Since:
2.1
See Also:
Serialized Form

Constructor Summary
AbstractMatcher(PatternMatcher<?> helper)
Method Summary
void | addPattern(String name, E target, boolean looseMatch) Finds and precompiles the wildcard patterns.
protected abstract E | convert(String path, E orig, Map<String,String> vars) Clones the target object and its children, replacing various properties with the values of the wildcard-matched strings.
protected String | convertParam(String val, Map<String,String> vars) Inserts into a value wildcard-matched strings where specified with the {x} syntax.
void | freeze()
E | match(String potentialMatch) Matches the path against the compiled wildcard patterns.
protected Map<String,String> | replaceParameters(Map<String,String> orig, Map<String,String> vars) Replaces parameter values
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AbstractMatcher

public AbstractMatcher(PatternMatcher<?> helper)
Method Detail

addPattern

public void addPattern(String name,
                       E target,
                       boolean looseMatch)

Finds and precompiles the wildcard patterns. Patterns will be evaluated in the order they were added. Only patterns that actually contain a wildcard will be compiled.

Patterns can optionally be matched "loosely". When the end of the pattern matches \*[^*]\*$ (wildcard, no wildcard, wildcard), if the pattern fails, it is also matched as if the last two characters didn't exist. The goal is to support the legacy "*!*" syntax, where the "!*" is optional.

Parameters:
name - The pattern
target - The object to associate with the pattern
looseMatch - To loosely match wildcards or not

freeze

public void freeze()

match

public E match(String potentialMatch)

Matches the path against the compiled wildcard patterns.

Parameters:
potentialMatch - The portion of the request URI for selecting a config.
Returns:
The action config if matched, else null

convert

protected abstract E convert(String path,
                             E orig,
                             Map<String,String> vars)

Clones the target object and its children, replacing various properties with the values of the wildcard-matched strings.

Parameters:
path - The requested path
orig - The original object
vars - A Map of wildcard-matched strings
Returns:
A cloned object with appropriate properties replaced with wildcard-matched values

replaceParameters

protected Map<String,String> replaceParameters(Map<String,String> orig,
                                               Map<String,String> vars)

Replaces parameter values

Parameters:
orig - The original parameters with placehold values
vars - A Map of wildcard-matched strings

convertParam

protected String convertParam(String val,
                              Map<String,String> vars)

Inserts into a value wildcard-matched strings where specified with the {x} syntax. If a wildcard-matched value isn't found, the replacement token is turned into an empty string.

Parameters:
val - The value to convert
vars - A Map of wildcard-matched strings
Returns:
The new value
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ActionConfigMatcher (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.impl
Class ActionConfigMatcher

java.lang.Object
    extended by  com.opensymphony.xwork2.config.impl.AbstractMatcher<ActionConfig>
        extended by  com.opensymphony.xwork2.config.impl.ActionConfigMatcher
All Implemented Interfaces:
Serializable
public class ActionConfigMatcher
extends AbstractMatcher<ActionConfig>
implements Serializable

Matches paths against pre-compiled wildcard expressions pulled from action configs. It uses the wildcard matcher from the Apache Cocoon project. Patterns will be matched in the order they exist in the config file. The first match wins, so more specific patterns should be defined before less specific patterns.

See Also:
Serialized Form

Constructor Summary
ActionConfigMatcher(Map<String,ActionConfig> configs)
Deprecated. Since 2.1, use ActionConfigMatcher(PatternMatcher, Map, boolean) instead
ActionConfigMatcher(Map<String,ActionConfig> configs, boolean looseMatch)
Deprecated. Since 2.1, use ActionConfigMatcher(PatternMatcher, Map, boolean) instead
ActionConfigMatcher(PatternMatcher<?> patternMatcher, Map<String,ActionConfig> configs, boolean looseMatch)
Finds and precompiles the wildcard patterns from the ActionConfig "path" attributes.
Method Summary
 ActionConfig convert(String path, ActionConfig orig, Map<String,String> vars)
Clones the ActionConfig and its children, replacing various properties with the values of the wildcard-matched strings.
Methods inherited from class com.opensymphony.xwork2.config.impl.AbstractMatcher
addPattern, convertParam, freeze, match, replaceParameters
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ActionConfigMatcher

@Deprecated
public ActionConfigMatcher(Map<String,ActionConfig> configs)
Deprecated. Since 2.1, use ActionConfigMatcher(PatternMatcher, Map, boolean) instead

Finds and precompiles the wildcard patterns from the ActionConfig "path" attributes. ActionConfig's will be evaluated in the order they exist in the config file. Only paths that actually contain a wildcard will be compiled. Patterns will matched strictly.

Parameters:
configs - An array of ActionConfig's to process

ActionConfigMatcher

@Deprecated
public ActionConfigMatcher(Map<String,ActionConfig> configs,
                                      boolean looseMatch)
Deprecated. Since 2.1, use ActionConfigMatcher(PatternMatcher, Map, boolean) instead

Finds and precompiles the wildcard patterns from the ActionConfig "path" attributes. ActionConfig's will be evaluated in the order they exist in the config file. Only paths that actually contain a wildcard will be compiled.

Patterns can optionally be matched "loosely". When the end of the pattern matches \*[^*]\*$ (wildcard, no wildcard, wildcard), if the pattern fails, it is also matched as if the last two characters didn't exist. The goal is to support the legacy "*!*" syntax, where the "!*" is optional.

Parameters:
configs - An array of ActionConfig's to process
looseMatch - To loosely match wildcards or not

ActionConfigMatcher

public ActionConfigMatcher(PatternMatcher<?> patternMatcher,
                           Map<String,ActionConfig> configs,
                           boolean looseMatch)

Finds and precompiles the wildcard patterns from the ActionConfig "path" attributes. ActionConfig's will be evaluated in the order they exist in the config file. Only paths that actually contain a wildcard will be compiled.

Patterns can optionally be matched "loosely". When the end of the pattern matches \*[^*]\*$ (wildcard, no wildcard, wildcard), if the pattern fails, it is also matched as if the last two characters didn't exist. The goal is to support the legacy "*!*" syntax, where the "!*" is optional.

Parameters:
configs - An array of ActionConfig's to process
looseMatch - To loosely match wildcards or not
Method Detail

convert

public ActionConfig convert(String path,
                            ActionConfig orig,
                            Map<String,String> vars)

Clones the ActionConfig and its children, replacing various properties with the values of the wildcard-matched strings.

Specified by:
convert in class AbstractMatcher<ActionConfig>
Parameters:
path - The requested path
orig - The original ActionConfig
vars - A Map of wildcard-matched strings
Returns:
A cloned ActionConfig with appropriate properties replaced with wildcard-matched values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultConfiguration (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.impl
Class DefaultConfiguration

java.lang.Object
    extended by  com.opensymphony.xwork2.config.impl.DefaultConfiguration
All Implemented Interfaces:
Configuration, Serializable
public class DefaultConfiguration
extends Object
implements Configuration

DefaultConfiguration

Author:
Jason Carreira Created Feb 24, 2003 7:38:06 AM
See Also:
Serialized Form

Field Summary
protected Container | container
protected String | defaultFrameworkBeanName
protected Set<String> | loadedFileNames
protected static Logger | LOG
protected Map<String,PackageConfig> | packageContexts
protected RuntimeConfiguration | runtimeConfiguration
protected List<UnknownHandlerConfig> | unknownHandlerStack
Constructor Summary
DefaultConfiguration()
DefaultConfiguration(String defaultBeanName)
Method Summary
void | addPackageConfig(String name, PackageConfig packageContext)
protected RuntimeConfiguration | buildRuntimeConfiguration() This builds the internal runtime configuration used by Xwork for finding and configuring Actions from the programmatic configuration data structures.
protected Container | createBootstrapContainer()
void | destroy() Allows the configuration to clean up any resources used
Container | getContainer()
Set<String> | getLoadedFileNames()
PackageConfig | getPackageConfig(String name)
Set<String> | getPackageConfigNames()
Map<String,PackageConfig> | getPackageConfigs()
RuntimeConfiguration | getRuntimeConfiguration() The current runtime configuration.
List<UnknownHandlerConfig> | getUnknownHandlerStack()
void | rebuildRuntimeConfiguration()
void | reload(List<ConfigurationProvider> providers) Calls the ConfigurationProviderFactory.getConfig() to tell it to reload the configuration and then calls buildRuntimeConfiguration().
List<PackageProvider> | reloadContainer(List<ContainerProvider> providers) Calls the ConfigurationProviderFactory.getConfig() to tell it to reload the configuration and then calls buildRuntimeConfiguration().
PackageConfig | removePackageConfig(String packageName) Removes a package from the the list of packages.
protected ActionContext | setContext(Container cont)
void | setUnknownHandlerStack(List<UnknownHandlerConfig> unknownHandlerStack)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

protected static final Logger LOG

packageContexts

protected Map<String,PackageConfig> packageContexts

runtimeConfiguration

protected RuntimeConfiguration runtimeConfiguration

container

protected Container container

defaultFrameworkBeanName

protected String defaultFrameworkBeanName

loadedFileNames

protected Set<String> loadedFileNames

unknownHandlerStack

protected List<UnknownHandlerConfig> unknownHandlerStack
Constructor Detail

DefaultConfiguration

public DefaultConfiguration()

DefaultConfiguration

public DefaultConfiguration(String defaultBeanName)
Method Detail

getPackageConfig

public PackageConfig getPackageConfig(String name)
Specified by:
getPackageConfig in interface Configuration

getUnknownHandlerStack

public List<UnknownHandlerConfig> getUnknownHandlerStack()
Specified by:
getUnknownHandlerStack in interface Configuration
Returns:
list of unknown handlers

setUnknownHandlerStack

public void setUnknownHandlerStack(List<UnknownHandlerConfig> unknownHandlerStack)
Specified by:
setUnknownHandlerStack in interface Configuration

getPackageConfigNames

public Set<String> getPackageConfigNames()
Specified by:
getPackageConfigNames in interface Configuration

getPackageConfigs

public Map<String,PackageConfig> getPackageConfigs()
Specified by:
getPackageConfigs in interface Configuration

getLoadedFileNames

public Set<String> getLoadedFileNames()
Specified by:
getLoadedFileNames in interface Configuration

getRuntimeConfiguration

public RuntimeConfiguration getRuntimeConfiguration()
Description copied from interface: Configuration
The current runtime configuration. Currently, if changes have been made to the Configuration since the last time buildRuntimeConfiguration() was called, you'll need to make sure to.

Specified by:
getRuntimeConfiguration in interface Configuration
Returns:
the current runtime configuration

getContainer

public Container getContainer()
Specified by:
getContainer in interface Configuration
Returns:
the container

addPackageConfig

public void addPackageConfig(String name,
                             PackageConfig packageContext)
Specified by:
addPackageConfig in interface Configuration

removePackageConfig

public PackageConfig removePackageConfig(String packageName)
Description copied from interface: Configuration
Removes a package from the the list of packages. Changes to the configuration won't take effect until buildRuntimeConfiguration is called.

Specified by:
removePackageConfig in interface Configuration
Parameters:
packageName - the name of the package to remove
Returns:
the package removed (if any)

destroy

public void destroy()
Allows the configuration to clean up any resources used

Specified by:
destroy in interface Configuration

rebuildRuntimeConfiguration

public void rebuildRuntimeConfiguration()
Specified by:
rebuildRuntimeConfiguration in interface Configuration

reload

public void reload(List<ConfigurationProvider> providers)
            throws ConfigurationException
Calls the ConfigurationProviderFactory.getConfig() to tell it to reload the configuration and then calls buildRuntimeConfiguration().

Specified by:
reload in interface Configuration
Throws:
ConfigurationException

reloadContainer

public List<PackageProvider> reloadContainer(List<ContainerProvider> providers)
                                      throws ConfigurationException
Calls the ConfigurationProviderFactory.getConfig() to tell it to reload the configuration and then calls buildRuntimeConfiguration().

Specified by:
reloadContainer in interface Configuration
Throws:
ConfigurationException

setContext

protected ActionContext setContext(Container cont)

createBootstrapContainer

protected Container createBootstrapContainer()

buildRuntimeConfiguration

protected RuntimeConfiguration buildRuntimeConfiguration()
                                                  throws ConfigurationException
This builds the internal runtime configuration used by Xwork for finding and configuring Actions from the programmatic configuration data structures. All of the old runtime configuration will be discarded and rebuilt.

It basically flattens the data structures to make the information easier to access. It will take an ActionConfig and combine its data with all inherited dast. For example, if the ActionConfig is in a package that contains a global result and it also contains a result, the resulting ActionConfig will have two results.

Throws:
ConfigurationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocatableConstantFactory (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.impl
Class LocatableConstantFactory<T>

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.config.impl.LocatableConstantFactory<T>
All Implemented Interfaces:
Factory, Locatable
public class LocatableConstantFactory<T>
extends Located
implements Factory

Factory that remembers where a constant came from

Field Summary
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
LocatableConstantFactory(T constant, Object location)
Method Summary
T | create(Context ignored) Creates an object to be injected.
String | toString()
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

LocatableConstantFactory

public LocatableConstantFactory(T constant,
                                Object location)
Method Detail

create

public T create(Context ignored)
Description copied from interface: Factory
Creates an object to be injected.

Specified by:
create in interface Factory
Parameters:
ignored - of this injection
Returns:
instance to be injected

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocatableFactory (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.impl
Class LocatableFactory<T>

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.config.impl.LocatableFactory<T>
All Implemented Interfaces:
Factory<T>, Locatable
public class LocatableFactory<T>
extends Located
implements Factory<T>

Attaches location information to the factory.

Field Summary
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
LocatableFactory(String name, Class type, Class implementation, Scope scope, Object location)
Method Summary
T | create(Context context) Creates an object to be injected.
String | toString()
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

LocatableFactory

public LocatableFactory(String name,
                        Class type,
                        Class implementation,
                        Scope scope,
                        Object location)
Method Detail

create

public T create(Context context)
Description copied from interface: Factory
Creates an object to be injected.

Specified by:
create in interface Factory<T>
Parameters:
context - of this injection
Returns:
instance to be injected

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MockConfiguration (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.impl
Class MockConfiguration

java.lang.Object
    extended by  com.opensymphony.xwork2.config.impl.MockConfiguration
All Implemented Interfaces:
Configuration, Serializable
public class MockConfiguration
extends Object
implements Configuration

Simple configuration used for unit testing

See Also:
Serialized Form

Field Summary
protected  List<UnknownHandlerConfig> unknownHandlerStack
Constructor Summary
MockConfiguration()
Method Summary
void | addPackageConfig(String name, PackageConfig packageContext)
void | buildRuntimeConfiguration()
void | destroy() Allow the Configuration to clean up any resources that have been used.
Container | getContainer()
Set<String> | getLoadedFileNames()
PackageConfig | getPackageConfig(String name)
Set<String> | getPackageConfigNames()
Map<String,PackageConfig> | getPackageConfigs()
RuntimeConfiguration | getRuntimeConfiguration() The current runtime configuration.
List<UnknownHandlerConfig> | getUnknownHandlerStack()
void | rebuildRuntimeConfiguration()
void | reload(List<ConfigurationProvider> providers)
List<PackageProvider> | reloadContainer(List<ContainerProvider> containerProviders)
PackageConfig | removePackageConfig(String name) Removes a package from the the list of packages.
void | selfRegister()
void | setUnknownHandlerStack(List<UnknownHandlerConfig> unknownHandlerStack)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

unknownHandlerStack

protected List<UnknownHandlerConfig> unknownHandlerStack
Constructor Detail

MockConfiguration

public MockConfiguration()
Method Detail

selfRegister

public void selfRegister()

getPackageConfig

public PackageConfig getPackageConfig(String name)
Specified by:
getPackageConfig in interface Configuration

getPackageConfigNames

public Set<String> getPackageConfigNames()
Specified by:
getPackageConfigNames in interface Configuration

getPackageConfigs

public Map<String,PackageConfig> getPackageConfigs()
Specified by:
getPackageConfigs in interface Configuration

getRuntimeConfiguration

public RuntimeConfiguration getRuntimeConfiguration()
Description copied from interface: Configuration
The current runtime configuration. Currently, if changes have been made to the Configuration since the last time buildRuntimeConfiguration() was called, you'll need to make sure to.

Specified by:
getRuntimeConfiguration in interface Configuration
Returns:
the current runtime configuration

addPackageConfig

public void addPackageConfig(String name,
                             PackageConfig packageContext)
Specified by:
addPackageConfig in interface Configuration

buildRuntimeConfiguration

public void buildRuntimeConfiguration()

destroy

public void destroy()
Description copied from interface: Configuration
Allow the Configuration to clean up any resources that have been used.

Specified by:
destroy in interface Configuration

rebuildRuntimeConfiguration

public void rebuildRuntimeConfiguration()
Specified by:
rebuildRuntimeConfiguration in interface Configuration

reload

public void reload(List<ConfigurationProvider> providers)
            throws ConfigurationException
Specified by:
reload in interface Configuration
Throws:
ConfigurationException

removePackageConfig

public PackageConfig removePackageConfig(String name)
Description copied from interface: Configuration
Removes a package from the the list of packages. Changes to the configuration won't take effect until buildRuntimeConfiguration is called.

Specified by:
removePackageConfig in interface Configuration
Parameters:
name - the name of the package to remove
Returns:
the package removed (if any)

getContainer

public Container getContainer()
Specified by:
getContainer in interface Configuration
Returns:
the container

getLoadedFileNames

public Set<String> getLoadedFileNames()
Specified by:
getLoadedFileNames in interface Configuration

reloadContainer

public List<PackageProvider> reloadContainer(List<ContainerProvider> containerProviders)
                                      throws ConfigurationException
Specified by:
reloadContainer in interface Configuration
Throws:
ConfigurationException

getUnknownHandlerStack

public List<UnknownHandlerConfig> getUnknownHandlerStack()
Specified by:
getUnknownHandlerStack in interface Configuration
Returns:
list of unknown handlers

setUnknownHandlerStack

public void setUnknownHandlerStack(List<UnknownHandlerConfig> unknownHandlerStack)
Specified by:
setUnknownHandlerStack in interface Configuration
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NamespaceMatch (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.impl
Class NamespaceMatch

java.lang.Object
    extended by  com.opensymphony.xwork2.config.impl.NamespaceMatch

public class NamespaceMatch
extends Object

Represents a match from a namespace pattern matching.

Constructor Summary
NamespaceMatch(String pattern, Map<String,String> variables)
Method Summary
String | getPattern()
Map<String,String> | getVariables()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NamespaceMatch

public NamespaceMatch(String pattern,
                      Map<String,String> variables)
Method Detail

getPattern

public String getPattern()
Returns:
The pattern that was matched

getVariables

public Map<String,String> getVariables()
Returns:
The variables containing the matched values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NamespaceMatcher (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.impl
Class NamespaceMatcher

java.lang.Object
    extended by  com.opensymphony.xwork2.config.impl.AbstractMatcher<NamespaceMatch>
        extended by  com.opensymphony.xwork2.config.impl.NamespaceMatcher
All Implemented Interfaces:
Serializable
public class NamespaceMatcher
extends AbstractMatcher<NamespaceMatch>

Matches namespace strings against a wildcard pattern matcher

See Also:
Serialized Form

Constructor Summary
NamespaceMatcher(PatternMatcher<?> patternMatcher, Set<String> namespaces)
Method Summary
protected  NamespaceMatch convert(String path, NamespaceMatch orig, Map<String,String> vars)
Clones the target object and its children, replacing various properties with the values of the wildcard-matched strings.
Methods inherited from class com.opensymphony.xwork2.config.impl.AbstractMatcher
addPattern, convertParam, freeze, match, replaceParameters
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NamespaceMatcher

public NamespaceMatcher(PatternMatcher<?> patternMatcher,
                        Set<String> namespaces)
Method Detail

convert

protected NamespaceMatch convert(String path,
                                 NamespaceMatch orig,
                                 Map<String,String> vars)
Description copied from class: AbstractMatcher

Clones the target object and its children, replacing various properties with the values of the wildcard-matched strings.

Specified by:
convert in class AbstractMatcher<NamespaceMatch>
Parameters:
path - The requested path
orig - The original object
vars - A Map of wildcard-matched strings
Returns:
A cloned object with appropriate properties replaced with wildcard-matched values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.config.impl (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.config.impl
Classes
AbstractMatcher
ActionConfigMatcher
DefaultConfiguration
LocatableConstantFactory
LocatableFactory
MockConfiguration
NamespaceMatch
NamespaceMatcher


com.opensymphony.xwork2.config.impl (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.config.impl

Configuration implementation classes.

See:
Description

Class Summary
AbstractMatcher<E> | Matches patterns against pre-compiled wildcard expressions pulled from target objects.
ActionConfigMatcher | Matches paths against pre-compiled wildcard expressions pulled from action configs.
DefaultConfiguration | DefaultConfiguration
LocatableConstantFactory<T> | Factory that remembers where a constant came from
LocatableFactory<T> | Attaches location information to the factory.
MockConfiguration | Simple configuration used for unit testing
NamespaceMatch | Represents a match from a namespace pattern matching.
NamespaceMatcher | Matches namespace strings against a wildcard pattern matcher

Package com.opensymphony.xwork2.config.impl Description

Configuration implementation classes.


com.opensymphony.xwork2.config.impl Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.config.impl

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.config.impl.AbstractMatcher<E> (implements java.io.Serializable)
      • com.opensymphony.xwork2.config.impl.ActionConfigMatcher (implements java.io.Serializable)
      • com.opensymphony.xwork2.config.impl.NamespaceMatcher
    • com.opensymphony.xwork2.config.impl.DefaultConfiguration (implements com.opensymphony.xwork2.config.Configuration)
    • com.opensymphony.xwork2.util.location.Located (implements com.opensymphony.xwork2.util.location.Locatable)
      • com.opensymphony.xwork2.config.impl.LocatableConstantFactory<T> (implements com.opensymphony.xwork2.inject.Factory<T>)
      • com.opensymphony.xwork2.config.impl.LocatableFactory<T> (implements com.opensymphony.xwork2.inject.Factory<T>)
    • com.opensymphony.xwork2.config.impl.MockConfiguration (implements com.opensymphony.xwork2.config.Configuration)
    • com.opensymphony.xwork2.config.impl.NamespaceMatch


Uses of Package com.opensymphony.xwork2.config.impl (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.config.impl

Packages that use com.opensymphony.xwork2.config.impl
com.opensymphony.xwork2.config.impl Configuration implementation classes.

Classes in com.opensymphony.xwork2.config.impl used by com.opensymphony.xwork2.config.impl
AbstractMatcher
Matches patterns against pre-compiled wildcard expressions pulled from target objects.
NamespaceMatch
Represents a match from a namespace pattern matching.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.impl.AbstractMatcher (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.impl.AbstractMatcher

Packages that use AbstractMatcher
com.opensymphony.xwork2.config.impl Configuration implementation classes.

Uses of AbstractMatcher in com.opensymphony.xwork2.config.impl

Subclasses of AbstractMatcher in com.opensymphony.xwork2.config.impl
class | ActionConfigMatcher Matches paths against pre-compiled wildcard expressions pulled from action configs.
class | NamespaceMatcher Matches namespace strings against a wildcard pattern matcher

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.impl.ActionConfigMatcher (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.impl.ActionConfigMatcher

No usage of com.opensymphony.xwork2.config.impl.ActionConfigMatcher

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.impl.DefaultConfiguration (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.impl.DefaultConfiguration

No usage of com.opensymphony.xwork2.config.impl.DefaultConfiguration

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.impl.LocatableConstantFactory (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.impl.LocatableConstantFactory

No usage of com.opensymphony.xwork2.config.impl.LocatableConstantFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.impl.LocatableFactory (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.impl.LocatableFactory

No usage of com.opensymphony.xwork2.config.impl.LocatableFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.impl.MockConfiguration (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.impl.MockConfiguration

No usage of com.opensymphony.xwork2.config.impl.MockConfiguration

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.impl.NamespaceMatch (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.impl.NamespaceMatch

Packages that use NamespaceMatch
com.opensymphony.xwork2.config.impl Configuration implementation classes.

Uses of NamespaceMatch in com.opensymphony.xwork2.config.impl

Methods in com.opensymphony.xwork2.config.impl that return NamespaceMatch
protected  NamespaceMatch NamespaceMatcher.convert(String path, NamespaceMatch orig, Map<String,String> vars)

Methods in com.opensymphony.xwork2.config.impl with parameters of type NamespaceMatch
protected  NamespaceMatch NamespaceMatcher.convert(String path, NamespaceMatch orig, Map<String,String> vars)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.impl.NamespaceMatcher (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.impl.NamespaceMatcher

No usage of com.opensymphony.xwork2.config.impl.NamespaceMatcher

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


InterceptorBuilder (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.providers
Class InterceptorBuilder

java.lang.Object
    extended by  com.opensymphony.xwork2.config.providers.InterceptorBuilder

public class InterceptorBuilder
extends Object

Builds a list of interceptors referenced by the refName in the supplied PackageConfig.

Version:
$Date: 2008-06-21 11:29:39 +0200 (Sa, 21 Jun 2008) $ $Id: InterceptorBuilder.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Mike, Rainer Hermanns, tmjee

Constructor Summary
InterceptorBuilder()
Method Summary
static List<InterceptorMapping> constructInterceptorReference(InterceptorLocator interceptorLocator, String refName, Map<String,String> refParams, Location location, ObjectFactory objectFactory)
Builds a list of interceptors referenced by the refName in the supplied PackageConfig (InterceptorMapping object).
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InterceptorBuilder

public InterceptorBuilder()
Method Detail

constructInterceptorReference

public static List<InterceptorMapping> constructInterceptorReference(InterceptorLocator interceptorLocator,
                                                                     String refName,
                                                                     Map<String,String> refParams,
                                                                     Location location,
                                                                     ObjectFactory objectFactory)
                                                              throws ConfigurationException
Builds a list of interceptors referenced by the refName in the supplied PackageConfig (InterceptorMapping object).

Parameters:
interceptorLocator -
refName -
refParams -
Returns:
list of interceptors referenced by the refName in the supplied PackageConfig (InterceptorMapping object).
Throws:
ConfigurationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.config.providers (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.config.providers
Classes
InterceptorBuilder
XmlConfigurationProvider
XmlHelper
XWorkConfigurationProvider


com.opensymphony.xwork2.config.providers (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.config.providers

Configuration provider classes.

See:
Description

Class Summary
InterceptorBuilder | Builds a list of interceptors referenced by the refName in the supplied PackageConfig.
XmlConfigurationProvider | Looks in the classpath for an XML file, "xwork.xml" by default, and uses it for the XWork configuration.
XmlHelper | XML utilities.
XWorkConfigurationProvider |

Package com.opensymphony.xwork2.config.providers Description

Configuration provider classes.


com.opensymphony.xwork2.config.providers Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.config.providers

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.config.providers.InterceptorBuilder
    • com.opensymphony.xwork2.config.providers.XmlConfigurationProvider (implements com.opensymphony.xwork2.config.ConfigurationProvider)
    • com.opensymphony.xwork2.config.providers.XmlHelper
    • com.opensymphony.xwork2.config.providers.XWorkConfigurationProvider (implements com.opensymphony.xwork2.config.ConfigurationProvider)


Uses of Package com.opensymphony.xwork2.config.providers (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.config.providers

No usage of com.opensymphony.xwork2.config.providers

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


XmlConfigurationProvider (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.providers
Class XmlConfigurationProvider

java.lang.Object
    extended by  com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
All Implemented Interfaces:
ConfigurationProvider, ContainerProvider, PackageProvider
public class XmlConfigurationProvider
extends Object
implements ConfigurationProvider

Looks in the classpath for an XML file, "xwork.xml" by default, and uses it for the XWork configuration.

Version:
$Revision: 1985 $
Author:
tmjee, Rainer Hermanns, Neo

Constructor Summary
XmlConfigurationProvider()
XmlConfigurationProvider(String filename)
XmlConfigurationProvider(String filename, boolean errorIfMissing)
Method Summary
protected void | addAction(Element actionElement, PackageConfig.Builder packageContext)
protected PackageConfig | addPackage(Element packageElement) Create a PackageConfig from an XML element representing it.
protected void | addResultTypes(PackageConfig.Builder packageContext, Element element)
protected List<ExceptionMappingConfig> | buildExceptionMappings(Element element, PackageConfig.Builder packageContext) Build a map of ResultConfig objects from below a given XML element.
protected List<InterceptorMapping> | buildInterceptorList(Element element, PackageConfig.Builder context)
protected PackageConfig.Builder | buildPackageContext(Element packageElement) This method builds a package context by looking for the parents of this new package.
protected Map<String,ResultConfig> | buildResults(Element element, PackageConfig.Builder packageContext) Build a map of ResultConfig objects from below a given XML element.
void | destroy() Called before removed from the configuration manager
boolean | equals(Object o)
protected Iterator<URL> | getConfigurationUrls(String fileName)
Map<String,String> | getDtdMappings() Returns an unmodifiable map of DTD mappings
protected String | guessResultType(String type)
int | hashCode()
void | init(Configuration configuration) Initializes with the configuration
protected void | loadDefaultActionRef(PackageConfig.Builder packageContext, Element element)
protected void | loadDefaultClassRef(PackageConfig.Builder packageContext, Element element)
protected void | loadDefaultInterceptorRef(PackageConfig.Builder packageContext, Element element)
protected void | loadExtraConfiguration(Document doc) Allows subclasses to load extra information from the document
protected void | loadGlobalResults(PackageConfig.Builder packageContext, Element packageElement) Load all of the global results for this package from the XML element.
protected void | loadGobalExceptionMappings(PackageConfig.Builder packageContext, Element packageElement) Load all of the global results for this package from the XML element.
protected void | loadInterceptors(PackageConfig.Builder context, Element element)
protected InterceptorStackConfig | loadInterceptorStack(Element element, PackageConfig.Builder context)
protected void | loadInterceptorStacks(Element element, PackageConfig.Builder context)
void | loadPackages() Loads the packages for the configuration.
boolean | needsReload() Tells whether the ConfigurationProvider should reload its configuration.
void | register(ContainerBuilder containerBuilder, LocatableProperties props) Registers beans and properties for the Container
void | setDtdMappings(Map<String,String> mappings)
void | setObjectFactory(ObjectFactory objectFactory)
void | setThrowExceptionOnDuplicateBeans(boolean val)
protected boolean | verifyAction(String className, String name, Location loc)
protected Class | verifyResultType(String className, Location loc)
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XmlConfigurationProvider

public XmlConfigurationProvider()

XmlConfigurationProvider

public XmlConfigurationProvider(String filename)

XmlConfigurationProvider

public XmlConfigurationProvider(String filename,
                                boolean errorIfMissing)
Method Detail

setThrowExceptionOnDuplicateBeans

public void setThrowExceptionOnDuplicateBeans(boolean val)

setDtdMappings

public void setDtdMappings(Map<String,String> mappings)

setObjectFactory

public void setObjectFactory(ObjectFactory objectFactory)

getDtdMappings

public Map<String,String> getDtdMappings()
Returns an unmodifiable map of DTD mappings

init

public void init(Configuration configuration)
Description copied from interface: ContainerProvider
Initializes with the configuration

Specified by:
init in interface ContainerProvider
Specified by:
init in interface PackageProvider
Parameters:
configuration - The configuration

destroy

public void destroy()
Description copied from interface: ContainerProvider
Called before removed from the configuration manager

Specified by:
destroy in interface ContainerProvider

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object

register

public void register(ContainerBuilder containerBuilder,
                     LocatableProperties props)
              throws ConfigurationException
Description copied from interface: ContainerProvider
Registers beans and properties for the Container

Specified by:
register in interface ContainerProvider
Parameters:
containerBuilder - The builder to register beans with
props - The properties to register constants with
Throws:
ConfigurationException - If anything goes wrong

loadPackages

public void loadPackages()
                  throws ConfigurationException
Description copied from interface: PackageProvider
Loads the packages for the configuration.

Specified by:
loadPackages in interface PackageProvider
Throws:
ConfigurationException

needsReload

public boolean needsReload()
Tells whether the ConfigurationProvider should reload its configuration. This method should only be called if ConfigurationManager.isReloadingConfigs() is true.

Specified by:
needsReload in interface ContainerProvider
Specified by:
needsReload in interface PackageProvider
Returns:
true if the file has been changed since the last time we read it

addAction

protected void addAction(Element actionElement,
                         PackageConfig.Builder packageContext)
                  throws ConfigurationException
Throws:
ConfigurationException

verifyAction

protected boolean verifyAction(String className,
                               String name,
                               Location loc)

addPackage

protected PackageConfig addPackage(Element packageElement)
                            throws ConfigurationException
Create a PackageConfig from an XML element representing it.

Throws:
ConfigurationException

addResultTypes

protected void addResultTypes(PackageConfig.Builder packageContext,
                              Element element)

verifyResultType

protected Class verifyResultType(String className,
                                 Location loc)

buildInterceptorList

protected List<InterceptorMapping> buildInterceptorList(Element element,
                                                        PackageConfig.Builder context)
                                                 throws ConfigurationException
Throws:
ConfigurationException

buildPackageContext

protected PackageConfig.Builder buildPackageContext(Element packageElement)
This method builds a package context by looking for the parents of this new package.

If no parents are found, it will return a root package.

buildResults

protected Map<String,ResultConfig> buildResults(Element element,
                                                PackageConfig.Builder packageContext)
Build a map of ResultConfig objects from below a given XML element.

guessResultType

protected String guessResultType(String type)

buildExceptionMappings

protected List<ExceptionMappingConfig> buildExceptionMappings(Element element,
                                                              PackageConfig.Builder packageContext)
Build a map of ResultConfig objects from below a given XML element.

loadDefaultInterceptorRef

protected void loadDefaultInterceptorRef(PackageConfig.Builder packageContext,
                                         Element element)

loadDefaultActionRef

protected void loadDefaultActionRef(PackageConfig.Builder packageContext,
                                    Element element)

loadGlobalResults

protected void loadGlobalResults(PackageConfig.Builder packageContext,
                                 Element packageElement)
Load all of the global results for this package from the XML element.

loadDefaultClassRef

protected void loadDefaultClassRef(PackageConfig.Builder packageContext,
                                   Element element)

loadGobalExceptionMappings

protected void loadGobalExceptionMappings(PackageConfig.Builder packageContext,
                                          Element packageElement)
Load all of the global results for this package from the XML element.

loadInterceptorStack

protected InterceptorStackConfig loadInterceptorStack(Element element,
                                                      PackageConfig.Builder context)
                                               throws ConfigurationException
Throws:
ConfigurationException

loadInterceptorStacks

protected void loadInterceptorStacks(Element element,
                                     PackageConfig.Builder context)
                              throws ConfigurationException
Throws:
ConfigurationException

loadInterceptors

protected void loadInterceptors(PackageConfig.Builder context,
                                Element element)
                         throws ConfigurationException
Throws:
ConfigurationException

getConfigurationUrls

protected Iterator<URL> getConfigurationUrls(String fileName)
                                      throws IOException
Throws:
IOException

loadExtraConfiguration

protected void loadExtraConfiguration(Document doc)
Allows subclasses to load extra information from the document

Parameters:
doc - The configuration document
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XmlHelper (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.providers
Class XmlHelper

java.lang.Object
    extended by  com.opensymphony.xwork2.config.providers.XmlHelper

public class XmlHelper
extends Object

XML utilities.

Author:
Mike

Constructor Summary
XmlHelper()
Method Summary
static String | getContent(Element element) This method will return the content of this particular element.
static Integer | getLoadOrder(Document doc) Return the value of the "order" attribute from the root element
static Map<String,String> | getParams(Element paramsElement) This method will find all the parameters under this paramsElement and return them as Map.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XmlHelper

public XmlHelper()
Method Detail

getParams

public static Map<String,String> getParams(Element paramsElement)
This method will find all the parameters under this paramsElement and return them as Map. For example,

      value1
      value2
      value3
will returns a Map with the following key, value pairs :-
  • param1 - value1
  • param2 - value2
  • param3 - value3

Parameters:
paramsElement -
Returns:

getContent

public static String getContent(Element element)
This method will return the content of this particular element. For example,

    something_1
When the Element <result> is passed in as argument (element to this method, it returns the content of it, namely, something_1 in the example above.

Returns:

getLoadOrder

public static Integer getLoadOrder(Document doc)
Return the value of the "order" attribute from the root element

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkConfigurationProvider (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.providers
Class XWorkConfigurationProvider

java.lang.Object
    extended by  com.opensymphony.xwork2.config.providers.XWorkConfigurationProvider
All Implemented Interfaces:
ConfigurationProvider, ContainerProvider, PackageProvider
public class XWorkConfigurationProvider
extends Object
implements ConfigurationProvider

Constructor Summary
XWorkConfigurationProvider()
Method Summary
void | destroy() Called before removed from the configuration manager
void | init(Configuration configuration) Initializes with the configuration
void | loadPackages() Loads the packages for the configuration.
boolean | needsReload() Tells whether the ContainerProvider should reload its configuration
void | register(ContainerBuilder builder, LocatableProperties props) Registers beans and properties for the Container
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XWorkConfigurationProvider

public XWorkConfigurationProvider()
Method Detail

destroy

public void destroy()
Description copied from interface: ContainerProvider
Called before removed from the configuration manager

Specified by:
destroy in interface ContainerProvider

init

public void init(Configuration configuration)
          throws ConfigurationException
Description copied from interface: ContainerProvider
Initializes with the configuration

Specified by:
init in interface ContainerProvider
Specified by:
init in interface PackageProvider
Parameters:
configuration - The configuration
Throws:
ConfigurationException - If anything goes wrong

loadPackages

public void loadPackages()
                  throws ConfigurationException
Description copied from interface: PackageProvider
Loads the packages for the configuration.

Specified by:
loadPackages in interface PackageProvider
Throws:
ConfigurationException

needsReload

public boolean needsReload()
Description copied from interface: ContainerProvider
Tells whether the ContainerProvider should reload its configuration

Specified by:
needsReload in interface ContainerProvider
Specified by:
needsReload in interface PackageProvider
Returns:
true, whether the ContainerProvider should reload its configuration, falseotherwise.

register

public void register(ContainerBuilder builder,
                     LocatableProperties props)
              throws ConfigurationException
Description copied from interface: ContainerProvider
Registers beans and properties for the Container

Specified by:
register in interface ContainerProvider
Parameters:
builder - The builder to register beans with
props - The properties to register constants with
Throws:
ConfigurationException - If anything goes wrong
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.opensymphony.xwork2.config.providers.InterceptorBuilder (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.providers.InterceptorBuilder

No usage of com.opensymphony.xwork2.config.providers.InterceptorBuilder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

No usage of com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.providers.XmlHelper (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.providers.XmlHelper

No usage of com.opensymphony.xwork2.config.providers.XmlHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.providers.XWorkConfigurationProvider (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.config.providers.XWorkConfigurationProvider

No usage of com.opensymphony.xwork2.config.providers.XWorkConfigurationProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


NullHandler (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.conversion
Interface NullHandler

All Known Implementing Classes:
InstantiatingNullHandler
public interface NullHandler

Interface for handling null results from Chains. Object has the opportunity to substitute an object for the null and continue.

Author:
Luke Blanshard (blanshlu@netscape.net), Drew Davidson (drew@ognl.org)

Method Summary
Object | nullMethodResult(Map<String,Object> context, Object target, String methodName, Object[] args) Method called on target returned null.
Object | nullPropertyValue(Map<String,Object> context, Object target, Object property) Property in target evaluated to null.

Method Detail

nullMethodResult

Object nullMethodResult(Map<String,Object> context,
                        Object target,
                        String methodName,
                        Object[] args)
Method called on target returned null.

nullPropertyValue

Object nullPropertyValue(Map<String,Object> context,
                         Object target,
                         Object property)
Property in target evaluated to null. Property can be a constant String property name or a DynamicSubscript.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ObjectTypeDeterminer (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.conversion
Interface ObjectTypeDeterminer

All Known Implementing Classes:
DefaultObjectTypeDeterminer, GenericsObjectTypeDeterminer, MockObjectTypeDeterminer
public interface ObjectTypeDeterminer

Determines what the key and and element class of a Map or Collection should be. For Maps, the elements are the values. For Collections, the elements are the elements of the collection.

See the implementations for javadoc description for the methods as they are dependent on the concrete implementation.

Author:
Gabriel Zimmerman

Method Summary
Class | getElementClass(Class parentClass, String property, Object key)
Class | getKeyClass(Class parentClass, String property)
String | getKeyProperty(Class parentClass, String property)
boolean | shouldCreateIfNew(Class parentClass, String property, Object target, String keyProperty, boolean isIndexAccessed)

Method Detail

getKeyClass

Class getKeyClass(Class parentClass,
                  String property)

getElementClass

Class getElementClass(Class parentClass,
                      String property,
                      Object key)

getKeyProperty

String getKeyProperty(Class parentClass,
                      String property)

shouldCreateIfNew

boolean shouldCreateIfNew(Class parentClass,
                          String property,
                          Object target,
                          String keyProperty,
                          boolean isIndexAccessed)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.conversion (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.conversion
Interfaces
NullHandler
ObjectTypeDeterminer
TypeConverter
Exceptions
TypeConversionException


com.opensymphony.xwork2.conversion (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.conversion

Interface Summary
NullHandler | Interface for handling null results from Chains.
ObjectTypeDeterminer | Determines what the key and and element class of a Map or Collection should be.
TypeConverter | Interface for accessing the type conversion facilities within a context.

Exception Summary
TypeConversionException TypeConversionException should be thrown by any TypeConverters which fail to convert values


com.opensymphony.xwork2.conversion Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.conversion

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.opensymphony.xwork2.XWorkException (implements com.opensymphony.xwork2.util.location.Locatable)
            • com.opensymphony.xwork2.conversion.TypeConversionException

Interface Hierarchy

  • com.opensymphony.xwork2.conversion.NullHandler
  • com.opensymphony.xwork2.conversion.ObjectTypeDeterminer
  • com.opensymphony.xwork2.conversion.TypeConverter


Uses of Package com.opensymphony.xwork2.conversion (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.conversion

Packages that use com.opensymphony.xwork2.conversion
com.opensymphony.xwork2.conversion.impl |
com.opensymphony.xwork2.mock | XWork specific mock classes.
com.opensymphony.xwork2.ognl |
com.opensymphony.xwork2.ognl.accessor |

Classes in com.opensymphony.xwork2.conversion used by com.opensymphony.xwork2.conversion.impl
NullHandler
Interface for handling null results from Chains.
ObjectTypeDeterminer
Determines what the key and and element class of a Map or Collection should be.
TypeConverter
Interface for accessing the type conversion facilities within a context.

Classes in com.opensymphony.xwork2.conversion used by com.opensymphony.xwork2.mock
ObjectTypeDeterminer
Determines what the key and and element class of a Map or Collection should be.

Classes in com.opensymphony.xwork2.conversion used by com.opensymphony.xwork2.ognl
NullHandler
Interface for handling null results from Chains.
TypeConverter
Interface for accessing the type conversion facilities within a context.

Classes in com.opensymphony.xwork2.conversion used by com.opensymphony.xwork2.ognl.accessor
ObjectTypeDeterminer
Determines what the key and and element class of a Map or Collection should be.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


TypeConversionException (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.conversion
Class TypeConversionException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  com.opensymphony.xwork2.XWorkException
                    extended by  com.opensymphony.xwork2.conversion.TypeConversionException
All Implemented Interfaces:
Locatable, Serializable
public class TypeConversionException
extends XWorkException

TypeConversionException should be thrown by any TypeConverters which fail to convert values

Author:
Jason Carreira Created Oct 3, 2003 12:18:33 AM
See Also:
Serialized Form

Constructor Summary
TypeConversionException()
Constructs a XWorkException with no detail message.
TypeConversionException(String s)
Constructs a XWorkException with the specified detail message.
TypeConversionException(String s, Throwable cause)
Constructs a XWorkException with the specified detail message.
TypeConversionException(Throwable cause)
Constructs a XWorkException with no detail message.
Method Summary
Methods inherited from class com.opensymphony.xwork2.XWorkException
getLocation, getThrowable, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TypeConversionException

public TypeConversionException()
Constructs a XWorkException with no detail message.

TypeConversionException

public TypeConversionException(String s)
Constructs a XWorkException with the specified detail message.

Parameters:
s - the detail message.

TypeConversionException

public TypeConversionException(Throwable cause)
Constructs a XWorkException with no detail message.

TypeConversionException

public TypeConversionException(String s,
                               Throwable cause)
Constructs a XWorkException with the specified detail message.

Parameters:
s - the detail message.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TypeConverter (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.conversion
Interface TypeConverter

All Known Implementing Classes:
AnnotationXWorkConverter, DefaultTypeConverter, EnumTypeConverter, XWorkBasicConverter, XWorkConverter, XWorkTypeConverterWrapper
public interface TypeConverter

Interface for accessing the type conversion facilities within a context. This interface was copied from OGNL's TypeConverter

Author:
Luke Blanshard (blanshlu@netscape.net), Drew Davidson (drew@ognl.org)

Field Summary
static Object | NO_CONVERSION_POSSIBLE
static String | TYPE_CONVERTER_CONTEXT_KEY
Method Summary
 Object convertValue(Map<String,Object> context, Object target, Member member, String propertyName, Object value, Class toType)
Converts the given value to a given type.

Field Detail

NO_CONVERSION_POSSIBLE

static final Object NO_CONVERSION_POSSIBLE

TYPE_CONVERTER_CONTEXT_KEY

static final String TYPE_CONVERTER_CONTEXT_KEY
See Also:
Constant Field Values
Method Detail

convertValue

Object convertValue(Map<String,Object> context,
                    Object target,
                    Member member,
                    String propertyName,
                    Object value,
                    Class toType)
Converts the given value to a given type. The OGNL context, target, member and name of property being set are given. This method should be able to handle conversion in general without any context, target, member or property name specified.

Parameters:
context - context under which the conversion is being done
target - target object in which the property is being set
member - member (Constructor, Method or Field) being set
propertyName - property name being set
value - value to be converted
toType - type to which value is converted
Returns:
Converted value of type toType or TypeConverter.NoConversionPossible to indicate that the conversion was not possible.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Conversion (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

com.opensymphony.xwork2.conversion.annotations
Annotation Type Conversion

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Conversion

A marker annotation for type conversions at Type level.

Annotation usage:

The Conversion annotation must be applied at Type level.

Annotation parameters:

Parameter | Required | Default | Description
conversion | no |  | used for Type Conversions applied at Type level.

Example code:

 @Conversion()
 public class ConversionAction implements Action {
 }

Version:
$Id: Conversion.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns

Optional Element Summary
 TypeConversion[] conversions
Allow Type Conversions being applied at Type level.

conversions

public abstract TypeConversion[] conversions
Allow Type Conversions being applied at Type level.

Default:
{}
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT


ConversionRule (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.opensymphony.xwork2.conversion.annotations
Enum ConversionRule

java.lang.Object
    extended by  java.lang.Enum<ConversionRule>
        extended by  com.opensymphony.xwork2.conversion.annotations.ConversionRule
All Implemented Interfaces:
Serializable, Comparable<ConversionRule>
public enum ConversionRule
extends Enum<ConversionRule>

ConversionRule

Version:
$Id: ConversionRule.java 1063 2006-07-10 00:30:29Z mrdon $
Author:
Rainer Hermanns

Enum Constant Summary
COLLECTION
CREATE_IF_NULL
ELEMENT
KEY
KEY_PROPERTY
MAP
PROPERTY
Method Summary
String | toString()
static ConversionRule | valueOf(String name) Returns the enum constant of this type with the specified name.
static ConversionRule[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

PROPERTY

public static final ConversionRule PROPERTY

COLLECTION

public static final ConversionRule COLLECTION

MAP

public static final ConversionRule MAP

KEY

public static final ConversionRule KEY

KEY_PROPERTY

public static final ConversionRule KEY_PROPERTY

ELEMENT

public static final ConversionRule ELEMENT

CREATE_IF_NULL

public static final ConversionRule CREATE_IF_NULL
Method Detail

values

public static ConversionRule[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (ConversionRule c : ConversionRule.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static ConversionRule valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
NullPointerException - if the argument is null

toString

public String toString()
Overrides:
toString in class Enum<ConversionRule>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


ConversionType (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.opensymphony.xwork2.conversion.annotations
Enum ConversionType

java.lang.Object
    extended by  java.lang.Enum<ConversionType>
        extended by  com.opensymphony.xwork2.conversion.annotations.ConversionType
All Implemented Interfaces:
Serializable, Comparable<ConversionType>
public enum ConversionType
extends Enum<ConversionType>

ConversionType

Version:
$Id: ConversionType.java 1063 2006-07-10 00:30:29Z mrdon $
Author:
Rainer Hermanns

Enum Constant Summary
APPLICATION
CLASS
Method Summary
String | toString()
static ConversionType | valueOf(String name) Returns the enum constant of this type with the specified name.
static ConversionType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

APPLICATION

public static final ConversionType APPLICATION

CLASS

public static final ConversionType CLASS
Method Detail

values

public static ConversionType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (ConversionType c : ConversionType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static ConversionType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
NullPointerException - if the argument is null

toString

public String toString()
Overrides:
toString in class Enum<ConversionType>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


com.opensymphony.xwork2.conversion.annotations (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.conversion.annotations
Enums
ConversionRule
ConversionType
Annotation Types
Conversion
TypeConversion


com.opensymphony.xwork2.conversion.annotations (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.conversion.annotations

Type conversion annotations.

See:
Description

Enum Summary
ConversionRule | ConversionRule
ConversionType | ConversionType

Annotation Types Summary
Conversion | A marker annotation for type conversions at Type level.
TypeConversion | This annotation is used for class and application wide conversion rules.

Package com.opensymphony.xwork2.conversion.annotations Description

Type conversion annotations.


com.opensymphony.xwork2.conversion.annotations Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.conversion.annotations

Package Hierarchies:
All Packages

Annotation Type Hierarchy

  • com.opensymphony.xwork2.conversion.annotations.TypeConversion (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.conversion.annotations.Conversion (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.opensymphony.xwork2.conversion.annotations.ConversionType
      • com.opensymphony.xwork2.conversion.annotations.ConversionRule


Uses of Package com.opensymphony.xwork2.conversion.annotations (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.conversion.annotations

Packages that use com.opensymphony.xwork2.conversion.annotations
com.opensymphony.xwork2.conversion.annotations Type conversion annotations.

Classes in com.opensymphony.xwork2.conversion.annotations used by com.opensymphony.xwork2.conversion.annotations
ConversionRule
ConversionRule
ConversionType
ConversionType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


TypeConversion (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

com.opensymphony.xwork2.conversion.annotations
Annotation Type TypeConversion

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface TypeConversion

This annotation is used for class and application wide conversion rules.

Class wide conversion:
The conversion rules will be assembled in a file called XXXAction-conversion.properties within the same package as the related action class. Set type to: type = ConversionType.CLASS

Allication wide conversion:
The conversion rules will be assembled within the xwork-conversion.properties file within the classpath root. Set type to: type = ConversionType.APPLICATION

Annotation usage: The TypeConversion annotation can be applied at property and method level.

Annotation parameters:

Parameter | Required | Default | Description
key | no | The annotated property/key name | The optional property name mostly used within TYPE level annotations.
type | no | ConversionType.CLASS | Enum value of ConversionType. Determines whether the conversion should be applied at application or class level.
rule | no | ConversionRule.PROPERTY | Enum value of ConversionRule. The ConversionRule can be a property, a Collection or a Map.
converter | either this or value |  | The class name of the TypeConverter to be used as converter.
value | either converter or this |  | The value to set for ConversionRule.KEY_PROPERTY.

Example code:

 @Conversion()
 public class ConversionAction implements Action {

   private String convertInt;

   private String convertDouble;
   private List users = null;

   private HashMap keyValues = null;

   @TypeConversion(type = ConversionType.APPLICATION, converter = "com.opensymphony.xwork2.util.XWorkBasicConverter")
   public void setConvertInt( String convertInt ) {
       this.convertInt = convertInt;
   }

   @TypeConversion(converter = "com.opensymphony.xwork2.util.XWorkBasicConverter")
   public void setConvertDouble( String convertDouble ) {
       this.convertDouble = convertDouble;
   }

   @TypeConversion(rule = ConversionRule.COLLECTION, converter = "java.util.String")
   public void setUsers( List users ) {
       this.users = users;
   }

   @TypeConversion(rule = ConversionRule.MAP, converter = "java.math.BigInteger")
   public void setKeyValues( HashMap keyValues ) {
       this.keyValues = keyValues;
   }

   @TypeConversion(type = ConversionType.APPLICATION, property = "java.util.Date", converter = "com.opensymphony.xwork2.util.XWorkBasicConverter")
   public String execute() throws Exception {
       return SUCCESS;
   }
 }

Version:
$Id: TypeConversion.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns

Optional Element Summary
String | converter The class of the TypeConverter to be used as converter.
String | key The optional key name used within TYPE level annotations.
ConversionRule | rule The ConversionRule can be a PROPERTY, KEY, KEY_PROPERTY, ELEMENT, COLLECTION (deprecated) or a MAP.
ConversionType | type The ConversionType can be either APPLICATION or CLASS.
String | value If used with ConversionRule.KEY_PROPERTY specify a value here! Note: If you use ConversionType.APPLICATION, you can not set a value!

key

public abstract String key
The optional key name used within TYPE level annotations. Defaults to the property name.

Default:
""

type

public abstract ConversionType type
The ConversionType can be either APPLICATION or CLASS. Defaults to CLASS. Note: If you use ConversionType.APPLICATION, you can not set a value!

Default:
com.opensymphony.xwork2.conversion.annotations.ConversionType.CLASS

rule

public abstract ConversionRule rule
The ConversionRule can be a PROPERTY, KEY, KEY_PROPERTY, ELEMENT, COLLECTION (deprecated) or a MAP. Note: Collection and Map vonversion rules can be determined via com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer.

See Also:
DefaultObjectTypeDeterminer
Default:
com.opensymphony.xwork2.conversion.annotations.ConversionRule.PROPERTY

converter

public abstract String converter
The class of the TypeConverter to be used as converter. Note: This can not be used with ConversionRule.KEY_PROPERTY!

Default:
""

value

public abstract String value
If used with ConversionRule.KEY_PROPERTY specify a value here! Note: If you use ConversionType.APPLICATION, you can not set a value!

Default:
""
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT


Uses of Class com.opensymphony.xwork2.conversion.annotations.Conversion (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.conversion.annotations.Conversion

No usage of com.opensymphony.xwork2.conversion.annotations.Conversion

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.conversion.annotations.ConversionRule (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.conversion.annotations.ConversionRule

Packages that use ConversionRule
com.opensymphony.xwork2.conversion.annotations Type conversion annotations.

Uses of ConversionRule in com.opensymphony.xwork2.conversion.annotations

Methods in com.opensymphony.xwork2.conversion.annotations that return ConversionRule
static ConversionRule | ConversionRule.valueOf(String name) Returns the enum constant of this type with the specified name.
static ConversionRule[] | ConversionRule.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.conversion.annotations.ConversionType (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.conversion.annotations.ConversionType

Packages that use ConversionType
com.opensymphony.xwork2.conversion.annotations Type conversion annotations.

Uses of ConversionType in com.opensymphony.xwork2.conversion.annotations

Methods in com.opensymphony.xwork2.conversion.annotations that return ConversionType
static ConversionType | ConversionType.valueOf(String name) Returns the enum constant of this type with the specified name.
static ConversionType[] | ConversionType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.conversion.annotations.TypeConversion (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.conversion.annotations.TypeConversion

No usage of com.opensymphony.xwork2.conversion.annotations.TypeConversion

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.conversion.NullHandler (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.conversion.NullHandler

Packages that use NullHandler
com.opensymphony.xwork2.conversion.impl
com.opensymphony.xwork2.ognl

Uses of NullHandler in com.opensymphony.xwork2.conversion.impl

Classes in com.opensymphony.xwork2.conversion.impl that implement NullHandler
 class InstantiatingNullHandler
Provided that the key ReflectionContextState.CREATE_NULL_OBJECTS is in the action context with a value of true (this key is set only during the execution of the ParametersInterceptor), OGNL expressions that have caused a NullPointerException will be temporarily stopped for evaluation while the system automatically tries to solve the null references by automatically creating the object.

Uses of NullHandler in com.opensymphony.xwork2.ognl

Constructors in com.opensymphony.xwork2.ognl with parameters of type NullHandler
OgnlNullHandlerWrapper(NullHandler target)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.conversion.ObjectTypeDeterminer (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.conversion.ObjectTypeDeterminer

Packages that use ObjectTypeDeterminer
com.opensymphony.xwork2.conversion.impl |
com.opensymphony.xwork2.mock | XWork specific mock classes.
com.opensymphony.xwork2.ognl.accessor |

Uses of ObjectTypeDeterminer in com.opensymphony.xwork2.conversion.impl

Classes in com.opensymphony.xwork2.conversion.impl that implement ObjectTypeDeterminer
class | DefaultObjectTypeDeterminer This ObjectTypeDeterminer looks at the Class-conversion.properties for entries that indicated what objects are contained within Maps and Collections.
class | GenericsObjectTypeDeterminer Deprecated. Use DefaultObjectTypeDeterminer instead. Since XWork 2.0.4 the DefaultObjectTypeDeterminer handles the annotation processing.

Methods in com.opensymphony.xwork2.conversion.impl with parameters of type ObjectTypeDeterminer
void | XWorkBasicConverter.setObjectTypeDeterminer(ObjectTypeDeterminer det)
void | InstantiatingNullHandler.setObjectTypeDeterminer(ObjectTypeDeterminer det)

Uses of ObjectTypeDeterminer in com.opensymphony.xwork2.mock

Classes in com.opensymphony.xwork2.mock that implement ObjectTypeDeterminer
 class MockObjectTypeDeterminer
Mocks the function of an ObjectTypeDeterminer for testing purposes.

Uses of ObjectTypeDeterminer in com.opensymphony.xwork2.ognl.accessor

Methods in com.opensymphony.xwork2.ognl.accessor with parameters of type ObjectTypeDeterminer
void | XWorkMapPropertyAccessor.setObjectTypeDeterminer(ObjectTypeDeterminer ot)
void | XWorkListPropertyAccessor.setObjectTypeDeterminer(ObjectTypeDeterminer ot)
void | XWorkCollectionPropertyAccessor.setObjectTypeDeterminer(ObjectTypeDeterminer ot)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.conversion.TypeConversionException (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.conversion.TypeConversionException

No usage of com.opensymphony.xwork2.conversion.TypeConversionException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.conversion.TypeConverter (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.conversion.TypeConverter

Packages that use TypeConverter
com.opensymphony.xwork2.conversion.impl
com.opensymphony.xwork2.ognl

Uses of TypeConverter in com.opensymphony.xwork2.conversion.impl

Classes in com.opensymphony.xwork2.conversion.impl that implement TypeConverter
class | AnnotationXWorkConverter Deprecated. Since XWork 2.0.4, the implementation of XWorkConverter handles the processing of annotations.
class | DefaultTypeConverter Default type conversion.
class | EnumTypeConverter Deprecated. Since Struts 2.1.0 as enum support is now built into XWork
class | XWorkBasicConverter XWork will automatically handle the most common type conversion for you.
class | XWorkConverter XWorkConverter is a singleton used by many of the Struts 2's Ognl extention points, such as InstantiatingNullHandler, XWorkListPropertyAccessor etc to do object conversion.

Fields in com.opensymphony.xwork2.conversion.impl with type parameters of type TypeConverter
protected  HashMap<String,TypeConverter> XWorkConverter.defaultMappings
Record class and its type converter mapping.

Methods in com.opensymphony.xwork2.conversion.impl that return TypeConverter
TypeConverter | DefaultTypeConverter.getTypeConverter(Map<String,Object> context)
TypeConverter | XWorkConverter.lookup(Class clazz) Looks for a TypeConverter in the default mappings.
TypeConverter | XWorkConverter.lookup(String className) Looks for a TypeConverter in the default mappings.

Methods in com.opensymphony.xwork2.conversion.impl with parameters of type TypeConverter
 void XWorkConverter.registerConverter(String className, TypeConverter converter)

Uses of TypeConverter in com.opensymphony.xwork2.ognl

Classes in com.opensymphony.xwork2.ognl that implement TypeConverter
 class XWorkTypeConverterWrapper
Wraps an OGNL TypeConverter as an XWork TypeConverter

Methods in com.opensymphony.xwork2.ognl that return TypeConverter
 TypeConverter OgnlTypeConverterWrapper.getTarget()

Constructors in com.opensymphony.xwork2.ognl with parameters of type TypeConverter
OgnlTypeConverterWrapper(TypeConverter conv)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AnnotationXWorkConverter (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.conversion.impl
Class AnnotationXWorkConverter

java.lang.Object
    extended by  com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
        extended by  com.opensymphony.xwork2.conversion.impl.XWorkConverter
            extended by  com.opensymphony.xwork2.conversion.impl.AnnotationXWorkConverter
All Implemented Interfaces:
TypeConverter
Deprecated. Since XWork 2.0.4, the implementation of XWorkConverter handles the processing of annotations.

@Deprecated
public class AnnotationXWorkConverter
extends XWorkConverter

Type conversion is great for situations where you need to turn a String in to a more complex object. Because the web is type-agnostic (everything is a string in HTTP), XWork's type conversion features are very useful. For instance, if you were prompting a user to enter in coordinates in the form of a string (such as "3, 22"), you could have XWork do the conversion both from String to Point and from Point to String.

Using this "point" example, if your action (or another compound object in which you are setting properties on) has a corresponding ClassName-conversion.properties file, XWork will use the configured type converters for conversion to and from strings. So turning "3, 22" in to new Point(3, 22) is done by merely adding the following entry to ClassName-conversion.properties (Note that the PointConverter should impl the TypeConverter interface):

point = com.acme.PointConverter

Your type converter should be sure to check what class type it is being requested to convert. Because it is used for both to and from strings, you will need to split the conversion method in to two parts: one that turns Strings in to Points, and one that turns Points in to Strings.

After this is done, you can now reference your point (using <ww:property value="post"/> in JSP or ${point} in FreeMarker) and it will be printed as "3, 22" again. As such, if you submit this back to an action, it will be converted back to a Point once again.

In some situations you may wish to apply a type converter globally. This can be done by editing the file xwork-conversion.properties in the root of your class path (typically WEB-INF/classes) and providing a property in the form of the class name of the object you wish to convert on the left hand side and the class name of the type converter on the right hand side. For example, providing a type converter for all Point objects would mean adding the following entry:

com.acme.Point = com.acme.PointConverter

Type conversion should not be used as a substitute for i18n. It is not recommended to use this feature to print out properly formatted dates. Rather, you should use the i18n features of XWork (and consult the JavaDocs for JDK's MessageFormat object) to see how a properly formatted date should be displayed.

Any error that occurs during type conversion may or may not wish to be reported. For example, reporting that the input "abc" could not be converted to a number might be important. On the other hand, reporting that an empty string, "", cannot be converted to a number might not be important - especially in a web environment where it is hard to distinguish between a user not entering a value vs. entering a blank value.

By default, all conversion errors are reported using the generic i18n key xwork.default.invalid.fieldvalue, which you can override (the default text is Invalid field value for field "xxx", where xxx is the field name) in your global i18n resource bundle.

However, sometimes you may wish to override this message on a per-field basis. You can do this by adding an i18n key associated with just your action (Action.properties) using the pattern invalid.fieldvalue.xxx, where xxx is the field name.

It is important to know that none of these errors are actually reported directly. Rather, they are added to a map called conversionErrors in the ActionContext. There are several ways this map can then be accessed and the errors can be reported accordingly.

Author:
Pat Lightbody, Rainer Hermanns
See Also:
XWorkConverter

Field Summary
Fields inherited from class com.opensymphony.xwork2.conversion.impl.XWorkConverter
CONVERSION_COLLECTION_PREFIX, CONVERSION_ERROR_PROPERTY_PREFIX, CONVERSION_PROPERTY_FULLNAME, defaultMappings, LAST_BEAN_CLASS_ACCESSED, LAST_BEAN_PROPERTY_ACCESSED, LOG, mappings, MESSAGE_INDEX_BRACKET_PATTERN, MESSAGE_INDEX_PATTERN, messageIndexPattern, noMapping, PERIOD, REPORT_CONVERSION_ERRORS, unknownMappings
Fields inherited from interface com.opensymphony.xwork2.conversion.TypeConverter
NO_CONVERSION_POSSIBLE, TYPE_CONVERTER_CONTEXT_KEY
Constructor Summary
AnnotationXWorkConverter()
Deprecated.
Method Summary
Methods inherited from class com.opensymphony.xwork2.conversion.impl.XWorkConverter
addConverterMapping, buildConverterFilename, buildConverterMapping, convertValue, convertValue, getConversionErrorMessage, getConverter, handleConversionException, loadConversionProperties, loadConversionProperties, lookup, lookup, registerConverter, registerConverterNotFound, setDefaultTypeConverter, setObjectFactory
Methods inherited from class com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
bigDecValue, bigIntValue, booleanValue, convertValue, doubleValue, enumValue, getTypeConverter, longValue, stringValue, stringValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AnnotationXWorkConverter

public AnnotationXWorkConverter()
Deprecated.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DefaultObjectTypeDeterminer (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.conversion.impl
Class DefaultObjectTypeDeterminer

java.lang.Object
    extended by  com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer
All Implemented Interfaces:
ObjectTypeDeterminer
Direct Known Subclasses:
GenericsObjectTypeDeterminer
public class DefaultObjectTypeDeterminer
extends Object
implements ObjectTypeDeterminer

This ObjectTypeDeterminer looks at the Class-conversion.properties for entries that indicated what objects are contained within Maps and Collections. For Collections, such as Lists, the element is specified using the pattern Element_xxx, where xxx is the field name of the collection property in your action or object. For Maps, both the key and the value may be specified by using the pattern Key_xxx and Element_xxx, respectively.

From WebWork 2.1.x, the Collection_xxx format is still supported and honored, although it is deprecated and will be removed eventually.

Author:
Gabriel Zimmerman

Field Summary
static String | CREATE_IF_NULL_PREFIX
static String | DEPRECATED_ELEMENT_PREFIX
static String | ELEMENT_PREFIX
static String | KEY_PREFIX
static String | KEY_PROPERTY_PREFIX
protected static Logger | LOG
Constructor Summary
DefaultObjectTypeDeterminer(XWorkConverter conv, ReflectionProvider prov)
Method Summary
protected
<T extends Annotation>
T
getAnnotation(Class parentClass, String property, Class<T> annotationClass)
Retrieves an annotation for the specified property of field, setter or getter.
 Class getElementClass(Class parentClass, String property, Object key)
Determines the element class by looking for the value of @Element annotation for the given class.
 Class getKeyClass(Class parentClass, String property)
Determines the key class by looking for the value of @Key annotation for the given class.
 String getKeyProperty(Class parentClass, String property)
Determines the key property for a Collection by getting it from the @KeyProperty annotation.
 boolean shouldCreateIfNew(Class parentClass, String property, Object target, String keyProperty, boolean isIndexAccessed)
Determines the createIfNull property for a Collection or Map by getting it from the @CreateIfNull annotation.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

protected static final Logger LOG

KEY_PREFIX

public static final String KEY_PREFIX
See Also:
Constant Field Values

ELEMENT_PREFIX

public static final String ELEMENT_PREFIX
See Also:
Constant Field Values

KEY_PROPERTY_PREFIX

public static final String KEY_PROPERTY_PREFIX
See Also:
Constant Field Values

CREATE_IF_NULL_PREFIX

public static final String CREATE_IF_NULL_PREFIX
See Also:
Constant Field Values

DEPRECATED_ELEMENT_PREFIX

public static final String DEPRECATED_ELEMENT_PREFIX
See Also:
Constant Field Values
Constructor Detail

DefaultObjectTypeDeterminer

public DefaultObjectTypeDeterminer(XWorkConverter conv,
                                   ReflectionProvider prov)
Method Detail

getKeyClass

public Class getKeyClass(Class parentClass,
                         String property)
Determines the key class by looking for the value of @Key annotation for the given class. If no annotation is found, the key class is determined by using the generic parametrics. As fallback, it determines the key class by looking for the value of Key_${property} in the properties file for the given class.

Specified by:
getKeyClass in interface ObjectTypeDeterminer
Parameters:
parentClass - the Class which contains as a property the Map or Collection we are finding the key for.
property - the property of the Map or Collection for the given parent class
See Also:
ObjectTypeDeterminer.getKeyClass(Class, String)

getElementClass

public Class getElementClass(Class parentClass,
                             String property,
                             Object key)
Determines the element class by looking for the value of @Element annotation for the given class. If no annotation is found, the element class is determined by using the generic parametrics. As fallback, it determines the key class by looking for the value of Element_${property} in the properties file for the given class. Also looks for the deprecated Collection_${property}

Specified by:
getElementClass in interface ObjectTypeDeterminer
Parameters:
parentClass - the Class which contains as a property the Map or Collection we are finding the key for.
property - the property of the Map or Collection for the given parent class
See Also:
ObjectTypeDeterminer.getElementClass(Class, String, Object)

getKeyProperty

public String getKeyProperty(Class parentClass,
                             String property)
Determines the key property for a Collection by getting it from the @KeyProperty annotation. As fallback, it determines the String key property for a Collection by getting it from the conversion properties file using the KeyProperty_ prefix. KeyProperty_${property}=somePropertyOfBeansInTheSet

Specified by:
getKeyProperty in interface ObjectTypeDeterminer
Parameters:
parentClass - the Class which contains as a property the Map or Collection we are finding the key for.
property - the property of the Map or Collection for the given parent class
See Also:
ObjectTypeDeterminer.getKeyProperty(Class, String)

shouldCreateIfNew

public boolean shouldCreateIfNew(Class parentClass,
                                 String property,
                                 Object target,
                                 String keyProperty,
                                 boolean isIndexAccessed)
Determines the createIfNull property for a Collection or Map by getting it from the @CreateIfNull annotation. As fallback, it determines the boolean CreateIfNull property for a Collection or Map by getting it from the conversion properties file using the CreateIfNull_ prefix. CreateIfNull_${property}=true|false

Specified by:
shouldCreateIfNew in interface ObjectTypeDeterminer
Parameters:
parentClass - the Class which contains as a property the Map or Collection we are finding the key for.
property - the property of the Map or Collection for the given parent class
target - the target object
keyProperty - the keyProperty value
isIndexAccessed - true, if the collection or map is accessed via index, false otherwise.
Returns:
true, if the Collection or Map should be created, false otherwise.
See Also:
ObjectTypeDeterminer.getKeyProperty(Class, String)

getAnnotation

protected <T extends Annotation> T getAnnotation(Class parentClass,
                                                 String property,
                                                 Class<T> annotationClass)
Retrieves an annotation for the specified property of field, setter or getter.

Type Parameters:
T - the annotation type to be retrieved
Parameters:
parentClass - the class
property - the property
annotationClass - the annotation
Returns:
the field or setter/getter annotation or null if not found
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultTypeConverter (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.conversion.impl
Class DefaultTypeConverter

java.lang.Object
    extended by  com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
All Implemented Interfaces:
TypeConverter
Direct Known Subclasses:
EnumTypeConverter, XWorkBasicConverter, XWorkConverter
public class DefaultTypeConverter
extends Object
implements TypeConverter

Default type conversion. Converts among numeric types and also strings. Contains the basic type mapping code from OGNL.

Author:
Luke Blanshard (blanshlu@netscape.net), Drew Davidson (drew@ognl.org)

Field Summary
Fields inherited from interface com.opensymphony.xwork2.conversion.TypeConverter
NO_CONVERSION_POSSIBLE, TYPE_CONVERTER_CONTEXT_KEY
Constructor Summary
DefaultTypeConverter()
Method Summary
static BigDecimal | bigDecValue(Object value) Evaluates the given object as a BigDecimal.
static BigInteger | bigIntValue(Object value) Evaluates the given object as a BigInteger.
static boolean | booleanValue(Object value) Evaluates the given object as a boolean: if it is a Boolean object, it's easy; if it's a Number or a Character, returns true for non-zero objects; and otherwise returns true for non-null objects.
Object | convertValue(Map<String,Object> context, Object value, Class toType)
Object | convertValue(Map<String,Object> context, Object target, Member member, String propertyName, Object value, Class toType) Converts the given value to a given type.
Object | convertValue(Object value, Class toType) Returns the value converted numerically to the given class type This method also detects when arrays are being converted and converts the components of one array to the type of the other.
static double | doubleValue(Object value) Evaluates the given object as a double-precision floating-point number.
Enum<?> | enumValue(Class toClass, Object o)
TypeConverter | getTypeConverter(Map<String,Object> context)
static long | longValue(Object value) Evaluates the given object as a long integer.
static String | stringValue(Object value) Evaluates the given object as a String.
static String | stringValue(Object value, boolean trim) Evaluates the given object as a String and trims it if the trim flag is true.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultTypeConverter

public DefaultTypeConverter()
Method Detail

convertValue

public Object convertValue(Map<String,Object> context,
                           Object value,
                           Class toType)

convertValue

public Object convertValue(Map<String,Object> context,
                           Object target,
                           Member member,
                           String propertyName,
                           Object value,
                           Class toType)
Description copied from interface: TypeConverter
Converts the given value to a given type. The OGNL context, target, member and name of property being set are given. This method should be able to handle conversion in general without any context, target, member or property name specified.

Specified by:
convertValue in interface TypeConverter
Parameters:
context - context under which the conversion is being done
target - target object in which the property is being set
member - member (Constructor, Method or Field) being set
propertyName - property name being set
value - value to be converted
toType - type to which value is converted
Returns:
Converted value of type toType or TypeConverter.NoConversionPossible to indicate that the conversion was not possible.

getTypeConverter

public TypeConverter getTypeConverter(Map<String,Object> context)

convertValue

public Object convertValue(Object value,
                           Class toType)
Returns the value converted numerically to the given class type This method also detects when arrays are being converted and converts the components of one array to the type of the other.

Parameters:
value - an object to be converted to the given type
toType - class type to be converted to
Returns:
converted value of the type given, or value if the value cannot be converted to the given type.

booleanValue

public static boolean booleanValue(Object value)
Evaluates the given object as a boolean: if it is a Boolean object, it's easy; if it's a Number or a Character, returns true for non-zero objects; and otherwise returns true for non-null objects.

Parameters:
value - an object to interpret as a boolean
Returns:
the boolean value implied by the given object

enumValue

public Enum<?> enumValue(Class toClass,
                         Object o)

longValue

public static long longValue(Object value)
                      throws NumberFormatException
Evaluates the given object as a long integer.

Parameters:
value - an object to interpret as a long integer
Returns:
the long integer value implied by the given object
Throws:
NumberFormatException - if the given object can't be understood as a long integer

doubleValue

public static double doubleValue(Object value)
                          throws NumberFormatException
Evaluates the given object as a double-precision floating-point number.

Parameters:
value - an object to interpret as a double
Returns:
the double value implied by the given object
Throws:
NumberFormatException - if the given object can't be understood as a double

bigIntValue

public static BigInteger bigIntValue(Object value)
                              throws NumberFormatException
Evaluates the given object as a BigInteger.

Parameters:
value - an object to interpret as a BigInteger
Returns:
the BigInteger value implied by the given object
Throws:
NumberFormatException - if the given object can't be understood as a BigInteger

bigDecValue

public static BigDecimal bigDecValue(Object value)
                              throws NumberFormatException
Evaluates the given object as a BigDecimal.

Parameters:
value - an object to interpret as a BigDecimal
Returns:
the BigDecimal value implied by the given object
Throws:
NumberFormatException - if the given object can't be understood as a BigDecimal

stringValue

public static String stringValue(Object value,
                                 boolean trim)
Evaluates the given object as a String and trims it if the trim flag is true.

Parameters:
value - an object to interpret as a String
Returns:
the String value implied by the given object as returned by the toString() method, or "null" if the object is null.

stringValue

public static String stringValue(Object value)
Evaluates the given object as a String.

Parameters:
value - an object to interpret as a String
Returns:
the String value implied by the given object as returned by the toString() method, or "null" if the object is null.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EnumTypeConverter (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.conversion.impl
Class EnumTypeConverter

java.lang.Object
    extended by  com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
        extended by  com.opensymphony.xwork2.conversion.impl.EnumTypeConverter
All Implemented Interfaces:
TypeConverter
Deprecated. Since Struts 2.1.0 as enum support is now built into XWork

@Deprecated
public class EnumTypeConverter
extends DefaultTypeConverter

EnumTypeConverter This class converts java 5 enums to String and from String[] to enum.

One of Java 5's improvements is providing enumeration facility.
Up to now, there existed no enumerations. The only way to simulate was the so-called int Enum pattern:
{code}
public static final int SEASON_WINTER = 0;
public static final int SEASON_SPRING = 1;
public static final int SEASON_SUMMER = 2;
public static final int SEASON_FALL   = 3;
{code}

Java 5.0 now provides the following construct:
{code}
public static enum Season { WINTER, SPRING, SUMMER, FALL };
{code}

h3. Implementing Java 5 Enumeration Type Conversion

1. myAction-conversion.properties*

Place a myAction-conversion.properties-file in the path of your Action.
Add the following entry to the properties-file:
{code}
nameOfYourField=fullyClassifiedNameOfYourConverter
{code}

2. myAction.java*
Your action contains the _enumeration_:
{code}
public enum Criticality {DEBUG, INFO, WARNING, ERROR, FATAL}
{code}

* Your action contains the _private field_:
{code}
private myEnum myFieldForEnum;
{code}

Your action contains _getters and setters_ for your field:
{code}
public myEnum getCriticality() {
        return myFieldForEnum;
    }

    public void setCriticality(myEnum myFieldForEnum) {
        this.myFieldForEnum= myFieldForEnum;
    }
{code}

3. JSP*

In your jsp you can access an enumeration value just normal by using the known -Tag: {code} {code}

Version:
$Id: EnumTypeConverter.java 1050 2006-06-26 21:46:27 +0200 (Mon, 26 Jun 2006) rainerh $
Author:
Tamara Cattivelli, Rainer Hermanns

Field Summary
Fields inherited from interface com.opensymphony.xwork2.conversion.TypeConverter
NO_CONVERSION_POSSIBLE, TYPE_CONVERTER_CONTEXT_KEY
Constructor Summary
EnumTypeConverter()
Deprecated.
Method Summary
Enum | convertFromString(String value, Class toClass) Deprecated. Converts one or more String values to the specified class.
Object | convertValue(Map<String,Object> context, Object o, Class toClass) Deprecated. Converts the given object to a given type.
Methods inherited from class com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
bigDecValue, bigIntValue, booleanValue, convertValue, convertValue, doubleValue, enumValue, getTypeConverter, longValue, stringValue, stringValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EnumTypeConverter

public EnumTypeConverter()
Deprecated.
Method Detail

convertValue

public Object convertValue(Map<String,Object> context,
                           Object o,
                           Class toClass)
Deprecated.
Converts the given object to a given type. How this is to be done is implemented in toClass. The OGNL context, o and toClass are given. This method should be able to handle conversion in general without any context or object specified.

Overrides:
convertValue in class DefaultTypeConverter
Parameters:
context - - OGNL context under which the conversion is being done
o - - the object to be converted
toClass - - the class that contains the code to convert to enumeration
Returns:
Converted value of type declared in toClass or TypeConverter.NoConversionPossible to indicate that the conversion was not possible.

convertFromString

public Enum convertFromString(String value,
                              Class toClass)
Deprecated.
Converts one or more String values to the specified class.

Parameters:
value - - the String values to be converted, such as those submitted from an HTML form
toClass - - the class to convert to
Returns:
the converted object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GenericsObjectTypeDeterminer (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.conversion.impl
Class GenericsObjectTypeDeterminer

java.lang.Object
    extended by  com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer
        extended by  com.opensymphony.xwork2.conversion.impl.GenericsObjectTypeDeterminer
All Implemented Interfaces:
ObjectTypeDeterminer
Deprecated. Use DefaultObjectTypeDeterminer instead. Since XWork 2.0.4 the DefaultObjectTypeDeterminer handles the annotation processing.

@Deprecated
public class GenericsObjectTypeDeterminer
extends DefaultObjectTypeDeterminer

GenericsObjectTypeDeterminer

Author:
Patrick Lightbody, Rainer Hermanns, Alexandru Popescu

Field Summary
Fields inherited from class com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer
CREATE_IF_NULL_PREFIX, DEPRECATED_ELEMENT_PREFIX, ELEMENT_PREFIX, KEY_PREFIX, KEY_PROPERTY_PREFIX, LOG
Constructor Summary
GenericsObjectTypeDeterminer(XWorkConverter conv, XWorkBasicConverter basicConv, ReflectionProvider prov)
Deprecated.
Method Summary
Methods inherited from class com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer
getAnnotation, getElementClass, getKeyClass, getKeyProperty, shouldCreateIfNew
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GenericsObjectTypeDeterminer

public GenericsObjectTypeDeterminer(XWorkConverter conv,
                                    XWorkBasicConverter basicConv,
                                    ReflectionProvider prov)
Deprecated.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InstantiatingNullHandler (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.conversion.impl
Class InstantiatingNullHandler

java.lang.Object
    extended by  com.opensymphony.xwork2.conversion.impl.InstantiatingNullHandler
All Implemented Interfaces:
NullHandler
public class InstantiatingNullHandler
extends Object
implements NullHandler

Provided that the key ReflectionContextState.CREATE_NULL_OBJECTS is in the action context with a value of true (this key is set only during the execution of the ParametersInterceptor), OGNL expressions that have caused a NullPointerException will be temporarily stopped for evaluation while the system automatically tries to solve the null references by automatically creating the object.

The following rules are used when handling null references:

  • If the property is declared exactly as a Collection or List, then an ArrayList shall be returned and assigned to the null references.
  • If the property is declared as a Map, then a HashMap will be returned and assigned to the null references.
  • If the null property is a simple bean with a no-arg constructor, it will simply be created using the ObjectFactory.buildBean(java.lang.Class, java.util.Map) method.
For example, if a form element has a text field named person.name and the expression person evaluates to null, then this class will be invoked. Because the person expression evaluates to a Person class, a new Person is created and assigned to the null reference. Finally, the name is set on that object and the overall effect is that the system automatically created a Person object for you, set it by calling setUsers() and then finally called getUsers().setName() as you would typically expect.
Field Summary
static String CREATE_NULL_OBJECTS
Deprecated. Use ReflectionContextState.CREATE_NULL_OBJECTS instead
Constructor Summary
InstantiatingNullHandler()
Method Summary
Object | nullMethodResult(Map<String,Object> context, Object target, String methodName, Object[] args) Method called on target returned null.
Object | nullPropertyValue(Map<String,Object> context, Object target, Object property) Property in target evaluated to null.
void | setObjectFactory(ObjectFactory fac)
void | setObjectTypeDeterminer(ObjectTypeDeterminer det)
void | setReflectionProvider(ReflectionProvider prov)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CREATE_NULL_OBJECTS

@Deprecated
public static final String CREATE_NULL_OBJECTS
Deprecated. Use ReflectionContextState.CREATE_NULL_OBJECTS instead
See Also:
Constant Field Values
Constructor Detail

InstantiatingNullHandler

public InstantiatingNullHandler()
Method Detail

setObjectTypeDeterminer

public void setObjectTypeDeterminer(ObjectTypeDeterminer det)

setReflectionProvider

public void setReflectionProvider(ReflectionProvider prov)

setObjectFactory

public void setObjectFactory(ObjectFactory fac)

nullMethodResult

public Object nullMethodResult(Map<String,Object> context,
                               Object target,
                               String methodName,
                               Object[] args)
Description copied from interface: NullHandler
Method called on target returned null.

Specified by:
nullMethodResult in interface NullHandler

nullPropertyValue

public Object nullPropertyValue(Map<String,Object> context,
                                Object target,
                                Object property)
Description copied from interface: NullHandler
Property in target evaluated to null. Property can be a constant String property name or a DynamicSubscript.

Specified by:
nullPropertyValue in interface NullHandler
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.conversion.impl (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.conversion.impl
Classes
AnnotationXWorkConverter
DefaultObjectTypeDeterminer
DefaultTypeConverter
EnumTypeConverter
GenericsObjectTypeDeterminer
InstantiatingNullHandler
XWorkBasicConverter
XWorkConverter


com.opensymphony.xwork2.conversion.impl (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.conversion.impl

Class Summary
AnnotationXWorkConverter | Deprecated. Since XWork 2.0.4, the implementation of XWorkConverter handles the processing of annotations.
DefaultObjectTypeDeterminer | This ObjectTypeDeterminer looks at the Class-conversion.properties for entries that indicated what objects are contained within Maps and Collections.
DefaultTypeConverter | Default type conversion.
EnumTypeConverter | Deprecated. Since Struts 2.1.0 as enum support is now built into XWork
GenericsObjectTypeDeterminer | Deprecated. Use DefaultObjectTypeDeterminer instead.
InstantiatingNullHandler | Provided that the key ReflectionContextState.CREATE_NULL_OBJECTS is in the action context with a value of true (this key is set only during the execution of the ParametersInterceptor), OGNL expressions that have caused a NullPointerException will be temporarily stopped for evaluation while the system automatically tries to solve the null references by automatically creating the object.
XWorkBasicConverter | XWork will automatically handle the most common type conversion for you.
XWorkConverter | XWorkConverter is a singleton used by many of the Struts 2's Ognl extention points, such as InstantiatingNullHandler, XWorkListPropertyAccessor etc to do object conversion.


com.opensymphony.xwork2.conversion.impl Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.conversion.impl

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer (implements com.opensymphony.xwork2.conversion.ObjectTypeDeterminer)
      • com.opensymphony.xwork2.conversion.impl.GenericsObjectTypeDeterminer
    • com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter (implements com.opensymphony.xwork2.conversion.TypeConverter)
      • com.opensymphony.xwork2.conversion.impl.EnumTypeConverter
      • com.opensymphony.xwork2.conversion.impl.XWorkBasicConverter
      • com.opensymphony.xwork2.conversion.impl.XWorkConverter
        • com.opensymphony.xwork2.conversion.impl.AnnotationXWorkConverter
    • com.opensymphony.xwork2.conversion.impl.InstantiatingNullHandler (implements com.opensymphony.xwork2.conversion.NullHandler)


Uses of Package com.opensymphony.xwork2.conversion.impl (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.conversion.impl

Packages that use com.opensymphony.xwork2.conversion.impl
com.opensymphony.xwork2.conversion.impl |
com.opensymphony.xwork2.ognl |
com.opensymphony.xwork2.ognl.accessor |
com.opensymphony.xwork2.util | XWork util classes.

Classes in com.opensymphony.xwork2.conversion.impl used by com.opensymphony.xwork2.conversion.impl
DefaultObjectTypeDeterminer
This ObjectTypeDeterminer looks at the Class-conversion.properties for entries that indicated what objects are contained within Maps and Collections.
DefaultTypeConverter
Default type conversion.
XWorkBasicConverter

XWork will automatically handle the most common type conversion for you.

XWorkConverter
XWorkConverter is a singleton used by many of the Struts 2's Ognl extention points, such as InstantiatingNullHandler, XWorkListPropertyAccessor etc to do object conversion.

Classes in com.opensymphony.xwork2.conversion.impl used by com.opensymphony.xwork2.ognl
XWorkConverter
XWorkConverter is a singleton used by many of the Struts 2's Ognl extention points, such as InstantiatingNullHandler, XWorkListPropertyAccessor etc to do object conversion.

Classes in com.opensymphony.xwork2.conversion.impl used by com.opensymphony.xwork2.ognl.accessor
XWorkConverter
XWorkConverter is a singleton used by many of the Struts 2's Ognl extention points, such as InstantiatingNullHandler, XWorkListPropertyAccessor etc to do object conversion.

Classes in com.opensymphony.xwork2.conversion.impl used by com.opensymphony.xwork2.util
XWorkConverter
XWorkConverter is a singleton used by many of the Struts 2's Ognl extention points, such as InstantiatingNullHandler, XWorkListPropertyAccessor etc to do object conversion.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


XWorkBasicConverter (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.conversion.impl
Class XWorkBasicConverter

java.lang.Object
    extended by  com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
        extended by  com.opensymphony.xwork2.conversion.impl.XWorkBasicConverter
All Implemented Interfaces:
TypeConverter
public class XWorkBasicConverter
extends DefaultTypeConverter

XWork will automatically handle the most common type conversion for you. This includes support for converting to and from Strings for each of the following:

  • String
  • boolean / Boolean
  • char / Character
  • int / Integer, float / Float, long / Long, double / Double
  • dates - uses the SHORT format for the Locale associated with the current request
  • arrays - assuming the individual strings can be coverted to the individual items
  • collections - if not object type can be determined, it is assumed to be a String and a new ArrayList is created

Note that with arrays the type conversion will defer to the type of the array elements and try to convert each item individually. As with any other type conversion, if the conversion can't be performed the standard type conversion error reporting is used to indicate a problem occured while processing the type conversion.

Author:
Pat Lightbody, Mike Mosiewicz, Rainer Hermanns, Alexandru Popescu

Field Summary
Fields inherited from interface com.opensymphony.xwork2.conversion.TypeConverter
NO_CONVERSION_POSSIBLE, TYPE_CONVERTER_CONTEXT_KEY
Constructor Summary
XWorkBasicConverter()
Method Summary
Object | convertValue(Map<String,Object> context, Object o, Member member, String s, Object value, Class toType) Converts the given value to a given type.
protected boolean | isInRange(Number value, String stringValue, Class toType)
protected boolean | isIntegerType(Class type)
void | setObjectFactory(ObjectFactory fac)
void | setObjectTypeDeterminer(ObjectTypeDeterminer det)
void | setXWorkConverter(XWorkConverter conv)
Methods inherited from class com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
bigDecValue, bigIntValue, booleanValue, convertValue, convertValue, doubleValue, enumValue, getTypeConverter, longValue, stringValue, stringValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XWorkBasicConverter

public XWorkBasicConverter()
Method Detail

setObjectTypeDeterminer

public void setObjectTypeDeterminer(ObjectTypeDeterminer det)

setXWorkConverter

public void setXWorkConverter(XWorkConverter conv)

setObjectFactory

public void setObjectFactory(ObjectFactory fac)

convertValue

public Object convertValue(Map<String,Object> context,
                           Object o,
                           Member member,
                           String s,
                           Object value,
                           Class toType)
Description copied from interface: TypeConverter
Converts the given value to a given type. The OGNL context, target, member and name of property being set are given. This method should be able to handle conversion in general without any context, target, member or property name specified.

Specified by:
convertValue in interface TypeConverter
Overrides:
convertValue in class DefaultTypeConverter
Parameters:
context - context under which the conversion is being done
o - target object in which the property is being set
member - member (Constructor, Method or Field) being set
s - property name being set
value - value to be converted
toType - type to which value is converted
Returns:
Converted value of type toType or TypeConverter.NoConversionPossible to indicate that the conversion was not possible.

isInRange

protected boolean isInRange(Number value,
                            String stringValue,
                            Class toType)

isIntegerType

protected boolean isIntegerType(Class type)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkConverter (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.conversion.impl
Class XWorkConverter

java.lang.Object
    extended by  com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
        extended by  com.opensymphony.xwork2.conversion.impl.XWorkConverter
All Implemented Interfaces:
TypeConverter
Direct Known Subclasses:
AnnotationXWorkConverter
public class XWorkConverter
extends DefaultTypeConverter

XWorkConverter is a singleton used by many of the Struts 2's Ognl extention points, such as InstantiatingNullHandler, XWorkListPropertyAccessor etc to do object conversion.

Type conversion is great for situations where you need to turn a String in to a more complex object. Because the web is type-agnostic (everything is a string in HTTP), Struts 2's type conversion features are very useful. For instance, if you were prompting a user to enter in coordinates in the form of a string (such as "3, 22"), you could have Struts 2 do the conversion both from String to Point and from Point to String.

Using this "point" example, if your action (or another compound object in which you are setting properties on) has a corresponding ClassName-conversion.properties file, Struts 2 will use the configured type converters for conversion to and from strings. So turning "3, 22" in to new Point(3, 22) is done by merely adding the following entry to ClassName-conversion.properties (Note that the PointConverter should impl the TypeConverter interface):

point = com.acme.PointConverter

Your type converter should be sure to check what class type it is being requested to convert. Because it is used for both to and from strings, you will need to split the conversion method in to two parts: one that turns Strings in to Points, and one that turns Points in to Strings.

After this is done, you can now reference your point (using <s:property value="point"/> in JSP or ${point} in FreeMarker) and it will be printed as "3, 22" again. As such, if you submit this back to an action, it will be converted back to a Point once again.

In some situations you may wish to apply a type converter globally. This can be done by editing the file xwork-conversion.properties in the root of your class path (typically WEB-INF/classes) and providing a property in the form of the class name of the object you wish to convert on the left hand side and the class name of the type converter on the right hand side. For example, providing a type converter for all Point objects would mean adding the following entry:

com.acme.Point = com.acme.PointConverter

Type conversion should not be used as a substitute for i18n. It is not recommended to use this feature to print out properly formatted dates. Rather, you should use the i18n features of Struts 2 (and consult the JavaDocs for JDK's MessageFormat object) to see how a properly formatted date should be displayed.

Any error that occurs during type conversion may or may not wish to be reported. For example, reporting that the input "abc" could not be converted to a number might be important. On the other hand, reporting that an empty string, "", cannot be converted to a number might not be important - especially in a web environment where it is hard to distinguish between a user not entering a value vs. entering a blank value.

By default, all conversion errors are reported using the generic i18n key xwork.default.invalid.fieldvalue, which you can override (the default text is Invalid field value for field "xxx", where xxx is the field name) in your global i18n resource bundle.

However, sometimes you may wish to override this message on a per-field basis. You can do this by adding an i18n key associated with just your action (Action.properties) using the pattern invalid.fieldvalue.xxx, where xxx is the field name.

It is important to know that none of these errors are actually reported directly. Rather, they are added to a map called conversionErrors in the ActionContext. There are several ways this map can then be accessed and the errors can be reported accordingly.

Version:
$Date: 2009-09-17 05:41:19 +0200 (Thu, 17 Sep 2009) $ $Id: XWorkConverter.java 2058 2009-09-17 03:41:19Z rainerh $
Author:
Pat Lightbody, Rainer Hermanns, Alexandru Popescu, tm_jee
See Also:
XWorkBasicConverter

Field Summary
static String | CONVERSION_COLLECTION_PREFIX
static String | CONVERSION_ERROR_PROPERTY_PREFIX
static String | CONVERSION_PROPERTY_FULLNAME
protected HashMap<String,TypeConverter> | defaultMappings Record class and its type converter mapping.
static String | LAST_BEAN_CLASS_ACCESSED
static String | LAST_BEAN_PROPERTY_ACCESSED
protected static Logger | LOG
protected HashMap<Class,Map<String,Object>> | mappings Target class conversion Mappings.
static String | MESSAGE_INDEX_BRACKET_PATTERN
static String | MESSAGE_INDEX_PATTERN
static Pattern | messageIndexPattern
protected HashSet<Class> | noMapping Unavailable target class conversion mappings, serves as a simple cache.
static String | PERIOD
static String | REPORT_CONVERSION_ERRORS
protected HashSet<String> | unknownMappings Record classes that doesn't have conversion mapping defined.
Fields inherited from interface com.opensymphony.xwork2.conversion.TypeConverter
NO_CONVERSION_POSSIBLE, TYPE_CONVERTER_CONTEXT_KEY
Constructor Summary
protected XWorkConverter()
Method Summary
protected void | addConverterMapping(Map<String,Object> mapping, Class clazz) Looks for converter mappings for the specified class and adds it to an existing map.
static String | buildConverterFilename(Class clazz)
protected Map<String,Object> | buildConverterMapping(Class clazz) Looks for converter mappings for the specified class, traversing up its class hierarchy and interfaces and adding any additional mappings it may find.
Object | convertValue(Map<String,Object> map, Object o, Class aClass)
Object | convertValue(Map<String,Object> context, Object target, Member member, String property, Object value, Class toClass) Convert value from one form to another.
static String | getConversionErrorMessage(String propertyName, ValueStack stack)
protected Object | getConverter(Class clazz, String property)
protected void | handleConversionException(Map<String,Object> context, String property, Object value, Object object)
void | loadConversionProperties(String propsName)
void | loadConversionProperties(String propsName, boolean require)
TypeConverter | lookup(Class clazz) Looks for a TypeConverter in the default mappings.
TypeConverter | lookup(String className) Looks for a TypeConverter in the default mappings.
void | registerConverter(String className, TypeConverter converter)
void | registerConverterNotFound(String className)
void | setDefaultTypeConverter(XWorkBasicConverter conv)
void | setObjectFactory(ObjectFactory factory)
Methods inherited from class com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter
bigDecValue, bigIntValue, booleanValue, convertValue, doubleValue, enumValue, getTypeConverter, longValue, stringValue, stringValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

protected static final Logger LOG

REPORT_CONVERSION_ERRORS

public static final String REPORT_CONVERSION_ERRORS
See Also:
Constant Field Values

CONVERSION_PROPERTY_FULLNAME

public static final String CONVERSION_PROPERTY_FULLNAME
See Also:
Constant Field Values

CONVERSION_ERROR_PROPERTY_PREFIX

public static final String CONVERSION_ERROR_PROPERTY_PREFIX
See Also:
Constant Field Values

CONVERSION_COLLECTION_PREFIX

public static final String CONVERSION_COLLECTION_PREFIX
See Also:
Constant Field Values

LAST_BEAN_CLASS_ACCESSED

public static final String LAST_BEAN_CLASS_ACCESSED
See Also:
Constant Field Values

LAST_BEAN_PROPERTY_ACCESSED

public static final String LAST_BEAN_PROPERTY_ACCESSED
See Also:
Constant Field Values

MESSAGE_INDEX_PATTERN

public static final String MESSAGE_INDEX_PATTERN
See Also:
Constant Field Values

MESSAGE_INDEX_BRACKET_PATTERN

public static final String MESSAGE_INDEX_BRACKET_PATTERN
See Also:
Constant Field Values

PERIOD

public static final String PERIOD
See Also:
Constant Field Values

messageIndexPattern

public static final Pattern messageIndexPattern

mappings

protected HashMap<Class,Map<String,Object>> mappings
Target class conversion Mappings.
 Map>
  - Class -> convert to class
  - Map
    - String -> property name
                eg. Element_property, property etc.
    - Object -> String to represent properties
                eg. value part of
                    KeyProperty_property=id
             -> TypeConverter to represent an Ognl TypeConverter
                eg. value part of
                    property=foo.bar.MyConverter
             -> Class to represent a class
                eg. value part of
                    Element_property=foo.bar.MyObject

noMapping

protected HashSet<Class> noMapping
Unavailable target class conversion mappings, serves as a simple cache.

defaultMappings

protected HashMap<String,TypeConverter> defaultMappings
Record class and its type converter mapping.
 - String - classname as String
 - TypeConverter - instance of TypeConverter

unknownMappings

protected HashSet<String> unknownMappings
Record classes that doesn't have conversion mapping defined.
 - String -> classname as String

Constructor Detail

XWorkConverter

protected XWorkConverter()
Method Detail

setObjectFactory

public void setObjectFactory(ObjectFactory factory)

setDefaultTypeConverter

public void setDefaultTypeConverter(XWorkBasicConverter conv)

getConversionErrorMessage

public static String getConversionErrorMessage(String propertyName,
                                               ValueStack stack)

buildConverterFilename

public static String buildConverterFilename(Class clazz)

convertValue

public Object convertValue(Map<String,Object> map,
                           Object o,
                           Class aClass)
Overrides:
convertValue in class DefaultTypeConverter

convertValue

public Object convertValue(Map<String,Object> context,
                           Object target,
                           Member member,
                           String property,
                           Object value,
                           Class toClass)
Convert value from one form to another. Minimum requirement of arguments:
  • supplying context, toClass and value
  • supplying context, target and value.

Specified by:
convertValue in interface TypeConverter
Overrides:
convertValue in class DefaultTypeConverter
Parameters:
context - context under which the conversion is being done
target - target object in which the property is being set
member - member (Constructor, Method or Field) being set
property - property name being set
value - value to be converted
toClass - type to which value is converted
Returns:
Converted value of type toType or TypeConverter.NoConversionPossible to indicate that the conversion was not possible.
See Also:
TypeConverter.convertValue(java.util.Map, java.lang.Object, java.lang.reflect.Member, java.lang.String, java.lang.Object, java.lang.Class)

lookup

public TypeConverter lookup(String className)
Looks for a TypeConverter in the default mappings.

Parameters:
className - name of the class the TypeConverter must handle
Returns:
a TypeConverter to handle the specified class or null if none can be found

lookup

public TypeConverter lookup(Class clazz)
Looks for a TypeConverter in the default mappings.

Parameters:
clazz - the class the TypeConverter must handle
Returns:
a TypeConverter to handle the specified class or null if none can be found

getConverter

protected Object getConverter(Class clazz,
                              String property)

handleConversionException

protected void handleConversionException(Map<String,Object> context,
                                         String property,
                                         Object value,
                                         Object object)

registerConverter

public void registerConverter(String className,
                              TypeConverter converter)

registerConverterNotFound

public void registerConverterNotFound(String className)

addConverterMapping

protected void addConverterMapping(Map<String,Object> mapping,
                                   Class clazz)
Looks for converter mappings for the specified class and adds it to an existing map. Only new converters are added. If a converter is defined on a key that already exists, the converter is ignored.

Parameters:
mapping - an existing map to add new converter mappings to
clazz - class to look for converter mappings for

buildConverterMapping

protected Map<String,Object> buildConverterMapping(Class clazz)
                                            throws Exception
Looks for converter mappings for the specified class, traversing up its class hierarchy and interfaces and adding any additional mappings it may find. Mappings lower in the hierarchy have priority over those higher in the hierarcy.

Parameters:
clazz - the class to look for converter mappings for
Returns:
the converter mappings
Throws:
Exception

loadConversionProperties

public void loadConversionProperties(String propsName)

loadConversionProperties

public void loadConversionProperties(String propsName,
                                     boolean require)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.opensymphony.xwork2.conversion.impl.AnnotationXWorkConverter (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.conversion.impl.AnnotationXWorkConverter

No usage of com.opensymphony.xwork2.conversion.impl.AnnotationXWorkConverter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.conversion.impl.DefaultObjectTypeDeterminer

Packages that use DefaultObjectTypeDeterminer
com.opensymphony.xwork2.conversion.impl

Uses of DefaultObjectTypeDeterminer in com.opensymphony.xwork2.conversion.impl

Subclasses of DefaultObjectTypeDeterminer in com.opensymphony.xwork2.conversion.impl
 class GenericsObjectTypeDeterminer
Deprecated. Use DefaultObjectTypeDeterminer instead. Since XWork 2.0.4 the DefaultObjectTypeDeterminer handles the annotation processing.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter

Packages that use DefaultTypeConverter
com.opensymphony.xwork2.conversion.impl

Uses of DefaultTypeConverter in com.opensymphony.xwork2.conversion.impl

Subclasses of DefaultTypeConverter in com.opensymphony.xwork2.conversion.impl
class | AnnotationXWorkConverter Deprecated. Since XWork 2.0.4, the implementation of XWorkConverter handles the processing of annotations.
class | EnumTypeConverter Deprecated. Since Struts 2.1.0 as enum support is now built into XWork
class | XWorkBasicConverter XWork will automatically handle the most common type conversion for you.
class | XWorkConverter XWorkConverter is a singleton used by many of the Struts 2's Ognl extention points, such as InstantiatingNullHandler, XWorkListPropertyAccessor etc to do object conversion.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.conversion.impl.EnumTypeConverter (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.conversion.impl.EnumTypeConverter

No usage of com.opensymphony.xwork2.conversion.impl.EnumTypeConverter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.conversion.impl.GenericsObjectTypeDeterminer (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.conversion.impl.GenericsObjectTypeDeterminer

No usage of com.opensymphony.xwork2.conversion.impl.GenericsObjectTypeDeterminer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.conversion.impl.InstantiatingNullHandler (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.conversion.impl.InstantiatingNullHandler

No usage of com.opensymphony.xwork2.conversion.impl.InstantiatingNullHandler

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.conversion.impl.XWorkBasicConverter (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.conversion.impl.XWorkBasicConverter

Packages that use XWorkBasicConverter
com.opensymphony.xwork2.conversion.impl

Uses of XWorkBasicConverter in com.opensymphony.xwork2.conversion.impl

Methods in com.opensymphony.xwork2.conversion.impl with parameters of type XWorkBasicConverter
 void XWorkConverter.setDefaultTypeConverter(XWorkBasicConverter conv)

Constructors in com.opensymphony.xwork2.conversion.impl with parameters of type XWorkBasicConverter
GenericsObjectTypeDeterminer(XWorkConverter conv, XWorkBasicConverter basicConv, ReflectionProvider prov)
Deprecated.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.conversion.impl.XWorkConverter (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.conversion.impl.XWorkConverter

Packages that use XWorkConverter
com.opensymphony.xwork2.conversion.impl |
com.opensymphony.xwork2.ognl |
com.opensymphony.xwork2.ognl.accessor |
com.opensymphony.xwork2.util | XWork util classes.

Uses of XWorkConverter in com.opensymphony.xwork2.conversion.impl

Subclasses of XWorkConverter in com.opensymphony.xwork2.conversion.impl
 class AnnotationXWorkConverter
Deprecated. Since XWork 2.0.4, the implementation of XWorkConverter handles the processing of annotations.

Methods in com.opensymphony.xwork2.conversion.impl with parameters of type XWorkConverter
 void XWorkBasicConverter.setXWorkConverter(XWorkConverter conv)

Constructors in com.opensymphony.xwork2.conversion.impl with parameters of type XWorkConverter
DefaultObjectTypeDeterminer(XWorkConverter conv, ReflectionProvider prov)
GenericsObjectTypeDeterminer(XWorkConverter conv, XWorkBasicConverter basicConv, ReflectionProvider prov)
Deprecated.

Uses of XWorkConverter in com.opensymphony.xwork2.ognl

Methods in com.opensymphony.xwork2.ognl with parameters of type XWorkConverter
protected void | OgnlValueStack.setRoot(XWorkConverter xworkConverter, CompoundRootAccessor accessor, CompoundRoot compoundRoot, boolean allowStaticMethodAccess)
void | OgnlValueStackFactory.setXWorkConverter(XWorkConverter conv)
void | OgnlUtil.setXWorkConverter(XWorkConverter conv)

Constructors in com.opensymphony.xwork2.ognl with parameters of type XWorkConverter
OgnlValueStack(ValueStack vs, XWorkConverter xworkConverter, CompoundRootAccessor accessor, boolean allowStaticAccess)
OgnlValueStack(XWorkConverter xworkConverter, CompoundRootAccessor accessor, TextProvider prov, boolean allowStaticAccess)

Uses of XWorkConverter in com.opensymphony.xwork2.ognl.accessor

Methods in com.opensymphony.xwork2.ognl.accessor with parameters of type XWorkConverter
void | XWorkMapPropertyAccessor.setXWorkConverter(XWorkConverter conv)
void | XWorkListPropertyAccessor.setXWorkConverter(XWorkConverter conv)
void | XWorkCollectionPropertyAccessor.setXWorkConverter(XWorkConverter conv)

Uses of XWorkConverter in com.opensymphony.xwork2.util

Constructors in com.opensymphony.xwork2.util with parameters of type XWorkConverter
XWorkList(ObjectFactory fac, XWorkConverter conv, Class clazz)
XWorkList(ObjectFactory fac, XWorkConverter conv, Class clazz, int initialCapacity)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ConversionDescription (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.conversion.metadata
Class ConversionDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.conversion.metadata.ConversionDescription

public class ConversionDescription
extends Object

ConversionDescription

Version:
$Id: ConversionDescription.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns

Field Summary
static String | DEPRECATED_ELEMENT_PREFIX
static String | ELEMENT_PREFIX
String | fullQualifiedClassName
static String | KEY_PREFIX
static String | KEY_PROPERTY_PREFIX
protected static Logger | log Jakarta commons-logging reference.
String | property
String | rule
String | type
String | typeConverter
String | value
Constructor Summary
ConversionDescription()
ConversionDescription(String property)
Creates an ConversionDescription with the specified property name.
Method Summary
String | asProperty() Returns the conversion description as property entry.
String | getFullQualifiedClassName() Returns the fullQualifiedClassName attribute is used to create the special conversion.properties file name.
String | getType()
String | getValue()
void | setFullQualifiedClassName(String fullQualifiedClassName) The fullQualifiedClassName attribute is used to create the special conversion.properties file name.
void | setProperty(String property) Sets the property name to be inserted into the related conversion.properties file. Note: Do not add COLLECTION_PREFIX or MAP_PREFIX keys to property names.
void | setRule(String rule) Sets the rule prefix for COLLECTION_PREFIX or MAP_PREFIX key.
void | setType(String type)
void | setTypeConverter(String typeConverter) Sets the class name of the type converter to be used.
void | setValue(String value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

protected static Logger log
Jakarta commons-logging reference.

KEY_PREFIX

public static final String KEY_PREFIX
See Also:
Constant Field Values

ELEMENT_PREFIX

public static final String ELEMENT_PREFIX
See Also:
Constant Field Values

KEY_PROPERTY_PREFIX

public static final String KEY_PROPERTY_PREFIX
See Also:
Constant Field Values

DEPRECATED_ELEMENT_PREFIX

public static final String DEPRECATED_ELEMENT_PREFIX
See Also:
Constant Field Values

property

public String property

typeConverter

public String typeConverter

rule

public String rule

value

public String value

fullQualifiedClassName

public String fullQualifiedClassName

type

public String type
Constructor Detail

ConversionDescription

public ConversionDescription()

ConversionDescription

public ConversionDescription(String property)
Creates an ConversionDescription with the specified property name.

Parameters:
property -
Method Detail

setProperty

public void setProperty(String property)

Sets the property name to be inserted into the related conversion.properties file.
Note: Do not add COLLECTION_PREFIX or MAP_PREFIX keys to property names.

Parameters:
property - The property to be converted.

setTypeConverter

public void setTypeConverter(String typeConverter)
Sets the class name of the type converter to be used.

Parameters:
typeConverter - The class name of the type converter.

setRule

public void setRule(String rule)
Sets the rule prefix for COLLECTION_PREFIX or MAP_PREFIX key. Defaults to en emtpy String.

Parameters:
rule -

setType

public void setType(String type)

getType

public String getType()

getValue

public String getValue()

setValue

public void setValue(String value)

asProperty

public String asProperty()
Returns the conversion description as property entry.

 Example:
property.name = converter.className
Collection_property.name = converter.className
Map_property.name = converter.className
 KeyProperty_name = id

Returns:
the conversion description as property entry.

getFullQualifiedClassName

public String getFullQualifiedClassName()
Returns the fullQualifiedClassName attribute is used to create the special conversion.properties file name.

Returns:
fullQualifiedClassName

setFullQualifiedClassName

public void setFullQualifiedClassName(String fullQualifiedClassName)
The fullQualifiedClassName attribute is used to create the special conversion.properties file name.

Parameters:
fullQualifiedClassName -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.conversion.metadata (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.conversion.metadata
Classes
ConversionDescription


com.opensymphony.xwork2.conversion.metadata (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.conversion.metadata

Type conversion meta data classes.

See:
Description

Class Summary
ConversionDescription ConversionDescription

Package com.opensymphony.xwork2.conversion.metadata Description

Type conversion meta data classes.


com.opensymphony.xwork2.conversion.metadata Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.conversion.metadata

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.conversion.metadata.ConversionDescription


Uses of Package com.opensymphony.xwork2.conversion.metadata (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.conversion.metadata

No usage of com.opensymphony.xwork2.conversion.metadata

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.conversion.metadata.ConversionDescription (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.conversion.metadata.ConversionDescription

No usage of com.opensymphony.xwork2.conversion.metadata.ConversionDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Container (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Interface Container

All Superinterfaces:
Serializable
public interface Container
extends Serializable

Injects dependencies into constructors, methods and fields annotated with Inject. Immutable.

When injecting a method or constructor, you can additionally annotate its parameters with Inject and specify a dependency name. When a parameter has no annotation, the container uses the name from the method or constructor's Inject annotation respectively.

For example:

  class Foo {

    // Inject the int constant named "i".
    @Inject("i") int i;

    // Inject the default implementation of Bar and the String constant
    // named "s".
    @Inject Foo(Bar bar, @Inject("s") String s) {
      ...
    }

    // Inject the default implementation of Baz and the Bob implementation
    // named "foo".
    @Inject void initialize(Baz baz, @Inject("foo") Bob bob) {
      ...
    }

    // Inject the default implementation of Tee.
    @Inject void setTee(Tee tee) {
      ...
    }
  }

To create and inject an instance of Foo:

  Container c = ...;
  Foo foo = c.inject(Foo.class);

Author:
crazybob@google.com (Bob Lee)
See Also:
ContainerBuilder

Field Summary
static String DEFAULT_NAME
Default dependency name.
Method Summary
<T> T
getInstance(Class<T> type)
Convenience method. Equivalent to getInstance(type, DEFAULT_NAME).
<T> T
getInstance(Class<T> type, String name)
Gets an instance of the given dependency which was declared in ContainerBuilder.
 Set<String> getInstanceNames(Class<?> type)
Gets a set of all registered names for the given type
<T> T
inject(Class<T> implementation)
Creates and injects a new instance of type implementation.
 void inject(Object o)
Injects dependencies into the fields and methods of an existing object.
 void removeScopeStrategy()
Removes the scope strategy for the current thread.
 void setScopeStrategy(Scope.Strategy scopeStrategy)
Sets the scope strategy for the current thread.

Field Detail

DEFAULT_NAME

static final String DEFAULT_NAME
Default dependency name.

See Also:
Constant Field Values
Method Detail

inject

void inject(Object o)
Injects dependencies into the fields and methods of an existing object.

inject

<T> T inject(Class<T> implementation)
Creates and injects a new instance of type implementation.

getInstance

<T> T getInstance(Class<T> type,
                  String name)
Gets an instance of the given dependency which was declared in ContainerBuilder.

getInstance

<T> T getInstance(Class<T> type)
Convenience method. Equivalent to getInstance(type, DEFAULT_NAME).

getInstanceNames

Set<String> getInstanceNames(Class<?> type)
Gets a set of all registered names for the given type

Parameters:
type - The instance type
Returns:
A set of registered names

setScopeStrategy

void setScopeStrategy(Scope.Strategy scopeStrategy)
Sets the scope strategy for the current thread.

removeScopeStrategy

void removeScopeStrategy()
Removes the scope strategy for the current thread.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ContainerBuilder (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Class ContainerBuilder

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.ContainerBuilder

public final class ContainerBuilder
extends Object

Builds a dependency injection Container. The combination of dependency type and name uniquely identifies a dependency mapping; you can use the same name for two different types. Not safe for concurrent use.

Adds the following factories by default:

  • Injects the current Container.
  • Injects the Logger for the injected member's declaring class.

Author:
crazybob@google.com (Bob Lee)

Nested Class Summary
static interface ContainerBuilder.Command
Implemented by classes which participate in building a container.
Constructor Summary
ContainerBuilder()
Constructs a new builder.
Method Summary
<T> ContainerBuilder
alias(Class<T> type, String alias)
Convenience method. Equivalent to alias(type, Container.DEFAULT_NAME, type).
<T> ContainerBuilder
alias(Class<T> type, String name, String alias)
Maps an existing factory to a new name.
 ContainerBuilder constant(String name, boolean value)
Maps a constant value to the given name.
 ContainerBuilder constant(String name, char value)
Maps a constant value to the given name.
 ContainerBuilder constant(String name, Class value)
Maps a class to the given name.
 ContainerBuilder constant(String name, double value)
Maps a constant value to the given name.
<E extends Enum<E>>
ContainerBuilder
constant(String name, E value)
Maps an enum to the given name.
 ContainerBuilder constant(String name, float value)
Maps a constant value to the given name.
 ContainerBuilder constant(String name, int value)
Maps a constant value to the given name.
 ContainerBuilder constant(String name, long value)
Maps a constant value to the given name.
 ContainerBuilder constant(String name, short value)
Maps a constant value to the given name.
 ContainerBuilder constant(String name, String value)
Maps a constant value to the given name.
 boolean contains(Class<?> type)
Convenience method. Equivalent to contains(type, Container.DEFAULT_NAME).
 boolean contains(Class<?> type, String name)
Returns true if this builder contains a mapping for the given type and name.
 Container create(boolean loadSingletons)
Creates a Container instance.
<T> ContainerBuilder
factory(Class<T> type)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, type).
<T> ContainerBuilder
factory(Class<T> type, Class<? extends T> implementation)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, implementation).
<T> ContainerBuilder
factory(Class<T> type, Class<? extends T> implementation, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, implementation, scope).
<T> ContainerBuilder
factory(Class<T> type, Factory<? extends T> factory)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, Scope.DEFAULT).
<T> ContainerBuilder
factory(Class<T> type, Factory<? extends T> factory, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, scope).
<T> ContainerBuilder
factory(Class<T> type, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, type, scope).
<T> ContainerBuilder
factory(Class<T> type, String name)
Convenience method. Equivalent to factory(type, name, type).
<T> ContainerBuilder
factory(Class<T> type, String name, Class<? extends T> implementation)
Maps an implementation class to a given dependency type and name.
<T> ContainerBuilder
factory(Class<T> type, String name, Class<? extends T> implementation, Scope scope)
Maps an implementation class to a given dependency type and name.
<T> ContainerBuilder
factory(Class<T> type, String name, Factory<? extends T> factory)
Convenience method. Equivalent to factory(type, name, factory, Scope.DEFAULT).
<T> ContainerBuilder
factory(Class<T> type, String name, Factory<? extends T> factory, Scope scope)
Maps a factory to a given dependency type and name.
<T> ContainerBuilder
factory(Class<T> type, String name, Scope scope)
Convenience method. Equivalent to factory(type, name, type, scope).
 ContainerBuilder injectStatics(Class<?>... types)
Upon creation, the Container will inject static fields and methods into the given classes.
 void setAllowDuplicates(boolean val)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ContainerBuilder

public ContainerBuilder()
Constructs a new builder.

Method Detail

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    String name,
                                    Factory<? extends T> factory,
                                    Scope scope)
Maps a factory to a given dependency type and name.

Parameters:
type - of dependency
name - of dependency
factory - creates objects to inject
scope - scope of injected instances
Returns:
this builder

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    Factory<? extends T> factory,
                                    Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, scope).

See Also:
factory(Class, String, Factory, Scope)

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    String name,
                                    Factory<? extends T> factory)
Convenience method. Equivalent to factory(type, name, factory, Scope.DEFAULT).

See Also:
factory(Class, String, Factory, Scope)

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    Factory<? extends T> factory)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, Scope.DEFAULT).

See Also:
factory(Class, String, Factory, Scope)

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    String name,
                                    Class<? extends T> implementation,
                                    Scope scope)
Maps an implementation class to a given dependency type and name. Creates instances using the container, recursively injecting dependencies.

Parameters:
type - of dependency
name - of dependency
implementation - class
scope - scope of injected instances
Returns:
this builder

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    String name,
                                    Class<? extends T> implementation)
Maps an implementation class to a given dependency type and name. Creates instances using the container, recursively injecting dependencies.

Sets scope to value from Scoped annotation on the implementation class. Defaults to Scope.DEFAULT if no annotation is found.

Parameters:
type - of dependency
name - of dependency
implementation - class
Returns:
this builder

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    Class<? extends T> implementation)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, implementation).

See Also:
factory(Class, String, Class)

factory

public <T> ContainerBuilder factory(Class<T> type)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, type).

See Also:
factory(Class, String, Class)

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    String name)
Convenience method. Equivalent to factory(type, name, type).

See Also:
factory(Class, String, Class)

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    Class<? extends T> implementation,
                                    Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, implementation, scope).

See Also:
factory(Class, String, Class, Scope)

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, type, scope).

See Also:
factory(Class, String, Class, Scope)

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    String name,
                                    Scope scope)
Convenience method. Equivalent to factory(type, name, type, scope).

See Also:
factory(Class, String, Class, Scope)

alias

public <T> ContainerBuilder alias(Class<T> type,
                                  String alias)
Convenience method. Equivalent to alias(type, Container.DEFAULT_NAME, type).

See Also:
alias(Class, String, String)

alias

public <T> ContainerBuilder alias(Class<T> type,
                                  String name,
                                  String alias)
Maps an existing factory to a new name.

Parameters:
type - of dependency
name - of dependency
alias - of to the dependency
Returns:
this builder

constant

public ContainerBuilder constant(String name,
                                 String value)
Maps a constant value to the given name.

constant

public ContainerBuilder constant(String name,
                                 int value)
Maps a constant value to the given name.

constant

public ContainerBuilder constant(String name,
                                 long value)
Maps a constant value to the given name.

constant

public ContainerBuilder constant(String name,
                                 boolean value)
Maps a constant value to the given name.

constant

public ContainerBuilder constant(String name,
                                 double value)
Maps a constant value to the given name.

constant

public ContainerBuilder constant(String name,
                                 float value)
Maps a constant value to the given name.

constant

public ContainerBuilder constant(String name,
                                 short value)
Maps a constant value to the given name.

constant

public ContainerBuilder constant(String name,
                                 char value)
Maps a constant value to the given name.

constant

public ContainerBuilder constant(String name,
                                 Class value)
Maps a class to the given name.

constant

public <E extends Enum<E>> ContainerBuilder constant(String name,
                                                     E value)
Maps an enum to the given name.

injectStatics

public ContainerBuilder injectStatics(Class<?>... types)
Upon creation, the Container will inject static fields and methods into the given classes.

Parameters:
types - for which static members will be injected

contains

public boolean contains(Class<?> type,
                        String name)
Returns true if this builder contains a mapping for the given type and name.

contains

public boolean contains(Class<?> type)
Convenience method. Equivalent to contains(type, Container.DEFAULT_NAME).

create

public Container create(boolean loadSingletons)
Creates a Container instance. Injects static members for classes which were registered using injectStatics(Class...).

Parameters:
loadSingletons - If true, the container will load all singletons now. If false, the container will lazily load singletons. Eager loading is appropriate for production use while lazy loading can speed development.
Throws:
IllegalStateException - if called more than once

setAllowDuplicates

public void setAllowDuplicates(boolean val)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContainerBuilder.Command (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Interface ContainerBuilder.Command

Enclosing class:
ContainerBuilder
public static interface ContainerBuilder.Command

Implemented by classes which participate in building a container.

Method Summary
 void build(ContainerBuilder builder)
Contributes factories to the given builder.

Method Detail

build

void build(ContainerBuilder builder)
Contributes factories to the given builder.

Parameters:
builder -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Context (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Interface Context

public interface Context

Context of the current injection.

Author:
crazybob@google.com (Bob Lee)

Method Summary
 Container getContainer()
Gets the Container.
 Member getMember()
Gets the field, method or constructor which is being injected.
 String getName()
Gets the name of the injection specified by Inject.value().
 Scope.Strategy getScopeStrategy()
Gets the current scope strategy.
 Class<?> getType()
Gets the type of the field or parameter which is being injected.

Method Detail

getContainer

Container getContainer()
Gets the Container.

getScopeStrategy

Scope.Strategy getScopeStrategy()
Gets the current scope strategy. See Container.setScopeStrategy(Scope.Strategy).

Throws:
IllegalStateException - if no strategy has been set

getMember

Member getMember()
Gets the field, method or constructor which is being injected. Returns null if the object currently being constructed is pre-loaded as a singleton or requested from Container.getInstance(Class).

getType

Class<?> getType()
Gets the type of the field or parameter which is being injected.

getName

String getName()
Gets the name of the injection specified by Inject.value().

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DependencyException (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Class DependencyException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  com.opensymphony.xwork2.inject.DependencyException
All Implemented Interfaces:
Serializable
public class DependencyException
extends RuntimeException

Thrown when a dependency is misconfigured.

Author:
crazybob@google.com (Bob Lee)
See Also:
Serialized Form

Constructor Summary
DependencyException(String message)
DependencyException(String message, Throwable cause)
DependencyException(Throwable cause)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DependencyException

public DependencyException(String message)

DependencyException

public DependencyException(String message,
                           Throwable cause)

DependencyException

public DependencyException(Throwable cause)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Factory (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Interface Factory<T>

All Known Implementing Classes:
LocatableConstantFactory, LocatableFactory
public interface Factory<T>

A custom factory. Creates objects which will be injected.

Author:
crazybob@google.com (Bob Lee)

Method Summary
 T create(Context context)
Creates an object to be injected.

Method Detail

create

T create(Context context)
         throws Exception
Creates an object to be injected.

Parameters:
context - of this injection
Returns:
instance to be injected
Throws:
Exception - if unable to create object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Inject (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.inject
Annotation Type Inject

@Target(value={METHOD,CONSTRUCTOR,FIELD,PARAMETER})
@Retention(value=RUNTIME)
public @interface Inject

Annotates members and parameters which should have their value[s] injected.

Author:
crazybob@google.com (Bob Lee)

Optional Element Summary
boolean | required Whether or not injection is required.
String | value Dependency name.

value

public abstract String value
Dependency name. Defaults to Container.DEFAULT_NAME.

Default:
"default"

required

public abstract boolean required
Whether or not injection is required. Applicable only to methods and fields (not constructors or parameters).

Default:
true
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


com.opensymphony.xwork2.inject (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.inject
Interfaces
Container
ContainerBuilder.Command
Context
Factory
Scope.Strategy
Classes
ContainerBuilder
Enums
Scope
Exceptions
DependencyException
Annotation Types
Inject
Scoped


com.opensymphony.xwork2.inject (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.inject

Guice (pronounced "juice").

See:
Description

Interface Summary
Container | Injects dependencies into constructors, methods and fields annotated with Inject.
ContainerBuilder.Command | Implemented by classes which participate in building a container.
Context | Context of the current injection.
Factory<T> | A custom factory.
Scope.Strategy | Pluggable scoping strategy.

Class Summary
ContainerBuilder Builds a dependency injection Container.

Enum Summary
Scope Scope of an injected objects.

Exception Summary
DependencyException Thrown when a dependency is misconfigured.

Annotation Types Summary
Inject | Annotates members and parameters which should have their value[s] injected.
Scoped | Annotates a scoped implementation class.

Package com.opensymphony.xwork2.inject Description

Guice (pronounced "juice"). A lightweight dependency injection container. Features include:

  • constructor, method, and field injection
  • static method and field injection
  • circular reference support (including constructors if you depend upon interfaces)
  • high performance
  • externalize what needs to be and no more


com.opensymphony.xwork2.inject Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.inject

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.inject.ContainerBuilder
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.opensymphony.xwork2.inject.DependencyException

Interface Hierarchy

  • com.opensymphony.xwork2.inject.ContainerBuilder.Command
  • com.opensymphony.xwork2.inject.Context
  • com.opensymphony.xwork2.inject.Factory<T>
  • com.opensymphony.xwork2.inject.Scope.Strategy
  • java.io.Serializable
    • com.opensymphony.xwork2.inject.Container

Annotation Type Hierarchy

  • com.opensymphony.xwork2.inject.Scoped (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.inject.Inject (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.opensymphony.xwork2.inject.Scope


Uses of Package com.opensymphony.xwork2.inject (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.inject

Packages that use com.opensymphony.xwork2.inject
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.conversion.impl |
com.opensymphony.xwork2.inject | Guice (pronounced "juice").
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.ognl |
com.opensymphony.xwork2.ognl.accessor |
com.opensymphony.xwork2.spring | Spring ObjectFactory classes.
com.opensymphony.xwork2.test |
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2
Container
Injects dependencies into constructors, methods and fields annotated with Inject.
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2.config
Container
Injects dependencies into constructors, methods and fields annotated with Inject.
ContainerBuilder
Builds a dependency injection Container.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2.config.impl
Container
Injects dependencies into constructors, methods and fields annotated with Inject.
Context
Context of the current injection.
Factory
A custom factory.
Scope
Scope of an injected objects.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2.config.providers
ContainerBuilder
Builds a dependency injection Container.
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2.conversion.impl
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2.inject
Container
Injects dependencies into constructors, methods and fields annotated with Inject.
ContainerBuilder
Builds a dependency injection Container.
Context
Context of the current injection.
Factory
A custom factory.
Scope
Scope of an injected objects.
Scope.Strategy
Pluggable scoping strategy.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2.interceptor
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2.ognl
Container
Injects dependencies into constructors, methods and fields annotated with Inject.
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2.ognl.accessor
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2.spring
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2.test
ContainerBuilder
Builds a dependency injection Container.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2.validator
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2.validator.validators
Inject
Annotates members and parameters which should have their value[s] injected.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Scope (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.opensymphony.xwork2.inject
Enum Scope

java.lang.Object
    extended by  java.lang.Enum<Scope>
        extended by  com.opensymphony.xwork2.inject.Scope
All Implemented Interfaces:
Serializable, Comparable<Scope>
public enum Scope
extends Enum<Scope>

Scope of an injected objects.

Author:
crazybob

Nested Class Summary
static interface Scope.Strategy
Pluggable scoping strategy.
Enum Constant Summary
DEFAULT
One instance per injection.
REQUEST
One instance per request.
SESSION
One instance per session.
SINGLETON
One instance per container.
THREAD
One instance per thread.
WIZARD
One instance per wizard.
Method Summary
static Scope | valueOf(String name) Returns the enum constant of this type with the specified name.
static Scope[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

DEFAULT

public static final Scope DEFAULT
One instance per injection.

SINGLETON

public static final Scope SINGLETON
One instance per container.

THREAD

public static final Scope THREAD
One instance per thread.

Note: if a thread local object strongly references its Container, neither the Container nor the object will be eligible for garbage collection, i.e. memory leak.

REQUEST

public static final Scope REQUEST
One instance per request.

SESSION

public static final Scope SESSION
One instance per session.

WIZARD

public static final Scope WIZARD
One instance per wizard.

Method Detail

values

public static Scope[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (Scope c : Scope.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Scope valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Scope.Strategy (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Interface Scope.Strategy

Enclosing class:
Scope
public static interface Scope.Strategy

Pluggable scoping strategy. Enables users to provide custom implementations of request, session, and wizard scopes. Implement and pass to Container.setScopeStrategy(com.opensymphony.xwork2.inject.Scope.Strategy).

Method Summary
<T> T
findInRequest(Class<T> type, String name, Callable<? extends T> factory)
Finds an object for the given type and name in the request scope.
<T> T
findInSession(Class<T> type, String name, Callable<? extends T> factory)
Finds an object for the given type and name in the session scope.
<T> T
findInWizard(Class<T> type, String name, Callable<? extends T> factory)
Finds an object for the given type and name in the wizard scope.

Method Detail

findInRequest

<T> T findInRequest(Class<T> type,
                    String name,
                    Callable<? extends T> factory)
                throws Exception
Finds an object for the given type and name in the request scope. Creates a new object if necessary using the given factory.

Throws:
Exception

findInSession

<T> T findInSession(Class<T> type,
                    String name,
                    Callable<? extends T> factory)
                throws Exception
Finds an object for the given type and name in the session scope. Creates a new object if necessary using the given factory.

Throws:
Exception

findInWizard

<T> T findInWizard(Class<T> type,
                   String name,
                   Callable<? extends T> factory)
               throws Exception
Finds an object for the given type and name in the wizard scope. Creates a new object if necessary using the given factory.

Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Scoped (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

com.opensymphony.xwork2.inject
Annotation Type Scoped

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Scoped

Annotates a scoped implementation class.

Author:
crazybob

Required Element Summary
 Scope value
Scope.

Element Detail

value

public abstract Scope value
Scope.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT


Uses of Interface com.opensymphony.xwork2.inject.Container (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.Container

Packages that use Container
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.inject | Guice (pronounced "juice").
com.opensymphony.xwork2.ognl |

Uses of Container in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as Container
protected Container | XWorkTestCase.container
protected Container | TestNGXWorkTestCase.container
protected Container | DefaultActionProxyFactory.container
protected Container | DefaultActionInvocation.container

Methods in com.opensymphony.xwork2 that return Container
 Container ActionContext.getContainer()
Sets the container for this request

Methods in com.opensymphony.xwork2 with parameters of type Container
void | ObjectFactory.setContainer(Container container)
void | DefaultUnknownHandlerManager.setContainer(Container container)
void | DefaultActionProxyFactory.setContainer(Container container)
void | DefaultActionInvocation.setContainer(Container cont)
void | ActionContext.setContainer(Container cont) Gets the container for this request

Uses of Container in com.opensymphony.xwork2.config

Methods in com.opensymphony.xwork2.config that return Container
 Container Configuration.getContainer()

Uses of Container in com.opensymphony.xwork2.config.impl

Fields in com.opensymphony.xwork2.config.impl declared as Container
protected  Container DefaultConfiguration.container

Methods in com.opensymphony.xwork2.config.impl that return Container
protected Container | DefaultConfiguration.createBootstrapContainer()
Container | MockConfiguration.getContainer()
Container | DefaultConfiguration.getContainer()

Methods in com.opensymphony.xwork2.config.impl with parameters of type Container
protected  ActionContext DefaultConfiguration.setContext(Container cont)

Uses of Container in com.opensymphony.xwork2.inject

Methods in com.opensymphony.xwork2.inject that return Container
Container | ContainerBuilder.create(boolean loadSingletons) Creates a Container instance.
Container | Context.getContainer() Gets the Container.

Uses of Container in com.opensymphony.xwork2.ognl

Methods in com.opensymphony.xwork2.ognl with parameters of type Container
 void OgnlValueStackFactory.setContainer(Container container)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.ContainerBuilder (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.inject.ContainerBuilder

Packages that use ContainerBuilder
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.inject | Guice (pronounced "juice").
com.opensymphony.xwork2.test |

Uses of ContainerBuilder in com.opensymphony.xwork2.config

Methods in com.opensymphony.xwork2.config with parameters of type ContainerBuilder
 void ContainerProvider.register(ContainerBuilder builder, LocatableProperties props)
Registers beans and properties for the Container

Uses of ContainerBuilder in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers with parameters of type ContainerBuilder
void | XWorkConfigurationProvider.register(ContainerBuilder builder, LocatableProperties props)
void | XmlConfigurationProvider.register(ContainerBuilder containerBuilder, LocatableProperties props)

Uses of ContainerBuilder in com.opensymphony.xwork2.inject

Methods in com.opensymphony.xwork2.inject that return ContainerBuilder
<T> ContainerBuilder
ContainerBuilder.alias(Class<T> type, String alias)
Convenience method. Equivalent to alias(type, Container.DEFAULT_NAME, type).
<T> ContainerBuilder
ContainerBuilder.alias(Class<T> type, String name, String alias)
Maps an existing factory to a new name.
 ContainerBuilder ContainerBuilder.constant(String name, boolean value)
Maps a constant value to the given name.
 ContainerBuilder ContainerBuilder.constant(String name, char value)
Maps a constant value to the given name.
 ContainerBuilder ContainerBuilder.constant(String name, Class value)
Maps a class to the given name.
 ContainerBuilder ContainerBuilder.constant(String name, double value)
Maps a constant value to the given name.
<E extends Enum<E>>
ContainerBuilder
ContainerBuilder.constant(String name, E value)
Maps an enum to the given name.
 ContainerBuilder ContainerBuilder.constant(String name, float value)
Maps a constant value to the given name.
 ContainerBuilder ContainerBuilder.constant(String name, int value)
Maps a constant value to the given name.
 ContainerBuilder ContainerBuilder.constant(String name, long value)
Maps a constant value to the given name.
 ContainerBuilder ContainerBuilder.constant(String name, short value)
Maps a constant value to the given name.
 ContainerBuilder ContainerBuilder.constant(String name, String value)
Maps a constant value to the given name.
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, type).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Class<? extends T> implementation)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, implementation).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Class<? extends T> implementation, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, implementation, scope).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Factory<? extends T> factory)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, Scope.DEFAULT).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Factory<? extends T> factory, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, scope).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, type, scope).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name)
Convenience method. Equivalent to factory(type, name, type).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Class<? extends T> implementation)
Maps an implementation class to a given dependency type and name.
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Class<? extends T> implementation, Scope scope)
Maps an implementation class to a given dependency type and name.
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Factory<? extends T> factory)
Convenience method. Equivalent to factory(type, name, factory, Scope.DEFAULT).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Factory<? extends T> factory, Scope scope)
Maps a factory to a given dependency type and name.
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Scope scope)
Convenience method. Equivalent to factory(type, name, type, scope).
 ContainerBuilder ContainerBuilder.injectStatics(Class<?>... types)
Upon creation, the Container will inject static fields and methods into the given classes.

Methods in com.opensymphony.xwork2.inject with parameters of type ContainerBuilder
 void ContainerBuilder.Command.build(ContainerBuilder builder)
Contributes factories to the given builder.

Uses of ContainerBuilder in com.opensymphony.xwork2.test

Methods in com.opensymphony.xwork2.test with parameters of type ContainerBuilder
 void StubConfigurationProvider.register(ContainerBuilder builder, LocatableProperties props)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.inject.ContainerBuilder.Command (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.ContainerBuilder.Command

No usage of com.opensymphony.xwork2.inject.ContainerBuilder.Command

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.inject.Context (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.Context

Packages that use Context
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.inject | Guice (pronounced "juice").

Uses of Context in com.opensymphony.xwork2.config.impl

Methods in com.opensymphony.xwork2.config.impl with parameters of type Context
T | LocatableFactory.create(Context context)
T | LocatableConstantFactory.create(Context ignored)

Uses of Context in com.opensymphony.xwork2.inject

Methods in com.opensymphony.xwork2.inject with parameters of type Context
 T Factory.create(Context context)
Creates an object to be injected.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.DependencyException (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.inject.DependencyException

No usage of com.opensymphony.xwork2.inject.DependencyException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.inject.Factory (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.Factory

Packages that use Factory
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.inject | Guice (pronounced "juice").

Uses of Factory in com.opensymphony.xwork2.config.impl

Classes in com.opensymphony.xwork2.config.impl that implement Factory
class | LocatableConstantFactory<T> Factory that remembers where a constant came from
class | LocatableFactory<T> Attaches location information to the factory.

Uses of Factory in com.opensymphony.xwork2.inject

Methods in com.opensymphony.xwork2.inject with parameters of type Factory
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Factory<? extends T> factory)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, Scope.DEFAULT).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Factory<? extends T> factory, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, scope).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Factory<? extends T> factory)
Convenience method. Equivalent to factory(type, name, factory, Scope.DEFAULT).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Factory<? extends T> factory, Scope scope)
Maps a factory to a given dependency type and name.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.Inject (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.inject.Inject

Packages that use Inject
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.conversion.impl |
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.ognl |
com.opensymphony.xwork2.ognl.accessor |
com.opensymphony.xwork2.spring | Spring ObjectFactory classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Uses of Inject in com.opensymphony.xwork2

Methods in com.opensymphony.xwork2 with annotations of type Inject
void | DefaultActionProxy.setActionEventListener(ActionEventListener listener)
void | DefaultActionInvocation.setActionEventListener(ActionEventListener listener)
void | ActionChainResult.setActionProxyFactory(ActionProxyFactory actionProxyFactory)
void | ObjectFactory.setClassLoader(ClassLoader cl)
void | DefaultUnknownHandlerManager.setConfiguration(Configuration configuration)
void | DefaultActionProxy.setConfiguration(Configuration config)
void | DefaultActionInvocation.setConfiguration(Configuration configuration)
void | ObjectFactory.setContainer(Container container)
void | DefaultUnknownHandlerManager.setContainer(Container container)
void | DefaultActionProxyFactory.setContainer(Container container)
void | DefaultActionInvocation.setContainer(Container cont)
void | DefaultActionProxy.setObjectFactory(ObjectFactory factory)
void | DefaultActionInvocation.setObjectFactory(ObjectFactory fac)
void | ObjectFactory.setReflectionProvider(ReflectionProvider prov)
void | TextProviderFactory.setTextProvider(TextProvider textProvider)
void | DefaultActionProxy.setUnknownHandler(UnknownHandlerManager unknownHandlerManager)
void | DefaultActionInvocation.setUnknownHandlerManager(UnknownHandlerManager unknownHandlerManager)
void | DefaultActionInvocation.setValueStackFactory(ValueStackFactory fac)

Uses of Inject in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers with annotations of type Inject
 void XmlConfigurationProvider.setObjectFactory(ObjectFactory objectFactory)

Uses of Inject in com.opensymphony.xwork2.conversion.impl

Methods in com.opensymphony.xwork2.conversion.impl with annotations of type Inject
void | XWorkConverter.setDefaultTypeConverter(XWorkBasicConverter conv)
void | XWorkConverter.setObjectFactory(ObjectFactory factory)
void | XWorkBasicConverter.setObjectFactory(ObjectFactory fac)
void | InstantiatingNullHandler.setObjectFactory(ObjectFactory fac)
void | XWorkBasicConverter.setObjectTypeDeterminer(ObjectTypeDeterminer det)
void | InstantiatingNullHandler.setObjectTypeDeterminer(ObjectTypeDeterminer det)
void | InstantiatingNullHandler.setReflectionProvider(ReflectionProvider prov)
void | XWorkBasicConverter.setXWorkConverter(XWorkConverter conv)

Constructors in com.opensymphony.xwork2.conversion.impl with annotations of type Inject
DefaultObjectTypeDeterminer(XWorkConverter conv, ReflectionProvider prov)

Constructor parameters in com.opensymphony.xwork2.conversion.impl with annotations of type Inject
DefaultObjectTypeDeterminer(XWorkConverter conv, ReflectionProvider prov)
DefaultObjectTypeDeterminer(XWorkConverter conv, ReflectionProvider prov)

Uses of Inject in com.opensymphony.xwork2.interceptor

Methods in com.opensymphony.xwork2.interceptor with annotations of type Inject
static void | StaticParametersInterceptor.setDevMode(String mode)
static void | ParametersInterceptor.setDevMode(String mode)
static void | AliasInterceptor.setDevMode(String mode)
void | ScopedModelDrivenInterceptor.setObjectFactory(ObjectFactory factory)
void | ChainingInterceptor.setReflectionProvider(ReflectionProvider prov)
void | StaticParametersInterceptor.setValueStackFactory(ValueStackFactory valueStackFactory)
void | ParametersInterceptor.setValueStackFactory(ValueStackFactory valueStackFactory)
void | AliasInterceptor.setValueStackFactory(ValueStackFactory valueStackFactory)

Uses of Inject in com.opensymphony.xwork2.ognl

Methods in com.opensymphony.xwork2.ognl with annotations of type Inject
void | OgnlValueStackFactory.setAllowStaticMethodAccess(String allowStaticMethodAccess)
void | OgnlValueStackFactory.setContainer(Container container)
void | OgnlValueStack.setDevMode(String mode)
static void | OgnlUtil.setDevMode(String mode)
static void | OgnlUtil.setEnableExpressionCache(String cache)
void | OgnlValueStack.setLogMissingProperties(String logMissingProperties)
void | OgnlValueStack.setOgnlUtil(OgnlUtil ognlUtil)
void | OgnlReflectionProvider.setOgnlUtil(OgnlUtil ognlUtil)
void | OgnlValueStackFactory.setTextProvider(TextProvider textProvider)
void | OgnlValueStackFactory.setXWorkConverter(XWorkConverter conv)
void | OgnlUtil.setXWorkConverter(XWorkConverter conv)

Uses of Inject in com.opensymphony.xwork2.ognl.accessor

Methods in com.opensymphony.xwork2.ognl.accessor with annotations of type Inject
static void | CompoundRootAccessor.setDevMode(String mode)
void | XWorkMapPropertyAccessor.setObjectFactory(ObjectFactory fac)
void | XWorkListPropertyAccessor.setObjectFactory(ObjectFactory fac)
void | XWorkCollectionPropertyAccessor.setObjectFactory(ObjectFactory fac)
void | XWorkMapPropertyAccessor.setObjectTypeDeterminer(ObjectTypeDeterminer ot)
void | XWorkListPropertyAccessor.setObjectTypeDeterminer(ObjectTypeDeterminer ot)
void | XWorkCollectionPropertyAccessor.setObjectTypeDeterminer(ObjectTypeDeterminer ot)
void | XWorkListPropertyAccessor.setOgnlUtil(OgnlUtil util)
void | XWorkListPropertyAccessor.setXWorkCollectionPropertyAccessor(ognl.PropertyAccessor acc)
void | XWorkMapPropertyAccessor.setXWorkConverter(XWorkConverter conv)
void | XWorkListPropertyAccessor.setXWorkConverter(XWorkConverter conv)
void | XWorkCollectionPropertyAccessor.setXWorkConverter(XWorkConverter conv)

Uses of Inject in com.opensymphony.xwork2.spring

Methods in com.opensymphony.xwork2.spring with annotations of type Inject
 void SpringObjectFactory.setApplicationContextPath(String ctx)

Uses of Inject in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with annotations of type Inject
void | ValidationInterceptor.setActionValidatorManager(ActionValidatorManager mgr)
void | DefaultValidatorFileParser.setMultiTextvalueSeparator(String type)
void | DefaultValidatorFileParser.setObjectFactory(ObjectFactory fac)
void | DefaultActionValidatorManager.setValidatorFactory(ValidatorFactory fac)
void | AnnotationActionValidatorManager.setValidatorFactory(ValidatorFactory fac)
void | DefaultActionValidatorManager.setValidatorFileParser(ValidatorFileParser parser)
void | AnnotationActionValidatorManager.setValidatorFileParser(ValidatorFileParser parser)

Constructors in com.opensymphony.xwork2.validator with annotations of type Inject
DefaultValidatorFactory(ObjectFactory objectFactory, ValidatorFileParser parser)

Constructor parameters in com.opensymphony.xwork2.validator with annotations of type Inject
DefaultValidatorFactory(ObjectFactory objectFactory, ValidatorFileParser parser)
DefaultValidatorFactory(ObjectFactory objectFactory, ValidatorFileParser parser)

Uses of Inject in com.opensymphony.xwork2.validator.validators

Methods in com.opensymphony.xwork2.validator.validators with annotations of type Inject
 void VisitorFieldValidator.setActionValidatorManager(ActionValidatorManager mgr)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.Scope (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.inject.Scope

Packages that use Scope
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.inject | Guice (pronounced "juice").

Uses of Scope in com.opensymphony.xwork2.config.impl

Constructors in com.opensymphony.xwork2.config.impl with parameters of type Scope
LocatableFactory(String name, Class type, Class implementation, Scope scope, Object location)

Uses of Scope in com.opensymphony.xwork2.inject

Methods in com.opensymphony.xwork2.inject that return Scope
static Scope | Scope.valueOf(String name) Returns the enum constant of this type with the specified name.
static Scope[] | Scope.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in com.opensymphony.xwork2.inject with parameters of type Scope
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Class<? extends T> implementation, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, implementation, scope).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Factory<? extends T> factory, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, scope).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, type, scope).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Class<? extends T> implementation, Scope scope)
Maps an implementation class to a given dependency type and name.
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Factory<? extends T> factory, Scope scope)
Maps a factory to a given dependency type and name.
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Scope scope)
Convenience method. Equivalent to factory(type, name, type, scope).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.inject.Scope.Strategy (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.Scope.Strategy

Packages that use Scope.Strategy
com.opensymphony.xwork2.inject Guice (pronounced "juice").

Uses of Scope.Strategy in com.opensymphony.xwork2.inject

Methods in com.opensymphony.xwork2.inject that return Scope.Strategy
 Scope.Strategy Context.getScopeStrategy()
Gets the current scope strategy.

Methods in com.opensymphony.xwork2.inject with parameters of type Scope.Strategy
 void Container.setScopeStrategy(Scope.Strategy scopeStrategy)
Sets the scope strategy for the current thread.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.Scoped (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.inject.Scoped

No usage of com.opensymphony.xwork2.inject.Scoped

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


FinalizablePhantomReference (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class FinalizablePhantomReference<T>

java.lang.Object
    extended by  java.lang.ref.Reference<T>
        extended by  java.lang.ref.PhantomReference<T>
            extended by  com.opensymphony.xwork2.inject.util.FinalizablePhantomReference<T>

public abstract class FinalizablePhantomReference<T>
extends PhantomReference<T>

Phantom reference with a finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent. This is a simpler alternative to using a ReferenceQueue.

Author:
crazybob@google.com (Bob Lee)

Constructor Summary
protected FinalizablePhantomReference(T referent)
Method Summary
 void finalizeReferent()
Invoked on a background thread after the referent has been garbage collected.
Methods inherited from class java.lang.ref.PhantomReference
get
Methods inherited from class java.lang.ref.Reference
clear, enqueue, isEnqueued
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FinalizablePhantomReference

protected FinalizablePhantomReference(T referent)
Method Detail

finalizeReferent

public void finalizeReferent()
Invoked on a background thread after the referent has been garbage collected.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


FinalizableSoftReference (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class FinalizableSoftReference<T>

java.lang.Object
    extended by  java.lang.ref.Reference<T>
        extended by  java.lang.ref.SoftReference<T>
            extended by  com.opensymphony.xwork2.inject.util.FinalizableSoftReference<T>

public abstract class FinalizableSoftReference<T>
extends SoftReference<T>

Soft reference with a finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent. This is a simpler alternative to using a ReferenceQueue.

Author:
crazybob@google.com (Bob Lee)

Constructor Summary
protected FinalizableSoftReference(T referent)
Method Summary
 void finalizeReferent()
Invoked on a background thread after the referent has been garbage collected.
Methods inherited from class java.lang.ref.SoftReference
get
Methods inherited from class java.lang.ref.Reference
clear, enqueue, isEnqueued
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FinalizableSoftReference

protected FinalizableSoftReference(T referent)
Method Detail

finalizeReferent

public void finalizeReferent()
Invoked on a background thread after the referent has been garbage collected.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FinalizableWeakReference (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class FinalizableWeakReference<T>

java.lang.Object
    extended by  java.lang.ref.Reference<T>
        extended by  java.lang.ref.WeakReference<T>
            extended by  com.opensymphony.xwork2.inject.util.FinalizableWeakReference<T>

public abstract class FinalizableWeakReference<T>
extends WeakReference<T>

Weak reference with a finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent. This is a simpler alternative to using a ReferenceQueue.

Author:
crazybob@google.com (Bob Lee)

Constructor Summary
protected FinalizableWeakReference(T referent)
Method Summary
 void finalizeReferent()
Invoked on a background thread after the referent has been garbage collected.
Methods inherited from class java.lang.ref.Reference
clear, enqueue, get, isEnqueued
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FinalizableWeakReference

protected FinalizableWeakReference(T referent)
Method Detail

finalizeReferent

public void finalizeReferent()
Invoked on a background thread after the referent has been garbage collected.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Function (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Interface Function<F,T>

public interface Function<F,T>

A Function provides a transformation on an object and returns the resulting object. For example, a StringToIntegerFunction may implement Function<String,Integer> and transform integers in String format to Integer format.

The transformation on the source object does not necessarily result in an object of a different type. For example, a FarenheitToCelciusFunction may implement Function<Float,Float>.

Implementors of Function which may cause side effects upon evaluation are strongly encouraged to state this fact clearly in their API documentation.

Method Summary
 T apply(F from)
Applies the function to an object of type F, resulting in an object of type T.

Method Detail

apply

T apply(F from)
Applies the function to an object of type F, resulting in an object of type T. Note that types F and T may or may not be the same.

Parameters:
from - The source object.
Returns:
The resulting object.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.inject.util (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.inject.util
Interfaces
Function
ReferenceMap.Strategy
Classes
FinalizablePhantomReference
FinalizableSoftReference
FinalizableWeakReference
ReferenceCache
ReferenceMap
Strings
Enums
ReferenceType


com.opensymphony.xwork2.inject.util (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.inject.util

Guice util classes.

See:
Description

Interface Summary
Function<F,T> | A Function provides a transformation on an object and returns the resulting object.
ReferenceMap.Strategy |

Class Summary
FinalizablePhantomReference<T> | Phantom reference with a finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent.
FinalizableSoftReference<T> | Soft reference with a finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent.
FinalizableWeakReference<T> | Weak reference with a finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent.
ReferenceCache<K,V> | Extends ReferenceMap to support lazy loading values by overriding ReferenceCache.create(Object).
ReferenceMap<K,V> | Concurrent hash map that wraps keys and/or values in soft or weak references.
Strings | String utilities.

Enum Summary
ReferenceType Reference type.

Package com.opensymphony.xwork2.inject.util Description

Guice util classes.


com.opensymphony.xwork2.inject.util Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.inject.util

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.ref.Reference<T>
      • java.lang.ref.PhantomReference<T>
        • com.opensymphony.xwork2.inject.util.FinalizablePhantomReference<T>
      • java.lang.ref.SoftReference<T>
        • com.opensymphony.xwork2.inject.util.FinalizableSoftReference<T>
      • java.lang.ref.WeakReference<T>
        • com.opensymphony.xwork2.inject.util.FinalizableWeakReference<T>
    • com.opensymphony.xwork2.inject.util.ReferenceMap<K,V> (implements java.util.Map<K,V>, java.io.Serializable)
      • com.opensymphony.xwork2.inject.util.ReferenceCache<K,V>
    • com.opensymphony.xwork2.inject.util.Strings

Interface Hierarchy

  • com.opensymphony.xwork2.inject.util.Function<F,T>
  • com.opensymphony.xwork2.inject.util.ReferenceMap.Strategy

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.opensymphony.xwork2.inject.util.ReferenceType


Uses of Package com.opensymphony.xwork2.inject.util (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.inject.util

Packages that use com.opensymphony.xwork2.inject.util
com.opensymphony.xwork2.inject.util Guice util classes.

Classes in com.opensymphony.xwork2.inject.util used by com.opensymphony.xwork2.inject.util
Function
A Function provides a transformation on an object and returns the resulting object.
ReferenceCache
Extends ReferenceMap to support lazy loading values by overriding ReferenceCache.create(Object).
ReferenceMap
Concurrent hash map that wraps keys and/or values in soft or weak references.
ReferenceMap.Strategy
ReferenceType
Reference type.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ReferenceCache (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class ReferenceCache<K,V>

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.util.ReferenceMap<K,V>
        extended by  com.opensymphony.xwork2.inject.util.ReferenceCache<K,V>
All Implemented Interfaces:
Serializable, Map<K,V>
public abstract class ReferenceCache<K,V>
extends ReferenceMap<K,V>

Extends ReferenceMap to support lazy loading values by overriding create(Object).

Author:
crazybob@google.com (Bob Lee)
See Also:
Serialized Form

Nested Class Summary
Nested classes/interfaces inherited from class com.opensymphony.xwork2.inject.util.ReferenceMap
ReferenceMap.Strategy
Constructor Summary
ReferenceCache()
Equivalent to new ReferenceCache(STRONG, STRONG).
ReferenceCache(ReferenceType keyReferenceType, ReferenceType valueReferenceType)
Method Summary
protected  void cancel()
Cancels the current create(Object).
protected abstract  V create(K key)
Override to lazy load values.
 V get(Object key)
If this map does not contain an entry for the given key and create(Object) has been overridden, this method will create a new value, put it in the map, and return it.
static
<K,V> ReferenceCache<K,V>
of(ReferenceType keyReferenceType, ReferenceType valueReferenceType, Function<? super K,? extends V> function)
Returns a ReferenceCache delegating to the specified function.
Methods inherited from class com.opensymphony.xwork2.inject.util.ReferenceMap
clear, containsKey, containsValue, entrySet, getPutStrategy, isEmpty, keySet, put, putAll, putIfAbsent, putIfAbsentStrategy, putStrategy, remove, remove, replace, replace, replaceStrategy, size, values
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Map
equals, hashCode

Constructor Detail

ReferenceCache

public ReferenceCache(ReferenceType keyReferenceType,
                      ReferenceType valueReferenceType)

ReferenceCache

public ReferenceCache()
Equivalent to new ReferenceCache(STRONG, STRONG).

Method Detail

create

protected abstract V create(K key)
Override to lazy load values. Use as an alternative to ReferenceMap.put(Object,Object). Invoked by getter if value isn't already cached. Must not return null. This method will not be called again until the garbage collector reclaims the returned value.

get

public V get(Object key)
If this map does not contain an entry for the given key and create(Object) has been overridden, this method will create a new value, put it in the map, and return it.

Specified by:
get in interface Map<K,V>
Overrides:
get in class ReferenceMap<K,V>
Throws:
NullPointerException - if create(Object) returns null.
CancellationException - if the creation is cancelled. See cancel().

cancel

protected void cancel()
Cancels the current create(Object). Throws CancellationException to all clients currently blocked on get(Object).

of

public static <K,V> ReferenceCache<K,V> of(ReferenceType keyReferenceType,
                                           ReferenceType valueReferenceType,
                                           Function<? super K,? extends V> function)
Returns a ReferenceCache delegating to the specified function. The specified function must not return null.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReferenceMap (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class ReferenceMap<K,V>

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.util.ReferenceMap<K,V>
All Implemented Interfaces:
Serializable, Map<K,V>
Direct Known Subclasses:
ReferenceCache
public class ReferenceMap<K,V>
extends Object
implements Map<K,V>, Serializable

Concurrent hash map that wraps keys and/or values in soft or weak references. Does not support null keys or values. Uses identity equality for weak and soft keys.

The concurrent semantics of ConcurrentHashMap combined with the fact that the garbage collector can asynchronously reclaim and clean up after keys and values at any time can lead to some racy semantics. For example, size() returns an upper bound on the size, i.e. the actual size may be smaller in cases where the key or value has been reclaimed but the map entry has not been cleaned up yet.

Another example: If get(Object) cannot find an existing entry for a key, it will try to create one. This operation is not atomic. One thread could put(Object, Object) a value between the time another thread running get() checks for an entry and decides to create one. In this case, the newly created value will replace the put value in the map. Also, two threads running get() concurrently can potentially create duplicate values for a given key.

In other words, this class is great for caching but not atomicity.

Author:
crazybob@google.com (Bob Lee)
See Also:
Serialized Form

Nested Class Summary
protected static interface ReferenceMap.Strategy
Constructor Summary
ReferenceMap(ReferenceType keyReferenceType, ReferenceType valueReferenceType)
Concurrent hash map that wraps keys and/or values based on specified reference types.
Method Summary
void | clear()
boolean | containsKey(Object key)
boolean | containsValue(Object value)
Set<Map.Entry<K,V>> | entrySet() Returns an unmodifiable set view of the entries in this map.
V | get(Object key)
protected com.opensymphony.xwork2.inject.util.ReferenceMap.PutStrategy | getPutStrategy()
boolean | isEmpty()
Set<K> | keySet() Returns an unmodifiable set view of the keys in this map.
V | put(K key, V value)
void | putAll(Map<? extends K,? extends V> t)
V | putIfAbsent(K key, V value)
protected ReferenceMap.Strategy | putIfAbsentStrategy()
protected ReferenceMap.Strategy | putStrategy()
V | remove(Object key)
boolean | remove(Object key, Object value)
V | replace(K key, V value)
boolean | replace(K key, V oldValue, V newValue)
protected ReferenceMap.Strategy | replaceStrategy()
int | size()
Collection<V> | values() Returns an unmodifiable set view of the values in this map.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Map
equals, hashCode

Constructor Detail

ReferenceMap

public ReferenceMap(ReferenceType keyReferenceType,
                    ReferenceType valueReferenceType)
Concurrent hash map that wraps keys and/or values based on specified reference types.

Parameters:
keyReferenceType - key reference type
valueReferenceType - value reference type
Method Detail

get

public V get(Object key)
Specified by:
get in interface Map<K,V>

put

public V put(K key,
             V value)
Specified by:
put in interface Map<K,V>

remove

public V remove(Object key)
Specified by:
remove in interface Map<K,V>

size

public int size()
Specified by:
size in interface Map<K,V>

isEmpty

public boolean isEmpty()
Specified by:
isEmpty in interface Map<K,V>

containsKey

public boolean containsKey(Object key)
Specified by:
containsKey in interface Map<K,V>

containsValue

public boolean containsValue(Object value)
Specified by:
containsValue in interface Map<K,V>

putAll

public void putAll(Map<? extends K,? extends V> t)
Specified by:
putAll in interface Map<K,V>

clear

public void clear()
Specified by:
clear in interface Map<K,V>

keySet

public Set<K> keySet()
Returns an unmodifiable set view of the keys in this map. As this method creates a defensive copy, the performance is O(n).

Specified by:
keySet in interface Map<K,V>

values

public Collection<V> values()
Returns an unmodifiable set view of the values in this map. As this method creates a defensive copy, the performance is O(n).

Specified by:
values in interface Map<K,V>

putIfAbsent

public V putIfAbsent(K key,
                     V value)

remove

public boolean remove(Object key,
                      Object value)

replace

public boolean replace(K key,
                       V oldValue,
                       V newValue)

replace

public V replace(K key,
                 V value)

entrySet

public Set<Map.Entry<K,V>> entrySet()
Returns an unmodifiable set view of the entries in this map. As this method creates a defensive copy, the performance is O(n).

Specified by:
entrySet in interface Map<K,V>

putStrategy

protected ReferenceMap.Strategy putStrategy()

putIfAbsentStrategy

protected ReferenceMap.Strategy putIfAbsentStrategy()

replaceStrategy

protected ReferenceMap.Strategy replaceStrategy()

getPutStrategy

protected com.opensymphony.xwork2.inject.util.ReferenceMap.PutStrategy getPutStrategy()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReferenceMap.Strategy (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Interface ReferenceMap.Strategy

Enclosing class:
ReferenceMap<K,V>
protected static interface ReferenceMap.Strategy

Method Summary
 Object execute(ReferenceMap map, Object keyReference, Object valueReference)

Method Detail

execute

Object execute(ReferenceMap map,
               Object keyReference,
               Object valueReference)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReferenceType (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.opensymphony.xwork2.inject.util
Enum ReferenceType

java.lang.Object
    extended by  java.lang.Enum<ReferenceType>
        extended by  com.opensymphony.xwork2.inject.util.ReferenceType
All Implemented Interfaces:
Serializable, Comparable<ReferenceType>
public enum ReferenceType
extends Enum<ReferenceType>

Reference type. Used to specify what type of reference to keep to a referent.

Author:
crazybob@google.com (Bob Lee)
See Also:
Reference

Enum Constant Summary
PHANTOM
Similar to weak references except the garbage collector doesn't actually reclaim the referent.
SOFT
Referent reclaimed in an LRU fashion when the VM runs low on memory and no strong references exist.
STRONG
Prevents referent from being reclaimed by the garbage collector.
WEAK
Referent reclaimed when no strong or soft references exist.
Method Summary
static ReferenceType | valueOf(String name) Returns the enum constant of this type with the specified name.
static ReferenceType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

STRONG

public static final ReferenceType STRONG
Prevents referent from being reclaimed by the garbage collector.

SOFT

public static final ReferenceType SOFT
Referent reclaimed in an LRU fashion when the VM runs low on memory and no strong references exist.

See Also:
SoftReference

WEAK

public static final ReferenceType WEAK
Referent reclaimed when no strong or soft references exist.

See Also:
WeakReference

PHANTOM

public static final ReferenceType PHANTOM
Similar to weak references except the garbage collector doesn't actually reclaim the referent. More flexible alternative to finalization.

See Also:
PhantomReference
Method Detail

values

public static ReferenceType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (ReferenceType c : ReferenceType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static ReferenceType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
NullPointerException - if the argument is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Strings (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class Strings

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.util.Strings

public class Strings
extends Object

String utilities.

Author:
crazybob@google.com (Bob Lee)

Constructor Summary
Strings()
Method Summary
static String capitalize(String s)
Returns a string that is equivalent to the specified string with its first character converted to uppercase as by String.toUpperCase(java.util.Locale).
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Strings

public Strings()
Method Detail

capitalize

public static String capitalize(String s)
Returns a string that is equivalent to the specified string with its first character converted to uppercase as by String.toUpperCase(java.util.Locale). The returned string will have the same value as the specified string if its first character is non-alphabetic, if its first character is already uppercase, or if the specified string is of length 0.

For example:

    capitalize("foo bar").equals("Foo bar");
    capitalize("2b or not 2b").equals("2b or not 2b")
    capitalize("Foo bar").equals("Foo bar");
    capitalize("").equals("");

Parameters:
s - the string whose first character is to be uppercased
Returns:
a string equivalent to s with its first character converted to uppercase
Throws:
NullPointerException - if s is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.opensymphony.xwork2.inject.util.FinalizablePhantomReference (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.FinalizablePhantomReference

No usage of com.opensymphony.xwork2.inject.util.FinalizablePhantomReference

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.FinalizableSoftReference (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.FinalizableSoftReference

No usage of com.opensymphony.xwork2.inject.util.FinalizableSoftReference

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.FinalizableWeakReference (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.FinalizableWeakReference

No usage of com.opensymphony.xwork2.inject.util.FinalizableWeakReference

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.inject.util.Function (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.util.Function

Packages that use Function
com.opensymphony.xwork2.inject.util Guice util classes.

Uses of Function in com.opensymphony.xwork2.inject.util

Methods in com.opensymphony.xwork2.inject.util with parameters of type Function
static
<K,V> ReferenceCache<K,V>
ReferenceCache.of(ReferenceType keyReferenceType, ReferenceType valueReferenceType, Function<? super K,? extends V> function)
Returns a ReferenceCache delegating to the specified function.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.ReferenceCache (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.ReferenceCache

Packages that use ReferenceCache
com.opensymphony.xwork2.inject.util Guice util classes.

Uses of ReferenceCache in com.opensymphony.xwork2.inject.util

Methods in com.opensymphony.xwork2.inject.util that return ReferenceCache
static
<K,V> ReferenceCache<K,V>
ReferenceCache.of(ReferenceType keyReferenceType, ReferenceType valueReferenceType, Function<? super K,? extends V> function)
Returns a ReferenceCache delegating to the specified function.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.ReferenceMap (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.ReferenceMap

Packages that use ReferenceMap
com.opensymphony.xwork2.inject.util Guice util classes.

Uses of ReferenceMap in com.opensymphony.xwork2.inject.util

Subclasses of ReferenceMap in com.opensymphony.xwork2.inject.util
 class ReferenceCache<K,V>
Extends ReferenceMap to support lazy loading values by overriding ReferenceCache.create(Object).

Methods in com.opensymphony.xwork2.inject.util with parameters of type ReferenceMap
 Object ReferenceMap.Strategy.execute(ReferenceMap map, Object keyReference, Object valueReference)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.inject.util.ReferenceMap.Strategy (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.util.ReferenceMap.Strategy

Packages that use ReferenceMap.Strategy
com.opensymphony.xwork2.inject.util Guice util classes.

Uses of ReferenceMap.Strategy in com.opensymphony.xwork2.inject.util

Methods in com.opensymphony.xwork2.inject.util that return ReferenceMap.Strategy
protected ReferenceMap.Strategy | ReferenceMap.putIfAbsentStrategy()
protected ReferenceMap.Strategy | ReferenceMap.putStrategy()
protected ReferenceMap.Strategy | ReferenceMap.replaceStrategy()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.ReferenceType (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.ReferenceType

Packages that use ReferenceType
com.opensymphony.xwork2.inject.util Guice util classes.

Uses of ReferenceType in com.opensymphony.xwork2.inject.util

Methods in com.opensymphony.xwork2.inject.util that return ReferenceType
static ReferenceType | ReferenceType.valueOf(String name) Returns the enum constant of this type with the specified name.
static ReferenceType[] | ReferenceType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in com.opensymphony.xwork2.inject.util with parameters of type ReferenceType
static
<K,V> ReferenceCache<K,V>
ReferenceCache.of(ReferenceType keyReferenceType, ReferenceType valueReferenceType, Function<? super K,? extends V> function)
Returns a ReferenceCache delegating to the specified function.

Constructors in com.opensymphony.xwork2.inject.util with parameters of type ReferenceType
ReferenceCache(ReferenceType keyReferenceType, ReferenceType valueReferenceType)
ReferenceMap(ReferenceType keyReferenceType, ReferenceType valueReferenceType)
Concurrent hash map that wraps keys and/or values based on specified reference types.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.Strings (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.Strings

No usage of com.opensymphony.xwork2.inject.util.Strings

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AbstractInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class AbstractInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
All Implemented Interfaces:
Interceptor, Serializable
Direct Known Subclasses:
ActionAutowiringInterceptor, AliasInterceptor, AnnotationParameterFilterIntereptor, ChainingInterceptor, ConversionErrorInterceptor, ExceptionMappingInterceptor, I18nInterceptor, LoggingInterceptor, MethodFilterInterceptor, ModelDrivenInterceptor, ParameterFilterInterceptor, ParameterRemoverInterceptor, ScopedModelDrivenInterceptor, StaticParametersInterceptor, TimerInterceptor
public abstract class AbstractInterceptor
extends Object
implements Interceptor

Provides default implementations of optional lifecycle methods

See Also:
Serialized Form

Constructor Summary
AbstractInterceptor()
Method Summary
void | destroy() Does nothing
void | init() Does nothing
abstract String | intercept(ActionInvocation invocation) Override to handle interception
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AbstractInterceptor

public AbstractInterceptor()
Method Detail

init

public void init()
Does nothing

Specified by:
init in interface Interceptor

destroy

public void destroy()
Does nothing

Specified by:
destroy in interface Interceptor

intercept

public abstract String intercept(ActionInvocation invocation)
                          throws Exception
Override to handle interception

Specified by:
intercept in interface Interceptor
Parameters:
invocation - the action invocation
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AliasInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class AliasInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.AliasInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class AliasInterceptor
extends AbstractInterceptor

The aim of this Interceptor is to alias a named parameter to a different named parameter. By acting as the glue between actions sharing similiar parameters (but with different names), it can help greatly with action chaining.

Action's alias expressions should be in the form of #{ "name1" : "alias1", "name2" : "alias2" }. This means that assuming an action (or something else in the stack) has a value for the expression named name1 and the action this interceptor is applied to has a setter named alias1, alias1 will be set with the value from name1.

Interceptor parameters:

  • aliasesKey (optional) - the name of the action parameter to look for the alias map (by default this is aliases).

Extending the interceptor:

This interceptor does not have any known extension points.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <!-- The value for the foo parameter will be applied as if it were named bar -->
     <param name="aliases">#{ 'foo' : 'bar' }</param>

     <interceptor-ref name="alias"/>
     <interceptor-ref name="basicStack"/>
     <result name="success">good_result.ftl</result>
 </action>

Author:
Matthew Payne
See Also:
Serialized Form

Field Summary
protected String | aliasesKey
protected ValueStackFactory | valueStackFactory
Constructor Summary
AliasInterceptor()
Method Summary
String | intercept(ActionInvocation invocation) Override to handle interception
void | setAliasesKey(String aliasesKey) Sets the name of the action parameter to look for the alias map.
static void | setDevMode(String mode)
void | setValueStackFactory(ValueStackFactory valueStackFactory)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

aliasesKey

protected String aliasesKey

valueStackFactory

protected ValueStackFactory valueStackFactory
Constructor Detail

AliasInterceptor

public AliasInterceptor()
Method Detail

setDevMode

public static void setDevMode(String mode)

setValueStackFactory

public void setValueStackFactory(ValueStackFactory valueStackFactory)

setAliasesKey

public void setAliasesKey(String aliasesKey)
Sets the name of the action parameter to look for the alias map.

Default is aliases.

Parameters:
aliasesKey - the name of the action parameter

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Parameters:
invocation - the action invocation
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChainingInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class ChainingInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.ChainingInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class ChainingInterceptor
extends AbstractInterceptor

An interceptor that copies all the properties of every object in the value stack to the currently executing object, except for any object that implements Unchainable. A collection of optional includes and excludes may be provided to control how and which parameters are copied. Only includes or excludes may be specified. Specifying both results in undefined behavior. See the javadocs for ReflectionProvider.copy(Object, Object, java.util.Map, java.util.Collection, java.util.Collection) for more information.

Note: It is important to remember that this interceptor does nothing if there are no objects already on the stack.
This means two things:
One, you can safely apply it to all your actions without any worry of adverse affects.
Two, it is up to you to ensure an object exists in the stack prior to invoking this action. The most typical way this is done is through the use of the chain result type, which combines with this interceptor to make up the action chaining feature.

Interceptor parameters:

  • excludes (optional) - the list of parameter names to exclude from copying (all others will be included).
  • includes (optional) - the list of parameter names to include when copying (all others will be excluded).

Extending the interceptor:

There are no known extension points to this interceptor.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="basicStack"/>
     <result name="success" type="chain">otherAction</result>
 </action>

 <action name="otherAction" class="com.examples.OtherAction">
     <interceptor-ref name="chain"/>
     <interceptor-ref name="basicStack"/>
     <result name="success">good_result.ftl</result>
 </action>

Author:
mrdon, tm_jee ( tm_jee(at)yahoo.co.uk )
See Also:
ActionChainResult, Serialized Form

Field Summary
protected Collection<String> | excludes
protected Collection<String> | includes
protected ReflectionProvider | reflectionProvider
Constructor Summary
ChainingInterceptor()
Method Summary
Collection<String> | getExcludes() Gets list of parameter names to exclude
Collection<String> | getIncludes() Gets list of parameter names to include
String | intercept(ActionInvocation invocation) Override to handle interception
void | setExcludes(Collection<String> excludes) Sets the list of parameter names to exclude from copying (all others will be included).
void | setIncludes(Collection<String> includes) Sets the list of parameter names to include when copying (all others will be excluded).
void | setReflectionProvider(ReflectionProvider prov)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

excludes

protected Collection<String> excludes

includes

protected Collection<String> includes

reflectionProvider

protected ReflectionProvider reflectionProvider
Constructor Detail

ChainingInterceptor

public ChainingInterceptor()
Method Detail

setReflectionProvider

public void setReflectionProvider(ReflectionProvider prov)

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Parameters:
invocation - the action invocation
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

getExcludes

public Collection<String> getExcludes()
Gets list of parameter names to exclude

Returns:
the exclude list

setExcludes

public void setExcludes(Collection<String> excludes)
Sets the list of parameter names to exclude from copying (all others will be included).

Parameters:
excludes - the excludes list

getIncludes

public Collection<String> getIncludes()
Gets list of parameter names to include

Returns:
the include list

setIncludes

public void setIncludes(Collection<String> includes)
Sets the list of parameter names to include when copying (all others will be excluded).

Parameters:
includes - the includes list
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConversionErrorInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class ConversionErrorInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class ConversionErrorInterceptor
extends AbstractInterceptor

ConversionErrorInterceptor adds conversion errors from the ActionContext to the Action's field errors.

This interceptor adds any error found in the ActionContext's conversionErrors map as a field error (provided that the action implements ValidationAware). In addition, any field that contains a validation error has its original value saved such that any subsequent requests for that value return the original value rather than the value in the action. This is important because if the value "abc" is submitted and can't be converted to an int, we want to display the original string ("abc") again rather than the int value (likely 0, which would make very little sense to the user).

Interceptor parameters:

  • None

Extending the interceptor:

Because this interceptor is not web-specific, it abstracts the logic for whether an error should be added. This allows for web-specific interceptors to use more complex logic in the shouldAddError(java.lang.String, java.lang.Object) method for when a value has a conversion error but is null or empty or otherwise indicates that the value was never actually entered by the user.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="params"/>
     <interceptor-ref name="conversionError"/>
     <result name="success">good_result.ftl</result>
 </action>

Author:
Jason Carreira
See Also:
Serialized Form

Field Summary
static String ORIGINAL_PROPERTY_OVERRIDE
Constructor Summary
ConversionErrorInterceptor()
Method Summary
protected Object | getOverrideExpr(ActionInvocation invocation, Object value)
String | intercept(ActionInvocation invocation) Override to handle interception
protected boolean | shouldAddError(String propertyName, Object value)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORIGINAL_PROPERTY_OVERRIDE

public static final String ORIGINAL_PROPERTY_OVERRIDE
See Also:
Constant Field Values
Constructor Detail

ConversionErrorInterceptor

public ConversionErrorInterceptor()
Method Detail

getOverrideExpr

protected Object getOverrideExpr(ActionInvocation invocation,
                                 Object value)

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Parameters:
invocation - the action invocation
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

shouldAddError

protected boolean shouldAddError(String propertyName,
                                 Object value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultWorkflowInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class DefaultWorkflowInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
            extended by  com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class DefaultWorkflowInterceptor
extends MethodFilterInterceptor

An interceptor that makes sure there are not validation errors before allowing the interceptor chain to continue. This interceptor does not perform any validation.

This interceptor does nothing if the name of the method being invoked is specified in the excludeMethods parameter. excludeMethods accepts a comma-delimited list of method names. For example, requests to foo!input.action and foo!back.action will be skipped by this interceptor if you set the excludeMethods parameter to "input, back".

Note: As this method extends off MethodFilterInterceptor, it is capable of deciding if it is applicable only to selective methods in the action class. This is done by adding param tags for the interceptor element, naming either a list of excluded method names and/or a list of included method names, whereby includeMethods overrides excludedMethods. A single * sign is interpreted as wildcard matching all methods for both parameters. See MethodFilterInterceptor for more info.

Interceptor parameters:

  • inputResultName - Default to "input". Determine the result name to be returned when an action / field error is found.

Extending the interceptor:

There are no known extension points for this interceptor.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="params"/>
     <interceptor-ref name="validation"/>
     <interceptor-ref name="workflow"/>
     <result name="success">good_result.ftl</result>
 </action>

 <-- In this case myMethod as well as mySecondMethod of the action class
        will not pass through the workflow process -->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="params"/>
     <interceptor-ref name="validation"/>
     <interceptor-ref name="workflow">
         <param name="excludeMethods">myMethod,mySecondMethod</param>
     </interceptor-ref name="workflow">
     <result name="success">good_result.ftl</result>
 </action>

 <-- In this case, the result named "error" will be used when
        an action / field error is found -->
 <-- The Interceptor will only be applied for myWorkflowMethod method of action
        classes, since this is the only included method while any others are excluded -->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="params"/>
     <interceptor-ref name="validation"/>
     <interceptor-ref name="workflow">
        <param name="inputResultName">error</param>
         <param name="excludeMethods">*</param>
         <param name="includeMethods">myWorkflowMethod</param>
     </interceptor-ref>
     <result name="success">good_result.ftl</result>
 </action>

Author:
Jason Carreira, Rainer Hermanns, Alexandru Popescu, Philip Luppens, tm_jee
See Also:
Serialized Form

Field Summary
Fields inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
excludeMethods, includeMethods, log
Constructor Summary
DefaultWorkflowInterceptor()
Method Summary
protected String | doIntercept(ActionInvocation invocation) Intercept ActionInvocation and returns a inputResultName when action / field errors is found registered.
void | setInputResultName(String inputResultName) Set the inputResultName (result name to be returned when a action / field error is found registered).
Methods inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
applyInterceptor, getExcludeMethodsSet, getIncludeMethodsSet, intercept, setExcludeMethods, setIncludeMethods
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultWorkflowInterceptor

public DefaultWorkflowInterceptor()
Method Detail

setInputResultName

public void setInputResultName(String inputResultName)
Set the inputResultName (result name to be returned when a action / field error is found registered). Default to Action.INPUT

Parameters:
inputResultName - what result name to use when there was validation error(s).

doIntercept

protected String doIntercept(ActionInvocation invocation)
                      throws Exception
Intercept ActionInvocation and returns a inputResultName when action / field errors is found registered.

Specified by:
doIntercept in class MethodFilterInterceptor
Parameters:
invocation - the action invocation
Returns:
String result name
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExceptionHolder (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class ExceptionHolder

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.ExceptionHolder
All Implemented Interfaces:
Serializable
public class ExceptionHolder
extends Object
implements Serializable

A simple wrapper around an exception, providing an easy way to print out the stack trace of the exception as well as a way to get a handle on the exception itself.

Author:
Matthew E. Porter (matthew dot porter at metissian dot com)
See Also:
Serialized Form

Constructor Summary
ExceptionHolder(Exception exception)
Holds the given exception
Method Summary
 Exception getException()
Gets the holded exception
 String getExceptionStack()
Gets the holded exception stacktrace using Throwable.printStackTrace().
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExceptionHolder

public ExceptionHolder(Exception exception)
Holds the given exception

Parameters:
exception - the exception to hold.
Method Detail

getException

public Exception getException()
Gets the holded exception

Returns:
the holded exception

getExceptionStack

public String getExceptionStack()
Gets the holded exception stacktrace using Throwable.printStackTrace().

Returns:
stacktrace
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExceptionMappingInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class ExceptionMappingInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class ExceptionMappingInterceptor
extends AbstractInterceptor

This interceptor forms the core functionality of the exception handling feature. Exception handling allows you to map an exception to a result code, just as if the action returned a result code instead of throwing an unexpected exception. When an exception is encountered, it is wrapped with an ExceptionHolder and pushed on the stack, providing easy access to the exception from within your result. Note: While you can configure exception mapping in your configuration file at any point, the configuration will not have any effect if this interceptor is not in the interceptor stack for your actions. It is recommended that you make this interceptor the first interceptor on the stack, ensuring that it has full access to catch any exception, even those caused by other interceptors.

Interceptor parameters:

  • logEnabled (optional) - Should exceptions also be logged? (boolean true|false)
  • logLevel (optional) - what log level should we use (trace, debug, info, warn, error, fatal)? - defaut is debug
  • logCategory (optional) - If provided we would use this category (eg. com.mycompany.app). Default is to use com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor.
The parameters above enables us to log all thrown exceptions with stacktace in our own logfile, and present a friendly webpage (with no stacktrace) to the end user.

Extending the interceptor:

If you want to add custom handling for publishing the Exception, you may override publishException(com.opensymphony.xwork2.ActionInvocation, ExceptionHolder). The default implementation pushes the given ExceptionHolder on value stack. A custom implementation could add additional logging etc.

Example code:

 <xwork>
     <package name="default" extends="xwork-default">
         <global-results>
             <result name="error" type="freemarker">error.ftl</result>
         </global-results>

         <global-exception-mappings>
             <exception-mapping exception="java.lang.Exception" result="error"/>
         </global-exception-mappings>

         <action name="test">
             <interceptor-ref name="exception"/>
             <interceptor-ref name="basicStack"/>
             <exception-mapping exception="com.acme.CustomException" result="custom_error"/>
             <result name="custom_error">custom_error.ftl</result>
             <result name="success" type="freemarker">test.ftl</result>
         </action>
     </package>
 </xwork>

This second example will also log the exceptions using our own category com.mycompany.app.unhandled at WARN level.

 <xwork>
   <package name="something" extends="xwork-default">
      <interceptors>
          <interceptor-stack name="exceptionmappingStack">
              <interceptor-ref name="exception">
                  <param name="logEnabled">true</param>
                  <param name="logCategory">com.mycompany.app.unhandled</param>
                  <param name="logLevel">WARN</param>
              </interceptor-ref>
              <interceptor-ref name="i18n"/>
              <interceptor-ref name="staticParams"/>
              <interceptor-ref name="params"/>
              <interceptor-ref name="validation">
                  <param name="excludeMethods">input,back,cancel,browse</param>
              </interceptor-ref>
          </interceptor-stack>
      </interceptors>

      <default-interceptor-ref name="exceptionmappingStack"/>

      <global-results>
           <result name="unhandledException">/unhandled-exception.jsp</result>
      </global-results>

      <global-exception-mappings>
           <exception-mapping exception="java.lang.Exception" result="unhandledException"/>
      </global-exception-mappings>

      <action name="exceptionDemo" class="org.apache.struts2.showcase.exceptionmapping.ExceptionMappingAction">
          <exception-mapping exception="org.apache.struts2.showcase.exceptionmapping.ExceptionMappingException"
                             result="damm"/>
          <result name="input">index.jsp</result>
          <result name="success">success.jsp</result>
          <result name="damm">damm.jsp</result>
      </action>

   </package>
 </xwork>

Author:
Matthew E. Porter (matthew dot porter at metissian dot com), Claus Ibsen
See Also:
Serialized Form

Field Summary
protected Logger | categoryLogger
protected static Logger | LOG
protected String | logCategory
protected boolean | logEnabled
protected String | logLevel

Constructor Summary
ExceptionMappingInterceptor()

Method Summary
protected void | doLog(Logger logger, Exception e) Performs the actual logging.
protected String | findResultFromExceptions(List<ExceptionMappingConfig> exceptionMappings, Throwable t)
int | getDepth(String exceptionMapping, Throwable t) Return the depth to the superclass matching.
String | getLogCategory()
String | getLogLevel()
protected void | handleLogging(Exception e) Handles the logging of the exception.
String | intercept(ActionInvocation invocation) Override to handle interception
boolean | isLogEnabled()
protected void | publishException(ActionInvocation invocation, ExceptionHolder exceptionHolder) Default implementation to handle ExceptionHolder publishing.
void | setLogCategory(String logCatgory)
void | setLogEnabled(boolean logEnabled)
void | setLogLevel(String logLevel)

Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init

Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

protected static final Logger LOG

categoryLogger

protected Logger categoryLogger

logEnabled

protected boolean logEnabled

logCategory

protected String logCategory

logLevel

protected String logLevel
Constructor Detail

ExceptionMappingInterceptor

public ExceptionMappingInterceptor()
Method Detail

isLogEnabled

public boolean isLogEnabled()

setLogEnabled

public void setLogEnabled(boolean logEnabled)

getLogCategory

public String getLogCategory()

setLogCategory

public void setLogCategory(String logCatgory)

getLogLevel

public String getLogLevel()

setLogLevel

public void setLogLevel(String logLevel)

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Parameters:
invocation - the action invocation
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

handleLogging

protected void handleLogging(Exception e)
Handles the logging of the exception.

Parameters:
e - the exception to log.

doLog

protected void doLog(Logger logger,
                     Exception e)
Performs the actual logging.

Parameters:
logger - the provided logger to use.
e - the exception to log.

findResultFromExceptions

protected String findResultFromExceptions(List<ExceptionMappingConfig> exceptionMappings,
                                          Throwable t)

getDepth

public int getDepth(String exceptionMapping,
                    Throwable t)
Return the depth to the superclass matching. 0 means ex matches exactly. Returns -1 if there's no match. Otherwise, returns depth. Lowest depth wins.

Parameters:
exceptionMapping - the mapping classname
t - the cause
Returns:
the depth, if not found -1 is returned.

publishException

protected void publishException(ActionInvocation invocation,
                                ExceptionHolder exceptionHolder)
Default implementation to handle ExceptionHolder publishing. Pushes given ExceptionHolder on the stack. Subclasses may override this to customize publishing.

Parameters:
invocation - The invocation to publish Exception for.
exceptionHolder - The exceptionHolder wrapping the Exception to publish.
Overview  Package   Class  Use  Tree  Deprecated  Index  Help
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


I18nInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class I18nInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.I18nInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class I18nInterceptor
extends AbstractInterceptor

An interceptor that handles setting the locale specified in a session as the locale for the current action request. In addition, this interceptor will look for a specific HTTP request parameter and set the locale to whatever value is provided. This means that this interceptor can be used to allow for your application to dynamically change the locale for the user's session or, alternatively, only for the current request (since XWork 2.1.3). This is very useful for applications that require multi-lingual support and want the user to be able to set his or her language preference at any point. The locale parameter is removed during the execution of this interceptor, ensuring that properties aren't set on an action (such as request_locale) that have no typical corresponding setter in your action.

For example, using the default parameter name, a request to foo.action?request_locale=en_US, then the locale for US English is saved in the user's session and will be used for all future requests.

Interceptor parameters:

  • parameterName (optional) - the name of the HTTP request parameter that dictates the locale to switch to and save in the session. By default this is request_locale
  • requestOnlyParameterName (optional) - the name of the HTTP request parameter that dictates the locale to switch to for the current request only, without saving it in the session. By default this is request_only_locale
  • attributeName (optional) - the name of the session key to store the selected locale. By default this is WW_TRANS_I18N_LOCALE

Extending the interceptor:

There are no known extensions points for this interceptor.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="i18n"/>
     <interceptor-ref name="basicStack"/>
     <result name="success">good_result.ftl</result>
 </action>

Author:
Aleksei Gopachenko
See Also:
Serialized Form

Field Summary
protected String | attributeName
static String | DEFAULT_PARAMETER
static String | DEFAULT_REQUESTONLY_PARAMETER
static String | DEFAULT_SESSION_ATTRIBUTE
protected static Logger | LOG
protected String | parameterName
protected String | requestOnlyParameterName
Constructor Summary
I18nInterceptor()
Method Summary
String | intercept(ActionInvocation invocation) Override to handle interception
protected void | saveLocale(ActionInvocation invocation, Locale locale) Save the given locale to the ActionInvocation.
void | setAttributeName(String attributeName)
void | setParameterName(String parameterName)
void | setRequestOnlyParameterName(String requestOnlyParameterName)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

protected static final Logger LOG

DEFAULT_SESSION_ATTRIBUTE

public static final String DEFAULT_SESSION_ATTRIBUTE
See Also:
Constant Field Values

DEFAULT_PARAMETER

public static final String DEFAULT_PARAMETER
See Also:
Constant Field Values

DEFAULT_REQUESTONLY_PARAMETER

public static final String DEFAULT_REQUESTONLY_PARAMETER
See Also:
Constant Field Values

parameterName

protected String parameterName

requestOnlyParameterName

protected String requestOnlyParameterName

attributeName

protected String attributeName
Constructor Detail

I18nInterceptor

public I18nInterceptor()
Method Detail

setParameterName

public void setParameterName(String parameterName)

setRequestOnlyParameterName

public void setRequestOnlyParameterName(String requestOnlyParameterName)

setAttributeName

public void setAttributeName(String attributeName)

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Parameters:
invocation - the action invocation
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

saveLocale

protected void saveLocale(ActionInvocation invocation,
                          Locale locale)
Save the given locale to the ActionInvocation.

Parameters:
invocation - The ActionInvocation.
locale - The locale to save.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Interceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Interface Interceptor

All Superinterfaces:
Serializable
All Known Implementing Classes:
AbstractInterceptor, ActionAutowiringInterceptor, AliasInterceptor, AnnotationParameterFilterIntereptor, AnnotationWorkflowInterceptor, ChainingInterceptor, ConversionErrorInterceptor, DefaultWorkflowInterceptor, ExceptionMappingInterceptor, I18nInterceptor, LoggingInterceptor, MethodFilterInterceptor, MockInterceptor, ModelDrivenInterceptor, ParameterFilterInterceptor, ParameterRemoverInterceptor, ParametersInterceptor, PrepareInterceptor, ScopedModelDrivenInterceptor, StaticParametersInterceptor, TimerInterceptor, ValidationInterceptor
public interface Interceptor
extends Serializable

An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.

Interceptors are objects that dynamically intercept Action invocations. They provide the developer with the opportunity to define code that can be executed before and/or after the execution of an action. They also have the ability to prevent an action from executing. Interceptors provide developers a way to encapulate common functionality in a re-usable form that can be applied to one or more Actions.

Interceptors must be stateless and not assume that a new instance will be created for each request or Action. Interceptors may choose to either short-circuit the ActionInvocation execution and return a return code (such as Action.SUCCESS), or it may choose to do some processing before and/or after delegating the rest of the procesing using ActionInvocation.invoke().

Interceptor's parameter could be overriden through the following ways :-

Method 1:

 <action name="myAction" class="myActionClass">
     <interceptor-ref name="exception"/>
     <interceptor-ref name="alias"/>
     <interceptor-ref name="params"/>
     <interceptor-ref name="servletConfig"/>
     <interceptor-ref name="prepare"/>
     <interceptor-ref name="i18n"/>
     <interceptor-ref name="chain"/>
     <interceptor-ref name="modelDriven"/>
     <interceptor-ref name="fileUpload"/>
     <interceptor-ref name="staticParams"/>
     <interceptor-ref name="params"/>
     <interceptor-ref name="conversionError"/>
     <interceptor-ref name="validation">
     <param name="excludeMethods">myValidationExcudeMethod</param>
     </interceptor-ref>
     <interceptor-ref name="workflow">
     <param name="excludeMethods">myWorkflowExcludeMethod</param>
     </interceptor-ref>
 </action>

Method 2:

 <action name="myAction" class="myActionClass">
   <interceptor-ref name="defaultStack">
     <param name="validation.excludeMethods">myValidationExcludeMethod</param>
     <param name="workflow.excludeMethods">myWorkflowExcludeMethod</param>
   </interceptor-ref>
 </action>

In the first method, the whole default stack is copied and the parameter then changed accordingly.

In the second method, the 'interceptor-ref' refer to an existing interceptor-stack, namely defaultStack in this example, and override the validator and workflow interceptor excludeMethods typically in this case. Note that in the 'param' tag, the name attribute contains a dot (.) the word before the dot(.) specifies the interceptor name whose parameter is to be overridden and the word after the dot (.) specifies the parameter itself. Essetially it is as follows :-

    <interceptor-name>.<parameter-name>

Note also that in this case the 'interceptor-ref' name attribute is used to indicate an interceptor stack which makes sense as if it is referring to the interceptor itself it would be just using Method 1 describe above.

Nested Interceptor param overriding

Interceptor stack parameter overriding could be nested into as many level as possible, though it would be advisable not to nest it too deep as to avoid confusion, For example,

 <interceptor name="interceptor1" class="foo.bar.Interceptor1" />
 <interceptor name="interceptor2" class="foo.bar.Interceptor2" />
 <interceptor name="interceptor3" class="foo.bar.Interceptor3" />
 <interceptor name="interceptor4" class="foo.bar.Interceptor4" />
 <interceptor-stack name="stack1">
     <interceptor-ref name="interceptor1" />
 </interceptor-stack>
 <interceptor-stack name="stack2">
     <interceptor-ref name="intercetor2" />
     <interceptor-ref name="stack1" />
 </interceptor-stack>
 <interceptor-stack name="stack3">
     <interceptor-ref name="interceptor3" />
     <interceptor-ref name="stack2" />
 </interceptor-stack>
 <interceptor-stack name="stack4">
     <interceptor-ref name="interceptor4" />
     <interceptor-ref name="stack3" />
  </interceptor-stack>
Assuming the interceptor has the following properties
Interceptor | property
Interceptor1 | param1
Interceptor2 | param2
Interceptor3 | param3
Interceptor4 | param4
We could override them as follows :-
    <action ... >
        <!-- to override parameters of interceptor located directly in the stack  -->
        <interceptor-ref name="stack4">
           <param name="interceptor4.param4"> ... </param>
        </interceptor-ref>
    </action>

    <action ... >
        <!-- to override parameters of interceptor located under nested stack -->
        <interceptor-ref name="stack4">
            <param name="stack3.interceptor3.param3"> ... </param>
            <param name="stack3.stack2.interceptor2.param2"> ... </param>
            <param name="stack3.stack2.stack1.interceptor1.param1"> ... </param>
        </interceptor-ref>
    </action>

Version:
$Date: 2008-06-21 15:36:59 +0200 (Sa, 21 Jun 2008) $ $Id: Interceptor.java 1837 2008-06-21 13:36:59Z musachy $
Author:
Jason Carreira, tmjee

Method Summary
void | destroy() Called to let an interceptor clean up any resources it has allocated.
void | init() Called after an interceptor is created, but before any requests are processed using intercept , giving the Interceptor a chance to initialize any needed resources.
String | intercept(ActionInvocation invocation) Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the ActionInvocation or to short-circuit the processing and just return a String return code.

Method Detail

destroy

void destroy()
Called to let an interceptor clean up any resources it has allocated.

init

void init()
Called after an interceptor is created, but before any requests are processed using intercept , giving the Interceptor a chance to initialize any needed resources.

intercept

String intercept(ActionInvocation invocation)
                 throws Exception
Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the ActionInvocation or to short-circuit the processing and just return a String return code.

Parameters:
invocation - the action invocation
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LoggingInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class LoggingInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.LoggingInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class LoggingInterceptor
extends AbstractInterceptor

This interceptor logs the start and end of the execution an action (in English-only, not internationalized).
Note:: This interceptor will log at INFO level.

There are no parameters for this interceptor. There are no obvious extensions to the existing interceptor.

 <!-- prints out a message before and after the immediate action execution -->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="completeStack"/>
     <interceptor-ref name="logger"/>
     <result name="success">good_result.ftl</result>
 </action>

 <!-- prints out a message before any more interceptors continue and after they have finished -->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="logger"/>
     <interceptor-ref name="completeStack"/>
     <result name="success">good_result.ftl</result>
 </action>

Author:
Jason Carreira
See Also:
Serialized Form

Constructor Summary
LoggingInterceptor()
Method Summary
 String intercept(ActionInvocation invocation)
Override to handle interception
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LoggingInterceptor

public LoggingInterceptor()
Method Detail

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Parameters:
invocation - the action invocation
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MethodFilterInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class MethodFilterInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
All Implemented Interfaces:
Interceptor, Serializable
Direct Known Subclasses:
DefaultWorkflowInterceptor, ParametersInterceptor, PrepareInterceptor, ValidationInterceptor
public abstract class MethodFilterInterceptor
extends AbstractInterceptor

MethodFilterInterceptor is an abstract Interceptor used as a base class for interceptors that will filter execution based on method names according to specified included/excluded method lists.

Settable parameters are as follows:

  • excludeMethods - method names to be excluded from interceptor processing
  • includeMethods - method names to be included in interceptor processing

NOTE: If method name are available in both includeMethods and excludeMethods, it will be considered as an included method: includeMethods takes precedence over excludeMethods.

Interceptors that extends this capability include:

  • TokenInterceptor
  • TokenSessionStoreInterceptor
  • DefaultWorkflowInterceptor
  • ValidationInterceptor

Version:
$Date: 2008-06-21 11:29:39 +0200 (Sa, 21 Jun 2008) $ $Id: MethodFilterInterceptor.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Alexandru Popescu, Rainer Hermanns
See Also:
TokenInterceptor, TokenSessionStoreInterceptor, DefaultWorkflowInterceptor, ValidationInterceptor, Serialized Form

Field Summary
protected Set<String> | excludeMethods
protected Set<String> | includeMethods
protected Logger | log
Constructor Summary
MethodFilterInterceptor()
Method Summary
protected boolean | applyInterceptor(ActionInvocation invocation)
protected abstract String | doIntercept(ActionInvocation invocation) Subclasses must override to implement the interceptor logic.
Set<String> | getExcludeMethodsSet()
Set<String> | getIncludeMethodsSet()
String | intercept(ActionInvocation invocation) Override to handle interception
void | setExcludeMethods(String excludeMethods)
void | setIncludeMethods(String includeMethods)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

protected transient Logger log

excludeMethods

protected Set<String> excludeMethods

includeMethods

protected Set<String> includeMethods
Constructor Detail

MethodFilterInterceptor

public MethodFilterInterceptor()
Method Detail

setExcludeMethods

public void setExcludeMethods(String excludeMethods)

getExcludeMethodsSet

public Set<String> getExcludeMethodsSet()

setIncludeMethods

public void setIncludeMethods(String includeMethods)

getIncludeMethodsSet

public Set<String> getIncludeMethodsSet()

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Parameters:
invocation - the action invocation
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

applyInterceptor

protected boolean applyInterceptor(ActionInvocation invocation)

doIntercept

protected abstract String doIntercept(ActionInvocation invocation)
                               throws Exception
Subclasses must override to implement the interceptor logic.

Parameters:
invocation - the action invocation
Returns:
the result of invocation
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MethodFilterInterceptorUtil (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class MethodFilterInterceptorUtil

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.MethodFilterInterceptorUtil

public class MethodFilterInterceptorUtil
extends Object

Utility class contains common methods used by MethodFilterInterceptor.

Author:
tm_jee

Constructor Summary
MethodFilterInterceptorUtil()
Method Summary
static boolean applyMethod(Set<String> excludeMethods, Set<String> includeMethods, String method)
Static method to decide if the specified method should be apply (not filtered) depending on the set of excludeMethods and includeMethods.
static boolean applyMethod(String excludeMethods, String includeMethods, String method)
Same as applyMethod(Set, Set, String), except that excludeMethods and includeMethods are supplied as comma separated string.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MethodFilterInterceptorUtil

public MethodFilterInterceptorUtil()
Method Detail

applyMethod

public static boolean applyMethod(Set<String> excludeMethods,
                                  Set<String> includeMethods,
                                  String method)
Static method to decide if the specified method should be apply (not filtered) depending on the set of excludeMethods and includeMethods.
  • includeMethods takes precedence over excludeMethods
Note: Supports wildcard listings in includeMethods/excludeMethods

Parameters:
excludeMethods - list of methods to exclude.
includeMethods - list of methods to include.
method - the specified method to check
Returns:
true if the method should be applied.

applyMethod

public static boolean applyMethod(String excludeMethods,
                                  String includeMethods,
                                  String method)
Same as applyMethod(Set, Set, String), except that excludeMethods and includeMethods are supplied as comma separated string.

Parameters:
excludeMethods - comma seperated string of methods to exclude.
includeMethods - comma seperated string of methods to include.
method - the specified method to check
Returns:
true if the method should be applied.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ModelDrivenInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class ModelDrivenInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class ModelDrivenInterceptor
extends AbstractInterceptor

Watches for ModelDriven actions and adds the action's model on to the value stack.

Note: The ModelDrivenInterceptor must come before the both StaticParametersInterceptor and ParametersInterceptor if you want the parameters to be applied to the model.

Note: The ModelDrivenInterceptor will only push the model into the stack when the model is not null, else it will be ignored.

Interceptor parameters:

  • refreshModelBeforeResult - set to true if you want the model to be refreshed on the value stack after action execution and before result execution. The setting is useful if you want to change the model instance during the action execution phase, like when loading it from the data layer. This will result in getModel() being called at least twice.

Extending the interceptor:

There are no known extension points to this interceptor.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="modelDriven"/>
     <interceptor-ref name="basicStack"/>
     <result name="success">good_result.ftl</result>
 </action>

Version:
$Date: 2009-07-28 02:25:13 +0200 (Di, 28 Jul 2009) $ $Id: ModelDrivenInterceptor.java 2027 2009-07-28 00:25:13Z musachy $
Author:
tm_jee
See Also:
Serialized Form

Nested Class Summary
protected static class ModelDrivenInterceptor.RefreshModelBeforeResult
Refreshes the model instance on the value stack, if it has changed
Field Summary
protected  boolean refreshModelBeforeResult
Constructor Summary
ModelDrivenInterceptor()
Method Summary
String | intercept(ActionInvocation invocation) Override to handle interception
void | setRefreshModelBeforeResult(boolean val)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

refreshModelBeforeResult

protected boolean refreshModelBeforeResult
Constructor Detail

ModelDrivenInterceptor

public ModelDrivenInterceptor()
Method Detail

setRefreshModelBeforeResult

public void setRefreshModelBeforeResult(boolean val)

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Parameters:
invocation - the action invocation
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ModelDrivenInterceptor.RefreshModelBeforeResult (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class ModelDrivenInterceptor.RefreshModelBeforeResult

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor.RefreshModelBeforeResult
All Implemented Interfaces:
PreResultListener
Enclosing class:
ModelDrivenInterceptor
protected static class ModelDrivenInterceptor.RefreshModelBeforeResult
extends Object
implements PreResultListener

Refreshes the model instance on the value stack, if it has changed

Field Summary
protected  ModelDriven action
Constructor Summary
ModelDrivenInterceptor.RefreshModelBeforeResult(ModelDriven action, Object model)
Method Summary
 void beforeResult(ActionInvocation invocation, String resultCode)
This callback method will be called after the Action execution and before the Result execution.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

action

protected ModelDriven action
Constructor Detail

ModelDrivenInterceptor.RefreshModelBeforeResult

public ModelDrivenInterceptor.RefreshModelBeforeResult(ModelDriven action,
                                                       Object model)
Method Detail

beforeResult

public void beforeResult(ActionInvocation invocation,
                         String resultCode)
Description copied from interface: PreResultListener
This callback method will be called after the Action execution and before the Result execution.

Specified by:
beforeResult in interface PreResultListener
Parameters:
invocation - the action invocation
resultCode - the result code returned by the action (eg. success).
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NoParameters (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Interface NoParameters

public interface NoParameters

Marker interface to incidate no auto setting of parameters.

This marker interface should be implemented by actions that do not want any request parameters set on them automatically (by the ParametersInterceptor). This may be useful if one is using the action tag and want to supply the parameters to the action manually using the param tag. It may also be useful if one for security reasons wants to make sure that parameters cannot be set by malicious users.

Author:
Dick Zetterberg (dick@transitor.se)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.interceptor (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.interceptor
Interfaces
Interceptor
NoParameters
ParameterNameAware
PreResultListener
ScopedModelDriven
ValidationWorkflowAware
Classes
AbstractInterceptor
AliasInterceptor
ChainingInterceptor
ConversionErrorInterceptor
DefaultWorkflowInterceptor
ExceptionHolder
ExceptionMappingInterceptor
I18nInterceptor
LoggingInterceptor
MethodFilterInterceptor
MethodFilterInterceptorUtil
ModelDrivenInterceptor
ModelDrivenInterceptor.RefreshModelBeforeResult
ParameterFilterInterceptor
ParameterRemoverInterceptor
ParametersInterceptor
PrefixMethodInvocationUtil
PrepareInterceptor
ScopedModelDrivenInterceptor
StaticParametersInterceptor
TimerInterceptor


com.opensymphony.xwork2.interceptor (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.interceptor

Interceptor classes.

See:
Description

Interface Summary
Interceptor | An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.
NoParameters | Marker interface to incidate no auto setting of parameters.
ParameterNameAware | This interface is implemented by actions that want to declare acceptable parameters.
PreResultListener | PreResultListeners may be registered with an ActionInvocation to get a callback after the Action has been executed but before the Result is executed.
ScopedModelDriven<T> | Adds the ability to set a model, probably retrieved from a given state.
ValidationWorkflowAware | ValidationWorkflowAware

Class Summary
AbstractInterceptor | Provides default implementations of optional lifecycle methods
AliasInterceptor | The aim of this Interceptor is to alias a named parameter to a different named parameter.
ChainingInterceptor | An interceptor that copies all the properties of every object in the value stack to the currently executing object, except for any object that implements Unchainable.
ConversionErrorInterceptor | ConversionErrorInterceptor adds conversion errors from the ActionContext to the Action's field errors.
DefaultWorkflowInterceptor | An interceptor that makes sure there are not validation errors before allowing the interceptor chain to continue.
ExceptionHolder | A simple wrapper around an exception, providing an easy way to print out the stack trace of the exception as well as a way to get a handle on the exception itself.
ExceptionMappingInterceptor | This interceptor forms the core functionality of the exception handling feature.
I18nInterceptor | An interceptor that handles setting the locale specified in a session as the locale for the current action request.
LoggingInterceptor | This interceptor logs the start and end of the execution an action (in English-only, not internationalized).
MethodFilterInterceptor | MethodFilterInterceptor is an abstract Interceptor used as a base class for interceptors that will filter execution based on method names according to specified included/excluded method lists.
MethodFilterInterceptorUtil | Utility class contains common methods used by MethodFilterInterceptor.
ModelDrivenInterceptor | Watches for ModelDriven actions and adds the action's model on to the value stack.
ModelDrivenInterceptor.RefreshModelBeforeResult | Refreshes the model instance on the value stack, if it has changed
ParameterFilterInterceptor | The Parameter Filter Interceptor blocks parameters from getting to the rest of the stack or your action.
ParameterRemoverInterceptor | This is a simple XWork interceptor that allows parameters (matching one of the paramNames attribute csv value) to be removed from the parameter map if they match a certain value (matching one of the paramValues attribute csv value), before they are set on the action.
ParametersInterceptor | This interceptor sets all parameters on the value stack.
PrefixMethodInvocationUtil | A utility class for invoking prefixed methods in action class.
PrepareInterceptor | This interceptor calls prepare() on actions which implement Preparable.
ScopedModelDrivenInterceptor | An interceptor that enables scoped model-driven actions.
StaticParametersInterceptor | This interceptor populates the action with the static parameters defined in the action configuration.
TimerInterceptor | This interceptor logs the amount of time in milliseconds.

Package com.opensymphony.xwork2.interceptor Description

Interceptor classes.


com.opensymphony.xwork2.interceptor Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.interceptor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.interceptor.AbstractInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
      • com.opensymphony.xwork2.interceptor.AliasInterceptor
      • com.opensymphony.xwork2.interceptor.ChainingInterceptor
      • com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor
      • com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
      • com.opensymphony.xwork2.interceptor.I18nInterceptor
      • com.opensymphony.xwork2.interceptor.LoggingInterceptor
      • com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
        • com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor
        • com.opensymphony.xwork2.interceptor.ParametersInterceptor
        • com.opensymphony.xwork2.interceptor.PrepareInterceptor
      • com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor
      • com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor
      • com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor
      • com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor
      • com.opensymphony.xwork2.interceptor.StaticParametersInterceptor
      • com.opensymphony.xwork2.interceptor.TimerInterceptor
    • com.opensymphony.xwork2.interceptor.ExceptionHolder (implements java.io.Serializable)
    • com.opensymphony.xwork2.interceptor.MethodFilterInterceptorUtil
    • com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor.RefreshModelBeforeResult (implements com.opensymphony.xwork2.interceptor.PreResultListener)
    • com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil

Interface Hierarchy

  • com.opensymphony.xwork2.ModelDriven<T>
    • com.opensymphony.xwork2.interceptor.ScopedModelDriven<T>
  • com.opensymphony.xwork2.interceptor.NoParameters
  • com.opensymphony.xwork2.interceptor.ParameterNameAware
  • com.opensymphony.xwork2.interceptor.PreResultListener
  • java.io.Serializable
    • com.opensymphony.xwork2.interceptor.Interceptor
  • com.opensymphony.xwork2.interceptor.ValidationWorkflowAware


Uses of Package com.opensymphony.xwork2.interceptor (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.interceptor

Packages that use com.opensymphony.xwork2.interceptor
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.interceptor.annotations | Interceptor annotations.
com.opensymphony.xwork2.mock | XWork specific mock classes.
com.opensymphony.xwork2.spring.interceptor | Spring specific interceptor classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.

Classes in com.opensymphony.xwork2.interceptor used by com.opensymphony.xwork2
Interceptor

An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.

PreResultListener
PreResultListeners may be registered with an ActionInvocation to get a callback after the Action has been executed but before the Result is executed.

Classes in com.opensymphony.xwork2.interceptor used by com.opensymphony.xwork2.config.entities
Interceptor

An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.

Classes in com.opensymphony.xwork2.interceptor used by com.opensymphony.xwork2.interceptor
AbstractInterceptor
Provides default implementations of optional lifecycle methods
ExceptionHolder
A simple wrapper around an exception, providing an easy way to print out the stack trace of the exception as well as a way to get a handle on the exception itself.
Interceptor

An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.

MethodFilterInterceptor
MethodFilterInterceptor is an abstract Interceptor used as a base class for interceptors that will filter execution based on method names according to specified included/excluded method lists.
PreResultListener
PreResultListeners may be registered with an ActionInvocation to get a callback after the Action has been executed but before the Result is executed.

Classes in com.opensymphony.xwork2.interceptor used by com.opensymphony.xwork2.interceptor.annotations
AbstractInterceptor
Provides default implementations of optional lifecycle methods
Interceptor

An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.

PreResultListener
PreResultListeners may be registered with an ActionInvocation to get a callback after the Action has been executed but before the Result is executed.

Classes in com.opensymphony.xwork2.interceptor used by com.opensymphony.xwork2.mock
Interceptor

An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.

PreResultListener
PreResultListeners may be registered with an ActionInvocation to get a callback after the Action has been executed but before the Result is executed.

Classes in com.opensymphony.xwork2.interceptor used by com.opensymphony.xwork2.spring.interceptor
AbstractInterceptor
Provides default implementations of optional lifecycle methods
Interceptor

An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.

Classes in com.opensymphony.xwork2.interceptor used by com.opensymphony.xwork2.validator
AbstractInterceptor
Provides default implementations of optional lifecycle methods
Interceptor

An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.

MethodFilterInterceptor
MethodFilterInterceptor is an abstract Interceptor used as a base class for interceptors that will filter execution based on method names according to specified included/excluded method lists.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ParameterFilterInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class ParameterFilterInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class ParameterFilterInterceptor
extends AbstractInterceptor

The Parameter Filter Interceptor blocks parameters from getting to the rest of the stack or your action. You can use multiple parameter filter interceptors for a given action, so, for example, you could use one in your default stack that filtered parameters you wanted blocked from every action and those you wanted blocked from an individual action you could add an additional interceptor for each action.

  • allowed - a comma delimited list of parameter prefixes that are allowed to pass to the action
  • blocked - a comma delimited list of parameter prefixes that are not allowed to pass to the action
  • defaultBlock - boolean (default to false) whether by default a given parameter is blocked. If true, then a parameter must have a prefix in the allowed list in order to be able to pass to the action

The way parameters are filtered for the least configuration is that if a string is in the allowed or blocked lists, then any parameter that is a member of the object represented by the parameter is allowed or blocked respectively.

For example, if the parameters are:

  • blocked: person,person.address.createDate,personDao
  • allowed: person.address
  • defaultBlock: false

The parameters person.name, person.phoneNum etc would be blocked because 'person' is in the blocked list. However, person.address.street and person.address.city would be allowed because person.address is in the allowed list (the longer string determines permissions).

There are no known extension points to this interceptor.

 <interceptors>
   ...
   <interceptor name="parameterFilter" class="com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor"/>
   ...
 </interceptors>

 <action ....>
   ...
   <interceptor-ref name="parameterFilter">
     <param name="blocked">person,person.address.createDate,personDao</param>
   </interceptor-ref>
   ...
 </action>

Author:
Gabe
See Also:
Serialized Form

Constructor Summary
ParameterFilterInterceptor()
Method Summary
Collection<String> | getAllowedCollection()
Collection<String> | getBlockedCollection()
String | intercept(ActionInvocation invocation) Override to handle interception
boolean | isDefaultBlock()
void | setAllowed(String allowed)
void | setAllowedCollection(Collection<String> allowed)
void | setBlocked(String blocked)
void | setBlockedCollection(Collection<String> blocked)
void | setDefaultBlock(boolean defaultExclude)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParameterFilterInterceptor

public ParameterFilterInterceptor()
Method Detail

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Parameters:
invocation - the action invocation
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

isDefaultBlock

public boolean isDefaultBlock()
Returns:
Returns the defaultBlock.

setDefaultBlock

public void setDefaultBlock(boolean defaultExclude)
Parameters:
defaultExclude - The defaultExclude to set.

getBlockedCollection

public Collection<String> getBlockedCollection()
Returns:
Returns the blocked.

setBlockedCollection

public void setBlockedCollection(Collection<String> blocked)
Parameters:
blocked - The blocked to set.

setBlocked

public void setBlocked(String blocked)
Parameters:
blocked - The blocked paramters as comma separated String.

getAllowedCollection

public Collection<String> getAllowedCollection()
Returns:
Returns the allowed.

setAllowedCollection

public void setAllowedCollection(Collection<String> allowed)
Parameters:
allowed - The allowed to set.

setAllowed

public void setAllowed(String allowed)
Parameters:
allowed - The allowed paramters as comma separated String.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParameterNameAware (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Interface ParameterNameAware

public interface ParameterNameAware

This interface is implemented by actions that want to declare acceptable parameters. Works in conjunction with ParametersInterceptor. For example, actions may want to create a whitelist of parameters they will accept or a blacklist of paramters they will reject to prevent clients from setting other unexpected (and possibly dangerous) parameters.

Author:
Bob Lee (crazybob@google.com)

Method Summary
 boolean acceptableParameterName(String parameterName)
Tests if the the action will accept the parameter with the given name.

Method Detail

acceptableParameterName

boolean acceptableParameterName(String parameterName)
Tests if the the action will accept the parameter with the given name.

Parameters:
parameterName - the parameter name
Returns:
if accepted, false otherwise
Overview  Package   Class  Use  Tree  Deprecated  Index  Help
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParameterRemoverInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class ParameterRemoverInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class ParameterRemoverInterceptor
extends AbstractInterceptor

This is a simple XWork interceptor that allows parameters (matching one of the paramNames attribute csv value) to be removed from the parameter map if they match a certain value (matching one of the paramValues attribute csv value), before they are set on the action. A typical usage would be to want a dropdown/select to map onto a boolean value on an action. The select had the options none, yes and no with values -1, true and false. The true and false would map across correctly. However the -1 would be set to false. This was not desired as one might needed the value on the action to stay null. This interceptor fixes this by preventing the parameter from ever reaching the action.

  • paramNames - A comma separated value (csv) indicating the parameter name whose param value should be considered that if they match any of the comma separated value (csv) from paramValues attribute, shall be removed from the parameter map such that they will not be applied to the action
  • paramValues - A comma separated value (csv) indicating the parameter value that if matched shall have its parameter be removed from the parameter map such that they will not be applied to the action
No intended extension point

 <action name="sample" class="org.martingilday.Sample">
        <interceptor-ref name="paramRemover">
                <param name="paramNames">aParam,anotherParam</param>
                <param name="paramValues">--,-1</param>
        </interceptor-ref>
        <interceptor-ref name="defaultStack" />
        ...
 </action>

Author:
martin.gilday
See Also:
Serialized Form

Constructor Summary
ParameterRemoverInterceptor()
Method Summary
String | intercept(ActionInvocation invocation) Decide if the parameter should be removed from the parameter map based on paramNames and paramValues.
void | setParamNames(String paramNames) Allows paramNames attribute to be set as comma-separated-values (csv).
void | setParamValues(String paramValues) Allows paramValues attribute to be set as a comma-separated-values (csv).
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParameterRemoverInterceptor

public ParameterRemoverInterceptor()
Method Detail

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Decide if the parameter should be removed from the parameter map based on paramNames and paramValues.

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Parameters:
invocation - the action invocation
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
See Also:
AbstractInterceptor

setParamNames

public void setParamNames(String paramNames)
Allows paramNames attribute to be set as comma-separated-values (csv).

Parameters:
paramNames - the paramNames to set

setParamValues

public void setParamValues(String paramValues)
Allows paramValues attribute to be set as a comma-separated-values (csv).

Parameters:
paramValues - the paramValues to set
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParametersInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class ParametersInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
            extended by  com.opensymphony.xwork2.interceptor.ParametersInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class ParametersInterceptor
extends MethodFilterInterceptor

This interceptor sets all parameters on the value stack.

This interceptor gets all parameters from ActionContext.getParameters() and sets them on the value stack by calling ValueStack.setValue(String, Object), typically resulting in the values submitted in a form request being applied to an action in the value stack. Note that the parameter map must contain a String key and often containers a String[] for the value.

The interceptor takes one parameter named 'ordered'. When set to true action properties are guaranteed to be set top-down which means that top action's properties are set first. Then it's subcomponents properties are set. The reason for this order is to enable a 'factory' pattern. For example, let's assume that one has an action that contains a property named 'modelClass' that allows to choose what is the underlying implementation of model. By assuring that modelClass property is set before any model properties are set, it's possible to choose model implementation during action.setModelClass() call. Similiarily it's possible to use action.setPrimaryKey() property set call to actually load the model class from persistent storage. Without any assumption on parameter order you have to use patterns like 'Preparable'.

Because parameter names are effectively OGNL statements, it is important that security be taken in to account. This interceptor will not apply any values in the parameters map if the expression contains an assignment (=), multiple expressions (,), or references any objects in the context (#). This is all done in the acceptableName(String) method. In addition to this method, if the action being invoked implements the ParameterNameAware interface, the action will be consulted to determine if the parameter should be set.

In addition to these restrictions, a flag (ReflectionContextState.DENY_METHOD_EXECUTION) is set such that no methods are allowed to be invoked. That means that any expression such as person.doSomething() or person.getName() will be explicitely forbidden. This is needed to make sure that your application is not exposed to attacks by malicious users.

While this interceptor is being invoked, a flag (ReflectionContextState.CREATE_NULL_OBJECTS) is turned on to ensure that any null reference is automatically created - if possible. See the type conversion documentation and the InstantiatingNullHandler javadocs for more information.

Finally, a third flag (XWorkConverter.REPORT_CONVERSION_ERRORS) is set that indicates any errors when converting the the values to their final data type (String[] -> int) an unrecoverable error occured. With this flag set, the type conversion errors will be reported in the action context. See the type conversion documentation and the XWorkConverter javadocs for more information.

If you are looking for detailed logging information about your parameters, turn on DEBUG level logging for this interceptor. A detailed log of all the parameter keys and values will be reported.

Note: Since XWork 2.0.2, this interceptor extends MethodFilterInterceptor, therefore being able to deal with excludeMethods / includeMethods parameters. See [Workflow Interceptor] (class DefaultWorkflowInterceptor) for documentation and examples on how to use this feature.

Interceptor parameters:

  • ordered - set to true if you want the top-down property setter behaviour

Extending the interceptor:

The best way to add behavior to this interceptor is to utilize the ParameterNameAware interface in your actions. However, if you wish to apply a global rule that isn't implemented in your action, then you could extend this interceptor and override the acceptableName(String) method.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="params"/>
     <result name="success">good_result.ftl</result>
 </action>

Author:
Patrick Lightbody
See Also:
Serialized Form

Field Summary
Fields inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
excludeMethods, includeMethods, log
Constructor Summary
ParametersInterceptor()
Method Summary
protected boolean | acceptableName(String name)
protected void | addParametersToContext(ActionContext ac, Map<String,Object> newParams) Adds the parameters into context's ParameterMap
String | doIntercept(ActionInvocation invocation) Subclasses must override to implement the interceptor logic.
protected Set | getExcludeParamsSet() Gets a set of regular expressions of parameters to remove from the parameter map
protected Comparator<String> | getOrderedComparator() Gets an instance of the comparator to use for the ordered sorting.
protected boolean | isAccepted(String paramName)
protected boolean | isExcluded(String paramName)
boolean | isOrdered() Whether to order the parameters or not
protected Map<String,Object> | retrieveParameters(ActionContext ac) Gets the parameter map to apply from wherever appropriate
void | setAcceptParamNames(String commaDelim)
static void | setDevMode(String mode)
void | setExcludeParams(String commaDelim) Sets a comma-delimited list of regular expressions to match parameters that should be removed from the parameter map.
void | setOrdered(boolean ordered) Set whether to order the parameters by object depth or not
protected void | setParameters(Object action, ValueStack stack, Map<String,Object> parameters)
void | setValueStackFactory(ValueStackFactory valueStackFactory)
Methods inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
applyInterceptor, getExcludeMethodsSet, getIncludeMethodsSet, intercept, setExcludeMethods, setIncludeMethods
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParametersInterceptor

public ParametersInterceptor()
Method Detail

setValueStackFactory

public void setValueStackFactory(ValueStackFactory valueStackFactory)

setDevMode

public static void setDevMode(String mode)

setAcceptParamNames

public void setAcceptParamNames(String commaDelim)

doIntercept

public String doIntercept(ActionInvocation invocation)
                   throws Exception
Description copied from class: MethodFilterInterceptor
Subclasses must override to implement the interceptor logic.

Specified by:
doIntercept in class MethodFilterInterceptor
Parameters:
invocation - the action invocation
Returns:
the result of invocation
Throws:
Exception

retrieveParameters

protected Map<String,Object> retrieveParameters(ActionContext ac)
Gets the parameter map to apply from wherever appropriate

Parameters:
ac - The action context
Returns:
The parameter map to apply

addParametersToContext

protected void addParametersToContext(ActionContext ac,
                                      Map<String,Object> newParams)
Adds the parameters into context's ParameterMap

Parameters:
ac - The action context
newParams - The parameter map to apply

In this class this is a no-op, since the parameters were fetched from the same location. In subclasses both retrieveParameters() and addParametersToContext() should be overridden.

setParameters

protected void setParameters(Object action,
                             ValueStack stack,
                             Map<String,Object> parameters)

getOrderedComparator

protected Comparator<String> getOrderedComparator()
Gets an instance of the comparator to use for the ordered sorting. Override this method to customize the ordering of the parameters as they are set to the action.

Returns:
A comparator to sort the parameters

acceptableName

protected boolean acceptableName(String name)

isAccepted

protected boolean isAccepted(String paramName)

isExcluded

protected boolean isExcluded(String paramName)

isOrdered

public boolean isOrdered()
Whether to order the parameters or not

Returns:
True to order

setOrdered

public void setOrdered(boolean ordered)
Set whether to order the parameters by object depth or not

Parameters:
ordered - True to order them

getExcludeParamsSet

protected Set getExcludeParamsSet()
Gets a set of regular expressions of parameters to remove from the parameter map

Returns:
A set of compiled regular expression patterns

setExcludeParams

public void setExcludeParams(String commaDelim)
Sets a comma-delimited list of regular expressions to match parameters that should be removed from the parameter map.

Parameters:
commaDelim - A comma-delimited list of regular expressions
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrefixMethodInvocationUtil (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class PrefixMethodInvocationUtil

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil

public class PrefixMethodInvocationUtil
extends Object

A utility class for invoking prefixed methods in action class. Interceptors that made use of this class are:

  • DefaultWorkflowInterceptor
  • PrepareInterceptor

In DefaultWorkflowInterceptor

applies only when action implements Validateable

  1. if the action class have validate{MethodName}(), it will be invoked
  2. else if the action class have validateDo{MethodName}(), it will be invoked
  3. no matter if 1] or 2] is performed, if alwaysInvokeValidate property of the interceptor is "true" (which is by default "true"), validate() will be invoked.
In PrepareInterceptor

Applies only when action implements Preparable

  1. if the action class have prepare{MethodName}(), it will be invoked
  2. else if the action class have prepareDo(MethodName()}(), it will be invoked
  3. no matter if 1] or 2] is performed, if alwaysinvokePrepare property of the interceptor is "true" (which is by default "true"), prepare() will be invoked.

Author:
Philip Luppens, tm_jee

Constructor Summary
PrefixMethodInvocationUtil()
Method Summary
static String | capitalizeMethodName(String methodName) This method capitalized the first character of methodName.
static Method | getPrefixedMethod(String[] prefixes, String methodName, Object action) This method returns a Method in action.
static void | invokePrefixMethod(ActionInvocation actionInvocation, String[] prefixes) This method will prefix actionInvocation's ActionProxy's method with prefixes before invoking the prefixed method.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PrefixMethodInvocationUtil

public PrefixMethodInvocationUtil()
Method Detail

invokePrefixMethod

public static void invokePrefixMethod(ActionInvocation actionInvocation,
                                      String[] prefixes)
                               throws InvocationTargetException,
                                      IllegalAccessException
This method will prefix actionInvocation's ActionProxy's method with prefixes before invoking the prefixed method. Order of the prefixes is important, as this method will return once a prefixed method is found in the action class.

For example, with

   invokePrefixMethod(actionInvocation, new String[] { "prepare", "prepareDo" });
Assuming actionInvocation.getProxy(),getMethod() returns "submit", the order of invocation would be as follows:-
  1. prepareSubmit()
  2. prepareDoSubmit()
If prepareSubmit() exists, it will be invoked and this method will return, prepareDoSubmit() will NOT be invoked.

On the other hand, if prepareDoSubmit() does not exists, and prepareDoSubmit() exists, it will be invoked.

If none of those two methods exists, nothing will be invoked.

Parameters:
actionInvocation - the action invocation
prefixes - prefixes for method names
Throws:
InvocationTargetException - is thrown if invocation of a method failed.
IllegalAccessException - is thrown if invocation of a method failed.

getPrefixedMethod

public static Method getPrefixedMethod(String[] prefixes,
                                       String methodName,
                                       Object action)
This method returns a Method in action. The method returned is found by searching for method in action whose method name is equals to the result of appending each prefixes to methodName. Only the first method found will be returned, hence the order of prefixes is important. If none is found this method will return null.

Parameters:
prefixes - the prefixes to prefix the methodName
methodName - the method name to be prefixed with prefixes
action - the action class of which the prefixed method is to be search for.
Returns:
a Method if one is found, else null.

capitalizeMethodName

public static String capitalizeMethodName(String methodName)
This method capitalized the first character of methodName.
eg. capitalizeMethodName("someMethod"); will return "SomeMethod".

Parameters:
methodName - the method name
Returns:
capitalized method name
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrepareInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class PrepareInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
            extended by  com.opensymphony.xwork2.interceptor.PrepareInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class PrepareInterceptor
extends MethodFilterInterceptor

This interceptor calls prepare() on actions which implement Preparable. This interceptor is very useful for any situation where you need to ensure some logic runs before the actual execute method runs.

A typical use of this is to run some logic to load an object from the database so that when parameters are set they can be set on this object. For example, suppose you have a User object with two properties: id and name. Provided that the params interceptor is called twice (once before and once after this interceptor), you can load the User object using the id property, and then when the second params interceptor is called the parameter user.name will be set, as desired, on the actual object loaded from the database. See the example for more info.

Note: Since XWork 2.0.2, this interceptor extends MethodFilterInterceptor, therefore being able to deal with excludeMethods / includeMethods parameters. See [Workflow Interceptor] (class DefaultWorkflowInterceptor) for documentation and examples on how to use this feature.

Update: Added logic to execute a prepare{MethodName} and conditionally the a general prepare() Method, depending on the 'alwaysInvokePrepare' parameter/property which is by default true. This allows us to run some logic based on the method name we specify in the ActionProxy. For example, you can specify a prepareInput() method that will be run before the invocation of the input method.

Interceptor parameters:

  • alwaysInvokePrepare - Default to true. If true, prepare will always be invoked, otherwise it will not.

Extending the interceptor:

There are no known extension points to this interceptor.

Example code:

 <!-- Calls the params interceptor twice, allowing you to
       pre-load data for the second time parameters are set -->
  <action name="someAction" class="com.examples.SomeAction">
      <interceptor-ref name="params"/>
      <interceptor-ref name="prepare"/>
      <interceptor-ref name="basicStack"/>
      <result name="success">good_result.ftl</result>
  </action>

Author:
Jason Carreira, Philip Luppens, tm_jee
See Also:
Preparable, Serialized Form

Field Summary
Fields inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
excludeMethods, includeMethods, log
Constructor Summary
PrepareInterceptor()
Method Summary
String | doIntercept(ActionInvocation invocation) Subclasses must override to implement the interceptor logic.
void | setAlwaysInvokePrepare(String alwaysInvokePrepare) Sets if the preapare method should always be executed.
Methods inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
applyInterceptor, getExcludeMethodsSet, getIncludeMethodsSet, intercept, setExcludeMethods, setIncludeMethods
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PrepareInterceptor

public PrepareInterceptor()
Method Detail

setAlwaysInvokePrepare

public void setAlwaysInvokePrepare(String alwaysInvokePrepare)
Sets if the preapare method should always be executed.

Default is true.

Parameters:
alwaysInvokePrepare - if prepare should always be executed or not.

doIntercept

public String doIntercept(ActionInvocation invocation)
                   throws Exception
Description copied from class: MethodFilterInterceptor
Subclasses must override to implement the interceptor logic.

Specified by:
doIntercept in class MethodFilterInterceptor
Parameters:
invocation - the action invocation
Returns:
the result of invocation
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PreResultListener (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Interface PreResultListener

All Known Implementing Classes:
AnnotationWorkflowInterceptor, ModelDrivenInterceptor.RefreshModelBeforeResult
public interface PreResultListener

PreResultListeners may be registered with an ActionInvocation to get a callback after the Action has been executed but before the Result is executed.

Author:
Jason Carreira

Method Summary
 void beforeResult(ActionInvocation invocation, String resultCode)
This callback method will be called after the Action execution and before the Result execution.

Method Detail

beforeResult

void beforeResult(ActionInvocation invocation,
                  String resultCode)
This callback method will be called after the Action execution and before the Result execution.

Parameters:
invocation - the action invocation
resultCode - the result code returned by the action (eg. success).
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ScopedModelDriven (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Interface ScopedModelDriven<T>

All Superinterfaces:
ModelDriven<T>
public interface ScopedModelDriven<T>
extends ModelDriven<T>

Adds the ability to set a model, probably retrieved from a given state.

Method Summary
String | getScopeKey() Gets the key under which the model is stored
void | setModel(T model) Sets the model
void | setScopeKey(String key) Sets the key under which the model is stored
Methods inherited from interface com.opensymphony.xwork2.ModelDriven
getModel

Method Detail

setModel

void setModel(T model)
Sets the model

setScopeKey

void setScopeKey(String key)
Sets the key under which the model is stored

Parameters:
key - The model key

getScopeKey

String getScopeKey()
Gets the key under which the model is stored

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ScopedModelDrivenInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class ScopedModelDrivenInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class ScopedModelDrivenInterceptor
extends AbstractInterceptor

An interceptor that enables scoped model-driven actions.

This interceptor only activates on actions that implement the ScopedModelDriven interface. If detected, it will retrieve the model class from the configured scope, then provide it to the Action.

Interceptor parameters:

  • className - The model class name. Defaults to the class name of the object returned by the getModel() method.
  • name - The key to use when storing or retrieving the instance in a scope. Defaults to the model class name.
  • scope - The scope to store and retrieve the model. Defaults to 'request' but can also be 'session'.

Extending the interceptor:

There are no known extension points for this interceptor.

Example code:

 <-- Basic usage -->
 <interceptor name="scopedModelDriven" class="com.opensymphony.interceptor.ScopedModelDrivenInterceptor" />

 <-- Using all available parameters -->
 <interceptor name="gangsterForm" class="com.opensymphony.interceptor.ScopedModelDrivenInterceptor">
      <param name="scope">session</param>
      <param name="name">gangsterForm</param>
      <param name="className">com.opensymphony.example.GangsterForm</param>
  </interceptor>

See Also:
Serialized Form

Constructor Summary
ScopedModelDrivenInterceptor()
Method Summary
String | intercept(ActionInvocation invocation) Override to handle interception
protected Object | resolveModel(ObjectFactory factory, ActionContext actionContext, String modelClassName, String modelScope, String modelName)
void | setClassName(String className)
void | setName(String name)
void | setObjectFactory(ObjectFactory factory)
void | setScope(String scope)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ScopedModelDrivenInterceptor

public ScopedModelDrivenInterceptor()
Method Detail

setObjectFactory

public void setObjectFactory(ObjectFactory factory)

resolveModel

protected Object resolveModel(ObjectFactory factory,
                              ActionContext actionContext,
                              String modelClassName,
                              String modelScope,
                              String modelName)
                       throws Exception
Throws:
Exception

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Parameters:
invocation - the action invocation
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

setClassName

public void setClassName(String className)
Parameters:
className - the className to set

setName

public void setName(String name)
Parameters:
name - the name to set

setScope

public void setScope(String scope)
Parameters:
scope - the scope to set
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StaticParametersInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class StaticParametersInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.StaticParametersInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class StaticParametersInterceptor
extends AbstractInterceptor

This interceptor populates the action with the static parameters defined in the action configuration. If the action implements Parameterizable, a map of the static parameters will be also be passed directly to the action. The static params will be added to the request params map, unless "merge" is set to false.

Parameters are typically defined with <param> elements within xwork.xml.

Interceptor parameters:

  • None

Extending the interceptor:

There are no extension points to this interceptor.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="staticParams">
          <param name="parse">true</param>
          <param name="overwrite">false</param>
     </interceptor-ref>
     <result name="success">good_result.ftl</result>
 </action>

Author:
Patrick Lightbody
See Also:
Serialized Form

Constructor Summary
StaticParametersInterceptor()
Method Summary
protected void | addParametersToContext(ActionContext ac, Map<String,?> newParams) Adds the parameters into context's ParameterMap.
String | intercept(ActionInvocation invocation) Override to handle interception
protected Map<String,String> | retrieveParameters(ActionContext ac)
static void | setDevMode(String mode)
void | setMerge(String value)
void | setOverwrite(String value) Overwrites already existing parameters from other sources.
void | setParse(String value)
void | setValueStackFactory(ValueStackFactory valueStackFactory)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StaticParametersInterceptor

public StaticParametersInterceptor()
Method Detail

setValueStackFactory

public void setValueStackFactory(ValueStackFactory valueStackFactory)

setDevMode

public static void setDevMode(String mode)

setParse

public void setParse(String value)

setMerge

public void setMerge(String value)

setOverwrite

public void setOverwrite(String value)
Overwrites already existing parameters from other sources. Static parameters are the successor over previously set parameters, if true.

Parameters:
value -

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Parameters:
invocation - the action invocation
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

retrieveParameters

protected Map<String,String> retrieveParameters(ActionContext ac)
Parameters:
ac - The action context
Returns:
the parameters from the action mapping in the context. If none found, returns an empty map.

addParametersToContext

protected void addParametersToContext(ActionContext ac,
                                      Map<String,?> newParams)
Adds the parameters into context's ParameterMap. As default, static parameters will not overwrite existing paramaters from other sources. If you want the static parameters as successor over already existing parameters, set overwrite to true.

Parameters:
ac - The action context
newParams - The parameter map to apply
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TimerInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class TimerInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.TimerInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class TimerInterceptor
extends AbstractInterceptor

This interceptor logs the amount of time in milliseconds. In order for this interceptor to work properly, the logging framework must be set to at least the INFO level. This interceptor relies on the Commons Logging API to report its execution-time value.

  • logLevel (optional) - what log level should we use (trace, debug, info, warn, error, fatal)? - defaut is info
  • logCategory (optional) - If provided we would use this category (eg. com.mycompany.app). Default is to use com.opensymphony.xwork2.interceptor.TimerInterceptor.
The parameters above enables us to log all action execution times in our own logfile. This interceptor can be extended to provide custom message format. Users should override the invokeUnderTiming method.

 <!-- records only the action's execution time -->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="completeStack"/>
     <interceptor-ref name="timer"/>
     <result name="success">good_result.ftl</result>
 </action>

 <!-- records action's execution time as well as other interceptors-->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="timer"/>
     <interceptor-ref name="completeStack"/>
     <result name="success">good_result.ftl</result>
 </action>
This second example uses our own log category at debug level.

 <!-- records only the action's execution time -->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="completeStack"/>
     <interceptor-ref name="timer">
         <param name="logLevel">debug</param>
         <param name="logCategory">com.mycompany.myapp.actiontime</param>
     <interceptor-ref/>
     <result name="success">good_result.ftl</result>
 </action>

 <!-- records action's execution time as well as other interceptors-->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="timer"/>
     <interceptor-ref name="completeStack"/>
     <result name="success">good_result.ftl</result>
 </action>

Author:
Jason Carreira, Claus Ibsen
See Also:
Serialized Form

Field Summary
protected Logger | categoryLogger
protected static Logger | LOG
protected String | logCategory
protected String | logLevel
Constructor Summary
TimerInterceptor()
Method Summary
protected void | doLog(Logger logger, String message) Performs the actual logging.
String | getLogCategory()
protected Logger | getLoggerToUse() Get's the logger to use.
String | getLogLevel()
String | intercept(ActionInvocation invocation) Override to handle interception
protected String | invokeUnderTiming(ActionInvocation invocation) Is called to invoke the action invocation and time the execution time.
void | setLogCategory(String logCatgory)
void | setLogLevel(String logLevel)
protected boolean | shouldLog() Determines if we should log the time.
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

protected static final Logger LOG

categoryLogger

protected Logger categoryLogger

logCategory

protected String logCategory

logLevel

protected String logLevel
Constructor Detail

TimerInterceptor

public TimerInterceptor()
Method Detail

getLogCategory

public String getLogCategory()

setLogCategory

public void setLogCategory(String logCatgory)

getLogLevel

public String getLogLevel()

setLogLevel

public void setLogLevel(String logLevel)

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Parameters:
invocation - the action invocation
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

invokeUnderTiming

protected String invokeUnderTiming(ActionInvocation invocation)
                            throws Exception
Is called to invoke the action invocation and time the execution time.

Parameters:
invocation - the action invocation.
Returns:
the result of the action execution.
Throws:
Exception - can be thrown from the action.

shouldLog

protected boolean shouldLog()
Determines if we should log the time.

Returns:
true to log, false to not log.

getLoggerToUse

protected Logger getLoggerToUse()
Get's the logger to use.

Returns:
the logger to use.

doLog

protected void doLog(Logger logger,
                     String message)
Performs the actual logging.

Parameters:
logger - the provided logger to use.
message - the message to log.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidationWorkflowAware (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Interface ValidationWorkflowAware

public interface ValidationWorkflowAware

ValidationWorkflowAware

Method Summary
 String getInputResultName()

Method Detail

getInputResultName

String getInputResultName()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


After (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

com.opensymphony.xwork2.interceptor.annotations
Annotation Type After

@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface After

Marks a action method that needs to be called after the main action method and the result was executed. Return value is ignored.

Annotation usage: The After annotation can be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
priority | no | 10 | Priority order of method execution

Example code:

 public class SampleAction extends ActionSupport {

  @After
  public void isValid() throws ValidationException {
    // validate model object, throw exception if failed
  }

  public String execute() {
     // perform action
     return SUCCESS;
  }
 }

Author:
Zsolt Szasz, zsolt at lorecraft dot com, Rainer Hermanns

Optional Element Summary
 int priority

priority

public abstract int priority
Default:
10
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT


Allowed (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.interceptor.annotations
Annotation Type Allowed

@Retention(value=RUNTIME)
@Target(value=FIELD)
public @interface Allowed

Declares that it is permitted for the field be mutated through a HttpRequest parameter.

Author:
martin.gilday

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


AnnotationParameterFilterIntereptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor.annotations
Class AnnotationParameterFilterIntereptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.annotations.AnnotationParameterFilterIntereptor
All Implemented Interfaces:
Interceptor, Serializable
public class AnnotationParameterFilterIntereptor
extends AbstractInterceptor

Annotation based version of ParameterFilterInterceptor.

This Interceptor must be placed in the stack before the ParametersInterceptor When a parameter matches a field that is marked Blocked then it is removed from the parameter map.

If an Action class is marked with BlockByDefault then all parameters are removed unless a field on the Action exists and is marked with Allowed

Author:
martin.gilday
See Also:
Serialized Form

Constructor Summary
AnnotationParameterFilterIntereptor()
Method Summary
 String intercept(ActionInvocation invocation)
Override to handle interception
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AnnotationParameterFilterIntereptor

public AnnotationParameterFilterIntereptor()
Method Detail

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Parameters:
invocation - the action invocation
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AnnotationWorkflowInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor.annotations
Class AnnotationWorkflowInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor
All Implemented Interfaces:
Interceptor, PreResultListener, Serializable
public class AnnotationWorkflowInterceptor
extends Object
implements Interceptor, PreResultListener

Invokes any annotated methods on the action. Specifically, it supports the following annotations:

  • @Before - will be invoked before the action method. If the returned value is not null, it is returned as the action result code
  • @BeforeResult - will be invoked after the action method but before the result execution
  • @After - will be invoked after the action method and result execution

There can be multiple methods marked with the same annotations, but the order of their execution is not guaranteed. However, the annotated methods on the superclass chain are guaranteed to be invoked before the annotated method in the current class in the case of a Before annotations and after, if the annotations is After.

  public class BaseAnnotatedAction {
        protected String log = "";

        @Before
        public String baseBefore() {
                log = log + "baseBefore-";
                return null;
        }
  }

  public class AnnotatedAction extends BaseAnnotatedAction {
        @Before
        public String before() {
                log = log + "before";
                return null;
        }

        public String execute() {
                log = log + "-execute";
                return Action.SUCCESS;
        }

        @BeforeResult
        public void beforeResult() throws Exception {
                log = log +"-beforeResult";
        }

        @After
        public void after() {
                log = log + "-after";
        }
  }

With the interceptor applied and the action executed on AnnotatedAction the log instance variable will contain baseBefore-before-execute-beforeResult-after.

Configure a stack in xwork.xml that replaces the PrepareInterceptor with the AnnotationWorkflowInterceptor:

 <interceptor-stack name="annotatedStack">
        <interceptor-ref name="staticParams"/>
        <interceptor-ref name="params"/>
        <interceptor-ref name="conversionError"/>
        <interceptor-ref name="annotationWorkflow"/>
 </interceptor-stack>

Author:
Zsolt Szasz, zsolt at lorecraft dot com, Rainer Hermanns, Dan Oxlade, dan d0t oxlade at gmail d0t c0m
See Also:
Serialized Form

Constructor Summary
AnnotationWorkflowInterceptor()
Method Summary
void | beforeResult(ActionInvocation invocation, String resultCode) Invokes any @BeforeResult annotated methods
protected static int | comparePriorities(int val1, int val2)
void | destroy() Called to let an interceptor clean up any resources it has allocated.
void | init() Called after an interceptor is created, but before any requests are processed using intercept , giving the Interceptor a chance to initialize any needed resources.
String | intercept(ActionInvocation invocation) Discovers annotated methods on the action and calls them according to the workflow
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AnnotationWorkflowInterceptor

public AnnotationWorkflowInterceptor()
Method Detail

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Discovers annotated methods on the action and calls them according to the workflow

Specified by:
intercept in interface Interceptor
Parameters:
invocation - the action invocation
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
See Also:
Interceptor.intercept(com.opensymphony.xwork2.ActionInvocation)

destroy

public void destroy()
Description copied from interface: Interceptor
Called to let an interceptor clean up any resources it has allocated.

Specified by:
destroy in interface Interceptor

init

public void init()
Description copied from interface: Interceptor
Called after an interceptor is created, but before any requests are processed using intercept , giving the Interceptor a chance to initialize any needed resources.

Specified by:
init in interface Interceptor

comparePriorities

protected static int comparePriorities(int val1,
                                       int val2)

beforeResult

public void beforeResult(ActionInvocation invocation,
                         String resultCode)
Invokes any @BeforeResult annotated methods

Specified by:
beforeResult in interface PreResultListener
Parameters:
invocation - the action invocation
resultCode - the result code returned by the action (eg. success).
See Also:
PreResultListener.beforeResult(com.opensymphony.xwork2.ActionInvocation,String)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Before (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.interceptor.annotations
Annotation Type Before

@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface Before

Marks a action method that needs to be executed before the main action method.

Annotation usage: The Before annotation can be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
priority | no | 10 | Priority order of method execution

Example code:

 public class SampleAction extends ActionSupport {

  @Before
  public void isAuthorized() throws AuthenticationException {
    // authorize request, throw exception if failed
  }

  public String execute() {
     // perform secure action
     return SUCCESS;
  }
 }

Author:
Zsolt Szasz, zsolt at lorecraft dot com, Rainer Hermanns

Optional Element Summary
 int priority

priority

public abstract int priority
Default:
10
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


BeforeResult (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.interceptor.annotations
Annotation Type BeforeResult

@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface BeforeResult

Marks a action method that needs to be executed before the result. Return value is ignored.

Annotation usage: The BeforeResult annotation can be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
priority | no | 10 | Priority order of method execution

Example code:

 public class SampleAction extends ActionSupport {

  @BeforeResult
  public void isValid() throws ValidationException {
    // validate model object, throw exception if failed
  }

  public String execute() {
     // perform action
     return SUCCESS;
  }
 }

Author:
Zsolt Szasz, zsolt at lorecraft dot com, Rainer Hermanns

Optional Element Summary
 int priority

priority

public abstract int priority
Default:
10
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


BlockByDefault (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.interceptor.annotations
Annotation Type BlockByDefault

@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface BlockByDefault

Declares that by default fields on the Action class are NOT permitted to be set from HttpRequest parameters. To allow access to a field it must be annotated with Allowed

Author:
martin.gilday

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


Blocked (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.interceptor.annotations
Annotation Type Blocked

@Retention(value=RUNTIME)
@Target(value=FIELD)
public @interface Blocked

Declares that the given field should NOT be able to be mutated through a HttpRequest parameter.

Author:
martin.gilday

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


InputConfig (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

com.opensymphony.xwork2.interceptor.annotations
Annotation Type InputConfig

@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface InputConfig

Marks a action method that if it's not validated by ValidationInterceptor then execute input method or input result.

Annotation usage: The InputConfig annotation can be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
methodName | no |  | execute this method if specific
resultName | no |  | return this result if methodName not specific

Example code:

 public class SampleAction extends ActionSupport {

  public void isValid() throws ValidationException {
    // validate model object, throw exception if failed
  }

  @InputConfig(methodName="input")
  public String execute() {
     // perform action
     return SUCCESS;
  }
  public String input() {
     // perform some data filling
     return INPUT;
  }
 }

Author:
zhouyanming, zhouyanming@gmail.com

Optional Element Summary
String | methodName
String | resultName

methodName

public abstract String methodName
Default:
""

resultName

public abstract String resultName
Default:
"input"
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT


com.opensymphony.xwork2.interceptor.annotations (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.interceptor.annotations
Classes
AnnotationParameterFilterIntereptor
AnnotationWorkflowInterceptor
Annotation Types
After
Allowed
Before
BeforeResult
BlockByDefault
Blocked
InputConfig


com.opensymphony.xwork2.interceptor.annotations (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.interceptor.annotations

Interceptor annotations.

See:
Description

Class Summary
AnnotationParameterFilterIntereptor | Annotation based version of ParameterFilterInterceptor.
AnnotationWorkflowInterceptor |

Annotation Types Summary
After | Marks a action method that needs to be called after the main action method and the result was executed.
Allowed | Declares that it is permitted for the field be mutated through a HttpRequest parameter.
Before | Marks a action method that needs to be executed before the main action method.
BeforeResult | Marks a action method that needs to be executed before the result.
BlockByDefault | Declares that by default fields on the Action class are NOT permitted to be set from HttpRequest parameters.
Blocked | Declares that the given field should NOT be able to be mutated through a HttpRequest parameter.
InputConfig | Marks a action method that if it's not validated by ValidationInterceptor then execute input method or input result.

Package com.opensymphony.xwork2.interceptor.annotations Description

Interceptor annotations.


com.opensymphony.xwork2.interceptor.annotations Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.interceptor.annotations

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.interceptor.AbstractInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
      • com.opensymphony.xwork2.interceptor.annotations.AnnotationParameterFilterIntereptor
    • com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor, com.opensymphony.xwork2.interceptor.PreResultListener)

Annotation Type Hierarchy

  • com.opensymphony.xwork2.interceptor.annotations.InputConfig (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.interceptor.annotations.Blocked (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.interceptor.annotations.BlockByDefault (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.interceptor.annotations.BeforeResult (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.interceptor.annotations.Before (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.interceptor.annotations.Allowed (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.interceptor.annotations.After (implements java.lang.annotation.Annotation)


Uses of Package com.opensymphony.xwork2.interceptor.annotations (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.interceptor.annotations

No usage of com.opensymphony.xwork2.interceptor.annotations

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.annotations.After (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.annotations.After

No usage of com.opensymphony.xwork2.interceptor.annotations.After

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.annotations.Allowed (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.annotations.Allowed

No usage of com.opensymphony.xwork2.interceptor.annotations.Allowed

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.annotations.AnnotationParameterFilterIntereptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.annotations.AnnotationParameterFilterIntereptor

No usage of com.opensymphony.xwork2.interceptor.annotations.AnnotationParameterFilterIntereptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor

No usage of com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.annotations.Before (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.annotations.Before

No usage of com.opensymphony.xwork2.interceptor.annotations.Before

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.annotations.BeforeResult (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.annotations.BeforeResult

No usage of com.opensymphony.xwork2.interceptor.annotations.BeforeResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.annotations.BlockByDefault (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.annotations.BlockByDefault

No usage of com.opensymphony.xwork2.interceptor.annotations.BlockByDefault

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.annotations.Blocked (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.annotations.Blocked

No usage of com.opensymphony.xwork2.interceptor.annotations.Blocked

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.annotations.InputConfig (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.annotations.InputConfig

No usage of com.opensymphony.xwork2.interceptor.annotations.InputConfig

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.AbstractInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.AbstractInterceptor

Packages that use AbstractInterceptor
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.interceptor.annotations | Interceptor annotations.
com.opensymphony.xwork2.spring.interceptor | Spring specific interceptor classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.

Uses of AbstractInterceptor in com.opensymphony.xwork2.interceptor

Subclasses of AbstractInterceptor in com.opensymphony.xwork2.interceptor
class | AliasInterceptor The aim of this Interceptor is to alias a named parameter to a different named parameter.
class | ChainingInterceptor An interceptor that copies all the properties of every object in the value stack to the currently executing object, except for any object that implements Unchainable.
class | ConversionErrorInterceptor ConversionErrorInterceptor adds conversion errors from the ActionContext to the Action's field errors.
class | DefaultWorkflowInterceptor An interceptor that makes sure there are not validation errors before allowing the interceptor chain to continue.
class | ExceptionMappingInterceptor This interceptor forms the core functionality of the exception handling feature.
class | I18nInterceptor An interceptor that handles setting the locale specified in a session as the locale for the current action request.
class | LoggingInterceptor This interceptor logs the start and end of the execution an action (in English-only, not internationalized).
class | MethodFilterInterceptor MethodFilterInterceptor is an abstract Interceptor used as a base class for interceptors that will filter execution based on method names according to specified included/excluded method lists.
class | ModelDrivenInterceptor Watches for ModelDriven actions and adds the action's model on to the value stack.
class | ParameterFilterInterceptor The Parameter Filter Interceptor blocks parameters from getting to the rest of the stack or your action.
class | ParameterRemoverInterceptor This is a simple XWork interceptor that allows parameters (matching one of the paramNames attribute csv value) to be removed from the parameter map if they match a certain value (matching one of the paramValues attribute csv value), before they are set on the action.
class | ParametersInterceptor This interceptor sets all parameters on the value stack.
class | PrepareInterceptor This interceptor calls prepare() on actions which implement Preparable.
class | ScopedModelDrivenInterceptor An interceptor that enables scoped model-driven actions.
class | StaticParametersInterceptor This interceptor populates the action with the static parameters defined in the action configuration.
class | TimerInterceptor This interceptor logs the amount of time in milliseconds.

Uses of AbstractInterceptor in com.opensymphony.xwork2.interceptor.annotations

Subclasses of AbstractInterceptor in com.opensymphony.xwork2.interceptor.annotations
 class AnnotationParameterFilterIntereptor
Annotation based version of ParameterFilterInterceptor.

Uses of AbstractInterceptor in com.opensymphony.xwork2.spring.interceptor

Subclasses of AbstractInterceptor in com.opensymphony.xwork2.spring.interceptor
 class ActionAutowiringInterceptor
TODO: Give a description of the Interceptor.

Uses of AbstractInterceptor in com.opensymphony.xwork2.validator

Subclasses of AbstractInterceptor in com.opensymphony.xwork2.validator
 class ValidationInterceptor
This interceptor runs the action through the standard validation framework, which in turn checks the action against any validation rules (found in files such as ActionClass-validation.xml) and adds field-level and action-level error messages (provided that the action implements ValidationAware).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.AliasInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.AliasInterceptor

No usage of com.opensymphony.xwork2.interceptor.AliasInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.ChainingInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.ChainingInterceptor

No usage of com.opensymphony.xwork2.interceptor.ChainingInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor

No usage of com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor

No usage of com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.ExceptionHolder (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.ExceptionHolder

Packages that use ExceptionHolder
com.opensymphony.xwork2.interceptor Interceptor classes.

Uses of ExceptionHolder in com.opensymphony.xwork2.interceptor

Methods in com.opensymphony.xwork2.interceptor with parameters of type ExceptionHolder
protected  void ExceptionMappingInterceptor.publishException(ActionInvocation invocation, ExceptionHolder exceptionHolder)
Default implementation to handle ExceptionHolder publishing.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor

No usage of com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.I18nInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.I18nInterceptor

No usage of com.opensymphony.xwork2.interceptor.I18nInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.interceptor.Interceptor (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.interceptor.Interceptor

Packages that use Interceptor
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.interceptor.annotations | Interceptor annotations.
com.opensymphony.xwork2.mock | XWork specific mock classes.
com.opensymphony.xwork2.spring.interceptor | Spring specific interceptor classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.

Uses of Interceptor in com.opensymphony.xwork2

Methods in com.opensymphony.xwork2 that return Interceptor
 Interceptor ObjectFactory.buildInterceptor(InterceptorConfig interceptorConfig, Map<String,String> interceptorRefParams)
Builds an Interceptor from the InterceptorConfig and the Map of parameters from the interceptor reference.

Uses of Interceptor in com.opensymphony.xwork2.config.entities

Methods in com.opensymphony.xwork2.config.entities that return Interceptor
 Interceptor InterceptorMapping.getInterceptor()

Constructors in com.opensymphony.xwork2.config.entities with parameters of type Interceptor
InterceptorMapping(String name, Interceptor interceptor)

Uses of Interceptor in com.opensymphony.xwork2.interceptor

Classes in com.opensymphony.xwork2.interceptor that implement Interceptor
class | AbstractInterceptor Provides default implementations of optional lifecycle methods
class | AliasInterceptor The aim of this Interceptor is to alias a named parameter to a different named parameter.
class | ChainingInterceptor An interceptor that copies all the properties of every object in the value stack to the currently executing object, except for any object that implements Unchainable.
class | ConversionErrorInterceptor ConversionErrorInterceptor adds conversion errors from the ActionContext to the Action's field errors.
class | DefaultWorkflowInterceptor An interceptor that makes sure there are not validation errors before allowing the interceptor chain to continue.
class | ExceptionMappingInterceptor This interceptor forms the core functionality of the exception handling feature.
class | I18nInterceptor An interceptor that handles setting the locale specified in a session as the locale for the current action request.
class | LoggingInterceptor This interceptor logs the start and end of the execution an action (in English-only, not internationalized).
class | MethodFilterInterceptor MethodFilterInterceptor is an abstract Interceptor used as a base class for interceptors that will filter execution based on method names according to specified included/excluded method lists.
class | ModelDrivenInterceptor Watches for ModelDriven actions and adds the action's model on to the value stack.
class | ParameterFilterInterceptor The Parameter Filter Interceptor blocks parameters from getting to the rest of the stack or your action.
class | ParameterRemoverInterceptor This is a simple XWork interceptor that allows parameters (matching one of the paramNames attribute csv value) to be removed from the parameter map if they match a certain value (matching one of the paramValues attribute csv value), before they are set on the action.
class | ParametersInterceptor This interceptor sets all parameters on the value stack.
class | PrepareInterceptor This interceptor calls prepare() on actions which implement Preparable.
class | ScopedModelDrivenInterceptor An interceptor that enables scoped model-driven actions.
class | StaticParametersInterceptor This interceptor populates the action with the static parameters defined in the action configuration.
class | TimerInterceptor This interceptor logs the amount of time in milliseconds.

Uses of Interceptor in com.opensymphony.xwork2.interceptor.annotations

Classes in com.opensymphony.xwork2.interceptor.annotations that implement Interceptor
class | AnnotationParameterFilterIntereptor Annotation based version of ParameterFilterInterceptor.
class | AnnotationWorkflowInterceptor

Uses of Interceptor in com.opensymphony.xwork2.mock

Classes in com.opensymphony.xwork2.mock that implement Interceptor
 class MockInterceptor
Mock for an Interceptor.

Uses of Interceptor in com.opensymphony.xwork2.spring.interceptor

Classes in com.opensymphony.xwork2.spring.interceptor that implement Interceptor
 class ActionAutowiringInterceptor
TODO: Give a description of the Interceptor.

Uses of Interceptor in com.opensymphony.xwork2.validator

Classes in com.opensymphony.xwork2.validator that implement Interceptor
 class ValidationInterceptor
This interceptor runs the action through the standard validation framework, which in turn checks the action against any validation rules (found in files such as ActionClass-validation.xml) and adds field-level and action-level error messages (provided that the action implements ValidationAware).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.LoggingInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.LoggingInterceptor

No usage of com.opensymphony.xwork2.interceptor.LoggingInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.MethodFilterInterceptor

Packages that use MethodFilterInterceptor
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.

Uses of MethodFilterInterceptor in com.opensymphony.xwork2.interceptor

Subclasses of MethodFilterInterceptor in com.opensymphony.xwork2.interceptor
class | DefaultWorkflowInterceptor An interceptor that makes sure there are not validation errors before allowing the interceptor chain to continue.
class | ParametersInterceptor This interceptor sets all parameters on the value stack.
class | PrepareInterceptor This interceptor calls prepare() on actions which implement Preparable.

Uses of MethodFilterInterceptor in com.opensymphony.xwork2.validator

Subclasses of MethodFilterInterceptor in com.opensymphony.xwork2.validator
 class ValidationInterceptor
This interceptor runs the action through the standard validation framework, which in turn checks the action against any validation rules (found in files such as ActionClass-validation.xml) and adds field-level and action-level error messages (provided that the action implements ValidationAware).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.MethodFilterInterceptorUtil (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.MethodFilterInterceptorUtil

No usage of com.opensymphony.xwork2.interceptor.MethodFilterInterceptorUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor

No usage of com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor.RefreshModelBeforeResult (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor.RefreshModelBeforeResult

No usage of com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor.RefreshModelBeforeResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.interceptor.NoParameters (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.interceptor.NoParameters

No usage of com.opensymphony.xwork2.interceptor.NoParameters

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

No usage of com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.interceptor.ParameterNameAware (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.interceptor.ParameterNameAware

No usage of com.opensymphony.xwork2.interceptor.ParameterNameAware

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor

No usage of com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.ParametersInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.ParametersInterceptor

No usage of com.opensymphony.xwork2.interceptor.ParametersInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil

No usage of com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.PrepareInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.PrepareInterceptor

No usage of com.opensymphony.xwork2.interceptor.PrepareInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.interceptor.PreResultListener (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.interceptor.PreResultListener

Packages that use PreResultListener
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.interceptor.annotations | Interceptor annotations.
com.opensymphony.xwork2.mock | XWork specific mock classes.

Uses of PreResultListener in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 with type parameters of type PreResultListener
protected  List<PreResultListener> DefaultActionInvocation.preResultListeners

Methods in com.opensymphony.xwork2 with parameters of type PreResultListener
void | DefaultActionInvocation.addPreResultListener(PreResultListener listener) Register a com.opensymphony.xwork2.interceptor.PreResultListener to be notified after the Action is executed and before the Result is executed.
void | ActionInvocation.addPreResultListener(PreResultListener listener) Register a PreResultListener to be notified after the Action is executed and before the Result is executed.

Uses of PreResultListener in com.opensymphony.xwork2.interceptor

Classes in com.opensymphony.xwork2.interceptor that implement PreResultListener
protected static class ModelDrivenInterceptor.RefreshModelBeforeResult
Refreshes the model instance on the value stack, if it has changed

Uses of PreResultListener in com.opensymphony.xwork2.interceptor.annotations

Classes in com.opensymphony.xwork2.interceptor.annotations that implement PreResultListener
 class AnnotationWorkflowInterceptor

Uses of PreResultListener in com.opensymphony.xwork2.mock

Methods in com.opensymphony.xwork2.mock with parameters of type PreResultListener
 void MockActionInvocation.addPreResultListener(PreResultListener listener)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.interceptor.ScopedModelDriven (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.interceptor.ScopedModelDriven

No usage of com.opensymphony.xwork2.interceptor.ScopedModelDriven

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor

No usage of com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.StaticParametersInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.StaticParametersInterceptor

No usage of com.opensymphony.xwork2.interceptor.StaticParametersInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.TimerInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.TimerInterceptor

No usage of com.opensymphony.xwork2.interceptor.TimerInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.interceptor.ValidationWorkflowAware (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.interceptor.ValidationWorkflowAware

No usage of com.opensymphony.xwork2.interceptor.ValidationWorkflowAware

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


MockActionInvocation (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.mock
Class MockActionInvocation

java.lang.Object
    extended by  com.opensymphony.xwork2.mock.MockActionInvocation
All Implemented Interfaces:
ActionInvocation, Serializable
Direct Known Subclasses:
MockActionInvocation
public class MockActionInvocation
extends Object
implements ActionInvocation

Mock for an ActionInvocation.

Version:
$Id: MockActionInvocation.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
plightbo, Rainer Hermanns, tm_jee
See Also:
Serialized Form

Constructor Summary
MockActionInvocation()
Method Summary
void | addPreResultListener(PreResultListener listener) Register a PreResultListener to be notified after the Action is executed and before the Result is executed.
Object | getAction() Get the Action associated with this ActionInvocation.
ActionEventListener | getActionEventListener()
ActionContext | getInvocationContext() Gets the ActionContext associated with this ActionInvocation.
ActionProxy | getProxy() Get the ActionProxy holding this ActionInvocation.
Result | getResult() If the ActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned.
String | getResultCode() Gets the result code returned from this ActionInvocation.
ValueStack | getStack() Gets the ValueStack associated with this ActionInvocation.
void | init(ActionProxy proxy)
String | invoke() Invokes the next step in processing this ActionInvocation.
String | invokeActionOnly() Invokes only the Action (not Interceptors or Results).
boolean | isExecuted() Gets whether this ActionInvocation has executed before.
void | setAction(Object action)
void | setActionEventListener(ActionEventListener listener) Sets the action event listener to respond to key action events.
void | setInvocationContext(ActionContext invocationContext)
void | setProxy(ActionProxy proxy)
void | setResult(Result result)
void | setResultCode(String resultCode) Sets the result code, possibly overriding the one returned by the action.
void | setStack(ValueStack stack)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MockActionInvocation

public MockActionInvocation()
Method Detail

getAction

public Object getAction()
Description copied from interface: ActionInvocation
Get the Action associated with this ActionInvocation.

Specified by:
getAction in interface ActionInvocation
Returns:
the Action

setAction

public void setAction(Object action)

getInvocationContext

public ActionContext getInvocationContext()
Description copied from interface: ActionInvocation
Gets the ActionContext associated with this ActionInvocation. The ActionProxy is responsible for setting this ActionContext onto the ThreadLocal before invoking the ActionInvocation and resetting the old ActionContext afterwards.

Specified by:
getInvocationContext in interface ActionInvocation
Returns:
the ActionContext.

setInvocationContext

public void setInvocationContext(ActionContext invocationContext)

getProxy

public ActionProxy getProxy()
Description copied from interface: ActionInvocation
Get the ActionProxy holding this ActionInvocation.

Specified by:
getProxy in interface ActionInvocation
Returns:
the ActionProxy.

setProxy

public void setProxy(ActionProxy proxy)

getResult

public Result getResult()
Description copied from interface: ActionInvocation
If the ActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned. If the ActionInvocation's result has not been executed before, the Result instance will be created and populated with the result params.

Specified by:
getResult in interface ActionInvocation
Returns:
the result.

setResult

public void setResult(Result result)

getResultCode

public String getResultCode()
Description copied from interface: ActionInvocation
Gets the result code returned from this ActionInvocation.

Specified by:
getResultCode in interface ActionInvocation
Returns:
the result code

setResultCode

public void setResultCode(String resultCode)
Description copied from interface: ActionInvocation
Sets the result code, possibly overriding the one returned by the action.

The "intended" purpose of this method is to allow PreResultListeners to override the result code returned by the Action.

If this method is used before the Action executes, the Action's returned result code will override what was set. However the Action could (if specifically coded to do so) inspect the ActionInvocation to see that someone "upstream" (e.g. an Interceptor) had suggested a value as the result, and it could therefore return the same value itself.

If this method is called between the Action execution and the Result execution, then the value set here will override the result code the action had returned. Creating an Interceptor that implements PreResultListener will give you this oportunity.

If this method is called after the Result has been executed, it will have the effect of raising an IllegalStateException.

Specified by:
setResultCode in interface ActionInvocation
Parameters:
resultCode - the result code.
See Also:
ActionInvocation.isExecuted()

getStack

public ValueStack getStack()
Description copied from interface: ActionInvocation
Gets the ValueStack associated with this ActionInvocation.

Specified by:
getStack in interface ActionInvocation
Returns:
the ValueStack

setStack

public void setStack(ValueStack stack)

isExecuted

public boolean isExecuted()
Description copied from interface: ActionInvocation
Gets whether this ActionInvocation has executed before. This will be set after the Action and the Result have executed.

Specified by:
isExecuted in interface ActionInvocation
Returns:
true if this ActionInvocation has executed before.

addPreResultListener

public void addPreResultListener(PreResultListener listener)
Description copied from interface: ActionInvocation
Register a PreResultListener to be notified after the Action is executed and before the Result is executed.

The ActionInvocation implementation must guarantee that listeners will be called in the order in which they are registered.

Listener registration and execution does not need to be thread-safe.

Specified by:
addPreResultListener in interface ActionInvocation
Parameters:
listener - the listener to add.

invoke

public String invoke()
              throws Exception
Description copied from interface: ActionInvocation
Invokes the next step in processing this ActionInvocation.

If there are more Interceptors, this will call the next one. If Interceptors choose not to short-circuit ActionInvocation processing and return their own return code, they will call invoke() to allow the next Interceptor to execute. If there are no more Interceptors to be applied, the Action is executed. If the ActionProxy.getExecuteResult() method returns true, the Result is also executed.

Specified by:
invoke in interface ActionInvocation
Returns:
the return code.
Throws:
Exception - can be thrown.

invokeActionOnly

public String invokeActionOnly()
                        throws Exception
Description copied from interface: ActionInvocation
Invokes only the Action (not Interceptors or Results).

This is useful in rare situations where advanced usage with the interceptor/action/result workflow is being manipulated for certain functionality.

Specified by:
invokeActionOnly in interface ActionInvocation
Returns:
the return code.
Throws:
Exception - can be thrown.

setActionEventListener

public void setActionEventListener(ActionEventListener listener)
Description copied from interface: ActionInvocation
Sets the action event listener to respond to key action events.

Specified by:
setActionEventListener in interface ActionInvocation
Parameters:
listener - the listener.

getActionEventListener

public ActionEventListener getActionEventListener()

init

public void init(ActionProxy proxy)
Specified by:
init in interface ActionInvocation
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


MockActionProxy (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.mock
Class MockActionProxy

java.lang.Object
    extended by  com.opensymphony.xwork2.mock.MockActionProxy
All Implemented Interfaces:
ActionProxy
public class MockActionProxy
extends Object
implements ActionProxy

Mock for an ActionProxy.

Author:
Patrick Lightbody (plightbo at gmail dot com)

Constructor Summary
MockActionProxy()
Method Summary
String | execute() Execute this ActionProxy.
Object | getAction() Gets the Action instance for this Proxy.
String | getActionName() Gets the alias name this ActionProxy is mapped to.
ActionConfig | getConfig() Gets the ActionConfig this ActionProxy is built from.
boolean | getExecuteResult() Gets the status of whether the ActionProxy is set to execute the Result after the Action is executed.
ActionInvocation | getInvocation() Gets the ActionInvocation associated with this ActionProxy.
String | getMethod() Gets the method name to execute, or null if no method has been specified (meaning execute will be invoked).
String | getNamespace() Gets the namespace the ActionConfig for this ActionProxy is mapped to.
boolean | isExecutedCalled()
void | prepare()
void | setAction(Object action)
void | setActionName(String actionName)
void | setConfig(ActionConfig config)
void | setExecuteResult(boolean executeResult) Sets whether this ActionProxy should also execute the Result after executing the Action.
void | setInvocation(ActionInvocation invocation)
void | setMethod(String method)
void | setNamespace(String namespace)
void | setReturnedResult(String returnedResult)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MockActionProxy

public MockActionProxy()
Method Detail

prepare

public void prepare()
             throws Exception
Throws:
Exception

execute

public String execute()
               throws Exception
Description copied from interface: ActionProxy
Execute this ActionProxy. This will set the ActionContext from the ActionInvocation into the ActionContext ThreadLocal before invoking the ActionInvocation, then set the old ActionContext back into the ThreadLocal.

Specified by:
execute in interface ActionProxy
Returns:
the result code returned from executing the ActionInvocation
Throws:
Exception - can be thrown.
See Also:
ActionInvocation

setReturnedResult

public void setReturnedResult(String returnedResult)

isExecutedCalled

public boolean isExecutedCalled()

getAction

public Object getAction()
Description copied from interface: ActionProxy
Gets the Action instance for this Proxy.

Specified by:
getAction in interface ActionProxy
Returns:
the Action instance

setAction

public void setAction(Object action)

getActionName

public String getActionName()
Description copied from interface: ActionProxy
Gets the alias name this ActionProxy is mapped to.

Specified by:
getActionName in interface ActionProxy
Returns:
the alias name

setActionName

public void setActionName(String actionName)

getConfig

public ActionConfig getConfig()
Description copied from interface: ActionProxy
Gets the ActionConfig this ActionProxy is built from.

Specified by:
getConfig in interface ActionProxy
Returns:
the ActionConfig

setConfig

public void setConfig(ActionConfig config)

getExecuteResult

public boolean getExecuteResult()
Description copied from interface: ActionProxy
Gets the status of whether the ActionProxy is set to execute the Result after the Action is executed.

Specified by:
getExecuteResult in interface ActionProxy
Returns:
the status

setExecuteResult

public void setExecuteResult(boolean executeResult)
Description copied from interface: ActionProxy
Sets whether this ActionProxy should also execute the Result after executing the Action.

Specified by:
setExecuteResult in interface ActionProxy
Parameters:
executeResult - true to also execute the Result.

getInvocation

public ActionInvocation getInvocation()
Description copied from interface: ActionProxy
Gets the ActionInvocation associated with this ActionProxy.

Specified by:
getInvocation in interface ActionProxy
Returns:
the ActionInvocation

setInvocation

public void setInvocation(ActionInvocation invocation)

getNamespace

public String getNamespace()
Description copied from interface: ActionProxy
Gets the namespace the ActionConfig for this ActionProxy is mapped to.

Specified by:
getNamespace in interface ActionProxy
Returns:
the namespace

setNamespace

public void setNamespace(String namespace)

getMethod

public String getMethod()
Description copied from interface: ActionProxy
Gets the method name to execute, or null if no method has been specified (meaning execute will be invoked).

Specified by:
getMethod in interface ActionProxy
Returns:
the method to execute

setMethod

public void setMethod(String method)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MockInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.mock
Class MockInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.mock.MockInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class MockInterceptor
extends Object
implements Interceptor

Mock for an Interceptor.

Author:
Jason Carreira
See Also:
Serialized Form

Field Summary
static String DEFAULT_FOO_VALUE
Constructor Summary
MockInterceptor()
Method Summary
 void destroy()
Called to let an interceptor clean up any resources it has allocated.
 boolean equals(Object o)
 String getExpectedFoo()
 String getFoo()
 int hashCode()
 void init()
Called after an Interceptor is created, but before any requests are processed using the intercept() methodName.
 String intercept(ActionInvocation invocation)
Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the DefaultActionInvocation or to short-circuit the processing and just return a String return code.
 boolean isExecuted()
 void setExpectedFoo(String expectedFoo)
 void setFoo(String foo)
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_FOO_VALUE

public static final String DEFAULT_FOO_VALUE
See Also:
Constant Field Values
Constructor Detail

MockInterceptor

public MockInterceptor()
Method Detail

isExecuted

public boolean isExecuted()

setExpectedFoo

public void setExpectedFoo(String expectedFoo)

getExpectedFoo

public String getExpectedFoo()

setFoo

public void setFoo(String foo)

getFoo

public String getFoo()

destroy

public void destroy()
Called to let an interceptor clean up any resources it has allocated.

Specified by:
destroy in interface Interceptor

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object

init

public void init()
Called after an Interceptor is created, but before any requests are processed using the intercept() methodName. This gives the Interceptor a chance to initialize any needed resources.

Specified by:
init in interface Interceptor

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the DefaultActionInvocation or to short-circuit the processing and just return a String return code.

Specified by:
intercept in interface Interceptor
Parameters:
invocation - the action invocation
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MockObjectTypeDeterminer (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.mock
Class MockObjectTypeDeterminer

java.lang.Object
    extended by  com.opensymphony.xwork2.mock.MockObjectTypeDeterminer
All Implemented Interfaces:
ObjectTypeDeterminer
public class MockObjectTypeDeterminer
extends Object
implements ObjectTypeDeterminer

Mocks the function of an ObjectTypeDeterminer for testing purposes.

Author:
Gabe

Constructor Summary
MockObjectTypeDeterminer()
MockObjectTypeDeterminer(Class keyClass, Class elementClass, String keyProperty, boolean shouldCreateIfNew)
Method Summary
Class | getElementClass()
Class | getElementClass(Class parentClass, String property, Object key)
Class | getKeyClass()
Class | getKeyClass(Class parentClass, String property)
String | getKeyProperty()
String | getKeyProperty(Class parentClass, String property)
boolean | isShouldCreateIfNew()
void | setElementClass(Class elementClass)
void | setKeyClass(Class keyClass)
void | setKeyProperty(String keyProperty)
void | setShouldCreateIfNew(boolean shouldCreateIfNew)
boolean | shouldCreateIfNew(Class parentClass, String property, Object target, String keyProperty, boolean isIndexAccessed)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MockObjectTypeDeterminer

public MockObjectTypeDeterminer()

MockObjectTypeDeterminer

public MockObjectTypeDeterminer(Class keyClass,
                                Class elementClass,
                                String keyProperty,
                                boolean shouldCreateIfNew)
Parameters:
keyClass -
elementClass -
keyProperty -
shouldCreateIfNew -
Method Detail

getKeyClass

public Class getKeyClass(Class parentClass,
                         String property)
Specified by:
getKeyClass in interface ObjectTypeDeterminer

getElementClass

public Class getElementClass(Class parentClass,
                             String property,
                             Object key)
Specified by:
getElementClass in interface ObjectTypeDeterminer

getKeyProperty

public String getKeyProperty(Class parentClass,
                             String property)
Specified by:
getKeyProperty in interface ObjectTypeDeterminer

shouldCreateIfNew

public boolean shouldCreateIfNew(Class parentClass,
                                 String property,
                                 Object target,
                                 String keyProperty,
                                 boolean isIndexAccessed)
Specified by:
shouldCreateIfNew in interface ObjectTypeDeterminer

getElementClass

public Class getElementClass()
Returns:
Returns the elementClass.

setElementClass

public void setElementClass(Class elementClass)
Parameters:
elementClass - The elementClass to set.

getKeyClass

public Class getKeyClass()
Returns:
Returns the keyClass.

setKeyClass

public void setKeyClass(Class keyClass)
Parameters:
keyClass - The keyClass to set.

getKeyProperty

public String getKeyProperty()
Returns:
Returns the keyProperty.

setKeyProperty

public void setKeyProperty(String keyProperty)
Parameters:
keyProperty - The keyProperty to set.

isShouldCreateIfNew

public boolean isShouldCreateIfNew()
Returns:
Returns the shouldCreateIfNew.

setShouldCreateIfNew

public void setShouldCreateIfNew(boolean shouldCreateIfNew)
Parameters:
shouldCreateIfNew - The shouldCreateIfNew to set.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MockResult (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.mock
Class MockResult

java.lang.Object
    extended by  com.opensymphony.xwork2.mock.MockResult
All Implemented Interfaces:
Result, Serializable
public class MockResult
extends Object
implements Result

Mock for a Result.

Author:
Mike, Rainer Hermanns
See Also:
Serialized Form

Constructor Summary
MockResult()
Method Summary
boolean | equals(Object o)
void | execute(ActionInvocation invocation) Represents a generic interface for all action execution results.
int | hashCode()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MockResult

public MockResult()
Method Detail

equals

public boolean equals(Object o)
Overrides:
equals in class Object

execute

public void execute(ActionInvocation invocation)
             throws Exception
Description copied from interface: Result
Represents a generic interface for all action execution results. Whether that be displaying a webpage, generating an email, sending a JMS message, etc.

Specified by:
execute in interface Result
Parameters:
invocation - the invocation context.
Throws:
Exception - can be thrown.

hashCode

public int hashCode()
Overrides:
hashCode in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.mock (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.mock
Classes
MockActionInvocation
MockActionProxy
MockInterceptor
MockObjectTypeDeterminer
MockResult


com.opensymphony.xwork2.mock (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.mock

XWork specific mock classes.

See:
Description

Class Summary
MockActionInvocation | Mock for an ActionInvocation.
MockActionProxy | Mock for an ActionProxy.
MockInterceptor | Mock for an Interceptor.
MockObjectTypeDeterminer | Mocks the function of an ObjectTypeDeterminer for testing purposes.
MockResult | Mock for a Result.

Package com.opensymphony.xwork2.mock Description

XWork specific mock classes.


com.opensymphony.xwork2.mock Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.mock

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.mock.MockActionInvocation (implements com.opensymphony.xwork2.ActionInvocation)
    • com.opensymphony.xwork2.mock.MockActionProxy (implements com.opensymphony.xwork2.ActionProxy)
    • com.opensymphony.xwork2.mock.MockInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
    • com.opensymphony.xwork2.mock.MockObjectTypeDeterminer (implements com.opensymphony.xwork2.conversion.ObjectTypeDeterminer)
    • com.opensymphony.xwork2.mock.MockResult (implements com.opensymphony.xwork2.Result)


Uses of Package com.opensymphony.xwork2.mock (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.mock

Packages that use com.opensymphony.xwork2.mock
com.opensymphony.xwork2 Main XWork interfaces and classes.

Classes in com.opensymphony.xwork2.mock used by com.opensymphony.xwork2
MockActionInvocation
Mock for an ActionInvocation.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.mock.MockActionInvocation (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.mock.MockActionInvocation

Packages that use MockActionInvocation
com.opensymphony.xwork2 Main XWork interfaces and classes.

Uses of MockActionInvocation in com.opensymphony.xwork2

Subclasses of MockActionInvocation in com.opensymphony.xwork2
 class MockActionInvocation
Deprecated. Please use @see com.opensymphony.xwork2.mock.MockActionInvocation instead

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.mock.MockActionProxy (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.mock.MockActionProxy

No usage of com.opensymphony.xwork2.mock.MockActionProxy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.mock.MockInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.mock.MockInterceptor

No usage of com.opensymphony.xwork2.mock.MockInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

No usage of com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.mock.MockResult (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.mock.MockResult

No usage of com.opensymphony.xwork2.mock.MockResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ObjectProxy (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl
Class ObjectProxy

java.lang.Object
    extended by  com.opensymphony.xwork2.ognl.ObjectProxy

public class ObjectProxy
extends Object

An Object to use within OGNL to proxy other Objects usually Collections that you set in a different place on the ValueStack but want to retain the context information about where they previously were.

Author:
Gabe

Constructor Summary
ObjectProxy()
Method Summary
Class | getLastClassAccessed()
String | getLastPropertyAccessed()
Object | getValue()
void | setLastClassAccessed(Class lastClassAccessed)
void | setLastPropertyAccessed(String lastPropertyAccessed)
void | setValue(Object value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ObjectProxy

public ObjectProxy()
Method Detail

getLastClassAccessed

public Class getLastClassAccessed()

setLastClassAccessed

public void setLastClassAccessed(Class lastClassAccessed)

getLastPropertyAccessed

public String getLastPropertyAccessed()

setLastPropertyAccessed

public void setLastPropertyAccessed(String lastPropertyAccessed)

getValue

public Object getValue()

setValue

public void setValue(Object value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


OgnlNullHandlerWrapper (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl
Class OgnlNullHandlerWrapper

java.lang.Object
    extended by  com.opensymphony.xwork2.ognl.OgnlNullHandlerWrapper
All Implemented Interfaces:
ognl.NullHandler
public class OgnlNullHandlerWrapper
extends Object
implements ognl.NullHandler

Constructor Summary
OgnlNullHandlerWrapper(NullHandler target)
Method Summary
Object | nullMethodResult(Map context, Object target, String methodName, Object[] args)
Object | nullPropertyValue(Map context, Object target, Object property)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OgnlNullHandlerWrapper

public OgnlNullHandlerWrapper(NullHandler target)
Method Detail

nullMethodResult

public Object nullMethodResult(Map context,
                               Object target,
                               String methodName,
                               Object[] args)
Specified by:
nullMethodResult in interface ognl.NullHandler

nullPropertyValue

public Object nullPropertyValue(Map context,
                                Object target,
                                Object property)
Specified by:
nullPropertyValue in interface ognl.NullHandler
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OgnlReflectionContextFactory (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl
Class OgnlReflectionContextFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.ognl.OgnlReflectionContextFactory
All Implemented Interfaces:
ReflectionContextFactory
public class OgnlReflectionContextFactory
extends Object
implements ReflectionContextFactory

Constructor Summary
OgnlReflectionContextFactory()
Method Summary
 Map createDefaultContext(Object root)
Creates and returns a new standard naming context for evaluating an OGNL expression.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OgnlReflectionContextFactory

public OgnlReflectionContextFactory()
Method Detail

createDefaultContext

public Map createDefaultContext(Object root)
Description copied from interface: ReflectionContextFactory
Creates and returns a new standard naming context for evaluating an OGNL expression.

Specified by:
createDefaultContext in interface ReflectionContextFactory
Parameters:
root - the root of the object graph
Returns:
a new Map with the keys root and context set appropriately
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OgnlReflectionProvider (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl
Class OgnlReflectionProvider

java.lang.Object
    extended by  com.opensymphony.xwork2.ognl.OgnlReflectionProvider
All Implemented Interfaces:
ReflectionProvider
public class OgnlReflectionProvider
extends Object
implements ReflectionProvider

Constructor Summary
OgnlReflectionProvider()
Method Summary
 void copy(Object from, Object to, Map<String,Object> context, Collection<String> exclusions, Collection<String> inclusions)
Copies the properties in the object "from" and sets them in the object "to" using specified type converter, or XWorkConverter if none is specified.
 Map getBeanMap(Object source)
Creates a Map with read properties for the given source object.
 Field getField(Class inClass, String name)
 Method getGetMethod(Class targetClass, String propertyName)
 PropertyDescriptor getPropertyDescriptor(Class targetClass, String propertyName)
This method returns a PropertyDescriptor for the given class and property name using a Map lookup (using getPropertyDescriptorsMap()).
 PropertyDescriptor[] getPropertyDescriptors(Object source)
Get's the java beans property descriptors for the given source.
 Object getRealTarget(String property, Map<String,Object> context, Object root)
Looks for the real target with the specified property given a root Object which may be a CompoundRoot.
 Method getSetMethod(Class targetClass, String propertyName)
 Object getValue(String expression, Map<String,Object> context, Object root)
Evaluates the given OGNL expression to extract a value from the given root object in a given context
 void setOgnlUtil(OgnlUtil ognlUtil)
 void setProperties(Map<String,String> properties, Object o)
Sets the properties on the object using the default context, defaulting to not throwing exceptions for problems setting the properties.
 void setProperties(Map<String,String> props, Object o, Map<String,Object> context)
Sets the object's properties using the default type converter, defaulting to not throw exceptions for problems setting the properties.
 void setProperties(Map<String,String> props, Object o, Map<String,Object> context, boolean throwPropertyExceptions)
Sets the object's properties using the default type converter.
 void setProperty(String name, Object value, Object o, Map<String,Object> context)
Sets the named property to the supplied value on the Object, defaults to not throwing property exceptions.
 void setProperty(String name, Object value, Object o, Map<String,Object> context, boolean throwPropertyExceptions)
Sets the named property to the supplied value on the Object,
 void setValue(String expression, Map<String,Object> context, Object root, Object value)
Evaluates the given OGNL expression to insert a value into the object graph rooted at the given root object given the context.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OgnlReflectionProvider

public OgnlReflectionProvider()
Method Detail

setOgnlUtil

public void setOgnlUtil(OgnlUtil ognlUtil)

getField

public Field getField(Class inClass,
                      String name)
Specified by:
getField in interface ReflectionProvider

getGetMethod

public Method getGetMethod(Class targetClass,
                           String propertyName)
                    throws IntrospectionException,
                           ReflectionException
Specified by:
getGetMethod in interface ReflectionProvider
Throws:
IntrospectionException
ReflectionException

getSetMethod

public Method getSetMethod(Class targetClass,
                           String propertyName)
                    throws IntrospectionException,
                           ReflectionException
Specified by:
getSetMethod in interface ReflectionProvider
Throws:
IntrospectionException
ReflectionException

setProperties

public void setProperties(Map<String,String> props,
                          Object o,
                          Map<String,Object> context)
Description copied from interface: ReflectionProvider
Sets the object's properties using the default type converter, defaulting to not throw exceptions for problems setting the properties.

Specified by:
setProperties in interface ReflectionProvider
Parameters:
props - the properties being set
o - the object
context - the action context

setProperties

public void setProperties(Map<String,String> props,
                          Object o,
                          Map<String,Object> context,
                          boolean throwPropertyExceptions)
                   throws ReflectionException
Description copied from interface: ReflectionProvider
Sets the object's properties using the default type converter.

Specified by:
setProperties in interface ReflectionProvider
Parameters:
props - the properties being set
o - the object
context - the action context
throwPropertyExceptions - boolean which tells whether it should throw exceptions for problems setting the properties
Throws:
ReflectionException

setProperties

public void setProperties(Map<String,String> properties,
                          Object o)
Description copied from interface: ReflectionProvider
Sets the properties on the object using the default context, defaulting to not throwing exceptions for problems setting the properties.

Specified by:
setProperties in interface ReflectionProvider

getPropertyDescriptor

public PropertyDescriptor getPropertyDescriptor(Class targetClass,
                                                String propertyName)
                                         throws IntrospectionException,
                                                ReflectionException
Description copied from interface: ReflectionProvider
This method returns a PropertyDescriptor for the given class and property name using a Map lookup (using getPropertyDescriptorsMap()).

Specified by:
getPropertyDescriptor in interface ReflectionProvider
Throws:
IntrospectionException
ReflectionException

copy

public void copy(Object from,
                 Object to,
                 Map<String,Object> context,
                 Collection<String> exclusions,
                 Collection<String> inclusions)
Description copied from interface: ReflectionProvider
Copies the properties in the object "from" and sets them in the object "to" using specified type converter, or XWorkConverter if none is specified.

Specified by:
copy in interface ReflectionProvider
Parameters:
from - the source object
to - the target object
context - the action context we're running under
exclusions - collection of method names to excluded from copying ( can be null)
inclusions - collection of method names to included copying (can be null) note if exclusions AND inclusions are supplied and not null nothing will get copied.

getRealTarget

public Object getRealTarget(String property,
                            Map<String,Object> context,
                            Object root)
                     throws ReflectionException
Description copied from interface: ReflectionProvider
Looks for the real target with the specified property given a root Object which may be a CompoundRoot.

Specified by:
getRealTarget in interface ReflectionProvider
Returns:
the real target or null if no object can be found with the specified property
Throws:
ReflectionException

setProperty

public void setProperty(String name,
                        Object value,
                        Object o,
                        Map<String,Object> context)
Description copied from interface: ReflectionProvider
Sets the named property to the supplied value on the Object, defaults to not throwing property exceptions.

Specified by:
setProperty in interface ReflectionProvider
Parameters:
name - the name of the property to be set
value - the value to set into the named property
o - the object upon which to set the property
context - the context which may include the TypeConverter

setProperty

public void setProperty(String name,
                        Object value,
                        Object o,
                        Map<String,Object> context,
                        boolean throwPropertyExceptions)
Description copied from interface: ReflectionProvider
Sets the named property to the supplied value on the Object,

Specified by:
setProperty in interface ReflectionProvider
Parameters:
name - the name of the property to be set
value - the value to set into the named property
o - the object upon which to set the property
context - the context which may include the TypeConverter
throwPropertyExceptions - boolean which tells whether it should throw exceptions for problems setting the properties

getBeanMap

public Map getBeanMap(Object source)
               throws IntrospectionException,
                      ReflectionException
Description copied from interface: ReflectionProvider
Creates a Map with read properties for the given source object.

If the source object does not have a read property (i.e. write-only) then the property is added to the map with the value here is no read method for property-name.

Specified by:
getBeanMap in interface ReflectionProvider
Parameters:
source - the source object.
Returns:
a Map with (key = read property name, value = value of read property).
Throws:
IntrospectionException - is thrown if an exception occurs during introspection.
ReflectionException

getValue

public Object getValue(String expression,
                       Map<String,Object> context,
                       Object root)
                throws ReflectionException
Description copied from interface: ReflectionProvider
Evaluates the given OGNL expression to extract a value from the given root object in a given context

Specified by:
getValue in interface ReflectionProvider
Parameters:
expression - the OGNL expression to be parsed
context - the naming context for the evaluation
root - the root object for the OGNL expression
Returns:
the result of evaluating the expression
Throws:
ReflectionException

setValue

public void setValue(String expression,
                     Map<String,Object> context,
                     Object root,
                     Object value)
              throws ReflectionException
Description copied from interface: ReflectionProvider
Evaluates the given OGNL expression to insert a value into the object graph rooted at the given root object given the context.

Specified by:
setValue in interface ReflectionProvider
Parameters:
expression - the OGNL expression to be parsed
context - the naming context for the evaluation
root - the root object for the OGNL expression
value - the value to insert into the object graph
Throws:
ReflectionException

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors(Object source)
                                            throws IntrospectionException
Description copied from interface: ReflectionProvider
Get's the java beans property descriptors for the given source.

Specified by:
getPropertyDescriptors in interface ReflectionProvider
Parameters:
source - the source object.
Returns:
property descriptors.
Throws:
IntrospectionException - is thrown if an exception occurs during introspection.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OgnlTypeConverterWrapper (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl
Class OgnlTypeConverterWrapper

java.lang.Object
    extended by  com.opensymphony.xwork2.ognl.OgnlTypeConverterWrapper
All Implemented Interfaces:
ognl.TypeConverter
public class OgnlTypeConverterWrapper
extends Object
implements ognl.TypeConverter

Wraps an XWork type conversion class for as an OGNL TypeConverter

Constructor Summary
OgnlTypeConverterWrapper(TypeConverter conv)
Method Summary
Object | convertValue(Map context, Object target, Member member, String propertyName, Object value, Class toType)
TypeConverter | getTarget()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OgnlTypeConverterWrapper

public OgnlTypeConverterWrapper(TypeConverter conv)
Method Detail

convertValue

public Object convertValue(Map context,
                           Object target,
                           Member member,
                           String propertyName,
                           Object value,
                           Class toType)
Specified by:
convertValue in interface ognl.TypeConverter

getTarget

public TypeConverter getTarget()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OgnlUtil (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl
Class OgnlUtil

java.lang.Object
    extended by  com.opensymphony.xwork2.ognl.OgnlUtil

public class OgnlUtil
extends Object

Utility class that provides common access to the Ognl APIs for setting and getting properties from objects (usually Actions).

Author:
Jason Carreira

Constructor Summary
OgnlUtil()
Method Summary
 Object compile(String expression)
 void copy(Object from, Object to, Map<String,Object> context)
Copies the properties in the object "from" and sets them in the object "to" using specified type converter, or XWorkConverter if none is specified.
 void copy(Object from, Object to, Map<String,Object> context, Collection<String> exclusions, Collection<String> inclusions)
Copies the properties in the object "from" and sets them in the object "to" using specified type converter, or XWorkConverter if none is specified.
 BeanInfo getBeanInfo(Class clazz)
Get's the java bean info for the given source.
 BeanInfo getBeanInfo(Object from)
Get's the java bean info for the given source object.
 Map getBeanMap(Object source)
Creates a Map with read properties for the given source object.
 PropertyDescriptor[] getPropertyDescriptors(Class clazz)
Get's the java beans property descriptors for the given class.
 PropertyDescriptor[] getPropertyDescriptors(Object source)
Get's the java beans property descriptors for the given source.
 Object getRealTarget(String property, Map<String,Object> context, Object root)
Looks for the real target with the specified property given a root Object which may be a CompoundRoot.
 Object getValue(String name, Map<String,Object> context, Object root)
 Object getValue(String name, Map<String,Object> context, Object root, Class resultType)
static void setDevMode(String mode)
static void setEnableExpressionCache(String cache)
 void setProperties(Map<String,?> properties, Object o)
Sets the properties on the object using the default context, defaulting to not throwing exceptions for problems setting the properties.
 void setProperties(Map<String,?> properties, Object o, boolean throwPropertyExceptions)
Sets the properties on the object using the default context.
 void setProperties(Map<String,?> props, Object o, Map<String,Object> context)
Sets the object's properties using the default type converter, defaulting to not throw exceptions for problems setting the properties.
 void setProperties(Map<String,?> props, Object o, Map<String,Object> context, boolean throwPropertyExceptions)
Sets the object's properties using the default type converter.
 void setProperty(String name, Object value, Object o, Map<String,Object> context)
Sets the named property to the supplied value on the Object, defaults to not throwing property exceptions.
 void setProperty(String name, Object value, Object o, Map<String,Object> context, boolean throwPropertyExceptions)
Sets the named property to the supplied value on the Object.
 void setValue(String name, Map<String,Object> context, Object root, Object value)
Wrapper around Ognl.setValue() to handle type conversion for collection elements.
 void setXWorkConverter(XWorkConverter conv)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OgnlUtil

public OgnlUtil()
Method Detail

setXWorkConverter

public void setXWorkConverter(XWorkConverter conv)

setDevMode

public static void setDevMode(String mode)

setEnableExpressionCache

public static void setEnableExpressionCache(String cache)

setProperties

public void setProperties(Map<String,?> props,
                          Object o,
                          Map<String,Object> context)
Sets the object's properties using the default type converter, defaulting to not throw exceptions for problems setting the properties.

Parameters:
props - the properties being set
o - the object
context - the action context

setProperties

public void setProperties(Map<String,?> props,
                          Object o,
                          Map<String,Object> context,
                          boolean throwPropertyExceptions)
                   throws ReflectionException
Sets the object's properties using the default type converter.

Parameters:
props - the properties being set
o - the object
context - the action context
throwPropertyExceptions - boolean which tells whether it should throw exceptions for problems setting the properties
Throws:
ReflectionException

setProperties

public void setProperties(Map<String,?> properties,
                          Object o)
Sets the properties on the object using the default context, defaulting to not throwing exceptions for problems setting the properties.

Parameters:
properties -
o -

setProperties

public void setProperties(Map<String,?> properties,
                          Object o,
                          boolean throwPropertyExceptions)
Sets the properties on the object using the default context.

Parameters:
properties - the property map to set on the object
o - the object to set the properties into
throwPropertyExceptions - boolean which tells whether it should throw exceptions for problems setting the properties

setProperty

public void setProperty(String name,
                        Object value,
                        Object o,
                        Map<String,Object> context)
Sets the named property to the supplied value on the Object, defaults to not throwing property exceptions.

Parameters:
name - the name of the property to be set
value - the value to set into the named property
o - the object upon which to set the property
context - the context which may include the TypeConverter

setProperty

public void setProperty(String name,
                        Object value,
                        Object o,
                        Map<String,Object> context,
                        boolean throwPropertyExceptions)
Sets the named property to the supplied value on the Object.

Parameters:
name - the name of the property to be set
value - the value to set into the named property
o - the object upon which to set the property
context - the context which may include the TypeConverter
throwPropertyExceptions - boolean which tells whether it should throw exceptions for problems setting the property

getRealTarget

public Object getRealTarget(String property,
                            Map<String,Object> context,
                            Object root)
                     throws ognl.OgnlException
Looks for the real target with the specified property given a root Object which may be a CompoundRoot.

Returns:
the real target or null if no object can be found with the specified property
Throws:
ognl.OgnlException

setValue

public void setValue(String name,
                     Map<String,Object> context,
                     Object root,
                     Object value)
              throws ognl.OgnlException
Wrapper around Ognl.setValue() to handle type conversion for collection elements. Ideally, this should be handled by OGNL directly.

Throws:
ognl.OgnlException

getValue

public Object getValue(String name,
                       Map<String,Object> context,
                       Object root)
                throws ognl.OgnlException
Throws:
ognl.OgnlException

getValue

public Object getValue(String name,
                       Map<String,Object> context,
                       Object root,
                       Class resultType)
                throws ognl.OgnlException
Throws:
ognl.OgnlException

compile

public Object compile(String expression)
               throws ognl.OgnlException
Throws:
ognl.OgnlException

copy

public void copy(Object from,
                 Object to,
                 Map<String,Object> context,
                 Collection<String> exclusions,
                 Collection<String> inclusions)
Copies the properties in the object "from" and sets them in the object "to" using specified type converter, or XWorkConverter if none is specified.

Parameters:
from - the source object
to - the target object
context - the action context we're running under
exclusions - collection of method names to excluded from copying ( can be null)
inclusions - collection of method names to included copying (can be null) note if exclusions AND inclusions are supplied and not null nothing will get copied.

copy

public void copy(Object from,
                 Object to,
                 Map<String,Object> context)
Copies the properties in the object "from" and sets them in the object "to" using specified type converter, or XWorkConverter if none is specified.

Parameters:
from - the source object
to - the target object
context - the action context we're running under

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors(Object source)
                                            throws IntrospectionException
Get's the java beans property descriptors for the given source.

Parameters:
source - the source object.
Returns:
property descriptors.
Throws:
IntrospectionException - is thrown if an exception occurs during introspection.

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors(Class clazz)
                                            throws IntrospectionException
Get's the java beans property descriptors for the given class.

Parameters:
clazz - the source object.
Returns:
property descriptors.
Throws:
IntrospectionException - is thrown if an exception occurs during introspection.

getBeanMap

public Map getBeanMap(Object source)
               throws IntrospectionException,
                      ognl.OgnlException
Creates a Map with read properties for the given source object.

If the source object does not have a read property (i.e. write-only) then the property is added to the map with the value here is no read method for property-name.

Parameters:
source - the source object.
Returns:
a Map with (key = read property name, value = value of read property).
Throws:
IntrospectionException - is thrown if an exception occurs during introspection.
ognl.OgnlException - is thrown by OGNL if the property value could not be retrieved

getBeanInfo

public BeanInfo getBeanInfo(Object from)
                     throws IntrospectionException
Get's the java bean info for the given source object. Calls getBeanInfo(Class c).

Parameters:
from - the source object.
Returns:
java bean info.
Throws:
IntrospectionException - is thrown if an exception occurs during introspection.

getBeanInfo

public BeanInfo getBeanInfo(Class clazz)
                     throws IntrospectionException
Get's the java bean info for the given source.

Parameters:
clazz - the source class.
Returns:
java bean info.
Throws:
IntrospectionException - is thrown if an exception occurs during introspection.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OgnlValueStack (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl
Class OgnlValueStack

java.lang.Object
    extended by  com.opensymphony.xwork2.ognl.OgnlValueStack
All Implemented Interfaces:
ClearableValueStack, MemberAccessValueStack, ValueStack, Serializable
public class OgnlValueStack
extends Object
implements Serializable, ValueStack, ClearableValueStack, MemberAccessValueStack

Ognl implementation of a value stack that allows for dynamic Ognl expressions to be evaluated against it. When evaluating an expression, the stack will be searched down the stack, from the latest objects pushed in to the earliest, looking for a bean with a getter or setter for the given property or a method of the given name (depending on the expression being evaluated).

Version:
$Date: 2009-05-28 16:34:27 +0200 (Do, 28 Mai 2009) $ $Id: OgnlValueStack.java 1995 2009-05-28 14:34:27Z rainerh $
Author:
Patrick Lightbody, tm_jee
See Also:
Serialized Form

Field Summary
Fields inherited from interface com.opensymphony.xwork2.util.ValueStack
REPORT_ERRORS_ON_NO_PROP, VALUE_STACK
Constructor Summary
protected | OgnlValueStack(ValueStack vs, XWorkConverter xworkConverter, CompoundRootAccessor accessor, boolean allowStaticAccess)
protected | OgnlValueStack(XWorkConverter xworkConverter, CompoundRootAccessor accessor, TextProvider prov, boolean allowStaticAccess)
Method Summary
 void clearContextValues()
Remove all values from the context
 String findString(String expr)
 String findString(String expr, boolean throwExceptionOnFailure)
 Object findValue(String expr)
Find a value by evaluating the given expression against the stack in the default search order.
 Object findValue(String expr, boolean throwExceptionOnFailure)
 Object findValue(String expr, Class asType)
Find a value by evaluating the given expression against the stack in the default search order.
 Object findValue(String expr, Class asType, boolean throwExceptionOnFailure)
 Map<String,Object> getContext()
Gets the context for this value stack.
 Map<Object,Object> getExprOverrides()
Gets the override map if anyone exists.
 CompoundRoot getRoot()
Get the CompoundRoot which holds the objects pushed onto the stack
static void link(Map<String,Object> context, Class clazz, String name)
 Object peek()
Get the object on the top of the stack without changing the stack.
 Object pop()
Get the object on the top of the stack and remove it from the stack.
 void push(Object o)
Put this object onto the top of the stack
 void set(String key, Object o)
Sets an object on the stack with the given key so it is retrievable by ValueStack.findValue(String), ValueStack.findValue(String, Class)
 void setAcceptProperties(Set<Pattern> acceptedProperties)
 void setDefaultType(Class defaultType)
Sets the default type to convert to if no type is provided when getting a value.
 void setDevMode(String mode)
 void setExcludeProperties(Set<Pattern> excludeProperties)
 void setExprOverrides(Map<Object,Object> overrides)
Set a override map containing key -> values that takes precedent when doing find operations on the ValueStack.
 void setLogMissingProperties(String logMissingProperties)
 void setOgnlUtil(OgnlUtil ognlUtil)
protected  void setRoot(XWorkConverter xworkConverter, CompoundRootAccessor accessor, CompoundRoot compoundRoot, boolean allowStaticMethodAccess)
 void setValue(String expr, Object value)
Attempts to set a property on a bean in the stack with the given expression using the default search order.
 void setValue(String expr, Object value, boolean throwExceptionOnFailure)
Attempts to set a property on a bean in the stack with the given expression using the default search order.
 int size()
Get the number of objects in the stack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OgnlValueStack

protected OgnlValueStack(XWorkConverter xworkConverter,
                         CompoundRootAccessor accessor,
                         TextProvider prov,
                         boolean allowStaticAccess)

OgnlValueStack

protected OgnlValueStack(ValueStack vs,
                         XWorkConverter xworkConverter,
                         CompoundRootAccessor accessor,
                         boolean allowStaticAccess)
Method Detail

link

public static void link(Map<String,Object> context,
                        Class clazz,
                        String name)

setOgnlUtil

public void setOgnlUtil(OgnlUtil ognlUtil)

setRoot

protected void setRoot(XWorkConverter xworkConverter,
                       CompoundRootAccessor accessor,
                       CompoundRoot compoundRoot,
                       boolean allowStaticMethodAccess)

setDevMode

public void setDevMode(String mode)

setLogMissingProperties

public void setLogMissingProperties(String logMissingProperties)

getContext

public Map<String,Object> getContext()
Description copied from interface: ValueStack
Gets the context for this value stack. The context holds all the information in the value stack and it's surroundings.

Specified by:
getContext in interface ValueStack
Returns:
the context.

setDefaultType

public void setDefaultType(Class defaultType)
Description copied from interface: ValueStack
Sets the default type to convert to if no type is provided when getting a value.

Specified by:
setDefaultType in interface ValueStack
Parameters:
defaultType - the new default type

setExprOverrides

public void setExprOverrides(Map<Object,Object> overrides)
Description copied from interface: ValueStack
Set a override map containing key -> values that takes precedent when doing find operations on the ValueStack.

See the unit test for ValueStackTest for examples.

Specified by:
setExprOverrides in interface ValueStack
Parameters:
overrides - overrides map.

getExprOverrides

public Map<Object,Object> getExprOverrides()
Description copied from interface: ValueStack
Gets the override map if anyone exists.

Specified by:
getExprOverrides in interface ValueStack
Returns:
the override map, null if not set.

getRoot

public CompoundRoot getRoot()
Description copied from interface: ValueStack
Get the CompoundRoot which holds the objects pushed onto the stack

Specified by:
getRoot in interface ValueStack
Returns:
the root

setValue

public void setValue(String expr,
                     Object value)
Description copied from interface: ValueStack
Attempts to set a property on a bean in the stack with the given expression using the default search order.

Specified by:
setValue in interface ValueStack
Parameters:
expr - the expression defining the path to the property to be set.
value - the value to be set into the named property

setValue

public void setValue(String expr,
                     Object value,
                     boolean throwExceptionOnFailure)
Description copied from interface: ValueStack
Attempts to set a property on a bean in the stack with the given expression using the default search order.

Specified by:
setValue in interface ValueStack
Parameters:
expr - the expression defining the path to the property to be set.
value - the value to be set into the named property
throwExceptionOnFailure - a flag to tell whether an exception should be thrown if there is no property with the given name.

findString

public String findString(String expr)
Specified by:
findString in interface ValueStack

findString

public String findString(String expr,
                         boolean throwExceptionOnFailure)
Specified by:
findString in interface ValueStack

findValue

public Object findValue(String expr,
                        boolean throwExceptionOnFailure)
Specified by:
findValue in interface ValueStack

findValue

public Object findValue(String expr)
Description copied from interface: ValueStack
Find a value by evaluating the given expression against the stack in the default search order.

Specified by:
findValue in interface ValueStack
Parameters:
expr - the expression giving the path of properties to navigate to find the property value to return
Returns:
the result of evaluating the expression

findValue

public Object findValue(String expr,
                        Class asType,
                        boolean throwExceptionOnFailure)
Specified by:
findValue in interface ValueStack

findValue

public Object findValue(String expr,
                        Class asType)
Description copied from interface: ValueStack
Find a value by evaluating the given expression against the stack in the default search order.

Specified by:
findValue in interface ValueStack
Parameters:
expr - the expression giving the path of properties to navigate to find the property value to return
asType - the type to convert the return value to
Returns:
the result of evaluating the expression

peek

public Object peek()
Description copied from interface: ValueStack
Get the object on the top of the stack without changing the stack.

Specified by:
peek in interface ValueStack
Returns:
the object on the top.
See Also:
CompoundRoot.peek()

pop

public Object pop()
Description copied from interface: ValueStack
Get the object on the top of the stack and remove it from the stack.

Specified by:
pop in interface ValueStack
Returns:
the object on the top of the stack
See Also:
CompoundRoot.pop()

push

public void push(Object o)
Description copied from interface: ValueStack
Put this object onto the top of the stack

Specified by:
push in interface ValueStack
Parameters:
o - the object to be pushed onto the stack
See Also:
CompoundRoot.push(Object)

set

public void set(String key,
                Object o)
Description copied from interface: ValueStack
Sets an object on the stack with the given key so it is retrievable by ValueStack.findValue(String), ValueStack.findValue(String, Class)

Specified by:
set in interface ValueStack
Parameters:
key - the key
o - the object

size

public int size()
Description copied from interface: ValueStack
Get the number of objects in the stack

Specified by:
size in interface ValueStack
Returns:
the number of objects in the stack

clearContextValues

public void clearContextValues()
Description copied from interface: ClearableValueStack
Remove all values from the context

Specified by:
clearContextValues in interface ClearableValueStack

setAcceptProperties

public void setAcceptProperties(Set<Pattern> acceptedProperties)
Specified by:
setAcceptProperties in interface MemberAccessValueStack

setExcludeProperties

public void setExcludeProperties(Set<Pattern> excludeProperties)
Specified by:
setExcludeProperties in interface MemberAccessValueStack
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OgnlValueStackFactory (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl
Class OgnlValueStackFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.ognl.OgnlValueStackFactory
All Implemented Interfaces:
ValueStackFactory
public class OgnlValueStackFactory
extends Object
implements ValueStackFactory

Creates an Ognl value stack

Constructor Summary
OgnlValueStackFactory()
Method Summary
ValueStack | createValueStack() Get a new instance of ValueStack
ValueStack | createValueStack(ValueStack stack) Get a new instance of ValueStack
void | setAllowStaticMethodAccess(String allowStaticMethodAccess)
void | setContainer(Container container)
void | setTextProvider(TextProvider textProvider)
void | setXWorkConverter(XWorkConverter conv)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OgnlValueStackFactory

public OgnlValueStackFactory()
Method Detail

setXWorkConverter

public void setXWorkConverter(XWorkConverter conv)

setTextProvider

public void setTextProvider(TextProvider textProvider)

setAllowStaticMethodAccess

public void setAllowStaticMethodAccess(String allowStaticMethodAccess)

createValueStack

public ValueStack createValueStack()
Description copied from interface: ValueStackFactory
Get a new instance of ValueStack

Specified by:
createValueStack in interface ValueStackFactory
Returns:
a new ValueStack.

createValueStack

public ValueStack createValueStack(ValueStack stack)
Description copied from interface: ValueStackFactory
Get a new instance of ValueStack

Specified by:
createValueStack in interface ValueStackFactory
Parameters:
stack - an existing stack to include.
Returns:
a new ValueStack.

setContainer

public void setContainer(Container container)
                  throws ClassNotFoundException
Throws:
ClassNotFoundException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.ognl (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.ognl
Classes
ObjectProxy
OgnlNullHandlerWrapper
OgnlReflectionContextFactory
OgnlReflectionProvider
OgnlTypeConverterWrapper
OgnlUtil
OgnlValueStack
OgnlValueStackFactory
SecurityMemberAccess
XWorkTypeConverterWrapper


com.opensymphony.xwork2.ognl (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.ognl

Class Summary
ObjectProxy | An Object to use within OGNL to proxy other Objects usually Collections that you set in a different place on the ValueStack but want to retain the context information about where they previously were.
OgnlNullHandlerWrapper |
OgnlReflectionContextFactory |
OgnlReflectionProvider |
OgnlTypeConverterWrapper | Wraps an XWork type conversion class for as an OGNL TypeConverter
OgnlUtil | Utility class that provides common access to the Ognl APIs for setting and getting properties from objects (usually Actions).
OgnlValueStack | Ognl implementation of a value stack that allows for dynamic Ognl expressions to be evaluated against it.
OgnlValueStackFactory | Creates an Ognl value stack
SecurityMemberAccess | Allows access decisions to be made on the basis of whether a member is static or not.
XWorkTypeConverterWrapper | Wraps an OGNL TypeConverter as an XWork TypeConverter


com.opensymphony.xwork2.ognl Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.ognl

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • ognl.DefaultMemberAccess (implements ognl.MemberAccess)
      • com.opensymphony.xwork2.ognl.SecurityMemberAccess
    • com.opensymphony.xwork2.ognl.ObjectProxy
    • com.opensymphony.xwork2.ognl.OgnlNullHandlerWrapper (implements ognl.NullHandler)
    • com.opensymphony.xwork2.ognl.OgnlReflectionContextFactory (implements com.opensymphony.xwork2.util.reflection.ReflectionContextFactory)
    • com.opensymphony.xwork2.ognl.OgnlReflectionProvider (implements com.opensymphony.xwork2.util.reflection.ReflectionProvider)
    • com.opensymphony.xwork2.ognl.OgnlTypeConverterWrapper (implements ognl.TypeConverter)
    • com.opensymphony.xwork2.ognl.OgnlUtil
    • com.opensymphony.xwork2.ognl.OgnlValueStack (implements com.opensymphony.xwork2.util.ClearableValueStack, com.opensymphony.xwork2.util.MemberAccessValueStack, java.io.Serializable, com.opensymphony.xwork2.util.ValueStack)
    • com.opensymphony.xwork2.ognl.OgnlValueStackFactory (implements com.opensymphony.xwork2.util.ValueStackFactory)
    • com.opensymphony.xwork2.ognl.XWorkTypeConverterWrapper (implements com.opensymphony.xwork2.conversion.TypeConverter)


Uses of Package com.opensymphony.xwork2.ognl (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.ognl

Packages that use com.opensymphony.xwork2.ognl
com.opensymphony.xwork2.ognl
com.opensymphony.xwork2.ognl.accessor

Classes in com.opensymphony.xwork2.ognl used by com.opensymphony.xwork2.ognl
OgnlUtil
Utility class that provides common access to the Ognl APIs for setting and getting properties from objects (usually Actions).

Classes in com.opensymphony.xwork2.ognl used by com.opensymphony.xwork2.ognl.accessor
OgnlUtil
Utility class that provides common access to the Ognl APIs for setting and getting properties from objects (usually Actions).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


SecurityMemberAccess (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl
Class SecurityMemberAccess

java.lang.Object
    extended by  ognl.DefaultMemberAccess
        extended by  com.opensymphony.xwork2.ognl.SecurityMemberAccess
All Implemented Interfaces:
ognl.MemberAccess
public class SecurityMemberAccess
extends ognl.DefaultMemberAccess

Allows access decisions to be made on the basis of whether a member is static or not. Also blocks or allows access to properties.

Field Summary
Fields inherited from class ognl.DefaultMemberAccess
allowPackageProtectedAccess, allowPrivateAccess, allowProtectedAccess
Constructor Summary
SecurityMemberAccess(boolean method)
Method Summary
boolean | getAllowStaticMethodAccess()
protected boolean | isAcceptableProperty(String name)
protected boolean | isAccepted(String paramName)
boolean | isAccessible(Map context, Object target, Member member, String propertyName)
protected boolean | isExcluded(String paramName)
void | setAcceptProperties(Set<Pattern> acceptedProperties)
void | setAllowStaticMethodAccess(boolean allowStaticMethodAccess)
void | setExcludeProperties(Set<Pattern> excludeProperties)
Methods inherited from class ognl.DefaultMemberAccess
getAllowPackageProtectedAccess, getAllowPrivateAccess, getAllowProtectedAccess, restore, setAllowPackageProtectedAccess, setAllowPrivateAccess, setAllowProtectedAccess, setup
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SecurityMemberAccess

public SecurityMemberAccess(boolean method)
Method Detail

getAllowStaticMethodAccess

public boolean getAllowStaticMethodAccess()

setAllowStaticMethodAccess

public void setAllowStaticMethodAccess(boolean allowStaticMethodAccess)

isAccessible

public boolean isAccessible(Map context,
                            Object target,
                            Member member,
                            String propertyName)
Specified by:
isAccessible in interface ognl.MemberAccess
Overrides:
isAccessible in class ognl.DefaultMemberAccess

isAcceptableProperty

protected boolean isAcceptableProperty(String name)

isAccepted

protected boolean isAccepted(String paramName)

isExcluded

protected boolean isExcluded(String paramName)

setExcludeProperties

public void setExcludeProperties(Set<Pattern> excludeProperties)

setAcceptProperties

public void setAcceptProperties(Set<Pattern> acceptedProperties)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkTypeConverterWrapper (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl
Class XWorkTypeConverterWrapper

java.lang.Object
    extended by  com.opensymphony.xwork2.ognl.XWorkTypeConverterWrapper
All Implemented Interfaces:
TypeConverter
public class XWorkTypeConverterWrapper
extends Object
implements TypeConverter

Wraps an OGNL TypeConverter as an XWork TypeConverter

Field Summary
Fields inherited from interface com.opensymphony.xwork2.conversion.TypeConverter
NO_CONVERSION_POSSIBLE, TYPE_CONVERTER_CONTEXT_KEY
Constructor Summary
XWorkTypeConverterWrapper(ognl.TypeConverter conv)
Method Summary
 Object convertValue(Map context, Object target, Member member, String propertyName, Object value, Class toType)
Converts the given value to a given type.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XWorkTypeConverterWrapper

public XWorkTypeConverterWrapper(ognl.TypeConverter conv)
Method Detail

convertValue

public Object convertValue(Map context,
                           Object target,
                           Member member,
                           String propertyName,
                           Object value,
                           Class toType)
Description copied from interface: TypeConverter
Converts the given value to a given type. The OGNL context, target, member and name of property being set are given. This method should be able to handle conversion in general without any context, target, member or property name specified.

Specified by:
convertValue in interface TypeConverter
Parameters:
context - context under which the conversion is being done
target - target object in which the property is being set
member - member (Constructor, Method or Field) being set
propertyName - property name being set
value - value to be converted
toType - type to which value is converted
Returns:
Converted value of type toType or TypeConverter.NoConversionPossible to indicate that the conversion was not possible.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CompoundRootAccessor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl.accessor
Class CompoundRootAccessor

java.lang.Object
    extended by  com.opensymphony.xwork2.ognl.accessor.CompoundRootAccessor
All Implemented Interfaces:
ognl.ClassResolver, ognl.MethodAccessor, ognl.PropertyAccessor
public class CompoundRootAccessor
extends Object
implements ognl.PropertyAccessor, ognl.MethodAccessor, ognl.ClassResolver

A stack that is able to call methods on objects in the stack.

Version:
$Revision: 2056 $
Author:
$Author: rainerh $, Rainer Hermanns

Constructor Summary
CompoundRootAccessor()
Method Summary
Object | callMethod(Map context, Object target, String name, Object[] objects)
Object | callStaticMethod(Map transientVars, Class aClass, String s, Object[] objects)
Class | classForName(String className, Map context)
Object | getProperty(Map context, Object target, Object name)
String | getSourceAccessor(ognl.OgnlContext context, Object target, Object index) Used by OGNl to generate bytecode
String | getSourceSetter(ognl.OgnlContext context, Object target, Object index) Used by OGNl to generate bytecode
static void | setDevMode(String mode)
void | setProperty(Map context, Object target, Object name, Object value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CompoundRootAccessor

public CompoundRootAccessor()
Method Detail

getSourceAccessor

public String getSourceAccessor(ognl.OgnlContext context,
                                Object target,
                                Object index)
Used by OGNl to generate bytecode

Specified by:
getSourceAccessor in interface ognl.PropertyAccessor

getSourceSetter

public String getSourceSetter(ognl.OgnlContext context,
                              Object target,
                              Object index)
Used by OGNl to generate bytecode

Specified by:
getSourceSetter in interface ognl.PropertyAccessor

setDevMode

public static void setDevMode(String mode)

setProperty

public void setProperty(Map context,
                        Object target,
                        Object name,
                        Object value)
                 throws ognl.OgnlException
Specified by:
setProperty in interface ognl.PropertyAccessor
Throws:
ognl.OgnlException

getProperty

public Object getProperty(Map context,
                          Object target,
                          Object name)
                   throws ognl.OgnlException
Specified by:
getProperty in interface ognl.PropertyAccessor
Throws:
ognl.OgnlException

callMethod

public Object callMethod(Map context,
                         Object target,
                         String name,
                         Object[] objects)
                  throws ognl.MethodFailedException
Specified by:
callMethod in interface ognl.MethodAccessor
Throws:
ognl.MethodFailedException

callStaticMethod

public Object callStaticMethod(Map transientVars,
                               Class aClass,
                               String s,
                               Object[] objects)
                        throws ognl.MethodFailedException
Specified by:
callStaticMethod in interface ognl.MethodAccessor
Throws:
ognl.MethodFailedException

classForName

public Class classForName(String className,
                          Map context)
                   throws ClassNotFoundException
Specified by:
classForName in interface ognl.ClassResolver
Throws:
ClassNotFoundException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ObjectAccessor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl.accessor
Class ObjectAccessor

java.lang.Object
    extended by  ognl.ObjectPropertyAccessor
        extended by  com.opensymphony.xwork2.ognl.accessor.ObjectAccessor
All Implemented Interfaces:
ognl.PropertyAccessor
public class ObjectAccessor
extends ognl.ObjectPropertyAccessor

Constructor Summary
ObjectAccessor()
Method Summary
Object | getProperty(Map map, Object o, Object o1)
void | setProperty(Map map, Object o, Object o1, Object o2)
Methods inherited from class ognl.ObjectPropertyAccessor
getPossibleProperty, getPropertyClass, getSourceAccessor, getSourceSetter, hasGetProperty, hasGetProperty, hasSetProperty, hasSetProperty, setPossibleProperty
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ObjectAccessor

public ObjectAccessor()
Method Detail

getProperty

public Object getProperty(Map map,
                          Object o,
                          Object o1)
                   throws ognl.OgnlException
Specified by:
getProperty in interface ognl.PropertyAccessor
Overrides:
getProperty in class ognl.ObjectPropertyAccessor
Throws:
ognl.OgnlException

setProperty

public void setProperty(Map map,
                        Object o,
                        Object o1,
                        Object o2)
                 throws ognl.OgnlException
Specified by:
setProperty in interface ognl.PropertyAccessor
Overrides:
setProperty in class ognl.ObjectPropertyAccessor
Throws:
ognl.OgnlException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ObjectProxyPropertyAccessor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl.accessor
Class ObjectProxyPropertyAccessor

java.lang.Object
    extended by  com.opensymphony.xwork2.ognl.accessor.ObjectProxyPropertyAccessor
All Implemented Interfaces:
ognl.PropertyAccessor
public class ObjectProxyPropertyAccessor
extends Object
implements ognl.PropertyAccessor

Is able to access (set/get) properties on a given object.

Uses Ognl internal.

Author:
Gabe

Constructor Summary
ObjectProxyPropertyAccessor()
Method Summary
Object | getProperty(Map context, Object target, Object name)
String | getSourceAccessor(ognl.OgnlContext context, Object target, Object index) Used by OGNl to generate bytecode
String | getSourceSetter(ognl.OgnlContext context, Object target, Object index) Used by OGNl to generate bytecode
void | setProperty(Map context, Object target, Object name, Object value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ObjectProxyPropertyAccessor

public ObjectProxyPropertyAccessor()
Method Detail

getSourceAccessor

public String getSourceAccessor(ognl.OgnlContext context,
                                Object target,
                                Object index)
Used by OGNl to generate bytecode

Specified by:
getSourceAccessor in interface ognl.PropertyAccessor

getSourceSetter

public String getSourceSetter(ognl.OgnlContext context,
                              Object target,
                              Object index)
Used by OGNl to generate bytecode

Specified by:
getSourceSetter in interface ognl.PropertyAccessor

getProperty

public Object getProperty(Map context,
                          Object target,
                          Object name)
                   throws ognl.OgnlException
Specified by:
getProperty in interface ognl.PropertyAccessor
Throws:
ognl.OgnlException

setProperty

public void setProperty(Map context,
                        Object target,
                        Object name,
                        Object value)
                 throws ognl.OgnlException
Specified by:
setProperty in interface ognl.PropertyAccessor
Throws:
ognl.OgnlException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.ognl.accessor (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.ognl.accessor
Classes
CompoundRootAccessor
ObjectAccessor
ObjectProxyPropertyAccessor
XWorkCollectionPropertyAccessor
XWorkEnumerationAccessor
XWorkIteratorPropertyAccessor
XWorkListPropertyAccessor
XWorkMapPropertyAccessor
XWorkMethodAccessor
XWorkObjectPropertyAccessor


com.opensymphony.xwork2.ognl.accessor (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.ognl.accessor

Class Summary
CompoundRootAccessor | A stack that is able to call methods on objects in the stack.
ObjectAccessor |
ObjectProxyPropertyAccessor | Is able to access (set/get) properties on a given object.
XWorkCollectionPropertyAccessor |
XWorkEnumerationAccessor |
XWorkIteratorPropertyAccessor |
XWorkListPropertyAccessor | Overrides the list property accessor so in the case of trying to add properties of a given bean and the JavaBean is not present, this class will create the necessary blank JavaBeans.
XWorkMapPropertyAccessor | Implementation of PropertyAccessor that sets and gets properties by storing and looking up values in Maps.
XWorkMethodAccessor | Allows methods to be executed under normal cirumstances, except when ReflectionContextState.DENY_METHOD_EXECUTION is in the action context with a value of true.
XWorkObjectPropertyAccessor |


com.opensymphony.xwork2.ognl.accessor Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.ognl.accessor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.ognl.accessor.CompoundRootAccessor (implements ognl.ClassResolver, ognl.MethodAccessor, ognl.PropertyAccessor)
    • ognl.MapPropertyAccessor (implements ognl.PropertyAccessor)
      • com.opensymphony.xwork2.ognl.accessor.XWorkMapPropertyAccessor
    • ognl.ObjectMethodAccessor (implements ognl.MethodAccessor)
      • com.opensymphony.xwork2.ognl.accessor.XWorkMethodAccessor
    • ognl.ObjectPropertyAccessor (implements ognl.PropertyAccessor)
      • ognl.EnumerationPropertyAccessor (implements ognl.PropertyAccessor)
        • com.opensymphony.xwork2.ognl.accessor.XWorkEnumerationAccessor
      • ognl.IteratorPropertyAccessor (implements ognl.PropertyAccessor)
        • com.opensymphony.xwork2.ognl.accessor.XWorkIteratorPropertyAccessor
      • ognl.ListPropertyAccessor (implements ognl.PropertyAccessor)
        • com.opensymphony.xwork2.ognl.accessor.XWorkListPropertyAccessor
      • com.opensymphony.xwork2.ognl.accessor.ObjectAccessor
      • ognl.SetPropertyAccessor (implements ognl.PropertyAccessor)
        • com.opensymphony.xwork2.ognl.accessor.XWorkCollectionPropertyAccessor
      • com.opensymphony.xwork2.ognl.accessor.XWorkObjectPropertyAccessor
    • com.opensymphony.xwork2.ognl.accessor.ObjectProxyPropertyAccessor (implements ognl.PropertyAccessor)


Uses of Package com.opensymphony.xwork2.ognl.accessor (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.ognl.accessor

Packages that use com.opensymphony.xwork2.ognl.accessor
com.opensymphony.xwork2.ognl

Classes in com.opensymphony.xwork2.ognl.accessor used by com.opensymphony.xwork2.ognl
CompoundRootAccessor
A stack that is able to call methods on objects in the stack.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


XWorkCollectionPropertyAccessor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl.accessor
Class XWorkCollectionPropertyAccessor

java.lang.Object
    extended by  ognl.ObjectPropertyAccessor
        extended by  ognl.SetPropertyAccessor
            extended by  com.opensymphony.xwork2.ognl.accessor.XWorkCollectionPropertyAccessor
All Implemented Interfaces:
ognl.PropertyAccessor
public class XWorkCollectionPropertyAccessor
extends ognl.SetPropertyAccessor

Author:
Gabe

Field Summary
static String KEY_PROPERTY_FOR_CREATION
Constructor Summary
XWorkCollectionPropertyAccessor()
Method Summary
Object | getProperty(Map context, Object target, Object key) Gets the property of a Collection by indexing the collection based on a key property.
Object | getPropertyThroughIteration(Map context, Collection collection, String property, Object key)
void | setObjectFactory(ObjectFactory fac)
void | setObjectTypeDeterminer(ObjectTypeDeterminer ot)
void | setProperty(Map arg0, Object arg1, Object arg2, Object arg3)
void | setXWorkConverter(XWorkConverter conv)
Methods inherited from class ognl.ObjectPropertyAccessor
getPossibleProperty, getPropertyClass, getSourceAccessor, getSourceSetter, hasGetProperty, hasGetProperty, hasSetProperty, hasSetProperty, setPossibleProperty
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface ognl.PropertyAccessor
getSourceAccessor, getSourceSetter

Field Detail

KEY_PROPERTY_FOR_CREATION

public static final String KEY_PROPERTY_FOR_CREATION
See Also:
Constant Field Values
Constructor Detail

XWorkCollectionPropertyAccessor

public XWorkCollectionPropertyAccessor()
Method Detail

setXWorkConverter

public void setXWorkConverter(XWorkConverter conv)

setObjectFactory

public void setObjectFactory(ObjectFactory fac)

setObjectTypeDeterminer

public void setObjectTypeDeterminer(ObjectTypeDeterminer ot)

getProperty

public Object getProperty(Map context,
                          Object target,
                          Object key)
                   throws ognl.OgnlException
Gets the property of a Collection by indexing the collection based on a key property. For example, if the key property were 'id', this method would convert the key Object to whatever type the id property was, and then access the Set like it was a Map returning a JavaBean with the value of id property matching the input.

Specified by:
getProperty in interface ognl.PropertyAccessor
Overrides:
getProperty in class ognl.SetPropertyAccessor
Throws:
ognl.OgnlException
See Also:
PropertyAccessor.getProperty(java.util.Map, Object, Object)

getPropertyThroughIteration

public Object getPropertyThroughIteration(Map context,
                                          Collection collection,
                                          String property,
                                          Object key)
                                   throws ognl.OgnlException
Throws:
ognl.OgnlException

setProperty

public void setProperty(Map arg0,
                        Object arg1,
                        Object arg2,
                        Object arg3)
                 throws ognl.OgnlException
Specified by:
setProperty in interface ognl.PropertyAccessor
Overrides:
setProperty in class ognl.ObjectPropertyAccessor
Throws:
ognl.OgnlException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkEnumerationAccessor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl.accessor
Class XWorkEnumerationAccessor

java.lang.Object
    extended by  ognl.ObjectPropertyAccessor
        extended by  ognl.EnumerationPropertyAccessor
            extended by  com.opensymphony.xwork2.ognl.accessor.XWorkEnumerationAccessor
All Implemented Interfaces:
ognl.PropertyAccessor
public class XWorkEnumerationAccessor
extends ognl.EnumerationPropertyAccessor

Author:
plightbo

Constructor Summary
XWorkEnumerationAccessor()
Method Summary
 void setProperty(Map context, Object target, Object name, Object value)
Methods inherited from class ognl.EnumerationPropertyAccessor
getProperty
Methods inherited from class ognl.ObjectPropertyAccessor
getPossibleProperty, getPropertyClass, getSourceAccessor, getSourceSetter, hasGetProperty, hasGetProperty, hasSetProperty, hasSetProperty, setPossibleProperty
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface ognl.PropertyAccessor
getSourceAccessor, getSourceSetter

Constructor Detail

XWorkEnumerationAccessor

public XWorkEnumerationAccessor()
Method Detail

setProperty

public void setProperty(Map context,
                        Object target,
                        Object name,
                        Object value)
                 throws ognl.OgnlException
Specified by:
setProperty in interface ognl.PropertyAccessor
Overrides:
setProperty in class ognl.EnumerationPropertyAccessor
Throws:
ognl.OgnlException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkIteratorPropertyAccessor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl.accessor
Class XWorkIteratorPropertyAccessor

java.lang.Object
    extended by  ognl.ObjectPropertyAccessor
        extended by  ognl.IteratorPropertyAccessor
            extended by  com.opensymphony.xwork2.ognl.accessor.XWorkIteratorPropertyAccessor
All Implemented Interfaces:
ognl.PropertyAccessor
public class XWorkIteratorPropertyAccessor
extends ognl.IteratorPropertyAccessor

Author:
plightbo

Constructor Summary
XWorkIteratorPropertyAccessor()
Method Summary
 void setProperty(Map context, Object target, Object name, Object value)
Methods inherited from class ognl.IteratorPropertyAccessor
getProperty
Methods inherited from class ognl.ObjectPropertyAccessor
getPossibleProperty, getPropertyClass, getSourceAccessor, getSourceSetter, hasGetProperty, hasGetProperty, hasSetProperty, hasSetProperty, setPossibleProperty
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface ognl.PropertyAccessor
getSourceAccessor, getSourceSetter

Constructor Detail

XWorkIteratorPropertyAccessor

public XWorkIteratorPropertyAccessor()
Method Detail

setProperty

public void setProperty(Map context,
                        Object target,
                        Object name,
                        Object value)
                 throws ognl.OgnlException
Specified by:
setProperty in interface ognl.PropertyAccessor
Overrides:
setProperty in class ognl.IteratorPropertyAccessor
Throws:
ognl.OgnlException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkListPropertyAccessor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl.accessor
Class XWorkListPropertyAccessor

java.lang.Object
    extended by  ognl.ObjectPropertyAccessor
        extended by  ognl.ListPropertyAccessor
            extended by  com.opensymphony.xwork2.ognl.accessor.XWorkListPropertyAccessor
All Implemented Interfaces:
ognl.PropertyAccessor
public class XWorkListPropertyAccessor
extends ognl.ListPropertyAccessor

Overrides the list property accessor so in the case of trying to add properties of a given bean and the JavaBean is not present, this class will create the necessary blank JavaBeans.

Author:
Gabriel Zimmerman

Constructor Summary
XWorkListPropertyAccessor()
Method Summary
Object | getProperty(Map context, Object target, Object name)
void | setObjectFactory(ObjectFactory fac)
void | setObjectTypeDeterminer(ObjectTypeDeterminer ot)
void | setOgnlUtil(OgnlUtil util)
void | setProperty(Map context, Object target, Object name, Object value)
void | setXWorkCollectionPropertyAccessor(ognl.PropertyAccessor acc)
void | setXWorkConverter(XWorkConverter conv)
Methods inherited from class ognl.ListPropertyAccessor
getPropertyClass, getSourceAccessor, getSourceSetter
Methods inherited from class ognl.ObjectPropertyAccessor
getPossibleProperty, hasGetProperty, hasGetProperty, hasSetProperty, hasSetProperty, setPossibleProperty
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XWorkListPropertyAccessor

public XWorkListPropertyAccessor()
Method Detail

setXWorkCollectionPropertyAccessor

public void setXWorkCollectionPropertyAccessor(ognl.PropertyAccessor acc)

setXWorkConverter

public void setXWorkConverter(XWorkConverter conv)

setObjectFactory

public void setObjectFactory(ObjectFactory fac)

setObjectTypeDeterminer

public void setObjectTypeDeterminer(ObjectTypeDeterminer ot)

setOgnlUtil

public void setOgnlUtil(OgnlUtil util)

getProperty

public Object getProperty(Map context,
                          Object target,
                          Object name)
                   throws ognl.OgnlException
Specified by:
getProperty in interface ognl.PropertyAccessor
Overrides:
getProperty in class ognl.ListPropertyAccessor
Throws:
ognl.OgnlException

setProperty

public void setProperty(Map context,
                        Object target,
                        Object name,
                        Object value)
                 throws ognl.OgnlException
Specified by:
setProperty in interface ognl.PropertyAccessor
Overrides:
setProperty in class ognl.ListPropertyAccessor
Throws:
ognl.OgnlException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkMapPropertyAccessor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl.accessor
Class XWorkMapPropertyAccessor

java.lang.Object
    extended by  ognl.MapPropertyAccessor
        extended by  com.opensymphony.xwork2.ognl.accessor.XWorkMapPropertyAccessor
All Implemented Interfaces:
ognl.PropertyAccessor
public class XWorkMapPropertyAccessor
extends ognl.MapPropertyAccessor

Implementation of PropertyAccessor that sets and gets properties by storing and looking up values in Maps.

Author:
Gabriel Zimmerman

Constructor Summary
XWorkMapPropertyAccessor()
Method Summary
Object | getProperty(Map context, Object target, Object name)
void | setObjectFactory(ObjectFactory fac)
void | setObjectTypeDeterminer(ObjectTypeDeterminer ot)
void | setProperty(Map context, Object target, Object name, Object value)
void | setXWorkConverter(XWorkConverter conv)
Methods inherited from class ognl.MapPropertyAccessor
getSourceAccessor, getSourceSetter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XWorkMapPropertyAccessor

public XWorkMapPropertyAccessor()
Method Detail

setXWorkConverter

public void setXWorkConverter(XWorkConverter conv)

setObjectFactory

public void setObjectFactory(ObjectFactory fac)

setObjectTypeDeterminer

public void setObjectTypeDeterminer(ObjectTypeDeterminer ot)

getProperty

public Object getProperty(Map context,
                          Object target,
                          Object name)
                   throws ognl.OgnlException
Specified by:
getProperty in interface ognl.PropertyAccessor
Overrides:
getProperty in class ognl.MapPropertyAccessor
Throws:
ognl.OgnlException

setProperty

public void setProperty(Map context,
                        Object target,
                        Object name,
                        Object value)
                 throws ognl.OgnlException
Specified by:
setProperty in interface ognl.PropertyAccessor
Overrides:
setProperty in class ognl.MapPropertyAccessor
Throws:
ognl.OgnlException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkMethodAccessor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl.accessor
Class XWorkMethodAccessor

java.lang.Object
    extended by  ognl.ObjectMethodAccessor
        extended by  com.opensymphony.xwork2.ognl.accessor.XWorkMethodAccessor
All Implemented Interfaces:
ognl.MethodAccessor
public class XWorkMethodAccessor
extends ognl.ObjectMethodAccessor

Allows methods to be executed under normal cirumstances, except when ReflectionContextState.DENY_METHOD_EXECUTION is in the action context with a value of true.

Author:
Patrick Lightbody, tmjee

Field Summary
static String | DENY_INDEXED_ACCESS_EXECUTION Deprecated. Use ReflectionContextState.DENY_INDEXED_ACCESS_EXECUTION instead
static String | DENY_METHOD_EXECUTION Deprecated. Use ReflectionContextState.DENY_METHOD_EXECUTION instead
Constructor Summary
XWorkMethodAccessor()
Method Summary
Object | callMethod(Map context, Object object, String string, Object[] objects)
Object | callStaticMethod(Map context, Class aClass, String string, Object[] objects)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DENY_METHOD_EXECUTION

@Deprecated
public static final String DENY_METHOD_EXECUTION
Deprecated. Use ReflectionContextState.DENY_METHOD_EXECUTION instead
See Also:
Constant Field Values

DENY_INDEXED_ACCESS_EXECUTION

@Deprecated
public static final String DENY_INDEXED_ACCESS_EXECUTION
Deprecated. Use ReflectionContextState.DENY_INDEXED_ACCESS_EXECUTION instead
See Also:
Constant Field Values
Constructor Detail

XWorkMethodAccessor

public XWorkMethodAccessor()
Method Detail

callMethod

public Object callMethod(Map context,
                         Object object,
                         String string,
                         Object[] objects)
                  throws ognl.MethodFailedException
Specified by:
callMethod in interface ognl.MethodAccessor
Overrides:
callMethod in class ognl.ObjectMethodAccessor
Throws:
ognl.MethodFailedException

callStaticMethod

public Object callStaticMethod(Map context,
                               Class aClass,
                               String string,
                               Object[] objects)
                        throws ognl.MethodFailedException
Specified by:
callStaticMethod in interface ognl.MethodAccessor
Overrides:
callStaticMethod in class ognl.ObjectMethodAccessor
Throws:
ognl.MethodFailedException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkObjectPropertyAccessor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.ognl.accessor
Class XWorkObjectPropertyAccessor

java.lang.Object
    extended by  ognl.ObjectPropertyAccessor
        extended by  com.opensymphony.xwork2.ognl.accessor.XWorkObjectPropertyAccessor
All Implemented Interfaces:
ognl.PropertyAccessor
public class XWorkObjectPropertyAccessor
extends ognl.ObjectPropertyAccessor

Author:
Gabe

Constructor Summary
XWorkObjectPropertyAccessor()
Method Summary
 Object getProperty(Map context, Object target, Object oname)
Methods inherited from class ognl.ObjectPropertyAccessor
getPossibleProperty, getPropertyClass, getSourceAccessor, getSourceSetter, hasGetProperty, hasGetProperty, hasSetProperty, hasSetProperty, setPossibleProperty, setProperty
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XWorkObjectPropertyAccessor

public XWorkObjectPropertyAccessor()
Method Detail

getProperty

public Object getProperty(Map context,
                          Object target,
                          Object oname)
                   throws ognl.OgnlException
Specified by:
getProperty in interface ognl.PropertyAccessor
Overrides:
getProperty in class ognl.ObjectPropertyAccessor
Throws:
ognl.OgnlException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.opensymphony.xwork2.ognl.accessor.CompoundRootAccessor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.accessor.CompoundRootAccessor

Packages that use CompoundRootAccessor
com.opensymphony.xwork2.ognl

Uses of CompoundRootAccessor in com.opensymphony.xwork2.ognl

Methods in com.opensymphony.xwork2.ognl with parameters of type CompoundRootAccessor
protected  void OgnlValueStack.setRoot(XWorkConverter xworkConverter, CompoundRootAccessor accessor, CompoundRoot compoundRoot, boolean allowStaticMethodAccess)

Constructors in com.opensymphony.xwork2.ognl with parameters of type CompoundRootAccessor
OgnlValueStack(ValueStack vs, XWorkConverter xworkConverter, CompoundRootAccessor accessor, boolean allowStaticAccess)
OgnlValueStack(XWorkConverter xworkConverter, CompoundRootAccessor accessor, TextProvider prov, boolean allowStaticAccess)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ognl.accessor.ObjectAccessor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.accessor.ObjectAccessor

No usage of com.opensymphony.xwork2.ognl.accessor.ObjectAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ognl.accessor.ObjectProxyPropertyAccessor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.accessor.ObjectProxyPropertyAccessor

No usage of com.opensymphony.xwork2.ognl.accessor.ObjectProxyPropertyAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ognl.accessor.XWorkCollectionPropertyAccessor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.accessor.XWorkCollectionPropertyAccessor

No usage of com.opensymphony.xwork2.ognl.accessor.XWorkCollectionPropertyAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ognl.accessor.XWorkEnumerationAccessor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.accessor.XWorkEnumerationAccessor

No usage of com.opensymphony.xwork2.ognl.accessor.XWorkEnumerationAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ognl.accessor.XWorkIteratorPropertyAccessor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.accessor.XWorkIteratorPropertyAccessor

No usage of com.opensymphony.xwork2.ognl.accessor.XWorkIteratorPropertyAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ognl.accessor.XWorkListPropertyAccessor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.accessor.XWorkListPropertyAccessor

No usage of com.opensymphony.xwork2.ognl.accessor.XWorkListPropertyAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ognl.accessor.XWorkMapPropertyAccessor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.accessor.XWorkMapPropertyAccessor

No usage of com.opensymphony.xwork2.ognl.accessor.XWorkMapPropertyAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ognl.accessor.XWorkMethodAccessor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.accessor.XWorkMethodAccessor

No usage of com.opensymphony.xwork2.ognl.accessor.XWorkMethodAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ognl.accessor.XWorkObjectPropertyAccessor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.accessor.XWorkObjectPropertyAccessor

No usage of com.opensymphony.xwork2.ognl.accessor.XWorkObjectPropertyAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ognl.ObjectProxy (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.ObjectProxy

No usage of com.opensymphony.xwork2.ognl.ObjectProxy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ognl.OgnlNullHandlerWrapper (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.OgnlNullHandlerWrapper

No usage of com.opensymphony.xwork2.ognl.OgnlNullHandlerWrapper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ognl.OgnlReflectionContextFactory (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.OgnlReflectionContextFactory

No usage of com.opensymphony.xwork2.ognl.OgnlReflectionContextFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ognl.OgnlReflectionProvider (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.OgnlReflectionProvider

No usage of com.opensymphony.xwork2.ognl.OgnlReflectionProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ognl.OgnlTypeConverterWrapper (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.OgnlTypeConverterWrapper

No usage of com.opensymphony.xwork2.ognl.OgnlTypeConverterWrapper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ognl.OgnlUtil (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.OgnlUtil

Packages that use OgnlUtil
com.opensymphony.xwork2.ognl
com.opensymphony.xwork2.ognl.accessor

Uses of OgnlUtil in com.opensymphony.xwork2.ognl

Methods in com.opensymphony.xwork2.ognl with parameters of type OgnlUtil
void | OgnlValueStack.setOgnlUtil(OgnlUtil ognlUtil)
void | OgnlReflectionProvider.setOgnlUtil(OgnlUtil ognlUtil)

Uses of OgnlUtil in com.opensymphony.xwork2.ognl.accessor

Methods in com.opensymphony.xwork2.ognl.accessor with parameters of type OgnlUtil
 void XWorkListPropertyAccessor.setOgnlUtil(OgnlUtil util)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ognl.OgnlValueStack (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.OgnlValueStack

No usage of com.opensymphony.xwork2.ognl.OgnlValueStack

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ognl.OgnlValueStackFactory (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.OgnlValueStackFactory

No usage of com.opensymphony.xwork2.ognl.OgnlValueStackFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ognl.SecurityMemberAccess (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.SecurityMemberAccess

No usage of com.opensymphony.xwork2.ognl.SecurityMemberAccess

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ognl.XWorkTypeConverterWrapper (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.ognl.XWorkTypeConverterWrapper

No usage of com.opensymphony.xwork2.ognl.XWorkTypeConverterWrapper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2.spring (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.spring
Classes
SpringObjectFactory
SpringProxyableObjectFactory


com.opensymphony.xwork2.spring (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.spring

Spring ObjectFactory classes.

See:
Description

Class Summary
SpringObjectFactory | Simple implementation of the ObjectFactory that makes use of Spring's application context if one has been configured, before falling back on the default mechanism of instantiating a new class using the class name.
SpringProxyableObjectFactory | SpringProxyableObjectFactory.

Package com.opensymphony.xwork2.spring Description

Spring ObjectFactory classes.


com.opensymphony.xwork2.spring Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.spring

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.ObjectFactory (implements java.io.Serializable)
      • com.opensymphony.xwork2.spring.SpringObjectFactory (implements org.springframework.context.ApplicationContextAware)
        • com.opensymphony.xwork2.spring.SpringProxyableObjectFactory


Uses of Package com.opensymphony.xwork2.spring (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.spring

Packages that use com.opensymphony.xwork2.spring
com.opensymphony.xwork2.spring Spring ObjectFactory classes.

Classes in com.opensymphony.xwork2.spring used by com.opensymphony.xwork2.spring
SpringObjectFactory
Simple implementation of the ObjectFactory that makes use of Spring's application context if one has been configured, before falling back on the default mechanism of instantiating a new class using the class name.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


SpringObjectFactory (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.spring
Class SpringObjectFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.ObjectFactory
        extended by  com.opensymphony.xwork2.spring.SpringObjectFactory
All Implemented Interfaces:
Serializable, ApplicationContextAware
Direct Known Subclasses:
SpringProxyableObjectFactory
public class SpringObjectFactory
extends ObjectFactory
implements ApplicationContextAware

Simple implementation of the ObjectFactory that makes use of Spring's application context if one has been configured, before falling back on the default mechanism of instantiating a new class using the class name.

In order to use this class in your application, you will need to instantiate a copy of this class and set it as XWork's ObjectFactory before the xwork.xml file is parsed. In a servlet environment, this could be done using a ServletContextListener.

Author:
Simon Stewart (sms@lateral.net)
See Also:
Serialized Form

Field Summary
protected ApplicationContext | appContext
protected int | autowireStrategy
protected AutowireCapableBeanFactory | autoWiringFactory
Fields inherited from class com.opensymphony.xwork2.ObjectFactory
reflectionProvider
Constructor Summary
SpringObjectFactory()
Method Summary
Object | autoWireBean(Object bean)
Object | autoWireBean(Object bean, AutowireCapableBeanFactory autoWiringFactory)
Object | buildBean(Class clazz, Map<String,Object> extraContext) Build a generic Java object of the given type.
Object | buildBean(String beanName, Map<String,Object> extraContext, boolean injectInternal) Looks up beans using Spring's application context before falling back to the method defined in the ObjectFactory.
protected AutowireCapableBeanFactory | findAutoWiringBeanFactory(ApplicationContext context) If the given context is assignable to AutowireCapbleBeanFactory or contains a parent or a factory that is, then set the autoWiringFactory appropriately.
int | getAutowireStrategy()
Class | getClassInstance(String className) Utility method to obtain the class matched to className.
void | initObjectFactory() Deprecated. Since 2.1 as it isn't necessary
boolean | isNoArgConstructorRequired() Allows for ObjectFactory implementations that support Actions without no-arg constructors.
void | setAlwaysRespectAutowireStrategy(boolean alwaysRespectAutowireStrategy) Determines if the autowire strategy is always followed when creating beans
void | setApplicationContext(ApplicationContext appContext) Set the Spring ApplicationContext that should be used to look beans up with.
void | setApplicationContextPath(String ctx)
void | setAutowireStrategy(int autowireStrategy) Sets the autowiring strategy
void | setUseClassCache(boolean useClassCache) Enable / disable caching of classes loaded by Spring.
Methods inherited from class com.opensymphony.xwork2.ObjectFactory
buildAction, buildBean, buildInterceptor, buildResult, buildValidator, getObjectFactory, injectInternalBeans, setClassLoader, setContainer, setReflectionProvider
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

appContext

protected ApplicationContext appContext

autoWiringFactory

protected AutowireCapableBeanFactory autoWiringFactory

autowireStrategy

protected int autowireStrategy
Constructor Detail

SpringObjectFactory

public SpringObjectFactory()
Method Detail

setApplicationContextPath

public void setApplicationContextPath(String ctx)

setApplicationContext

public void setApplicationContext(ApplicationContext appContext)
                           throws BeansException
Set the Spring ApplicationContext that should be used to look beans up with.

Specified by:
setApplicationContext in interface ApplicationContextAware
Parameters:
appContext - The Spring ApplicationContext that should be used to look beans up with.
Throws:
BeansException

setAutowireStrategy

public void setAutowireStrategy(int autowireStrategy)
Sets the autowiring strategy

Parameters:
autowireStrategy -

getAutowireStrategy

public int getAutowireStrategy()

findAutoWiringBeanFactory

protected AutowireCapableBeanFactory findAutoWiringBeanFactory(ApplicationContext context)
If the given context is assignable to AutowireCapbleBeanFactory or contains a parent or a factory that is, then set the autoWiringFactory appropriately.

Parameters:
context -

buildBean

public Object buildBean(String beanName,
                        Map<String,Object> extraContext,
                        boolean injectInternal)
                 throws Exception
Looks up beans using Spring's application context before falling back to the method defined in the ObjectFactory.

Overrides:
buildBean in class ObjectFactory
Parameters:
beanName - The name of the bean to look up in the application context
extraContext -
Returns:
A bean from Spring or the result of calling the overridden method.
Throws:
Exception

buildBean

public Object buildBean(Class clazz,
                        Map<String,Object> extraContext)
                 throws Exception
Description copied from class: ObjectFactory
Build a generic Java object of the given type.

Overrides:
buildBean in class ObjectFactory
Parameters:
clazz -
extraContext -
Throws:
Exception

autoWireBean

public Object autoWireBean(Object bean)

autoWireBean

public Object autoWireBean(Object bean,
                           AutowireCapableBeanFactory autoWiringFactory)
Parameters:
bean -
autoWiringFactory -

getClassInstance

public Class getClassInstance(String className)
                       throws ClassNotFoundException
Description copied from class: ObjectFactory
Utility method to obtain the class matched to className. Caches look ups so that subsequent lookups will be faster.

Overrides:
getClassInstance in class ObjectFactory
Parameters:
className - The fully qualified name of the class to return
Returns:
The class itself
Throws:
ClassNotFoundException

initObjectFactory

@Deprecated
public void initObjectFactory()
Deprecated. Since 2.1 as it isn't necessary

This method sets the ObjectFactory used by XWork to this object. It's best used as the "init-method" of a Spring bean definition in order to hook Spring and XWork together properly (as an alternative to the org.apache.struts2.spring.lifecycle.SpringObjectFactoryListener)

isNoArgConstructorRequired

public boolean isNoArgConstructorRequired()
Allows for ObjectFactory implementations that support Actions without no-arg constructors.

Overrides:
isNoArgConstructorRequired in class ObjectFactory
Returns:
false

setUseClassCache

public void setUseClassCache(boolean useClassCache)
Enable / disable caching of classes loaded by Spring.

Parameters:
useClassCache -

setAlwaysRespectAutowireStrategy

public void setAlwaysRespectAutowireStrategy(boolean alwaysRespectAutowireStrategy)
Determines if the autowire strategy is always followed when creating beans

Parameters:
alwaysRespectAutowireStrategy - True if the strategy is always used
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


SpringProxyableObjectFactory (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.spring
Class SpringProxyableObjectFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.ObjectFactory
        extended by  com.opensymphony.xwork2.spring.SpringObjectFactory
            extended by  com.opensymphony.xwork2.spring.SpringProxyableObjectFactory
All Implemented Interfaces:
Serializable, ApplicationContextAware
public class SpringProxyableObjectFactory
extends SpringObjectFactory

SpringProxyableObjectFactory.

Author:
Jason Carreira
See Also:
Serialized Form

Field Summary
Fields inherited from class com.opensymphony.xwork2.spring.SpringObjectFactory
appContext, autowireStrategy, autoWiringFactory
Fields inherited from class com.opensymphony.xwork2.ObjectFactory
reflectionProvider
Constructor Summary
SpringProxyableObjectFactory()
Method Summary
Object | buildBean(String beanName, Map<String,Object> extraContext) Build a generic Java object of the given type.
protected ApplicationContext | getApplicationContext(Map<String,Object> context) Subclasses may override this to return a different application context.
Methods inherited from class com.opensymphony.xwork2.spring.SpringObjectFactory
autoWireBean, autoWireBean, buildBean, buildBean, findAutoWiringBeanFactory, getAutowireStrategy, getClassInstance, initObjectFactory, isNoArgConstructorRequired, setAlwaysRespectAutowireStrategy, setApplicationContext, setApplicationContextPath, setAutowireStrategy, setUseClassCache
Methods inherited from class com.opensymphony.xwork2.ObjectFactory
buildAction, buildInterceptor, buildResult, buildValidator, getObjectFactory, injectInternalBeans, setClassLoader, setContainer, setReflectionProvider
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SpringProxyableObjectFactory

public SpringProxyableObjectFactory()
Method Detail

buildBean

public Object buildBean(String beanName,
                        Map<String,Object> extraContext)
                 throws Exception
Description copied from class: ObjectFactory
Build a generic Java object of the given type.

Overrides:
buildBean in class ObjectFactory
Parameters:
beanName - the type of Object to build
extraContext - a Map of extra context which uses the same keys as the ActionContext
Throws:
Exception

getApplicationContext

protected ApplicationContext getApplicationContext(Map<String,Object> context)
Subclasses may override this to return a different application context. Note that this application context should see any changes made to the autoWiringFactory, so the application context should be either the original or a child context of the original.

Parameters:
context - provided context.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.opensymphony.xwork2.spring.SpringObjectFactory (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.spring.SpringObjectFactory

Packages that use SpringObjectFactory
com.opensymphony.xwork2.spring Spring ObjectFactory classes.

Uses of SpringObjectFactory in com.opensymphony.xwork2.spring

Subclasses of SpringObjectFactory in com.opensymphony.xwork2.spring
 class SpringProxyableObjectFactory
SpringProxyableObjectFactory.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.spring.SpringProxyableObjectFactory (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.spring.SpringProxyableObjectFactory

No usage of com.opensymphony.xwork2.spring.SpringProxyableObjectFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ActionAutowiringInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.spring.interceptor
Class ActionAutowiringInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor
All Implemented Interfaces:
Interceptor, Serializable, ApplicationContextAware
public class ActionAutowiringInterceptor
extends AbstractInterceptor
implements ApplicationContextAware

TODO: Give a description of the Interceptor. TODO: Describe the paramters for this Interceptor. TODO: Discuss some possible extension of the Interceptor.

 <!-- TODO: Describe how the Interceptor reference will effect execution -->
 <action name="someAction" class="com.examples.SomeAction">
      TODO: fill in the interceptor reference.
     <interceptor-ref name=""/>
     <result name="success">good_result.ftl</result>
 </action>
Autowires action classes to Spring beans. The strategy for autowiring the beans can be configured by setting the parameter on the interceptor. Actions that need access to the ActionContext can implements the ApplicationContextAware interface. The context will also be placed on the action context under the APPLICATION_CONTEXT attribute.

Author:
Simon Stewart, Eric Hauser
See Also:
Serialized Form

Field Summary
static String APPLICATION_CONTEXT
Constructor Summary
ActionAutowiringInterceptor()
Method Summary
protected ApplicationContext | getApplicationContext()
String | intercept(ActionInvocation invocation) Looks for the ApplicationContext under the attribute that the Spring listener sets in the servlet context.
void | setApplicationContext(ApplicationContext applicationContext)
void | setAutowireStrategy(Integer autowireStrategy)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

APPLICATION_CONTEXT

public static final String APPLICATION_CONTEXT
See Also:
Constant Field Values
Constructor Detail

ActionAutowiringInterceptor

public ActionAutowiringInterceptor()
Method Detail

setAutowireStrategy

public void setAutowireStrategy(Integer autowireStrategy)
Parameters:
autowireStrategy -

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Looks for the ApplicationContext under the attribute that the Spring listener sets in the servlet context. The configuration is done the first time here instead of in init() since the ActionContext is not available during Interceptor initialization.

Autowires the action to Spring beans and places the ApplicationContext on the ActionContext

TODO Should this check to see if the SpringObjectFactory has already been configured instead of instantiating a new one? Or is there a good reason for the interceptor to have it's own factory?

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Parameters:
invocation -
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception

setApplicationContext

public void setApplicationContext(ApplicationContext applicationContext)
                           throws BeansException
Specified by:
setApplicationContext in interface ApplicationContextAware
Parameters:
applicationContext -
Throws:
BeansException

getApplicationContext

protected ApplicationContext getApplicationContext()
Returns:
context
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.spring.interceptor (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.spring.interceptor
Classes
ActionAutowiringInterceptor


com.opensymphony.xwork2.spring.interceptor (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.spring.interceptor

Spring specific interceptor classes.

See:
Description

Class Summary
ActionAutowiringInterceptor TODO: Give a description of the Interceptor.

Package com.opensymphony.xwork2.spring.interceptor Description

Spring specific interceptor classes.


com.opensymphony.xwork2.spring.interceptor Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.spring.interceptor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.interceptor.AbstractInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
      • com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor (implements org.springframework.context.ApplicationContextAware)


Uses of Package com.opensymphony.xwork2.spring.interceptor (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.spring.interceptor

No usage of com.opensymphony.xwork2.spring.interceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor

No usage of com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2.test (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.test
Classes
StubConfigurationProvider


com.opensymphony.xwork2.test (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.test

Class Summary
StubConfigurationProvider


com.opensymphony.xwork2.test Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.test

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.test.StubConfigurationProvider (implements com.opensymphony.xwork2.config.ConfigurationProvider)


Uses of Package com.opensymphony.xwork2.test (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.test

No usage of com.opensymphony.xwork2.test

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


StubConfigurationProvider (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.test
Class StubConfigurationProvider

java.lang.Object
    extended by  com.opensymphony.xwork2.test.StubConfigurationProvider
All Implemented Interfaces:
ConfigurationProvider, ContainerProvider, PackageProvider
public class StubConfigurationProvider
extends Object
implements ConfigurationProvider

Constructor Summary
StubConfigurationProvider()
Method Summary
void | destroy() Called before removed from the configuration manager
void | init(Configuration configuration) Initializes with the configuration
void | loadPackages() Loads the packages for the configuration.
boolean | needsReload() Tells whether the ContainerProvider should reload its configuration
void | register(ContainerBuilder builder, LocatableProperties props) Registers beans and properties for the Container
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StubConfigurationProvider

public StubConfigurationProvider()
Method Detail

destroy

public void destroy()
Description copied from interface: ContainerProvider
Called before removed from the configuration manager

Specified by:
destroy in interface ContainerProvider

init

public void init(Configuration configuration)
          throws ConfigurationException
Description copied from interface: ContainerProvider
Initializes with the configuration

Specified by:
init in interface ContainerProvider
Specified by:
init in interface PackageProvider
Parameters:
configuration - The configuration
Throws:
ConfigurationException - If anything goes wrong

loadPackages

public void loadPackages()
                  throws ConfigurationException
Description copied from interface: PackageProvider
Loads the packages for the configuration.

Specified by:
loadPackages in interface PackageProvider
Throws:
ConfigurationException

needsReload

public boolean needsReload()
Description copied from interface: ContainerProvider
Tells whether the ContainerProvider should reload its configuration

Specified by:
needsReload in interface ContainerProvider
Specified by:
needsReload in interface PackageProvider
Returns:
true, whether the ContainerProvider should reload its configuration, falseotherwise.

register

public void register(ContainerBuilder builder,
                     LocatableProperties props)
              throws ConfigurationException
Description copied from interface: ContainerProvider
Registers beans and properties for the Container

Specified by:
register in interface ContainerProvider
Parameters:
builder - The builder to register beans with
props - The properties to register constants with
Throws:
ConfigurationException - If anything goes wrong
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.opensymphony.xwork2.test.StubConfigurationProvider (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.test.StubConfigurationProvider

No usage of com.opensymphony.xwork2.test.StubConfigurationProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AnnotationUtils (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class AnnotationUtils

java.lang.Object
    extended by  com.opensymphony.xwork2.util.AnnotationUtils

public class AnnotationUtils
extends Object

AnnotationUtils Various utility methods dealing with annotations

Version:
$Id: AnnotationUtils.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns, Zsolt Szasz, zsolt at lorecraft dot com, Dan Oxlade, dan d0t oxlade at gmail d0t c0m

Constructor Summary
AnnotationUtils()
Method Summary
static void addAllFields(Class annotationClass, Class clazz, List<Field> allFields)
Adds all fields with the specified Annotation of class clazz and its superclasses to allFields
static void addAllInterfaces(Class clazz, List<Class> allInterfaces)
static void addAllMethods(Class annotationClass, Class clazz, List<Method> allMethods)
Adds all methods with the specified Annotation of class clazz and its superclasses to allFields
static String[] find(Class clazz, String pckgname)
Retrieves all classes within a packages.
static List<Method> findAnnotatedMethods(Class clazz, Class<? extends Annotation> annotationClass)
Deprecated. since 2.0.4 use getAnnotatedMethods
static void findRecursively(Class clazz, Class<? extends Annotation> annotationClass, List<Method> methods)
Deprecated. since 2.0.4 use getAnnotatedMethods
static Collection<Method> getAnnotatedMethods(Class clazz, Class<? extends Annotation>... annotation)
For the given Class get a collection of the the AnnotatedElements that match the given annotations or if no annotations are specified then return all of the annotated elements of the given Class.
static boolean isAnnotatedBy(AnnotatedElement annotatedElement, Class<? extends Annotation>... annotation)
Varargs version of AnnotatedElement.isAnnotationPresent()
static String resolvePropertyName(Method method)
Returns the property name for a method.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AnnotationUtils

public AnnotationUtils()
Method Detail

addAllFields

public static void addAllFields(Class annotationClass,
                                Class clazz,
                                List<Field> allFields)
Adds all fields with the specified Annotation of class clazz and its superclasses to allFields

Parameters:
annotationClass -
clazz -
allFields -

addAllMethods

public static void addAllMethods(Class annotationClass,
                                 Class clazz,
                                 List<Method> allMethods)
Adds all methods with the specified Annotation of class clazz and its superclasses to allFields

Parameters:
annotationClass -
clazz -
allMethods -

addAllInterfaces

public static void addAllInterfaces(Class clazz,
                                    List<Class> allInterfaces)
Parameters:
clazz -
allInterfaces -

getAnnotatedMethods

public static final Collection<Method> getAnnotatedMethods(Class clazz,
                                                           Class<? extends Annotation>... annotation)
For the given Class get a collection of the the AnnotatedElements that match the given annotations or if no annotations are specified then return all of the annotated elements of the given Class. Includes only the method level annotations.

Parameters:
clazz - The Class to inspect
annotation - the Annotations to find
Returns:
A Collection<AnnotatedElement> containing all of the method AnnotatedElements matching the specified Annotations

isAnnotatedBy

public static final boolean isAnnotatedBy(AnnotatedElement annotatedElement,
                                          Class<? extends Annotation>... annotation)
Varargs version of AnnotatedElement.isAnnotationPresent()

See Also:
AnnotatedElement

findAnnotatedMethods

@Deprecated
public static List<Method> findAnnotatedMethods(Class clazz,
                                                           Class<? extends Annotation> annotationClass)
Deprecated. since 2.0.4 use getAnnotatedMethods

findRecursively

@Deprecated
public static void findRecursively(Class clazz,
                                              Class<? extends Annotation> annotationClass,
                                              List<Method> methods)
Deprecated. since 2.0.4 use getAnnotatedMethods

resolvePropertyName

public static String resolvePropertyName(Method method)
Returns the property name for a method. This method is independant from property fields.

Parameters:
method - The method to get the property name for.
Returns:
the property name for given method; null if non could be resolved.

find

public static String[] find(Class clazz,
                            String pckgname)
Retrieves all classes within a packages. TODO: this currently does not work with jars.

Parameters:
pckgname -
Returns:
Array of full qualified class names from this package.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ArrayUtils (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ArrayUtils

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ArrayUtils

public class ArrayUtils
extends Object

Author:
Dan Oxlade, dan d0t oxlade at gmail d0t c0m

Constructor Summary
ArrayUtils()
Method Summary
static boolean | isEmpty(Object[] array)
static boolean | isNotEmpty(Object[] array)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ArrayUtils

public ArrayUtils()
Method Detail

isEmpty

public static boolean isEmpty(Object[] array)

isNotEmpty

public static boolean isNotEmpty(Object[] array)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClassLoaderUtil (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ClassLoaderUtil

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ClassLoaderUtil

public class ClassLoaderUtil
extends Object

This class is extremely useful for loading resources and classes in a fault tolerant manner that works across different applications servers. It has come out of many months of frustrating use of multiple application servers at Atlassian, please don't change things unless you're sure they're not going to break in one server or another! It was brought in from oscore trunk revision 147.

Version:
$Revision: 117 $
Author:
$Author: hani $

Constructor Summary
ClassLoaderUtil()
Method Summary
static URL | getResource(String resourceName, Class callingClass) Load a given resource.
static InputStream | getResourceAsStream(String resourceName, Class callingClass) This is a convenience method to load a resource as a stream.
static Iterator<URL> | getResources(String resourceName, Class callingClass, boolean aggregate) Load all resources with a given name, potentially aggregating all results from the searched classloaders.
static Class | loadClass(String className, Class callingClass) Load a class with a given name.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ClassLoaderUtil

public ClassLoaderUtil()
Method Detail

getResources

public static Iterator<URL> getResources(String resourceName,
                                         Class callingClass,
                                         boolean aggregate)
                                  throws IOException
Load all resources with a given name, potentially aggregating all results from the searched classloaders. If no results are found, the resource name is prepended by '/' and tried again. This method will try to load the resources using the following methods (in order):
  • From Thread.currentThread().getContextClassLoader()
  • From ClassLoaderUtil.class.getClassLoader()
  • callingClass.getClassLoader()

Parameters:
resourceName - The name of the resources to load
callingClass - The Class object of the calling object
Throws:
IOException

getResource

public static URL getResource(String resourceName,
                              Class callingClass)
Load a given resource. This method will try to load the resource using the following methods (in order):
  • From Thread.currentThread().getContextClassLoader()
  • From ClassLoaderUtil.class.getClassLoader()
  • callingClass.getClassLoader()

Parameters:
resourceName - The name IllegalStateException("Unable to call ")of the resource to load
callingClass - The Class object of the calling object

getResourceAsStream

public static InputStream getResourceAsStream(String resourceName,
                                              Class callingClass)
This is a convenience method to load a resource as a stream. The algorithm used to find the resource is given in getResource()

Parameters:
resourceName - The name of the resource to load
callingClass - The Class object of the calling object

loadClass

public static Class loadClass(String className,
                              Class callingClass)
                       throws ClassNotFoundException
Load a class with a given name. It will try to load the class in the following order:
  • From Thread.currentThread().getContextClassLoader()
  • Using the basic Class.forName()
  • From ClassLoaderUtil.class.getClassLoader()
  • From the callingClass.getClassLoader()

Parameters:
className - The name of the class to load
callingClass - The Class object of the calling object
Throws:
ClassNotFoundException - If the class cannot be found anywhere.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClassPathFinder (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ClassPathFinder

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ClassPathFinder

public class ClassPathFinder
extends Object

This class is an utility class that will search through the classpath for files whose names match the given pattern. The filename is tested using the given implementation of PatternMatcher by default it uses WildcardHelper

Version:
$Rev: $ $Date: $

Constructor Summary
ClassPathFinder()
Method Summary
Vector<String> | findMatches() Builds a Vector containing Strings which each name a file who's name matches the pattern set by setPattern(String).
String | getPattern() retrieves the pattern in use
void | setPattern(String pattern) sets the String pattern for comparing filenames
void | setPatternMatcher(PatternMatcher<int[]> patternMatcher) sets the PatternMatcher implementation to use when comparing filenames
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ClassPathFinder

public ClassPathFinder()
Method Detail

getPattern

public String getPattern()
retrieves the pattern in use

setPattern

public void setPattern(String pattern)
sets the String pattern for comparing filenames

Parameters:
pattern -

findMatches

public Vector<String> findMatches()
Builds a Vector containing Strings which each name a file who's name matches the pattern set by setPattern(String). The classpath is searched recursively, so use with caution.

Returns:
Vector containing matching filenames

setPatternMatcher

public void setPatternMatcher(PatternMatcher<int[]> patternMatcher)
sets the PatternMatcher implementation to use when comparing filenames

Parameters:
patternMatcher -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClearableValueStack (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Interface ClearableValueStack

All Known Implementing Classes:
OgnlValueStack
public interface ClearableValueStack

ValueStacks implementing this interface provide a way to remove values from their contexts.

Method Summary
 void clearContextValues()
Remove all values from the context

Method Detail

clearContextValues

void clearContextValues()
Remove all values from the context

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CompoundRoot (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class CompoundRoot

java.lang.Object
    extended by  java.util.AbstractCollection<E>
        extended by  java.util.AbstractList<E>
            extended by  java.util.ArrayList
                extended by  com.opensymphony.xwork2.util.CompoundRoot
All Implemented Interfaces:
Serializable, Cloneable, Iterable, Collection, List, RandomAccess
public class CompoundRoot
extends ArrayList

A Stack that is implemented using a List.

Version:
$Revision: 1063 $
Author:
plightbo
See Also:
Serialized Form

Field Summary
Fields inherited from class java.util.AbstractList
modCount
Constructor Summary
CompoundRoot()
CompoundRoot(List list)
Method Summary
CompoundRoot | cutStack(int index)
Object | peek()
Object | pop()
void | push(Object o)
Methods inherited from class java.util.ArrayList
add, add, addAll, addAll, clear, clone, contains, ensureCapacity, get, indexOf, isEmpty, lastIndexOf, remove, remove, removeRange, set, size, toArray, toArray, trimToSize
Methods inherited from class java.util.AbstractList
equals, hashCode, iterator, listIterator, listIterator, subList
Methods inherited from class java.util.AbstractCollection
containsAll, removeAll, retainAll, toString
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.List
containsAll, equals, hashCode, iterator, listIterator, listIterator, removeAll, retainAll, subList

Constructor Detail

CompoundRoot

public CompoundRoot()

CompoundRoot

public CompoundRoot(List list)
Method Detail

cutStack

public CompoundRoot cutStack(int index)

peek

public Object peek()

pop

public Object pop()

push

public void push(Object o)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CreateIfNull (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.util
Annotation Type CreateIfNull

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface CreateIfNull

Sets the CreateIfNull for type conversion.

Annotation usage:

The CreateIfNull annotation must be applied at field or method level.

Annotation parameters:

Parameter | Required | Default | Description
value | no | false | The CreateIfNull property value.

Example code:

 @CreateIfNull( value = true )
 private List users;

Version:
$Id: CreateIfNull.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns

Optional Element Summary
 boolean value
The CreateIfNull value.

value

public abstract boolean value
The CreateIfNull value. Defaults to true.

Default:
true
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


DomHelper (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class DomHelper

java.lang.Object
    extended by  com.opensymphony.xwork2.util.DomHelper

public class DomHelper
extends Object

Helper class to create and retrieve information from location-enabled DOM-trees.

Since:
1.2

Nested Class Summary
static class | DomHelper.DOMBuilder The DOMBuilder is a utility class that will generate a W3C DOM Document from SAX events.
static class | DomHelper.StartHandler
Field Summary
static String XMLNS_URI
Constructor Summary
DomHelper()
Method Summary
static Location | getLocationObject(Element element)
static Document | parse(InputSource inputSource) Creates a W3C Document that remembers the location of each element in the source file.
static Document | parse(InputSource inputSource, Map<String,String> dtdMappings) Creates a W3C Document that remembers the location of each element in the source file.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

XMLNS_URI

public static final String XMLNS_URI
See Also:
Constant Field Values
Constructor Detail

DomHelper

public DomHelper()
Method Detail

getLocationObject

public static Location getLocationObject(Element element)

parse

public static Document parse(InputSource inputSource)
Creates a W3C Document that remembers the location of each element in the source file. The location of element nodes can then be retrieved using the getLocationObject(Element) method.

Parameters:
inputSource - the inputSource to read the document from

parse

public static Document parse(InputSource inputSource,
                             Map<String,String> dtdMappings)
Creates a W3C Document that remembers the location of each element in the source file. The location of element nodes can then be retrieved using the getLocationObject(Element) method.

Parameters:
inputSource - the inputSource to read the document from
dtdMappings - a map of DTD names and public ids
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DomHelper.DOMBuilder (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class DomHelper.DOMBuilder

java.lang.Object
    extended by  com.opensymphony.xwork2.util.DomHelper.DOMBuilder
All Implemented Interfaces:
ContentHandler
Enclosing class:
DomHelper
public static class DomHelper.DOMBuilder
extends Object
implements ContentHandler

The DOMBuilder is a utility class that will generate a W3C DOM Document from SAX events.

Author:
Carsten Ziegeler

Field Summary
protected SAXTransformerFactory | factory The transformer factory
protected static SAXTransformerFactory | FACTORY The default transformer factory shared by all instances
protected ContentHandler | nextHandler
protected Node | parentNode The parentNode
protected DOMResult | result The result
Constructor Summary
DomHelper.DOMBuilder()
Construct a new instance of this DOMBuilder.
DomHelper.DOMBuilder(Node parentNode)
Constructs a new instance that appends nodes to the given parent node.
DomHelper.DOMBuilder(SAXTransformerFactory factory)
Construct a new instance of this DOMBuilder.
DomHelper.DOMBuilder(SAXTransformerFactory factory, Node parentNode)
Construct a new instance of this DOMBuilder.
Method Summary
void | characters(char[] arg0, int arg1, int arg2)
void | endDocument()
void | endElement(String arg0, String arg1, String arg2)
void | endPrefixMapping(String arg0)
Document | getDocument() Return the newly built Document.
void | ignorableWhitespace(char[] arg0, int arg1, int arg2)
void | processingInstruction(String arg0, String arg1)
void | setDocumentLocator(Locator locator)
void | skippedEntity(String arg0)
void | startDocument()
void | startElement(String uri, String loc, String raw, Attributes attrs)
void | startPrefixMapping(String arg0, String arg1)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FACTORY

protected static SAXTransformerFactory FACTORY
The default transformer factory shared by all instances

factory

protected SAXTransformerFactory factory
The transformer factory

result

protected DOMResult result
The result

parentNode

protected Node parentNode
The parentNode

nextHandler

protected ContentHandler nextHandler
Constructor Detail

DomHelper.DOMBuilder

public DomHelper.DOMBuilder()
Construct a new instance of this DOMBuilder.

DomHelper.DOMBuilder

public DomHelper.DOMBuilder(SAXTransformerFactory factory)
Construct a new instance of this DOMBuilder.

DomHelper.DOMBuilder

public DomHelper.DOMBuilder(Node parentNode)
Constructs a new instance that appends nodes to the given parent node.

DomHelper.DOMBuilder

public DomHelper.DOMBuilder(SAXTransformerFactory factory,
                            Node parentNode)
Construct a new instance of this DOMBuilder.

Method Detail

getDocument

public Document getDocument()
Return the newly built Document.

setDocumentLocator

public void setDocumentLocator(Locator locator)
Specified by:
setDocumentLocator in interface ContentHandler

startDocument

public void startDocument()
                   throws SAXException
Specified by:
startDocument in interface ContentHandler
Throws:
SAXException

endDocument

public void endDocument()
                 throws SAXException
Specified by:
endDocument in interface ContentHandler
Throws:
SAXException

startElement

public void startElement(String uri,
                         String loc,
                         String raw,
                         Attributes attrs)
                  throws SAXException
Specified by:
startElement in interface ContentHandler
Throws:
SAXException

endElement

public void endElement(String arg0,
                       String arg1,
                       String arg2)
                throws SAXException
Specified by:
endElement in interface ContentHandler
Throws:
SAXException

startPrefixMapping

public void startPrefixMapping(String arg0,
                               String arg1)
                        throws SAXException
Specified by:
startPrefixMapping in interface ContentHandler
Throws:
SAXException

endPrefixMapping

public void endPrefixMapping(String arg0)
                      throws SAXException
Specified by:
endPrefixMapping in interface ContentHandler
Throws:
SAXException

characters

public void characters(char[] arg0,
                       int arg1,
                       int arg2)
                throws SAXException
Specified by:
characters in interface ContentHandler
Throws:
SAXException

ignorableWhitespace

public void ignorableWhitespace(char[] arg0,
                                int arg1,
                                int arg2)
                         throws SAXException
Specified by:
ignorableWhitespace in interface ContentHandler
Throws:
SAXException

processingInstruction

public void processingInstruction(String arg0,
                                  String arg1)
                           throws SAXException
Specified by:
processingInstruction in interface ContentHandler
Throws:
SAXException

skippedEntity

public void skippedEntity(String arg0)
                   throws SAXException
Specified by:
skippedEntity in interface ContentHandler
Throws:
SAXException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DomHelper.StartHandler (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class DomHelper.StartHandler

java.lang.Object
    extended by  org.xml.sax.helpers.DefaultHandler
        extended by  com.opensymphony.xwork2.util.DomHelper.StartHandler
All Implemented Interfaces:
ContentHandler, DTDHandler, EntityResolver, ErrorHandler
Enclosing class:
DomHelper
public static class DomHelper.StartHandler
extends DefaultHandler

Constructor Summary
DomHelper.StartHandler(ContentHandler next, Map<String,String> dtdMappings)
Create a filter that is chained to another handler.
Method Summary
void | characters(char[] arg0, int arg1, int arg2)
void | endDocument()
void | endElement(String arg0, String arg1, String arg2)
void | endPrefixMapping(String arg0)
void | error(SAXParseException exception)
void | fatalError(SAXParseException exception)
void | ignorableWhitespace(char[] arg0, int arg1, int arg2)
void | processingInstruction(String arg0, String arg1)
InputSource | resolveEntity(String publicId, String systemId)
void | setDocumentLocator(Locator locator)
void | skippedEntity(String arg0)
void | startDocument()
void | startElement(String uri, String loc, String raw, Attributes attrs)
void | startPrefixMapping(String arg0, String arg1)
void | warning(SAXParseException exception)
Methods inherited from class org.xml.sax.helpers.DefaultHandler
notationDecl, unparsedEntityDecl
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DomHelper.StartHandler

public DomHelper.StartHandler(ContentHandler next,
                              Map<String,String> dtdMappings)
Create a filter that is chained to another handler.

Parameters:
next - the next handler in the chain.
Method Detail

setDocumentLocator

public void setDocumentLocator(Locator locator)
Specified by:
setDocumentLocator in interface ContentHandler
Overrides:
setDocumentLocator in class DefaultHandler

startDocument

public void startDocument()
                   throws SAXException
Specified by:
startDocument in interface ContentHandler
Overrides:
startDocument in class DefaultHandler
Throws:
SAXException

endDocument

public void endDocument()
                 throws SAXException
Specified by:
endDocument in interface ContentHandler
Overrides:
endDocument in class DefaultHandler
Throws:
SAXException

startElement

public void startElement(String uri,
                         String loc,
                         String raw,
                         Attributes attrs)
                  throws SAXException
Specified by:
startElement in interface ContentHandler
Overrides:
startElement in class DefaultHandler
Throws:
SAXException

endElement

public void endElement(String arg0,
                       String arg1,
                       String arg2)
                throws SAXException
Specified by:
endElement in interface ContentHandler
Overrides:
endElement in class DefaultHandler
Throws:
SAXException

startPrefixMapping

public void startPrefixMapping(String arg0,
                               String arg1)
                        throws SAXException
Specified by:
startPrefixMapping in interface ContentHandler
Overrides:
startPrefixMapping in class DefaultHandler
Throws:
SAXException

endPrefixMapping

public void endPrefixMapping(String arg0)
                      throws SAXException
Specified by:
endPrefixMapping in interface ContentHandler
Overrides:
endPrefixMapping in class DefaultHandler
Throws:
SAXException

characters

public void characters(char[] arg0,
                       int arg1,
                       int arg2)
                throws SAXException
Specified by:
characters in interface ContentHandler
Overrides:
characters in class DefaultHandler
Throws:
SAXException

ignorableWhitespace

public void ignorableWhitespace(char[] arg0,
                                int arg1,
                                int arg2)
                         throws SAXException
Specified by:
ignorableWhitespace in interface ContentHandler
Overrides:
ignorableWhitespace in class DefaultHandler
Throws:
SAXException

processingInstruction

public void processingInstruction(String arg0,
                                  String arg1)
                           throws SAXException
Specified by:
processingInstruction in interface ContentHandler
Overrides:
processingInstruction in class DefaultHandler
Throws:
SAXException

skippedEntity

public void skippedEntity(String arg0)
                   throws SAXException
Specified by:
skippedEntity in interface ContentHandler
Overrides:
skippedEntity in class DefaultHandler
Throws:
SAXException

resolveEntity

public InputSource resolveEntity(String publicId,
                                 String systemId)
Specified by:
resolveEntity in interface EntityResolver
Overrides:
resolveEntity in class DefaultHandler

warning

public void warning(SAXParseException exception)
Specified by:
warning in interface ErrorHandler
Overrides:
warning in class DefaultHandler

error

public void error(SAXParseException exception)
           throws SAXException
Specified by:
error in interface ErrorHandler
Overrides:
error in class DefaultHandler
Throws:
SAXException

fatalError

public void fatalError(SAXParseException exception)
                throws SAXException
Specified by:
fatalError in interface ErrorHandler
Overrides:
fatalError in class DefaultHandler
Throws:
SAXException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Element (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.util
Annotation Type Element

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface Element

Sets the Element for type conversion.

Annotation usage:

The Element annotation must be applied at field or method level.

Annotation parameters:

Parameter | Required | Default | Description
value | no | java.lang.Object.class | The element property value.

Example code:

 // The key property for User objects within the users collection is the userName attribute.
 @Element( value = com.acme.User )
 private Map userMap;

 @Element( value = com.acme.User )
 public List userList;

Version:
$Id: Element.java 1351 2007-02-16 09:11:20Z rainerh $
Author:
Rainer Hermanns

Optional Element Summary
 Class value
The Element value.

value

public abstract Class value
The Element value. Defaults to java.lang.Object.class.

Default:
java.lang.Object.class
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


FileManager (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class FileManager

java.lang.Object
    extended by  com.opensymphony.xwork2.util.FileManager

public class FileManager
extends Object

FileManager

This class was brought in from oscore trunk revision 147.

Author:
Jason Carreira Created May 7, 2003 8:44:26 PM

Field Summary
protected static boolean reloadingConfigs
Method Summary
static boolean | fileNeedsReloading(String fileName)
static boolean | fileNeedsReloading(String fileName, Class clazz)
static boolean | isReloadingConfigs()
static InputStream | loadFile(String fileName, Class clazz) Loads opens the named file and returns the InputStream
static InputStream | loadFile(URL fileUrl) Loads opens the named file and returns the InputStream
static InputStream | loadFile(URL fileUrl, boolean openStream) Loads opens the named file and returns the InputStream
static void | setReloadingConfigs(boolean reloadingConfigs)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

reloadingConfigs

protected static boolean reloadingConfigs
Method Detail

setReloadingConfigs

public static void setReloadingConfigs(boolean reloadingConfigs)

isReloadingConfigs

public static boolean isReloadingConfigs()

fileNeedsReloading

public static boolean fileNeedsReloading(String fileName,
                                         Class clazz)

fileNeedsReloading

public static boolean fileNeedsReloading(String fileName)

loadFile

public static InputStream loadFile(String fileName,
                                   Class clazz)
Loads opens the named file and returns the InputStream

Parameters:
fileName - - the name of the file to open
Returns:
an InputStream of the file contents or null
Throws:
IllegalArgumentException - if there is no file with the given file name

loadFile

public static InputStream loadFile(URL fileUrl)
Loads opens the named file and returns the InputStream

Parameters:
fileUrl - - the URL of the file to open
Returns:
an InputStream of the file contents or null
Throws:
IllegalArgumentException - if there is no file with the given file name

loadFile

public static InputStream loadFile(URL fileUrl,
                                   boolean openStream)
Loads opens the named file and returns the InputStream

Parameters:
fileUrl - - the URL of the file to open
openStream - - if true, open an InputStream to the file and return it
Returns:
an InputStream of the file contents or null
Throws:
IllegalArgumentException - if there is no file with the given file name
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Key (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.util
Annotation Type Key

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface Key

Sets the Key for type conversion.

Annotation usage:

The Key annotation must be applied at field or method level.

Annotation parameters:

Parameter | Required | Default | Description
value | no | java.lang.Object.class | The key property value.

Example code:

 // The key property for User objects within the users collection is the userName attribute.
 @Key( value = java.lang.Long.class )
 private Map userMap;

Version:
$Id: Key.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns

Optional Element Summary
 Class value
The Key value.

value

public abstract Class value
The Key value. Defaults to java.lang.Object.class.

Default:
java.lang.Object.class
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


KeyProperty (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.util
Annotation Type KeyProperty

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface KeyProperty

Sets the KeyProperty for type conversion.

Annotation usage:

The KeyProperty annotation must be applied at field or method level.

This annotation should be used with Generic types, if the key property of the key element needs to be specified.

Annotation parameters:

Parameter | Required | Default | Description
value | no | id | The key property value.

Example code:

 // The key property for User objects within the users collection is the userName attribute.
 @KeyProperty( value = "userName" )
 protected List users = null;

Author:
Patrick Lightbody, Rainer Hermanns

Optional Element Summary
 String value
The KeyProperty value.

value

public abstract String value
The KeyProperty value. Defaults to the id attribute.

Default:
"id"
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


LocalizedTextUtil (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class LocalizedTextUtil

java.lang.Object
    extended by  com.opensymphony.xwork2.util.LocalizedTextUtil

public class LocalizedTextUtil
extends Object

Provides support for localization in XWork.

Resource bundles are searched in the following order:

  1. ActionClass.properties
  2. Interface.properties (every interface and sub-interface)
  3. BaseClass.properties (all the way to Object.properties)
  4. ModelDriven's model (if implements ModelDriven), for the model object repeat from 1
  5. package.properties (of the directory where class is located and every parent directory all the way to the root directory)
  6. search up the i18n message key hierarchy itself
  7. global resource properties

To clarify #5, while traversing the package hierarchy, Struts 2 will look for a file package.properties:

com/
acme/
package.properties
actions/
package.properties
FooAction.java
FooAction.properties

If FooAction.properties does not exist, com/acme/action/package.properties will be searched for, if not found com/acme/package.properties, if not found com/package.properties, etc.

A global resource bundle could be specified programatically, as well as the locale.

Version:
$Date: 2009-07-23 19:46:50 +0200 (Do, 23 Jul 2009) $ $Id: LocalizedTextUtil.java 2026 2009-07-23 17:46:50Z musachy $
Author:
Jason Carreira, Mark Woon, Rainer Hermanns, tm_jee

Constructor Summary
LocalizedTextUtil()
Method Summary
static void addDefaultResourceBundle(String resourceBundleName)
Add's the bundle to the internal list of default bundles.
static void clearBundle(String bundleName)
Removes the bundle from any cached "misses"
static void clearDefaultResourceBundles()
Clears the internal list of resource bundles.
static String findDefaultText(String aTextName, Locale locale)
Returns a localized message for the specified key, aTextName.
static String findDefaultText(String aTextName, Locale locale, Object[] params)
Returns a localized message for the specified key, aTextName, substituting variables from the array of params into the message.
static ResourceBundle findResourceBundle(String aBundleName, Locale locale)
Finds the given resorce bundle by it's name.
static String findText(Class aClass, String aTextName, Locale locale)
Calls findText(Class aClass, String aTextName, Locale locale, String defaultMessage, Object[] args) with aTextName as the default message.
static String findText(Class aClass, String aTextName, Locale locale, String defaultMessage, Object[] args)
Finds a localized text message for the given key, aTextName.
static String findText(Class aClass, String aTextName, Locale locale, String defaultMessage, Object[] args, ValueStack valueStack)
Finds a localized text message for the given key, aTextName.
static String findText(ResourceBundle bundle, String aTextName, Locale locale)
Finds a localized text message for the given key, aTextName, in the specified resource bundle with aTextName as the default message.
static String findText(ResourceBundle bundle, String aTextName, Locale locale, String defaultMessage, Object[] args)
Finds a localized text message for the given key, aTextName, in the specified resource bundle.
static String findText(ResourceBundle bundle, String aTextName, Locale locale, String defaultMessage, Object[] args, ValueStack valueStack)
Finds a localized text message for the given key, aTextName, in the specified resource bundle.
static Locale localeFromString(String localeStr, Locale defaultLocale)
Builds a Locale from a String of the form en_US_foo into a Locale with language "en", country "US" and variant "foo".
static void reset()
Clears all the internal lists.
static void setDelegatedClassLoader(ClassLoader classLoader)
Sets a ClassLoader to look up the bundle from if none can be found on the current thread's classloader
static void setReloadBundles(boolean reloadBundles)
Should resorce bundles be reloaded.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LocalizedTextUtil

public LocalizedTextUtil()
Method Detail

clearDefaultResourceBundles

public static void clearDefaultResourceBundles()
Clears the internal list of resource bundles.

setReloadBundles

public static void setReloadBundles(boolean reloadBundles)
Should resorce bundles be reloaded.

Parameters:
reloadBundles - reload bundles?

addDefaultResourceBundle

public static void addDefaultResourceBundle(String resourceBundleName)
Add's the bundle to the internal list of default bundles.

If the bundle already exists in the list it will be readded.

Parameters:
resourceBundleName - the name of the bundle to add.

localeFromString

public static Locale localeFromString(String localeStr,
                                      Locale defaultLocale)
Builds a Locale from a String of the form en_US_foo into a Locale with language "en", country "US" and variant "foo". This will parse the output of Locale.toString().

Parameters:
localeStr - The locale String to parse.
defaultLocale - The locale to use if localeStr is null.
Returns:
requested Locale

findDefaultText

public static String findDefaultText(String aTextName,
                                     Locale locale)
Returns a localized message for the specified key, aTextName. Neither the key nor the message is evaluated.

Parameters:
aTextName - the message key
locale - the locale the message should be for
Returns:
a localized message based on the specified key, or null if no localized message can be found for it

findDefaultText

public static String findDefaultText(String aTextName,
                                     Locale locale,
                                     Object[] params)
Returns a localized message for the specified key, aTextName, substituting variables from the array of params into the message. Neither the key nor the message is evaluated.

Parameters:
aTextName - the message key
locale - the locale the message should be for
params - an array of objects to be substituted into the message text
Returns:
A formatted message based on the specified key, or null if no localized message can be found for it

findResourceBundle

public static ResourceBundle findResourceBundle(String aBundleName,
                                                Locale locale)
Finds the given resorce bundle by it's name.

Will use Thread.currentThread().getContextClassLoader() as the classloader. If delegatedClassLoader is defined and the bundle cannot be found the current classloader it will delegate to that.

Parameters:
aBundleName - the name of the bundle (usually it's FQN classname).
locale - the locale.
Returns:
the bundle, null if not found.

setDelegatedClassLoader

public static void setDelegatedClassLoader(ClassLoader classLoader)
Sets a ClassLoader to look up the bundle from if none can be found on the current thread's classloader

Parameters:
classLoader -

clearBundle

public static void clearBundle(String bundleName)
Removes the bundle from any cached "misses"

Parameters:
bundleName -

findText

public static String findText(Class aClass,
                              String aTextName,
                              Locale locale)
Calls findText(Class aClass, String aTextName, Locale locale, String defaultMessage, Object[] args) with aTextName as the default message.

See Also:
findText(Class aClass, String aTextName, Locale locale, String defaultMessage, Object[] args)

findText

public static String findText(Class aClass,
                              String aTextName,
                              Locale locale,
                              String defaultMessage,
                              Object[] args)
Finds a localized text message for the given key, aTextName. Both the key and the message itself is evaluated as required. The following algorithm is used to find the requested message:

  1. Look for message in aClass' class hierarchy.
    1. Look for the message in a resource bundle for aClass
    2. If not found, look for the message in a resource bundle for any implemented interface
    3. If not found, traverse up the Class' hierarchy and repeat from the first sub-step
  2. If not found and aClass is a ModelDriven Action, then look for message in the model's class hierarchy (repeat sub-steps listed above).
  3. If not found, look for message in child property. This is determined by evaluating the message key as an OGNL expression. For example, if the key is user.address.state, then it will attempt to see if "user" can be resolved into an object. If so, repeat the entire process fromthe beginning with the object's class as aClass and "address.state" as the message key.
  4. If not found, look for the message in aClass' package hierarchy.
  5. If still not found, look for the message in the default resource bundles.
  6. Return defaultMessage

When looking for the message, if the key indexes a collection (e.g. user.phone[0]) and a message for that specific key cannot be found, the general form will also be looked up (i.e. user.phone[*]).

If a message is found, it will also be interpolated. Anything within ${...} will be treated as an OGNL expression and evaluated as such.

Parameters:
aClass - the class whose name to use as the start point for the search
aTextName - the key to find the text message for
locale - the locale the message should be for
defaultMessage - the message to be returned if no text message can be found in any resource bundle
Returns:
the localized text, or null if none can be found and no defaultMessage is provided

findText

public static String findText(Class aClass,
                              String aTextName,
                              Locale locale,
                              String defaultMessage,
                              Object[] args,
                              ValueStack valueStack)
Finds a localized text message for the given key, aTextName. Both the key and the message itself is evaluated as required. The following algorithm is used to find the requested message:

  1. Look for message in aClass' class hierarchy.
    1. Look for the message in a resource bundle for aClass
    2. If not found, look for the message in a resource bundle for any implemented interface
    3. If not found, traverse up the Class' hierarchy and repeat from the first sub-step
  2. If not found and aClass is a ModelDriven Action, then look for message in the model's class hierarchy (repeat sub-steps listed above).
  3. If not found, look for message in child property. This is determined by evaluating the message key as an OGNL expression. For example, if the key is user.address.state, then it will attempt to see if "user" can be resolved into an object. If so, repeat the entire process fromthe beginning with the object's class as aClass and "address.state" as the message key.
  4. If not found, look for the message in aClass' package hierarchy.
  5. If still not found, look for the message in the default resource bundles.
  6. Return defaultMessage

When looking for the message, if the key indexes a collection (e.g. user.phone[0]) and a message for that specific key cannot be found, the general form will also be looked up (i.e. user.phone[*]).

If a message is found, it will also be interpolated. Anything within ${...} will be treated as an OGNL expression and evaluated as such.

If a message is not found a WARN log will be logged.

Parameters:
aClass - the class whose name to use as the start point for the search
aTextName - the key to find the text message for
locale - the locale the message should be for
defaultMessage - the message to be returned if no text message can be found in any resource bundle
valueStack - the value stack to use to evaluate expressions instead of the one in the ActionContext ThreadLocal
Returns:
the localized text, or null if none can be found and no defaultMessage is provided

findText

public static String findText(ResourceBundle bundle,
                              String aTextName,
                              Locale locale)
Finds a localized text message for the given key, aTextName, in the specified resource bundle with aTextName as the default message.

If a message is found, it will also be interpolated. Anything within ${...} will be treated as an OGNL expression and evaluated as such.

See Also:
findText(java.util.ResourceBundle, String, java.util.Locale, String, Object[])

findText

public static String findText(ResourceBundle bundle,
                              String aTextName,
                              Locale locale,
                              String defaultMessage,
                              Object[] args)
Finds a localized text message for the given key, aTextName, in the specified resource bundle.

If a message is found, it will also be interpolated. Anything within ${...} will be treated as an OGNL expression and evaluated as such.

If a message is not found a WARN log will be logged.

Parameters:
bundle - the bundle
aTextName - the key
locale - the locale
defaultMessage - the default message to use if no message was found in the bundle
args - arguments for the message formatter.

findText

public static String findText(ResourceBundle bundle,
                              String aTextName,
                              Locale locale,
                              String defaultMessage,
                              Object[] args,
                              ValueStack valueStack)
Finds a localized text message for the given key, aTextName, in the specified resource bundle.

If a message is found, it will also be interpolated. Anything within ${...} will be treated as an OGNL expression and evaluated as such.

If a message is not found a WARN log will be logged.

Parameters:
bundle - the bundle
aTextName - the key
locale - the locale
defaultMessage - the default message to use if no message was found in the bundle
args - arguments for the message formatter.
valueStack - the OGNL value stack.

reset

public static void reset()
Clears all the internal lists.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MemberAccessValueStack (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Interface MemberAccessValueStack

All Known Implementing Classes:
OgnlValueStack
public interface MemberAccessValueStack

ValueStacks implementing this interface provide a way to remove block or allow access to properties using regular expressions

Method Summary
void | setAcceptProperties(Set<Pattern> acceptedProperties)
void | setExcludeProperties(Set<Pattern> excludeProperties)

Method Detail

setExcludeProperties

void setExcludeProperties(Set<Pattern> excludeProperties)

setAcceptProperties

void setAcceptProperties(Set<Pattern> acceptedProperties)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NamedVariablePatternMatcher (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class NamedVariablePatternMatcher

java.lang.Object
    extended by  com.opensymphony.xwork2.util.NamedVariablePatternMatcher
All Implemented Interfaces:
PatternMatcher<NamedVariablePatternMatcher.CompiledPattern>
public class NamedVariablePatternMatcher
extends Object
implements PatternMatcher<NamedVariablePatternMatcher.CompiledPattern>

An implementation of a pattern matcher that uses simple named wildcards. The named wildcards are defined using the {VARIABLE_NAME} syntax and will match any characters that aren't '/'. Internally, the pattern is converted into a regular expression where the named wildcard will be translated into ([^/]+) so that at least one character must match in order for the wildcard to be matched successfully. Matched values will be available in the variable map, indexed by the name they were given in the pattern.

For example, the following patterns will be processed as so:

Pattern | Example | Variable Map Contents
/animals/{animal} | /animals/dog | {animal -> dog}
/animals/{animal}/tag/No{id} | /animals/dog/tag/No23 | {animal -> dog, id -> 23}
/{language} | /en | {language -> en}

Excaping hasn't been implemented since the intended use of these patterns will be in matching URLs.

Nested Class Summary
static class NamedVariablePatternMatcher.CompiledPattern
Stores the compiled pattern and the variable names matches will correspond to.
Constructor Summary
NamedVariablePatternMatcher()
Method Summary
NamedVariablePatternMatcher.CompiledPattern | compilePattern(String data) Compiles the pattern.
boolean | isLiteral(String pattern) Determines if the pattern is a simple literal string or contains wildcards that will need to be processed
boolean | match(Map<String,String> map, String data, NamedVariablePatternMatcher.CompiledPattern expr) Tries to process the data against the compiled expression.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NamedVariablePatternMatcher

public NamedVariablePatternMatcher()
Method Detail

isLiteral

public boolean isLiteral(String pattern)
Description copied from interface: PatternMatcher
Determines if the pattern is a simple literal string or contains wildcards that will need to be processed

Specified by:
isLiteral in interface PatternMatcher<NamedVariablePatternMatcher.CompiledPattern>
Parameters:
pattern - The string pattern
Returns:
True if the pattern doesn't contain processing elements, false otherwise

compilePattern

public NamedVariablePatternMatcher.CompiledPattern compilePattern(String data)
Compiles the pattern.

Specified by:
compilePattern in interface PatternMatcher<NamedVariablePatternMatcher.CompiledPattern>
Parameters:
data - The pattern, must not be null or empty
Returns:
The compiled pattern, null if the pattern was null or empty

match

public boolean match(Map<String,String> map,
                     String data,
                     NamedVariablePatternMatcher.CompiledPattern expr)
Tries to process the data against the compiled expression. If successful, the map will contain the matched data, using the specified variable names in the original pattern.

Specified by:
match in interface PatternMatcher<NamedVariablePatternMatcher.CompiledPattern>
Parameters:
map - The map of variables
data - The data to match
expr - The compiled pattern
Returns:
True if matched, false if not matched, the data was null, or the data was an empty string
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NamedVariablePatternMatcher.CompiledPattern (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class NamedVariablePatternMatcher.CompiledPattern

java.lang.Object
    extended by  com.opensymphony.xwork2.util.NamedVariablePatternMatcher.CompiledPattern
Enclosing class:
NamedVariablePatternMatcher
public static class NamedVariablePatternMatcher.CompiledPattern
extends Object

Stores the compiled pattern and the variable names matches will correspond to.

Constructor Summary
NamedVariablePatternMatcher.CompiledPattern(Pattern pattern, List<String> variableNames)
Method Summary
Pattern | getPattern()
List<String> | getVariableNames()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NamedVariablePatternMatcher.CompiledPattern

public NamedVariablePatternMatcher.CompiledPattern(Pattern pattern,
                                                   List<String> variableNames)
Method Detail

getPattern

public Pattern getPattern()

getVariableNames

public List<String> getVariableNames()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.util (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.util
Interfaces
ClearableValueStack
MemberAccessValueStack
PatternMatcher
ResolverUtil.Test
TextParseUtil.ParsedValueEvaluator
ValueStack
ValueStackFactory
Classes
AnnotationUtils
ArrayUtils
ClassLoaderUtil
ClassPathFinder
CompoundRoot
DomHelper
DomHelper.DOMBuilder
DomHelper.StartHandler
FileManager
LocalizedTextUtil
NamedVariablePatternMatcher
NamedVariablePatternMatcher.CompiledPattern
PropertiesReader
ResolverUtil
ResolverUtil.AnnotatedWith
ResolverUtil.ClassTest
ResolverUtil.IsA
ResolverUtil.NameEndsWith
ResolverUtil.NameIs
ResolverUtil.ResourceTest
TextParseUtil
URLUtil
WildcardHelper
XWorkList
XWorkTestCaseHelper
Annotation Types
CreateIfNull
Element
Key
KeyProperty


com.opensymphony.xwork2.util (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.util

XWork util classes.

See:
Description

Interface Summary
ClearableValueStack | ValueStacks implementing this interface provide a way to remove values from their contexts.
MemberAccessValueStack | ValueStacks implementing this interface provide a way to remove block or allow access to properties using regular expressions
PatternMatcher<E> | Compiles and matches a pattern against a value
ResolverUtil.Test | A simple interface that specifies how to test classes to determine if they are to be included in the results produced by the ResolverUtil.
TextParseUtil.ParsedValueEvaluator | A parsed value evaluator for TextParseUtil.
ValueStack | ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.
ValueStackFactory | Factory that creates a value stack, defaulting to the OgnlValueStackFactory

Class Summary
AnnotationUtils | AnnotationUtils Various utility methods dealing with annotations
ArrayUtils |
ClassLoaderUtil | This class is extremely useful for loading resources and classes in a fault tolerant manner that works across different applications servers.
ClassPathFinder | This class is an utility class that will search through the classpath for files whose names match the given pattern.
CompoundRoot | A Stack that is implemented using a List.
DomHelper | Helper class to create and retrieve information from location-enabled DOM-trees.
DomHelper.DOMBuilder | The DOMBuilder is a utility class that will generate a W3C DOM Document from SAX events.
DomHelper.StartHandler |
FileManager | FileManager This class was brought in from oscore trunk revision 147.
LocalizedTextUtil | Provides support for localization in XWork.
NamedVariablePatternMatcher | An implementation of a pattern matcher that uses simple named wildcards.
NamedVariablePatternMatcher.CompiledPattern | Stores the compiled pattern and the variable names matches will correspond to.
PropertiesReader | This class is used to read properties lines.
ResolverUtil<T> | ResolverUtil is used to locate classes that are available in the/a class path and meet arbitrary conditions.
ResolverUtil.AnnotatedWith | A Test that checks to see if each class is annotated with a specific annotation.
ResolverUtil.ClassTest |
ResolverUtil.IsA | A Test that checks to see if each class is assignable to the provided class.
ResolverUtil.NameEndsWith | A Test that checks to see if each class name ends with the provided suffix.
ResolverUtil.NameIs |
ResolverUtil.ResourceTest |
TextParseUtil | Utility class for text parsing.
URLUtil | Helper class to extract file paths from different urls
WildcardHelper | This class is an utility class that perform wilcard-patterns matching and isolation taken from Apache Cocoon.
XWorkList | A simple list that guarantees that inserting and retrieving objects will always work regardless of the current size of the list.
XWorkTestCaseHelper | Generic test setup methods to be used with any unit testing framework.

Annotation Types Summary
CreateIfNull | Sets the CreateIfNull for type conversion.
Element | Sets the Element for type conversion.
Key | Sets the Key for type conversion.
KeyProperty | Sets the KeyProperty for type conversion.

Package com.opensymphony.xwork2.util Description

XWork util classes.


com.opensymphony.xwork2.util Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.util

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.AbstractCollection<E> (implements java.util.Collection<E>)
      • java.util.AbstractList<E> (implements java.util.List<E>)
        • java.util.ArrayList<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
          • com.opensymphony.xwork2.util.CompoundRoot
          • com.opensymphony.xwork2.util.XWorkList
    • com.opensymphony.xwork2.util.AnnotationUtils
    • com.opensymphony.xwork2.util.ArrayUtils
    • com.opensymphony.xwork2.util.ClassLoaderUtil
    • com.opensymphony.xwork2.util.ClassPathFinder
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • com.opensymphony.xwork2.util.DomHelper.StartHandler
    • com.opensymphony.xwork2.util.DomHelper
    • com.opensymphony.xwork2.util.DomHelper.DOMBuilder (implements org.xml.sax.ContentHandler)
    • com.opensymphony.xwork2.util.FileManager
    • com.opensymphony.xwork2.util.LocalizedTextUtil
    • com.opensymphony.xwork2.util.NamedVariablePatternMatcher (implements com.opensymphony.xwork2.util.PatternMatcher<E>)
    • com.opensymphony.xwork2.util.NamedVariablePatternMatcher.CompiledPattern
    • java.io.Reader (implements java.io.Closeable, java.lang.Readable)
      • java.io.BufferedReader
        • java.io.LineNumberReader
          • com.opensymphony.xwork2.util.PropertiesReader
    • com.opensymphony.xwork2.util.ResolverUtil<T>
    • com.opensymphony.xwork2.util.ResolverUtil.ClassTest (implements com.opensymphony.xwork2.util.ResolverUtil.Test)
      • com.opensymphony.xwork2.util.ResolverUtil.AnnotatedWith
      • com.opensymphony.xwork2.util.ResolverUtil.IsA
      • com.opensymphony.xwork2.util.ResolverUtil.NameEndsWith
    • com.opensymphony.xwork2.util.ResolverUtil.ResourceTest (implements com.opensymphony.xwork2.util.ResolverUtil.Test)
      • com.opensymphony.xwork2.util.ResolverUtil.NameIs
    • com.opensymphony.xwork2.util.TextParseUtil
    • com.opensymphony.xwork2.util.URLUtil
    • com.opensymphony.xwork2.util.WildcardHelper (implements com.opensymphony.xwork2.util.PatternMatcher<E>)
    • com.opensymphony.xwork2.util.XWorkTestCaseHelper

Interface Hierarchy

  • com.opensymphony.xwork2.util.ClearableValueStack
  • com.opensymphony.xwork2.util.MemberAccessValueStack
  • com.opensymphony.xwork2.util.PatternMatcher<E>
  • com.opensymphony.xwork2.util.ResolverUtil.Test
  • com.opensymphony.xwork2.util.TextParseUtil.ParsedValueEvaluator
  • com.opensymphony.xwork2.util.ValueStack
  • com.opensymphony.xwork2.util.ValueStackFactory

Annotation Type Hierarchy

  • com.opensymphony.xwork2.util.KeyProperty (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.util.Key (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.util.Element (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.util.CreateIfNull (implements java.lang.annotation.Annotation)


Uses of Package com.opensymphony.xwork2.util (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.util

Packages that use com.opensymphony.xwork2.util
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.conversion.impl |
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.mock | XWork specific mock classes.
com.opensymphony.xwork2.ognl |
com.opensymphony.xwork2.util | XWork util classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Classes in com.opensymphony.xwork2.util used by com.opensymphony.xwork2
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.
ValueStackFactory
Factory that creates a value stack, defaulting to the OgnlValueStackFactory

Classes in com.opensymphony.xwork2.util used by com.opensymphony.xwork2.config.impl
PatternMatcher
Compiles and matches a pattern against a value

Classes in com.opensymphony.xwork2.util used by com.opensymphony.xwork2.conversion.impl
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by com.opensymphony.xwork2.interceptor
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.
ValueStackFactory
Factory that creates a value stack, defaulting to the OgnlValueStackFactory

Classes in com.opensymphony.xwork2.util used by com.opensymphony.xwork2.mock
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by com.opensymphony.xwork2.ognl
ClearableValueStack
ValueStacks implementing this interface provide a way to remove values from their contexts.
CompoundRoot
A Stack that is implemented using a List.
MemberAccessValueStack
ValueStacks implementing this interface provide a way to remove block or allow access to properties using regular expressions
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.
ValueStackFactory
Factory that creates a value stack, defaulting to the OgnlValueStackFactory

Classes in com.opensymphony.xwork2.util used by com.opensymphony.xwork2.util
CompoundRoot
A Stack that is implemented using a List.
NamedVariablePatternMatcher.CompiledPattern
Stores the compiled pattern and the variable names matches will correspond to.
PatternMatcher
Compiles and matches a pattern against a value
ResolverUtil.ClassTest
ResolverUtil.ResourceTest
ResolverUtil.Test
A simple interface that specifies how to test classes to determine if they are to be included in the results produced by the ResolverUtil.
TextParseUtil.ParsedValueEvaluator
A parsed value evaluator for TextParseUtil.
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by com.opensymphony.xwork2.validator
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by com.opensymphony.xwork2.validator.validators
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PatternMatcher (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Interface PatternMatcher<E>

All Known Implementing Classes:
NamedVariablePatternMatcher, WildcardHelper
public interface PatternMatcher<E>

Compiles and matches a pattern against a value

Since:
2.1

Method Summary
E | compilePattern(String data) Translate the given String into an object representing the pattern matchable by this class.
boolean | isLiteral(String pattern) Determines if the pattern is a simple literal string or contains wildcards that will need to be processed
boolean | match(Map<String,String> map, String data, E expr) Match a pattern against a string

Method Detail

isLiteral

boolean isLiteral(String pattern)
Determines if the pattern is a simple literal string or contains wildcards that will need to be processed

Parameters:
pattern - The string pattern
Returns:
True if the pattern doesn't contain processing elements, false otherwise

compilePattern

E compilePattern(String data)

Translate the given String into an object representing the pattern matchable by this class.

Parameters:
data - The string to translate.
Returns:
The encoded string
Throws:
NullPointerException - If data is null.

match

boolean match(Map<String,String> map,
              String data,
              E expr)
Match a pattern against a string

Parameters:
map - The map to store matched values
data - The string to match
expr - The compiled wildcard expression
Returns:
True if a match
Throws:
NullPointerException - If any parameters are null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertiesReader (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class PropertiesReader

java.lang.Object
    extended by  java.io.Reader
        extended by  java.io.BufferedReader
            extended by  java.io.LineNumberReader
                extended by  com.opensymphony.xwork2.util.PropertiesReader
All Implemented Interfaces:
Closeable, Readable
public class PropertiesReader
extends LineNumberReader

This class is used to read properties lines. These lines do not terminate with new-line chars but rather when there is no backslash sign a the end of the line. This is used to concatenate multiple lines for readability. This class was pulled out of Jakarta Commons Configuration and Jakarta Commons Lang trunk revision 476093

Field Summary
Fields inherited from class java.io.Reader
lock
Constructor Summary
PropertiesReader(Reader reader)
Constructor.
PropertiesReader(Reader reader, char listDelimiter)
Creates a new instance of PropertiesReader and sets the underlaying reader and the list delimiter.
Method Summary
boolean | contains(char[] array, char objectToFind) Checks if the object is in the given array.
List<String> | getCommentLines() Returns the comment lines that have been read for the last property.
String | getPropertyName() Returns the name of the last read property.
String | getPropertyValue() Returns the value of the last read property.
boolean | nextProperty() Parses the next property from the input stream and stores the found name and value in internal fields.
String | readProperty() Reads a property line.
static String | unescapeJava(String str) Unescapes any Java literals found in the String.
protected static String | unescapeJava(String str, char delimiter) Unescapes any Java literals found in the String to a Writer.
static void | unescapeJava(Writer out, String str) Unescapes any Java literals found in the String to a Writer.
Methods inherited from class java.io.LineNumberReader
getLineNumber, mark, read, read, readLine, reset, setLineNumber, skip
Methods inherited from class java.io.BufferedReader
close, markSupported, ready
Methods inherited from class java.io.Reader
read, read
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PropertiesReader

public PropertiesReader(Reader reader)
Constructor.

Parameters:
reader - A Reader.

PropertiesReader

public PropertiesReader(Reader reader,
                        char listDelimiter)
Creates a new instance of PropertiesReader and sets the underlaying reader and the list delimiter.

Parameters:
reader - the reader
listDelimiter - the list delimiter character
Since:
1.3
Method Detail

readProperty

public String readProperty()
                    throws IOException
Reads a property line. Returns null if Stream is at EOF. Concatenates lines ending with "\". Skips lines beginning with "#" or "!" and empty lines. The return value is a property definition (<name> = <value>)

Returns:
A string containing a property value or null
Throws:
IOException - in case of an I/O error

nextProperty

public boolean nextProperty()
                     throws IOException
Parses the next property from the input stream and stores the found name and value in internal fields. These fields can be obtained using the provided getter methods. The return value indicates whether EOF was reached (false) or whether further properties are available (true).

Returns:
a flag if further properties are available
Throws:
IOException - if an error occurs
Since:
1.3

getCommentLines

public List<String> getCommentLines()
Returns the comment lines that have been read for the last property.

Returns:
the comment lines for the last property returned by readProperty()
Since:
1.3

getPropertyName

public String getPropertyName()
Returns the name of the last read property. This method can be called after nextProperty() was invoked and its return value was true.

Returns:
the name of the last read property
Since:
1.3

getPropertyValue

public String getPropertyValue()
Returns the value of the last read property. This method can be called after nextProperty() was invoked and its return value was true.

Returns:
the value of the last read property
Since:
1.3

unescapeJava

protected static String unescapeJava(String str,
                                     char delimiter)

Unescapes any Java literals found in the String to a Writer.

This is a slightly modified version of the StringEscapeUtils.unescapeJava() function in commons-lang that doesn't drop escaped separators (i.e '\,').

Parameters:
str - the String to unescape, may be null
delimiter - the delimiter for multi-valued properties
Returns:
the processed string
Throws:
IllegalArgumentException - if the Writer is null

contains

public boolean contains(char[] array,
                        char objectToFind)

Checks if the object is in the given array.

The method returns false if a null array is passed in.

Parameters:
array - the array to search through
objectToFind - the object to find
Returns:
true if the array contains the object

unescapeJava

public static String unescapeJava(String str)

Unescapes any Java literals found in the String. For example, it will turn a sequence of '\' and 'n' into a newline character, unless the '\' is preceded by another '\'.

Parameters:
str - the String to unescape, may be null
Returns:
a new unescaped String, null if null string input

unescapeJava

public static void unescapeJava(Writer out,
                                String str)
                         throws IOException

Unescapes any Java literals found in the String to a Writer.

For example, it will turn a sequence of '\' and 'n' into a newline character, unless the '\' is preceded by another '\'.

A null string input has no effect.

Parameters:
out - the Writer used to output unescaped characters
str - the String to unescape, may be null
Throws:
IllegalArgumentException - if the Writer is null
IOException - if error occurs on underlying Writer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResolverUtil (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ResolverUtil<T>

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ResolverUtil<T>

public class ResolverUtil<T>
extends Object

ResolverUtil is used to locate classes that are available in the/a class path and meet arbitrary conditions. The two most common conditions are that a class implements/extends another class, or that is it annotated with a specific annotation. However, through the use of the ResolverUtil.Test class it is possible to search using arbitrary conditions.

A ClassLoader is used to locate all locations (directories and jar files) in the class path that contain classes within certain packages, and then to load those classes and check them. By default the ClassLoader returned by Thread.currentThread().getContextClassLoader() is used, but this can be overridden by calling setClassLoader(ClassLoader) prior to invoking any of the find() methods.

General searches are initiated by calling the find(com.opensymphony.xwork2.util.ResolverUtil.Test, String...) ()} method and supplying a package name and a Test instance. This will cause the named package and all sub-packages to be scanned for classes that meet the test. There are also utility methods for the common use cases of scanning multiple packages for extensions of particular classes, or classes annotated with a specific annotation.

The standard usage pattern for the ResolverUtil class is as follows:

ResolverUtil<ActionBean> resolver = new ResolverUtil<ActionBean>();
resolver.findImplementation(ActionBean.class, pkg1, pkg2);
resolver.find(new CustomTest(), pkg1);
resolver.find(new CustomTest(), pkg2);
Collection<ActionBean> beans = resolver.getClasses();

This class was copied from Stripes - http://stripes.mc4j.org/confluence/display/stripes/Home

Author:
Tim Fennell

Nested Class Summary
static class | ResolverUtil.AnnotatedWith A Test that checks to see if each class is annotated with a specific annotation.
static class | ResolverUtil.ClassTest
static class | ResolverUtil.IsA A Test that checks to see if each class is assignable to the provided class.
static class | ResolverUtil.NameEndsWith A Test that checks to see if each class name ends with the provided suffix.
static class | ResolverUtil.NameIs
static class | ResolverUtil.ResourceTest
static interface | ResolverUtil.Test A simple interface that specifies how to test classes to determine if they are to be included in the results produced by the ResolverUtil.
Constructor Summary
ResolverUtil()
Method Summary
protected void | addIfMatching(ResolverUtil.Test test, String fqn) Add the class designated by the fully qualified class name provided to the set of resolved classes if and only if it is approved by the Test supplied.
void | find(ResolverUtil.Test test, String... packageNames) Attempts to discover classes that pass the test.
void | findAnnotated(Class<? extends Annotation> annotation, String... packageNames) Attempts to discover classes that are annotated with to the annotation.
void | findImplementations(Class parent, String... packageNames) Attempts to discover classes that are assignable to the type provided.
void | findInPackage(ResolverUtil.Test test, String packageName) Scans for classes starting at the package provided and descending into subpackages.
void | findNamedResource(String name, String... pathNames)
void | findSuffix(String suffix, String... packageNames) Attempts to discover classes who's name ends with the provided suffix.
Set<Class<? extends T>> | getClasses() Provides access to the classes discovered so far.
ClassLoader | getClassLoader() Returns the classloader that will be used for scanning for classes.
Set<URL> | getResources()
void | setClassLoader(ClassLoader classloader) Sets an explicit ClassLoader that should be used when scanning for classes.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResolverUtil

public ResolverUtil()
Method Detail

getClasses

public Set<Class<? extends T>> getClasses()
Provides access to the classes discovered so far. If no calls have been made to any of the find() methods, this set will be empty.

Returns:
the set of classes that have been discovered.

getResources

public Set<URL> getResources()

getClassLoader

public ClassLoader getClassLoader()
Returns the classloader that will be used for scanning for classes. If no explicit ClassLoader has been set by the calling, the context class loader will be used.

Returns:
the ClassLoader that will be used to scan for classes

setClassLoader

public void setClassLoader(ClassLoader classloader)
Sets an explicit ClassLoader that should be used when scanning for classes. If none is set then the context classloader will be used.

Parameters:
classloader - a ClassLoader to use when scanning for classes

findImplementations

public void findImplementations(Class parent,
                                String... packageNames)
Attempts to discover classes that are assignable to the type provided. In the case that an interface is provided this method will collect implementations. In the case of a non-interface class, subclasses will be collected. Accumulated classes can be accessed by calling getClasses().

Parameters:
parent - the class of interface to find subclasses or implementations of
packageNames - one or more package names to scan (including subpackages) for classes

findSuffix

public void findSuffix(String suffix,
                       String... packageNames)
Attempts to discover classes who's name ends with the provided suffix. Accumulated classes can be accessed by calling getClasses().

Parameters:
suffix - The class name suffix to match
packageNames - one or more package names to scan (including subpackages) for classes

findAnnotated

public void findAnnotated(Class<? extends Annotation> annotation,
                          String... packageNames)
Attempts to discover classes that are annotated with to the annotation. Accumulated classes can be accessed by calling getClasses().

Parameters:
annotation - the annotation that should be present on matching classes
packageNames - one or more package names to scan (including subpackages) for classes

findNamedResource

public void findNamedResource(String name,
                              String... pathNames)

find

public void find(ResolverUtil.Test test,
                 String... packageNames)
Attempts to discover classes that pass the test. Accumulated classes can be accessed by calling getClasses().

Parameters:
test - the test to determine matching classes
packageNames - one or more package names to scan (including subpackages) for classes

findInPackage

public void findInPackage(ResolverUtil.Test test,
                          String packageName)
Scans for classes starting at the package provided and descending into subpackages. Each class is offered up to the Test as it is discovered, and if the Test returns true the class is retained. Accumulated classes can be fetched by calling getClasses().

Parameters:
test - an instance of ResolverUtil.Test that will be used to filter classes
packageName - the name of the package from which to start scanning for classes, e.g. net.sourceforge.stripes

addIfMatching

protected void addIfMatching(ResolverUtil.Test test,
                             String fqn)
Add the class designated by the fully qualified class name provided to the set of resolved classes if and only if it is approved by the Test supplied.

Parameters:
test - the test used to determine if the class matches
fqn - the fully qualified name of a class
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResolverUtil.AnnotatedWith (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ResolverUtil.AnnotatedWith

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ResolverUtil.ClassTest
        extended by  com.opensymphony.xwork2.util.ResolverUtil.AnnotatedWith
All Implemented Interfaces:
ResolverUtil.Test
Enclosing class:
ResolverUtil<T>
public static class ResolverUtil.AnnotatedWith
extends ResolverUtil.ClassTest

A Test that checks to see if each class is annotated with a specific annotation. If it is, then the test returns true, otherwise false.

Constructor Summary
ResolverUtil.AnnotatedWith(Class<? extends Annotation> annotation)
Construts an AnnotatedWith test for the specified annotation type.
Method Summary
boolean | matches(Class type) Returns true if the type is annotated with the class provided to the constructor.
String | toString()
Methods inherited from class com.opensymphony.xwork2.util.ResolverUtil.ClassTest
doesMatchClass, doesMatchResource, matches
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ResolverUtil.AnnotatedWith

public ResolverUtil.AnnotatedWith(Class<? extends Annotation> annotation)
Construts an AnnotatedWith test for the specified annotation type.

Method Detail

matches

public boolean matches(Class type)
Returns true if the type is annotated with the class provided to the constructor.

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResolverUtil.ClassTest (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ResolverUtil.ClassTest

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ResolverUtil.ClassTest
All Implemented Interfaces:
ResolverUtil.Test
Direct Known Subclasses:
ResolverUtil.AnnotatedWith, ResolverUtil.IsA, ResolverUtil.NameEndsWith
Enclosing class:
ResolverUtil<T>
public abstract static class ResolverUtil.ClassTest
extends Object
implements ResolverUtil.Test

Constructor Summary
ResolverUtil.ClassTest()
Method Summary
boolean | doesMatchClass()
boolean | doesMatchResource()
boolean | matches(URL resource)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.util.ResolverUtil.Test
matches

Constructor Detail

ResolverUtil.ClassTest

public ResolverUtil.ClassTest()
Method Detail

matches

public boolean matches(URL resource)
Specified by:
matches in interface ResolverUtil.Test

doesMatchClass

public boolean doesMatchClass()
Specified by:
doesMatchClass in interface ResolverUtil.Test

doesMatchResource

public boolean doesMatchResource()
Specified by:
doesMatchResource in interface ResolverUtil.Test
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResolverUtil.IsA (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ResolverUtil.IsA

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ResolverUtil.ClassTest
        extended by  com.opensymphony.xwork2.util.ResolverUtil.IsA
All Implemented Interfaces:
ResolverUtil.Test
Enclosing class:
ResolverUtil<T>
public static class ResolverUtil.IsA
extends ResolverUtil.ClassTest

A Test that checks to see if each class is assignable to the provided class. Note that this test will match the parent type itself if it is presented for matching.

Constructor Summary
ResolverUtil.IsA(Class parentType)
Constructs an IsA test using the supplied Class as the parent class/interface.
Method Summary
boolean | matches(Class type) Returns true if type is assignable to the parent type supplied in the constructor.
String | toString()
Methods inherited from class com.opensymphony.xwork2.util.ResolverUtil.ClassTest
doesMatchClass, doesMatchResource, matches
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ResolverUtil.IsA

public ResolverUtil.IsA(Class parentType)
Constructs an IsA test using the supplied Class as the parent class/interface.

Method Detail

matches

public boolean matches(Class type)
Returns true if type is assignable to the parent type supplied in the constructor.

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResolverUtil.NameEndsWith (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ResolverUtil.NameEndsWith

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ResolverUtil.ClassTest
        extended by  com.opensymphony.xwork2.util.ResolverUtil.NameEndsWith
All Implemented Interfaces:
ResolverUtil.Test
Enclosing class:
ResolverUtil<T>
public static class ResolverUtil.NameEndsWith
extends ResolverUtil.ClassTest

A Test that checks to see if each class name ends with the provided suffix.

Constructor Summary
ResolverUtil.NameEndsWith(String suffix)
Constructs a NameEndsWith test using the supplied suffix.
Method Summary
boolean | matches(Class type) Returns true if type name ends with the suffix supplied in the constructor.
String | toString()
Methods inherited from class com.opensymphony.xwork2.util.ResolverUtil.ClassTest
doesMatchClass, doesMatchResource, matches
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ResolverUtil.NameEndsWith

public ResolverUtil.NameEndsWith(String suffix)
Constructs a NameEndsWith test using the supplied suffix.

Method Detail

matches

public boolean matches(Class type)
Returns true if type name ends with the suffix supplied in the constructor.

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResolverUtil.NameIs (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ResolverUtil.NameIs

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ResolverUtil.ResourceTest
        extended by  com.opensymphony.xwork2.util.ResolverUtil.NameIs
All Implemented Interfaces:
ResolverUtil.Test
Enclosing class:
ResolverUtil<T>
public static class ResolverUtil.NameIs
extends ResolverUtil.ResourceTest

Constructor Summary
ResolverUtil.NameIs(String name)
Method Summary
boolean | matches(URL resource)
String | toString()
Methods inherited from class com.opensymphony.xwork2.util.ResolverUtil.ResourceTest
doesMatchClass, doesMatchResource, matches
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ResolverUtil.NameIs

public ResolverUtil.NameIs(String name)
Method Detail

matches

public boolean matches(URL resource)

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResolverUtil.ResourceTest (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ResolverUtil.ResourceTest

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ResolverUtil.ResourceTest
All Implemented Interfaces:
ResolverUtil.Test
Direct Known Subclasses:
ResolverUtil.NameIs
Enclosing class:
ResolverUtil<T>
public abstract static class ResolverUtil.ResourceTest
extends Object
implements ResolverUtil.Test

Constructor Summary
ResolverUtil.ResourceTest()
Method Summary
boolean | doesMatchClass()
boolean | doesMatchResource()
boolean | matches(Class cls) Will be called repeatedly with candidate classes.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.util.ResolverUtil.Test
matches

Constructor Detail

ResolverUtil.ResourceTest

public ResolverUtil.ResourceTest()
Method Detail

matches

public boolean matches(Class cls)
Description copied from interface: ResolverUtil.Test
Will be called repeatedly with candidate classes. Must return True if a class is to be included in the results, false otherwise.

Specified by:
matches in interface ResolverUtil.Test

doesMatchClass

public boolean doesMatchClass()
Specified by:
doesMatchClass in interface ResolverUtil.Test

doesMatchResource

public boolean doesMatchResource()
Specified by:
doesMatchResource in interface ResolverUtil.Test
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResolverUtil.Test (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Interface ResolverUtil.Test

All Known Implementing Classes:
ResolverUtil.AnnotatedWith, ResolverUtil.ClassTest, ResolverUtil.IsA, ResolverUtil.NameEndsWith, ResolverUtil.NameIs, ResolverUtil.ResourceTest
Enclosing class:
ResolverUtil<T>
public static interface ResolverUtil.Test

A simple interface that specifies how to test classes to determine if they are to be included in the results produced by the ResolverUtil.

Method Summary
boolean | doesMatchClass()
boolean | doesMatchResource()
boolean | matches(Class type) Will be called repeatedly with candidate classes.
boolean | matches(URL resource)

Method Detail

matches

boolean matches(Class type)
Will be called repeatedly with candidate classes. Must return True if a class is to be included in the results, false otherwise.

matches

boolean matches(URL resource)

doesMatchClass

boolean doesMatchClass()

doesMatchResource

boolean doesMatchResource()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextParseUtil (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class TextParseUtil

java.lang.Object
    extended by  com.opensymphony.xwork2.util.TextParseUtil

public class TextParseUtil
extends Object

Utility class for text parsing.

Version:
$Date: 2009-03-17 22:41:20 +0100 (Di, 17 Mär 2009) $ $Id: TextParseUtil.java 1945 2009-03-17 21:41:20Z musachy $
Author:
Jason Carreira, Rainer Hermanns, tm_jee

Nested Class Summary
static interface TextParseUtil.ParsedValueEvaluator
A parsed value evaluator for TextParseUtil.
Constructor Summary
TextParseUtil()
Method Summary
static Set<String> commaDelimitedStringToSet(String s)
Returns a set from comma delimted Strings.
static Object translateVariables(char[] openChars, String expression, ValueStack stack, Class asType, TextParseUtil.ParsedValueEvaluator evaluator)
Converted object from variable translation.
static Object translateVariables(char[] openChars, String expression, ValueStack stack, Class asType, TextParseUtil.ParsedValueEvaluator evaluator, int maxLoopCount)
Converted object from variable translation.
static String translateVariables(char open, String expression, ValueStack stack)
Converts all instances of ${...} in expression to the value returned by a call to ValueStack.findValue(java.lang.String).
static Object translateVariables(char open, String expression, ValueStack stack, Class asType)
Converted object from variable translation.
static Object translateVariables(char open, String expression, ValueStack stack, Class asType, TextParseUtil.ParsedValueEvaluator evaluator)
Converted object from variable translation.
static Object translateVariables(char open, String expression, ValueStack stack, Class asType, TextParseUtil.ParsedValueEvaluator evaluator, int maxLoopCount)
Converted object from variable translation.
static String translateVariables(String expression, ValueStack stack)
Converts all instances of ${...}, and %{...} in expression to the value returned by a call to ValueStack.findValue(java.lang.String).
static String translateVariables(String expression, ValueStack stack, TextParseUtil.ParsedValueEvaluator evaluator)
Function similarly as translateVariables(char, String, ValueStack) except for the introduction of an additional evaluator that allows the parsed value to be evaluated by the evaluator.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextParseUtil

public TextParseUtil()
Method Detail

translateVariables

public static String translateVariables(String expression,
                                        ValueStack stack)
Converts all instances of ${...}, and %{...} in expression to the value returned by a call to ValueStack.findValue(java.lang.String). If an item cannot be found on the stack (null is returned), then the entire variable ${...} is not displayed, just as if the item was on the stack but returned an empty string.

Parameters:
expression - an expression that hasn't yet been translated
Returns:
the parsed expression

translateVariables

public static String translateVariables(String expression,
                                        ValueStack stack,
                                        TextParseUtil.ParsedValueEvaluator evaluator)
Function similarly as translateVariables(char, String, ValueStack) except for the introduction of an additional evaluator that allows the parsed value to be evaluated by the evaluator. The evaluator could be null, if it is it will just be skipped as if it is just calling translateVariables(char, String, ValueStack).

A typical use-case would be when we need to URL Encode the parsed value. To do so we could just supply a URLEncodingEvaluator for example.

Parameters:
expression -
stack -
evaluator - The parsed Value evaluator (could be null).
Returns:
the parsed (and possibly evaluated) variable String.

translateVariables

public static String translateVariables(char open,
                                        String expression,
                                        ValueStack stack)
Converts all instances of ${...} in expression to the value returned by a call to ValueStack.findValue(java.lang.String). If an item cannot be found on the stack (null is returned), then the entire variable ${...} is not displayed, just as if the item was on the stack but returned an empty string.

Parameters:
open -
expression -
stack -
Returns:
Translated variable String

translateVariables

public static Object translateVariables(char open,
                                        String expression,
                                        ValueStack stack,
                                        Class asType)
Converted object from variable translation.

Parameters:
open -
expression -
stack -
asType -
Returns:
Converted object from variable translation.

translateVariables

public static Object translateVariables(char open,
                                        String expression,
                                        ValueStack stack,
                                        Class asType,
                                        TextParseUtil.ParsedValueEvaluator evaluator)
Converted object from variable translation.

Parameters:
open -
expression -
stack -
asType -
evaluator -
Returns:
Converted object from variable translation.

translateVariables

public static Object translateVariables(char[] openChars,
                                        String expression,
                                        ValueStack stack,
                                        Class asType,
                                        TextParseUtil.ParsedValueEvaluator evaluator)
Converted object from variable translation.

Parameters:
open -
expression -
stack -
asType -
evaluator -
Returns:
Converted object from variable translation.

translateVariables

public static Object translateVariables(char open,
                                        String expression,
                                        ValueStack stack,
                                        Class asType,
                                        TextParseUtil.ParsedValueEvaluator evaluator,
                                        int maxLoopCount)
Converted object from variable translation.

Parameters:
open -
expression -
stack -
asType -
evaluator -
Returns:
Converted object from variable translation.

translateVariables

public static Object translateVariables(char[] openChars,
                                        String expression,
                                        ValueStack stack,
                                        Class asType,
                                        TextParseUtil.ParsedValueEvaluator evaluator,
                                        int maxLoopCount)
Converted object from variable translation.

Parameters:
open -
expression -
stack -
asType -
evaluator -
Returns:
Converted object from variable translation.

commaDelimitedStringToSet

public static Set<String> commaDelimitedStringToSet(String s)
Returns a set from comma delimted Strings.

Parameters:
s - The String to parse.
Returns:
A set from comma delimted Strings.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextParseUtil.ParsedValueEvaluator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Interface TextParseUtil.ParsedValueEvaluator

Enclosing class:
TextParseUtil
public static interface TextParseUtil.ParsedValueEvaluator

A parsed value evaluator for TextParseUtil. It could be supplied by calling TextParseUtil.translateVariables(char, String, ValueStack, Class, ParsedValueEvaluator).

By supplying this ParsedValueEvaluator, the parsed value (parsed against the value stack) value will be given to ParsedValueEvaluator to be evaluated before the translateVariable process goes on.

A typical use-case would be to have a custom ParseValueEvaluator to URL Encode the parsed value.

Version:
$Date: 2009-03-17 22:41:20 +0100 (Di, 17 Mär 2009) $ $Id: TextParseUtil.java 1945 2009-03-17 21:41:20Z musachy $
Author:
tm_jee

Method Summary
 Object evaluate(Object parsedValue)
Evaluated the value parsed by Ognl value stack.

Method Detail

evaluate

Object evaluate(Object parsedValue)
Evaluated the value parsed by Ognl value stack.

Parameters:
parsedValue - - value parsed by ognl value stack
Returns:
return the evaluted value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


URLUtil (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class URLUtil

java.lang.Object
    extended by  com.opensymphony.xwork2.util.URLUtil

public class URLUtil
extends Object

Helper class to extract file paths from different urls

Field Summary
static String | JBOSS5_VFSMEMORY
static String | JBOSS5_VFSZIP Prefix for Jar files in JBoss Virtual File System
Constructor Summary
URLUtil()
Method Summary
static boolean | isJarURL(URL fileUrl) Check if given URL is matching Jar pattern for different servers
static boolean | isJBoss5Url(URL fileUrl) Check if given URL is pointing to JBoss 5 VFS resource
static URL | normalizeToFileProtocol(URL url) Convert URLs to URLs with "file" protocol
static boolean | verifyUrl(String url) Verify That the given String is in valid URL format.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

JBOSS5_VFSZIP

public static final String JBOSS5_VFSZIP
Prefix for Jar files in JBoss Virtual File System

See Also:
Constant Field Values

JBOSS5_VFSMEMORY

public static final String JBOSS5_VFSMEMORY
See Also:
Constant Field Values
Constructor Detail

URLUtil

public URLUtil()
Method Detail

normalizeToFileProtocol

public static URL normalizeToFileProtocol(URL url)
Convert URLs to URLs with "file" protocol

Parameters:
url - URL to convert to a jar url
Returns:
a URL to a file, or null if the URL external form cannot be parsed

verifyUrl

public static final boolean verifyUrl(String url)
Verify That the given String is in valid URL format.

Parameters:
url - The url string to verify.
Returns:
a boolean indicating whether the URL seems to be incorrect.

isJarURL

public static boolean isJarURL(URL fileUrl)
Check if given URL is matching Jar pattern for different servers

Parameters:
fileUrl -
Returns:

isJBoss5Url

public static boolean isJBoss5Url(URL fileUrl)
Check if given URL is pointing to JBoss 5 VFS resource

Parameters:
fileUrl -
Returns:
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValueStack (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Interface ValueStack

All Known Implementing Classes:
OgnlValueStack
public interface ValueStack

ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it. When evaluating an expression, the stack will be searched down the stack, from the latest objects pushed in to the earliest, looking for a bean with a getter or setter for the given property or a method of the given name (depending on the expression being evaluated).

Field Summary
static String | REPORT_ERRORS_ON_NO_PROP
static String | VALUE_STACK
Method Summary
 String findString(String expr)
 String findString(String expr, boolean throwExceptionOnFailure)
 Object findValue(String expr)
Find a value by evaluating the given expression against the stack in the default search order.
 Object findValue(String expr, boolean throwExceptionOnFailure)
 Object findValue(String expr, Class asType)
Find a value by evaluating the given expression against the stack in the default search order.
 Object findValue(String expr, Class asType, boolean throwExceptionOnFailure)
 Map<String,Object> getContext()
Gets the context for this value stack.
 Map<Object,Object> getExprOverrides()
Gets the override map if anyone exists.
 CompoundRoot getRoot()
Get the CompoundRoot which holds the objects pushed onto the stack
 Object peek()
Get the object on the top of the stack without changing the stack.
 Object pop()
Get the object on the top of the stack and remove it from the stack.
 void push(Object o)
Put this object onto the top of the stack
 void set(String key, Object o)
Sets an object on the stack with the given key so it is retrievable by findValue(String), findValue(String, Class)
 void setDefaultType(Class defaultType)
Sets the default type to convert to if no type is provided when getting a value.
 void setExprOverrides(Map<Object,Object> overrides)
Set a override map containing key -> values that takes precedent when doing find operations on the ValueStack.
 void setValue(String expr, Object value)
Attempts to set a property on a bean in the stack with the given expression using the default search order.
 void setValue(String expr, Object value, boolean throwExceptionOnFailure)
Attempts to set a property on a bean in the stack with the given expression using the default search order.
 int size()
Get the number of objects in the stack

Field Detail

VALUE_STACK

static final String VALUE_STACK
See Also:
Constant Field Values

REPORT_ERRORS_ON_NO_PROP

static final String REPORT_ERRORS_ON_NO_PROP
See Also:
Constant Field Values
Method Detail

getContext

Map<String,Object> getContext()
Gets the context for this value stack. The context holds all the information in the value stack and it's surroundings.

Returns:
the context.

setDefaultType

void setDefaultType(Class defaultType)
Sets the default type to convert to if no type is provided when getting a value.

Parameters:
defaultType - the new default type

setExprOverrides

void setExprOverrides(Map<Object,Object> overrides)
Set a override map containing key -> values that takes precedent when doing find operations on the ValueStack.

See the unit test for ValueStackTest for examples.

Parameters:
overrides - overrides map.

getExprOverrides

Map<Object,Object> getExprOverrides()
Gets the override map if anyone exists.

Returns:
the override map, null if not set.

getRoot

CompoundRoot getRoot()
Get the CompoundRoot which holds the objects pushed onto the stack

Returns:
the root

setValue

void setValue(String expr,
              Object value)
Attempts to set a property on a bean in the stack with the given expression using the default search order.

Parameters:
expr - the expression defining the path to the property to be set.
value - the value to be set into the named property

setValue

void setValue(String expr,
              Object value,
              boolean throwExceptionOnFailure)
Attempts to set a property on a bean in the stack with the given expression using the default search order.

Parameters:
expr - the expression defining the path to the property to be set.
value - the value to be set into the named property
throwExceptionOnFailure - a flag to tell whether an exception should be thrown if there is no property with the given name.

findString

String findString(String expr)

findString

String findString(String expr,
                  boolean throwExceptionOnFailure)

findValue

Object findValue(String expr)
Find a value by evaluating the given expression against the stack in the default search order.

Parameters:
expr - the expression giving the path of properties to navigate to find the property value to return
Returns:
the result of evaluating the expression

findValue

Object findValue(String expr,
                 boolean throwExceptionOnFailure)

findValue

Object findValue(String expr,
                 Class asType)
Find a value by evaluating the given expression against the stack in the default search order.

Parameters:
expr - the expression giving the path of properties to navigate to find the property value to return
asType - the type to convert the return value to
Returns:
the result of evaluating the expression

findValue

Object findValue(String expr,
                 Class asType,
                 boolean throwExceptionOnFailure)

peek

Object peek()
Get the object on the top of the stack without changing the stack.

Returns:
the object on the top.
See Also:
CompoundRoot.peek()

pop

Object pop()
Get the object on the top of the stack and remove it from the stack.

Returns:
the object on the top of the stack
See Also:
CompoundRoot.pop()

push

void push(Object o)
Put this object onto the top of the stack

Parameters:
o - the object to be pushed onto the stack
See Also:
CompoundRoot.push(Object)

set

void set(String key,
         Object o)
Sets an object on the stack with the given key so it is retrievable by findValue(String), findValue(String, Class)

Parameters:
key - the key
o - the object

size

int size()
Get the number of objects in the stack

Returns:
the number of objects in the stack
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValueStackFactory (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Interface ValueStackFactory

All Known Implementing Classes:
OgnlValueStackFactory
public interface ValueStackFactory

Factory that creates a value stack, defaulting to the OgnlValueStackFactory

Method Summary
ValueStack | createValueStack() Get a new instance of ValueStack
ValueStack | createValueStack(ValueStack stack) Get a new instance of ValueStack

Method Detail

createValueStack

ValueStack createValueStack()
Get a new instance of ValueStack

Returns:
a new ValueStack.

createValueStack

ValueStack createValueStack(ValueStack stack)
Get a new instance of ValueStack

Parameters:
stack - an existing stack to include.
Returns:
a new ValueStack.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WildcardHelper (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class WildcardHelper

java.lang.Object
    extended by  com.opensymphony.xwork2.util.WildcardHelper
All Implemented Interfaces:
PatternMatcher<int[]>
public class WildcardHelper
extends Object
implements PatternMatcher<int[]>

This class is an utility class that perform wilcard-patterns matching and isolation taken from Apache Cocoon.

Version:
$Rev: 1833 $ $Date: 2005-05-07 12:11:38 -0400 (Sat, 07 May 2005) $

Field Summary
protected static int | MATCH_BEGIN The int representing begin in the pattern int [].
protected static int | MATCH_END The int value that terminates the pattern int [].
protected static int | MATCH_FILE The int representing '*' in the pattern int [].
protected static int | MATCH_PATH The int representing '**' in the pattern int [].
protected static int | MATCH_THEEND The int representing end in pattern int [].
Constructor Summary
WildcardHelper()
Method Summary
int[] | compilePattern(String data) Translate the given String into a int [] representing the pattern matchable by this class.
protected int | indexOfArray(int[] r, int rpos, int rend, char[] d, int dpos) Get the offset of a part of an int array within a char array.
boolean | isLiteral(String pattern) Determines if the pattern contains any * characters
protected int | lastIndexOfArray(int[] r, int rpos, int rend, char[] d, int dpos) Get the offset of a last occurance of an int array within a char array.
boolean | match(Map<String,String> map, String data, int[] expr) Match a pattern agains a string and isolates wildcard replacement into a Stack.
protected boolean | matchArray(int[] r, int rpos, int rend, char[] d, int dpos) Matches elements of array r from rpos to rend with array d, starting from dpos.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

MATCH_FILE

protected static final int MATCH_FILE
The int representing '*' in the pattern int [].

See Also:
Constant Field Values

MATCH_PATH

protected static final int MATCH_PATH
The int representing '**' in the pattern int [].

See Also:
Constant Field Values

MATCH_BEGIN

protected static final int MATCH_BEGIN
The int representing begin in the pattern int [].

See Also:
Constant Field Values

MATCH_THEEND

protected static final int MATCH_THEEND
The int representing end in pattern int [].

See Also:
Constant Field Values

MATCH_END

protected static final int MATCH_END
The int value that terminates the pattern int [].

See Also:
Constant Field Values
Constructor Detail

WildcardHelper

public WildcardHelper()
Method Detail

isLiteral

public boolean isLiteral(String pattern)
Determines if the pattern contains any * characters

Specified by:
isLiteral in interface PatternMatcher<int[]>
Parameters:
pattern - The pattern
Returns:
True if no wildcards are found

compilePattern

public int[] compilePattern(String data)

Translate the given String into a int [] representing the pattern matchable by this class.
This function translates a String into an int array converting the special '*' and '\' characters.
Here is how the conversion algorithm works:

  • The '*' character is converted to MATCH_FILE, meaning that zero or more characters (excluding the path separator '/') are to be matched.
  • The '**' sequence is converted to MATCH_PATH, meaning that zero or more characters (including the path separator '/') are to be matched.
  • The '\' character is used as an escape sequence ('\*' is translated in '*', not in MATCH_FILE). If an exact '\' character is to be matched the source string must contain a '\\'. sequence.

When more than two '*' characters, not separated by another character, are found their value is considered as '**' (MATCH_PATH).
The array is always terminated by a special value (MATCH_END).
All MATCH* values are less than zero, while normal characters are equal or greater.

Specified by:
compilePattern in interface PatternMatcher<int[]>
Parameters:
data - The string to translate.
Returns:
The encoded string as an int array, terminated by the MATCH_END value (don't consider the array length).
Throws:
NullPointerException - If data is null.

match

public boolean match(Map<String,String> map,
                     String data,
                     int[] expr)
Match a pattern agains a string and isolates wildcard replacement into a Stack.

Specified by:
match in interface PatternMatcher<int[]>
Parameters:
map - The map to store matched values
data - The string to match
expr - The compiled wildcard expression
Returns:
True if a match
Throws:
NullPointerException - If any parameters are null

indexOfArray

protected int indexOfArray(int[] r,
                           int rpos,
                           int rend,
                           char[] d,
                           int dpos)
Get the offset of a part of an int array within a char array.
This method return the index in d of the first occurrence after dpos of that part of array specified by r, starting at rpos and terminating at rend.

Parameters:
r - The array containing the data that need to be matched in d.
rpos - The index of the first character in r to look for.
rend - The index of the last character in r to look for plus 1.
d - The array of char that should contain a part of r.
dpos - The starting offset in d for the matching.
Returns:
The offset in d of the part of r matched in d or -1 if that was not found.

lastIndexOfArray

protected int lastIndexOfArray(int[] r,
                               int rpos,
                               int rend,
                               char[] d,
                               int dpos)
Get the offset of a last occurance of an int array within a char array.
This method return the index in d of the last occurrence after dpos of that part of array specified by r, starting at rpos and terminating at rend.

Parameters:
r - The array containing the data that need to be matched in d.
rpos - The index of the first character in r to look for.
rend - The index of the last character in r to look for plus 1.
d - The array of char that should contain a part of r.
dpos - The starting offset in d for the matching.
Returns:
The offset in d of the last part of r matched in d or -1 if that was not found.

matchArray

protected boolean matchArray(int[] r,
                             int rpos,
                             int rend,
                             char[] d,
                             int dpos)
Matches elements of array r from rpos to rend with array d, starting from dpos.
This method return true if elements of array r from rpos to rend equals elements of array d starting from dpos to dpos+(rend-rpos).

Parameters:
r - The array containing the data that need to be matched in d.
rpos - The index of the first character in r to look for.
rend - The index of the last character in r to look for.
d - The array of char that should start from a part of r.
dpos - The starting offset in d for the matching.
Returns:
true if array d starts from portion of array r.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkList (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class XWorkList

java.lang.Object
    extended by  java.util.AbstractCollection<E>
        extended by  java.util.AbstractList<E>
            extended by  java.util.ArrayList
                extended by  com.opensymphony.xwork2.util.XWorkList
All Implemented Interfaces:
Serializable, Cloneable, Iterable, Collection, List, RandomAccess
public class XWorkList
extends ArrayList

A simple list that guarantees that inserting and retrieving objects will always work regardless of the current size of the list. Upon insertion, type conversion is also performed if necessary. Empty beans will be created to fill the gap between the current list size and the requested index using ObjectFactory's buildBean method.

Author:
Patrick Lightbody
See Also:
Serialized Form

Field Summary
Fields inherited from class java.util.AbstractList
modCount
Constructor Summary
XWorkList(ObjectFactory fac, XWorkConverter conv, Class clazz)
XWorkList(ObjectFactory fac, XWorkConverter conv, Class clazz, int initialCapacity)
Method Summary
void | add(int index, Object element) Inserts the specified element at the specified position in this list.
boolean | add(Object element) Appends the specified element to the end of this list.
boolean | addAll(Collection c) Appends all of the elements in the specified Collection to the end of this list, in the order that they are returned by the specified Collection's Iterator.
boolean | addAll(int index, Collection c) Inserts all of the elements in the specified Collection into this list, starting at the specified position.
boolean | contains(Object element)
Object | get(int index) Returns the element at the specified position in this list.
Object | set(int index, Object element) Replaces the element at the specified position in this list with the specified element.
Methods inherited from class java.util.ArrayList
clear, clone, ensureCapacity, indexOf, isEmpty, lastIndexOf, remove, remove, removeRange, size, toArray, toArray, trimToSize
Methods inherited from class java.util.AbstractList
equals, hashCode, iterator, listIterator, listIterator, subList
Methods inherited from class java.util.AbstractCollection
containsAll, removeAll, retainAll, toString
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.List
containsAll, equals, hashCode, iterator, listIterator, listIterator, removeAll, retainAll, subList

Constructor Detail

XWorkList

public XWorkList(ObjectFactory fac,
                 XWorkConverter conv,
                 Class clazz)

XWorkList

public XWorkList(ObjectFactory fac,
                 XWorkConverter conv,
                 Class clazz,
                 int initialCapacity)
Method Detail

add

public void add(int index,
                Object element)
Inserts the specified element at the specified position in this list. Shifts the element currently at that position (if any) and any subsequent elements to the right (adds one to their indices).

This method is guaranteed to work since it will create empty beans to fill the gap between the current list size and the requested index to enable the element to be set. This method also performs any necessary type conversion.

Specified by:
add in interface List
Overrides:
add in class ArrayList
Parameters:
index - index at which the specified element is to be inserted.
element - element to be inserted.

add

public boolean add(Object element)
Appends the specified element to the end of this list.

This method performs any necessary type conversion.

Specified by:
add in interface Collection
Specified by:
add in interface List
Overrides:
add in class ArrayList
Parameters:
element - element to be appended to this list.
Returns:
true (as per the general contract of Collection.add).

addAll

public boolean addAll(Collection c)
Appends all of the elements in the specified Collection to the end of this list, in the order that they are returned by the specified Collection's Iterator. The behavior of this operation is undefined if the specified Collection is modified while the operation is in progress. (This implies that the behavior of this call is undefined if the specified Collection is this list, and this list is nonempty.)

This method performs any necessary type conversion.

Specified by:
addAll in interface Collection
Specified by:
addAll in interface List
Overrides:
addAll in class ArrayList
Parameters:
c - the elements to be inserted into this list.
Returns:
true if this list changed as a result of the call.
Throws:
NullPointerException - if the specified collection is null.

addAll

public boolean addAll(int index,
                      Collection c)
Inserts all of the elements in the specified Collection into this list, starting at the specified position. Shifts the element currently at that position (if any) and any subsequent elements to the right (increases their indices). The new elements will appear in the list in the order that they are returned by the specified Collection's iterator.

This method is guaranteed to work since it will create empty beans to fill the gap between the current list size and the requested index to enable the element to be set. This method also performs any necessary type conversion.

Specified by:
addAll in interface List
Overrides:
addAll in class ArrayList
Parameters:
index - index at which to insert first element from the specified collection.
c - elements to be inserted into this list.
Returns:
true if this list changed as a result of the call.

get

public Object get(int index)
Returns the element at the specified position in this list.

An object is guaranteed to be returned since it will create empty beans to fill the gap between the current list size and the requested index.

Specified by:
get in interface List
Overrides:
get in class ArrayList
Parameters:
index - index of element to return.
Returns:
the element at the specified position in this list.

set

public Object set(int index,
                  Object element)
Replaces the element at the specified position in this list with the specified element.

This method is guaranteed to work since it will create empty beans to fill the gap between the current list size and the requested index to enable the element to be set. This method also performs any necessary type conversion.

Specified by:
set in interface List
Overrides:
set in class ArrayList
Parameters:
index - index of element to replace.
element - element to be stored at the specified position.
Returns:
the element previously at the specified position.

contains

public boolean contains(Object element)
Specified by:
contains in interface Collection
Specified by:
contains in interface List
Overrides:
contains in class ArrayList
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkTestCaseHelper (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class XWorkTestCaseHelper

java.lang.Object
    extended by  com.opensymphony.xwork2.util.XWorkTestCaseHelper

public class XWorkTestCaseHelper
extends Object

Generic test setup methods to be used with any unit testing framework.

Constructor Summary
XWorkTestCaseHelper()
Method Summary
static ConfigurationManager | loadConfigurationProviders(ConfigurationManager configurationManager, ConfigurationProvider... providers)
static ConfigurationManager | setUp()
static void | tearDown(ConfigurationManager configurationManager)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XWorkTestCaseHelper

public XWorkTestCaseHelper()
Method Detail

setUp

public static ConfigurationManager setUp()
                                  throws Exception
Throws:
Exception

loadConfigurationProviders

public static ConfigurationManager loadConfigurationProviders(ConfigurationManager configurationManager,
                                                              ConfigurationProvider... providers)

tearDown

public static void tearDown(ConfigurationManager configurationManager)
                     throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.opensymphony.xwork2.util.AnnotationUtils (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.AnnotationUtils

No usage of com.opensymphony.xwork2.util.AnnotationUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ArrayUtils (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.ArrayUtils

No usage of com.opensymphony.xwork2.util.ArrayUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ClassLoaderUtil (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.ClassLoaderUtil

No usage of com.opensymphony.xwork2.util.ClassLoaderUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ClassPathFinder (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.ClassPathFinder

No usage of com.opensymphony.xwork2.util.ClassPathFinder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.ClearableValueStack (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.util.ClearableValueStack

Packages that use ClearableValueStack
com.opensymphony.xwork2.ognl

Uses of ClearableValueStack in com.opensymphony.xwork2.ognl

Classes in com.opensymphony.xwork2.ognl that implement ClearableValueStack
 class OgnlValueStack
Ognl implementation of a value stack that allows for dynamic Ognl expressions to be evaluated against it.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.CompoundRoot (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.CompoundRoot

Packages that use CompoundRoot
com.opensymphony.xwork2.ognl |
com.opensymphony.xwork2.util | XWork util classes.

Uses of CompoundRoot in com.opensymphony.xwork2.ognl

Methods in com.opensymphony.xwork2.ognl that return CompoundRoot
 CompoundRoot OgnlValueStack.getRoot()

Methods in com.opensymphony.xwork2.ognl with parameters of type CompoundRoot
protected  void OgnlValueStack.setRoot(XWorkConverter xworkConverter, CompoundRootAccessor accessor, CompoundRoot compoundRoot, boolean allowStaticMethodAccess)

Uses of CompoundRoot in com.opensymphony.xwork2.util

Methods in com.opensymphony.xwork2.util that return CompoundRoot
CompoundRoot | CompoundRoot.cutStack(int index)
CompoundRoot | ValueStack.getRoot() Get the CompoundRoot which holds the objects pushed onto the stack

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.CreateIfNull (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.CreateIfNull

No usage of com.opensymphony.xwork2.util.CreateIfNull

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.DomHelper (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.DomHelper

No usage of com.opensymphony.xwork2.util.DomHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.DomHelper.DOMBuilder (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.DomHelper.DOMBuilder

No usage of com.opensymphony.xwork2.util.DomHelper.DOMBuilder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.DomHelper.StartHandler (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.DomHelper.StartHandler

No usage of com.opensymphony.xwork2.util.DomHelper.StartHandler

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.Element (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.Element

No usage of com.opensymphony.xwork2.util.Element

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.FileManager (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.FileManager

No usage of com.opensymphony.xwork2.util.FileManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.Key (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.Key

No usage of com.opensymphony.xwork2.util.Key

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.KeyProperty (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.KeyProperty

No usage of com.opensymphony.xwork2.util.KeyProperty

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.LocalizedTextUtil (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.LocalizedTextUtil

No usage of com.opensymphony.xwork2.util.LocalizedTextUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.MemberAccessValueStack (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.util.MemberAccessValueStack

Packages that use MemberAccessValueStack
com.opensymphony.xwork2.ognl

Uses of MemberAccessValueStack in com.opensymphony.xwork2.ognl

Classes in com.opensymphony.xwork2.ognl that implement MemberAccessValueStack
 class OgnlValueStack
Ognl implementation of a value stack that allows for dynamic Ognl expressions to be evaluated against it.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.NamedVariablePatternMatcher (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.NamedVariablePatternMatcher

No usage of com.opensymphony.xwork2.util.NamedVariablePatternMatcher

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.NamedVariablePatternMatcher.CompiledPattern (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.NamedVariablePatternMatcher.CompiledPattern

Packages that use NamedVariablePatternMatcher.CompiledPattern
com.opensymphony.xwork2.util XWork util classes.

Uses of NamedVariablePatternMatcher.CompiledPattern in com.opensymphony.xwork2.util

Methods in com.opensymphony.xwork2.util that return NamedVariablePatternMatcher.CompiledPattern
 NamedVariablePatternMatcher.CompiledPattern NamedVariablePatternMatcher.compilePattern(String data)
Compiles the pattern.

Methods in com.opensymphony.xwork2.util with parameters of type NamedVariablePatternMatcher.CompiledPattern
 boolean NamedVariablePatternMatcher.match(Map<String,String> map, String data, NamedVariablePatternMatcher.CompiledPattern expr)
Tries to process the data against the compiled expression.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.PatternMatcher (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.util.PatternMatcher

Packages that use PatternMatcher
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.util | XWork util classes.

Uses of PatternMatcher in com.opensymphony.xwork2.config.impl

Constructors in com.opensymphony.xwork2.config.impl with parameters of type PatternMatcher
AbstractMatcher(PatternMatcher<?> helper)
ActionConfigMatcher(PatternMatcher<?> patternMatcher, Map<String,ActionConfig> configs, boolean looseMatch)
Finds and precompiles the wildcard patterns from the ActionConfig "path" attributes.
NamespaceMatcher(PatternMatcher<?> patternMatcher, Set<String> namespaces)

Uses of PatternMatcher in com.opensymphony.xwork2.util

Classes in com.opensymphony.xwork2.util that implement PatternMatcher
class | NamedVariablePatternMatcher An implementation of a pattern matcher that uses simple named wildcards.
class | WildcardHelper This class is an utility class that perform wilcard-patterns matching and isolation taken from Apache Cocoon.

Methods in com.opensymphony.xwork2.util with parameters of type PatternMatcher
 void ClassPathFinder.setPatternMatcher(PatternMatcher<int[]> patternMatcher)
sets the PatternMatcher implementation to use when comparing filenames

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.PropertiesReader (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.PropertiesReader

No usage of com.opensymphony.xwork2.util.PropertiesReader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ResolverUtil (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.ResolverUtil

No usage of com.opensymphony.xwork2.util.ResolverUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ResolverUtil.AnnotatedWith (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.ResolverUtil.AnnotatedWith

No usage of com.opensymphony.xwork2.util.ResolverUtil.AnnotatedWith

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ResolverUtil.ClassTest (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.ResolverUtil.ClassTest

Packages that use ResolverUtil.ClassTest
com.opensymphony.xwork2.util XWork util classes.

Uses of ResolverUtil.ClassTest in com.opensymphony.xwork2.util

Subclasses of ResolverUtil.ClassTest in com.opensymphony.xwork2.util
static class | ResolverUtil.AnnotatedWith A Test that checks to see if each class is annotated with a specific annotation.
static class | ResolverUtil.IsA A Test that checks to see if each class is assignable to the provided class.
static class | ResolverUtil.NameEndsWith A Test that checks to see if each class name ends with the provided suffix.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ResolverUtil.IsA (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.ResolverUtil.IsA

No usage of com.opensymphony.xwork2.util.ResolverUtil.IsA

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ResolverUtil.NameEndsWith (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.ResolverUtil.NameEndsWith

No usage of com.opensymphony.xwork2.util.ResolverUtil.NameEndsWith

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ResolverUtil.NameIs (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.ResolverUtil.NameIs

No usage of com.opensymphony.xwork2.util.ResolverUtil.NameIs

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ResolverUtil.ResourceTest (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.ResolverUtil.ResourceTest

Packages that use ResolverUtil.ResourceTest
com.opensymphony.xwork2.util XWork util classes.

Uses of ResolverUtil.ResourceTest in com.opensymphony.xwork2.util

Subclasses of ResolverUtil.ResourceTest in com.opensymphony.xwork2.util
static class ResolverUtil.NameIs

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.ResolverUtil.Test (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.util.ResolverUtil.Test

Packages that use ResolverUtil.Test
com.opensymphony.xwork2.util XWork util classes.

Uses of ResolverUtil.Test in com.opensymphony.xwork2.util

Classes in com.opensymphony.xwork2.util that implement ResolverUtil.Test
static class | ResolverUtil.AnnotatedWith A Test that checks to see if each class is annotated with a specific annotation.
static class | ResolverUtil.ClassTest
static class | ResolverUtil.IsA A Test that checks to see if each class is assignable to the provided class.
static class | ResolverUtil.NameEndsWith A Test that checks to see if each class name ends with the provided suffix.
static class | ResolverUtil.NameIs
static class | ResolverUtil.ResourceTest

Methods in com.opensymphony.xwork2.util with parameters of type ResolverUtil.Test
protected void | ResolverUtil.addIfMatching(ResolverUtil.Test test, String fqn) Add the class designated by the fully qualified class name provided to the set of resolved classes if and only if it is approved by the Test supplied.
void | ResolverUtil.find(ResolverUtil.Test test, String... packageNames) Attempts to discover classes that pass the test.
void | ResolverUtil.findInPackage(ResolverUtil.Test test, String packageName) Scans for classes starting at the package provided and descending into subpackages.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.TextParseUtil (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.TextParseUtil

No usage of com.opensymphony.xwork2.util.TextParseUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.TextParseUtil.ParsedValueEvaluator (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.util.TextParseUtil.ParsedValueEvaluator

Packages that use TextParseUtil.ParsedValueEvaluator
com.opensymphony.xwork2.util XWork util classes.

Uses of TextParseUtil.ParsedValueEvaluator in com.opensymphony.xwork2.util

Methods in com.opensymphony.xwork2.util with parameters of type TextParseUtil.ParsedValueEvaluator
static Object TextParseUtil.translateVariables(char[] openChars, String expression, ValueStack stack, Class asType, TextParseUtil.ParsedValueEvaluator evaluator)
Converted object from variable translation.
static Object TextParseUtil.translateVariables(char[] openChars, String expression, ValueStack stack, Class asType, TextParseUtil.ParsedValueEvaluator evaluator, int maxLoopCount)
Converted object from variable translation.
static Object TextParseUtil.translateVariables(char open, String expression, ValueStack stack, Class asType, TextParseUtil.ParsedValueEvaluator evaluator)
Converted object from variable translation.
static Object TextParseUtil.translateVariables(char open, String expression, ValueStack stack, Class asType, TextParseUtil.ParsedValueEvaluator evaluator, int maxLoopCount)
Converted object from variable translation.
static String TextParseUtil.translateVariables(String expression, ValueStack stack, TextParseUtil.ParsedValueEvaluator evaluator)
Function similarly as TextParseUtil.translateVariables(char, String, ValueStack) except for the introduction of an additional evaluator that allows the parsed value to be evaluated by the evaluator.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.URLUtil (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.URLUtil

No usage of com.opensymphony.xwork2.util.URLUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.ValueStack (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.util.ValueStack

Packages that use ValueStack
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.conversion.impl |
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.mock | XWork specific mock classes.
com.opensymphony.xwork2.ognl |
com.opensymphony.xwork2.util | XWork util classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Uses of ValueStack in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as ValueStack
protected  ValueStack DefaultActionInvocation.stack

Methods in com.opensymphony.xwork2 that return ValueStack
ValueStack | DefaultActionInvocation.getStack()
ValueStack | ActionInvocation.getStack() Gets the ValueStack associated with this ActionInvocation.
ValueStack | ActionContext.getValueStack() Gets the OGNL value stack.

Methods in com.opensymphony.xwork2 with parameters of type ValueStack
String | TextProviderSupport.getText(String key, String defaultValue, List<Object> args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | TextProvider.getText(String key, String defaultValue, List<Object> args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | DefaultTextProvider.getText(String key, String defaultValue, List<Object> args, ValueStack stack)
String | CompositeTextProvider.getText(String key, String defaultValue, List<Object> args, ValueStack stack) It will consult each TextProviders and return the first valid message for this key, before returining defaultValue
String | ActionSupport.getText(String key, String defaultValue, List<Object> args, ValueStack stack)
String | TextProviderSupport.getText(String key, String defaultValue, String[] args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | TextProvider.getText(String key, String defaultValue, String[] args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | DefaultTextProvider.getText(String key, String defaultValue, String[] args, ValueStack stack)
String | CompositeTextProvider.getText(String key, String defaultValue, String[] args, ValueStack stack) It will consult each TextProviders and return the first valid message for this key, before returining defaultValue
String | ActionSupport.getText(String key, String defaultValue, String[] args, ValueStack stack)
String | ActionEventListener.handleException(Throwable t, ValueStack stack) Called when an exception is thrown by the action
Object | ActionEventListener.prepare(Object action, ValueStack stack) Called after an action has been created.
void | ActionContext.setValueStack(ValueStack stack) Sets the OGNL value stack.

Uses of ValueStack in com.opensymphony.xwork2.conversion.impl

Methods in com.opensymphony.xwork2.conversion.impl with parameters of type ValueStack
static String XWorkConverter.getConversionErrorMessage(String propertyName, ValueStack stack)

Uses of ValueStack in com.opensymphony.xwork2.interceptor

Methods in com.opensymphony.xwork2.interceptor with parameters of type ValueStack
protected  void ParametersInterceptor.setParameters(Object action, ValueStack stack, Map<String,Object> parameters)

Uses of ValueStack in com.opensymphony.xwork2.mock

Methods in com.opensymphony.xwork2.mock that return ValueStack
 ValueStack MockActionInvocation.getStack()

Methods in com.opensymphony.xwork2.mock with parameters of type ValueStack
 void MockActionInvocation.setStack(ValueStack stack)

Uses of ValueStack in com.opensymphony.xwork2.ognl

Classes in com.opensymphony.xwork2.ognl that implement ValueStack
 class OgnlValueStack
Ognl implementation of a value stack that allows for dynamic Ognl expressions to be evaluated against it.

Methods in com.opensymphony.xwork2.ognl that return ValueStack
ValueStack | OgnlValueStackFactory.createValueStack()
ValueStack | OgnlValueStackFactory.createValueStack(ValueStack stack)

Methods in com.opensymphony.xwork2.ognl with parameters of type ValueStack
 ValueStack OgnlValueStackFactory.createValueStack(ValueStack stack)

Constructors in com.opensymphony.xwork2.ognl with parameters of type ValueStack
OgnlValueStack(ValueStack vs, XWorkConverter xworkConverter, CompoundRootAccessor accessor, boolean allowStaticAccess)

Uses of ValueStack in com.opensymphony.xwork2.util

Methods in com.opensymphony.xwork2.util that return ValueStack
ValueStack | ValueStackFactory.createValueStack() Get a new instance of ValueStack
ValueStack | ValueStackFactory.createValueStack(ValueStack stack) Get a new instance of ValueStack

Methods in com.opensymphony.xwork2.util with parameters of type ValueStack
 ValueStack ValueStackFactory.createValueStack(ValueStack stack)
Get a new instance of ValueStack
static String LocalizedTextUtil.findText(Class aClass, String aTextName, Locale locale, String defaultMessage, Object[] args, ValueStack valueStack)
Finds a localized text message for the given key, aTextName.
static String LocalizedTextUtil.findText(ResourceBundle bundle, String aTextName, Locale locale, String defaultMessage, Object[] args, ValueStack valueStack)
Finds a localized text message for the given key, aTextName, in the specified resource bundle.
static Object TextParseUtil.translateVariables(char[] openChars, String expression, ValueStack stack, Class asType, TextParseUtil.ParsedValueEvaluator evaluator)
Converted object from variable translation.
static Object TextParseUtil.translateVariables(char[] openChars, String expression, ValueStack stack, Class asType, TextParseUtil.ParsedValueEvaluator evaluator, int maxLoopCount)
Converted object from variable translation.
static String TextParseUtil.translateVariables(char open, String expression, ValueStack stack)
Converts all instances of ${...} in expression to the value returned by a call to findValue(java.lang.String).
static Object TextParseUtil.translateVariables(char open, String expression, ValueStack stack, Class asType)
Converted object from variable translation.
static Object TextParseUtil.translateVariables(char open, String expression, ValueStack stack, Class asType, TextParseUtil.ParsedValueEvaluator evaluator)
Converted object from variable translation.
static Object TextParseUtil.translateVariables(char open, String expression, ValueStack stack, Class asType, TextParseUtil.ParsedValueEvaluator evaluator, int maxLoopCount)
Converted object from variable translation.
static String TextParseUtil.translateVariables(String expression, ValueStack stack)
Converts all instances of ${...}, and %{...} in expression to the value returned by a call to findValue(java.lang.String).
static String TextParseUtil.translateVariables(String expression, ValueStack stack, TextParseUtil.ParsedValueEvaluator evaluator)
Function similarly as TextParseUtil.translateVariables(char, String, ValueStack) except for the introduction of an additional evaluator that allows the parsed value to be evaluated by the evaluator.

Uses of ValueStack in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type ValueStack
String | DelegatingValidatorContext.getText(String key, String defaultValue, List<Object> args, ValueStack stack)
String | DelegatingValidatorContext.getText(String key, String defaultValue, String[] args, ValueStack stack)
void | Validator.setValueStack(ValueStack stack) Sets the value stack to use to resolve values and parameters

Uses of ValueStack in com.opensymphony.xwork2.validator.validators

Methods in com.opensymphony.xwork2.validator.validators with parameters of type ValueStack
 void ValidatorSupport.setValueStack(ValueStack stack)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.ValueStackFactory (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.util.ValueStackFactory

Packages that use ValueStackFactory
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.ognl |

Uses of ValueStackFactory in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as ValueStackFactory
protected  ValueStackFactory DefaultActionInvocation.valueStackFactory

Methods in com.opensymphony.xwork2 with parameters of type ValueStackFactory
 void DefaultActionInvocation.setValueStackFactory(ValueStackFactory fac)

Uses of ValueStackFactory in com.opensymphony.xwork2.interceptor

Fields in com.opensymphony.xwork2.interceptor declared as ValueStackFactory
protected  ValueStackFactory AliasInterceptor.valueStackFactory

Methods in com.opensymphony.xwork2.interceptor with parameters of type ValueStackFactory
void | StaticParametersInterceptor.setValueStackFactory(ValueStackFactory valueStackFactory)
void | ParametersInterceptor.setValueStackFactory(ValueStackFactory valueStackFactory)
void | AliasInterceptor.setValueStackFactory(ValueStackFactory valueStackFactory)

Uses of ValueStackFactory in com.opensymphony.xwork2.ognl

Classes in com.opensymphony.xwork2.ognl that implement ValueStackFactory
 class OgnlValueStackFactory
Creates an Ognl value stack

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.WildcardHelper (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.WildcardHelper

No usage of com.opensymphony.xwork2.util.WildcardHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.XWorkList (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.XWorkList

No usage of com.opensymphony.xwork2.util.XWorkList

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.XWorkTestCaseHelper (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.XWorkTestCaseHelper

No usage of com.opensymphony.xwork2.util.XWorkTestCaseHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


FileResourceStore (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.classloader
Class FileResourceStore

java.lang.Object
    extended by  com.opensymphony.xwork2.util.classloader.FileResourceStore
All Implemented Interfaces:
ResourceStore
public final class FileResourceStore
extends Object
implements ResourceStore

Reads a class from disk class taken from Apache JCI

Constructor Summary
FileResourceStore(File pFile)
Method Summary
byte[] | read(String pResourceName)
String | toString()
void | write(String pResourceName, byte[] pData)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

FileResourceStore

public FileResourceStore(File pFile)
Method Detail

read

public byte[] read(String pResourceName)
Specified by:
read in interface ResourceStore

write

public void write(String pResourceName,
                  byte[] pData)
Specified by:
write in interface ResourceStore

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


JarResourceStore (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.classloader
Class JarResourceStore

java.lang.Object
    extended by  com.opensymphony.xwork2.util.classloader.JarResourceStore
All Implemented Interfaces:
ResourceStore
public class JarResourceStore
extends Object
implements ResourceStore

Read resources from a jar file

Constructor Summary
JarResourceStore(File file)
Method Summary
static long | copy(InputStream input, OutputStream output)
byte[] | read(String pResourceName)
void | write(String pResourceName, byte[] pResourceData)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JarResourceStore

public JarResourceStore(File file)
Method Detail

write

public void write(String pResourceName,
                  byte[] pResourceData)
Specified by:
write in interface ResourceStore

read

public byte[] read(String pResourceName)
Specified by:
read in interface ResourceStore

copy

public static long copy(InputStream input,
                        OutputStream output)
                 throws IOException
Throws:
IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.util.classloader (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.util.classloader
Interfaces
ResourceStore
Classes
FileResourceStore
JarResourceStore
ReloadingClassLoader
ResourceStoreClassLoader


com.opensymphony.xwork2.util.classloader (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.util.classloader

Interface Summary
ResourceStore *interface taken from Apache JCI

Class Summary
FileResourceStore | Reads a class from disk class taken from Apache JCI
JarResourceStore | Read resources from a jar file
ReloadingClassLoader | The ReloadingClassLoader uses a delegation mechanism to allow classes to be reloaded.
ResourceStoreClassLoader | class taken from Apache JCI


com.opensymphony.xwork2.util.classloader Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.util.classloader

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.ClassLoader
      • com.opensymphony.xwork2.util.classloader.ReloadingClassLoader
      • com.opensymphony.xwork2.util.classloader.ResourceStoreClassLoader
    • com.opensymphony.xwork2.util.classloader.FileResourceStore (implements com.opensymphony.xwork2.util.classloader.ResourceStore)
    • com.opensymphony.xwork2.util.classloader.JarResourceStore (implements com.opensymphony.xwork2.util.classloader.ResourceStore)

Interface Hierarchy

  • com.opensymphony.xwork2.util.classloader.ResourceStore


Uses of Package com.opensymphony.xwork2.util.classloader (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.util.classloader

Packages that use com.opensymphony.xwork2.util.classloader
com.opensymphony.xwork2.util.classloader

Classes in com.opensymphony.xwork2.util.classloader used by com.opensymphony.xwork2.util.classloader
ResourceStore
*interface taken from Apache JCI

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ReloadingClassLoader (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.classloader
Class ReloadingClassLoader

java.lang.Object
    extended by  java.lang.ClassLoader
        extended by  com.opensymphony.xwork2.util.classloader.ReloadingClassLoader

public class ReloadingClassLoader
extends ClassLoader

The ReloadingClassLoader uses a delegation mechanism to allow classes to be reloaded. That means that loadClass calls may return different results if the class was changed in the underlying ResourceStore.

class taken from Apache JCI

Constructor Summary
ReloadingClassLoader(ClassLoader pParent)
Method Summary
boolean | addResourceStore(ResourceStore pStore)
void | clearAssertionStatus()
URL | getResource(String name)
InputStream | getResourceAsStream(String name)
protected boolean | isAccepted(String className)
Class | loadClass(String name)
void | reload()
boolean | removeResourceStore(ResourceStore pStore)
void | setAccepClasses(Set<Pattern> acceptClasses)
void | setClassAssertionStatus(String className, boolean enabled)
void | setDefaultAssertionStatus(boolean enabled)
void | setPackageAssertionStatus(String packageName, boolean enabled)
Methods inherited from class java.lang.ClassLoader
defineClass, defineClass, defineClass, defineClass, definePackage, findClass, findLibrary, findLoadedClass, findResource, findResources, findSystemClass, getPackage, getPackages, getParent, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, resolveClass, setSigners
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ReloadingClassLoader

public ReloadingClassLoader(ClassLoader pParent)
Method Detail

addResourceStore

public boolean addResourceStore(ResourceStore pStore)

removeResourceStore

public boolean removeResourceStore(ResourceStore pStore)

reload

public void reload()

clearAssertionStatus

public void clearAssertionStatus()
Overrides:
clearAssertionStatus in class ClassLoader

getResource

public URL getResource(String name)
Overrides:
getResource in class ClassLoader

getResourceAsStream

public InputStream getResourceAsStream(String name)
Overrides:
getResourceAsStream in class ClassLoader

loadClass

public Class loadClass(String name)
                throws ClassNotFoundException
Overrides:
loadClass in class ClassLoader
Throws:
ClassNotFoundException

setClassAssertionStatus

public void setClassAssertionStatus(String className,
                                    boolean enabled)
Overrides:
setClassAssertionStatus in class ClassLoader

setDefaultAssertionStatus

public void setDefaultAssertionStatus(boolean enabled)
Overrides:
setDefaultAssertionStatus in class ClassLoader

setPackageAssertionStatus

public void setPackageAssertionStatus(String packageName,
                                      boolean enabled)
Overrides:
setPackageAssertionStatus in class ClassLoader

setAccepClasses

public void setAccepClasses(Set<Pattern> acceptClasses)

isAccepted

protected boolean isAccepted(String className)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResourceStore (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.classloader
Interface ResourceStore

All Known Implementing Classes:
FileResourceStore, JarResourceStore
public interface ResourceStore

*interface taken from Apache JCI

Method Summary
byte[] | read(String pResourceName)
void | write(String pResourceName, byte[] pResourceData)

Method Detail

write

void write(String pResourceName,
           byte[] pResourceData)

read

byte[] read(String pResourceName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResourceStoreClassLoader (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.classloader
Class ResourceStoreClassLoader

java.lang.Object
    extended by  java.lang.ClassLoader
        extended by  com.opensymphony.xwork2.util.classloader.ResourceStoreClassLoader

public final class ResourceStoreClassLoader
extends ClassLoader

class taken from Apache JCI

Constructor Summary
ResourceStoreClassLoader(ClassLoader pParent, ResourceStore[] pStores)
Method Summary
protected Class | findClass(String name)
protected Class | loadClass(String name, boolean resolve)
Methods inherited from class java.lang.ClassLoader
clearAssertionStatus, defineClass, defineClass, defineClass, defineClass, definePackage, findLibrary, findLoadedClass, findResource, findResources, findSystemClass, getPackage, getPackages, getParent, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResourceStoreClassLoader

public ResourceStoreClassLoader(ClassLoader pParent,
                                ResourceStore[] pStores)
Method Detail

loadClass

protected Class loadClass(String name,
                          boolean resolve)
                   throws ClassNotFoundException
Overrides:
loadClass in class ClassLoader
Throws:
ClassNotFoundException

findClass

protected Class findClass(String name)
                   throws ClassNotFoundException
Overrides:
findClass in class ClassLoader
Throws:
ClassNotFoundException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.opensymphony.xwork2.util.classloader.FileResourceStore (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.classloader.FileResourceStore

No usage of com.opensymphony.xwork2.util.classloader.FileResourceStore

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.classloader.JarResourceStore (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.classloader.JarResourceStore

No usage of com.opensymphony.xwork2.util.classloader.JarResourceStore

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.classloader.ReloadingClassLoader (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.classloader.ReloadingClassLoader

No usage of com.opensymphony.xwork2.util.classloader.ReloadingClassLoader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.classloader.ResourceStore (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.util.classloader.ResourceStore

Packages that use ResourceStore
com.opensymphony.xwork2.util.classloader

Uses of ResourceStore in com.opensymphony.xwork2.util.classloader

Classes in com.opensymphony.xwork2.util.classloader that implement ResourceStore
class | FileResourceStore Reads a class from disk class taken from Apache JCI
class | JarResourceStore Read resources from a jar file

Methods in com.opensymphony.xwork2.util.classloader with parameters of type ResourceStore
boolean | ReloadingClassLoader.addResourceStore(ResourceStore pStore)
boolean | ReloadingClassLoader.removeResourceStore(ResourceStore pStore)

Constructors in com.opensymphony.xwork2.util.classloader with parameters of type ResourceStore
ResourceStoreClassLoader(ClassLoader pParent, ResourceStore[] pStores)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.classloader.ResourceStoreClassLoader (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.classloader.ResourceStoreClassLoader

No usage of com.opensymphony.xwork2.util.classloader.ResourceStoreClassLoader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ClassFinder (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.finder
Class ClassFinder

java.lang.Object
    extended by  com.opensymphony.xwork2.util.finder.ClassFinder

public class ClassFinder
extends Object

ClassFinder searches the classpath of the specified ClassLoaderInterface for packages, classes, constructors, methods, or fields with specific annotations. For security reasons ASM is used to find the annotations. Classes are not loaded unless they match the requirements of a called findAnnotated* method. Once loaded, these classes are cached. The getClassesNotLoaded() method can be used immediately after any find* method to get a list of classes which matched the find requirements (i.e. contained the annotation), but were unable to be loaded.

Version:
$Rev$ $Date$
Author:
David Blevins

Nested Class Summary
class | ClassFinder.Annotatable
class | ClassFinder.AnnotationInfo
class | ClassFinder.ClassInfo
class | ClassFinder.FieldInfo
static interface | ClassFinder.Info
class | ClassFinder.InfoBuildingVisitor
class | ClassFinder.MethodInfo
class | ClassFinder.PackageInfo
Constructor Summary
ClassFinder(Class... classes)
ClassFinder(ClassLoaderInterface classLoader)
Creates a ClassFinder that will search the urls in the specified ClassLoaderInterface excluding the urls in the ClassLoaderInterface's parent.
ClassFinder(ClassLoaderInterface classLoader, boolean excludeParent)
Creates a ClassFinder that will search the urls in the specified ClassLoaderInterface.
ClassFinder(ClassLoaderInterface classLoader, ClassLoaderInterface exclude)
Creates a ClassFinder that will search the urls in the specified classloader excluding the urls in the 'exclude' ClassLoaderInterface.
ClassFinder(ClassLoaderInterface classLoaderInterface, Collection<URL> urls)
ClassFinder(ClassLoaderInterface classLoaderInterface, Collection<URL> urls, boolean extractBaseInterfaces)
ClassFinder(ClassLoaderInterface classLoaderInterface, Collection<URL> urls, boolean extractBaseInterfaces, Set<String> protocols)
ClassFinder(ClassLoaderInterface classLoader, String... dirNames)
ClassFinder(ClassLoaderInterface classLoader, URL url)
ClassFinder(List<Class> classes)
Method Summary
List<Class> | findAnnotatedClasses(Class<? extends Annotation> annotation)
List<Constructor> | findAnnotatedConstructors(Class<? extends Annotation> annotation)
List<Field> | findAnnotatedFields(Class<? extends Annotation> annotation)
List<Method> | findAnnotatedMethods(Class<? extends Annotation> annotation)
List<Package> | findAnnotatedPackages(Class<? extends Annotation> annotation)
List<Class> | findClasses()
List<Class> | findClasses(Test<ClassFinder.ClassInfo> test)
List<Class> | findClassesInPackage(String packageName, boolean recursive)
List<String> | getClassesNotLoaded() Returns a list of classes that could not be loaded in last invoked findAnnotated* method.
boolean | isAnnotationPresent(Class<? extends Annotation> annotation)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ClassFinder

public ClassFinder(ClassLoaderInterface classLoader)
            throws Exception
Creates a ClassFinder that will search the urls in the specified ClassLoaderInterface excluding the urls in the ClassLoaderInterface's parent. To include the parent ClassLoaderInterface, use: new ClassFinder(ClassLoaderInterface, false); To exclude the parent's parent, use: new ClassFinder(ClassLoaderInterface, ClassLoaderInterface.getParent().getParent());

Parameters:
classLoader - source of classes to scan
Throws:
Exception - if something goes wrong

ClassFinder

public ClassFinder(ClassLoaderInterface classLoader,
                   boolean excludeParent)
            throws Exception
Creates a ClassFinder that will search the urls in the specified ClassLoaderInterface.

Parameters:
classLoader - source of classes to scan
excludeParent - Allegedly excludes classes from parent ClassLoaderInterface, whatever that might mean
Throws:
Exception - if something goes wrong.

ClassFinder

public ClassFinder(ClassLoaderInterface classLoader,
                   ClassLoaderInterface exclude)
            throws Exception
Creates a ClassFinder that will search the urls in the specified classloader excluding the urls in the 'exclude' ClassLoaderInterface.

Parameters:
classLoader - source of classes to scan
exclude - source of classes to exclude from scanning
Throws:
Exception - if something goes wrong

ClassFinder

public ClassFinder(ClassLoaderInterface classLoader,
                   URL url)

ClassFinder

public ClassFinder(ClassLoaderInterface classLoader,
                   String... dirNames)

ClassFinder

public ClassFinder(ClassLoaderInterface classLoaderInterface,
                   Collection<URL> urls)

ClassFinder

public ClassFinder(ClassLoaderInterface classLoaderInterface,
                   Collection<URL> urls,
                   boolean extractBaseInterfaces)

ClassFinder

public ClassFinder(ClassLoaderInterface classLoaderInterface,
                   Collection<URL> urls,
                   boolean extractBaseInterfaces,
                   Set<String> protocols)

ClassFinder

public ClassFinder(Class... classes)

ClassFinder

public ClassFinder(List<Class> classes)
Method Detail

isAnnotationPresent

public boolean isAnnotationPresent(Class<? extends Annotation> annotation)

getClassesNotLoaded

public List<String> getClassesNotLoaded()
Returns a list of classes that could not be loaded in last invoked findAnnotated* method.

The list will only contain entries of classes whose byte code matched the requirements of last invoked find* method, but were unable to be loaded and included in the results.

The list returned is unmodifiable. Once obtained, the returned list will be a live view of the results from the last findAnnotated* method call.

This method is not thread safe.

Returns:
an unmodifiable live view of classes that could not be loaded in previous findAnnotated* call.

findAnnotatedPackages

public List<Package> findAnnotatedPackages(Class<? extends Annotation> annotation)

findAnnotatedClasses

public List<Class> findAnnotatedClasses(Class<? extends Annotation> annotation)

findAnnotatedMethods

public List<Method> findAnnotatedMethods(Class<? extends Annotation> annotation)

findAnnotatedConstructors

public List<Constructor> findAnnotatedConstructors(Class<? extends Annotation> annotation)

findAnnotatedFields

public List<Field> findAnnotatedFields(Class<? extends Annotation> annotation)

findClassesInPackage

public List<Class> findClassesInPackage(String packageName,
                                        boolean recursive)

findClasses

public List<Class> findClasses(Test<ClassFinder.ClassInfo> test)

findClasses

public List<Class> findClasses()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ClassFinder.Annotatable (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.finder
Class ClassFinder.Annotatable

java.lang.Object
    extended by  com.opensymphony.xwork2.util.finder.ClassFinder.Annotatable
Direct Known Subclasses:
ClassFinder.AnnotationInfo, ClassFinder.ClassInfo, ClassFinder.FieldInfo, ClassFinder.MethodInfo, ClassFinder.PackageInfo
Enclosing class:
ClassFinder
public class ClassFinder.Annotatable
extends Object

Constructor Summary
ClassFinder.Annotatable()
ClassFinder.Annotatable(AnnotatedElement element)
Method Summary
 List<ClassFinder.AnnotationInfo> getAnnotations()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ClassFinder.Annotatable

public ClassFinder.Annotatable(AnnotatedElement element)

ClassFinder.Annotatable

public ClassFinder.Annotatable()
Method Detail

getAnnotations

public List<ClassFinder.AnnotationInfo> getAnnotations()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClassFinder.AnnotationInfo (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.finder
Class ClassFinder.AnnotationInfo

java.lang.Object
    extended by  com.opensymphony.xwork2.util.finder.ClassFinder.Annotatable
        extended by  com.opensymphony.xwork2.util.finder.ClassFinder.AnnotationInfo
All Implemented Interfaces:
ClassFinder.Info
Enclosing class:
ClassFinder
public class ClassFinder.AnnotationInfo
extends ClassFinder.Annotatable
implements ClassFinder.Info

Constructor Summary
ClassFinder.AnnotationInfo(Annotation annotation)
ClassFinder.AnnotationInfo(Class<? extends Annotation> annotation)
ClassFinder.AnnotationInfo(String name)
Method Summary
String | getName()
String | toString()
Methods inherited from class com.opensymphony.xwork2.util.finder.ClassFinder.Annotatable
getAnnotations
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.util.finder.ClassFinder.Info
getAnnotations

Constructor Detail

ClassFinder.AnnotationInfo

public ClassFinder.AnnotationInfo(Annotation annotation)

ClassFinder.AnnotationInfo

public ClassFinder.AnnotationInfo(Class<? extends Annotation> annotation)

ClassFinder.AnnotationInfo

public ClassFinder.AnnotationInfo(String name)
Method Detail

getName

public String getName()
Specified by:
getName in interface ClassFinder.Info

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClassFinder.ClassInfo (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.finder
Class ClassFinder.ClassInfo

java.lang.Object
    extended by  com.opensymphony.xwork2.util.finder.ClassFinder.Annotatable
        extended by  com.opensymphony.xwork2.util.finder.ClassFinder.ClassInfo
All Implemented Interfaces:
ClassFinder.Info
Enclosing class:
ClassFinder
public class ClassFinder.ClassInfo
extends ClassFinder.Annotatable
implements ClassFinder.Info

Constructor Summary
ClassFinder.ClassInfo(Class clazz)
ClassFinder.ClassInfo(String name, String superType)
Method Summary
Class | get()
List<ClassFinder.MethodInfo> | getConstructors()
List<ClassFinder.FieldInfo> | getFields()
List<String> | getInterfaces()
List<ClassFinder.MethodInfo> | getMethods()
String | getName()
String | getPackageName()
List<String> | getSuperInterfaces()
String | getSuperType()
String | toString()
Methods inherited from class com.opensymphony.xwork2.util.finder.ClassFinder.Annotatable
getAnnotations
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.util.finder.ClassFinder.Info
getAnnotations

Constructor Detail

ClassFinder.ClassInfo

public ClassFinder.ClassInfo(Class clazz)

ClassFinder.ClassInfo

public ClassFinder.ClassInfo(String name,
                             String superType)
Method Detail

getPackageName

public String getPackageName()

getConstructors

public List<ClassFinder.MethodInfo> getConstructors()

getInterfaces

public List<String> getInterfaces()

getSuperInterfaces

public List<String> getSuperInterfaces()

getFields

public List<ClassFinder.FieldInfo> getFields()

getMethods

public List<ClassFinder.MethodInfo> getMethods()

getName

public String getName()
Specified by:
getName in interface ClassFinder.Info

getSuperType

public String getSuperType()

get

public Class get()
          throws ClassNotFoundException
Throws:
ClassNotFoundException

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClassFinder.FieldInfo (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.finder
Class ClassFinder.FieldInfo

java.lang.Object
    extended by  com.opensymphony.xwork2.util.finder.ClassFinder.Annotatable
        extended by  com.opensymphony.xwork2.util.finder.ClassFinder.FieldInfo
All Implemented Interfaces:
ClassFinder.Info
Enclosing class:
ClassFinder
public class ClassFinder.FieldInfo
extends ClassFinder.Annotatable
implements ClassFinder.Info

Constructor Summary
ClassFinder.FieldInfo(ClassFinder.ClassInfo info, Field field)
ClassFinder.FieldInfo(ClassFinder.ClassInfo declaringClass, String name, String type)
Method Summary
ClassFinder.ClassInfo | getDeclaringClass()
String | getName()
String | getType()
String | toString()
Methods inherited from class com.opensymphony.xwork2.util.finder.ClassFinder.Annotatable
getAnnotations
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.util.finder.ClassFinder.Info
getAnnotations

Constructor Detail

ClassFinder.FieldInfo

public ClassFinder.FieldInfo(ClassFinder.ClassInfo info,
                             Field field)

ClassFinder.FieldInfo

public ClassFinder.FieldInfo(ClassFinder.ClassInfo declaringClass,
                             String name,
                             String type)
Method Detail

getName

public String getName()
Specified by:
getName in interface ClassFinder.Info

getDeclaringClass

public ClassFinder.ClassInfo getDeclaringClass()

getType

public String getType()

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClassFinder.Info (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.finder
Interface ClassFinder.Info

All Known Implementing Classes:
ClassFinder.AnnotationInfo, ClassFinder.ClassInfo, ClassFinder.FieldInfo, ClassFinder.MethodInfo, ClassFinder.PackageInfo
Enclosing class:
ClassFinder
public static interface ClassFinder.Info

Method Summary
List<ClassFinder.AnnotationInfo> | getAnnotations()
String | getName()

Method Detail

getName

String getName()

getAnnotations

List<ClassFinder.AnnotationInfo> getAnnotations()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClassFinder.InfoBuildingVisitor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.finder
Class ClassFinder.InfoBuildingVisitor

java.lang.Object
    extended by  org.objectweb.asm.commons.EmptyVisitor
        extended by  com.opensymphony.xwork2.util.finder.ClassFinder.InfoBuildingVisitor
All Implemented Interfaces:
org.objectweb.asm.AnnotationVisitor, org.objectweb.asm.ClassVisitor, org.objectweb.asm.FieldVisitor, org.objectweb.asm.MethodVisitor
Enclosing class:
ClassFinder
public class ClassFinder.InfoBuildingVisitor
extends org.objectweb.asm.commons.EmptyVisitor

Constructor Summary
ClassFinder.InfoBuildingVisitor()
ClassFinder.InfoBuildingVisitor(ClassFinder.Info info)
Method Summary
void | visit(int version, int access, String name, String signature, String superName, String[] interfaces)
org.objectweb.asm.AnnotationVisitor | visitAnnotation(String desc, boolean visible)
org.objectweb.asm.FieldVisitor | visitField(int access, String name, String desc, String signature, Object value)
org.objectweb.asm.MethodVisitor | visitMethod(int access, String name, String desc, String signature, String[] exceptions)
org.objectweb.asm.AnnotationVisitor | visitParameterAnnotation(int param, String desc, boolean visible)
Methods inherited from class org.objectweb.asm.commons.EmptyVisitor
visit, visitAnnotation, visitAnnotationDefault, visitArray, visitAttribute, visitCode, visitEnd, visitEnum, visitFieldInsn, visitFrame, visitIincInsn, visitInnerClass, visitInsn, visitIntInsn, visitJumpInsn, visitLabel, visitLdcInsn, visitLineNumber, visitLocalVariable, visitLookupSwitchInsn, visitMaxs, visitMethodInsn, visitMultiANewArrayInsn, visitOuterClass, visitSource, visitTableSwitchInsn, visitTryCatchBlock, visitTypeInsn, visitVarInsn
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ClassFinder.InfoBuildingVisitor

public ClassFinder.InfoBuildingVisitor()

ClassFinder.InfoBuildingVisitor

public ClassFinder.InfoBuildingVisitor(ClassFinder.Info info)
Method Detail

visit

public void visit(int version,
                  int access,
                  String name,
                  String signature,
                  String superName,
                  String[] interfaces)
Specified by:
visit in interface org.objectweb.asm.ClassVisitor
Overrides:
visit in class org.objectweb.asm.commons.EmptyVisitor

visitAnnotation

public org.objectweb.asm.AnnotationVisitor visitAnnotation(String desc,
                                                           boolean visible)
Specified by:
visitAnnotation in interface org.objectweb.asm.ClassVisitor
Specified by:
visitAnnotation in interface org.objectweb.asm.FieldVisitor
Specified by:
visitAnnotation in interface org.objectweb.asm.MethodVisitor
Overrides:
visitAnnotation in class org.objectweb.asm.commons.EmptyVisitor

visitField

public org.objectweb.asm.FieldVisitor visitField(int access,
                                                 String name,
                                                 String desc,
                                                 String signature,
                                                 Object value)
Specified by:
visitField in interface org.objectweb.asm.ClassVisitor
Overrides:
visitField in class org.objectweb.asm.commons.EmptyVisitor

visitMethod

public org.objectweb.asm.MethodVisitor visitMethod(int access,
                                                   String name,
                                                   String desc,
                                                   String signature,
                                                   String[] exceptions)
Specified by:
visitMethod in interface org.objectweb.asm.ClassVisitor
Overrides:
visitMethod in class org.objectweb.asm.commons.EmptyVisitor

visitParameterAnnotation

public org.objectweb.asm.AnnotationVisitor visitParameterAnnotation(int param,
                                                                    String desc,
                                                                    boolean visible)
Specified by:
visitParameterAnnotation in interface org.objectweb.asm.MethodVisitor
Overrides:
visitParameterAnnotation in class org.objectweb.asm.commons.EmptyVisitor
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClassFinder.MethodInfo (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.finder
Class ClassFinder.MethodInfo

java.lang.Object
    extended by  com.opensymphony.xwork2.util.finder.ClassFinder.Annotatable
        extended by  com.opensymphony.xwork2.util.finder.ClassFinder.MethodInfo
All Implemented Interfaces:
ClassFinder.Info
Enclosing class:
ClassFinder
public class ClassFinder.MethodInfo
extends ClassFinder.Annotatable
implements ClassFinder.Info

Constructor Summary
ClassFinder.MethodInfo(ClassFinder.ClassInfo info, Constructor constructor)
ClassFinder.MethodInfo(ClassFinder.ClassInfo info, Method method)
ClassFinder.MethodInfo(ClassFinder.ClassInfo declarignClass, String name, String returnType)
Method Summary
ClassFinder.ClassInfo | getDeclaringClass()
String | getName()
List<List<ClassFinder.AnnotationInfo>> | getParameterAnnotations()
List<ClassFinder.AnnotationInfo> | getParameterAnnotations(int index)
String | getReturnType()
String | toString()
Methods inherited from class com.opensymphony.xwork2.util.finder.ClassFinder.Annotatable
getAnnotations
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.util.finder.ClassFinder.Info
getAnnotations

Constructor Detail

ClassFinder.MethodInfo

public ClassFinder.MethodInfo(ClassFinder.ClassInfo info,
                              Constructor constructor)

ClassFinder.MethodInfo

public ClassFinder.MethodInfo(ClassFinder.ClassInfo info,
                              Method method)

ClassFinder.MethodInfo

public ClassFinder.MethodInfo(ClassFinder.ClassInfo declarignClass,
                              String name,
                              String returnType)
Method Detail

getParameterAnnotations

public List<List<ClassFinder.AnnotationInfo>> getParameterAnnotations()

getParameterAnnotations

public List<ClassFinder.AnnotationInfo> getParameterAnnotations(int index)

getName

public String getName()
Specified by:
getName in interface ClassFinder.Info

getDeclaringClass

public ClassFinder.ClassInfo getDeclaringClass()

getReturnType

public String getReturnType()

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClassFinder.PackageInfo (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.finder
Class ClassFinder.PackageInfo

java.lang.Object
    extended by  com.opensymphony.xwork2.util.finder.ClassFinder.Annotatable
        extended by  com.opensymphony.xwork2.util.finder.ClassFinder.PackageInfo
All Implemented Interfaces:
ClassFinder.Info
Enclosing class:
ClassFinder
public class ClassFinder.PackageInfo
extends ClassFinder.Annotatable
implements ClassFinder.Info

Constructor Summary
ClassFinder.PackageInfo(Package pkg)
ClassFinder.PackageInfo(String name)
Method Summary
Package | get()
String | getName()
Methods inherited from class com.opensymphony.xwork2.util.finder.ClassFinder.Annotatable
getAnnotations
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.util.finder.ClassFinder.Info
getAnnotations

Constructor Detail

ClassFinder.PackageInfo

public ClassFinder.PackageInfo(Package pkg)

ClassFinder.PackageInfo

public ClassFinder.PackageInfo(String name)
Method Detail

getName

public String getName()
Specified by:
getName in interface ClassFinder.Info

get

public Package get()
            throws ClassNotFoundException
Throws:
ClassNotFoundException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClassLoaderInterface (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.finder
Interface ClassLoaderInterface

All Known Implementing Classes:
ClassLoaderInterfaceDelegate
public interface ClassLoaderInterface

Classes implementing this interface can find resources and load classes, usually delegating to a class loader

Field Summary
static String CLASS_LOADER_INTERFACE
Method Summary
ClassLoaderInterface | getParent()
URL | getResource(String name)
InputStream | getResourceAsStream(String name)
Enumeration<URL> | getResources(String name)
Class<?> | loadClass(String name)

Field Detail

CLASS_LOADER_INTERFACE

static final String CLASS_LOADER_INTERFACE
See Also:
Constant Field Values
Method Detail

loadClass

Class<?> loadClass(String name)
                   throws ClassNotFoundException
Throws:
ClassNotFoundException

getResource

URL getResource(String name)

getResources

Enumeration<URL> getResources(String name)
                              throws IOException
Throws:
IOException

getResourceAsStream

InputStream getResourceAsStream(String name)
                                throws IOException
Throws:
IOException

getParent

ClassLoaderInterface getParent()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClassLoaderInterfaceDelegate (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.finder
Class ClassLoaderInterfaceDelegate

java.lang.Object
    extended by  com.opensymphony.xwork2.util.finder.ClassLoaderInterfaceDelegate
All Implemented Interfaces:
ClassLoaderInterface
public class ClassLoaderInterfaceDelegate
extends Object
implements ClassLoaderInterface

Default implementation of ClassLoaderInterface, which delegates to an actual ClassLoader

Field Summary
Fields inherited from interface com.opensymphony.xwork2.util.finder.ClassLoaderInterface
CLASS_LOADER_INTERFACE
Constructor Summary
ClassLoaderInterfaceDelegate(ClassLoader classLoader)
Method Summary
ClassLoaderInterface | getParent()
URL | getResource(String className)
InputStream | getResourceAsStream(String name)
Enumeration<URL> | getResources(String name)
Class<?> | loadClass(String name)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ClassLoaderInterfaceDelegate

public ClassLoaderInterfaceDelegate(ClassLoader classLoader)
Method Detail

loadClass

public Class<?> loadClass(String name)
                   throws ClassNotFoundException
Specified by:
loadClass in interface ClassLoaderInterface
Throws:
ClassNotFoundException

getResource

public URL getResource(String className)
Specified by:
getResource in interface ClassLoaderInterface

getResources

public Enumeration<URL> getResources(String name)
                              throws IOException
Specified by:
getResources in interface ClassLoaderInterface
Throws:
IOException

getResourceAsStream

public InputStream getResourceAsStream(String name)
Specified by:
getResourceAsStream in interface ClassLoaderInterface

getParent

public ClassLoaderInterface getParent()
Specified by:
getParent in interface ClassLoaderInterface
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.util.finder (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.util.finder
Interfaces
ClassFinder.Info
ClassLoaderInterface
Test
Classes
ClassFinder
ClassLoaderInterfaceDelegate
ResourceFinder
UrlSet


com.opensymphony.xwork2.util.finder (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.util.finder

Interface Summary
ClassFinder.Info |
ClassLoaderInterface | Classes implementing this interface can find resources and load classes, usually delegating to a class loader
Test<T> | This is the testing interface that is used to accept or reject resources.

Class Summary
ClassFinder | ClassFinder searches the classpath of the specified ClassLoaderInterface for packages, classes, constructors, methods, or fields with specific annotations.
ClassLoaderInterfaceDelegate | Default implementation of ClassLoaderInterface, which delegates to an actual ClassLoader
ResourceFinder |
UrlSet | Use with ClassFinder to filter the Urls to be scanned, example:


com.opensymphony.xwork2.util.finder Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.util.finder

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.util.finder.ClassFinder
    • com.opensymphony.xwork2.util.finder.ClassFinder.Annotatable
      • com.opensymphony.xwork2.util.finder.ClassFinder.AnnotationInfo (implements com.opensymphony.xwork2.util.finder.ClassFinder.Info)
      • com.opensymphony.xwork2.util.finder.ClassFinder.ClassInfo (implements com.opensymphony.xwork2.util.finder.ClassFinder.Info)
      • com.opensymphony.xwork2.util.finder.ClassFinder.FieldInfo (implements com.opensymphony.xwork2.util.finder.ClassFinder.Info)
      • com.opensymphony.xwork2.util.finder.ClassFinder.MethodInfo (implements com.opensymphony.xwork2.util.finder.ClassFinder.Info)
      • com.opensymphony.xwork2.util.finder.ClassFinder.PackageInfo (implements com.opensymphony.xwork2.util.finder.ClassFinder.Info)
    • com.opensymphony.xwork2.util.finder.ClassLoaderInterfaceDelegate (implements com.opensymphony.xwork2.util.finder.ClassLoaderInterface)
    • org.objectweb.asm.commons.EmptyVisitor (implements org.objectweb.asm.AnnotationVisitor, org.objectweb.asm.ClassVisitor, org.objectweb.asm.FieldVisitor, org.objectweb.asm.MethodVisitor)
      • com.opensymphony.xwork2.util.finder.ClassFinder.InfoBuildingVisitor
    • com.opensymphony.xwork2.util.finder.ResourceFinder
    • com.opensymphony.xwork2.util.finder.UrlSet

Interface Hierarchy

  • com.opensymphony.xwork2.util.finder.ClassFinder.Info
  • com.opensymphony.xwork2.util.finder.ClassLoaderInterface
  • com.opensymphony.xwork2.util.finder.Test<T>


Uses of Package com.opensymphony.xwork2.util.finder (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.util.finder

Packages that use com.opensymphony.xwork2.util.finder
com.opensymphony.xwork2.util.finder

Classes in com.opensymphony.xwork2.util.finder used by com.opensymphony.xwork2.util.finder
ClassFinder.Annotatable
ClassFinder.AnnotationInfo
ClassFinder.ClassInfo
ClassFinder.FieldInfo
ClassFinder.Info
ClassFinder.MethodInfo
ClassLoaderInterface
Classes implementing this interface can find resources and load classes, usually delegating to a class loader
Test
This is the testing interface that is used to accept or reject resources.
UrlSet
Use with ClassFinder to filter the Urls to be scanned, example:

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ResourceFinder (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.finder
Class ResourceFinder

java.lang.Object
    extended by  com.opensymphony.xwork2.util.finder.ResourceFinder

public class ResourceFinder
extends Object

Version:
$Rev$ $Date$
Author:
David Blevins

Constructor Summary
ResourceFinder(String path)
ResourceFinder(String path, ClassLoaderInterface classLoaderInterface)
ResourceFinder(String path, ClassLoaderInterface classLoaderInterface, URL... urls)
ResourceFinder(String path, URL... urls)
ResourceFinder(URL... urls)
Method Summary
URL | find(String uri)
List<URL> | findAll(String uri)
List<Class> | findAllClasses(String uri) Executes findAllStrings assuming the strings are the names of a classes that should be loaded and returned.
List<Class> | findAllImplementations(Class interfase) Assumes the class specified points to a file in the classpath that contains the name of a class that implements or is a subclass of the specfied class.
List<Properties> | findAllProperties(String uri) Finds the corresponding resources and reads them in as a properties files Any URL that cannot be read in as a properties file will cause an exception to be thrown.
List<String> | findAllStrings(String uri) Reads the contents of the found URLs as a list of String's and returns them.
List<Class> | findAvailableClasses(String uri) Executes findAvailableStrings assuming the strings are the names of a classes that should be loaded and returned.
List<Class> | findAvailableImplementations(Class interfase) Assumes the class specified points to a file in the classpath that contains the name of a class that implements or is a subclass of the specfied class.
List<Properties> | findAvailableProperties(String uri) Finds the corresponding resources and reads them in as a properties files Any URL that cannot be read in as a properties file will be added to the 'resourcesNotLoaded' collection.
List<String> | findAvailableStrings(String uri) Reads the contents of the found URLs as a Strings and returns them.
Class | findClass(String uri) Executes findString(String) assuming the contents URL found is the name of a class that should be loaded and returned.
Class | findImplementation(Class interfase) Assumes the class specified points to a file in the classpath that contains the name of a class that implements or is a subclass of the specfied class.
Set<String> | findPackages(String uri) Gets a list of subpckages from jars or dirs
Map<URL,Set<String>> | findPackagesMap(String uri) Gets a list of subpckages from jars or dirs
Properties | findProperties(String uri) Finds the corresponding resource and reads it in as a properties file Example classpath: META-INF/widget.properties ResourceFinder finder = new ResourceFinder("META-INF/"); Properties widgetProps = finder.findProperties("widget.properties");
String | findString(String uri) Reads the contents of the URL as a String's and returns it.
Map<String,URL> | getResourcesMap(String uri)
List<String> | getResourcesNotLoaded() Returns a list of resources that could not be loaded in the last invoked findAvailable* or mapAvailable* methods.
Map<String,Class> | mapAllClasses(String uri) Executes mapAllStrings assuming the value of each entry in the map is the name of a class that should be loaded.
Map<String,Class> | mapAllImplementations(Class interfase) Assumes the class specified points to a directory in the classpath that holds files containing the name of a class that implements or is a subclass of the specfied class.
Map<String,Properties> | mapAllProperties(String uri) Finds the corresponding resources and reads them in as a properties files Any URL that cannot be read in as a properties file will cause an exception to be thrown.
Map<String,String> | mapAllStrings(String uri) Reads the contents of all non-directory URLs immediately under the specified location and returns them in a map keyed by the file name.
Map<String,Class> | mapAvailableClasses(String uri) Executes mapAvailableStrings assuming the value of each entry in the map is the name of a class that should be loaded.
Map<String,Class> | mapAvailableImplementations(Class interfase) Assumes the class specified points to a directory in the classpath that holds files containing the name of a class that implements or is a subclass of the specfied class.
Map<String,Properties> | mapAvailableProperties(String uri) Finds the corresponding resources and reads them in as a properties files Any URL that cannot be read in as a properties file will be added to the 'resourcesNotLoaded' collection.
Map<String,String> | mapAvailableStrings(String uri) Reads the contents of all non-directory URLs immediately under the specified location and returns them in a map keyed by the file name.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResourceFinder

public ResourceFinder(URL... urls)

ResourceFinder

public ResourceFinder(String path)

ResourceFinder

public ResourceFinder(String path,
                      URL... urls)

ResourceFinder

public ResourceFinder(String path,
                      ClassLoaderInterface classLoaderInterface)

ResourceFinder

public ResourceFinder(String path,
                      ClassLoaderInterface classLoaderInterface,
                      URL... urls)
Method Detail

getResourcesNotLoaded

public List<String> getResourcesNotLoaded()
Returns a list of resources that could not be loaded in the last invoked findAvailable* or mapAvailable* methods.

The list will only contain entries of resources that match the requirements of the last invoked findAvailable* or mapAvailable* methods, but were unable to be loaded and included in their results.

The list returned is unmodifiable and the results of this method will change after each invocation of a findAvailable* or mapAvailable* methods.

This method is not thread safe.

find

public URL find(String uri)
         throws IOException
Throws:
IOException

findAll

public List<URL> findAll(String uri)
                  throws IOException
Throws:
IOException

findString

public String findString(String uri)
                  throws IOException
Reads the contents of the URL as a String's and returns it.

Parameters:
uri -
Returns:
a stringified content of a resource
Throws:
IOException - if a resource pointed out by the uri param could not be find
See Also:
ClassLoader.getResource(String)

findAllStrings

public List<String> findAllStrings(String uri)
                            throws IOException
Reads the contents of the found URLs as a list of String's and returns them.

Parameters:
uri -
Returns:
a list of the content of each resource URL found
Throws:
IOException - if any of the found URLs are unable to be read.

findAvailableStrings

public List<String> findAvailableStrings(String uri)
                                  throws IOException
Reads the contents of the found URLs as a Strings and returns them. Individual URLs that cannot be read are skipped and added to the list of 'resourcesNotLoaded'

Parameters:
uri -
Returns:
a list of the content of each resource URL found
Throws:
IOException - if classLoader.getResources throws an exception

mapAllStrings

public Map<String,String> mapAllStrings(String uri)
                                 throws IOException
Reads the contents of all non-directory URLs immediately under the specified location and returns them in a map keyed by the file name.

Any URLs that cannot be read will cause an exception to be thrown.

Example classpath:

META-INF/serializables/one META-INF/serializables/two META-INF/serializables/three META-INF/serializables/four/foo.txt

ResourceFinder finder = new ResourceFinder("META-INF/");
Map map = finder.mapAvailableStrings("serializables");
map.contains("one");  // true
map.contains("two");  // true
map.contains("three");  // true
map.contains("four");  // false

Parameters:
uri -
Returns:
a list of the content of each resource URL found
Throws:
IOException - if any of the urls cannot be read

mapAvailableStrings

public Map<String,String> mapAvailableStrings(String uri)
                                       throws IOException
Reads the contents of all non-directory URLs immediately under the specified location and returns them in a map keyed by the file name.

Individual URLs that cannot be read are skipped and added to the list of 'resourcesNotLoaded'

Example classpath:

META-INF/serializables/one META-INF/serializables/two # not readable META-INF/serializables/three META-INF/serializables/four/foo.txt

ResourceFinder finder = new ResourceFinder("META-INF/");
Map map = finder.mapAvailableStrings("serializables");
map.contains("one");  // true
map.contains("two");  // false
map.contains("three");  // true
map.contains("four");  // false

Parameters:
uri -
Returns:
a list of the content of each resource URL found
Throws:
IOException - if classLoader.getResources throws an exception

findClass

public Class findClass(String uri)
                throws IOException,
                       ClassNotFoundException
Executes findString(String) assuming the contents URL found is the name of a class that should be loaded and returned.

Parameters:
uri -
Returns:
Throws:
IOException
ClassNotFoundException

findAllClasses

public List<Class> findAllClasses(String uri)
                           throws IOException,
                                  ClassNotFoundException
Executes findAllStrings assuming the strings are the names of a classes that should be loaded and returned.

Any URL or class that cannot be loaded will cause an exception to be thrown.

Parameters:
uri -
Returns:
Throws:
IOException
ClassNotFoundException

findAvailableClasses

public List<Class> findAvailableClasses(String uri)
                                 throws IOException
Executes findAvailableStrings assuming the strings are the names of a classes that should be loaded and returned.

Any class that cannot be loaded will be skipped and placed in the 'resourcesNotLoaded' collection.

Parameters:
uri -
Returns:
Throws:
IOException - if classLoader.getResources throws an exception

mapAllClasses

public Map<String,Class> mapAllClasses(String uri)
                                throws IOException,
                                       ClassNotFoundException
Executes mapAllStrings assuming the value of each entry in the map is the name of a class that should be loaded.

Any class that cannot be loaded will be cause an exception to be thrown.

Example classpath:

META-INF/xmlparsers/xerces META-INF/xmlparsers/crimson

ResourceFinder finder = new ResourceFinder("META-INF/");
Map map = finder.mapAvailableStrings("xmlparsers");
map.contains("xerces");  // true
map.contains("crimson");  // true
Class xercesClass = map.get("xerces");
Class crimsonClass = map.get("crimson");

Parameters:
uri -
Returns:
Throws:
IOException
ClassNotFoundException

mapAvailableClasses

public Map<String,Class> mapAvailableClasses(String uri)
                                      throws IOException
Executes mapAvailableStrings assuming the value of each entry in the map is the name of a class that should be loaded.

Any class that cannot be loaded will be skipped and placed in the 'resourcesNotLoaded' collection.

Example classpath:

META-INF/xmlparsers/xerces META-INF/xmlparsers/crimson

ResourceFinder finder = new ResourceFinder("META-INF/");
Map map = finder.mapAvailableStrings("xmlparsers");
map.contains("xerces");  // true
map.contains("crimson");  // true
Class xercesClass = map.get("xerces");
Class crimsonClass = map.get("crimson");

Parameters:
uri -
Returns:
Throws:
IOException - if classLoader.getResources throws an exception

findImplementation

public Class findImplementation(Class interfase)
                         throws IOException,
                                ClassNotFoundException
Assumes the class specified points to a file in the classpath that contains the name of a class that implements or is a subclass of the specfied class.

Any class that cannot be loaded will be cause an exception to be thrown.

Example classpath:

META-INF/java.io.InputStream # contains the classname org.acme.AcmeInputStream META-INF/java.io.OutputStream

ResourceFinder finder = new ResourceFinder("META-INF/");
Class clazz = finder.findImplementation(java.io.InputStream.class);
clazz.getName();  // returns "org.acme.AcmeInputStream"

Parameters:
interfase - a superclass or interface
Returns:
Throws:
IOException - if the URL cannot be read
ClassNotFoundException - if the class found is not loadable
ClassCastException - if the class found is not assignable to the specified superclass or interface

findAllImplementations

public List<Class> findAllImplementations(Class interfase)
                                   throws IOException,
                                          ClassNotFoundException
Assumes the class specified points to a file in the classpath that contains the name of a class that implements or is a subclass of the specfied class.

Any class that cannot be loaded or assigned to the specified interface will be cause an exception to be thrown.

Example classpath:

META-INF/java.io.InputStream # contains the classname org.acme.AcmeInputStream META-INF/java.io.InputStream # contains the classname org.widget.NeatoInputStream META-INF/java.io.InputStream # contains the classname com.foo.BarInputStream

ResourceFinder finder = new ResourceFinder("META-INF/");
List classes = finder.findAllImplementations(java.io.InputStream.class);
classes.contains("org.acme.AcmeInputStream");  // true
classes.contains("org.widget.NeatoInputStream");  // true
classes.contains("com.foo.BarInputStream");  // true

Parameters:
interfase - a superclass or interface
Returns:
Throws:
IOException - if the URL cannot be read
ClassNotFoundException - if the class found is not loadable
ClassCastException - if the class found is not assignable to the specified superclass or interface

findAvailableImplementations

public List<Class> findAvailableImplementations(Class interfase)
                                         throws IOException
Assumes the class specified points to a file in the classpath that contains the name of a class that implements or is a subclass of the specfied class.

Any class that cannot be loaded or are not assignable to the specified class will be skipped and placed in the 'resourcesNotLoaded' collection.

Example classpath:

META-INF/java.io.InputStream # contains the classname org.acme.AcmeInputStream META-INF/java.io.InputStream # contains the classname org.widget.NeatoInputStream META-INF/java.io.InputStream # contains the classname com.foo.BarInputStream

ResourceFinder finder = new ResourceFinder("META-INF/");
List classes = finder.findAllImplementations(java.io.InputStream.class);
classes.contains("org.acme.AcmeInputStream");  // true
classes.contains("org.widget.NeatoInputStream");  // true
classes.contains("com.foo.BarInputStream");  // true

Parameters:
interfase - a superclass or interface
Returns:
Throws:
IOException - if classLoader.getResources throws an exception

mapAllImplementations

public Map<String,Class> mapAllImplementations(Class interfase)
                                        throws IOException,
                                               ClassNotFoundException
Assumes the class specified points to a directory in the classpath that holds files containing the name of a class that implements or is a subclass of the specfied class.

Any class that cannot be loaded or assigned to the specified interface will be cause an exception to be thrown.

Example classpath:

META-INF/java.net.URLStreamHandler/jar META-INF/java.net.URLStreamHandler/file META-INF/java.net.URLStreamHandler/http

ResourceFinder finder = new ResourceFinder("META-INF/");
Map map = finder.mapAllImplementations(java.net.URLStreamHandler.class);
Class jarUrlHandler = map.get("jar");
Class fileUrlHandler = map.get("file");
Class httpUrlHandler = map.get("http");

Parameters:
interfase - a superclass or interface
Returns:
Throws:
IOException - if the URL cannot be read
ClassNotFoundException - if the class found is not loadable
ClassCastException - if the class found is not assignable to the specified superclass or interface

mapAvailableImplementations

public Map<String,Class> mapAvailableImplementations(Class interfase)
                                              throws IOException
Assumes the class specified points to a directory in the classpath that holds files containing the name of a class that implements or is a subclass of the specfied class.

Any class that cannot be loaded or are not assignable to the specified class will be skipped and placed in the 'resourcesNotLoaded' collection.

Example classpath:

META-INF/java.net.URLStreamHandler/jar META-INF/java.net.URLStreamHandler/file META-INF/java.net.URLStreamHandler/http

ResourceFinder finder = new ResourceFinder("META-INF/");
Map map = finder.mapAllImplementations(java.net.URLStreamHandler.class);
Class jarUrlHandler = map.get("jar");
Class fileUrlHandler = map.get("file");
Class httpUrlHandler = map.get("http");

Parameters:
interfase - a superclass or interface
Returns:
Throws:
IOException - if classLoader.getResources throws an exception

findProperties

public Properties findProperties(String uri)
                          throws IOException
Finds the corresponding resource and reads it in as a properties file

Example classpath:

META-INF/widget.properties

ResourceFinder finder = new ResourceFinder("META-INF/"); Properties widgetProps = finder.findProperties("widget.properties");

Parameters:
uri -
Returns:
Throws:
IOException - if the URL cannot be read or is not in properties file format

findAllProperties

public List<Properties> findAllProperties(String uri)
                                   throws IOException
Finds the corresponding resources and reads them in as a properties files

Any URL that cannot be read in as a properties file will cause an exception to be thrown.

Example classpath:

META-INF/app.properties META-INF/app.properties META-INF/app.properties

ResourceFinder finder = new ResourceFinder("META-INF/"); List appProps = finder.findAllProperties("app.properties");

Parameters:
uri -
Returns:
Throws:
IOException - if the URL cannot be read or is not in properties file format

findAvailableProperties

public List<Properties> findAvailableProperties(String uri)
                                         throws IOException
Finds the corresponding resources and reads them in as a properties files

Any URL that cannot be read in as a properties file will be added to the 'resourcesNotLoaded' collection.

Example classpath:

META-INF/app.properties META-INF/app.properties META-INF/app.properties

ResourceFinder finder = new ResourceFinder("META-INF/"); List appProps = finder.findAvailableProperties("app.properties");

Parameters:
uri -
Returns:
Throws:
IOException - if classLoader.getResources throws an exception

mapAllProperties

public Map<String,Properties> mapAllProperties(String uri)
                                        throws IOException
Finds the corresponding resources and reads them in as a properties files

Any URL that cannot be read in as a properties file will cause an exception to be thrown.

Example classpath:

META-INF/jdbcDrivers/oracle.properties META-INF/jdbcDrivers/mysql.props META-INF/jdbcDrivers/derby

ResourceFinder finder = new ResourceFinder("META-INF/");
List driversList = finder.findAvailableProperties("jdbcDrivers");
Properties oracleProps = driversList.get("oracle.properties");
Properties mysqlProps = driversList.get("mysql.props");
Properties derbyProps = driversList.get("derby");

Parameters:
uri -
Returns:
Throws:
IOException - if the URL cannot be read or is not in properties file format

mapAvailableProperties

public Map<String,Properties> mapAvailableProperties(String uri)
                                              throws IOException
Finds the corresponding resources and reads them in as a properties files

Any URL that cannot be read in as a properties file will be added to the 'resourcesNotLoaded' collection.

Example classpath:

META-INF/jdbcDrivers/oracle.properties META-INF/jdbcDrivers/mysql.props META-INF/jdbcDrivers/derby

ResourceFinder finder = new ResourceFinder("META-INF/");
List driversList = finder.findAvailableProperties("jdbcDrivers");
Properties oracleProps = driversList.get("oracle.properties");
Properties mysqlProps = driversList.get("mysql.props");
Properties derbyProps = driversList.get("derby");

Parameters:
uri -
Returns:
Throws:
IOException - if classLoader.getResources throws an exception

getResourcesMap

public Map<String,URL> getResourcesMap(String uri)
                                throws IOException
Throws:
IOException

findPackages

public Set<String> findPackages(String uri)
                         throws IOException
Gets a list of subpckages from jars or dirs

Throws:
IOException

findPackagesMap

public Map<URL,Set<String>> findPackagesMap(String uri)
                                     throws IOException
Gets a list of subpckages from jars or dirs

Throws:
IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Test (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.finder
Interface Test<T>

public interface Test<T>

This is the testing interface that is used to accept or reject resources.

Method Summary
 boolean test(T t)
The test method.

Method Detail

test

boolean test(T t)
The test method.

Parameters:
t - The resource object to test.
Returns:
True if the resource should be accepted, false otherwise.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UrlSet (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.finder
Class UrlSet

java.lang.Object
    extended by  com.opensymphony.xwork2.util.finder.UrlSet

public class UrlSet
extends Object

Use with ClassFinder to filter the Urls to be scanned, example:

 UrlSet urlSet = new UrlSet(classLoader);
 urlSet = urlSet.exclude(ClassLoader.getSystemClassLoader().getParent());
 urlSet = urlSet.excludeJavaExtDirs();
 urlSet = urlSet.excludeJavaEndorsedDirs();
 urlSet = urlSet.excludeJavaHome();
 urlSet = urlSet.excludePaths(System.getProperty("sun.boot.class.path", ""));
 urlSet = urlSet.exclude(".*?/JavaVM.framework/.*");
 urlSet = urlSet.exclude(".*?/activemq-(core|ra)-[\\d.]+.jar(!/)?");

Version:
$Rev$ $Date$
Author:
David Blevins

Constructor Summary
UrlSet(ClassLoaderInterface classLoader)
UrlSet(ClassLoaderInterface classLoader, Set<String> protocols)
UrlSet(Collection<URL> urls)
Ignores all URLs that are not "jar" or "file"
UrlSet(URL... urls)
Method Summary
 UrlSet exclude(ClassLoaderInterface parent)
 UrlSet exclude(File file)
 UrlSet exclude(String pattern)
 UrlSet exclude(UrlSet urlSet)
 UrlSet excludeJavaEndorsedDirs()
Calls excludePaths(System.getProperty("java.endorsed.dirs"))
 UrlSet excludeJavaExtDirs()
Calls excludePaths(System.getProperty("java.ext.dirs"))
 UrlSet excludeJavaHome()
 UrlSet excludePaths(String pathString)
 List<URL> getUrls()
 UrlSet include(UrlSet urlSet)
 UrlSet includeClassesUrl(ClassLoaderInterface classLoaderInterface)
Try to find a classes directory inside a war file add its normalized url to this set
 UrlSet matching(String pattern)
 UrlSet relative(File file)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UrlSet

public UrlSet(ClassLoaderInterface classLoader)
       throws IOException
Throws:
IOException

UrlSet

public UrlSet(ClassLoaderInterface classLoader,
              Set<String> protocols)
       throws IOException
Throws:
IOException

UrlSet

public UrlSet(URL... urls)

UrlSet

public UrlSet(Collection<URL> urls)
Ignores all URLs that are not "jar" or "file"

Parameters:
urls -
Method Detail

include

public UrlSet include(UrlSet urlSet)

exclude

public UrlSet exclude(UrlSet urlSet)

exclude

public UrlSet exclude(ClassLoaderInterface parent)
               throws IOException
Throws:
IOException

exclude

public UrlSet exclude(File file)
               throws MalformedURLException
Throws:
MalformedURLException

exclude

public UrlSet exclude(String pattern)
               throws MalformedURLException
Throws:
MalformedURLException

excludeJavaExtDirs

public UrlSet excludeJavaExtDirs()
                          throws MalformedURLException
Calls excludePaths(System.getProperty("java.ext.dirs"))

Returns:
Throws:
MalformedURLException

excludeJavaEndorsedDirs

public UrlSet excludeJavaEndorsedDirs()
                               throws MalformedURLException
Calls excludePaths(System.getProperty("java.endorsed.dirs"))

Returns:
Throws:
MalformedURLException

excludeJavaHome

public UrlSet excludeJavaHome()
                       throws MalformedURLException
Throws:
MalformedURLException

excludePaths

public UrlSet excludePaths(String pathString)
                    throws MalformedURLException
Throws:
MalformedURLException

matching

public UrlSet matching(String pattern)

includeClassesUrl

public UrlSet includeClassesUrl(ClassLoaderInterface classLoaderInterface)
                         throws IOException
Try to find a classes directory inside a war file add its normalized url to this set

Throws:
IOException

relative

public UrlSet relative(File file)
                throws MalformedURLException
Throws:
MalformedURLException

getUrls

public List<URL> getUrls()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.opensymphony.xwork2.util.finder.ClassFinder (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.finder.ClassFinder

No usage of com.opensymphony.xwork2.util.finder.ClassFinder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.finder.ClassFinder.Annotatable (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.finder.ClassFinder.Annotatable

Packages that use ClassFinder.Annotatable
com.opensymphony.xwork2.util.finder

Uses of ClassFinder.Annotatable in com.opensymphony.xwork2.util.finder

Subclasses of ClassFinder.Annotatable in com.opensymphony.xwork2.util.finder
class | ClassFinder.AnnotationInfo
class | ClassFinder.ClassInfo
class | ClassFinder.FieldInfo
class | ClassFinder.MethodInfo
class | ClassFinder.PackageInfo

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.finder.ClassFinder.AnnotationInfo (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.finder.ClassFinder.AnnotationInfo

Packages that use ClassFinder.AnnotationInfo
com.opensymphony.xwork2.util.finder

Uses of ClassFinder.AnnotationInfo in com.opensymphony.xwork2.util.finder

Methods in com.opensymphony.xwork2.util.finder that return types with arguments of type ClassFinder.AnnotationInfo
List<ClassFinder.AnnotationInfo> | ClassFinder.Annotatable.getAnnotations()
List<ClassFinder.AnnotationInfo> | ClassFinder.Info.getAnnotations()
List<List<ClassFinder.AnnotationInfo>> | ClassFinder.MethodInfo.getParameterAnnotations()
List<ClassFinder.AnnotationInfo> | ClassFinder.MethodInfo.getParameterAnnotations(int index)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.finder.ClassFinder.ClassInfo (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.finder.ClassFinder.ClassInfo

Packages that use ClassFinder.ClassInfo
com.opensymphony.xwork2.util.finder

Uses of ClassFinder.ClassInfo in com.opensymphony.xwork2.util.finder

Methods in com.opensymphony.xwork2.util.finder that return ClassFinder.ClassInfo
ClassFinder.ClassInfo | ClassFinder.MethodInfo.getDeclaringClass()
ClassFinder.ClassInfo | ClassFinder.FieldInfo.getDeclaringClass()

Method parameters in com.opensymphony.xwork2.util.finder with type arguments of type ClassFinder.ClassInfo
 List<Class> ClassFinder.findClasses(Test<ClassFinder.ClassInfo> test)

Constructors in com.opensymphony.xwork2.util.finder with parameters of type ClassFinder.ClassInfo
ClassFinder.FieldInfo(ClassFinder.ClassInfo info, Field field)
ClassFinder.FieldInfo(ClassFinder.ClassInfo declaringClass, String name, String type)
ClassFinder.MethodInfo(ClassFinder.ClassInfo info, Constructor constructor)
ClassFinder.MethodInfo(ClassFinder.ClassInfo info, Method method)
ClassFinder.MethodInfo(ClassFinder.ClassInfo declarignClass, String name, String returnType)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.finder.ClassFinder.FieldInfo (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.finder.ClassFinder.FieldInfo

Packages that use ClassFinder.FieldInfo
com.opensymphony.xwork2.util.finder

Uses of ClassFinder.FieldInfo in com.opensymphony.xwork2.util.finder

Methods in com.opensymphony.xwork2.util.finder that return types with arguments of type ClassFinder.FieldInfo
 List<ClassFinder.FieldInfo> ClassFinder.ClassInfo.getFields()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.finder.ClassFinder.Info (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.util.finder.ClassFinder.Info

Packages that use ClassFinder.Info
com.opensymphony.xwork2.util.finder

Uses of ClassFinder.Info in com.opensymphony.xwork2.util.finder

Classes in com.opensymphony.xwork2.util.finder that implement ClassFinder.Info
class | ClassFinder.AnnotationInfo
class | ClassFinder.ClassInfo
class | ClassFinder.FieldInfo
class | ClassFinder.MethodInfo
class | ClassFinder.PackageInfo

Constructors in com.opensymphony.xwork2.util.finder with parameters of type ClassFinder.Info
ClassFinder.InfoBuildingVisitor(ClassFinder.Info info)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.finder.ClassFinder.InfoBuildingVisitor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.finder.ClassFinder.InfoBuildingVisitor

No usage of com.opensymphony.xwork2.util.finder.ClassFinder.InfoBuildingVisitor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.finder.ClassFinder.MethodInfo (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.finder.ClassFinder.MethodInfo

Packages that use ClassFinder.MethodInfo
com.opensymphony.xwork2.util.finder

Uses of ClassFinder.MethodInfo in com.opensymphony.xwork2.util.finder

Methods in com.opensymphony.xwork2.util.finder that return types with arguments of type ClassFinder.MethodInfo
List<ClassFinder.MethodInfo> | ClassFinder.ClassInfo.getConstructors()
List<ClassFinder.MethodInfo> | ClassFinder.ClassInfo.getMethods()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.finder.ClassFinder.PackageInfo (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.finder.ClassFinder.PackageInfo

No usage of com.opensymphony.xwork2.util.finder.ClassFinder.PackageInfo

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.finder.ClassLoaderInterface (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.util.finder.ClassLoaderInterface

Packages that use ClassLoaderInterface
com.opensymphony.xwork2.util.finder

Uses of ClassLoaderInterface in com.opensymphony.xwork2.util.finder

Classes in com.opensymphony.xwork2.util.finder that implement ClassLoaderInterface
 class ClassLoaderInterfaceDelegate
Default implementation of ClassLoaderInterface, which delegates to an actual ClassLoader

Methods in com.opensymphony.xwork2.util.finder that return ClassLoaderInterface
ClassLoaderInterface | ClassLoaderInterfaceDelegate.getParent()
ClassLoaderInterface | ClassLoaderInterface.getParent()

Methods in com.opensymphony.xwork2.util.finder with parameters of type ClassLoaderInterface
UrlSet | UrlSet.exclude(ClassLoaderInterface parent)
UrlSet | UrlSet.includeClassesUrl(ClassLoaderInterface classLoaderInterface) Try to find a classes directory inside a war file add its normalized url to this set

Constructors in com.opensymphony.xwork2.util.finder with parameters of type ClassLoaderInterface
ClassFinder(ClassLoaderInterface classLoader)
Creates a ClassFinder that will search the urls in the specified ClassLoaderInterface excluding the urls in the ClassLoaderInterface's parent.
ClassFinder(ClassLoaderInterface classLoader, boolean excludeParent)
Creates a ClassFinder that will search the urls in the specified ClassLoaderInterface.
ClassFinder(ClassLoaderInterface classLoader, ClassLoaderInterface exclude)
Creates a ClassFinder that will search the urls in the specified classloader excluding the urls in the 'exclude' ClassLoaderInterface.
ClassFinder(ClassLoaderInterface classLoaderInterface, Collection<URL> urls)
ClassFinder(ClassLoaderInterface classLoaderInterface, Collection<URL> urls, boolean extractBaseInterfaces)
ClassFinder(ClassLoaderInterface classLoaderInterface, Collection<URL> urls, boolean extractBaseInterfaces, Set<String> protocols)
ClassFinder(ClassLoaderInterface classLoader, String... dirNames)
ClassFinder(ClassLoaderInterface classLoader, URL url)
ResourceFinder(String path, ClassLoaderInterface classLoaderInterface)
ResourceFinder(String path, ClassLoaderInterface classLoaderInterface, URL... urls)
UrlSet(ClassLoaderInterface classLoader)
UrlSet(ClassLoaderInterface classLoader, Set<String> protocols)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.finder.ClassLoaderInterfaceDelegate (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.finder.ClassLoaderInterfaceDelegate

No usage of com.opensymphony.xwork2.util.finder.ClassLoaderInterfaceDelegate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.finder.ResourceFinder (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.finder.ResourceFinder

No usage of com.opensymphony.xwork2.util.finder.ResourceFinder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.finder.Test (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.util.finder.Test

Packages that use Test
com.opensymphony.xwork2.util.finder

Uses of Test in com.opensymphony.xwork2.util.finder

Methods in com.opensymphony.xwork2.util.finder with parameters of type Test
 List<Class> ClassFinder.findClasses(Test<ClassFinder.ClassInfo> test)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.finder.UrlSet (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.finder.UrlSet

Packages that use UrlSet
com.opensymphony.xwork2.util.finder

Uses of UrlSet in com.opensymphony.xwork2.util.finder

Methods in com.opensymphony.xwork2.util.finder that return UrlSet
 UrlSet UrlSet.exclude(ClassLoaderInterface parent)
 UrlSet UrlSet.exclude(File file)
 UrlSet UrlSet.exclude(String pattern)
 UrlSet UrlSet.exclude(UrlSet urlSet)
 UrlSet UrlSet.excludeJavaEndorsedDirs()
Calls excludePaths(System.getProperty("java.endorsed.dirs"))
 UrlSet UrlSet.excludeJavaExtDirs()
Calls excludePaths(System.getProperty("java.ext.dirs"))
 UrlSet UrlSet.excludeJavaHome()
 UrlSet UrlSet.excludePaths(String pathString)
 UrlSet UrlSet.include(UrlSet urlSet)
 UrlSet UrlSet.includeClassesUrl(ClassLoaderInterface classLoaderInterface)
Try to find a classes directory inside a war file add its normalized url to this set
 UrlSet UrlSet.matching(String pattern)
 UrlSet UrlSet.relative(File file)

Methods in com.opensymphony.xwork2.util.finder with parameters of type UrlSet
UrlSet | UrlSet.exclude(UrlSet urlSet)
UrlSet | UrlSet.include(UrlSet urlSet)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Locatable (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.location
Interface Locatable

All Known Implementing Classes:
ActionConfig, ConfigurationException, ExceptionMappingConfig, InterceptorConfig, InterceptorStackConfig, LocatableConstantFactory, LocatableFactory, LocatableProperties, Located, PackageConfig, ReferenceResolverException, ReflectionException, ResultConfig, ResultTypeConfig, TypeConversionException, ValidatorConfig, XWorkException
public interface Locatable

A interface that should be implemented by objects knowning their location (i.e. where they have been created from).

Method Summary
 Location getLocation()
Get the location of this object

Method Detail

getLocation

Location getLocation()
Get the location of this object

Returns:
the location
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


LocatableProperties (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.location
Class LocatableProperties

java.lang.Object
    extended by  java.util.Dictionary<K,V>
        extended by  java.util.Hashtable<Object,Object>
            extended by  java.util.Properties
                extended by  com.opensymphony.xwork2.util.location.LocatableProperties
All Implemented Interfaces:
Locatable, Serializable, Cloneable, Map<Object,Object>
public class LocatableProperties
extends Properties
implements Locatable

Properties implementation that remembers the location of each property. When loaded, a custom properties file parser is used to remember both the line number and preceeding comments for each property entry.

See Also:
Serialized Form

Field Summary
Fields inherited from class java.util.Properties
defaults
Constructor Summary
LocatableProperties()
LocatableProperties(Location loc)
Method Summary
Location | getLocation() Get the location of this object
Location | getPropertyLocation(String key)
void | load(InputStream in)
Object | setProperty(String key, String value, Object locationObj)
Methods inherited from class java.util.Properties
getProperty, getProperty, list, list, load, loadFromXML, propertyNames, save, setProperty, store, store, storeToXML, storeToXML, stringPropertyNames
Methods inherited from class java.util.Hashtable
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

LocatableProperties

public LocatableProperties()

LocatableProperties

public LocatableProperties(Location loc)
Method Detail

load

public void load(InputStream in)
          throws IOException
Overrides:
load in class Properties
Throws:
IOException

setProperty

public Object setProperty(String key,
                          String value,
                          Object locationObj)

getPropertyLocation

public Location getPropertyLocation(String key)

getLocation

public Location getLocation()
Description copied from interface: Locatable
Get the location of this object

Specified by:
getLocation in interface Locatable
Returns:
the location
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Located (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.location
Class Located

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
All Implemented Interfaces:
Locatable
Direct Known Subclasses:
ActionConfig, ExceptionMappingConfig, InterceptorConfig, InterceptorStackConfig, LocatableConstantFactory, LocatableFactory, PackageConfig, ResultConfig, ResultTypeConfig, ValidatorConfig
public abstract class Located
extends Object
implements Locatable

Base class for location aware objects

Field Summary
protected  Location location
Constructor Summary
Located()
Method Summary
Location | getLocation() Get the location of this object
void | setLocation(Location loc) Set the location of this object
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

location

protected Location location
Constructor Detail

Located

public Located()
Method Detail

getLocation

public Location getLocation()
Get the location of this object

Specified by:
getLocation in interface Locatable
Returns:
the location

setLocation

public void setLocation(Location loc)
Set the location of this object

Parameters:
loc - the location
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Location (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.location
Interface Location

All Known Implementing Classes:
LocationImpl
public interface Location

A location in a resource. The location is composed of the URI of the resource, and the line and column numbers within that resource (when available), along with a description.

Locations are mostly provided by Locatables objects.

Field Summary
static Location UNKNOWN
Constant for unknown locations.
Method Summary
int | getColumnNumber() Get the column number of this location
String | getDescription() Get the description of this location
int | getLineNumber() Get the line number of this location
List<String> | getSnippet(int padding) Gets a source code snippet with the default padding
String | getURI() Get the URI of this location

Field Detail

UNKNOWN

static final Location UNKNOWN
Constant for unknown locations.

Method Detail

getDescription

String getDescription()
Get the description of this location

Returns:
the description (can be null)

getURI

String getURI()
Get the URI of this location

Returns:
the URI (null if unknown).

getLineNumber

int getLineNumber()
Get the line number of this location

Returns:
the line number (-1 if unknown)

getColumnNumber

int getColumnNumber()
Get the column number of this location

Returns:
the column number (-1 if unknown)

getSnippet

List<String> getSnippet(int padding)
Gets a source code snippet with the default padding

Parameters:
padding - The amount of lines before and after the error to include
Returns:
A list of source lines
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocationAttributes (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.location
Class LocationAttributes

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.LocationAttributes

public class LocationAttributes
extends Object

A class to handle location information stored in attributes. These attributes are typically setup using LocationAttributes.Pipe which augments the SAX stream with additional attributes, e.g.:

 <root xmlns:loc="http://opensymphony.com/xwork/location"
       loc:src="file://path/to/file.xml"
       loc:line="1" loc:column="1">
   <foo loc:src="file://path/to/file.xml" loc:line="2" loc:column="3"/>
 </root>

Since:
2.1.8
Version:
$Id: LocationAttributes.java 1223 2006-11-23 20:33:15Z rainerh $
See Also:
LocationAttributes.Pipe

Nested Class Summary
static class LocationAttributes.Pipe
A SAX filter that adds the information available from the Locator as attributes.
Field Summary
static String | COL_ATTR Attribute name for the column number
static String | LINE_ATTR Attribute name for the line number
static String | PREFIX Prefix for the location namespace
static String | Q_COL_ATTR Attribute qualified name for the column number
static String | Q_LINE_ATTR Attribute qualified name for the line number
static String | Q_SRC_ATTR Attribute qualified name for the location URI
static String | SRC_ATTR Attribute name for the location URI
static String | URI Namespace URI for location attributes
Method Summary
static Attributes | addLocationAttributes(Locator locator, Attributes attrs) Add location attributes to a set of SAX attributes.
static int | getColumn(Attributes attrs) Returns the column number of an element (SAX flavor)
static int | getColumn(Element elem) Returns the column number of an element (DOM flavor)
static int | getLine(Attributes attrs) Returns the line number of an element (SAX flavor)
static int | getLine(Element elem) Returns the line number of an element (DOM flavor)
static Location | getLocation(Attributes attrs, String description) Returns the Location of an element (SAX flavor).
static Location | getLocation(Element elem) Same as getLocation(elem, null).
static Location | getLocation(Element elem, String description) Returns the Location of an element (DOM flavor).
static String | getLocationString(Attributes attrs) Returns the location of an element (SAX flavor).
static String | getLocationString(Element elem) Returns the location of an element that has been processed by this pipe (DOM flavor).
static String | getURI(Attributes attrs) Returns the URI of an element (SAX flavor)
static String | getURI(Element elem) Returns the URI of an element (DOM flavor)
static void | remove(Element elem, boolean recurse) Remove the location attributes from a DOM element.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PREFIX

public static final String PREFIX
Prefix for the location namespace

See Also:
Constant Field Values

URI

public static final String URI
Namespace URI for location attributes

See Also:
Constant Field Values

SRC_ATTR

public static final String SRC_ATTR
Attribute name for the location URI

See Also:
Constant Field Values

LINE_ATTR

public static final String LINE_ATTR
Attribute name for the line number

See Also:
Constant Field Values

COL_ATTR

public static final String COL_ATTR
Attribute name for the column number

See Also:
Constant Field Values

Q_SRC_ATTR

public static final String Q_SRC_ATTR
Attribute qualified name for the location URI

See Also:
Constant Field Values

Q_LINE_ATTR

public static final String Q_LINE_ATTR
Attribute qualified name for the line number

See Also:
Constant Field Values

Q_COL_ATTR

public static final String Q_COL_ATTR
Attribute qualified name for the column number

See Also:
Constant Field Values
Method Detail

addLocationAttributes

public static Attributes addLocationAttributes(Locator locator,
                                               Attributes attrs)
Add location attributes to a set of SAX attributes.

Parameters:
locator - the Locator (can be null)
attrs - the Attributes where locator information should be added
Returns:
Location enabled Attributes.

getLocation

public static Location getLocation(Attributes attrs,
                                   String description)
Returns the Location of an element (SAX flavor).

Parameters:
attrs - the element's attributes that hold the location information
description - a description for the location (can be null)
Returns:
a Location object

getLocationString

public static String getLocationString(Attributes attrs)
Returns the location of an element (SAX flavor). If the location is to be kept into an object built from this element, consider using getLocation(Attributes, String) and the Locatable interface.

Parameters:
attrs - the element's attributes that hold the location information
Returns:
a location string as defined by Location.

getURI

public static String getURI(Attributes attrs)
Returns the URI of an element (SAX flavor)

Parameters:
attrs - the element's attributes that hold the location information
Returns:
the element's URI or "[unknown location]" if attrs has no location information.

getLine

public static int getLine(Attributes attrs)
Returns the line number of an element (SAX flavor)

Parameters:
attrs - the element's attributes that hold the location information
Returns:
the element's line number or -1 if attrs has no location information.

getColumn

public static int getColumn(Attributes attrs)
Returns the column number of an element (SAX flavor)

Parameters:
attrs - the element's attributes that hold the location information
Returns:
the element's column number or -1 if attrs has no location information.

getLocation

public static Location getLocation(Element elem,
                                   String description)
Returns the Location of an element (DOM flavor).

Parameters:
elem - the element that holds the location information
description - a description for the location (if null, the element's name is used)
Returns:
a Location object

getLocation

public static Location getLocation(Element elem)
Same as getLocation(elem, null).

getLocationString

public static String getLocationString(Element elem)
Returns the location of an element that has been processed by this pipe (DOM flavor). If the location is to be kept into an object built from this element, consider using getLocation(Element) and the Locatable interface.

Parameters:
elem - the element that holds the location information
Returns:
a location string as defined by Location.

getURI

public static String getURI(Element elem)
Returns the URI of an element (DOM flavor)

Parameters:
elem - the element that holds the location information
Returns:
the element's URI or "[unknown location]" if elem has no location information.

getLine

public static int getLine(Element elem)
Returns the line number of an element (DOM flavor)

Parameters:
elem - the element that holds the location information
Returns:
the element's line number or -1 if elem has no location information.

getColumn

public static int getColumn(Element elem)
Returns the column number of an element (DOM flavor)

Parameters:
elem - the element that holds the location information
Returns:
the element's column number or -1 if elem has no location information.

remove

public static void remove(Element elem,
                          boolean recurse)
Remove the location attributes from a DOM element.

Parameters:
elem - the element to remove the location attributes from.
recurse - if true, also remove location attributes on descendant elements.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocationAttributes.Pipe (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.location
Class LocationAttributes.Pipe

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.LocationAttributes.Pipe
All Implemented Interfaces:
ContentHandler
Enclosing class:
LocationAttributes
public static class LocationAttributes.Pipe
extends Object
implements ContentHandler

A SAX filter that adds the information available from the Locator as attributes. The purpose of having location as attributes is to allow this information to survive transformations of the document (an XSL could copy these attributes over) or conversion of SAX events to a DOM.

The location is added as 3 attributes in a specific namespace to each element.

 <root xmlns:loc="http://opensymphony.com/xwork/location"
       loc:src="file://path/to/file.xml"
       loc:line="1" loc:column="1">
   <foo loc:src="file://path/to/file.xml" loc:line="2" loc:column="3"/>
 </root>
Note: Although this adds a lot of information to the serialized form of the document, the overhead in SAX events is not that big, as attribute names are interned, and all src attributes point to the same string.

See Also:
LocationAttributes

Constructor Summary
LocationAttributes.Pipe()
Create a filter.
LocationAttributes.Pipe(ContentHandler next)
Create a filter that is chained to another handler.
Method Summary
void | characters(char[] arg0, int arg1, int arg2)
void | endDocument()
void | endElement(String arg0, String arg1, String arg2)
void | endPrefixMapping(String arg0)
void | ignorableWhitespace(char[] arg0, int arg1, int arg2)
void | processingInstruction(String arg0, String arg1)
void | setDocumentLocator(Locator locator)
void | skippedEntity(String arg0)
void | startDocument()
void | startElement(String uri, String loc, String raw, Attributes attrs)
void | startPrefixMapping(String arg0, String arg1)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LocationAttributes.Pipe

public LocationAttributes.Pipe()
Create a filter. It has to be chained to another handler to be really useful.

LocationAttributes.Pipe

public LocationAttributes.Pipe(ContentHandler next)
Create a filter that is chained to another handler.

Parameters:
next - the next handler in the chain.
Method Detail

setDocumentLocator

public void setDocumentLocator(Locator locator)
Specified by:
setDocumentLocator in interface ContentHandler

startDocument

public void startDocument()
                   throws SAXException
Specified by:
startDocument in interface ContentHandler
Throws:
SAXException

endDocument

public void endDocument()
                 throws SAXException
Specified by:
endDocument in interface ContentHandler
Throws:
SAXException

startElement

public void startElement(String uri,
                         String loc,
                         String raw,
                         Attributes attrs)
                  throws SAXException
Specified by:
startElement in interface ContentHandler
Throws:
SAXException

endElement

public void endElement(String arg0,
                       String arg1,
                       String arg2)
                throws SAXException
Specified by:
endElement in interface ContentHandler
Throws:
SAXException

startPrefixMapping

public void startPrefixMapping(String arg0,
                               String arg1)
                        throws SAXException
Specified by:
startPrefixMapping in interface ContentHandler
Throws:
SAXException

endPrefixMapping

public void endPrefixMapping(String arg0)
                      throws SAXException
Specified by:
endPrefixMapping in interface ContentHandler
Throws:
SAXException

characters

public void characters(char[] arg0,
                       int arg1,
                       int arg2)
                throws SAXException
Specified by:
characters in interface ContentHandler
Throws:
SAXException

ignorableWhitespace

public void ignorableWhitespace(char[] arg0,
                                int arg1,
                                int arg2)
                         throws SAXException
Specified by:
ignorableWhitespace in interface ContentHandler
Throws:
SAXException

processingInstruction

public void processingInstruction(String arg0,
                                  String arg1)
                           throws SAXException
Specified by:
processingInstruction in interface ContentHandler
Throws:
SAXException

skippedEntity

public void skippedEntity(String arg0)
                   throws SAXException
Specified by:
skippedEntity in interface ContentHandler
Throws:
SAXException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocationImpl (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.location
Class LocationImpl

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.LocationImpl
All Implemented Interfaces:
Location, Serializable
public class LocationImpl
extends Object
implements Location, Serializable

A simple immutable and serializable implementation of Location.

See Also:
Serialized Form

Constructor Summary
LocationImpl(Location location)
Copy constructor.
LocationImpl(String description, Location location)
Create a location from an existing one, but with a different description
LocationImpl(String description, String uri)
Build a location for a given URI, with unknown line and column numbers.
LocationImpl(String description, String uri, int line, int column)
Build a location for a given URI and line and column numbers.
Method Summary
boolean | equals(Object obj)
static LocationImpl | get(Location location) Obtain a LocationImpl from a Location.
int | getColumnNumber() Get the column number of this location
String | getDescription() Get the description of this location
int | getLineNumber() Get the line number of this location
List<String> | getSnippet(int padding) Gets a source code snippet with the default padding
String | getURI() Get the URI of this location
int | hashCode()
String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

LocationImpl

public LocationImpl(String description,
                    String uri)
Build a location for a given URI, with unknown line and column numbers.

Parameters:
uri - the resource URI

LocationImpl

public LocationImpl(String description,
                    String uri,
                    int line,
                    int column)
Build a location for a given URI and line and column numbers.

Parameters:
uri - the resource URI
line - the line number (starts at 1)
column - the column number (starts at 1)

LocationImpl

public LocationImpl(Location location)
Copy constructor.

Parameters:
location - the location to be copied

LocationImpl

public LocationImpl(String description,
                    Location location)
Create a location from an existing one, but with a different description

Method Detail

get

public static LocationImpl get(Location location)
Obtain a LocationImpl from a Location. If location is already a LocationImpl, it is returned, otherwise it is copied.

This method is useful when an immutable and serializable location is needed, such as in locatable exceptions.

Parameters:
location - the location
Returns:
an immutable and serializable version of location

getDescription

public String getDescription()
Get the description of this location

Specified by:
getDescription in interface Location
Returns:
the description (can be null)

getURI

public String getURI()
Get the URI of this location

Specified by:
getURI in interface Location
Returns:
the URI (null if unknown).

getLineNumber

public int getLineNumber()
Get the line number of this location

Specified by:
getLineNumber in interface Location
Returns:
the line number (-1 if unknown)

getColumnNumber

public int getColumnNumber()
Get the column number of this location

Specified by:
getColumnNumber in interface Location
Returns:
the column number (-1 if unknown)

getSnippet

public List<String> getSnippet(int padding)
Gets a source code snippet with the default padding

Specified by:
getSnippet in interface Location
Parameters:
padding - The amount of lines before and after the error to include
Returns:
A list of source lines

equals

public boolean equals(Object obj)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocationUtils (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.location
Class LocationUtils

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.LocationUtils

public class LocationUtils
extends Object

Location-related utility methods.

Nested Class Summary
static interface LocationUtils.LocationFinder
An finder or object locations
Field Summary
static String UNKNOWN_STRING
The string representation of an unknown location: "[unknown location]".
Method Summary
static void addFinder(LocationUtils.LocationFinder finder)
Add a LocationUtils.LocationFinder to the list of finders that will be queried for an object's location by getLocation(Object, String).
static Location getLocation(Object obj)
Get the location of an object.
static Location getLocation(Object obj, String description)
Get the location of an object.
static boolean isKnown(Location location)
Checks if a location is known, i.e.
static boolean isUnknown(Location location)
Checks if a location is unknown, i.e.
static LocationImpl parse(String text)
Parse a location string of the form "uri:line:column" (e.g.
static String toString(Location location)
Builds a string representation of a location, in the "descripton - uri:line:column" format (e.g.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

UNKNOWN_STRING

public static final String UNKNOWN_STRING
The string representation of an unknown location: "[unknown location]".

See Also:
Constant Field Values
Method Detail

toString

public static String toString(Location location)
Builds a string representation of a location, in the "descripton - uri:line:column" format (e.g. "foo - file://path/to/file.xml:3:40"). For an unknown location, returns UNKNOWN_STRING.

Returns:
the string representation

parse

public static LocationImpl parse(String text)
                          throws IllegalArgumentException
Parse a location string of the form "uri:line:column" (e.g. "path/to/file.xml:3:40") to a Location object. Additionally, a description may also optionally be present, separated with an hyphen (e.g. "foo - path/to/file.xml:3.40").

Parameters:
text - the text to parse
Returns:
the location (possibly null if text was null or in an incorrect format)
Throws:
IllegalArgumentException

isKnown

public static boolean isKnown(Location location)
Checks if a location is known, i.e. it is not null nor equal to Location.UNKNOWN.

Parameters:
location - the location to check
Returns:
true if the location is known

isUnknown

public static boolean isUnknown(Location location)
Checks if a location is unknown, i.e. it is either null or equal to Location.UNKNOWN.

Parameters:
location - the location to check
Returns:
true if the location is unknown

addFinder

public static void addFinder(LocationUtils.LocationFinder finder)
Add a LocationUtils.LocationFinder to the list of finders that will be queried for an object's location by getLocation(Object, String).

Important: LocationUtils internally stores a weak reference to the finder. This avoids creating strong links between the classloader holding this class and the finder's classloader, which can cause some weird memory leaks if the finder's classloader is to be reloaded. Therefore, you have to keep a strong reference to the finder in the calling code, e.g.:

   private static LocationUtils.LocationFinder myFinder =
       new LocationUtils.LocationFinder() {
           public Location getLocation(Object obj, String desc) {
               ...
           }
       };

   static {
       LocationUtils.addFinder(myFinder);
   }

Parameters:
finder - the location finder to add

getLocation

public static Location getLocation(Object obj)
Get the location of an object. Some well-known located classes built in the JDK are handled by this method. Handling of other located classes can be handled by adding new location finders.

Parameters:
obj - the object of which to get the location
Returns:
the object's location, or Location.UNKNOWN if no location could be found

getLocation

public static Location getLocation(Object obj,
                                   String description)
Get the location of an object. Some well-known located classes built in the JDK are handled by this method. Handling of other located classes can be handled by adding new location finders.

Parameters:
obj - the object of which to get the location
description - an optional description of the object's location, used if a Location object has to be created.
Returns:
the object's location, or Location.UNKNOWN if no location could be found
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocationUtils.LocationFinder (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.location
Interface LocationUtils.LocationFinder

Enclosing class:
LocationUtils
public static interface LocationUtils.LocationFinder

An finder or object locations

Method Summary
 Location getLocation(Object obj, String description)
Get the location of an object

Method Detail

getLocation

Location getLocation(Object obj,
                     String description)
Get the location of an object

Parameters:
obj - the object for which to find a location
description - and optional description to be added to the object's location
Returns:
the object's location or null if object's class isn't handled by this finder.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.util.location (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.util.location
Interfaces
Locatable
Location
LocationUtils.LocationFinder
Classes
LocatableProperties
Located
LocationAttributes
LocationAttributes.Pipe
LocationImpl
LocationUtils


com.opensymphony.xwork2.util.location (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.util.location

Classes and utilities used to track location information.

See:
Description

Interface Summary
Locatable | A interface that should be implemented by objects knowning their location (i.e.
Location | A location in a resource.
LocationUtils.LocationFinder | An finder or object locations

Class Summary
LocatableProperties | Properties implementation that remembers the location of each property.
Located | Base class for location aware objects
LocationAttributes | A class to handle location information stored in attributes.
LocationAttributes.Pipe | A SAX filter that adds the information available from the Locator as attributes.
LocationImpl | A simple immutable and serializable implementation of Location.
LocationUtils | Location-related utility methods.

Package com.opensymphony.xwork2.util.location Description

Classes and utilities used to track location information.


com.opensymphony.xwork2.util.location Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.util.location

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.Dictionary<K,V>
      • java.util.Hashtable<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • java.util.Properties
          • com.opensymphony.xwork2.util.location.LocatableProperties (implements com.opensymphony.xwork2.util.location.Locatable)
    • com.opensymphony.xwork2.util.location.Located (implements com.opensymphony.xwork2.util.location.Locatable)
    • com.opensymphony.xwork2.util.location.LocationAttributes
    • com.opensymphony.xwork2.util.location.LocationAttributes.Pipe (implements org.xml.sax.ContentHandler)
    • com.opensymphony.xwork2.util.location.LocationImpl (implements com.opensymphony.xwork2.util.location.Location, java.io.Serializable)
    • com.opensymphony.xwork2.util.location.LocationUtils

Interface Hierarchy

  • com.opensymphony.xwork2.util.location.Locatable
  • com.opensymphony.xwork2.util.location.Location
  • com.opensymphony.xwork2.util.location.LocationUtils.LocationFinder


Uses of Package com.opensymphony.xwork2.util.location (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.util.location

Packages that use com.opensymphony.xwork2.util.location
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.conversion |
com.opensymphony.xwork2.test |
com.opensymphony.xwork2.util | XWork util classes.
com.opensymphony.xwork2.util.location | Classes and utilities used to track location information.
com.opensymphony.xwork2.util.reflection |
com.opensymphony.xwork2.validator | XWork validation subsystem.

Classes in com.opensymphony.xwork2.util.location used by com.opensymphony.xwork2
Locatable
A interface that should be implemented by objects knowning their location (i.e.
Location
A location in a resource.

Classes in com.opensymphony.xwork2.util.location used by com.opensymphony.xwork2.config
Locatable
A interface that should be implemented by objects knowning their location (i.e.
LocatableProperties
Properties implementation that remembers the location of each property.

Classes in com.opensymphony.xwork2.util.location used by com.opensymphony.xwork2.config.entities
Locatable
A interface that should be implemented by objects knowning their location (i.e.
Located
Base class for location aware objects
Location
A location in a resource.

Classes in com.opensymphony.xwork2.util.location used by com.opensymphony.xwork2.config.impl
Locatable
A interface that should be implemented by objects knowning their location (i.e.
Located
Base class for location aware objects

Classes in com.opensymphony.xwork2.util.location used by com.opensymphony.xwork2.config.providers
LocatableProperties
Properties implementation that remembers the location of each property.
Location
A location in a resource.

Classes in com.opensymphony.xwork2.util.location used by com.opensymphony.xwork2.conversion
Locatable
A interface that should be implemented by objects knowning their location (i.e.

Classes in com.opensymphony.xwork2.util.location used by com.opensymphony.xwork2.test
LocatableProperties
Properties implementation that remembers the location of each property.

Classes in com.opensymphony.xwork2.util.location used by com.opensymphony.xwork2.util
Location
A location in a resource.

Classes in com.opensymphony.xwork2.util.location used by com.opensymphony.xwork2.util.location
Locatable
A interface that should be implemented by objects knowning their location (i.e.
Location
A location in a resource.
LocationImpl
A simple immutable and serializable implementation of Location.
LocationUtils.LocationFinder
An finder or object locations

Classes in com.opensymphony.xwork2.util.location used by com.opensymphony.xwork2.util.reflection
Locatable
A interface that should be implemented by objects knowning their location (i.e.

Classes in com.opensymphony.xwork2.util.location used by com.opensymphony.xwork2.validator
Locatable
A interface that should be implemented by objects knowning their location (i.e.
Located
Base class for location aware objects
Location
A location in a resource.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.location.Locatable (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.util.location.Locatable

Packages that use Locatable
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.conversion |
com.opensymphony.xwork2.util.location | Classes and utilities used to track location information.
com.opensymphony.xwork2.util.reflection |
com.opensymphony.xwork2.validator | XWork validation subsystem.

Uses of Locatable in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement Locatable
 class XWorkException
A generic runtime exception that optionally contains Location information

Uses of Locatable in com.opensymphony.xwork2.config

Classes in com.opensymphony.xwork2.config that implement Locatable
class | ConfigurationException ConfigurationException
class | ReferenceResolverException Exception when a reference can't be resolved.

Uses of Locatable in com.opensymphony.xwork2.config.entities

Classes in com.opensymphony.xwork2.config.entities that implement Locatable
class | ActionConfig Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.
class | ExceptionMappingConfig Configuration for exception mapping.
class | InterceptorConfig Configuration for Interceptors.
class | InterceptorStackConfig Configuration for InterceptorStack.
class | PackageConfig Configuration for Package.
class | ResultConfig Configuration for Result.
class | ResultTypeConfig Configuration class for result types.

Uses of Locatable in com.opensymphony.xwork2.config.impl

Classes in com.opensymphony.xwork2.config.impl that implement Locatable
class | LocatableConstantFactory<T> Factory that remembers where a constant came from
class | LocatableFactory<T> Attaches location information to the factory.

Uses of Locatable in com.opensymphony.xwork2.conversion

Classes in com.opensymphony.xwork2.conversion that implement Locatable
 class TypeConversionException
TypeConversionException should be thrown by any TypeConverters which fail to convert values

Uses of Locatable in com.opensymphony.xwork2.util.location

Classes in com.opensymphony.xwork2.util.location that implement Locatable
class | LocatableProperties Properties implementation that remembers the location of each property.
class | Located Base class for location aware objects

Uses of Locatable in com.opensymphony.xwork2.util.reflection

Classes in com.opensymphony.xwork2.util.reflection that implement Locatable
 class ReflectionException

Uses of Locatable in com.opensymphony.xwork2.validator

Classes in com.opensymphony.xwork2.validator that implement Locatable
 class ValidatorConfig
Holds the necessary information for configuring an instance of a Validator.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.location.LocatableProperties (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.location.LocatableProperties

Packages that use LocatableProperties
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.test |

Uses of LocatableProperties in com.opensymphony.xwork2.config

Methods in com.opensymphony.xwork2.config with parameters of type LocatableProperties
 void ContainerProvider.register(ContainerBuilder builder, LocatableProperties props)
Registers beans and properties for the Container

Uses of LocatableProperties in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers with parameters of type LocatableProperties
void | XWorkConfigurationProvider.register(ContainerBuilder builder, LocatableProperties props)
void | XmlConfigurationProvider.register(ContainerBuilder containerBuilder, LocatableProperties props)

Uses of LocatableProperties in com.opensymphony.xwork2.test

Methods in com.opensymphony.xwork2.test with parameters of type LocatableProperties
 void StubConfigurationProvider.register(ContainerBuilder builder, LocatableProperties props)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.location.Located (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.location.Located

Packages that use Located
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.

Uses of Located in com.opensymphony.xwork2.config.entities

Subclasses of Located in com.opensymphony.xwork2.config.entities
class | ActionConfig Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.
class | ExceptionMappingConfig Configuration for exception mapping.
class | InterceptorConfig Configuration for Interceptors.
class | InterceptorStackConfig Configuration for InterceptorStack.
class | PackageConfig Configuration for Package.
class | ResultConfig Configuration for Result.
class | ResultTypeConfig Configuration class for result types.

Uses of Located in com.opensymphony.xwork2.config.impl

Subclasses of Located in com.opensymphony.xwork2.config.impl
class | LocatableConstantFactory<T> Factory that remembers where a constant came from
class | LocatableFactory<T> Attaches location information to the factory.

Uses of Located in com.opensymphony.xwork2.validator

Subclasses of Located in com.opensymphony.xwork2.validator
 class ValidatorConfig
Holds the necessary information for configuring an instance of a Validator.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.location.Location (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.util.location.Location

Packages that use Location
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.util | XWork util classes.
com.opensymphony.xwork2.util.location | Classes and utilities used to track location information.
com.opensymphony.xwork2.validator | XWork validation subsystem.

Uses of Location in com.opensymphony.xwork2

Methods in com.opensymphony.xwork2 that return Location
 Location XWorkException.getLocation()
Gets the location of the error, if available

Uses of Location in com.opensymphony.xwork2.config.entities

Methods in com.opensymphony.xwork2.config.entities with parameters of type Location
ResultTypeConfig.Builder | ResultTypeConfig.Builder.location(Location loc)
ResultConfig.Builder | ResultConfig.Builder.location(Location loc)
PackageConfig.Builder | PackageConfig.Builder.location(Location loc)
InterceptorStackConfig.Builder | InterceptorStackConfig.Builder.location(Location loc)
InterceptorConfig.Builder | InterceptorConfig.Builder.location(Location loc)
ExceptionMappingConfig.Builder | ExceptionMappingConfig.Builder.location(Location loc)
ActionConfig.Builder | ActionConfig.Builder.location(Location loc)

Uses of Location in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers with parameters of type Location
static List<InterceptorMapping> | InterceptorBuilder.constructInterceptorReference(InterceptorLocator interceptorLocator, String refName, Map<String,String> refParams, Location location, ObjectFactory objectFactory) Builds a list of interceptors referenced by the refName in the supplied PackageConfig (InterceptorMapping object).
protected boolean | XmlConfigurationProvider.verifyAction(String className, String name, Location loc)
protected Class | XmlConfigurationProvider.verifyResultType(String className, Location loc)

Uses of Location in com.opensymphony.xwork2.util

Methods in com.opensymphony.xwork2.util that return Location
static Location DomHelper.getLocationObject(Element element)

Uses of Location in com.opensymphony.xwork2.util.location

Classes in com.opensymphony.xwork2.util.location that implement Location
 class LocationImpl
A simple immutable and serializable implementation of Location.

Fields in com.opensymphony.xwork2.util.location declared as Location
protected Location | Located.location
static Location | Location.UNKNOWN Constant for unknown locations.

Methods in com.opensymphony.xwork2.util.location that return Location
 Location Located.getLocation()
Get the location of this object
 Location LocatableProperties.getLocation()
 Location Locatable.getLocation()
Get the location of this object
static Location LocationAttributes.getLocation(Attributes attrs, String description)
Returns the Location of an element (SAX flavor).
static Location LocationAttributes.getLocation(Element elem)
Same as getLocation(elem, null).
static Location LocationAttributes.getLocation(Element elem, String description)
Returns the Location of an element (DOM flavor).
static Location LocationUtils.getLocation(Object obj)
Get the location of an object.
static Location LocationUtils.getLocation(Object obj, String description)
Get the location of an object.
 Location LocationUtils.LocationFinder.getLocation(Object obj, String description)
Get the location of an object
 Location LocatableProperties.getPropertyLocation(String key)

Methods in com.opensymphony.xwork2.util.location with parameters of type Location
static LocationImpl | LocationImpl.get(Location location) Obtain a LocationImpl from a Location.
static boolean | LocationUtils.isKnown(Location location) Checks if a location is known, i.e.
static boolean | LocationUtils.isUnknown(Location location) Checks if a location is unknown, i.e.
void | Located.setLocation(Location loc) Set the location of this object
static String | LocationUtils.toString(Location location) Builds a string representation of a location, in the "descripton - uri:line:column" format (e.g.

Constructors in com.opensymphony.xwork2.util.location with parameters of type Location
LocatableProperties(Location loc)
LocationImpl(Location location)
Copy constructor.
LocationImpl(String description, Location location)
Create a location from an existing one, but with a different description

Uses of Location in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type Location
 ValidatorConfig.Builder ValidatorConfig.Builder.location(Location loc)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.location.LocationAttributes (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.location.LocationAttributes

No usage of com.opensymphony.xwork2.util.location.LocationAttributes

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.location.LocationAttributes.Pipe

No usage of com.opensymphony.xwork2.util.location.LocationAttributes.Pipe

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.location.LocationImpl (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.location.LocationImpl

Packages that use LocationImpl
com.opensymphony.xwork2.util.location Classes and utilities used to track location information.

Uses of LocationImpl in com.opensymphony.xwork2.util.location

Methods in com.opensymphony.xwork2.util.location that return LocationImpl
static LocationImpl | LocationImpl.get(Location location) Obtain a LocationImpl from a Location.
static LocationImpl | LocationUtils.parse(String text) Parse a location string of the form "uri:line:column" (e.g.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.location.LocationUtils (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.location.LocationUtils

No usage of com.opensymphony.xwork2.util.location.LocationUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.location.LocationUtils.LocationFinder (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.util.location.LocationUtils.LocationFinder

Packages that use LocationUtils.LocationFinder
com.opensymphony.xwork2.util.location Classes and utilities used to track location information.

Uses of LocationUtils.LocationFinder in com.opensymphony.xwork2.util.location

Methods in com.opensymphony.xwork2.util.location with parameters of type LocationUtils.LocationFinder
static void LocationUtils.addFinder(LocationUtils.LocationFinder finder)
Add a LocationUtils.LocationFinder to the list of finders that will be queried for an object's location by LocationUtils.getLocation(Object, String).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Logger (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.logging
Interface Logger

All Known Implementing Classes:
CommonsLogger, JdkLogger
public interface Logger

Main logger interface for logging things

Method Summary
void | debug(String msg, String... args)
void | debug(String msg, Throwable ex, String... args)
void | error(String msg, String... args)
void | error(String msg, Throwable ex, String... args)
void | fatal(String msg, String... args)
void | fatal(String msg, Throwable ex, String... args)
void | info(String msg, String... args)
void | info(String msg, Throwable ex, String... args)
boolean | isDebugEnabled()
boolean | isErrorEnabled()
boolean | isFatalEnabled()
boolean | isInfoEnabled()
boolean | isTraceEnabled()
boolean | isWarnEnabled()
void | trace(String msg, String... args)
void | trace(String msg, Throwable ex, String... args)
void | warn(String msg, String... args)
void | warn(String msg, Throwable ex, String... args)

Method Detail

trace

void trace(String msg,
           String... args)

trace

void trace(String msg,
           Throwable ex,
           String... args)

isTraceEnabled

boolean isTraceEnabled()

debug

void debug(String msg,
           String... args)

debug

void debug(String msg,
           Throwable ex,
           String... args)

isDebugEnabled

boolean isDebugEnabled()

info

void info(String msg,
          String... args)

info

void info(String msg,
          Throwable ex,
          String... args)

isInfoEnabled

boolean isInfoEnabled()

warn

void warn(String msg,
          String... args)

warn

void warn(String msg,
          Throwable ex,
          String... args)

isWarnEnabled

boolean isWarnEnabled()

error

void error(String msg,
           String... args)

error

void error(String msg,
           Throwable ex,
           String... args)

isErrorEnabled

boolean isErrorEnabled()

fatal

void fatal(String msg,
           String... args)

fatal

void fatal(String msg,
           Throwable ex,
           String... args)

isFatalEnabled

boolean isFatalEnabled()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


LoggerFactory (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.logging
Class LoggerFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.util.logging.LoggerFactory
Direct Known Subclasses:
CommonsLoggerFactory, JdkLoggerFactory
public abstract class LoggerFactory
extends Object

Creates loggers. Static accessor will lazily try to decide on the best factory if none specified.

Constructor Summary
LoggerFactory()
Method Summary
static Logger | getLogger(Class<?> cls)
static Logger | getLogger(String name)
protected static LoggerFactory | getLoggerFactory()
protected abstract Logger | getLoggerImpl(Class<?> cls)
protected abstract Logger | getLoggerImpl(String name)
static void | setLoggerFactory(LoggerFactory factory)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LoggerFactory

public LoggerFactory()
Method Detail

setLoggerFactory

public static void setLoggerFactory(LoggerFactory factory)

getLogger

public static Logger getLogger(Class<?> cls)

getLogger

public static Logger getLogger(String name)

getLoggerFactory

protected static LoggerFactory getLoggerFactory()

getLoggerImpl

protected abstract Logger getLoggerImpl(Class<?> cls)

getLoggerImpl

protected abstract Logger getLoggerImpl(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LoggerUtils (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.logging
Class LoggerUtils

java.lang.Object
    extended by  com.opensymphony.xwork2.util.logging.LoggerUtils

public class LoggerUtils
extends Object

Logging utility methods

Constructor Summary
LoggerUtils()
Method Summary
static String format(String msg, String... args)
Formats messages using parameters.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LoggerUtils

public LoggerUtils()
Method Detail

format

public static String format(String msg,
                            String... args)
Formats messages using parameters. For example, the call:
 format("foo #1", "bob");
will return:
 foo bob

Parameters:
msg - The message
args - A list of arguments. A maximum of 10 are supported.
Returns:
The formatted string
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.util.logging (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.util.logging
Interfaces
Logger
Classes
LoggerFactory
LoggerUtils


com.opensymphony.xwork2.util.logging (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.util.logging

Interface Summary
Logger Main logger interface for logging things

Class Summary
LoggerFactory | Creates loggers.
LoggerUtils | Logging utility methods


com.opensymphony.xwork2.util.logging Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.util.logging

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.util.logging.LoggerFactory
    • com.opensymphony.xwork2.util.logging.LoggerUtils

Interface Hierarchy

  • com.opensymphony.xwork2.util.logging.Logger


Uses of Package com.opensymphony.xwork2.util.logging (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.util.logging

Packages that use com.opensymphony.xwork2.util.logging
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.conversion.impl |
com.opensymphony.xwork2.conversion.metadata | Type conversion meta data classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.util.logging |
com.opensymphony.xwork2.util.logging.commons |
com.opensymphony.xwork2.util.logging.jdk |
com.opensymphony.xwork2.validator.metadata | Validator meta data classes.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Classes in com.opensymphony.xwork2.util.logging used by com.opensymphony.xwork2
Logger
Main logger interface for logging things
LoggerFactory
Creates loggers.

Classes in com.opensymphony.xwork2.util.logging used by com.opensymphony.xwork2.config
Logger
Main logger interface for logging things

Classes in com.opensymphony.xwork2.util.logging used by com.opensymphony.xwork2.config.impl
Logger
Main logger interface for logging things

Classes in com.opensymphony.xwork2.util.logging used by com.opensymphony.xwork2.conversion.impl
Logger
Main logger interface for logging things

Classes in com.opensymphony.xwork2.util.logging used by com.opensymphony.xwork2.conversion.metadata
Logger
Main logger interface for logging things

Classes in com.opensymphony.xwork2.util.logging used by com.opensymphony.xwork2.interceptor
Logger
Main logger interface for logging things

Classes in com.opensymphony.xwork2.util.logging used by com.opensymphony.xwork2.util.logging
Logger
Main logger interface for logging things
LoggerFactory
Creates loggers.

Classes in com.opensymphony.xwork2.util.logging used by com.opensymphony.xwork2.util.logging.commons
Logger
Main logger interface for logging things
LoggerFactory
Creates loggers.

Classes in com.opensymphony.xwork2.util.logging used by com.opensymphony.xwork2.util.logging.jdk
Logger
Main logger interface for logging things
LoggerFactory
Creates loggers.

Classes in com.opensymphony.xwork2.util.logging used by com.opensymphony.xwork2.validator.metadata
Logger
Main logger interface for logging things

Classes in com.opensymphony.xwork2.util.logging used by com.opensymphony.xwork2.validator.validators
Logger
Main logger interface for logging things

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.logging.Logger (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.util.logging.Logger

Packages that use Logger
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.conversion.impl |
com.opensymphony.xwork2.conversion.metadata | Type conversion meta data classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.util.logging |
com.opensymphony.xwork2.util.logging.commons |
com.opensymphony.xwork2.util.logging.jdk |
com.opensymphony.xwork2.validator.metadata | Validator meta data classes.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Uses of Logger in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as Logger
protected static Logger ActionSupport.LOG

Uses of Logger in com.opensymphony.xwork2.config

Fields in com.opensymphony.xwork2.config declared as Logger
protected static Logger ConfigurationManager.LOG

Uses of Logger in com.opensymphony.xwork2.config.impl

Fields in com.opensymphony.xwork2.config.impl declared as Logger
protected static Logger DefaultConfiguration.LOG

Uses of Logger in com.opensymphony.xwork2.conversion.impl

Fields in com.opensymphony.xwork2.conversion.impl declared as Logger
protected static Logger | XWorkConverter.LOG
protected static Logger | DefaultObjectTypeDeterminer.LOG

Uses of Logger in com.opensymphony.xwork2.conversion.metadata

Fields in com.opensymphony.xwork2.conversion.metadata declared as Logger
protected static Logger ConversionDescription.log
Jakarta commons-logging reference.

Uses of Logger in com.opensymphony.xwork2.interceptor

Fields in com.opensymphony.xwork2.interceptor declared as Logger
protected Logger | TimerInterceptor.categoryLogger
protected Logger | ExceptionMappingInterceptor.categoryLogger
protected Logger | MethodFilterInterceptor.log
protected static Logger | TimerInterceptor.LOG
protected static Logger | I18nInterceptor.LOG
protected static Logger | ExceptionMappingInterceptor.LOG

Methods in com.opensymphony.xwork2.interceptor that return Logger
protected  Logger TimerInterceptor.getLoggerToUse()
Get's the logger to use.

Methods in com.opensymphony.xwork2.interceptor with parameters of type Logger
protected void | ExceptionMappingInterceptor.doLog(Logger logger, Exception e) Performs the actual logging.
protected void | TimerInterceptor.doLog(Logger logger, String message) Performs the actual logging.

Uses of Logger in com.opensymphony.xwork2.util.logging

Methods in com.opensymphony.xwork2.util.logging that return Logger
static Logger | LoggerFactory.getLogger(Class<?> cls)
static Logger | LoggerFactory.getLogger(String name)
protected abstract Logger | LoggerFactory.getLoggerImpl(Class<?> cls)
protected abstract Logger | LoggerFactory.getLoggerImpl(String name)

Uses of Logger in com.opensymphony.xwork2.util.logging.commons

Classes in com.opensymphony.xwork2.util.logging.commons that implement Logger
 class CommonsLogger
Simple logger that delegates to commons logging

Methods in com.opensymphony.xwork2.util.logging.commons that return Logger
protected Logger | CommonsLoggerFactory.getLoggerImpl(Class<?> cls)
protected Logger | CommonsLoggerFactory.getLoggerImpl(String name)

Uses of Logger in com.opensymphony.xwork2.util.logging.jdk

Classes in com.opensymphony.xwork2.util.logging.jdk that implement Logger
 class JdkLogger
Delegates to jdk logger.

Methods in com.opensymphony.xwork2.util.logging.jdk that return Logger
protected Logger | JdkLoggerFactory.getLoggerImpl(Class<?> cls)
protected Logger | JdkLoggerFactory.getLoggerImpl(String name)

Uses of Logger in com.opensymphony.xwork2.validator.metadata

Fields in com.opensymphony.xwork2.validator.metadata declared as Logger
protected static Logger AbstractFieldValidatorDescription.log
Jakarta commons-logging reference.

Uses of Logger in com.opensymphony.xwork2.validator.validators

Fields in com.opensymphony.xwork2.validator.validators declared as Logger
protected  Logger ValidatorSupport.log

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.logging.LoggerFactory (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.logging.LoggerFactory

Packages that use LoggerFactory
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.util.logging |
com.opensymphony.xwork2.util.logging.commons |
com.opensymphony.xwork2.util.logging.jdk |

Uses of LoggerFactory in com.opensymphony.xwork2

Methods in com.opensymphony.xwork2 with parameters of type LoggerFactory
 void XWork.setLoggerFactory(LoggerFactory factory)

Uses of LoggerFactory in com.opensymphony.xwork2.util.logging

Methods in com.opensymphony.xwork2.util.logging that return LoggerFactory
protected static LoggerFactory LoggerFactory.getLoggerFactory()

Methods in com.opensymphony.xwork2.util.logging with parameters of type LoggerFactory
static void LoggerFactory.setLoggerFactory(LoggerFactory factory)

Uses of LoggerFactory in com.opensymphony.xwork2.util.logging.commons

Subclasses of LoggerFactory in com.opensymphony.xwork2.util.logging.commons
 class CommonsLoggerFactory
Creates commons-logging-backed loggers

Uses of LoggerFactory in com.opensymphony.xwork2.util.logging.jdk

Subclasses of LoggerFactory in com.opensymphony.xwork2.util.logging.jdk
 class JdkLoggerFactory
Creates jdk loggers

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.logging.LoggerUtils (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.logging.LoggerUtils

No usage of com.opensymphony.xwork2.util.logging.LoggerUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CommonsLogger (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.logging.commons
Class CommonsLogger

java.lang.Object
    extended by  com.opensymphony.xwork2.util.logging.commons.CommonsLogger
All Implemented Interfaces:
Logger
public class CommonsLogger
extends Object
implements Logger

Simple logger that delegates to commons logging

Constructor Summary
CommonsLogger(Log log)
Method Summary
void | debug(String msg, String... args)
void | debug(String msg, Throwable ex, String... args)
void | error(String msg, String... args)
void | error(String msg, Throwable ex, String... args)
void | fatal(String msg, String... args)
void | fatal(String msg, Throwable ex, String... args)
void | info(String msg, String... args)
void | info(String msg, Throwable ex, String... args)
boolean | isDebugEnabled()
boolean | isErrorEnabled()
boolean | isFatalEnabled()
boolean | isInfoEnabled()
boolean | isTraceEnabled()
boolean | isWarnEnabled()
void | trace(String msg, String... args)
void | trace(String msg, Throwable ex, String... args)
void | warn(String msg, String... args)
void | warn(String msg, Throwable ex, String... args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CommonsLogger

public CommonsLogger(Log log)
Method Detail

error

public void error(String msg,
                  String... args)
Specified by:
error in interface Logger

error

public void error(String msg,
                  Throwable ex,
                  String... args)
Specified by:
error in interface Logger

info

public void info(String msg,
                 String... args)
Specified by:
info in interface Logger

info

public void info(String msg,
                 Throwable ex,
                 String... args)
Specified by:
info in interface Logger

isInfoEnabled

public boolean isInfoEnabled()
Specified by:
isInfoEnabled in interface Logger

warn

public void warn(String msg,
                 String... args)
Specified by:
warn in interface Logger

warn

public void warn(String msg,
                 Throwable ex,
                 String... args)
Specified by:
warn in interface Logger

isDebugEnabled

public boolean isDebugEnabled()
Specified by:
isDebugEnabled in interface Logger

debug

public void debug(String msg,
                  String... args)
Specified by:
debug in interface Logger

debug

public void debug(String msg,
                  Throwable ex,
                  String... args)
Specified by:
debug in interface Logger

isTraceEnabled

public boolean isTraceEnabled()
Specified by:
isTraceEnabled in interface Logger

trace

public void trace(String msg,
                  String... args)
Specified by:
trace in interface Logger

trace

public void trace(String msg,
                  Throwable ex,
                  String... args)
Specified by:
trace in interface Logger

fatal

public void fatal(String msg,
                  String... args)
Specified by:
fatal in interface Logger

fatal

public void fatal(String msg,
                  Throwable ex,
                  String... args)
Specified by:
fatal in interface Logger

isErrorEnabled

public boolean isErrorEnabled()
Specified by:
isErrorEnabled in interface Logger

isFatalEnabled

public boolean isFatalEnabled()
Specified by:
isFatalEnabled in interface Logger

isWarnEnabled

public boolean isWarnEnabled()
Specified by:
isWarnEnabled in interface Logger
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


CommonsLoggerFactory (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.logging.commons
Class CommonsLoggerFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.util.logging.LoggerFactory
        extended by  com.opensymphony.xwork2.util.logging.commons.CommonsLoggerFactory

public class CommonsLoggerFactory
extends LoggerFactory

Creates commons-logging-backed loggers

Constructor Summary
CommonsLoggerFactory()
Method Summary
protected Logger | getLoggerImpl(Class<?> cls)
protected Logger | getLoggerImpl(String name)
Methods inherited from class com.opensymphony.xwork2.util.logging.LoggerFactory
getLogger, getLogger, getLoggerFactory, setLoggerFactory
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CommonsLoggerFactory

public CommonsLoggerFactory()
Method Detail

getLoggerImpl

protected Logger getLoggerImpl(Class<?> cls)
Specified by:
getLoggerImpl in class LoggerFactory

getLoggerImpl

protected Logger getLoggerImpl(String name)
Specified by:
getLoggerImpl in class LoggerFactory
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.util.logging.commons (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.util.logging.commons
Classes
CommonsLogger
CommonsLoggerFactory


com.opensymphony.xwork2.util.logging.commons (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.util.logging.commons

Class Summary
CommonsLogger | Simple logger that delegates to commons logging
CommonsLoggerFactory | Creates commons-logging-backed loggers


com.opensymphony.xwork2.util.logging.commons Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.util.logging.commons

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.util.logging.commons.CommonsLogger (implements com.opensymphony.xwork2.util.logging.Logger)
    • com.opensymphony.xwork2.util.logging.LoggerFactory
      • com.opensymphony.xwork2.util.logging.commons.CommonsLoggerFactory


Uses of Package com.opensymphony.xwork2.util.logging.commons (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.util.logging.commons

No usage of com.opensymphony.xwork2.util.logging.commons

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.logging.commons.CommonsLogger (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.logging.commons.CommonsLogger

No usage of com.opensymphony.xwork2.util.logging.commons.CommonsLogger

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.logging.commons.CommonsLoggerFactory (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.logging.commons.CommonsLoggerFactory

No usage of com.opensymphony.xwork2.util.logging.commons.CommonsLoggerFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


JdkLogger (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.logging.jdk
Class JdkLogger

java.lang.Object
    extended by  com.opensymphony.xwork2.util.logging.jdk.JdkLogger
All Implemented Interfaces:
Logger
public class JdkLogger
extends Object
implements Logger

Delegates to jdk logger. Maps fatal to Level.SEVERE along with error.

Constructor Summary
JdkLogger(Logger log)
Method Summary
void | debug(String msg, String... args)
void | debug(String msg, Throwable ex, String... args)
void | error(String msg, String... args)
void | error(String msg, Throwable ex, String... args)
void | fatal(String msg, String... args)
void | fatal(String msg, Throwable ex, String... args)
void | info(String msg, String... args)
void | info(String msg, Throwable ex, String... args)
boolean | isDebugEnabled()
boolean | isErrorEnabled()
boolean | isFatalEnabled()
boolean | isInfoEnabled()
boolean | isTraceEnabled()
boolean | isWarnEnabled()
void | trace(String msg, String... args)
void | trace(String msg, Throwable ex, String... args)
void | warn(String msg, String... args)
void | warn(String msg, Throwable ex, String... args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JdkLogger

public JdkLogger(Logger log)
Method Detail

error

public void error(String msg,
                  String... args)
Specified by:
error in interface Logger

error

public void error(String msg,
                  Throwable ex,
                  String... args)
Specified by:
error in interface Logger

fatal

public void fatal(String msg,
                  String... args)
Specified by:
fatal in interface Logger

fatal

public void fatal(String msg,
                  Throwable ex,
                  String... args)
Specified by:
fatal in interface Logger

info

public void info(String msg,
                 String... args)
Specified by:
info in interface Logger

info

public void info(String msg,
                 Throwable ex,
                 String... args)
Specified by:
info in interface Logger

isInfoEnabled

public boolean isInfoEnabled()
Specified by:
isInfoEnabled in interface Logger

warn

public void warn(String msg,
                 String... args)
Specified by:
warn in interface Logger

warn

public void warn(String msg,
                 Throwable ex,
                 String... args)
Specified by:
warn in interface Logger

isDebugEnabled

public boolean isDebugEnabled()
Specified by:
isDebugEnabled in interface Logger

debug

public void debug(String msg,
                  String... args)
Specified by:
debug in interface Logger

debug

public void debug(String msg,
                  Throwable ex,
                  String... args)
Specified by:
debug in interface Logger

isTraceEnabled

public boolean isTraceEnabled()
Specified by:
isTraceEnabled in interface Logger

trace

public void trace(String msg,
                  String... args)
Specified by:
trace in interface Logger

trace

public void trace(String msg,
                  Throwable ex,
                  String... args)
Specified by:
trace in interface Logger

isErrorEnabled

public boolean isErrorEnabled()
Specified by:
isErrorEnabled in interface Logger

isFatalEnabled

public boolean isFatalEnabled()
Specified by:
isFatalEnabled in interface Logger

isWarnEnabled

public boolean isWarnEnabled()
Specified by:
isWarnEnabled in interface Logger
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


JdkLoggerFactory (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.logging.jdk
Class JdkLoggerFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.util.logging.LoggerFactory
        extended by  com.opensymphony.xwork2.util.logging.jdk.JdkLoggerFactory

public class JdkLoggerFactory
extends LoggerFactory

Creates jdk loggers

Constructor Summary
JdkLoggerFactory()
Method Summary
protected Logger | getLoggerImpl(Class<?> cls)
protected Logger | getLoggerImpl(String name)
Methods inherited from class com.opensymphony.xwork2.util.logging.LoggerFactory
getLogger, getLogger, getLoggerFactory, setLoggerFactory
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JdkLoggerFactory

public JdkLoggerFactory()
Method Detail

getLoggerImpl

protected Logger getLoggerImpl(Class<?> cls)
Specified by:
getLoggerImpl in class LoggerFactory

getLoggerImpl

protected Logger getLoggerImpl(String name)
Specified by:
getLoggerImpl in class LoggerFactory
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.util.logging.jdk (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.util.logging.jdk
Classes
JdkLogger
JdkLoggerFactory


com.opensymphony.xwork2.util.logging.jdk (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.util.logging.jdk

Class Summary
JdkLogger | Delegates to jdk logger.
JdkLoggerFactory | Creates jdk loggers


com.opensymphony.xwork2.util.logging.jdk Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.util.logging.jdk

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.util.logging.jdk.JdkLogger (implements com.opensymphony.xwork2.util.logging.Logger)
    • com.opensymphony.xwork2.util.logging.LoggerFactory
      • com.opensymphony.xwork2.util.logging.jdk.JdkLoggerFactory


Uses of Package com.opensymphony.xwork2.util.logging.jdk (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.util.logging.jdk

No usage of com.opensymphony.xwork2.util.logging.jdk

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.logging.jdk.JdkLogger (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.logging.jdk.JdkLogger

No usage of com.opensymphony.xwork2.util.logging.jdk.JdkLogger

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.logging.jdk.JdkLoggerFactory (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.logging.jdk.JdkLoggerFactory

No usage of com.opensymphony.xwork2.util.logging.jdk.JdkLoggerFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ObjectProfiler (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.profiling
Class ObjectProfiler

java.lang.Object
    extended by  com.opensymphony.xwork2.util.profiling.ObjectProfiler

public class ObjectProfiler
extends Object

Author:
Scott Farquhar

Constructor Summary
ObjectProfiler()
Method Summary
static Object getProfiledObject(Class interfaceClazz, Object o)
Given a class, and an interface that it implements, return a proxied version of the class that implements the interface.
static String getTrimmedClassName(Method method)
Given a method, get the Method name, with no package information.
static Object profiledInvoke(Method target, Object value, Object[] args)
A profiled call Method.invoke(java.lang.Object, java.lang.Object[]).
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ObjectProfiler

public ObjectProfiler()
Method Detail

getProfiledObject

public static Object getProfiledObject(Class interfaceClazz,
                                       Object o)
Given a class, and an interface that it implements, return a proxied version of the class that implements the interface.

The usual use of this is to profile methods from Factory objects:

 public PersistenceManager getPersistenceManager()
 {
   return new DefaultPersistenceManager();
 }

 instead write:
 public PersistenceManager getPersistenceManager()
 {
   return ObjectProfiler.getProfiledObject(PersistenceManager.class, new DefaultPersistenceManager());
 }

A side effect of this is that you will no longer be able to downcast to DefaultPersistenceManager. This is probably a *good* thing.

Parameters:
interfaceClazz - The interface to implement.
o - The object to proxy
Returns:
A proxied object, or the input object if the interfaceClazz wasn't an interface.

profiledInvoke

public static Object profiledInvoke(Method target,
                                    Object value,
                                    Object[] args)
                             throws IllegalAccessException,
                                    InvocationTargetException
A profiled call Method.invoke(java.lang.Object, java.lang.Object[]). If UtilTimerStack.isActive() returns false, then no profiling is performed.

Throws:
IllegalAccessException
InvocationTargetException

getTrimmedClassName

public static String getTrimmedClassName(Method method)
Given a method, get the Method name, with no package information.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.util.profiling (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.util.profiling
Interfaces
UtilTimerStack.ProfilingBlock
Classes
ObjectProfiler
ProfilingTimerBean
UtilTimerStack


com.opensymphony.xwork2.util.profiling (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.util.profiling

Classes to enable profiling of action execution.

See:
Description

Interface Summary
UtilTimerStack.ProfilingBlock<T> A callback interface where code subjected to profile is to be executed.

Class Summary
ObjectProfiler |
ProfilingTimerBean | Bean to contain information about the pages profiled
UtilTimerStack | A timer stack.

Package com.opensymphony.xwork2.util.profiling Description

Classes to enable profiling of action execution.


com.opensymphony.xwork2.util.profiling Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.util.profiling

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.util.profiling.ObjectProfiler
    • com.opensymphony.xwork2.util.profiling.ProfilingTimerBean (implements java.io.Serializable)
    • com.opensymphony.xwork2.util.profiling.UtilTimerStack

Interface Hierarchy

  • com.opensymphony.xwork2.util.profiling.UtilTimerStack.ProfilingBlock<T>


Uses of Package com.opensymphony.xwork2.util.profiling (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.util.profiling

Packages that use com.opensymphony.xwork2.util.profiling
com.opensymphony.xwork2.util.profiling Classes to enable profiling of action execution.

Classes in com.opensymphony.xwork2.util.profiling used by com.opensymphony.xwork2.util.profiling
ProfilingTimerBean
Bean to contain information about the pages profiled
UtilTimerStack.ProfilingBlock
A callback interface where code subjected to profile is to be executed.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ProfilingTimerBean (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.profiling
Class ProfilingTimerBean

java.lang.Object
    extended by  com.opensymphony.xwork2.util.profiling.ProfilingTimerBean
All Implemented Interfaces:
Serializable
public class ProfilingTimerBean
extends Object
implements Serializable

Bean to contain information about the pages profiled

Version:
$Date$ $Id$
Author:
Mike Cannon-Brookes, Scott Farquhar
See Also:
Serialized Form

Constructor Summary
ProfilingTimerBean(String resource)
Method Summary
void | addChild(ProfilingTimerBean child)
protected void | addParent(ProfilingTimerBean parent)
ProfilingTimerBean | getParent()
String | getPrintable(long minTime) Get a formatted string representing all the methods that took longer than a specified time.
protected String | getPrintable(String indent, long minTime)
String | getResource()
void | setEndTime()
void | setStartTime()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ProfilingTimerBean

public ProfilingTimerBean(String resource)
Method Detail

addParent

protected void addParent(ProfilingTimerBean parent)

getParent

public ProfilingTimerBean getParent()

addChild

public void addChild(ProfilingTimerBean child)

setStartTime

public void setStartTime()

setEndTime

public void setEndTime()

getResource

public String getResource()

getPrintable

public String getPrintable(long minTime)
Get a formatted string representing all the methods that took longer than a specified time.

getPrintable

protected String getPrintable(String indent,
                              long minTime)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UtilTimerStack (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.profiling
Class UtilTimerStack

java.lang.Object
    extended by  com.opensymphony.xwork2.util.profiling.UtilTimerStack

public class UtilTimerStack
extends Object

A timer stack.

Struts2 profiling aspects involves the following :-

  • ActionContextCleanUp
  • FreemarkerPageFilter
  • DispatcherFilter
    • Dispatcher
      • creation of DefaultActionProxy
        • creation of DefaultActionInvocation
          • creation of Action
      • execution of DefaultActionProxy
        • invocation of DefaultActionInvocation
          • invocation of Interceptors
          • invocation of Action
          • invocation of PreResultListener
          • invocation of Result
XWork2 profiling aspects involves the following :-
    • creation of DefaultActionProxy
      • creation of DefaultActionInvocation
        • creation of Action
    • execution of DefaultActionProxy
      • invocation of DefaultActionInvocation
        • invocation of Interceptors
        • invocation of Action
        • invocation of PreResultListener
        • invocation of Result
Activating / Deactivating of the profiling feature could be done through:-

System properties:-

  -Dxwork.profile.activate=true
This could be done in the container startup script eg. CATALINA_OPTS in catalina.sh (tomcat) or using "java -Dxwork.profile.activate=true -jar start.jar" (jetty)

Code :-

  UtilTimerStack.setActivate(true);
This could be done in a static block, in a Spring bean with lazy-init="false", in a Servlet with init-on-startup as some numeric value, in a Filter or Listener's init method etc.

Parameter:-

 <action ... >
  ...
  <interceptor-ref name="profiling">
      <param name="profilingKey">profiling</param>
  </interceptor-ref>
  ...
 </action>

 or

 <action .... >
 ...
  <interceptor-ref name="profiling" />
 ...
 </action>

 through url

 http://host:port/context/namespace/someAction.action?profiling=true

 through code

 ActionContext.getContext().getParameters().put("profiling", "true);
To use profiling activation through parameter, one will need to pass in through the 'profiling' parameter (which is the default) and could be changed through the param tag in the interceptor-ref.

Warning:

Profiling activation through a parameter requires the following:

  • Profiling interceptor in interceptor stack
  • dev mode on (struts.devMode=true in struts.properties)

One could filter out the profile logging by having a System property as follows. With this 'xwork.profile.mintime' property, one could only log profile information when its execution time exceed those specified in 'xwork.profile.mintime' system property. If no such property is specified, it will be assumed to be 0, hence all profile information will be logged.

  -Dxwork.profile.mintime=10000
One could extend the profiling feature provided by Struts2 in their web application as well.

    String logMessage = "Log message";
    UtilTimerStack.push(logMessage);
    try {
        // do some code
    }
    finally {
        UtilTimerStack.pop(logMessage); // this needs to be the same text as above
    }
or

   String result = UtilTimerStack.profile("purchaseItem: ",
       new UtilTimerStack.ProfilingBlock() {
            public String doProfiling() {
               // do some code
               return "Ok";
            }
       });
Profiled result is logged using commons-logging under the logger named 'com.opensymphony.xwork2.util.profiling.UtilTimerStack'. Depending on the underlying logging implementation say if it is Log4j, one could direct the log to appear in a different file, being emailed to someone or have it stored in the db.

Version:
$Date$ $Id$

Nested Class Summary
static interface UtilTimerStack.ProfilingBlock<T>
A callback interface where code subjected to profile is to be executed.
Field Summary
static String | ACTIVATE_PROPERTY System property that controls whether this timer should be used or not.
protected static ThreadLocal<ProfilingTimerBean> | current
static String | MIN_TIME System property that controls the min time, that if exceeded will cause a log (at INFO level) to be created.
Constructor Summary
UtilTimerStack()
Method Summary
static boolean isActive()
Determine if profiling is being activated, by searching for a system property 'xwork.profile.activate', default to false (profiling is off).
static void pop(String name)
End a preformance profiling with the name given.
static
<T> T
profile(String name, UtilTimerStack.ProfilingBlock<T> block)
A convenience method that allows block of code subjected to profiling to be executed and avoid the need of coding boiler code that does pushing (UtilTimeBean.push(...)) and poping (UtilTimerBean.pop(...)) in a try ...
static void push(String name)
Create and start a performance profiling with the name given.
static void setActive(boolean active)
Turn profiling on or off.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

current

protected static ThreadLocal<ProfilingTimerBean> current

ACTIVATE_PROPERTY

public static final String ACTIVATE_PROPERTY
System property that controls whether this timer should be used or not. Set to "true" activates the timer. Set to "false" to disactivate.

See Also:
Constant Field Values

MIN_TIME

public static final String MIN_TIME
System property that controls the min time, that if exceeded will cause a log (at INFO level) to be created.

See Also:
Constant Field Values
Constructor Detail

UtilTimerStack

public UtilTimerStack()
Method Detail

push

public static void push(String name)
Create and start a performance profiling with the name given. Deal with profile hierarchy automatically, so caller don't have to be concern about it.

Parameters:
name - profile name

pop

public static void pop(String name)
End a preformance profiling with the name given. Deal with profile hierarchy automatically, so caller don't have to be concern about it.

Parameters:
name - profile name

isActive

public static boolean isActive()
Determine if profiling is being activated, by searching for a system property 'xwork.profile.activate', default to false (profiling is off).

Returns:
true, if active, false otherwise.

setActive

public static void setActive(boolean active)
Turn profiling on or off.

Parameters:
active -

profile

public static <T> T profile(String name,
                            UtilTimerStack.ProfilingBlock<T> block)
                 throws Exception
A convenience method that allows block of code subjected to profiling to be executed and avoid the need of coding boiler code that does pushing (UtilTimeBean.push(...)) and poping (UtilTimerBean.pop(...)) in a try ... finally ... block.

Example of usage:

         // we need a returning result
   String result = UtilTimerStack.profile("purchaseItem: ",
       new UtilTimerStack.ProfilingBlock() {
            public String doProfiling() {
               getMyService().purchaseItem(....)
               return "Ok";
            }
       });
or
   // we don't need a returning result
   UtilTimerStack.profile("purchaseItem: ",
       new UtilTimerStack.ProfilingBlock() {
            public String doProfiling() {
               getMyService().purchaseItem(....)
               return null;
            }
       });

Type Parameters:
T - any return value if there's one.
Parameters:
name - profile name
block - code block subjected to profiling
Returns:
T
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UtilTimerStack.ProfilingBlock (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.profiling
Interface UtilTimerStack.ProfilingBlock<T>

Type Parameters:
T -
Enclosing class:
UtilTimerStack
public static interface UtilTimerStack.ProfilingBlock<T>

A callback interface where code subjected to profile is to be executed. This eliminates the need of coding boiler code that does pushing (UtilTimerBean.push(...)) and poping (UtilTimerBean.pop(...)) in a try ... finally ... block.

Version:
$Date$ $Id$

Method Summary
 T doProfiling()
Method that execute the code subjected to profiling.

Method Detail

doProfiling

T doProfiling()
              throws Exception
Method that execute the code subjected to profiling.

Returns:
profiles Type
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.opensymphony.xwork2.util.profiling.ObjectProfiler (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.profiling.ObjectProfiler

No usage of com.opensymphony.xwork2.util.profiling.ObjectProfiler

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.profiling.ProfilingTimerBean

Packages that use ProfilingTimerBean
com.opensymphony.xwork2.util.profiling Classes to enable profiling of action execution.

Uses of ProfilingTimerBean in com.opensymphony.xwork2.util.profiling

Fields in com.opensymphony.xwork2.util.profiling with type parameters of type ProfilingTimerBean
protected static ThreadLocal<ProfilingTimerBean> UtilTimerStack.current

Methods in com.opensymphony.xwork2.util.profiling that return ProfilingTimerBean
 ProfilingTimerBean ProfilingTimerBean.getParent()

Methods in com.opensymphony.xwork2.util.profiling with parameters of type ProfilingTimerBean
void | ProfilingTimerBean.addChild(ProfilingTimerBean child)
protected void | ProfilingTimerBean.addParent(ProfilingTimerBean parent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.profiling.UtilTimerStack (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.profiling.UtilTimerStack

No usage of com.opensymphony.xwork2.util.profiling.UtilTimerStack

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.profiling.UtilTimerStack.ProfilingBlock (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.util.profiling.UtilTimerStack.ProfilingBlock

Packages that use UtilTimerStack.ProfilingBlock
com.opensymphony.xwork2.util.profiling Classes to enable profiling of action execution.

Uses of UtilTimerStack.ProfilingBlock in com.opensymphony.xwork2.util.profiling

Methods in com.opensymphony.xwork2.util.profiling with parameters of type UtilTimerStack.ProfilingBlock
static
<T> T
UtilTimerStack.profile(String name, UtilTimerStack.ProfilingBlock<T> block)
A convenience method that allows block of code subjected to profiling to be executed and avoid the need of coding boiler code that does pushing (UtilTimeBean.push(...)) and poping (UtilTimerBean.pop(...)) in a try ...

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2.util.reflection (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.util.reflection
Interfaces
ReflectionContextFactory
ReflectionExceptionHandler
ReflectionProvider
Classes
ReflectionContextState
ReflectionProviderFactory
Exceptions
ReflectionException


com.opensymphony.xwork2.util.reflection (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.util.reflection

Interface Summary
ReflectionContextFactory |
ReflectionExceptionHandler | Declares a class that wants to handle its own reflection exceptions
ReflectionProvider |

Class Summary
ReflectionContextState | Manages variables in the reflection context and returns values to be used by the application.
ReflectionProviderFactory |

Exception Summary
ReflectionException


com.opensymphony.xwork2.util.reflection Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.util.reflection

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.util.reflection.ReflectionContextState
    • com.opensymphony.xwork2.util.reflection.ReflectionProviderFactory
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.opensymphony.xwork2.XWorkException (implements com.opensymphony.xwork2.util.location.Locatable)
            • com.opensymphony.xwork2.util.reflection.ReflectionException

Interface Hierarchy

  • com.opensymphony.xwork2.util.reflection.ReflectionContextFactory
  • com.opensymphony.xwork2.util.reflection.ReflectionExceptionHandler
  • com.opensymphony.xwork2.util.reflection.ReflectionProvider


Uses of Package com.opensymphony.xwork2.util.reflection (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.util.reflection

Packages that use com.opensymphony.xwork2.util.reflection
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.conversion.impl |
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.ognl |
com.opensymphony.xwork2.util.reflection |

Classes in com.opensymphony.xwork2.util.reflection used by com.opensymphony.xwork2
ReflectionProvider

Classes in com.opensymphony.xwork2.util.reflection used by com.opensymphony.xwork2.conversion.impl
ReflectionProvider

Classes in com.opensymphony.xwork2.util.reflection used by com.opensymphony.xwork2.interceptor
ReflectionProvider

Classes in com.opensymphony.xwork2.util.reflection used by com.opensymphony.xwork2.ognl
ReflectionContextFactory
ReflectionException
ReflectionProvider

Classes in com.opensymphony.xwork2.util.reflection used by com.opensymphony.xwork2.util.reflection
ReflectionException
ReflectionProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ReflectionContextFactory (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.reflection
Interface ReflectionContextFactory

All Known Implementing Classes:
OgnlReflectionContextFactory
public interface ReflectionContextFactory

Method Summary
 Map createDefaultContext(Object root)
Creates and returns a new standard naming context for evaluating an OGNL expression.

Method Detail

createDefaultContext

Map createDefaultContext(Object root)
Creates and returns a new standard naming context for evaluating an OGNL expression.

Parameters:
root - the root of the object graph
Returns:
a new Map with the keys root and context set appropriately
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ReflectionContextState (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.reflection
Class ReflectionContextState

java.lang.Object
    extended by  com.opensymphony.xwork2.util.reflection.ReflectionContextState

public class ReflectionContextState
extends Object

Manages variables in the reflection context and returns values to be used by the application.

Author:
Gabe

Field Summary
static String | CREATE_NULL_OBJECTS
static String | CURRENT_PROPERTY_PATH
static String | DENY_INDEXED_ACCESS_EXECUTION
static String | DENY_METHOD_EXECUTION
static String | FULL_PROPERTY_PATH
Constructor Summary
ReflectionContextState()
Method Summary
static void | clear(Map<String,Object> context)
static void | clearCurrentPropertyPath(Map<String,Object> context)
static String | getCurrentPropertyPath(Map<String,Object> context) Gets the current property path but not completely.
static String | getFullPropertyPath(Map<String,Object> context)
static Class | getLastBeanClassAccessed(Map<String,Object> context)
static String | getLastBeanPropertyAccessed(Map<String,Object> context)
static Map<Object,Object> | getSetMap(Map<String,Object> context, String path)
static boolean | isCreatingNullObjects(Map<String,Object> context)
static boolean | isDenyMethodExecution(Map<String,Object> context)
static boolean | isGettingByKeyProperty(Map<String,Object> context)
static boolean | isReportingConversionErrors(Map<String,Object> context)
static void | setCreatingNullObjects(Map<String,Object> context, boolean creatingNullObjects)
static void | setDenyMethodExecution(Map<String,Object> context, boolean denyMethodExecution)
static void | setFullPropertyPath(Map<String,Object> context, String path)
static void | setGettingByKeyProperty(Map<String,Object> context, boolean gettingByKeyProperty)
static void | setLastBeanClassAccessed(Map<String,Object> context, Class clazz)
static void | setLastBeanPropertyAccessed(Map<String,Object> context, String property)
static void | setReportingConversionErrors(Map<String,Object> context, boolean reportingErrors)
static void | setSetMap(Map<String,Object> context, Map<Object,Object> setMap, String path)
static void | updateCurrentPropertyPath(Map<String,Object> context, Object name)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CURRENT_PROPERTY_PATH

public static final String CURRENT_PROPERTY_PATH
See Also:
Constant Field Values

FULL_PROPERTY_PATH

public static final String FULL_PROPERTY_PATH
See Also:
Constant Field Values

CREATE_NULL_OBJECTS

public static final String CREATE_NULL_OBJECTS
See Also:
Constant Field Values

DENY_METHOD_EXECUTION

public static final String DENY_METHOD_EXECUTION
See Also:
Constant Field Values

DENY_INDEXED_ACCESS_EXECUTION

public static final String DENY_INDEXED_ACCESS_EXECUTION
See Also:
Constant Field Values
Constructor Detail

ReflectionContextState

public ReflectionContextState()
Method Detail

isCreatingNullObjects

public static boolean isCreatingNullObjects(Map<String,Object> context)

setCreatingNullObjects

public static void setCreatingNullObjects(Map<String,Object> context,
                                          boolean creatingNullObjects)

isGettingByKeyProperty

public static boolean isGettingByKeyProperty(Map<String,Object> context)

setDenyMethodExecution

public static void setDenyMethodExecution(Map<String,Object> context,
                                          boolean denyMethodExecution)

isDenyMethodExecution

public static boolean isDenyMethodExecution(Map<String,Object> context)

setGettingByKeyProperty

public static void setGettingByKeyProperty(Map<String,Object> context,
                                           boolean gettingByKeyProperty)

isReportingConversionErrors

public static boolean isReportingConversionErrors(Map<String,Object> context)

setReportingConversionErrors

public static void setReportingConversionErrors(Map<String,Object> context,
                                                boolean reportingErrors)

getLastBeanClassAccessed

public static Class getLastBeanClassAccessed(Map<String,Object> context)

setLastBeanPropertyAccessed

public static void setLastBeanPropertyAccessed(Map<String,Object> context,
                                               String property)

getLastBeanPropertyAccessed

public static String getLastBeanPropertyAccessed(Map<String,Object> context)

setLastBeanClassAccessed

public static void setLastBeanClassAccessed(Map<String,Object> context,
                                            Class clazz)

getCurrentPropertyPath

public static String getCurrentPropertyPath(Map<String,Object> context)
Gets the current property path but not completely. It does not use the [ and ] used in some representations of Maps and Lists. The reason for this is that the current property path is only currently used for caching purposes so there is no real reason to have an exact replica.

So if the real path is myProp.myMap['myKey'] this would return myProp.myMap.myKey.

Parameters:
context -

getFullPropertyPath

public static String getFullPropertyPath(Map<String,Object> context)

setFullPropertyPath

public static void setFullPropertyPath(Map<String,Object> context,
                                       String path)

updateCurrentPropertyPath

public static void updateCurrentPropertyPath(Map<String,Object> context,
                                             Object name)

setSetMap

public static void setSetMap(Map<String,Object> context,
                             Map<Object,Object> setMap,
                             String path)

getSetMap

public static Map<Object,Object> getSetMap(Map<String,Object> context,
                                           String path)

clearCurrentPropertyPath

public static void clearCurrentPropertyPath(Map<String,Object> context)

clear

public static void clear(Map<String,Object> context)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReflectionException (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.reflection
Class ReflectionException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  com.opensymphony.xwork2.XWorkException
                    extended by  com.opensymphony.xwork2.util.reflection.ReflectionException
All Implemented Interfaces:
Locatable, Serializable
public class ReflectionException
extends XWorkException

See Also:
Serialized Form

Constructor Summary
ReflectionException()
ReflectionException(String s)
ReflectionException(String s, Object target)
ReflectionException(String s, Throwable cause)
ReflectionException(String s, Throwable cause, Object target)
ReflectionException(Throwable cause)
ReflectionException(Throwable cause, Object target)
Method Summary
Methods inherited from class com.opensymphony.xwork2.XWorkException
getLocation, getThrowable, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ReflectionException

public ReflectionException()

ReflectionException

public ReflectionException(String s)

ReflectionException

public ReflectionException(String s,
                           Object target)

ReflectionException

public ReflectionException(Throwable cause)

ReflectionException

public ReflectionException(Throwable cause,
                           Object target)

ReflectionException

public ReflectionException(String s,
                           Throwable cause)

ReflectionException

public ReflectionException(String s,
                           Throwable cause,
                           Object target)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReflectionExceptionHandler (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.reflection
Interface ReflectionExceptionHandler

public interface ReflectionExceptionHandler

Declares a class that wants to handle its own reflection exceptions

Method Summary
 void handle(ReflectionException ex)
Handles a reflection exception

Method Detail

handle

void handle(ReflectionException ex)
Handles a reflection exception

Parameters:
ex - The reflection exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReflectionProvider (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.reflection
Interface ReflectionProvider

All Known Implementing Classes:
OgnlReflectionProvider
public interface ReflectionProvider

Method Summary
 void copy(Object from, Object to, Map<String,Object> context, Collection<String> exclusions, Collection<String> inclusions)
Copies the properties in the object "from" and sets them in the object "to" using specified type converter, or XWorkConverter if none is specified.
 Map<String,Object> getBeanMap(Object source)
Creates a Map with read properties for the given source object.
 Field getField(Class inClass, String name)
 Method getGetMethod(Class targetClass, String propertyName)
 PropertyDescriptor getPropertyDescriptor(Class targetClass, String propertyName)
This method returns a PropertyDescriptor for the given class and property name using a Map lookup (using getPropertyDescriptorsMap()).
 PropertyDescriptor[] getPropertyDescriptors(Object source)
Get's the java beans property descriptors for the given source.
 Object getRealTarget(String property, Map<String,Object> context, Object root)
Looks for the real target with the specified property given a root Object which may be a CompoundRoot.
 Method getSetMethod(Class targetClass, String propertyName)
 Object getValue(String expression, Map<String,Object> context, Object root)
Evaluates the given OGNL expression to extract a value from the given root object in a given context
 void setProperties(Map<String,String> properties, Object o)
Sets the properties on the object using the default context, defaulting to not throwing exceptions for problems setting the properties.
 void setProperties(Map<String,String> props, Object o, Map<String,Object> context)
Sets the object's properties using the default type converter, defaulting to not throw exceptions for problems setting the properties.
 void setProperties(Map<String,String> props, Object o, Map<String,Object> context, boolean throwPropertyExceptions)
Sets the object's properties using the default type converter.
 void setProperty(String name, Object value, Object o, Map<String,Object> context)
Sets the named property to the supplied value on the Object, defaults to not throwing property exceptions.
 void setProperty(String name, Object value, Object o, Map<String,Object> context, boolean throwPropertyExceptions)
Sets the named property to the supplied value on the Object,
 void setValue(String expression, Map<String,Object> context, Object root, Object value)
Evaluates the given OGNL expression to insert a value into the object graph rooted at the given root object given the context.

Method Detail

getGetMethod

Method getGetMethod(Class targetClass,
                    String propertyName)
                    throws IntrospectionException,
                           ReflectionException
Throws:
IntrospectionException
ReflectionException

getSetMethod

Method getSetMethod(Class targetClass,
                    String propertyName)
                    throws IntrospectionException,
                           ReflectionException
Throws:
IntrospectionException
ReflectionException

getField

Field getField(Class inClass,
               String name)

setProperties

void setProperties(Map<String,String> props,
                   Object o,
                   Map<String,Object> context)
Sets the object's properties using the default type converter, defaulting to not throw exceptions for problems setting the properties.

Parameters:
props - the properties being set
o - the object
context - the action context

setProperties

void setProperties(Map<String,String> props,
                   Object o,
                   Map<String,Object> context,
                   boolean throwPropertyExceptions)
                   throws ReflectionException
Sets the object's properties using the default type converter.

Parameters:
props - the properties being set
o - the object
context - the action context
throwPropertyExceptions - boolean which tells whether it should throw exceptions for problems setting the properties
Throws:
ReflectionException

setProperties

void setProperties(Map<String,String> properties,
                   Object o)
Sets the properties on the object using the default context, defaulting to not throwing exceptions for problems setting the properties.

Parameters:
properties -
o -

getPropertyDescriptor

PropertyDescriptor getPropertyDescriptor(Class targetClass,
                                         String propertyName)
                                         throws IntrospectionException,
                                                ReflectionException
This method returns a PropertyDescriptor for the given class and property name using a Map lookup (using getPropertyDescriptorsMap()).

Throws:
IntrospectionException
ReflectionException

copy

void copy(Object from,
          Object to,
          Map<String,Object> context,
          Collection<String> exclusions,
          Collection<String> inclusions)
Copies the properties in the object "from" and sets them in the object "to" using specified type converter, or XWorkConverter if none is specified.

Parameters:
from - the source object
to - the target object
context - the action context we're running under
exclusions - collection of method names to excluded from copying ( can be null)
inclusions - collection of method names to included copying (can be null) note if exclusions AND inclusions are supplied and not null nothing will get copied.

getRealTarget

Object getRealTarget(String property,
                     Map<String,Object> context,
                     Object root)
                     throws ReflectionException
Looks for the real target with the specified property given a root Object which may be a CompoundRoot.

Returns:
the real target or null if no object can be found with the specified property
Throws:
ReflectionException

setProperty

void setProperty(String name,
                 Object value,
                 Object o,
                 Map<String,Object> context,
                 boolean throwPropertyExceptions)
Sets the named property to the supplied value on the Object,

Parameters:
name - the name of the property to be set
value - the value to set into the named property
o - the object upon which to set the property
context - the context which may include the TypeConverter
throwPropertyExceptions - boolean which tells whether it should throw exceptions for problems setting the properties

setProperty

void setProperty(String name,
                 Object value,
                 Object o,
                 Map<String,Object> context)
Sets the named property to the supplied value on the Object, defaults to not throwing property exceptions.

Parameters:
name - the name of the property to be set
value - the value to set into the named property
o - the object upon which to set the property
context - the context which may include the TypeConverter

getBeanMap

Map<String,Object> getBeanMap(Object source)
                              throws IntrospectionException,
                                     ReflectionException
Creates a Map with read properties for the given source object.

If the source object does not have a read property (i.e. write-only) then the property is added to the map with the value here is no read method for property-name.

Parameters:
source - the source object.
Returns:
a Map with (key = read property name, value = value of read property).
Throws:
IntrospectionException - is thrown if an exception occurs during introspection.
ReflectionException

getValue

Object getValue(String expression,
                Map<String,Object> context,
                Object root)
                throws ReflectionException
Evaluates the given OGNL expression to extract a value from the given root object in a given context

Parameters:
expression - the OGNL expression to be parsed
context - the naming context for the evaluation
root - the root object for the OGNL expression
Returns:
the result of evaluating the expression
Throws:
ReflectionException

setValue

void setValue(String expression,
              Map<String,Object> context,
              Object root,
              Object value)
              throws ReflectionException
Evaluates the given OGNL expression to insert a value into the object graph rooted at the given root object given the context.

Parameters:
expression - the OGNL expression to be parsed
root - the root object for the OGNL expression
context - the naming context for the evaluation
value - the value to insert into the object graph
Throws:
ReflectionException

getPropertyDescriptors

PropertyDescriptor[] getPropertyDescriptors(Object source)
                                            throws IntrospectionException
Get's the java beans property descriptors for the given source.

Parameters:
source - the source object.
Returns:
property descriptors.
Throws:
IntrospectionException - is thrown if an exception occurs during introspection.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReflectionProviderFactory (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.reflection
Class ReflectionProviderFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.util.reflection.ReflectionProviderFactory

public class ReflectionProviderFactory
extends Object

Constructor Summary
ReflectionProviderFactory()
Method Summary
static ReflectionProvider getInstance()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ReflectionProviderFactory

public ReflectionProviderFactory()
Method Detail

getInstance

public static ReflectionProvider getInstance()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Interface com.opensymphony.xwork2.util.reflection.ReflectionContextFactory (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.util.reflection.ReflectionContextFactory

Packages that use ReflectionContextFactory
com.opensymphony.xwork2.ognl

Uses of ReflectionContextFactory in com.opensymphony.xwork2.ognl

Classes in com.opensymphony.xwork2.ognl that implement ReflectionContextFactory
 class OgnlReflectionContextFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.reflection.ReflectionContextState (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.reflection.ReflectionContextState

No usage of com.opensymphony.xwork2.util.reflection.ReflectionContextState

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.reflection.ReflectionException (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.reflection.ReflectionException

Packages that use ReflectionException
com.opensymphony.xwork2.ognl
com.opensymphony.xwork2.util.reflection

Uses of ReflectionException in com.opensymphony.xwork2.ognl

Methods in com.opensymphony.xwork2.ognl that throw ReflectionException
Map | OgnlReflectionProvider.getBeanMap(Object source)
Method | OgnlReflectionProvider.getGetMethod(Class targetClass, String propertyName)
PropertyDescriptor | OgnlReflectionProvider.getPropertyDescriptor(Class targetClass, String propertyName)
Object | OgnlReflectionProvider.getRealTarget(String property, Map<String,Object> context, Object root)
Method | OgnlReflectionProvider.getSetMethod(Class targetClass, String propertyName)
Object | OgnlReflectionProvider.getValue(String expression, Map<String,Object> context, Object root)
void | OgnlUtil.setProperties(Map<String,?> props, Object o, Map<String,Object> context, boolean throwPropertyExceptions) Sets the object's properties using the default type converter.
void | OgnlReflectionProvider.setProperties(Map<String,String> props, Object o, Map<String,Object> context, boolean throwPropertyExceptions)
void | OgnlReflectionProvider.setValue(String expression, Map<String,Object> context, Object root, Object value)

Uses of ReflectionException in com.opensymphony.xwork2.util.reflection

Methods in com.opensymphony.xwork2.util.reflection with parameters of type ReflectionException
 void ReflectionExceptionHandler.handle(ReflectionException ex)
Handles a reflection exception

Methods in com.opensymphony.xwork2.util.reflection that throw ReflectionException
 Map<String,Object> ReflectionProvider.getBeanMap(Object source)
Creates a Map with read properties for the given source object.
 Method ReflectionProvider.getGetMethod(Class targetClass, String propertyName)
 PropertyDescriptor ReflectionProvider.getPropertyDescriptor(Class targetClass, String propertyName)
This method returns a PropertyDescriptor for the given class and property name using a Map lookup (using getPropertyDescriptorsMap()).
 Object ReflectionProvider.getRealTarget(String property, Map<String,Object> context, Object root)
Looks for the real target with the specified property given a root Object which may be a CompoundRoot.
 Method ReflectionProvider.getSetMethod(Class targetClass, String propertyName)
 Object ReflectionProvider.getValue(String expression, Map<String,Object> context, Object root)
Evaluates the given OGNL expression to extract a value from the given root object in a given context
 void ReflectionProvider.setProperties(Map<String,String> props, Object o, Map<String,Object> context, boolean throwPropertyExceptions)
Sets the object's properties using the default type converter.
 void ReflectionProvider.setValue(String expression, Map<String,Object> context, Object root, Object value)
Evaluates the given OGNL expression to insert a value into the object graph rooted at the given root object given the context.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.reflection.ReflectionExceptionHandler (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.util.reflection.ReflectionExceptionHandler

No usage of com.opensymphony.xwork2.util.reflection.ReflectionExceptionHandler

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.reflection.ReflectionProvider (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.util.reflection.ReflectionProvider

Packages that use ReflectionProvider
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.conversion.impl |
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.ognl |
com.opensymphony.xwork2.util.reflection |

Uses of ReflectionProvider in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as ReflectionProvider
protected  ReflectionProvider ObjectFactory.reflectionProvider

Methods in com.opensymphony.xwork2 with parameters of type ReflectionProvider
 void ObjectFactory.setReflectionProvider(ReflectionProvider prov)

Constructors in com.opensymphony.xwork2 with parameters of type ReflectionProvider
ObjectFactory(ReflectionProvider prov)

Uses of ReflectionProvider in com.opensymphony.xwork2.conversion.impl

Methods in com.opensymphony.xwork2.conversion.impl with parameters of type ReflectionProvider
 void InstantiatingNullHandler.setReflectionProvider(ReflectionProvider prov)

Constructors in com.opensymphony.xwork2.conversion.impl with parameters of type ReflectionProvider
DefaultObjectTypeDeterminer(XWorkConverter conv, ReflectionProvider prov)
GenericsObjectTypeDeterminer(XWorkConverter conv, XWorkBasicConverter basicConv, ReflectionProvider prov)
Deprecated.

Uses of ReflectionProvider in com.opensymphony.xwork2.interceptor

Fields in com.opensymphony.xwork2.interceptor declared as ReflectionProvider
protected  ReflectionProvider ChainingInterceptor.reflectionProvider

Methods in com.opensymphony.xwork2.interceptor with parameters of type ReflectionProvider
 void ChainingInterceptor.setReflectionProvider(ReflectionProvider prov)

Uses of ReflectionProvider in com.opensymphony.xwork2.ognl

Classes in com.opensymphony.xwork2.ognl that implement ReflectionProvider
 class OgnlReflectionProvider

Uses of ReflectionProvider in com.opensymphony.xwork2.util.reflection

Methods in com.opensymphony.xwork2.util.reflection that return ReflectionProvider
static ReflectionProvider ReflectionProviderFactory.getInstance()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.reflection.ReflectionProviderFactory (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.util.reflection.ReflectionProviderFactory

No usage of com.opensymphony.xwork2.util.reflection.ReflectionProviderFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ActionValidatorManager (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Interface ActionValidatorManager

All Known Implementing Classes:
AnnotationActionValidatorManager, DefaultActionValidatorManager
public interface ActionValidatorManager

ActionValidatorManager is the main interface for validation managers (regular and annotation based).

Author:
Rainer Hermanns

Method Summary
List<Validator> | getValidators(Class clazz, String context) Returns a list of validators for the given class and context.
List<Validator> | getValidators(Class clazz, String context, String method) Returns a list of validators for the given class, context, and method.
void | validate(Object object, String context) Validates the given object using action and its context.
void | validate(Object object, String context, String method) Validates the given object using an action, its context, and the name of the method being invoked on the action.
void | validate(Object object, String context, ValidatorContext validatorContext) Validates an action give its context and a validation context.
void | validate(Object object, String context, ValidatorContext validatorContext, String method) Validates an action give its context and a validation context.

Method Detail

getValidators

List<Validator> getValidators(Class clazz,
                              String context,
                              String method)
Returns a list of validators for the given class, context, and method. This is the primary lookup method for validators.

Parameters:
clazz - the class to lookup.
context - the context of the action class - can be null.
method - the name of the method being invoked on the action - can be null.
Returns:
a list of all validators for the given class and context.

getValidators

List<Validator> getValidators(Class clazz,
                              String context)
Returns a list of validators for the given class and context. This is the primary lookup method for validators.

Parameters:
clazz - the class to lookup.
context - the context of the action class - can be null.
Returns:
a list of all validators for the given class and context.

validate

void validate(Object object,
              String context)
              throws ValidationException
Validates the given object using action and its context.

Parameters:
object - the action to validate.
context - the action's context.
Throws:
ValidationException - if an error happens when validating the action.

validate

void validate(Object object,
              String context,
              ValidatorContext validatorContext)
              throws ValidationException
Validates an action give its context and a validation context.

Parameters:
object - the action to validate.
context - the action's context.
validatorContext - the validation context to use
Throws:
ValidationException - if an error happens when validating the action.

validate

void validate(Object object,
              String context,
              String method)
              throws ValidationException
Validates the given object using an action, its context, and the name of the method being invoked on the action.

Parameters:
object - the action to validate.
context - the action's context.
method - the name of the method being invoked on the action - can be null.
Throws:
ValidationException - if an error happens when validating the action.

validate

void validate(Object object,
              String context,
              ValidatorContext validatorContext,
              String method)
              throws ValidationException
Validates an action give its context and a validation context.

Parameters:
object - the action to validate.
context - the action's context.
validatorContext - the validation context to use
method - the name of the method being invoked on the action - can be null.
Throws:
ValidationException - if an error happens when validating the action.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AnnotationActionValidatorManager (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class AnnotationActionValidatorManager

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
All Implemented Interfaces:
ActionValidatorManager
public class AnnotationActionValidatorManager
extends Object
implements ActionValidatorManager

AnnotationActionValidatorManager is the entry point into XWork's annotations-based validator framework. Validation rules are specified as annotations within the source files.

Author:
Rainer Hermanns, jepjep

Nested Class Summary
protected  class AnnotationActionValidatorManager.InternalValidatorContextWrapper
An ValidatorContext wrapper that returns the full field name AbstractActionValidatorManager.InternalValidatorContextWrapper by consulting it's parent if its an VisitorFieldValidator.AppendingValidatorContext.
Field Summary
protected static String VALIDATION_CONFIG_SUFFIX
The file suffix for any validation file.
Constructor Summary
AnnotationActionValidatorManager()
Method Summary
protected List<ValidatorConfig> | buildClassValidatorConfigs(Class aClass, boolean checkFile)
protected static String | buildValidatorKey(Class clazz) Builds a key for validators - used when caching validators.
List<Validator> | getValidators(Class clazz, String context) Returns a list of validators for the given class and context.
List<Validator> | getValidators(Class clazz, String context, String method) Returns a list of validators for the given class, context, and method.
void | setValidatorFactory(ValidatorFactory fac)
void | setValidatorFileParser(ValidatorFileParser parser)
void | validate(Object object, String context) Validates the given object using action and its context.
void | validate(Object object, String context, String method) Validates the given object using an action, its context, and the name of the method being invoked on the action.
void | validate(Object object, String context, ValidatorContext validatorContext) Validates an action give its context and a validation context.
void | validate(Object object, String context, ValidatorContext validatorContext, String method) Validates an action give its context and a validation context.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

VALIDATION_CONFIG_SUFFIX

protected static final String VALIDATION_CONFIG_SUFFIX
The file suffix for any validation file.

See Also:
Constant Field Values
Constructor Detail

AnnotationActionValidatorManager

public AnnotationActionValidatorManager()
Method Detail

setValidatorFactory

public void setValidatorFactory(ValidatorFactory fac)

setValidatorFileParser

public void setValidatorFileParser(ValidatorFileParser parser)

getValidators

public List<Validator> getValidators(Class clazz,
                                     String context)
Description copied from interface: ActionValidatorManager
Returns a list of validators for the given class and context. This is the primary lookup method for validators.

Specified by:
getValidators in interface ActionValidatorManager
Parameters:
clazz - the class to lookup.
context - the context of the action class - can be null.
Returns:
a list of all validators for the given class and context.

getValidators

public List<Validator> getValidators(Class clazz,
                                     String context,
                                     String method)
Description copied from interface: ActionValidatorManager
Returns a list of validators for the given class, context, and method. This is the primary lookup method for validators.

Specified by:
getValidators in interface ActionValidatorManager
Parameters:
clazz - the class to lookup.
context - the context of the action class - can be null.
method - the name of the method being invoked on the action - can be null.
Returns:
a list of all validators for the given class and context.

validate

public void validate(Object object,
                     String context)
              throws ValidationException
Description copied from interface: ActionValidatorManager
Validates the given object using action and its context.

Specified by:
validate in interface ActionValidatorManager
Parameters:
object - the action to validate.
context - the action's context.
Throws:
ValidationException - if an error happens when validating the action.

validate

public void validate(Object object,
                     String context,
                     String method)
              throws ValidationException
Description copied from interface: ActionValidatorManager
Validates the given object using an action, its context, and the name of the method being invoked on the action.

Specified by:
validate in interface ActionValidatorManager
Parameters:
object - the action to validate.
context - the action's context.
method - the name of the method being invoked on the action - can be null.
Throws:
ValidationException - if an error happens when validating the action.

validate

public void validate(Object object,
                     String context,
                     ValidatorContext validatorContext)
              throws ValidationException
Description copied from interface: ActionValidatorManager
Validates an action give its context and a validation context.

Specified by:
validate in interface ActionValidatorManager
Parameters:
object - the action to validate.
context - the action's context.
validatorContext - the validation context to use
Throws:
ValidationException - if an error happens when validating the action.

validate

public void validate(Object object,
                     String context,
                     ValidatorContext validatorContext,
                     String method)
              throws ValidationException
Description copied from interface: ActionValidatorManager
Validates an action give its context and a validation context.

Specified by:
validate in interface ActionValidatorManager
Parameters:
object - the action to validate.
context - the action's context.
validatorContext - the validation context to use
method - the name of the method being invoked on the action - can be null.
Throws:
ValidationException - if an error happens when validating the action.

buildValidatorKey

protected static String buildValidatorKey(Class clazz)
Builds a key for validators - used when caching validators.

Parameters:
clazz - the action.
Returns:
a validator key which is the class name plus context.

buildClassValidatorConfigs

protected List<ValidatorConfig> buildClassValidatorConfigs(Class aClass,
                                                           boolean checkFile)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AnnotationActionValidatorManager.InternalValidatorContextWrapper (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class AnnotationActionValidatorManager.InternalValidatorContextWrapper

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.AnnotationActionValidatorManager.InternalValidatorContextWrapper
Enclosing class:
AnnotationActionValidatorManager
protected class AnnotationActionValidatorManager.InternalValidatorContextWrapper
extends Object

An ValidatorContext wrapper that returns the full field name AbstractActionValidatorManager.InternalValidatorContextWrapper by consulting it's parent if its an VisitorFieldValidator.AppendingValidatorContext.

Eg. if we have nested Visitor AddressVisitor nested inside PersonVisitor, when using the normal #getFullFieldName, we will get "address.somefield", we lost the parent, with this wrapper, we will get "person.address.somefield". This is so that the key is used to register errors, so that we don't screw up short-curcuit feature when using nested visitor. See XW-571 (nested visitor validators break short-circuit functionality) at http://jira.opensymphony.com/browse/XW-571

Method Summary
 String getFullFieldName(String field)
Get the full field name by consulting the parent, so that when we are using nested visitors ( visitor nested inside visitor etc.) we still get the full field name including its parents.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getFullFieldName

public String getFullFieldName(String field)
Get the full field name by consulting the parent, so that when we are using nested visitors ( visitor nested inside visitor etc.) we still get the full field name including its parents. See XW-571 for more details.

Parameters:
field -
Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AnnotationValidationConfigurationBuilder (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class AnnotationValidationConfigurationBuilder

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

public class AnnotationValidationConfigurationBuilder
extends Object

AnnotationValidationConfigurationBuilder

Version:
$Id: AnnotationValidationConfigurationBuilder.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns, jepjep

Constructor Summary
AnnotationValidationConfigurationBuilder(ValidatorFactory fac)
Method Summary
List<ValidatorConfig> | buildAnnotationClassValidatorConfigs(Class aClass)
String | resolvePropertyName(Method method) Returns the property name for a method.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AnnotationValidationConfigurationBuilder

public AnnotationValidationConfigurationBuilder(ValidatorFactory fac)
Method Detail

buildAnnotationClassValidatorConfigs

public List<ValidatorConfig> buildAnnotationClassValidatorConfigs(Class aClass)

resolvePropertyName

public String resolvePropertyName(Method method)
Returns the property name for a method. This method is independant from property fields.

Parameters:
method - The method to get the property name for.
Returns:
the property name for given method; null if non could be resolved.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultActionValidatorManager (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class DefaultActionValidatorManager

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.DefaultActionValidatorManager
All Implemented Interfaces:
ActionValidatorManager
public class DefaultActionValidatorManager
extends Object
implements ActionValidatorManager

This is the entry point into XWork's rule-based validation framework.

Validation rules are specified in XML configuration files named className-contextName-validation.xml where className is the name of the class the configuration is for and -contextName is optional (contextName is an arbitrary key that is used to look up additional validation rules for a specific context).

Author:
Jason Carreira, Mark Woon, James House, Rainer Hermanns

Nested Class Summary
protected  class DefaultActionValidatorManager.InternalValidatorContextWrapper
An ValidatorContext wrapper that returns the full field name DefaultActionValidatorManager.InternalValidatorContextWrapper.getFullFieldName(String) by consulting it's parent if its an VisitorFieldValidator.AppendingValidatorContext.
Field Summary
protected static String VALIDATION_CONFIG_SUFFIX
The file suffix for any validation file.
Constructor Summary
DefaultActionValidatorManager()
Method Summary
protected static String | buildValidatorKey(Class clazz, String context) Builds a key for validators - used when caching validators.
List<Validator> | getValidators(Class clazz, String context) Returns a list of validators for the given class and context.
List<Validator> | getValidators(Class clazz, String context, String method) Returns a list of validators for the given class, context, and method.
void | setValidatorFactory(ValidatorFactory fac)
void | setValidatorFileParser(ValidatorFileParser parser)
void | validate(Object object, String context) Validates the given object using action and its context.
void | validate(Object object, String context, String method) Validates the given object using an action, its context, and the name of the method being invoked on the action.
void | validate(Object object, String context, ValidatorContext validatorContext) Validates an action give its context and a validation context.
void | validate(Object object, String context, ValidatorContext validatorContext, String method) Validates an action give its context and a validation context.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

VALIDATION_CONFIG_SUFFIX

protected static final String VALIDATION_CONFIG_SUFFIX
The file suffix for any validation file.

See Also:
Constant Field Values
Constructor Detail

DefaultActionValidatorManager

public DefaultActionValidatorManager()
Method Detail

setValidatorFileParser

public void setValidatorFileParser(ValidatorFileParser parser)

setValidatorFactory

public void setValidatorFactory(ValidatorFactory fac)

getValidators

public List<Validator> getValidators(Class clazz,
                                     String context)
Description copied from interface: ActionValidatorManager
Returns a list of validators for the given class and context. This is the primary lookup method for validators.

Specified by:
getValidators in interface ActionValidatorManager
Parameters:
clazz - the class to lookup.
context - the context of the action class - can be null.
Returns:
a list of all validators for the given class and context.

getValidators

public List<Validator> getValidators(Class clazz,
                                     String context,
                                     String method)
Description copied from interface: ActionValidatorManager
Returns a list of validators for the given class, context, and method. This is the primary lookup method for validators.

Specified by:
getValidators in interface ActionValidatorManager
Parameters:
clazz - the class to lookup.
context - the context of the action class - can be null.
method - the name of the method being invoked on the action - can be null.
Returns:
a list of all validators for the given class and context.

validate

public void validate(Object object,
                     String context)
              throws ValidationException
Description copied from interface: ActionValidatorManager
Validates the given object using action and its context.

Specified by:
validate in interface ActionValidatorManager
Parameters:
object - the action to validate.
context - the action's context.
Throws:
ValidationException - if an error happens when validating the action.

validate

public void validate(Object object,
                     String context,
                     String method)
              throws ValidationException
Description copied from interface: ActionValidatorManager
Validates the given object using an action, its context, and the name of the method being invoked on the action.

Specified by:
validate in interface ActionValidatorManager
Parameters:
object - the action to validate.
context - the action's context.
method - the name of the method being invoked on the action - can be null.
Throws:
ValidationException - if an error happens when validating the action.

validate

public void validate(Object object,
                     String context,
                     ValidatorContext validatorContext)
              throws ValidationException
Description copied from interface: ActionValidatorManager
Validates an action give its context and a validation context.

Specified by:
validate in interface ActionValidatorManager
Parameters:
object - the action to validate.
context - the action's context.
validatorContext - the validation context to use
Throws:
ValidationException - if an error happens when validating the action.

validate

public void validate(Object object,
                     String context,
                     ValidatorContext validatorContext,
                     String method)
              throws ValidationException
Description copied from interface: ActionValidatorManager
Validates an action give its context and a validation context.

Specified by:
validate in interface ActionValidatorManager
Parameters:
object - the action to validate.
context - the action's context.
validatorContext - the validation context to use
method - the name of the method being invoked on the action - can be null.
Throws:
ValidationException - if an error happens when validating the action.

buildValidatorKey

protected static String buildValidatorKey(Class clazz,
                                          String context)
Builds a key for validators - used when caching validators.

Parameters:
clazz - the action.
context - the action's context.
Returns:
a validator key which is the class name plus context.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultActionValidatorManager.InternalValidatorContextWrapper (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class DefaultActionValidatorManager.InternalValidatorContextWrapper

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.DefaultActionValidatorManager.InternalValidatorContextWrapper
Enclosing class:
DefaultActionValidatorManager
protected class DefaultActionValidatorManager.InternalValidatorContextWrapper
extends Object

An ValidatorContext wrapper that returns the full field name getFullFieldName(String) by consulting it's parent if its an VisitorFieldValidator.AppendingValidatorContext.

Eg. if we have nested Visitor AddressVisitor nested inside PersonVisitor, when using the normal #getFullFieldName, we will get "address.somefield", we lost the parent, with this wrapper, we will get "person.address.somefield". This is so that the key is used to register errors, so that we don't screw up short-curcuit feature when using nested visitor. See XW-571 (nested visitor validators break short-circuit functionality) at http://jira.opensymphony.com/browse/XW-571

Method Summary
 String getFullFieldName(String field)
Get the full field name by consulting the parent, so that when we are using nested visitors ( visitor nested inside visitor etc.) we still get the full field name including its parents.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

getFullFieldName

public String getFullFieldName(String field)
Get the full field name by consulting the parent, so that when we are using nested visitors ( visitor nested inside visitor etc.) we still get the full field name including its parents. See XW-571 for more details.

Parameters:
field - The field name
Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultValidatorFactory (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class DefaultValidatorFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.DefaultValidatorFactory
All Implemented Interfaces:
ValidatorFactory
public class DefaultValidatorFactory
extends Object
implements ValidatorFactory

Default validator factory

Version:
$Date: 2009-05-28 16:26:05 +0200 (Do, 28 Mai 2009) $ $Id: DefaultValidatorFactory.java 1994 2009-05-28 14:26:05Z rainerh $
Author:
Jason Carreira, James House

Field Summary
protected ObjectFactory | objectFactory
protected ValidatorFileParser | validatorFileParser
protected Map<String,String> | validators
Constructor Summary
DefaultValidatorFactory(ObjectFactory objectFactory, ValidatorFileParser parser)
Method Summary
Validator | getValidator(ValidatorConfig cfg) Get a Validator that matches the given configuration.
String | lookupRegisteredValidatorType(String name) Lookup to get the FQ classname of the given validator name.
void | registerValidator(String name, String className) Registers the given validator to the existing map of validators.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

validators

protected Map<String,String> validators

objectFactory

protected ObjectFactory objectFactory

validatorFileParser

protected ValidatorFileParser validatorFileParser
Constructor Detail

DefaultValidatorFactory

public DefaultValidatorFactory(ObjectFactory objectFactory,
                               ValidatorFileParser parser)
Method Detail

getValidator

public Validator getValidator(ValidatorConfig cfg)
Description copied from interface: ValidatorFactory
Get a Validator that matches the given configuration.

Specified by:
getValidator in interface ValidatorFactory
Parameters:
cfg - the configurator.
Returns:
the validator.

registerValidator

public void registerValidator(String name,
                              String className)
Description copied from interface: ValidatorFactory
Registers the given validator to the existing map of validators. This will add to the existing list.

Specified by:
registerValidator in interface ValidatorFactory
Parameters:
name - name of validator to add.
className - the FQ classname of the validator.

lookupRegisteredValidatorType

public String lookupRegisteredValidatorType(String name)
Description copied from interface: ValidatorFactory
Lookup to get the FQ classname of the given validator name.

Specified by:
lookupRegisteredValidatorType in interface ValidatorFactory
Parameters:
name - name of validator to lookup.
Returns:
the found FQ classname
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultValidatorFileParser (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class DefaultValidatorFileParser

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.DefaultValidatorFileParser
All Implemented Interfaces:
ValidatorFileParser
public class DefaultValidatorFileParser
extends Object
implements ValidatorFileParser

Parse the validation file. (eg. MyAction-validation.xml, MyAction-actionAlias-validation.xml) to return a List of ValidatorConfig encapsulating the validator information.

Author:
Jason Carreira, James House, tm_jee ( tm_jee (at) yahoo.co.uk ), Rob Harrop, Rene Gielen, Martin Gilday
See Also:
ValidatorConfig

Constructor Summary
DefaultValidatorFileParser()
Method Summary
String | getMultiTextvalueSeparator()
String | getTextValue(Element valueEle) Extract trimmed text value from the given DOM element, ignoring XML comments.
List<ValidatorConfig> | parseActionValidatorConfigs(ValidatorFactory validatorFactory, InputStream is, String resourceName) Parse resource for a list of ValidatorConfig objects (configuring which validator(s) are being applied to a particular field etc.)
void | parseValidatorDefinitions(Map<String,String> validators, InputStream is, String resourceName) Parses validator definitions (register various validators with XWork).
void | setMultiTextvalueSeparator(String type)
void | setObjectFactory(ObjectFactory fac)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultValidatorFileParser

public DefaultValidatorFileParser()
Method Detail

setMultiTextvalueSeparator

public void setMultiTextvalueSeparator(String type)

getMultiTextvalueSeparator

public String getMultiTextvalueSeparator()

setObjectFactory

public void setObjectFactory(ObjectFactory fac)

parseActionValidatorConfigs

public List<ValidatorConfig> parseActionValidatorConfigs(ValidatorFactory validatorFactory,
                                                         InputStream is,
                                                         String resourceName)
Description copied from interface: ValidatorFileParser
Parse resource for a list of ValidatorConfig objects (configuring which validator(s) are being applied to a particular field etc.)

Specified by:
parseActionValidatorConfigs in interface ValidatorFileParser
is - input stream to the resource
resourceName - file name of the resource
Returns:
List list of ValidatorConfig

parseValidatorDefinitions

public void parseValidatorDefinitions(Map<String,String> validators,
                                      InputStream is,
                                      String resourceName)
Description copied from interface: ValidatorFileParser
Parses validator definitions (register various validators with XWork).

Specified by:
parseValidatorDefinitions in interface ValidatorFileParser
is - The input stream
resourceName - The location of the input stream

getTextValue

public String getTextValue(Element valueEle)
Extract trimmed text value from the given DOM element, ignoring XML comments. Appends all CharacterData nodes and EntityReference nodes into a single String value, excluding Comment nodes. This method is based on a method originally found in DomUtils class of Springframework.

See Also:
CharacterData, EntityReference, Comment
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DelegatingValidatorContext (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class DelegatingValidatorContext

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.DelegatingValidatorContext
All Implemented Interfaces:
LocaleProvider, TextProvider, ValidationAware, ValidatorContext
Direct Known Subclasses:
VisitorFieldValidator.AppendingValidatorContext
public class DelegatingValidatorContext
extends Object
implements ValidatorContext

A default implementation of the ValidatorContext interface.

Author:
Jason Carreira, Rainer Hermanns

Constructor Summary
DelegatingValidatorContext(Class clazz)
Create a new validation context given a Class definition.
DelegatingValidatorContext(Object object)
Creates a new validation context given an object - usually an Action.
DelegatingValidatorContext(ValidationAware validationAware, TextProvider textProvider, LocaleProvider localeProvider)
Creates a new validation context given a ValidationAware object, and a text and locale provider.
Method Summary
void | addActionError(String anErrorMessage) Add an Action-level error message to this Action.
void | addActionMessage(String aMessage) Add an Action-level message to this Action.
void | addFieldError(String fieldName, String errorMessage) Add an error message for a given field.
Collection<String> | getActionErrors() Get the Collection of Action-level error messages for this action.
Collection<String> | getActionMessages() Get the Collection of Action-level messages for this action.
Map<String,List<String>> | getFieldErrors() Get the field specific errors associated with this action.
String | getFullFieldName(String fieldName) Translates a simple field name into a full field name in OGNL syntax.
Locale | getLocale() Gets the provided locale.
String | getText(String aTextName) Gets a message based on a message key, or null if no message is found.
String | getText(String aTextName, List<Object> args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
String | getText(String aTextName, String defaultValue) Gets a message based on a key, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String[] args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
String | getText(String aTextName, String defaultValue, List<Object> args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, List<Object> args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String aTextName, String defaultValue, String obj) Gets a message based on a key using the supplied obj, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, String[] args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, String[] args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
protected TextProvider | getTextProvider()
ResourceBundle | getTexts() Get the resource bundle associated with the implementing class (usually an action).
ResourceBundle | getTexts(String aBundleName) Get the named bundle, such as "com/acme/Foo".
protected ValidationAware | getValidationAware()
boolean | hasActionErrors() Check whether there are any Action-level error messages.
boolean | hasActionMessages() Checks whether there are any Action-level messages.
boolean | hasErrors() Checks whether there are any action errors or field errors.
boolean | hasFieldErrors() Check whether there are any field errors associated with this action.
boolean | hasKey(String key) Checks if a message key exists.
protected static LocaleProvider | makeLocaleProvider(Object object)
static TextProvider | makeTextProvider(Object object, LocaleProvider localeProvider)
protected static ValidationAware | makeValidationAware(Object object)
void | setActionErrors(Collection<String> errorMessages) Set the Collection of Action-level String error messages.
void | setActionMessages(Collection<String> messages) Set the Collection of Action-level String messages (not errors).
void | setFieldErrors(Map<String,List<String>> errorMap) Set the field error map of fieldname (String) to Collection of String error messages.
protected void | setTextProvider(TextProvider textProvider)
protected void | setValidationAware(ValidationAware validationAware)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DelegatingValidatorContext

public DelegatingValidatorContext(ValidationAware validationAware,
                                  TextProvider textProvider,
                                  LocaleProvider localeProvider)
Creates a new validation context given a ValidationAware object, and a text and locale provider. These objects are used internally to set errors and get and set error text.

DelegatingValidatorContext

public DelegatingValidatorContext(Object object)
Creates a new validation context given an object - usually an Action. The internal objects (validation aware instance and a locale and text provider) are created based on the given action.

Parameters:
object - the object to use for validation (usually an Action).

DelegatingValidatorContext

public DelegatingValidatorContext(Class clazz)
Create a new validation context given a Class definition. The locale provider, text provider and the validation context are created based on the class.

Parameters:
clazz - the class to initialize the context with.
Method Detail

setActionErrors

public void setActionErrors(Collection<String> errorMessages)
Description copied from interface: ValidationAware
Set the Collection of Action-level String error messages.

Specified by:
setActionErrors in interface ValidationAware
Parameters:
errorMessages - Collection of String error messages

getActionErrors

public Collection<String> getActionErrors()
Description copied from interface: ValidationAware
Get the Collection of Action-level error messages for this action. Error messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getActionErrors in interface ValidationAware
Returns:
Collection of String error messages

setActionMessages

public void setActionMessages(Collection<String> messages)
Description copied from interface: ValidationAware
Set the Collection of Action-level String messages (not errors).

Specified by:
setActionMessages in interface ValidationAware
Parameters:
messages - Collection of String messages (not errors).

getActionMessages

public Collection<String> getActionMessages()
Description copied from interface: ValidationAware
Get the Collection of Action-level messages for this action. Messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getActionMessages in interface ValidationAware
Returns:
Collection of String messages

setFieldErrors

public void setFieldErrors(Map<String,List<String>> errorMap)
Description copied from interface: ValidationAware
Set the field error map of fieldname (String) to Collection of String error messages.

Specified by:
setFieldErrors in interface ValidationAware
Parameters:
errorMap - field error map

getFieldErrors

public Map<String,List<String>> getFieldErrors()
Description copied from interface: ValidationAware
Get the field specific errors associated with this action. Error messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getFieldErrors in interface ValidationAware
Returns:
Map with errors mapped from fieldname (String) to Collection of String error messages

getFullFieldName

public String getFullFieldName(String fieldName)
Description copied from interface: ValidatorContext
Translates a simple field name into a full field name in OGNL syntax.

Specified by:
getFullFieldName in interface ValidatorContext
Parameters:
fieldName - the field name to lookup.
Returns:
the full field name in OGNL syntax.

getLocale

public Locale getLocale()
Description copied from interface: LocaleProvider
Gets the provided locale.

Specified by:
getLocale in interface LocaleProvider
Returns:
the locale.

hasKey

public boolean hasKey(String key)
Description copied from interface: TextProvider
Checks if a message key exists.

Specified by:
hasKey in interface TextProvider
Returns:
boolean true if key exists, false otherwise.

getText

public String getText(String aTextName)
Description copied from interface: TextProvider
Gets a message based on a message key, or null if no message is found.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
Returns:
the message as found in the resource bundle, or null if none is found.

getText

public String getText(String aTextName,
                      String defaultValue)
Description copied from interface: TextProvider
Gets a message based on a key, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String aTextName,
                      String defaultValue,
                      String obj)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied obj, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
obj - obj to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String aTextName,
                      List<Object> args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
args - a list args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or null if none is found.

getText

public String getText(String key,
                      String[] args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
args - an array args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or null if none is found.

getText

public String getText(String aTextName,
                      String defaultValue,
                      List<Object> args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - a list args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      String[] args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - an array args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getTexts

public ResourceBundle getTexts(String aBundleName)
Description copied from interface: TextProvider
Get the named bundle, such as "com/acme/Foo".

Specified by:
getTexts in interface TextProvider
Parameters:
aBundleName - the name of the resource bundle, such as "com/acme/Foo".
Returns:
the bundle

getText

public String getText(String key,
                      String defaultValue,
                      List<Object> args,
                      ValueStack stack)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - a list args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      String[] args,
                      ValueStack stack)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - an array args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getTexts

public ResourceBundle getTexts()
Description copied from interface: TextProvider
Get the resource bundle associated with the implementing class (usually an action).

Specified by:
getTexts in interface TextProvider
Returns:
the bundle

addActionError

public void addActionError(String anErrorMessage)
Description copied from interface: ValidationAware
Add an Action-level error message to this Action.

Specified by:
addActionError in interface ValidationAware
Parameters:
anErrorMessage - the error message

addActionMessage

public void addActionMessage(String aMessage)
Description copied from interface: ValidationAware
Add an Action-level message to this Action.

Specified by:
addActionMessage in interface ValidationAware
Parameters:
aMessage - the message

addFieldError

public void addFieldError(String fieldName,
                          String errorMessage)
Description copied from interface: ValidationAware
Add an error message for a given field.

Specified by:
addFieldError in interface ValidationAware
Parameters:
fieldName - name of field
errorMessage - the error message

hasActionErrors

public boolean hasActionErrors()
Description copied from interface: ValidationAware
Check whether there are any Action-level error messages.

Specified by:
hasActionErrors in interface ValidationAware
Returns:
true if any Action-level error messages have been registered

hasActionMessages

public boolean hasActionMessages()
Description copied from interface: ValidationAware
Checks whether there are any Action-level messages.

Specified by:
hasActionMessages in interface ValidationAware
Returns:
true if any Action-level messages have been registered

hasErrors

public boolean hasErrors()
Description copied from interface: ValidationAware
Checks whether there are any action errors or field errors.

Note: that this does not have the same meaning as in WW 1.x.

Specified by:
hasErrors in interface ValidationAware
Returns:
(hasActionErrors() || hasFieldErrors())

hasFieldErrors

public boolean hasFieldErrors()
Description copied from interface: ValidationAware
Check whether there are any field errors associated with this action.

Specified by:
hasFieldErrors in interface ValidationAware
Returns:
whether there are any field errors

makeTextProvider

public static TextProvider makeTextProvider(Object object,
                                            LocaleProvider localeProvider)

makeLocaleProvider

protected static LocaleProvider makeLocaleProvider(Object object)

makeValidationAware

protected static ValidationAware makeValidationAware(Object object)

setTextProvider

protected void setTextProvider(TextProvider textProvider)

getTextProvider

protected TextProvider getTextProvider()

setValidationAware

protected void setValidationAware(ValidationAware validationAware)

getValidationAware

protected ValidationAware getValidationAware()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Interface FieldValidator

All Superinterfaces:
Validator
All Known Implementing Classes:
AbstractRangeValidator, ConditionalVisitorFieldValidator, ConversionErrorFieldValidator, DateRangeFieldValidator, DoubleRangeFieldValidator, EmailValidator, FieldExpressionValidator, FieldValidatorSupport, IntRangeFieldValidator, LongRangeFieldValidator, RegexFieldValidator, RepopulateConversionErrorFieldValidatorSupport, RequiredFieldValidator, RequiredStringValidator, ShortRangeFieldValidator, StringLengthFieldValidator, URLValidator, VisitorFieldValidator
public interface FieldValidator
extends Validator

The FieldValidator interface defines the methods to be implemented by FieldValidators. Which are used by the XWork validation framework to validate Action properties before executing the Action.

Method Summary
String | getFieldName() Gets the field name to be validated
void | setFieldName(String fieldName) Sets the field name to validate with this FieldValidator
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getMessageParameters, getValidatorContext, getValidatorType, setDefaultMessage, setMessageKey, setMessageParameters, setValidatorContext, setValidatorType, setValueStack, validate

Method Detail

setFieldName

void setFieldName(String fieldName)
Sets the field name to validate with this FieldValidator

Parameters:
fieldName - the field name

getFieldName

String getFieldName()
Gets the field name to be validated

Returns:
the field name
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.validator (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.validator
Interfaces
ActionValidatorManager
FieldValidator
ShortCircuitableValidator
Validator
ValidatorContext
ValidatorFactory
ValidatorFileParser
Classes
AnnotationActionValidatorManager
AnnotationValidationConfigurationBuilder
DefaultActionValidatorManager
DefaultValidatorFactory
DefaultValidatorFileParser
DelegatingValidatorContext
ValidationInterceptor
ValidatorConfig
ValidatorConfig.Builder
Exceptions
ValidationException


com.opensymphony.xwork2.validator (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.validator

XWork validation subsystem.

See:
Description

Interface Summary
ActionValidatorManager | ActionValidatorManager is the main interface for validation managers (regular and annotation based).
FieldValidator | The FieldValidator interface defines the methods to be implemented by FieldValidators.
ShortCircuitableValidator | This interface should be implemented by validators that can short-circuit the validator queue that it is in.
Validator<T> |
ValidatorContext | The context for validation.
ValidatorFactory | ValidatorFactory
ValidatorFileParser | This class serves 2 purpose : Parse the validation config file.

Class Summary
AnnotationActionValidatorManager | AnnotationActionValidatorManager is the entry point into XWork's annotations-based validator framework.
AnnotationValidationConfigurationBuilder | AnnotationValidationConfigurationBuilder
DefaultActionValidatorManager | This is the entry point into XWork's rule-based validation framework.
DefaultValidatorFactory | Default validator factory
DefaultValidatorFileParser | Parse the validation file.
DelegatingValidatorContext | A default implementation of the ValidatorContext interface.
ValidationInterceptor | This interceptor runs the action through the standard validation framework, which in turn checks the action against any validation rules (found in files such as ActionClass-validation.xml) and adds field-level and action-level error messages (provided that the action implements ValidationAware).
ValidatorConfig | Holds the necessary information for configuring an instance of a Validator.
ValidatorConfig.Builder | Builds a ValidatorConfig

Exception Summary
ValidationException ValidationException.

Package com.opensymphony.xwork2.validator Description

XWork validation subsystem.


com.opensymphony.xwork2.validator Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.validator

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.interceptor.AbstractInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
      • com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
        • com.opensymphony.xwork2.validator.ValidationInterceptor
    • com.opensymphony.xwork2.validator.AnnotationActionValidatorManager (implements com.opensymphony.xwork2.validator.ActionValidatorManager)
    • com.opensymphony.xwork2.validator.AnnotationActionValidatorManager.InternalValidatorContextWrapper
    • com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder
    • com.opensymphony.xwork2.validator.DefaultActionValidatorManager (implements com.opensymphony.xwork2.validator.ActionValidatorManager)
    • com.opensymphony.xwork2.validator.DefaultActionValidatorManager.InternalValidatorContextWrapper
    • com.opensymphony.xwork2.validator.DefaultValidatorFactory (implements com.opensymphony.xwork2.validator.ValidatorFactory)
    • com.opensymphony.xwork2.validator.DefaultValidatorFileParser (implements com.opensymphony.xwork2.validator.ValidatorFileParser)
    • com.opensymphony.xwork2.validator.DelegatingValidatorContext (implements com.opensymphony.xwork2.validator.ValidatorContext)
    • com.opensymphony.xwork2.util.location.Located (implements com.opensymphony.xwork2.util.location.Locatable)
      • com.opensymphony.xwork2.validator.ValidatorConfig
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • com.opensymphony.xwork2.validator.ValidationException
    • com.opensymphony.xwork2.validator.ValidatorConfig.Builder

Interface Hierarchy

  • com.opensymphony.xwork2.validator.ActionValidatorManager
  • com.opensymphony.xwork2.LocaleProvider
    • com.opensymphony.xwork2.validator.ValidatorContext (also extends com.opensymphony.xwork2.TextProvider, com.opensymphony.xwork2.ValidationAware)
  • com.opensymphony.xwork2.validator.ShortCircuitableValidator
  • com.opensymphony.xwork2.TextProvider
    • com.opensymphony.xwork2.validator.ValidatorContext (also extends com.opensymphony.xwork2.LocaleProvider, com.opensymphony.xwork2.ValidationAware)
  • com.opensymphony.xwork2.ValidationAware
    • com.opensymphony.xwork2.validator.ValidatorContext (also extends com.opensymphony.xwork2.LocaleProvider, com.opensymphony.xwork2.TextProvider)
  • com.opensymphony.xwork2.validator.Validator<T>
    • com.opensymphony.xwork2.validator.FieldValidator
  • com.opensymphony.xwork2.validator.ValidatorFactory
  • com.opensymphony.xwork2.validator.ValidatorFileParser


Uses of Package com.opensymphony.xwork2.validator (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.validator

Packages that use com.opensymphony.xwork2.validator
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Classes in com.opensymphony.xwork2.validator used by com.opensymphony.xwork2
Validator

Classes in com.opensymphony.xwork2.validator used by com.opensymphony.xwork2.validator
ActionValidatorManager
ActionValidatorManager is the main interface for validation managers (regular and annotation based).
ValidationException
ValidationException.
Validator
ValidatorConfig
Holds the necessary information for configuring an instance of a Validator.
ValidatorConfig.Builder
Builds a ValidatorConfig
ValidatorContext
The context for validation.
ValidatorFactory
ValidatorFactory
ValidatorFileParser
This class serves 2 purpose : Parse the validation config file.

Classes in com.opensymphony.xwork2.validator used by com.opensymphony.xwork2.validator.validators
ActionValidatorManager
ActionValidatorManager is the main interface for validation managers (regular and annotation based).
DelegatingValidatorContext
A default implementation of the ValidatorContext interface.
FieldValidator
The FieldValidator interface defines the methods to be implemented by FieldValidators.
ShortCircuitableValidator
This interface should be implemented by validators that can short-circuit the validator queue that it is in.
ValidationException
ValidationException.
Validator
ValidatorContext
The context for validation.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ShortCircuitableValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Interface ShortCircuitableValidator

All Known Implementing Classes:
AbstractRangeValidator, ConditionalVisitorFieldValidator, ConversionErrorFieldValidator, DateRangeFieldValidator, DoubleRangeFieldValidator, EmailValidator, ExpressionValidator, FieldExpressionValidator, FieldValidatorSupport, IntRangeFieldValidator, LongRangeFieldValidator, RegexFieldValidator, RepopulateConversionErrorFieldValidatorSupport, RequiredFieldValidator, RequiredStringValidator, ShortRangeFieldValidator, StringLengthFieldValidator, URLValidator, ValidatorSupport, VisitorFieldValidator
public interface ShortCircuitableValidator

This interface should be implemented by validators that can short-circuit the validator queue that it is in.

Author:
Mark Woon

Method Summary
boolean | isShortCircuit() Gets whether this field validator should short circuit the validator queue it's in if validation fails.
void | setShortCircuit(boolean shortcircuit) Sets whether this field validator should short circuit the validator queue it's in if validation fails.

Method Detail

setShortCircuit

void setShortCircuit(boolean shortcircuit)
Sets whether this field validator should short circuit the validator queue it's in if validation fails.

Parameters:
shortcircuit - true if this field validator should short circuit on failure, false otherwise

isShortCircuit

boolean isShortCircuit()
Gets whether this field validator should short circuit the validator queue it's in if validation fails.

Returns:
true if this field validator should short circuit on failure, false otherwise
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidationException (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class ValidationException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  com.opensymphony.xwork2.validator.ValidationException
All Implemented Interfaces:
Serializable
public class ValidationException
extends Exception

ValidationException.

Author:
Jason Carreira
See Also:
Serialized Form

Constructor Summary
ValidationException()
Constructs an Exception with no specified detail message.
ValidationException(String s)
Constructs an Exception with the specified detail message.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ValidationException

public ValidationException()
Constructs an Exception with no specified detail message.

ValidationException

public ValidationException(String s)
Constructs an Exception with the specified detail message.

Parameters:
s - the detail message.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidationInterceptor (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class ValidationInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
            extended by  com.opensymphony.xwork2.validator.ValidationInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class ValidationInterceptor
extends MethodFilterInterceptor

This interceptor runs the action through the standard validation framework, which in turn checks the action against any validation rules (found in files such as ActionClass-validation.xml) and adds field-level and action-level error messages (provided that the action implements ValidationAware). This interceptor is often one of the last (or second to last) interceptors applied in a stack, as it assumes that all values have already been set on the action.

This interceptor does nothing if the name of the method being invoked is specified in the excludeMethods parameter. excludeMethods accepts a comma-delimited list of method names. For example, requests to foo!input.action and foo!back.action will be skipped by this interceptor if you set the excludeMethods parameter to "input, back".

The workflow of the action request does not change due to this interceptor. Rather, this interceptor is often used in conjuction with the workflow interceptor.

NOTE: As this method extends off MethodFilterInterceptor, it is capable of deciding if it is applicable only to selective methods in the action class. See MethodFilterInterceptor for more info.

Interceptor parameters:

  • alwaysInvokeValidate - Defaults to true. If true validate() method will always be invoked, otherwise it will not.
  • programmatic - Defaults to true. If true and the action is Validateable call validate(), and any method that starts with "validate".
  • declarative - Defaults to true. Perform validation based on xml or annotations.

Extending the interceptor:

There are no known extension points for this interceptor.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="params"/>
     <interceptor-ref name="validation"/>
     <interceptor-ref name="workflow"/>
     <result name="success">good_result.ftl</result>
 </action>

 <-- in the following case myMethod of the action class will not
        get validated -->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="params"/>
     <interceptor-ref name="validation">
         <param name="excludeMethods">myMethod</param>
     </interceptor-ref>
     <interceptor-ref name="workflow"/>
     <result name="success">good_result.ftl</result>
 </action>

 <-- in the following case only annotated methods of the action class will
        be validated -->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="params"/>
     <interceptor-ref name="validation">
         <param name="validateAnnotatedMethodOnly">true</param>
     </interceptor-ref>
     <interceptor-ref name="workflow"/>
     <result name="success">good_result.ftl</result>
 </action>

Author:
Jason Carreira, Rainer Hermanns, Alexandru Popescu
See Also:
ActionValidatorManager, DefaultWorkflowInterceptor, Serialized Form

Field Summary
Fields inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
excludeMethods, includeMethods, log
Constructor Summary
ValidationInterceptor()
Method Summary
protected  void doBeforeInvocation(ActionInvocation invocation)
Gets the current action and its context and delegates to ActionValidatorManager proper validate method.
protected  String doIntercept(ActionInvocation invocation)
Subclasses must override to implement the interceptor logic.
 boolean isValidateAnnotatedMethodOnly()
Gets if validate() should always be called or only per annotated method.
 void setActionValidatorManager(ActionValidatorManager mgr)
 void setAlwaysInvokeValidate(String alwaysInvokeValidate)
Determines if Validateable's validate() should always be invoked.
 void setDeclarative(boolean declarative)
Determines if validation based on annotations or xml should be performed.
 void setProgrammatic(boolean programmatic)
Determines if Validateable's validate() should be called, as well as methods whose name that start with "validate".
 void setValidateAnnotatedMethodOnly(boolean validateAnnotatedMethodOnly)
Determine if validate() should always be called or only per annotated method.
Methods inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
applyInterceptor, getExcludeMethodsSet, getIncludeMethodsSet, intercept, setExcludeMethods, setIncludeMethods
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ValidationInterceptor

public ValidationInterceptor()
Method Detail

setActionValidatorManager

public void setActionValidatorManager(ActionValidatorManager mgr)

setProgrammatic

public void setProgrammatic(boolean programmatic)
Determines if Validateable's validate() should be called, as well as methods whose name that start with "validate". Defaults to "true".

Parameters:
programmatic - true then validate() is invoked.

setDeclarative

public void setDeclarative(boolean declarative)
Determines if validation based on annotations or xml should be performed. Defaults to "true".

Parameters:
declarative - true then perform validation based on annotations or xml.

setAlwaysInvokeValidate

public void setAlwaysInvokeValidate(String alwaysInvokeValidate)
Determines if Validateable's validate() should always be invoked. Default to "true".

Parameters:
alwaysInvokeValidate - true then validate() is always invoked.

isValidateAnnotatedMethodOnly

public boolean isValidateAnnotatedMethodOnly()
Gets if validate() should always be called or only per annotated method.

Returns:
true to only validate per annotated method, otherwise false to always validate.

setValidateAnnotatedMethodOnly

public void setValidateAnnotatedMethodOnly(boolean validateAnnotatedMethodOnly)
Determine if validate() should always be called or only per annotated method. Default to false.

Parameters:
validateAnnotatedMethodOnly - true to only validate per annotated method, otherwise false to always validate.

doBeforeInvocation

protected void doBeforeInvocation(ActionInvocation invocation)
                           throws Exception
Gets the current action and its context and delegates to ActionValidatorManager proper validate method.

Parameters:
invocation - the execution state of the Action.
Throws:
Exception - if an error occurs validating the action.

doIntercept

protected String doIntercept(ActionInvocation invocation)
                      throws Exception
Description copied from class: MethodFilterInterceptor
Subclasses must override to implement the interceptor logic.

Specified by:
doIntercept in class MethodFilterInterceptor
Parameters:
invocation - the action invocation
Returns:
the result of invocation
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Validator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Interface Validator<T>

All Known Subinterfaces:
FieldValidator
All Known Implementing Classes:
AbstractRangeValidator, ConditionalVisitorFieldValidator, ConversionErrorFieldValidator, DateRangeFieldValidator, DoubleRangeFieldValidator, EmailValidator, ExpressionValidator, FieldExpressionValidator, FieldValidatorSupport, IntRangeFieldValidator, LongRangeFieldValidator, RegexFieldValidator, RepopulateConversionErrorFieldValidatorSupport, RequiredFieldValidator, RequiredStringValidator, ShortRangeFieldValidator, StringLengthFieldValidator, URLValidator, ValidatorSupport, VisitorFieldValidator
public interface Validator<T>

The validators supplied by the XWork distribution (and any validators you might write yourself) come in two different flavors:

  1. Plain Validators / Non-Field validators
  2. FieldValidators

Plain Validators (such as the ExpressionValidator) perform validation checks that are not inherently tied to a single specified field. When you declare a plain Validator in your -validation.xml file you do not associate a fieldname attribute with it. (You should avoid using plain Validators within the syntax described below.)

FieldValidators (such as the EmailValidator) are designed to perform validation checks on a single field. They require that you specify a fieldname attribute in your -validation.xml file. There are two different (but equivalent) XML syntaxes you can use to declare FieldValidators (see " vs. syntax" below).

There are two places where the differences between the two validator flavors are important to keep in mind:

  1. when choosing the xml syntax used for declaring a validator (either or )
  2. when using the short-circuit capability

NOTE:Note that you do not declare what "flavor" of validator you are using in your -validation.xml file, you just declare the name of the validator to use and Struts will know whether it's a "plain Validator" or a "FieldValidator" by looking at the validation class that the validator's programmer chose to implement.

To define validation rules for an Action, create a file named ActionName-validation.xml in the same package as the Action. You may also create alias-specific validation rules which add to the default validation rules defined in ActionName-validation.xml by creating another file in the same directory named ActionName-aliasName-validation.xml. In both cases, ActionName is the name of the Action class, and aliasName is the name of the Action alias defined in the xwork.xml configuration for the Action.

The framework will also search up the inheritance tree of the Action to find validation rules for directly implemented interfaces and parent classes of the Action. This is particularly powerful when combined with ModelDriven Actions and the VisitorFieldValidator. Here's an example of how validation rules are discovered. Given the following class structure:

  • interface Animal;
  • interface Quadraped extends Animal;
  • class AnimalImpl implements Animal;
  • class QuadrapedImpl extends AnimalImpl implements Quadraped;
  • class Dog extends QuadrapedImpl;

The framework method will look for the following config files if Dog is to be validated:

  • Animal
  • Animal-aliasname
  • AnimalImpl
  • AnimalImpl-aliasname
  • Quadraped
  • Quadraped-aliasname
  • QuadrapedImpl
  • QuadrapedImpl-aliasname
  • Dog
  • Dog-aliasname

While this process is similar to what the XW:Localization framework does when finding messages, there are some subtle differences. The most important difference is that validation rules are discovered from the parent downwards.

NOTE:Child's *-validation.xml will add on to parent's *-validation.xml according to the class hierarchy defined above. With this feature, one could have more generic validation rule at the parent and more specific validation rule at the child.

There are two ways you can define validators in your -validation.xml file:

  1. <validator>
  2. <field-validator>

Keep the following in mind when using either syntax:

Non-Field-Validator The <validator> element allows you to declare both types of validators (either a plain Validator a field-specific FieldValidator).

    <!-- Declaring a plain Validator using the <validator> syntax: -->

    <validator type="expression>
          <param name="expression">foo gt bar</param>
          <message>foo must be great than bar.</message>
    </validator>

    <!-- Declaring a field validator using the <validator> syntax; -->

    <validator type="required">
         <param name="fieldName">bar</param>
         <message>You must enter a value for bar.</message>
    </validator>

field-validator The <field-validator> elements are basically the same as the <validator> elements except that they inherit the fieldName attribute from the enclosing <field> element. FieldValidators defined within a <field-validator> element will have their fieldName automatically filled with the value of the parent <field> element's fieldName attribute. The reason for this structure is to conveniently group the validators for a particular field under one element, otherwise the fieldName attribute would have to be repeated, over and over, for each individual <validator>.

HINT: It is always better to defined field-validator inside a <field> tag instead of using a <validator> tag and supplying fieldName as its param as the xml code itself is clearer (grouping of field is clearer)

NOTE: Note that you should only use FieldValidators (not plain Validators) within a block. A plain Validator inside a <field> will not be allowed and would generate error when parsing the xml, as it is not allowed in the defined dtd (xwork-validator-1.0.2.dtd)

 Declaring a FieldValidator using the <field-validator> syntax:

 <field name="email_address">
   <field-validator type="required">
       <message>You cannot leave the email address field empty.</message>
   </field-validator>
   <field-validator type="email">
       <message>The email address you entered is not valid.</message>
   </field-validator>
 </field>

The choice is yours. It's perfectly legal to only use elements without the elements and set the fieldName attribute for each of them. The following are effectively equal:

 <field name="email_address">
   <field-validator type="required">
       <message>You cannot leave the email address field empty.</message>
   </field-validator>
   <field-validator type="email">
       <message>The email address you entered is not valid.</message>
   </field-validator>
 </field>

 <validator type="required">
   <param name="fieldName">email_address</param>
   <message>You cannot leave the email address field empty.</message>
 </validator>
 <validator type="email">
   <param name="fieldName">email_address</param>
   <message>The email address you entered is not valid.</message>
 </validator>

It is possible to short-circuit a stack of validators. Here is another sample config file containing validation rules from the Xwork test cases: Notice that some of the <field-validator> and <validator> elements have the short-circuit attribute set to true.

 <!-- START SNIPPET: exShortCircuitingValidators -->
 <!DOCTYPE validators PUBLIC
         "-//OpenSymphony Group//XWork Validator 1.0.2//EN"
         "http://www.opensymphony.com/xwork/xwork-validator-1.0.2.dtd">
 <validators>
   <!-- Field Validators for email field -->
   <field name="email">
       <field-validator type="required" short-circuit="true">
           <message>You must enter a value for email.</message>
       </field-validator>
       <field-validator type="email" short-circuit="true">
           <message>Not a valid e-mail.</message>
       </field-validator>
   </field>
   <!-- Field Validators for email2 field -->
   <field name="email2">
      <field-validator type="required">
           <message>You must enter a value for email2.</message>
       </field-validator>
      <field-validator type="email">
           <message>Not a valid e-mail2.</message>
       </field-validator>
   </field>
   <!-- Plain Validator 1 -->
   <validator type="expression">
       <param name="expression">email.equals(email2)</param>
       <message>Email not the same as email2</message>
   </validator>
   <!-- Plain Validator 2 -->
   <validator type="expression" short-circuit="true">
       <param name="expression">email.startsWith('mark')</param>
       <message>Email does not start with mark</message>
   </validator>
 </validators>
 <!-- END SNIPPET: exShortCircuitingValidators -->

short-circuiting and Validator flavors

Plain validator takes precedence over field-validator. They get validated first in the order they are defined and then the field-validator in the order they are defined. Failure of a particular validator marked as short-circuit will prevent the evaluation of subsequent validators and an error (action error or field error depending on the type of validator) will be added to the ValidationContext of the object being validated.

In the example above, the actual execution of validator would be as follows:

  1. Plain Validator 1
  2. Plain Validator 2
  3. Field Validators for email field
  4. Field Validators for email2 field

Since Plain Validator 2 is short-circuited, if its validation failed, it will causes Field validators for email field and Field validators for email2 field to not be validated as well.

Usefull Information: More complicated validation should probably be done in the validate() method on the action itself (assuming the action implements Validatable interface which ActionSupport already does).

A plain Validator (non FieldValidator) that gets short-circuited will completely break out of the validation stack. No other validators will be evaluated and plain validators takes precedence over field validators meaning that they get evaluated in the order they are defined before field validators get a chance to be evaluated.

Short cuircuiting and validator flavours

A FieldValidator that gets short-circuited will only prevent other FieldValidators for the same field from being evaluated. Note that this "same field" behavior applies regardless of whether the or syntax was used to declare the validation rule. By way of example, given this -validation.xml file:

 <validator type="required" short-circuit="true">
   <param name="fieldName">bar</param>
   <message>You must enter a value for bar.</message>
 </validator>

 <validator type="expression">
   <param name="expression">foo gt bar</param>
   <message>foo must be great than bar.</message>
 </validator>

both validators will be run, even if the "required" validator short-circuits. "required" validators are FieldValidator's and will not short-circuit the plain ExpressionValidator because FieldValidators only short-circuit other checks on that same field. Since the plain Validator is not field specific, it is not short-circuited.

As mentioned above, the framework will also search up the inheritance tree of the action to find default validations for interfaces and parent classes of the Action. If you are using the short-circuit attribute and relying on default validators higher up in the inheritance tree, make sure you don't accidentally short-circuit things higher in the tree that you really want!

The effect of having common validators on both

  • <actionClass>-validation.xml
  • <actionClass>-<actionAlias>-validation.xml

It should be noted that the nett effect will be validation on both the validators available in both validation configuration file. For example if we have 'requiredstring' validators defined in both validation xml file for field named 'address', we will see 2 validation error indicating that the the address cannot be empty (assuming validation failed). This is due to WebWork will merge validators found in both validation configuration files.

The logic behind this design decision is such that we could have common validators in <actionClass>-validation.xml and more context specific validators to be located in <actionClass>-<actionAlias>-validation.xml

Validator's validation messages could be internatinalized. For example,

   <field-validator type="required">
      <message key="required.field" />
   </field-validator>
or
   <validator type="expression">
      <param name="expression">email.startsWith('Mark')</param>
      <message key="email.invalid" />
   </validator>
In the first case, WebWork would look for i18n with key 'required.field' as the validation error message if validation fails, and 'email.invalid' in the second case.

We could also provide a default message such that if validation failed and the i18n key for the message cannot be found, WebWork would fall back and use the default message. An example would be as follows :-

   <field-validator type="required">
      <message key="required.field">This field is required.</message>
   </field-validator>
or
   <validator type="expression">
      <param name="expression">email.startsWith('Mark')</param>
      <message key="email.invalid">Email needs with starts with Mark</message>
   </validator>

Author:
Jason Carreira

Method Summary
String | getDefaultMessage() Gets the default message used for validation failures
String | getMessage(Object object) Gets the validation failure message for the given object
String | getMessageKey() Gets the resource bundle key used for lookup of validation failure message
String[] | getMessageParameters() Gets the messsage parameters to be used when parsing i18n messages
ValidatorContext | getValidatorContext() Gets the validation context used
String | getValidatorType() Gets the vaildator type used (see class javadoc).
void | setDefaultMessage(String message) Sets the default message to use for validation failure
void | setMessageKey(String key) Sets a resource bundle key to be used for lookup of validation failure message
void | setMessageParameters(String[] messageParameters) Sets the messsage parameters to be used when parsing i18n messages
void | setValidatorContext(ValidatorContext validatorContext) This method will be called before validate with a non-null ValidatorContext.
void | setValidatorType(String type) Sets the validator type to use (see class javadoc).
void | setValueStack(ValueStack stack) Sets the value stack to use to resolve values and parameters
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Method Detail

setDefaultMessage

void setDefaultMessage(String message)
Sets the default message to use for validation failure

Parameters:
message - the default message

getDefaultMessage

String getDefaultMessage()
Gets the default message used for validation failures

Returns:
the default message

getMessage

String getMessage(Object object)
Gets the validation failure message for the given object

Parameters:
object - object being validated (eg. a domain model object)
Returns:
the validation failure message

setMessageKey

void setMessageKey(String key)
Sets a resource bundle key to be used for lookup of validation failure message

Parameters:
key - the resource bundle key

getMessageKey

String getMessageKey()
Gets the resource bundle key used for lookup of validation failure message

Returns:
the resource bundle key

setMessageParameters

void setMessageParameters(String[] messageParameters)
Sets the messsage parameters to be used when parsing i18n messages

Parameters:
messageParameters - the messsage parameters

getMessageParameters

String[] getMessageParameters()
Gets the messsage parameters to be used when parsing i18n messages

Returns:
the messsage parameters

setValidatorContext

void setValidatorContext(ValidatorContext validatorContext)
This method will be called before validate with a non-null ValidatorContext.

Parameters:
validatorContext - the validation context to use.

getValidatorContext

ValidatorContext getValidatorContext()
Gets the validation context used

Returns:
the validation context

validate

void validate(Object object)
              throws ValidationException
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Parameters:
object - the object to be validated.
Throws:
ValidationException - is thrown if there is validation error(s).

setValidatorType

void setValidatorType(String type)
Sets the validator type to use (see class javadoc).

Parameters:
type - the type to use.

getValidatorType

String getValidatorType()
Gets the vaildator type used (see class javadoc).

Returns:
the type used

setValueStack

void setValueStack(ValueStack stack)
Sets the value stack to use to resolve values and parameters

Parameters:
stack - The value stack for the request
Since:
2.1.1
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidatorConfig (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class ValidatorConfig

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.validator.ValidatorConfig
All Implemented Interfaces:
Locatable
public class ValidatorConfig
extends Located

Holds the necessary information for configuring an instance of a Validator.

Author:
James House, Rainer Hermanns, tm_jee, Martin Gilday

Nested Class Summary
static class ValidatorConfig.Builder
Builds a ValidatorConfig
Field Summary
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
protected | ValidatorConfig(String validatorType)
protected | ValidatorConfig(ValidatorConfig orig)
Method Summary
String | getDefaultMessage()
String | getMessageKey()
String[] | getMessageParams()
Map<String,String> | getParams()
String | getType()
boolean | isShortCircuit()
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ValidatorConfig

protected ValidatorConfig(String validatorType)
Parameters:
validatorType -

ValidatorConfig

protected ValidatorConfig(ValidatorConfig orig)
Method Detail

getDefaultMessage

public String getDefaultMessage()
Returns:
Returns the defaultMessage for the validator.

getMessageKey

public String getMessageKey()
Returns:
Returns the messageKey for the validator.

isShortCircuit

public boolean isShortCircuit()
Returns:
Returns wether the shortCircuit flag should be set on the validator.

getParams

public Map<String,String> getParams()
Returns:
Returns the configured params to set on the validator.

getType

public String getType()
Returns:
Returns the type of validator to configure.

getMessageParams

public String[] getMessageParams()
Returns:
The i18n message parameters/arguments to be used.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidatorConfig.Builder (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class ValidatorConfig.Builder

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.ValidatorConfig.Builder
Enclosing class:
ValidatorConfig
public static final class ValidatorConfig.Builder
extends Object

Builds a ValidatorConfig

Constructor Summary
ValidatorConfig.Builder(String validatorType)
ValidatorConfig.Builder(ValidatorConfig config)
Method Summary
ValidatorConfig.Builder | addParam(String name, String value)
ValidatorConfig.Builder | addParams(Map<String,String> params)
ValidatorConfig | build()
ValidatorConfig.Builder | defaultMessage(String msg)
ValidatorConfig.Builder | location(Location loc)
ValidatorConfig.Builder | messageKey(String key)
ValidatorConfig.Builder | messageParams(String[] msgParams)
ValidatorConfig.Builder | removeParam(String key)
ValidatorConfig.Builder | shortCircuit(boolean shortCircuit)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ValidatorConfig.Builder

public ValidatorConfig.Builder(String validatorType)

ValidatorConfig.Builder

public ValidatorConfig.Builder(ValidatorConfig config)
Method Detail

shortCircuit

public ValidatorConfig.Builder shortCircuit(boolean shortCircuit)

defaultMessage

public ValidatorConfig.Builder defaultMessage(String msg)

messageParams

public ValidatorConfig.Builder messageParams(String[] msgParams)

messageKey

public ValidatorConfig.Builder messageKey(String key)

addParam

public ValidatorConfig.Builder addParam(String name,
                                        String value)

addParams

public ValidatorConfig.Builder addParams(Map<String,String> params)

location

public ValidatorConfig.Builder location(Location loc)

build

public ValidatorConfig build()

removeParam

public ValidatorConfig.Builder removeParam(String key)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidatorContext (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Interface ValidatorContext

All Superinterfaces:
LocaleProvider, TextProvider, ValidationAware
All Known Implementing Classes:
DelegatingValidatorContext, VisitorFieldValidator.AppendingValidatorContext
public interface ValidatorContext
extends ValidationAware, TextProvider, LocaleProvider

The context for validation. This interface extends others to provide methods for reporting errors and messages as well as looking up error messages in a resource bundle using a specific locale.

Author:
Jason Carreira

Method Summary
 String getFullFieldName(String fieldName)
Translates a simple field name into a full field name in OGNL syntax.
Methods inherited from interface com.opensymphony.xwork2.ValidationAware
addActionError, addActionMessage, addFieldError, getActionErrors, getActionMessages, getFieldErrors, hasActionErrors, hasActionMessages, hasErrors, hasFieldErrors, setActionErrors, setActionMessages, setFieldErrors
Methods inherited from interface com.opensymphony.xwork2.TextProvider
getText, getText, getText, getText, getText, getText, getText, getText, getText, getTexts, getTexts, hasKey
Methods inherited from interface com.opensymphony.xwork2.LocaleProvider
getLocale

Method Detail

getFullFieldName

String getFullFieldName(String fieldName)
Translates a simple field name into a full field name in OGNL syntax.

Parameters:
fieldName - the field name to lookup.
Returns:
the full field name in OGNL syntax.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidatorFactory (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Interface ValidatorFactory

All Known Implementing Classes:
DefaultValidatorFactory
public interface ValidatorFactory

ValidatorFactory

Validation rules are handled by validators, which must be registered with the ValidatorFactory (using the registerValidator method). The simplest way to do so is to add a file name validators.xml in the root of the classpath (/WEB-INF/classes) that declares all the validators you intend to use.

INFORMATION validators.xml if being defined should be available in the classpath. However this is not necessary, if no custom validator is needed. Predefined sets of validators will automatically be picked up when defined in com/opensymphony/xwork2/validator/validators/default.xml packaged in in the xwork jar file. See ValidatorFactory static block for details.

WARNING If custom validator is being defined and a validators.xml is created and place in the classpath, do remember to copy all the other pre-defined validators that is needed into the validators.xml as if not they will not be registered. Once a validators.xml is detected in the classpath, the default one (com/opensymphony/xwork2/validator/validators/default.xml) will not be loaded. It is only loaded when a custom validators.xml cannot be found in the classpath. Be careful.

Note: The default validationWorkflowStack already includes this.
All that is required to enable validation for an Action is to put the ValidationInterceptor in the interceptor refs of the action (see xwork.xml) like so:

     <interceptor name="validator" class="com.opensymphony.xwork2.validator.ValidationInterceptor"/>

Field Validators Field validators, as the name indicate, act on single fields accessible through an action. A validator, in contrast, is more generic and can do validations in the full action context, involving more than one field (or even no field at all) in validation rule. Most validations can be defined on per field basis. This should be preferred over non-field validation wherever possible, as field validator messages are bound to the related field and will be presented next to the corresponding input element in the respecting view.

Non Field Validators Non-field validators only add action level messages. Non-field validators are mostly domain specific and therefore offer custom implementations. The most important standard non-field validator provided by XWork is ExpressionValidator.

NOTE: Non-field validators takes precedence over field validators regardless of the order they are defined in *-validation.xml. If a non-field validator is short-circuited, it will causes its non-field validator to not being executed. See validation framework documentation for more info.

VALIDATION RULES: Validation rules can be specified:

  1. Per Action class: in a file named ActionName-validation.xml
  2. Per Action alias: in a file named ActionName-alias-validation.xml
  3. Inheritance hierarchy and interfaces implemented by Action class: XWork searches up the inheritance tree of the action to find default validations for parent classes of the Action and interfaces implemented
Here is an example for SimpleAction-validation.xml:

 <!DOCTYPE validators PUBLIC "-//OpenSymphony Group//XWork Validator 1.0.2//EN"
        "http://www.opensymphony.com/xwork/xwork-validator-1.0.2.dtd">
 <validators>
   <field name="bar">
       <field-validator type="required">
           <message>You must enter a value for bar.</message>
       </field-validator>
       <field-validator type="int">
           <param name="min">6</param>
           <param name="max">10</param>
           <message>bar must be between ${min} and ${max}, current value is ${bar}.</message>
       </field-validator>
   </field>
   <field name="bar2">
       <field-validator type="regex">
           <param name="expression">[0-9],[0-9]</param>
           <message>The value of bar2 must be in the format "x, y", where x and y are between 0 and 9</message>
      </field-validator>
   </field>
   <field name="date">
       <field-validator type="date">
           <param name="min">12/22/2002</param>
           <param name="max">12/25/2002</param>
           <message>The date must be between 12-22-2002 and 12-25-2002.</message>
       </field-validator>
   </field>
   <field name="foo">
       <field-validator type="int">
           <param name="min">0</param>
           <param name="max">100</param>
           <message key="foo.range">Could not find foo.range!</message>
       </field-validator>
   </field>
   <validator type="expression">
       <param name="expression">foo lt bar </param>
       <message>Foo must be greater than Bar. Foo = ${foo}, Bar = ${bar}.</message>
   </validator>
 </validators>

Here we can see the configuration of validators for the SimpleAction class. Validators (and field-validators) must have a type attribute, which refers to a name of an Validator registered with the ValidatorFactory as above. Validator elements may also have <param> elements with name and value attributes to set arbitrary parameters into the Validator instance. See below for discussion of the message element.

Each Validator or Field-Validator element must define one message element inside the validator element body. The message element has 1 attributes, key which is not required. The body of the message tag is taken as the default message which should be added to the Action if the validator fails. Key gives a message key to look up in the Action's ResourceBundles using getText() from LocaleAware if the Action implements that interface (as ActionSupport does). This provides for Localized messages based on the Locale of the user making the request (or whatever Locale you've set into the LocaleAware Action). After either retrieving the message from the ResourceBundle using the Key value, or using the Default message, the current Validator is pushed onto the ValueStack, then the message is parsed for \$\{...\} sections which are replaced with the evaluated value of the string between the \$\{ and \}. This allows you to parameterize your messages with values from the Validator, the Action, or both.

If the validator fails, the validator is pushed onto the ValueStack and the message - either the default or the locale-specific one if the key attribute is defined (and such a message exists) - is parsed for ${...} sections which are replaced with the evaluated value of the string between the ${ and }. This allows you to parameterize your messages with values from the validator, the Action, or both.

NOTE: Since validation rules are in an XML file, you must make sure you escape special characters. For example, notice that in the expression validator rule above we use "&gt;" instead of ">". Consult a resource on XML for the full list of characters that must be escaped. The most commonly used characters that must be escaped are: & (use &amp;), > (user &gt;), and < (use &lt;).

Here is an example of a parameterized message:

This will pull the min and max parameters from the IntRangeFieldValidator and the value of bar from the Action.

    bar must be between ${min} and ${max}, current value is ${bar}.

Another notable fact is that the provided message value is capable of containing OGNL expressions. Keeping this in mind, it is possible to construct quite sophisticated messages.

See the following example to get an impression:

    ${getText("validation.failednotice")}! ${getText("reason")}: ${getText("validation.inputrequired")}

Version:
$Date$ $Id$
Author:
Jason Carreira, James House

Method Summary
Validator | getValidator(ValidatorConfig cfg) Get a Validator that matches the given configuration.
String | lookupRegisteredValidatorType(String name) Lookup to get the FQ classname of the given validator name.
void | registerValidator(String name, String className) Registers the given validator to the existing map of validators.

Method Detail

getValidator

Validator getValidator(ValidatorConfig cfg)
Get a Validator that matches the given configuration.

Parameters:
cfg - the configurator.
Returns:
the validator.

registerValidator

void registerValidator(String name,
                       String className)
Registers the given validator to the existing map of validators. This will add to the existing list.

Parameters:
name - name of validator to add.
className - the FQ classname of the validator.

lookupRegisteredValidatorType

String lookupRegisteredValidatorType(String name)
Lookup to get the FQ classname of the given validator name.

Parameters:
name - name of validator to lookup.
Returns:
the found FQ classname
Throws:
IllegalArgumentException - is thrown if the name is not found.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidatorFileParser (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Interface ValidatorFileParser

All Known Implementing Classes:
DefaultValidatorFileParser
public interface ValidatorFileParser

This class serves 2 purpose :

  • Parse the validation config file. (eg. MyAction-validation.xml, MyAction-actionAlias-validation.xml) to return a List of ValidatorConfig encapsulating the validator information.
  • Parse the validator definition file, (eg. validators.xml) that defines the Validators registered with XWork.

Author:
Jason Carreira, James House, tm_jee ( tm_jee (at) yahoo.co.uk ), Rob Harrop, Rene Gielen
See Also:
ValidatorConfig

Method Summary
List<ValidatorConfig> | parseActionValidatorConfigs(ValidatorFactory validatorFactory, InputStream is, String resourceName) Parse resource for a list of ValidatorConfig objects (configuring which validator(s) are being applied to a particular field etc.)
void | parseValidatorDefinitions(Map<String,String> validators, InputStream is, String resourceName) Parses validator definitions (register various validators with XWork).

Method Detail

parseActionValidatorConfigs

List<ValidatorConfig> parseActionValidatorConfigs(ValidatorFactory validatorFactory,
                                                  InputStream is,
                                                  String resourceName)
Parse resource for a list of ValidatorConfig objects (configuring which validator(s) are being applied to a particular field etc.)

Parameters:
is - input stream to the resource
resourceName - file name of the resource
Returns:
List list of ValidatorConfig

parseValidatorDefinitions

void parseValidatorDefinitions(Map<String,String> validators,
                               InputStream is,
                               String resourceName)
Parses validator definitions (register various validators with XWork).

Parameters:
is - The input stream
resourceName - The location of the input stream
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ConditionalVisitorFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type ConditionalVisitorFieldValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface ConditionalVisitorFieldValidator

The validator allows you to forward validator to object properties of your action using the objects own validator files. This allows you to use the ModelDriven development pattern and manage your validations for your models in one place, where they belong, next to your model classes. The ConditionalVisitorFieldValidator can handle either simple Object properties, Collections of Objects, or Arrays. The error message for the ConditionalVisitorFieldValidator will be appended in front of validator messages added by the validations for the Object message.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
expression | yes |  | Boolean conditional expression
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
context | no | action alias | Determines the context to use for validating the Object property. If not defined, the context of the Action validation is propogated to the Object property validation. In the case of Action validation, this context is the Action alias.
appendPrefix | no | true | Determines whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs. For example, suppose that the bean being validated has a "name" property. If appendPrefix is true, then the field error will be stored under the field "bean.name". If appendPrefix is false, then the field error will be stored under the field "name". If you are using the VisitorFieldValidator to validate the model from a ModelDriven Action, you should set appendPrefix to false unless you are using "model.name" to reference the properties on your model.

Example code:

 @ConditionalVisitorFieldValidator(expression="app.appid > 100",  message = "Default message", key = "i18n.key", shortCircuit = true, context = "action alias", appendPrefix = true)

Author:
Matt Raible

Required Element Summary
 String expression
The conditional expression.
Optional Element Summary
boolean | appendPrefix Determines whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs.
String | context Determines the context to use for validating the Object property.
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
String | message The default error message for this validator.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.

Element Detail

expression

public abstract String expression
The conditional expression.

context

public abstract String context
Determines the context to use for validating the Object property. If not defined, the context of the Action validator is propogated to the Object property validator. In the case of Action validator, this context is the Action alias.

Default:
""

appendPrefix

public abstract boolean appendPrefix
Determines whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs. For example, suppose that the bean being validated has a "name" property. If appendPrefix is true, then the field error will be stored under the field "bean.name". If appendPrefix is false, then the field error will be stored under the field "name". If you are using the ConditionalVisitorFieldValidator to validate the model from a ModelDriven Action, you should set appendPrefix to false unless you are using "model.name" to reference the properties on your model.

Default:
true

message

public abstract String message
The default error message for this validator. NOTE: It is required to set a message, if you are not using the message key for 18n lookup!

Default:
""

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT


ConversionErrorFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type ConversionErrorFieldValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface ConversionErrorFieldValidator

This validator checks if there are any conversion errors for a field and applies them if they exist. See Type Conversion Error Handling for details.

Annotation usage:

The ConversionErrorFieldValidator annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.

Example code:

 @ConversionErrorFieldValidator(message = "Default message", key = "i18n.key", shortCircuit = true)

Version:
$Id: ConversionErrorFieldValidator.java 1834 2008-06-21 12:09:59Z rainerh $
Author:
Rainer Hermanns

Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
String | message The default error message for this validator.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
ValidatorType | type The validation type for this field/method.

message

public abstract String message
The default error message for this validator. NOTE: It is required to set a message, if you are not using the message key for 18n lookup!

Default:
""

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType type
The validation type for this field/method.

Default:
com.opensymphony.xwork2.validator.annotations.ValidatorType.FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


CustomValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type CustomValidator

@Target(value={METHOD,TYPE})
@Retention(value=RUNTIME)
public @interface CustomValidator

This annotation can be used for custom validators. Use the ValidationParameter annotation to supply additional params.

Annotation usage:

The annotation must be applied at method or type level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.

Example code:

 @CustomValidator(type ="customValidatorName", fieldName = "myField")

Version:
$Id: CustomValidator.java 1834 2008-06-21 12:09:59Z rainerh $
Author:
jepjep, Rainer Hermanns

Required Element Summary
 String type
Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key
String | message The default error message for this validator.
ValidationParameter[] | parameters
boolean | shortCircuit

Element Detail

type

public abstract String type

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

message

public abstract String message
The default error message for this validator. NOTE: It is required to set a message, if you are not using the message key for 18n lookup!

Default:
""

key

public abstract String key
Default:
""

parameters

public abstract ValidationParameter[] parameters
Default:
{}

shortCircuit

public abstract boolean shortCircuit
Default:
false
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


DateRangeFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type DateRangeFieldValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface DateRangeFieldValidator

This validator checks that a date field has a value within a specified range.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.
min | no |  | Date property. The minimum the date must be.
max | no |  | Date property. The maximum date can be.

If neither min nor max is set, nothing will be done.

Example code:

 @DateRangeFieldValidator(message = "Default message", key = "i18n.key", shortCircuit = true, min = "2005/01/01", max = "2005/12/31")

Version:
$Id: DateRangeFieldValidator.java 1834 2008-06-21 12:09:59Z rainerh $
Author:
Rainer Hermanns

Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
String | max Date property.
String | message The default error message for this validator.
String | min Date property.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
ValidatorType | type The validation type for this field/method.

min

public abstract String min
Date property. The minimum the date must be.

Default:
""

max

public abstract String max
Date property. The maximum date can be.

Default:
""

message

public abstract String message
The default error message for this validator. NOTE: It is required to set a message, if you are not using the message key for 18n lookup!

Default:
""

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType type
The validation type for this field/method.

Default:
com.opensymphony.xwork2.validator.annotations.ValidatorType.FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


DoubleRangeFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type DoubleRangeFieldValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface DoubleRangeFieldValidator

This validator checks that a double field has a value within a specified range. If neither min nor max is set, nothing will be done.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.
minInclusive | no |  | Double property. The inclusive minimum the number must be.
maxInclusive | no |  | Double property. The inclusive maximum number can be.
minExclusive | no |  | Double property. The exclusive minimum the number must be.
maxExclusive | no |  | Double property. The exclusive maximum number can be.

If neither min nor max is set, nothing will be done.

The values for min and max must be inserted as String values so that "0" can be handled as a possible value.

Example code:

 @DoubleRangeFieldValidator(message = "Default message", key = "i18n.key", shortCircuit = true, minInclusive = "0.123", maxInclusive = "99.987")

Version:
$Id: DoubleRangeFieldValidator.java 1834 2008-06-21 12:09:59Z rainerh $
Author:
Rainer Hermanns

Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
String | maxExclusive Double property.
String | maxInclusive Double property.
String | message The default error message for this validator.
String | minExclusive Double property.
String | minInclusive Double property.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
ValidatorType | type The validation type for this field/method.

minInclusive

public abstract String minInclusive
Double property. The inclusive minimum the number must be.

Default:
""

maxInclusive

public abstract String maxInclusive
Double property. The inclusive minimum the number must be.

Default:
""

minExclusive

public abstract String minExclusive
Double property. The exclusive maximum number can be.

Default:
""

maxExclusive

public abstract String maxExclusive
Double property. The exclusive maximum number can be.

Default:
""

message

public abstract String message
The default error message for this validator. NOTE: It is required to set a message, if you are not using the message key for 18n lookup!

Default:
""

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType type
The validation type for this field/method.

Default:
com.opensymphony.xwork2.validator.annotations.ValidatorType.FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


EmailValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type EmailValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface EmailValidator

This validator checks that a field is a valid e-mail address if it contains a non-empty String.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.

Example code:

 @EmailValidator(message = "Default message", key = "i18n.key", shortCircuit = true)

Version:
$Id: EmailValidator.java 1834 2008-06-21 12:09:59Z rainerh $
Author:
Rainer Hermanns

Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
String | message The default error message for this validator.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
ValidatorType | type The validation type for this field/method.

message

public abstract String message
The default error message for this validator. NOTE: It is required to set a message, if you are not using the message key for 18n lookup!

Default:
""

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType type
The validation type for this field/method.

Default:
com.opensymphony.xwork2.validator.annotations.ValidatorType.FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


ExpressionValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type ExpressionValidator

@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface ExpressionValidator

This non-field level validator validates a supplied regular expression.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
shortCircuit | no | false | If this validator should be used as shortCircuit.
expression | yes |  | An OGNL expression that returns a boolean value.

Example code:

 @ExpressionValidator(message = "Default message", key = "i18n.key", shortCircuit = true, expression = "an OGNL expression" )

Version:
$Id: ExpressionValidator.java 1834 2008-06-21 12:09:59Z rainerh $
Author:
Rainer Hermanns

Required Element Summary
 String expression
The expressions to validate.
Optional Element Summary
String | key The message key to lookup for i18n.
String | message The default error message for this validator.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.

Element Detail

expression

public abstract String expression
The expressions to validate. An OGNL expression that returns a boolean value.

message

public abstract String message
The default error message for this validator. NOTE: It is required to set a message, if you are not using the message key for 18n lookup!

Default:
""

key

public abstract String key
The message key to lookup for i18n.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


FieldExpressionValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type FieldExpressionValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface FieldExpressionValidator

This validator uses an OGNL expression to perform its validator. The error message will be added to the field if the expression returns false when it is evaluated against the value stack.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
expression | yes |  | An OGNL expression that returns a boolean value.

Example code:

 @FieldExpressionValidator(message = "Default message", key = "i18n.key", shortCircuit = true, expression = "an OGNL expression")

Version:
$Id: FieldExpressionValidator.java 1834 2008-06-21 12:09:59Z rainerh $
Author:
Rainer Hermanns

Required Element Summary
 String expression
An OGNL expression that returns a boolean value.
Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
String | message The default error message for this validator.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.

Element Detail

expression

public abstract String expression
An OGNL expression that returns a boolean value.

message

public abstract String message
The default error message for this validator. NOTE: It is required to set a message, if you are not using the message key for 18n lookup!

Default:
""

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


IntRangeFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type IntRangeFieldValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface IntRangeFieldValidator

This validator checks that a numeric field has a value within a specified range. If neither min nor max is set, nothing will be done.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.
min | no |  | Integer property. The minimum the number must be.
max | no |  | Integer property. The maximum number can be.

If neither min nor max is set, nothing will be done.

The values for min and max must be inserted as String values so that "0" can be handled as a possible value.

Example code:

 @IntRangeFieldValidator(message = "Default message", key = "i18n.key", shortCircuit = true, min = "0", max = "42")

Version:
$Id: IntRangeFieldValidator.java 1834 2008-06-21 12:09:59Z rainerh $
Author:
Rainer Hermanns

Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
String | max Integer property.
String | message The default error message for this validator.
String | min Integer property.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
ValidatorType | type The validation type for this field/method.

min

public abstract String min
Integer property. The minimum the number must be.

Default:
""

max

public abstract String max
Integer property. The maximum number can be.

Default:
""

message

public abstract String message
The default error message for this validator. NOTE: It is required to set a message, if you are not using the message key for 18n lookup!

Default:
""

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType type
The validation type for this field/method.

Default:
com.opensymphony.xwork2.validator.annotations.ValidatorType.FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


com.opensymphony.xwork2.validator.annotations (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.validator.annotations
Enums
ValidatorType
Annotation Types
ConditionalVisitorFieldValidator
ConversionErrorFieldValidator
CustomValidator
DateRangeFieldValidator
DoubleRangeFieldValidator
EmailValidator
ExpressionValidator
FieldExpressionValidator
IntRangeFieldValidator
RegexFieldValidator
RequiredFieldValidator
RequiredStringValidator
StringLengthFieldValidator
UrlValidator
Validation
ValidationParameter
Validations
VisitorFieldValidator


com.opensymphony.xwork2.validator.annotations (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.validator.annotations

Validator annotations.

See:
Description

Enum Summary
ValidatorType ValidatorType

Annotation Types Summary
ConditionalVisitorFieldValidator | The validator allows you to forward validator to object properties of your action using the objects own validator files.
ConversionErrorFieldValidator | This validator checks if there are any conversion errors for a field and applies them if they exist.
CustomValidator | This annotation can be used for custom validators.
DateRangeFieldValidator | This validator checks that a date field has a value within a specified range.
DoubleRangeFieldValidator | This validator checks that a double field has a value within a specified range.
EmailValidator | This validator checks that a field is a valid e-mail address if it contains a non-empty String.
ExpressionValidator | This non-field level validator validates a supplied regular expression.
FieldExpressionValidator | This validator uses an OGNL expression to perform its validator.
IntRangeFieldValidator | This validator checks that a numeric field has a value within a specified range.
RegexFieldValidator | Validates a string field using a regular expression.
RequiredFieldValidator | This validator checks that a field is non-null.
RequiredStringValidator | This validator checks that a String field is not empty (i.e.
StringLengthFieldValidator | This validator checks that a String field is of the right length.
UrlValidator | This validator checks that a field is a valid URL.
Validation | Deprecated. Since Struts 2.1 because it isn't necessary anymore
ValidationParameter | The ValidationParameter annotation is used as a parameter for CustomValidators.
Validations |
VisitorFieldValidator | The validator allows you to forward validator to object properties of your action using the objects own validator files.

Package com.opensymphony.xwork2.validator.annotations Description

Validator annotations.


com.opensymphony.xwork2.validator.annotations Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.validator.annotations

Package Hierarchies:
All Packages

Annotation Type Hierarchy

  • com.opensymphony.xwork2.validator.annotations.VisitorFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.Validations (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.ValidationParameter (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.Validation (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.UrlValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.StringLengthFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.RequiredStringValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.RequiredFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.RegexFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.IntRangeFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.FieldExpressionValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.ExpressionValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.EmailValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.DoubleRangeFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.DateRangeFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.CustomValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.ConversionErrorFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.ConditionalVisitorFieldValidator (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.opensymphony.xwork2.validator.annotations.ValidatorType


Uses of Package com.opensymphony.xwork2.validator.annotations (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.validator.annotations

Packages that use com.opensymphony.xwork2.validator.annotations
com.opensymphony.xwork2.validator.annotations Validator annotations.

Classes in com.opensymphony.xwork2.validator.annotations used by com.opensymphony.xwork2.validator.annotations
ValidatorType
ValidatorType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


RegexFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type RegexFieldValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface RegexFieldValidator

Validates a string field using a regular expression.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.
expression | yes |  | The regex to validate the field value against.

Example code:

 @RegexFieldValidator( key = "regex.field", expression = "yourregexp")

Version:
$Id: RegexFieldValidator.java 1834 2008-06-21 12:09:59Z rainerh $
Author:
Rainer Hermanns

Required Element Summary
 String expression
Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
String | message The default error message for this validator.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
ValidatorType | type The validation type for this field/method.

Element Detail

expression

public abstract String expression

message

public abstract String message
The default error message for this validator. NOTE: It is required to set a message, if you are not using the message key for 18n lookup!

Default:
""

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType type
The validation type for this field/method.

Default:
com.opensymphony.xwork2.validator.annotations.ValidatorType.FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


RequiredFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type RequiredFieldValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface RequiredFieldValidator

This validator checks that a field is non-null.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.

Example code:

 @RequiredFieldValidator(message = "Default message", key = "i18n.key", shortCircuit = true)

Version:
$Id: RequiredFieldValidator.java 1834 2008-06-21 12:09:59Z rainerh $
Author:
Rainer Hermanns

Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
String | message The default error message for this validator.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
ValidatorType | type The validation type for this field/method.

message

public abstract String message
The default error message for this validator. NOTE: It is required to set a message, if you are not using the message key for 18n lookup!

Default:
""

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType type
The validation type for this field/method.

Default:
com.opensymphony.xwork2.validator.annotations.ValidatorType.FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


RequiredStringValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type RequiredStringValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface RequiredStringValidator

This validator checks that a String field is not empty (i.e. non-null with a length > 0).

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.
trim | no | true | Boolean property. Determines whether the String is trimmed before performing the length check.

Example code:

 @RequiredStringValidator(message = "Default message", key = "i18n.key", shortCircuit = true, trim = true)

Version:
$Id: RequiredStringValidator.java 1834 2008-06-21 12:09:59Z rainerh $
Author:
Rainer Hermanns

Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
String | message The default error message for this validator.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
boolean | trim Boolean property.
ValidatorType | type The validation type for this field/method.

trim

public abstract boolean trim
Boolean property. Determines whether the String is trimmed before performing the length check.

Default:
true

message

public abstract String message
The default error message for this validator. NOTE: It is required to set a message, if you are not using the message key for 18n lookup!

Default:
""

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType type
The validation type for this field/method.

Default:
com.opensymphony.xwork2.validator.annotations.ValidatorType.FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


StringLengthFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type StringLengthFieldValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface StringLengthFieldValidator

This validator checks that a String field is of the right length. It assumes that the field is a String. If neither minLength nor maxLength is set, nothing will be done.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.
trim | no | true | Boolean property. Determines whether the String is trimmed before performing the length check.
minLength | no |  | Integer property. The minimum length the String must be.
maxLength | no |  | Integer property. The maximum length the String can be.

If neither minLength nor maxLength is set, nothing will be done.

Example code:

 @StringLengthFieldValidator(message = "Default message", key = "i18n.key", shortCircuit = true, trim = true, minLength = "5",  maxLength = "12")

Version:
$Id: StringLengthFieldValidator.java 1834 2008-06-21 12:09:59Z rainerh $
Author:
Rainer Hermanns

Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
String | maxLength Integer property.
String | message The default error message for this validator.
String | minLength Integer property.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
boolean | trim Boolean property.
ValidatorType[] | type The validation type for this field/method.

trim

public abstract boolean trim
Boolean property. Determines whether the String is trimmed before performing the length check.

Default:
true

minLength

public abstract String minLength
Integer property. The minimum length the String must be.

Default:
""

maxLength

public abstract String maxLength
Integer property. The maximum length the String can be.

Default:
""

message

public abstract String message
The default error message for this validator. NOTE: It is required to set a message, if you are not using the message key for 18n lookup!

Default:
""

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType[] type
The validation type for this field/method.

Default:
com.opensymphony.xwork2.validator.annotations.ValidatorType.FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


UrlValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type UrlValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface UrlValidator

This validator checks that a field is a valid URL.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.

Example code:

 @UrlValidator(message = "Default message", key = "i18n.key", shortCircuit = true)

Version:
$Id: UrlValidator.java 1834 2008-06-21 12:09:59Z rainerh $
Author:
Rainer Hermanns

Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
String | message The default error message for this validator.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
ValidatorType | type The validation type for this field/method.

message

public abstract String message
The default error message for this validator. NOTE: It is required to set a message, if you are not using the message key for 18n lookup!

Default:
""

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType type
The validation type for this field/method.

Default:
com.opensymphony.xwork2.validator.annotations.ValidatorType.FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


Validation (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type Validation

Deprecated. Since Struts 2.1 because it isn't necessary anymore

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Validation

This annotation has been deprecated since 2.1 as its previous purpose, to define classes that support annotation validations, is no longer necessary.

Annotation usage:

The Validation annotation must be applied at Type level.

Annotation parameters:

Parameter | Required | Default | Notes
validations | yes |  |

Example code: An Annotated Interface

 @Validation()
 public interface AnnotationDataAware {

     void setBarObj(Bar b);

     Bar getBarObj();

     @RequiredFieldValidator(message = "You must enter a value for data.")
     @RequiredStringValidator(message = "You must enter a value for data.")
     void setData(String data);

     String getData();
 }

Example code: An Annotated Class

 @Validation()
 public class SimpleAnnotationAction extends ActionSupport {

     @RequiredFieldValidator(type = ValidatorType.FIELD, message = "You must enter a value for bar.")
     @IntRangeFieldValidator(type = ValidatorType.FIELD, min = "6", max = "10", message = "bar must be between ${min} and ${max}, current value is ${bar}.")
     public void setBar(int bar) {
         this.bar = bar;
     }

     public int getBar() {
         return bar;
     }

     @Validations(
             requiredFields =
                     {@RequiredFieldValidator(type = ValidatorType.SIMPLE, fieldName = "customfield", message = "You must enter a value for field.")},
             requiredStrings =
                     {@RequiredStringValidator(type = ValidatorType.SIMPLE, fieldName = "stringisrequired", message = "You must enter a value for string.")},
             emails =
                     { @EmailValidator(type = ValidatorType.SIMPLE, fieldName = "emailaddress", message = "You must enter a value for email.")},
             urls =
                     { @UrlValidator(type = ValidatorType.SIMPLE, fieldName = "hreflocation", message = "You must enter a value for email.")},
             stringLengthFields =
                     {@StringLengthFieldValidator(type = ValidatorType.SIMPLE, trim = true, minLength="10" , maxLength = "12", fieldName = "needstringlength", message = "You must enter a stringlength.")},
             intRangeFields =
                     { @IntRangeFieldValidator(type = ValidatorType.SIMPLE, fieldName = "intfield", min = "6", max = "10", message = "bar must be between ${min} and ${max}, current value is ${bar}.")},
             dateRangeFields =
                     {@DateRangeFieldValidator(type = ValidatorType.SIMPLE, fieldName = "datefield", min = "-1", max = "99", message = "bar must be between ${min} and ${max}, current value is ${bar}.")},
             expressions = {
                 @ExpressionValidator(expression = "foo > 1", message = "Foo must be greater than Bar 1. Foo = ${foo}, Bar = ${bar}."),
                 @ExpressionValidator(expression = "foo > 2", message = "Foo must be greater than Bar 2. Foo = ${foo}, Bar = ${bar}."),
                 @ExpressionValidator(expression = "foo > 3", message = "Foo must be greater than Bar 3. Foo = ${foo}, Bar = ${bar}."),
                 @ExpressionValidator(expression = "foo > 4", message = "Foo must be greater than Bar 4. Foo = ${foo}, Bar = ${bar}."),
                 @ExpressionValidator(expression = "foo > 5", message = "Foo must be greater than Bar 5. Foo = ${foo}, Bar = ${bar}.")
     }
     )
     public String execute() throws Exception {
         return SUCCESS;
     }
 }

Version:
$Id: Validation.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns

Optional Element Summary
 Validations[] validations
Deprecated. Used for class or interface validation rules.

validations

public abstract Validations[] validations
Deprecated.
Used for class or interface validation rules.

Default:
{}
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


ValidationParameter (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type ValidationParameter

@Target(value={METHOD,TYPE})
@Retention(value=RUNTIME)
public @interface ValidationParameter

The ValidationParameter annotation is used as a parameter for CustomValidators.

Annotation usage:

The annotation must embedded into CustomValidator annotations as a parameter.

Annotation parameters:

Parameter | Required | Default | Notes
name | yes |  | parameter name.
value | yes |  | parameter value.

Example code:

 @CustomValidator(
   type ="customValidatorName",
   fieldName = "myField",
   parameters = { @ValidationParameter( name = "paramName", value = "paramValue" ) }
 )

Author:
jepjep, Rainer Hermanns

Required Element Summary
String | name
String | value

Element Detail

name

public abstract String name

value

public abstract String value
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


Validations (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type Validations

@Target(value={METHOD,TYPE})
@Retention(value=RUNTIME)
public @interface Validations

If you want to use several annotations of the same type, these annotations must be nested within the @Validations() annotation.

Annotation usage:

Used at METHOD level.

Annotation parameters:

Parameter | Required | Notes
requiredFields | no | Add list of RequiredFieldValidators
customValidators | no | Add list of CustomValidators
conversionErrorFields | no | Add list of ConversionErrorFieldValidators
dateRangeFields | no | Add list of DateRangeFieldValidators
emails | no | Add list of EmailValidators
fieldExpressions | no | Add list of FieldExpressionValidators
intRangeFields | no | Add list of IntRangeFieldValidators
requiredStrings | no | Add list of RequiredStringValidators
stringLengthFields | no | Add list of StringLengthFieldValidators
urls | no | Add list of UrlValidators
visitorFields | no | Add list of VisitorFieldValidators
regexFields | no | Add list of RegexFieldValidator
expressions | no | Add list of ExpressionValidator

Example code:

 @Validations(
           requiredFields =
                   {@RequiredFieldValidator(type = ValidatorType.SIMPLE, fieldName = "customfield", message = "You must enter a value for field.")},
           requiredStrings =
                   {@RequiredStringValidator(type = ValidatorType.SIMPLE, fieldName = "stringisrequired", message = "You must enter a value for string.")},
           emails =
                   { @EmailValidator(type = ValidatorType.SIMPLE, fieldName = "emailaddress", message = "You must enter a value for email.")},
           urls =
                   { @UrlValidator(type = ValidatorType.SIMPLE, fieldName = "hreflocation", message = "You must enter a value for email.")},
           stringLengthFields =
                   {@StringLengthFieldValidator(type = ValidatorType.SIMPLE, trim = true, minLength="10" , maxLength = "12", fieldName = "needstringlength", message = "You must enter a stringlength.")},
           intRangeFields =
                   { @IntRangeFieldValidator(type = ValidatorType.SIMPLE, fieldName = "intfield", min = "6", max = "10", message = "bar must be between ${min} and ${max}, current value is ${bar}.")},
           dateRangeFields =
                   {@DateRangeFieldValidator(type = ValidatorType.SIMPLE, fieldName = "datefield", min = "-1", max = "99", message = "bar must be between ${min} and ${max}, current value is ${bar}.")},
           expressions = {
               @ExpressionValidator(expression = "foo > 1", message = "Foo must be greater than Bar 1. Foo = ${foo}, Bar = ${bar}."),
               @ExpressionValidator(expression = "foo > 2", message = "Foo must be greater than Bar 2. Foo = ${foo}, Bar = ${bar}."),
               @ExpressionValidator(expression = "foo > 3", message = "Foo must be greater than Bar 3. Foo = ${foo}, Bar = ${bar}."),
               @ExpressionValidator(expression = "foo > 4", message = "Foo must be greater than Bar 4. Foo = ${foo}, Bar = ${bar}."),
               @ExpressionValidator(expression = "foo > 5", message = "Foo must be greater than Bar 5. Foo = ${foo}, Bar = ${bar}.")
   }
   )
   public String execute() throws Exception {
       return SUCCESS;
   }

Version:
$Id: Validations.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
jepjep, Rainer Hermanns

Optional Element Summary
ConditionalVisitorFieldValidator[] | conditionalVisitorFields
ConversionErrorFieldValidator[] | conversionErrorFields
CustomValidator[] | customValidators Custom Validation rules.
DateRangeFieldValidator[] | dateRangeFields
EmailValidator[] | emails
ExpressionValidator[] | expressions
FieldExpressionValidator[] | fieldExpressions
IntRangeFieldValidator[] | intRangeFields
RegexFieldValidator[] | regexFields
RequiredFieldValidator[] | requiredFields
RequiredStringValidator[] | requiredStrings
StringLengthFieldValidator[] | stringLengthFields
UrlValidator[] | urls
VisitorFieldValidator[] | visitorFields

customValidators

public abstract CustomValidator[] customValidators
Custom Validation rules.

Default:
{}

conversionErrorFields

public abstract ConversionErrorFieldValidator[] conversionErrorFields
Default:
{}

dateRangeFields

public abstract DateRangeFieldValidator[] dateRangeFields
Default:
{}

emails

public abstract EmailValidator[] emails
Default:
{}

fieldExpressions

public abstract FieldExpressionValidator[] fieldExpressions
Default:
{}

intRangeFields

public abstract IntRangeFieldValidator[] intRangeFields
Default:
{}

requiredFields

public abstract RequiredFieldValidator[] requiredFields
Default:
{}

requiredStrings

public abstract RequiredStringValidator[] requiredStrings
Default:
{}

stringLengthFields

public abstract StringLengthFieldValidator[] stringLengthFields
Default:
{}

urls

public abstract UrlValidator[] urls
Default:
{}

conditionalVisitorFields

public abstract ConditionalVisitorFieldValidator[] conditionalVisitorFields
Default:
{}

visitorFields

public abstract VisitorFieldValidator[] visitorFields
Default:
{}

regexFields

public abstract RegexFieldValidator[] regexFields
Default:
{}

expressions

public abstract ExpressionValidator[] expressions
Default:
{}
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


ValidatorType (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.opensymphony.xwork2.validator.annotations
Enum ValidatorType

java.lang.Object
    extended by  java.lang.Enum<ValidatorType>
        extended by  com.opensymphony.xwork2.validator.annotations.ValidatorType
All Implemented Interfaces:
Serializable, Comparable<ValidatorType>
public enum ValidatorType
extends Enum<ValidatorType>

ValidatorType

Version:
$Id: ValidatorType.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Enum Constant Summary
FIELD
SIMPLE
Method Summary
String | toString()
static ValidatorType | valueOf(String name) Returns the enum constant of this type with the specified name.
static ValidatorType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

FIELD

public static final ValidatorType FIELD

SIMPLE

public static final ValidatorType SIMPLE
Method Detail

values

public static ValidatorType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (ValidatorType c : ValidatorType.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static ValidatorType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
NullPointerException - if the argument is null

toString

public String toString()
Overrides:
toString in class Enum<ValidatorType>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


VisitorFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type VisitorFieldValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface VisitorFieldValidator

The validator allows you to forward validator to object properties of your action using the objects own validator files. This allows you to use the ModelDriven development pattern and manage your validations for your models in one place, where they belong, next to your model classes. The VisitorFieldValidator can handle either simple Object properties, Collections of Objects, or Arrays. The error message for the VisitorFieldValidator will be appended in front of validator messages added by the validations for the Object message.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
context | no | action alias | Determines the context to use for validating the Object property. If not defined, the context of the Action validation is propogated to the Object property validation. In the case of Action validation, this context is the Action alias.
appendPrefix | no | true | Determines whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs. For example, suppose that the bean being validated has a "name" property. If appendPrefix is true, then the field error will be stored under the field "bean.name". If appendPrefix is false, then the field error will be stored under the field "name". If you are using the VisitorFieldValidator to validate the model from a ModelDriven Action, you should set appendPrefix to false unless you are using "model.name" to reference the properties on your model.

Example code:

 @VisitorFieldValidator(message = "Default message", key = "i18n.key", shortCircuit = true, context = "action alias", appendPrefix = true)

Version:
$Id: VisitorFieldValidator.java 1834 2008-06-21 12:09:59Z rainerh $
Author:
Rainer Hermanns

Optional Element Summary
boolean | appendPrefix Determines whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs.
String | context Determines the context to use for validating the Object property.
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
String | message The default error message for this validator.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.

context

public abstract String context
Determines the context to use for validating the Object property. If not defined, the context of the Action validator is propogated to the Object property validator. In the case of Action validator, this context is the Action alias.

Default:
""

appendPrefix

public abstract boolean appendPrefix
Determines whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs. For example, suppose that the bean being validated has a "name" property. If appendPrefix is true, then the field error will be stored under the field "bean.name". If appendPrefix is false, then the field error will be stored under the field "name". If you are using the VisitorFieldValidator to validate the model from a ModelDriven Action, you should set appendPrefix to false unless you are using "model.name" to reference the properties on your model.

Default:
true

message

public abstract String message
The default error message for this validator. NOTE: It is required to set a message, if you are not using the message key for 18n lookup!

Default:
""

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT


Uses of Class com.opensymphony.xwork2.validator.annotations.ConditionalVisitorFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.ConditionalVisitorFieldValidator

No usage of com.opensymphony.xwork2.validator.annotations.ConditionalVisitorFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.ConversionErrorFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.ConversionErrorFieldValidator

No usage of com.opensymphony.xwork2.validator.annotations.ConversionErrorFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.CustomValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.CustomValidator

No usage of com.opensymphony.xwork2.validator.annotations.CustomValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.DateRangeFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.DateRangeFieldValidator

No usage of com.opensymphony.xwork2.validator.annotations.DateRangeFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.DoubleRangeFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.DoubleRangeFieldValidator

No usage of com.opensymphony.xwork2.validator.annotations.DoubleRangeFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.EmailValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.EmailValidator

No usage of com.opensymphony.xwork2.validator.annotations.EmailValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.ExpressionValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.ExpressionValidator

No usage of com.opensymphony.xwork2.validator.annotations.ExpressionValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.FieldExpressionValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.FieldExpressionValidator

No usage of com.opensymphony.xwork2.validator.annotations.FieldExpressionValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.IntRangeFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.IntRangeFieldValidator

No usage of com.opensymphony.xwork2.validator.annotations.IntRangeFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.RegexFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.RegexFieldValidator

No usage of com.opensymphony.xwork2.validator.annotations.RegexFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.RequiredFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.RequiredFieldValidator

No usage of com.opensymphony.xwork2.validator.annotations.RequiredFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.RequiredStringValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.RequiredStringValidator

No usage of com.opensymphony.xwork2.validator.annotations.RequiredStringValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.StringLengthFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.StringLengthFieldValidator

No usage of com.opensymphony.xwork2.validator.annotations.StringLengthFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.UrlValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.UrlValidator

No usage of com.opensymphony.xwork2.validator.annotations.UrlValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.Validation (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.Validation

No usage of com.opensymphony.xwork2.validator.annotations.Validation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.ValidationParameter (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.ValidationParameter

No usage of com.opensymphony.xwork2.validator.annotations.ValidationParameter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.Validations (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.Validations

No usage of com.opensymphony.xwork2.validator.annotations.Validations

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.ValidatorType (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.ValidatorType

Packages that use ValidatorType
com.opensymphony.xwork2.validator.annotations Validator annotations.

Uses of ValidatorType in com.opensymphony.xwork2.validator.annotations

Methods in com.opensymphony.xwork2.validator.annotations that return ValidatorType
static ValidatorType | ValidatorType.valueOf(String name) Returns the enum constant of this type with the specified name.
static ValidatorType[] | ValidatorType.values() Returns an array containing the constants of this enum type, in the order they are declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.VisitorFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.VisitorFieldValidator

No usage of com.opensymphony.xwork2.validator.annotations.VisitorFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.validator.ActionValidatorManager (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.validator.ActionValidatorManager

Packages that use ActionValidatorManager
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Uses of ActionValidatorManager in com.opensymphony.xwork2.validator

Classes in com.opensymphony.xwork2.validator that implement ActionValidatorManager
class | AnnotationActionValidatorManager AnnotationActionValidatorManager is the entry point into XWork's annotations-based validator framework.
class | DefaultActionValidatorManager This is the entry point into XWork's rule-based validation framework.

Methods in com.opensymphony.xwork2.validator with parameters of type ActionValidatorManager
 void ValidationInterceptor.setActionValidatorManager(ActionValidatorManager mgr)

Uses of ActionValidatorManager in com.opensymphony.xwork2.validator.validators

Methods in com.opensymphony.xwork2.validator.validators with parameters of type ActionValidatorManager
 void VisitorFieldValidator.setActionValidatorManager(ActionValidatorManager mgr)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.AnnotationActionValidatorManager

No usage of com.opensymphony.xwork2.validator.AnnotationActionValidatorManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager.InternalValidatorContextWrapper (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.AnnotationActionValidatorManager.InternalValidatorContextWrapper

No usage of com.opensymphony.xwork2.validator.AnnotationActionValidatorManager.InternalValidatorContextWrapper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

No usage of com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.DefaultActionValidatorManager (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.DefaultActionValidatorManager

No usage of com.opensymphony.xwork2.validator.DefaultActionValidatorManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.DefaultActionValidatorManager.InternalValidatorContextWrapper (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.DefaultActionValidatorManager.InternalValidatorContextWrapper

No usage of com.opensymphony.xwork2.validator.DefaultActionValidatorManager.InternalValidatorContextWrapper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.DefaultValidatorFactory (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.DefaultValidatorFactory

No usage of com.opensymphony.xwork2.validator.DefaultValidatorFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.DefaultValidatorFileParser (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.DefaultValidatorFileParser

No usage of com.opensymphony.xwork2.validator.DefaultValidatorFileParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.DelegatingValidatorContext (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.DelegatingValidatorContext

Packages that use DelegatingValidatorContext
com.opensymphony.xwork2.validator.validators XWork default validator classes.

Uses of DelegatingValidatorContext in com.opensymphony.xwork2.validator.validators

Subclasses of DelegatingValidatorContext in com.opensymphony.xwork2.validator.validators
static class VisitorFieldValidator.AppendingValidatorContext

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.validator.FieldValidator (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.validator.FieldValidator

Packages that use FieldValidator
com.opensymphony.xwork2.validator.validators XWork default validator classes.

Uses of FieldValidator in com.opensymphony.xwork2.validator.validators

Classes in com.opensymphony.xwork2.validator.validators that implement FieldValidator
class | AbstractRangeValidator Base class for range based validators.
class | ConditionalVisitorFieldValidator ConditionalVisitorFieldValidator <field name="colleaguePosition"> <field-validator type="fieldexpression" short-circuit="true"> reason == 'colleague' and colleaguePositionID == '_CHOOSE_' <message>You must choose a position where you worked with this person, or choose "Other..."</message> </field-validator> <field-validator type="conditionalvisitor"> reason == 'colleague' and colleaguePositionID == 'OTHER' <message/> </field-validator> </field>
class | ConversionErrorFieldValidator Field Validator that checks if a conversion error occured for this field.
class | DateRangeFieldValidator Field Validator that checks if the date supplied is within a specific range.
class | DoubleRangeFieldValidator Field Validator that checks if the double specified is within a certain range.
class | EmailValidator EmailValidator checks that a given String field, if not empty, is a valid email address.
class | FieldExpressionValidator Validates a field using an OGNL expression.
class | FieldValidatorSupport Base class for field validators.
class | IntRangeFieldValidator Field Validator that checks if the integer specified is within a certain range.
class | LongRangeFieldValidator Field Validator that checks if the long specified is within a certain range.
class | RegexFieldValidator Validates a string field using a regular expression.
class | RepopulateConversionErrorFieldValidatorSupport An abstract base class that adds in the capability to populate the stack with a fake parameter map when a conversion error has occurred and the 'repopulateField' property is set to "true".
class | RequiredFieldValidator RequiredFieldValidator checks if the specified field is not null.
class | RequiredStringValidator RequiredStringValidator checks that a String field is non-null and has a length > 0.
class | ShortRangeFieldValidator Field Validator that checks if the short specified is within a certain range.
class | StringLengthFieldValidator StringLengthFieldValidator checks that a String field is of a certain length.
class | URLValidator URLValidator checks that a given field is a String and a valid URL fieldName - The field name this validator is validating.
class | VisitorFieldValidator The VisitorFieldValidator allows you to forward validation to object properties of your action using the object's own validation files.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.validator.ShortCircuitableValidator (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.validator.ShortCircuitableValidator

Packages that use ShortCircuitableValidator
com.opensymphony.xwork2.validator.validators XWork default validator classes.

Uses of ShortCircuitableValidator in com.opensymphony.xwork2.validator.validators

Classes in com.opensymphony.xwork2.validator.validators that implement ShortCircuitableValidator
class | AbstractRangeValidator Base class for range based validators.
class | ConditionalVisitorFieldValidator ConditionalVisitorFieldValidator <field name="colleaguePosition"> <field-validator type="fieldexpression" short-circuit="true"> reason == 'colleague' and colleaguePositionID == '_CHOOSE_' <message>You must choose a position where you worked with this person, or choose "Other..."</message> </field-validator> <field-validator type="conditionalvisitor"> reason == 'colleague' and colleaguePositionID == 'OTHER' <message/> </field-validator> </field>
class | ConversionErrorFieldValidator Field Validator that checks if a conversion error occured for this field.
class | DateRangeFieldValidator Field Validator that checks if the date supplied is within a specific range.
class | DoubleRangeFieldValidator Field Validator that checks if the double specified is within a certain range.
class | EmailValidator EmailValidator checks that a given String field, if not empty, is a valid email address.
class | ExpressionValidator A Non-Field Level validator that validates based on regular expression supplied.
class | FieldExpressionValidator Validates a field using an OGNL expression.
class | FieldValidatorSupport Base class for field validators.
class | IntRangeFieldValidator Field Validator that checks if the integer specified is within a certain range.
class | LongRangeFieldValidator Field Validator that checks if the long specified is within a certain range.
class | RegexFieldValidator Validates a string field using a regular expression.
class | RepopulateConversionErrorFieldValidatorSupport An abstract base class that adds in the capability to populate the stack with a fake parameter map when a conversion error has occurred and the 'repopulateField' property is set to "true".
class | RequiredFieldValidator RequiredFieldValidator checks if the specified field is not null.
class | RequiredStringValidator RequiredStringValidator checks that a String field is non-null and has a length > 0.
class | ShortRangeFieldValidator Field Validator that checks if the short specified is within a certain range.
class | StringLengthFieldValidator StringLengthFieldValidator checks that a String field is of a certain length.
class | URLValidator URLValidator checks that a given field is a String and a valid URL fieldName - The field name this validator is validating.
class | ValidatorSupport Abstract implementation of the Validator interface suitable for subclassing.
class | VisitorFieldValidator The VisitorFieldValidator allows you to forward validation to object properties of your action using the object's own validation files.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.ValidationException (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.ValidationException

Packages that use ValidationException
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Uses of ValidationException in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator that throw ValidationException
void | Validator.validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
void | DefaultActionValidatorManager.validate(Object object, String context)
void | AnnotationActionValidatorManager.validate(Object object, String context)
void | ActionValidatorManager.validate(Object object, String context) Validates the given object using action and its context.
void | DefaultActionValidatorManager.validate(Object object, String context, String method)
void | AnnotationActionValidatorManager.validate(Object object, String context, String method)
void | ActionValidatorManager.validate(Object object, String context, String method) Validates the given object using an action, its context, and the name of the method being invoked on the action.
void | DefaultActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext)
void | AnnotationActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext)
void | ActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext) Validates an action give its context and a validation context.
void | DefaultActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext, String method)
void | AnnotationActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext, String method)
void | ActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext, String method) Validates an action give its context and a validation context.

Uses of ValidationException in com.opensymphony.xwork2.validator.validators

Methods in com.opensymphony.xwork2.validator.validators that throw ValidationException
protected abstract void | RepopulateConversionErrorFieldValidatorSupport.doValidate(Object object)
void | ConversionErrorFieldValidator.doValidate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
protected Object | ValidatorSupport.getFieldValue(String name, Object object) Return the field value named name from object, object should have the appropriate getter/setter.
void | RepopulateConversionErrorFieldValidatorSupport.repopulateField(Object object)
void | VisitorFieldValidator.validate(Object object)
void | URLValidator.validate(Object object)
void | StringLengthFieldValidator.validate(Object object)
void | RequiredStringValidator.validate(Object object)
void | RequiredFieldValidator.validate(Object object)
void | RepopulateConversionErrorFieldValidatorSupport.validate(Object object)
void | RegexFieldValidator.validate(Object object)
void | FieldExpressionValidator.validate(Object object)
void | ExpressionValidator.validate(Object object)
void | DoubleRangeFieldValidator.validate(Object object)
void | ConditionalVisitorFieldValidator.validate(Object object) If expression evaluates to true, invoke visitor validation.
void | AbstractRangeValidator.validate(Object object)
boolean | ConditionalVisitorFieldValidator.validateExpression(Object object) Validate the expression contained in the "expression" paramter.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.ValidationInterceptor (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.ValidationInterceptor

No usage of com.opensymphony.xwork2.validator.ValidationInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.validator.Validator (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.validator.Validator

Packages that use Validator
com.opensymphony.xwork2 | Main XWork interfaces and classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Uses of Validator in com.opensymphony.xwork2

Methods in com.opensymphony.xwork2 that return Validator
 Validator ObjectFactory.buildValidator(String className, Map<String,String> params, Map<String,Object> extraContext)
Build a Validator of the given type and set the parameters on it

Uses of Validator in com.opensymphony.xwork2.validator

Subinterfaces of Validator in com.opensymphony.xwork2.validator
 interface FieldValidator
The FieldValidator interface defines the methods to be implemented by FieldValidators.

Methods in com.opensymphony.xwork2.validator that return Validator
Validator | ValidatorFactory.getValidator(ValidatorConfig cfg) Get a Validator that matches the given configuration.
Validator | DefaultValidatorFactory.getValidator(ValidatorConfig cfg)

Methods in com.opensymphony.xwork2.validator that return types with arguments of type Validator
List<Validator> | DefaultActionValidatorManager.getValidators(Class clazz, String context)
List<Validator> | AnnotationActionValidatorManager.getValidators(Class clazz, String context)
List<Validator> | ActionValidatorManager.getValidators(Class clazz, String context) Returns a list of validators for the given class and context.
List<Validator> | DefaultActionValidatorManager.getValidators(Class clazz, String context, String method)
List<Validator> | AnnotationActionValidatorManager.getValidators(Class clazz, String context, String method)
List<Validator> | ActionValidatorManager.getValidators(Class clazz, String context, String method) Returns a list of validators for the given class, context, and method.

Uses of Validator in com.opensymphony.xwork2.validator.validators

Classes in com.opensymphony.xwork2.validator.validators that implement Validator
class | AbstractRangeValidator Base class for range based validators.
class | ConditionalVisitorFieldValidator ConditionalVisitorFieldValidator <field name="colleaguePosition"> <field-validator type="fieldexpression" short-circuit="true"> reason == 'colleague' and colleaguePositionID == '_CHOOSE_' <message>You must choose a position where you worked with this person, or choose "Other..."</message> </field-validator> <field-validator type="conditionalvisitor"> reason == 'colleague' and colleaguePositionID == 'OTHER' <message/> </field-validator> </field>
class | ConversionErrorFieldValidator Field Validator that checks if a conversion error occured for this field.
class | DateRangeFieldValidator Field Validator that checks if the date supplied is within a specific range.
class | DoubleRangeFieldValidator Field Validator that checks if the double specified is within a certain range.
class | EmailValidator EmailValidator checks that a given String field, if not empty, is a valid email address.
class | ExpressionValidator A Non-Field Level validator that validates based on regular expression supplied.
class | FieldExpressionValidator Validates a field using an OGNL expression.
class | FieldValidatorSupport Base class for field validators.
class | IntRangeFieldValidator Field Validator that checks if the integer specified is within a certain range.
class | LongRangeFieldValidator Field Validator that checks if the long specified is within a certain range.
class | RegexFieldValidator Validates a string field using a regular expression.
class | RepopulateConversionErrorFieldValidatorSupport An abstract base class that adds in the capability to populate the stack with a fake parameter map when a conversion error has occurred and the 'repopulateField' property is set to "true".
class | RequiredFieldValidator RequiredFieldValidator checks if the specified field is not null.
class | RequiredStringValidator RequiredStringValidator checks that a String field is non-null and has a length > 0.
class | ShortRangeFieldValidator Field Validator that checks if the short specified is within a certain range.
class | StringLengthFieldValidator StringLengthFieldValidator checks that a String field is of a certain length.
class | URLValidator URLValidator checks that a given field is a String and a valid URL fieldName - The field name this validator is validating.
class | ValidatorSupport Abstract implementation of the Validator interface suitable for subclassing.
class | VisitorFieldValidator The VisitorFieldValidator allows you to forward validation to object properties of your action using the object's own validation files.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.ValidatorConfig (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.ValidatorConfig

Packages that use ValidatorConfig
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of ValidatorConfig in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator that return ValidatorConfig
 ValidatorConfig ValidatorConfig.Builder.build()

Methods in com.opensymphony.xwork2.validator that return types with arguments of type ValidatorConfig
List<ValidatorConfig> | AnnotationValidationConfigurationBuilder.buildAnnotationClassValidatorConfigs(Class aClass)
protected List<ValidatorConfig> | AnnotationActionValidatorManager.buildClassValidatorConfigs(Class aClass, boolean checkFile)
List<ValidatorConfig> | ValidatorFileParser.parseActionValidatorConfigs(ValidatorFactory validatorFactory, InputStream is, String resourceName) Parse resource for a list of ValidatorConfig objects (configuring which validator(s) are being applied to a particular field etc.)
List<ValidatorConfig> | DefaultValidatorFileParser.parseActionValidatorConfigs(ValidatorFactory validatorFactory, InputStream is, String resourceName)

Methods in com.opensymphony.xwork2.validator with parameters of type ValidatorConfig
Validator | ValidatorFactory.getValidator(ValidatorConfig cfg) Get a Validator that matches the given configuration.
Validator | DefaultValidatorFactory.getValidator(ValidatorConfig cfg)

Constructors in com.opensymphony.xwork2.validator with parameters of type ValidatorConfig
ValidatorConfig.Builder(ValidatorConfig config)
ValidatorConfig(ValidatorConfig orig)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.ValidatorConfig.Builder (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.ValidatorConfig.Builder

Packages that use ValidatorConfig.Builder
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of ValidatorConfig.Builder in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator that return ValidatorConfig.Builder
ValidatorConfig.Builder | ValidatorConfig.Builder.addParam(String name, String value)
ValidatorConfig.Builder | ValidatorConfig.Builder.addParams(Map<String,String> params)
ValidatorConfig.Builder | ValidatorConfig.Builder.defaultMessage(String msg)
ValidatorConfig.Builder | ValidatorConfig.Builder.location(Location loc)
ValidatorConfig.Builder | ValidatorConfig.Builder.messageKey(String key)
ValidatorConfig.Builder | ValidatorConfig.Builder.messageParams(String[] msgParams)
ValidatorConfig.Builder | ValidatorConfig.Builder.removeParam(String key)
ValidatorConfig.Builder | ValidatorConfig.Builder.shortCircuit(boolean shortCircuit)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.validator.ValidatorContext (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.validator.ValidatorContext

Packages that use ValidatorContext
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Uses of ValidatorContext in com.opensymphony.xwork2.validator

Classes in com.opensymphony.xwork2.validator that implement ValidatorContext
 class DelegatingValidatorContext
A default implementation of the ValidatorContext interface.

Methods in com.opensymphony.xwork2.validator that return ValidatorContext
 ValidatorContext Validator.getValidatorContext()
Gets the validation context used

Methods in com.opensymphony.xwork2.validator with parameters of type ValidatorContext
void | Validator.setValidatorContext(ValidatorContext validatorContext) This method will be called before validate with a non-null ValidatorContext.
void | DefaultActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext)
void | AnnotationActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext)
void | ActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext) Validates an action give its context and a validation context.
void | DefaultActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext, String method)
void | AnnotationActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext, String method)
void | ActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext, String method) Validates an action give its context and a validation context.

Uses of ValidatorContext in com.opensymphony.xwork2.validator.validators

Classes in com.opensymphony.xwork2.validator.validators that implement ValidatorContext
static class VisitorFieldValidator.AppendingValidatorContext

Methods in com.opensymphony.xwork2.validator.validators that return ValidatorContext
 ValidatorContext ValidatorSupport.getValidatorContext()

Methods in com.opensymphony.xwork2.validator.validators with parameters of type ValidatorContext
 void ValidatorSupport.setValidatorContext(ValidatorContext validatorContext)

Constructors in com.opensymphony.xwork2.validator.validators with parameters of type ValidatorContext
VisitorFieldValidator.AppendingValidatorContext(ValidatorContext parent, Object object, String field, String message)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.validator.ValidatorFactory (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.validator.ValidatorFactory

Packages that use ValidatorFactory
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of ValidatorFactory in com.opensymphony.xwork2.validator

Classes in com.opensymphony.xwork2.validator that implement ValidatorFactory
 class DefaultValidatorFactory
Default validator factory

Methods in com.opensymphony.xwork2.validator with parameters of type ValidatorFactory
List<ValidatorConfig> | ValidatorFileParser.parseActionValidatorConfigs(ValidatorFactory validatorFactory, InputStream is, String resourceName) Parse resource for a list of ValidatorConfig objects (configuring which validator(s) are being applied to a particular field etc.)
List<ValidatorConfig> | DefaultValidatorFileParser.parseActionValidatorConfigs(ValidatorFactory validatorFactory, InputStream is, String resourceName)
void | DefaultActionValidatorManager.setValidatorFactory(ValidatorFactory fac)
void | AnnotationActionValidatorManager.setValidatorFactory(ValidatorFactory fac)

Constructors in com.opensymphony.xwork2.validator with parameters of type ValidatorFactory
AnnotationValidationConfigurationBuilder(ValidatorFactory fac)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.validator.ValidatorFileParser (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.validator.ValidatorFileParser

Packages that use ValidatorFileParser
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of ValidatorFileParser in com.opensymphony.xwork2.validator

Classes in com.opensymphony.xwork2.validator that implement ValidatorFileParser
 class DefaultValidatorFileParser
Parse the validation file.

Fields in com.opensymphony.xwork2.validator declared as ValidatorFileParser
protected  ValidatorFileParser DefaultValidatorFactory.validatorFileParser

Methods in com.opensymphony.xwork2.validator with parameters of type ValidatorFileParser
void | DefaultActionValidatorManager.setValidatorFileParser(ValidatorFileParser parser)
void | AnnotationActionValidatorManager.setValidatorFileParser(ValidatorFileParser parser)

Constructors in com.opensymphony.xwork2.validator with parameters of type ValidatorFileParser
DefaultValidatorFactory(ObjectFactory objectFactory, ValidatorFileParser parser)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AbstractFieldValidatorDescription (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class AbstractFieldValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
All Implemented Interfaces:
ValidatorDescription
Direct Known Subclasses:
ConversionErrorFieldValidatorDescription, DateRangeFieldValidatorDescription, DoubleRangeFieldValidatorDescription, EmailValidatorDescription, FieldExpressionValidatorDescription, IntRangeFieldValidatorDescription, RequiredFieldValidatorDescription, RequiredStringValidatorDescription, StringLengthFieldValidatorDescription, URLValidatorDescription, VisitorFieldValidatorDescription
public abstract class AbstractFieldValidatorDescription
extends Object
implements ValidatorDescription

AbstractFieldValidatorDescription

Version:
$Id: AbstractFieldValidatorDescription.java 1630 2007-10-05 15:10:08Z mrdon $
Author:
Rainer Hermanns

Field Summary
String | fieldName
String | key
protected static Logger | log Jakarta commons-logging reference.
String | message
boolean | shortCircuit
boolean | simpleValidator
Constructor Summary
AbstractFieldValidatorDescription()
AbstractFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
abstract String | asFieldXml() Returns the field validator XML definition.
abstract String | asSimpleXml() Returns the validator XML definition.
String | asXml() Returns the validator XML definition.
String | getFieldName() Sets the field name for this validator rule.
boolean | isSimpleValidator()
void | setFieldName(String fieldName) Sets the field name for this validator rule.
void | setKey(String key) Sets the I18N message key.
void | setMessage(String message) Sets the default validator failure message.
void | setShortCircuit(boolean shortCircuit) Set the shortCircuit flag.
void | setSimpleValidator(boolean simpleValidator)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

protected static Logger log
Jakarta commons-logging reference.

fieldName

public String fieldName

key

public String key

message

public String message

shortCircuit

public boolean shortCircuit

simpleValidator

public boolean simpleValidator
Constructor Detail

AbstractFieldValidatorDescription

public AbstractFieldValidatorDescription()

AbstractFieldValidatorDescription

public AbstractFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

getFieldName

public String getFieldName()
Sets the field name for this validator rule.

Specified by:
getFieldName in interface ValidatorDescription
Returns:
fieldName the field name for this validator rule

setFieldName

public void setFieldName(String fieldName)
Sets the field name for this validator rule.

Parameters:
fieldName - the field name for this validator rule

setKey

public void setKey(String key)
Sets the I18N message key.

Specified by:
setKey in interface ValidatorDescription
Parameters:
key - the I18N message key

setMessage

public void setMessage(String message)
Sets the default validator failure message.

Specified by:
setMessage in interface ValidatorDescription
Parameters:
message - the default validator failure message

setShortCircuit

public void setShortCircuit(boolean shortCircuit)
Set the shortCircuit flag.

Specified by:
setShortCircuit in interface ValidatorDescription
Parameters:
shortCircuit - the shortCircuit flag.

setSimpleValidator

public void setSimpleValidator(boolean simpleValidator)

isSimpleValidator

public boolean isSimpleValidator()
Specified by:
isSimpleValidator in interface ValidatorDescription

asXml

public String asXml()
Returns the validator XML definition.

Specified by:
asXml in interface ValidatorDescription
Returns:
the validator XML definition.

asFieldXml

public abstract String asFieldXml()
Returns the field validator XML definition.

Returns:
the field validator XML definition.

asSimpleXml

public abstract String asSimpleXml()
Returns the validator XML definition.

Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ConversionErrorFieldValidatorDescription (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class ConversionErrorFieldValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class ConversionErrorFieldValidatorDescription
extends AbstractFieldValidatorDescription

ConversionErrorFieldValidatorDescription

Version:
$Id: ConversionErrorFieldValidatorDescription.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
ConversionErrorFieldValidatorDescription()
ConversionErrorFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the field validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ConversionErrorFieldValidatorDescription

public ConversionErrorFieldValidatorDescription()

ConversionErrorFieldValidatorDescription

public ConversionErrorFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

asFieldXml

public String asFieldXml()
Returns the field validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the field validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateRangeFieldValidatorDescription (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class DateRangeFieldValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class DateRangeFieldValidatorDescription
extends AbstractFieldValidatorDescription

DateRangeFieldValidatorDescription

Version:
$Id: DateRangeFieldValidatorDescription.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns

Field Summary
String | max
String | min
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
DateRangeFieldValidatorDescription()
DateRangeFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the field validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
void | setMax(String max)
void | setMin(String min)
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

min

public String min

max

public String max
Constructor Detail

DateRangeFieldValidatorDescription

public DateRangeFieldValidatorDescription()

DateRangeFieldValidatorDescription

public DateRangeFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

setMin

public void setMin(String min)

setMax

public void setMax(String max)

asFieldXml

public String asFieldXml()
Returns the field validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the field validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DoubleRangeFieldValidatorDescription (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class DoubleRangeFieldValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class DoubleRangeFieldValidatorDescription
extends AbstractFieldValidatorDescription

DoubleRangeFieldValidatorDescription

Version:
$Id: DoubleRangeFieldValidatorDescription.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns

Field Summary
String | max
String | min
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
DoubleRangeFieldValidatorDescription()
DoubleRangeFieldValidatorDescription(String fieldName)
Creates an DoubleRangeFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the field validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
void | setMax(String max)
void | setMin(String min)
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

min

public String min

max

public String max
Constructor Detail

DoubleRangeFieldValidatorDescription

public DoubleRangeFieldValidatorDescription()

DoubleRangeFieldValidatorDescription

public DoubleRangeFieldValidatorDescription(String fieldName)
Creates an DoubleRangeFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

setMin

public void setMin(String min)

setMax

public void setMax(String max)

asFieldXml

public String asFieldXml()
Returns the field validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the field validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmailValidatorDescription (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class EmailValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class EmailValidatorDescription
extends AbstractFieldValidatorDescription

EmailValidatorDescription

Version:
$Id: EmailValidatorDescription.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
EmailValidatorDescription()
EmailValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the field validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EmailValidatorDescription

public EmailValidatorDescription()

EmailValidatorDescription

public EmailValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

asFieldXml

public String asFieldXml()
Returns the field validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the field validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExpressionValidatorDescription (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class ExpressionValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class ExpressionValidatorDescription
extends Object
implements ValidatorDescription

ExpressionValidatorDescription

Version:
$Id: ExpressionValidatorDescription.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns

Field Summary
String | expression
String | key
String | message
boolean | shortCircuit
Constructor Summary
ExpressionValidatorDescription()
Method Summary
String | asXml() Returns the validator XML definition.
String | getFieldName() Returns the field name to create the validation rule for.
boolean | isSimpleValidator()
void | setExpression(String expression)
void | setKey(String key) Sets the I18N message key.
void | setMessage(String message) Sets the default validator failure message.
void | setShortCircuit(boolean shortCircuit) Set the shortCircuit flag.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

expression

public String expression

key

public String key

message

public String message

shortCircuit

public boolean shortCircuit
Constructor Detail

ExpressionValidatorDescription

public ExpressionValidatorDescription()
Method Detail

setExpression

public void setExpression(String expression)

setKey

public void setKey(String key)
Description copied from interface: ValidatorDescription
Sets the I18N message key.

Specified by:
setKey in interface ValidatorDescription
Parameters:
key - the I18N message key

setMessage

public void setMessage(String message)
Description copied from interface: ValidatorDescription
Sets the default validator failure message.

Specified by:
setMessage in interface ValidatorDescription
Parameters:
message - the default validator failure message

setShortCircuit

public void setShortCircuit(boolean shortCircuit)
Description copied from interface: ValidatorDescription
Set the shortCircuit flag.

Specified by:
setShortCircuit in interface ValidatorDescription
Parameters:
shortCircuit - the shortCircuit flag.

getFieldName

public String getFieldName()
Returns the field name to create the validation rule for.

Specified by:
getFieldName in interface ValidatorDescription
Returns:
The field name to create the validation rule for

asXml

public String asXml()
Description copied from interface: ValidatorDescription
Returns the validator XML definition.

Specified by:
asXml in interface ValidatorDescription
Returns:
the validator XML definition.

isSimpleValidator

public boolean isSimpleValidator()
Specified by:
isSimpleValidator in interface ValidatorDescription
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldExpressionValidatorDescription (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class FieldExpressionValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class FieldExpressionValidatorDescription
extends AbstractFieldValidatorDescription

FieldExpressionValidatorDescription

Version:
$Id: FieldExpressionValidatorDescription.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns

Field Summary
String | expression
String | key
String | message
boolean | shortCircuit
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, log, simpleValidator
Constructor Summary
FieldExpressionValidatorDescription()
FieldExpressionValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
void | setExpression(String expression)
void | setKey(String key) Sets the I18N message key.
void | setMessage(String message) Sets the default validator failure message.
void | setShortCircuit(boolean shortCircuit) Set the shortCircuit flag.
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

expression

public String expression

key

public String key

message

public String message

shortCircuit

public boolean shortCircuit
Constructor Detail

FieldExpressionValidatorDescription

public FieldExpressionValidatorDescription()

FieldExpressionValidatorDescription

public FieldExpressionValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

setExpression

public void setExpression(String expression)

setKey

public void setKey(String key)
Description copied from class: AbstractFieldValidatorDescription
Sets the I18N message key.

Specified by:
setKey in interface ValidatorDescription
Overrides:
setKey in class AbstractFieldValidatorDescription
Parameters:
key - the I18N message key

setMessage

public void setMessage(String message)
Description copied from class: AbstractFieldValidatorDescription
Sets the default validator failure message.

Specified by:
setMessage in interface ValidatorDescription
Overrides:
setMessage in class AbstractFieldValidatorDescription
Parameters:
message - the default validator failure message

setShortCircuit

public void setShortCircuit(boolean shortCircuit)
Description copied from class: AbstractFieldValidatorDescription
Set the shortCircuit flag.

Specified by:
setShortCircuit in interface ValidatorDescription
Overrides:
setShortCircuit in class AbstractFieldValidatorDescription
Parameters:
shortCircuit - the shortCircuit flag.

asFieldXml

public String asFieldXml()
Returns the validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IntRangeFieldValidatorDescription (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class IntRangeFieldValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class IntRangeFieldValidatorDescription
extends AbstractFieldValidatorDescription

IntRangeFieldValidatorDescription

Version:
$Id: IntRangeFieldValidatorDescription.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns

Field Summary
String | max
String | min
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
IntRangeFieldValidatorDescription()
IntRangeFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the field validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
void | setMax(String max)
void | setMin(String min)
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

min

public String min

max

public String max
Constructor Detail

IntRangeFieldValidatorDescription

public IntRangeFieldValidatorDescription()

IntRangeFieldValidatorDescription

public IntRangeFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

setMin

public void setMin(String min)

setMax

public void setMax(String max)

asFieldXml

public String asFieldXml()
Returns the field validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the field validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.validator.metadata (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.validator.metadata
Interfaces
ValidatorDescription
Classes
AbstractFieldValidatorDescription
ConversionErrorFieldValidatorDescription
DateRangeFieldValidatorDescription
DoubleRangeFieldValidatorDescription
EmailValidatorDescription
ExpressionValidatorDescription
FieldExpressionValidatorDescription
IntRangeFieldValidatorDescription
RequiredFieldValidatorDescription
RequiredStringValidatorDescription
StringLengthFieldValidatorDescription
URLValidatorDescription
VisitorFieldValidatorDescription


com.opensymphony.xwork2.validator.metadata (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.validator.metadata

Validator meta data classes.

See:
Description

Interface Summary
ValidatorDescription ValidatorDescription

Class Summary
AbstractFieldValidatorDescription | AbstractFieldValidatorDescription
ConversionErrorFieldValidatorDescription | ConversionErrorFieldValidatorDescription
DateRangeFieldValidatorDescription | DateRangeFieldValidatorDescription
DoubleRangeFieldValidatorDescription | DoubleRangeFieldValidatorDescription
EmailValidatorDescription | EmailValidatorDescription
ExpressionValidatorDescription | ExpressionValidatorDescription
FieldExpressionValidatorDescription | FieldExpressionValidatorDescription
IntRangeFieldValidatorDescription | IntRangeFieldValidatorDescription
RequiredFieldValidatorDescription | RequiredFieldValidatorDescription
RequiredStringValidatorDescription | RequiredStringValidatorDescription
StringLengthFieldValidatorDescription | StringLengthFieldValidatorDescription
URLValidatorDescription | URLValidatorDescription
VisitorFieldValidatorDescription | VisitorFieldValidatorDescription

Package com.opensymphony.xwork2.validator.metadata Description

Validator meta data classes.


com.opensymphony.xwork2.validator.metadata Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.validator.metadata

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription (implements com.opensymphony.xwork2.validator.metadata.ValidatorDescription)
      • com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.URLValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription
    • com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription (implements com.opensymphony.xwork2.validator.metadata.ValidatorDescription)

Interface Hierarchy

  • com.opensymphony.xwork2.validator.metadata.ValidatorDescription


Uses of Package com.opensymphony.xwork2.validator.metadata (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.validator.metadata

Packages that use com.opensymphony.xwork2.validator.metadata
com.opensymphony.xwork2.validator.metadata Validator meta data classes.

Classes in com.opensymphony.xwork2.validator.metadata used by com.opensymphony.xwork2.validator.metadata
AbstractFieldValidatorDescription
AbstractFieldValidatorDescription
ValidatorDescription
ValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


RequiredFieldValidatorDescription (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class RequiredFieldValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class RequiredFieldValidatorDescription
extends AbstractFieldValidatorDescription

RequiredFieldValidatorDescription

Version:
$Id: RequiredFieldValidatorDescription.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
RequiredFieldValidatorDescription()
RequiredFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the field validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RequiredFieldValidatorDescription

public RequiredFieldValidatorDescription()

RequiredFieldValidatorDescription

public RequiredFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

asFieldXml

public String asFieldXml()
Returns the field validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the field validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequiredStringValidatorDescription (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class RequiredStringValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class RequiredStringValidatorDescription
extends AbstractFieldValidatorDescription

RequiredStringValidatorDescription

Version:
$Id: RequiredStringValidatorDescription.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns

Field Summary
 boolean trim
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
RequiredStringValidatorDescription()
RequiredStringValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the field validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
void | setTrim(boolean trim)
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

trim

public boolean trim
Constructor Detail

RequiredStringValidatorDescription

public RequiredStringValidatorDescription()

RequiredStringValidatorDescription

public RequiredStringValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

setTrim

public void setTrim(boolean trim)

asFieldXml

public String asFieldXml()
Returns the field validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the field validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StringLengthFieldValidatorDescription (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class StringLengthFieldValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class StringLengthFieldValidatorDescription
extends AbstractFieldValidatorDescription

StringLengthFieldValidatorDescription

Version:
$Id: StringLengthFieldValidatorDescription.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns

Field Summary
String | maxLength
String | minLength
boolean | trim
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
StringLengthFieldValidatorDescription()
StringLengthFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the field validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
void | setMaxLength(String maxLength)
void | setMinLength(String minLength)
void | setTrim(boolean trim)
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

trim

public boolean trim

minLength

public String minLength

maxLength

public String maxLength
Constructor Detail

StringLengthFieldValidatorDescription

public StringLengthFieldValidatorDescription()

StringLengthFieldValidatorDescription

public StringLengthFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

setTrim

public void setTrim(boolean trim)

setMinLength

public void setMinLength(String minLength)

setMaxLength

public void setMaxLength(String maxLength)

asFieldXml

public String asFieldXml()
Returns the field validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the field validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


URLValidatorDescription (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class URLValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.URLValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class URLValidatorDescription
extends AbstractFieldValidatorDescription

URLValidatorDescription

Version:
$Id: URLValidatorDescription.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
URLValidatorDescription()
URLValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified aliasNames.
Method Summary
String | asFieldXml() Returns the field validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

URLValidatorDescription

public URLValidatorDescription()

URLValidatorDescription

public URLValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified aliasNames.

Parameters:
fieldName -
Method Detail

asFieldXml

public String asFieldXml()
Returns the field validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the field validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidatorDescription (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Interface ValidatorDescription

All Known Implementing Classes:
AbstractFieldValidatorDescription, ConversionErrorFieldValidatorDescription, DateRangeFieldValidatorDescription, DoubleRangeFieldValidatorDescription, EmailValidatorDescription, ExpressionValidatorDescription, FieldExpressionValidatorDescription, IntRangeFieldValidatorDescription, RequiredFieldValidatorDescription, RequiredStringValidatorDescription, StringLengthFieldValidatorDescription, URLValidatorDescription, VisitorFieldValidatorDescription
public interface ValidatorDescription

ValidatorDescription

Version:
$Id: ValidatorDescription.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Method Summary
String | asXml() Returns the validator XML definition.
String | getFieldName() Returns the field name to create the validation rule for.
boolean | isSimpleValidator()
void | setKey(String key) Sets the I18N message key.
void | setMessage(String message) Sets the default validator failure message.
void | setShortCircuit(boolean shortCircuit) Set the shortCircuit flag.

Method Detail

asXml

String asXml()
Returns the validator XML definition.

Returns:
the validator XML definition.

getFieldName

String getFieldName()
Returns the field name to create the validation rule for.

Returns:
The field name to create the validation rule for

setKey

void setKey(String key)
Sets the I18N message key.

Parameters:
key - the I18N message key

setMessage

void setMessage(String message)
Sets the default validator failure message.

Parameters:
message - the default validator failure message

setShortCircuit

void setShortCircuit(boolean shortCircuit)
Set the shortCircuit flag.

Parameters:
shortCircuit - the shortCircuit flag.

isSimpleValidator

boolean isSimpleValidator()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VisitorFieldValidatorDescription (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class VisitorFieldValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class VisitorFieldValidatorDescription
extends AbstractFieldValidatorDescription

VisitorFieldValidatorDescription

Version:
$Id: VisitorFieldValidatorDescription.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Rainer Hermanns

Field Summary
boolean | appendPrefix
String | context
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
VisitorFieldValidatorDescription()
VisitorFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
void | setAppendPrefix(boolean appendPrefix)
void | setContext(String context)
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

context

public String context

appendPrefix

public boolean appendPrefix
Constructor Detail

VisitorFieldValidatorDescription

public VisitorFieldValidatorDescription()

VisitorFieldValidatorDescription

public VisitorFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

setContext

public void setContext(String context)

setAppendPrefix

public void setAppendPrefix(boolean appendPrefix)

asFieldXml

public String asFieldXml()
Returns the validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription

Packages that use AbstractFieldValidatorDescription
com.opensymphony.xwork2.validator.metadata Validator meta data classes.

Uses of AbstractFieldValidatorDescription in com.opensymphony.xwork2.validator.metadata

Subclasses of AbstractFieldValidatorDescription in com.opensymphony.xwork2.validator.metadata
class | ConversionErrorFieldValidatorDescription ConversionErrorFieldValidatorDescription
class | DateRangeFieldValidatorDescription DateRangeFieldValidatorDescription
class | DoubleRangeFieldValidatorDescription DoubleRangeFieldValidatorDescription
class | EmailValidatorDescription EmailValidatorDescription
class | FieldExpressionValidatorDescription FieldExpressionValidatorDescription
class | IntRangeFieldValidatorDescription IntRangeFieldValidatorDescription
class | RequiredFieldValidatorDescription RequiredFieldValidatorDescription
class | RequiredStringValidatorDescription RequiredStringValidatorDescription
class | StringLengthFieldValidatorDescription StringLengthFieldValidatorDescription
class | URLValidatorDescription URLValidatorDescription
class | VisitorFieldValidatorDescription VisitorFieldValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.URLValidatorDescription (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.URLValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.URLValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.validator.metadata.ValidatorDescription (XWork: Core 2.1.6 API)

Uses of Interface
com.opensymphony.xwork2.validator.metadata.ValidatorDescription

Packages that use ValidatorDescription
com.opensymphony.xwork2.validator.metadata Validator meta data classes.

Uses of ValidatorDescription in com.opensymphony.xwork2.validator.metadata

Classes in com.opensymphony.xwork2.validator.metadata that implement ValidatorDescription
class | AbstractFieldValidatorDescription AbstractFieldValidatorDescription
class | ConversionErrorFieldValidatorDescription ConversionErrorFieldValidatorDescription
class | DateRangeFieldValidatorDescription DateRangeFieldValidatorDescription
class | DoubleRangeFieldValidatorDescription DoubleRangeFieldValidatorDescription
class | EmailValidatorDescription EmailValidatorDescription
class | ExpressionValidatorDescription ExpressionValidatorDescription
class | FieldExpressionValidatorDescription FieldExpressionValidatorDescription
class | IntRangeFieldValidatorDescription IntRangeFieldValidatorDescription
class | RequiredFieldValidatorDescription RequiredFieldValidatorDescription
class | RequiredStringValidatorDescription RequiredStringValidatorDescription
class | StringLengthFieldValidatorDescription StringLengthFieldValidatorDescription
class | URLValidatorDescription URLValidatorDescription
class | VisitorFieldValidatorDescription VisitorFieldValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AbstractRangeValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class AbstractRangeValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
Direct Known Subclasses:
DateRangeFieldValidator, IntRangeFieldValidator, LongRangeFieldValidator, ShortRangeFieldValidator
public abstract class AbstractRangeValidator
extends FieldValidatorSupport

Base class for range based validators.

Author:
Jason Carreira, Cameron Braid

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
AbstractRangeValidator()
Method Summary
protected abstract Comparable | getMaxComparatorValue()
protected abstract Comparable | getMinComparatorValue()
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getMessageParameters, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setMessageParameters, setParse, setShortCircuit, setValidatorContext, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getMessageParameters, getValidatorContext, setDefaultMessage, setMessageKey, setMessageParameters, setValidatorContext, setValueStack

Constructor Detail

AbstractRangeValidator

public AbstractRangeValidator()
Method Detail

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Parameters:
object - the object to be validated.
Throws:
ValidationException - is thrown if there is validation error(s).

getMaxComparatorValue

protected abstract Comparable getMaxComparatorValue()

getMinComparatorValue

protected abstract Comparable getMinComparatorValue()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ConditionalVisitorFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class ConditionalVisitorFieldValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.VisitorFieldValidator
                extended by  com.opensymphony.xwork2.validator.validators.ConditionalVisitorFieldValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class ConditionalVisitorFieldValidator
extends VisitorFieldValidator

ConditionalVisitorFieldValidator <field name="colleaguePosition"> <field-validator type="fieldexpression" short-circuit="true"> reason == 'colleague' and colleaguePositionID == '_CHOOSE_' <message>You must choose a position where you worked with this person, or choose "Other..."</message> </field-validator> <field-validator type="conditionalvisitor"> reason == 'colleague' and colleaguePositionID == 'OTHER' <message/> </field-validator> </field>

Author:
Matt Raible

Nested Class Summary
Nested classes/interfaces inherited from class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator
VisitorFieldValidator.AppendingValidatorContext
Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
ConditionalVisitorFieldValidator()
Method Summary
String | getExpression()
void | setExpression(String expression)
void | validate(Object object) If expression evaluates to true, invoke visitor validation.
boolean | validateExpression(Object object) Validate the expression contained in the "expression" paramter.
Methods inherited from class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator
getContext, isAppendPrefix, setActionValidatorManager, setAppendPrefix, setContext
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getMessageParameters, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setMessageParameters, setParse, setShortCircuit, setValidatorContext, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getMessageParameters, getValidatorContext, setDefaultMessage, setMessageKey, setMessageParameters, setValidatorContext, setValueStack

Constructor Detail

ConditionalVisitorFieldValidator

public ConditionalVisitorFieldValidator()
Method Detail

setExpression

public void setExpression(String expression)

getExpression

public String getExpression()

validate

public void validate(Object object)
              throws ValidationException
If expression evaluates to true, invoke visitor validation.

Specified by:
validate in interface Validator
Overrides:
validate in class VisitorFieldValidator
Parameters:
object - the object being validated
Throws:
ValidationException

validateExpression

public boolean validateExpression(Object object)
                           throws ValidationException
Validate the expression contained in the "expression" paramter.

Parameters:
object - the object you're validating
Returns:
true if expression evaluates to true (implying a validation failure)
Throws:
ValidationException - if anything goes wrong
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConversionErrorFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class ConversionErrorFieldValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport
                extended by  com.opensymphony.xwork2.validator.validators.ConversionErrorFieldValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class ConversionErrorFieldValidator
extends RepopulateConversionErrorFieldValidatorSupport

Field Validator that checks if a conversion error occured for this field.

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required
     <!-- Plain Validator Syntax -->
     <validator type="conversion">
                <param name="fieldName">myField</param>
          <message>Conversion Error Occurred</message>
     </validator>

     <!-- Field Validator Syntax -->
     <field name="myField">
        <field-validator type="conversion">
           <message>Conversion Error Occurred</message>
        </field-validator>
     </field>

Version:
$Date $Id: ConversionErrorFieldValidator.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Jason Carreira, tm_jee

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
ConversionErrorFieldValidator()
Method Summary
 void doValidate(Object object)
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport
getRepopulateField, repopulateField, setRepopulateField, validate
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getMessageParameters, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setMessageParameters, setParse, setShortCircuit, setValidatorContext, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getMessageParameters, getValidatorContext, setDefaultMessage, setMessageKey, setMessageParameters, setValidatorContext, setValueStack

Constructor Detail

ConversionErrorFieldValidator

public ConversionErrorFieldValidator()
Method Detail

doValidate

public void doValidate(Object object)
                throws ValidationException
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Specified by:
doValidate in class RepopulateConversionErrorFieldValidatorSupport
Parameters:
object -
Throws:
ValidationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateRangeFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class DateRangeFieldValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
                extended by  com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class DateRangeFieldValidator
extends AbstractRangeValidator

Field Validator that checks if the date supplied is within a specific range. NOTE: If no date converter is specified, XWorkBasicConverter will kick in to do the date conversion, which by default using the Date.SHORT format using the a programmatically specified locale else falling back to the system default locale.

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required
  • min - the min date range. If not specified will not be checked.
  • max - the max date range. If not specified will not be checked.

    <validators>
                <!-- Plain Validator syntax -->
                <validator type="date">
                <param name="fieldName">birthday</param>
              <param name="min">01/01/1990</param>
              <param name="max">01/01/2000</param>
              <message>Birthday must be within ${min} and ${max}</message>
                </validator>

          <!-- Field Validator Syntax -->
          <field name="birthday">
                <field-validator type="date">
                    <param name="min">01/01/1990</param>
                  <param name="max">01/01/2000</param>
                  <message>Birthday must be within ${min} and ${max}</message>
                </field>
          </field>

    </validators>

Version:
$Date: 2008-06-21 11:29:39 +0200 (Sa, 21 Jun 2008) $ $Id: DateRangeFieldValidator.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Jason Carreira

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
DateRangeFieldValidator()
Method Summary
Date | getMax()
protected Comparable | getMaxComparatorValue()
Date | getMin()
protected Comparable | getMinComparatorValue()
void | setMax(Date max)
void | setMin(Date min)
Methods inherited from class com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
validate
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getMessageParameters, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setMessageParameters, setParse, setShortCircuit, setValidatorContext, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getMessageParameters, getValidatorContext, setDefaultMessage, setMessageKey, setMessageParameters, setValidatorContext, setValueStack

Constructor Detail

DateRangeFieldValidator

public DateRangeFieldValidator()
Method Detail

setMax

public void setMax(Date max)

getMax

public Date getMax()

setMin

public void setMin(Date min)

getMin

public Date getMin()

getMaxComparatorValue

protected Comparable getMaxComparatorValue()
Specified by:
getMaxComparatorValue in class AbstractRangeValidator

getMinComparatorValue

protected Comparable getMinComparatorValue()
Specified by:
getMinComparatorValue in class AbstractRangeValidator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DoubleRangeFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class DoubleRangeFieldValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class DoubleRangeFieldValidator
extends FieldValidatorSupport

Field Validator that checks if the double specified is within a certain range.

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required
  • minInclusive - the minimum inclusive value in FloatValue format specified by Java language (if none is specified, it will not be checked)
  • maxInclusive - the maximum inclusive value in FloatValue format specified by Java language (if none is specified, it will not be checked)
  • minExclusive - the minimum exclusive value in FloatValue format specified by Java language (if none is specified, it will not be checked)
  • maxExclusive - the maximum exclusive value in FloatValue format specified by Java language (if none is specified, it will not be checked)

                 <validators>
           <!-- Plain Validator Syntax -->
           <validator type="double">
               <param name="fieldName">percentage</param>
               <param name="minInclusive">20.1</param>
               <param name="maxInclusive">50.1</param>
               <message>Age needs to be between ${minInclusive} and
${maxInclusive} (inclusive)</message>
           </validator>

           <!-- Field Validator Syntax -->
           <field name="percentage">
               <field-validator type="double">
                   <param name="minExclusive">0.123</param>
                   <param name="maxExclusive">99.98</param>
                   <message>Percentage needs to be between ${minExclusive}
and ${maxExclusive} (exclusive)</message>
               </field-validator>
           </field>
      </validators>

Version:
$Id: DoubleRangeFieldValidator.java 1184 2006-11-12 07:30:31Z tm_jee $
Author:
Rainer Hermanns, Rene Gielen

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
DoubleRangeFieldValidator()
Method Summary
String | getMaxExclusive()
String | getMaxInclusive()
String | getMinExclusive()
String | getMinInclusive()
void | setMaxExclusive(String maxExclusive)
void | setMaxInclusive(String maxInclusive)
void | setMinExclusive(String minExclusive)
void | setMinInclusive(String minInclusive)
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getMessageParameters, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setMessageParameters, setParse, setShortCircuit, setValidatorContext, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getMessageParameters, getValidatorContext, setDefaultMessage, setMessageKey, setMessageParameters, setValidatorContext, setValueStack

Constructor Detail

DoubleRangeFieldValidator

public DoubleRangeFieldValidator()
Method Detail

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Parameters:
object - the object to be validated.
Throws:
ValidationException - is thrown if there is validation error(s).

setMaxInclusive

public void setMaxInclusive(String maxInclusive)

getMaxInclusive

public String getMaxInclusive()

setMinInclusive

public void setMinInclusive(String minInclusive)

getMinInclusive

public String getMinInclusive()

getMinExclusive

public String getMinExclusive()

setMinExclusive

public void setMinExclusive(String minExclusive)

getMaxExclusive

public String getMaxExclusive()

setMaxExclusive

public void setMaxExclusive(String maxExclusive)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmailValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class EmailValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.RegexFieldValidator
                extended by  com.opensymphony.xwork2.validator.validators.EmailValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class EmailValidator
extends RegexFieldValidator

EmailValidator checks that a given String field, if not empty, is a valid email address.

The regular expression used to validate that the string is an email address is:

 \\b(^[_A-Za-z0-9-]+(\\.[_A-Za-z0-9-]+)*@([A-Za-z0-9-])+((\\.com)|(\\.net)|(\\.org)|(\\.info)|(\\.edu)|(\\.mil)|(\\.gov)|(\\.biz)|(\\.ws)|(\\.us)|(\\.tv)|(\\.cc)|(\\.aero)|(\\.arpa)|(\\.coop)|(\\.int)|(\\.jobs)|(\\.museum)|(\\.name)|(\\.pro)|(\\.travel)|(\\.nato)|(\\..{2,3})|(\\..{2,3}\\..{2,3}))$)\\b
  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required

     <!-- Plain Validator Syntax -->
     <validators>
         <validator type="email">
             <param name="fieldName">myEmail</param>
             <message>Must provide a valid email</message>
         </validator>
     </validators>

     <!-- Field Validator Syntax -->
     <field name="myEmail">
        <field-validator type="email">
           <message>Must provide a valid email</message>
        </field-validator>
     </field>

Version:
$Date: 2008-12-15 17:02:09 +0100 (Mo, 15 Dez 2008) $ $Id: EmailValidator.java 1885 2008-12-15 16:02:09Z musachy $
Author:
jhouse, tm_jee

Field Summary
static String emailAddressPattern
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
EmailValidator()
Method Summary
Methods inherited from class com.opensymphony.xwork2.validator.validators.RegexFieldValidator
getExpression, isCaseSensitive, isTrimed, setCaseSensitive, setExpression, setTrim, validate
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getMessageParameters, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setMessageParameters, setParse, setShortCircuit, setValidatorContext, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getMessageParameters, getValidatorContext, setDefaultMessage, setMessageKey, setMessageParameters, setValidatorContext, setValueStack

Field Detail

emailAddressPattern

public static final String emailAddressPattern
See Also:
Constant Field Values
Constructor Detail

EmailValidator

public EmailValidator()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExpressionValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class ExpressionValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.ExpressionValidator
All Implemented Interfaces:
ShortCircuitableValidator, Validator
public class ExpressionValidator
extends ValidatorSupport

A Non-Field Level validator that validates based on regular expression supplied.

  • expression - the Ognl expression to be evaluated against the stack (Must evaluate to a Boolean)

     <validators>
           <validator type="expression">
              <param name="expression"> .... </param>
              <message>Failed to meet Ognl Expression  .... </message>
           </validator>
     </validators>

Author:
Jason Carreira

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
ExpressionValidator()
Method Summary
String | getExpression()
void | setExpression(String expression)
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getMessageParameters, getParse, getValidatorContext, getValidatorType, isShortCircuit, setDefaultMessage, setMessageKey, setMessageParameters, setParse, setShortCircuit, setValidatorContext, setValidatorType, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ExpressionValidator

public ExpressionValidator()
Method Detail

setExpression

public void setExpression(String expression)

getExpression

public String getExpression()

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Parameters:
object - the object to be validated.
Throws:
ValidationException - is thrown if there is validation error(s).
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldExpressionValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class FieldExpressionValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.FieldExpressionValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class FieldExpressionValidator
extends FieldValidatorSupport

Validates a field using an OGNL expression.

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required
  • expression - The Ognl expression (must evaluate to a boolean) which is to be evalidated the stack

    <!-- Plain Validator Syntax -->
    <validators>
        <!-- Plain Validator Syntax -->
        <validator type="fieldexpression">
           <param name="fieldName">myField</param>
           <param name="expression"><![CDATA[#myCreditLimit > #myGirfriendCreditLimit]]></param>
           <message>My credit limit should be MORE than my girlfriend</message>
        <validator>

        <!-- Field Validator Syntax -->
        <field name="myField">
            <field-validator type="fieldexpression">
                <param name="expression"><![CDATA[#myCreditLimit > #myGirfriendCreditLimit]]></param>
                <message>My credit limit should be MORE than my girlfriend</message>
            </field-validator>
        </field>

    </vaidators>

Version:
$Revision: 1063 $
Author:
$Author: mrdon $

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
FieldExpressionValidator()
Method Summary
String | getExpression()
void | setExpression(String expression)
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getMessageParameters, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setMessageParameters, setParse, setShortCircuit, setValidatorContext, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getMessageParameters, getValidatorContext, setDefaultMessage, setMessageKey, setMessageParameters, setValidatorContext, setValueStack

Constructor Detail

FieldExpressionValidator

public FieldExpressionValidator()
Method Detail

setExpression

public void setExpression(String expression)

getExpression

public String getExpression()

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Parameters:
object - the object to be validated.
Throws:
ValidationException - is thrown if there is validation error(s).
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldValidatorSupport (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class FieldValidatorSupport

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
Direct Known Subclasses:
AbstractRangeValidator, DoubleRangeFieldValidator, FieldExpressionValidator, RegexFieldValidator, RepopulateConversionErrorFieldValidatorSupport, RequiredFieldValidator, RequiredStringValidator, StringLengthFieldValidator, URLValidator, VisitorFieldValidator
public abstract class FieldValidatorSupport
extends ValidatorSupport
implements FieldValidator

Base class for field validators.

Author:
Jason Carreira

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
FieldValidatorSupport()
Method Summary
String | getFieldName() Gets the field name to be validated
String | getValidatorType() Gets the vaildator type used (see class javadoc).
void | setFieldName(String fieldName) Sets the field name to validate with this FieldValidator
void | setValidatorType(String type) Sets the validator type to use (see class javadoc).
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getMessageParameters, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setMessageParameters, setParse, setShortCircuit, setValidatorContext, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getMessageParameters, getValidatorContext, setDefaultMessage, setMessageKey, setMessageParameters, setValidatorContext, setValueStack, validate

Constructor Detail

FieldValidatorSupport

public FieldValidatorSupport()
Method Detail

setFieldName

public void setFieldName(String fieldName)
Description copied from interface: FieldValidator
Sets the field name to validate with this FieldValidator

Specified by:
setFieldName in interface FieldValidator
Parameters:
fieldName - the field name

getFieldName

public String getFieldName()
Description copied from interface: FieldValidator
Gets the field name to be validated

Specified by:
getFieldName in interface FieldValidator
Returns:
the field name

setValidatorType

public void setValidatorType(String type)
Description copied from interface: Validator
Sets the validator type to use (see class javadoc).

Specified by:
setValidatorType in interface Validator
Overrides:
setValidatorType in class ValidatorSupport
Parameters:
type - the type to use.

getValidatorType

public String getValidatorType()
Description copied from interface: Validator
Gets the vaildator type used (see class javadoc).

Specified by:
getValidatorType in interface Validator
Overrides:
getValidatorType in class ValidatorSupport
Returns:
the type used
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IntRangeFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class IntRangeFieldValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
                extended by  com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class IntRangeFieldValidator
extends AbstractRangeValidator

Field Validator that checks if the integer specified is within a certain range.

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required
  • min - the minimum value (if none is specified, it will not be checked)
  • max - the maximum value (if none is specified, it will not be checked)

                <validators>
           <!-- Plain Validator Syntax -->
           <validator type="int">
               <param name="fieldName">age</param>
               <param name="min">20</param>
               <param name="max">50</param>
               <message>Age needs to be between ${min} and ${max}</message>
           </validator>

           <!-- Field Validator Syntax -->
           <field name="age">
               <field-validator type="int">
                   <param name="min">20</param>
                   <param name="max">50</param>
                   <message>Age needs to be between ${min} and ${max}</message>
               </field-validator>
           </field>
      </validators>

Version:
$Date: 2008-06-21 11:29:39 +0200 (Sa, 21 Jun 2008) $ $Id: IntRangeFieldValidator.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Jason Carreira

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
IntRangeFieldValidator()
Method Summary
Integer | getMax()
Comparable | getMaxComparatorValue()
Integer | getMin()
Comparable | getMinComparatorValue()
void | setMax(Integer max)
void | setMin(Integer min)
Methods inherited from class com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
validate
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getMessageParameters, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setMessageParameters, setParse, setShortCircuit, setValidatorContext, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getMessageParameters, getValidatorContext, setDefaultMessage, setMessageKey, setMessageParameters, setValidatorContext, setValueStack

Constructor Detail

IntRangeFieldValidator

public IntRangeFieldValidator()
Method Detail

setMax

public void setMax(Integer max)

getMax

public Integer getMax()

getMaxComparatorValue

public Comparable getMaxComparatorValue()
Specified by:
getMaxComparatorValue in class AbstractRangeValidator

setMin

public void setMin(Integer min)

getMin

public Integer getMin()

getMinComparatorValue

public Comparable getMinComparatorValue()
Specified by:
getMinComparatorValue in class AbstractRangeValidator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LongRangeFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class LongRangeFieldValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
                extended by  com.opensymphony.xwork2.validator.validators.LongRangeFieldValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class LongRangeFieldValidator
extends AbstractRangeValidator

Field Validator that checks if the long specified is within a certain range.

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required
  • min - the minimum value (if none is specified, it will not be checked)
  • max - the maximum value (if none is specified, it will not be checked)

              <validators>
           <!-- Plain Validator Syntax -->
           <validator type="long">
               <param name="fieldName">age</param>
               <param name="min">20</param>
               <param name="max">50</param>
               <message>Age needs to be between ${min} and ${max}</message>
           </validator>

           <!-- Field Validator Syntax -->
           <field name="age">
               <field-validator type="long">
                   <param name="min">20</param>
                   <param name="max">50</param>
                   <message>Age needs to be between ${min} and ${max}</message>
               </field-validator>
           </field>
      </validators>

Version:
$Date$

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
LongRangeFieldValidator()
Method Summary
Long | getMax()
Comparable | getMaxComparatorValue()
Long | getMin()
Comparable | getMinComparatorValue()
void | setMax(Long max)
void | setMin(Long min)
Methods inherited from class com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
validate
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getMessageParameters, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setMessageParameters, setParse, setShortCircuit, setValidatorContext, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getMessageParameters, getValidatorContext, setDefaultMessage, setMessageKey, setMessageParameters, setValidatorContext, setValueStack

Constructor Detail

LongRangeFieldValidator

public LongRangeFieldValidator()
Method Detail

setMax

public void setMax(Long max)

getMax

public Long getMax()

getMaxComparatorValue

public Comparable getMaxComparatorValue()
Specified by:
getMaxComparatorValue in class AbstractRangeValidator

setMin

public void setMin(Long min)

getMin

public Long getMin()

getMinComparatorValue

public Comparable getMinComparatorValue()
Specified by:
getMinComparatorValue in class AbstractRangeValidator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.validator.validators (XWork: Core 2.1.6 API)

 com.opensymphony.xwork2.validator.validators
Classes
AbstractRangeValidator
ConditionalVisitorFieldValidator
ConversionErrorFieldValidator
DateRangeFieldValidator
DoubleRangeFieldValidator
EmailValidator
ExpressionValidator
FieldExpressionValidator
FieldValidatorSupport
IntRangeFieldValidator
LongRangeFieldValidator
RegexFieldValidator
RepopulateConversionErrorFieldValidatorSupport
RequiredFieldValidator
RequiredStringValidator
ShortRangeFieldValidator
StringLengthFieldValidator
URLValidator
ValidatorSupport
VisitorFieldValidator
VisitorFieldValidator.AppendingValidatorContext


com.opensymphony.xwork2.validator.validators (XWork: Core 2.1.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.validator.validators

XWork default validator classes.

See:
Description

Class Summary
AbstractRangeValidator | Base class for range based validators.
ConditionalVisitorFieldValidator | ConditionalVisitorFieldValidator <field name="colleaguePosition"> <field-validator type="fieldexpression" short-circuit="true"> reason == 'colleague' and colleaguePositionID == '_CHOOSE_' <message>You must choose a position where you worked with this person, or choose "Other..."</message> </field-validator> <field-validator type="conditionalvisitor"> reason == 'colleague' and colleaguePositionID == 'OTHER' <message/> </field-validator> </field>
ConversionErrorFieldValidator | Field Validator that checks if a conversion error occured for this field.
DateRangeFieldValidator | Field Validator that checks if the date supplied is within a specific range.
DoubleRangeFieldValidator | Field Validator that checks if the double specified is within a certain range.
EmailValidator | EmailValidator checks that a given String field, if not empty, is a valid email address.
ExpressionValidator | A Non-Field Level validator that validates based on regular expression supplied.
FieldExpressionValidator | Validates a field using an OGNL expression.
FieldValidatorSupport | Base class for field validators.
IntRangeFieldValidator | Field Validator that checks if the integer specified is within a certain range.
LongRangeFieldValidator | Field Validator that checks if the long specified is within a certain range.
RegexFieldValidator | Validates a string field using a regular expression.
RepopulateConversionErrorFieldValidatorSupport | An abstract base class that adds in the capability to populate the stack with a fake parameter map when a conversion error has occurred and the 'repopulateField' property is set to "true".
RequiredFieldValidator | RequiredFieldValidator checks if the specified field is not null.
RequiredStringValidator | RequiredStringValidator checks that a String field is non-null and has a length > 0.
ShortRangeFieldValidator | Field Validator that checks if the short specified is within a certain range.
StringLengthFieldValidator | StringLengthFieldValidator checks that a String field is of a certain length.
URLValidator | URLValidator checks that a given field is a String and a valid URL fieldName - The field name this validator is validating.
ValidatorSupport | Abstract implementation of the Validator interface suitable for subclassing.
VisitorFieldValidator | The VisitorFieldValidator allows you to forward validation to object properties of your action using the object's own validation files.
VisitorFieldValidator.AppendingValidatorContext |

Package com.opensymphony.xwork2.validator.validators Description

XWork default validator classes.

Overview Package Class Use Tree Deprecated Index Help
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.opensymphony.xwork2.validator.validators Class Hierarchy (XWork: Core 2.1.6 API)

Hierarchy For Package com.opensymphony.xwork2.validator.validators

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.validator.DelegatingValidatorContext (implements com.opensymphony.xwork2.validator.ValidatorContext)
      • com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext
    • com.opensymphony.xwork2.validator.validators.ValidatorSupport (implements com.opensymphony.xwork2.validator.ShortCircuitableValidator, com.opensymphony.xwork2.validator.Validator<T>)
      • com.opensymphony.xwork2.validator.validators.ExpressionValidator
      • com.opensymphony.xwork2.validator.validators.FieldValidatorSupport (implements com.opensymphony.xwork2.validator.FieldValidator)
        • com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
          • com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator
          • com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator
          • com.opensymphony.xwork2.validator.validators.LongRangeFieldValidator
          • com.opensymphony.xwork2.validator.validators.ShortRangeFieldValidator
        • com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator
        • com.opensymphony.xwork2.validator.validators.FieldExpressionValidator
        • com.opensymphony.xwork2.validator.validators.RegexFieldValidator
          • com.opensymphony.xwork2.validator.validators.EmailValidator
        • com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport
          • com.opensymphony.xwork2.validator.validators.ConversionErrorFieldValidator
        • com.opensymphony.xwork2.validator.validators.RequiredFieldValidator
        • com.opensymphony.xwork2.validator.validators.RequiredStringValidator
        • com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator
        • com.opensymphony.xwork2.validator.validators.URLValidator
        • com.opensymphony.xwork2.validator.validators.VisitorFieldValidator
          • com.opensymphony.xwork2.validator.validators.ConditionalVisitorFieldValidator
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Package com.opensymphony.xwork2.validator.validators (XWork: Core 2.1.6 API)

Uses of Package
com.opensymphony.xwork2.validator.validators

Packages that use com.opensymphony.xwork2.validator.validators
com.opensymphony.xwork2.validator.validators XWork default validator classes.

Classes in com.opensymphony.xwork2.validator.validators used by com.opensymphony.xwork2.validator.validators
AbstractRangeValidator
Base class for range based validators.
FieldValidatorSupport
Base class for field validators.
RegexFieldValidator
Validates a string field using a regular expression.
RepopulateConversionErrorFieldValidatorSupport
An abstract base class that adds in the capability to populate the stack with a fake parameter map when a conversion error has occurred and the 'repopulateField' property is set to "true".
ValidatorSupport
Abstract implementation of the Validator interface suitable for subclassing.
VisitorFieldValidator
The VisitorFieldValidator allows you to forward validation to object properties of your action using the object's own validation files.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


RegexFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class RegexFieldValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.RegexFieldValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
Direct Known Subclasses:
EmailValidator
public class RegexFieldValidator
extends FieldValidatorSupport

Validates a string field using a regular expression.

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required
  • expression - The RegExp expression REQUIRED
  • caseSensitive - Boolean (Optional). Sets whether the expression should be matched against in a case-sensitive way. Default is true.
  • trim - Boolean (Optional). Sets whether the expression should be trimed before matching. Default is true.

    <validators>
        <!-- Plain Validator Syntax -->
        <validator type="regex">
            <param name="fieldName">myStrangePostcode</param>
            <param name="expression"><![CDATA[([aAbBcCdD][123][eEfFgG][456])]]<>/param>
        </validator>

        <!-- Field Validator Syntax -->
        <field name="myStrangePostcode">
            <field-validator type="regex">
               <param name="expression"><![CDATA[([aAbBcCdD][123][eEfFgG][456])]]></param>
            </field-validator>
        </field>
    </validators>

Version:
$Date: 2008-06-21 11:29:39 +0200 (Sa, 21 Jun 2008) $ $Revision: 1833 $
Author:
Quake Wang

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
RegexFieldValidator()
Method Summary
String | getExpression()
boolean | isCaseSensitive()
boolean | isTrimed()
void | setCaseSensitive(boolean caseSensitive) Sets whether the expression should be matched against in a case-sensitive way.
void | setExpression(String expression) Sets the regular expression to be matched.
void | setTrim(boolean trim) Sets whether the expression should be trimed before matching.
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getMessageParameters, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setMessageParameters, setParse, setShortCircuit, setValidatorContext, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getMessageParameters, getValidatorContext, setDefaultMessage, setMessageKey, setMessageParameters, setValidatorContext, setValueStack

Constructor Detail

RegexFieldValidator

public RegexFieldValidator()
Method Detail

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Parameters:
object - the object to be validated.
Throws:
ValidationException - is thrown if there is validation error(s).

getExpression

public String getExpression()
Returns:
Returns the regular expression to be matched.

setExpression

public void setExpression(String expression)
Sets the regular expression to be matched.

isCaseSensitive

public boolean isCaseSensitive()
Returns:
Returns whether the expression should be matched against in a case-sensitive way. Default is true.

setCaseSensitive

public void setCaseSensitive(boolean caseSensitive)
Sets whether the expression should be matched against in a case-sensitive way. Default is true.

isTrimed

public boolean isTrimed()
Returns:
Returns whether the expression should be trimed before matching. Default is true.

setTrim

public void setTrim(boolean trim)
Sets whether the expression should be trimed before matching. Default is true.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RepopulateConversionErrorFieldValidatorSupport (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class RepopulateConversionErrorFieldValidatorSupport

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
Direct Known Subclasses:
ConversionErrorFieldValidator
public abstract class RepopulateConversionErrorFieldValidatorSupport
extends FieldValidatorSupport

An abstract base class that adds in the capability to populate the stack with a fake parameter map when a conversion error has occurred and the 'repopulateField' property is set to "true".

The capability of auto-repopulating the stack with a fake parameter map when a conversion error has occurred can be done with 'repopulateField' property set to "true".

This is typically usefull when one wants to repopulate the field with the original value when a conversion error occurred. Eg. with a textfield that only allows an Integer (the action class have an Integer field declared), upon conversion error, the incorrectly entered integer (maybe a text 'one') will not appear when dispatched back. With 'repopulateField' porperty set to true, it will, meaning the textfield will have 'one' as its value upon conversion error.

 <!-- myJspPage.jsp -->
 <ww:form action="someAction" method="POST">
   ....
   <ww:textfield
       label="My Integer Field"
       name="myIntegerField" />
   ....
   <ww:submit />
 </ww:form>

 <!-- xwork.xml -->
 <xwork>
 <include file="xwork-default.xml" />
 ....
 <package name="myPackage" extends="xwork-default">
   ....
   <action name="someAction" class="example.MyActionSupport.java">
      <result name="input">myJspPage.jsp</result>
      <result>success.jsp</result>
   </action>
   ....
 </package>
 ....
 </xwork>

 <!-- MyActionSupport.java -->
 public class MyActionSupport extends ActionSupport {
    private Integer myIntegerField;

    public Integer getMyIntegerField() { return this.myIntegerField; }
    public void setMyIntegerField(Integer myIntegerField) {
       this.myIntegerField = myIntegerField;
    }
 }

 <!-- MyActionSupport-someAction-validation.xml -->
 <validators>
   ...
   <field name="myIntegerField">
      <field-validator type="conversion">
         <param name="repopulateField">true</param>
         <message>Conversion Error (Integer Wanted)</message>
      </field-validator>
   </field>
   ...
 </validators>

Version:
$Date: 2009-08-12 20:13:44 +0200 (Mi, 12 Aug 2009) $ $Id: RepopulateConversionErrorFieldValidatorSupport.java 2036 2009-08-12 18:13:44Z musachy $
Author:
tm_jee

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
RepopulateConversionErrorFieldValidatorSupport()
Method Summary
protected abstract void | doValidate(Object object)
String | getRepopulateField()
void | repopulateField(Object object)
void | setRepopulateField(String repopulateField)
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getMessageParameters, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setMessageParameters, setParse, setShortCircuit, setValidatorContext, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getMessageParameters, getValidatorContext, setDefaultMessage, setMessageKey, setMessageParameters, setValidatorContext, setValueStack

Constructor Detail

RepopulateConversionErrorFieldValidatorSupport

public RepopulateConversionErrorFieldValidatorSupport()
Method Detail

getRepopulateField

public String getRepopulateField()

setRepopulateField

public void setRepopulateField(String repopulateField)

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Parameters:
object - the object to be validated.
Throws:
ValidationException - is thrown if there is validation error(s).

repopulateField

public void repopulateField(Object object)
                     throws ValidationException
Throws:
ValidationException

doValidate

protected abstract void doValidate(Object object)
                            throws ValidationException
Throws:
ValidationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequiredFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class RequiredFieldValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.RequiredFieldValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class RequiredFieldValidator
extends FieldValidatorSupport

RequiredFieldValidator checks if the specified field is not null.

  • fieldName - field name if plain-validator syntax is used, not needed if field-validator syntax is used

           <validators>

         <!-- Plain Validator Syntax -->
         <validator type="required">
             <param name="fieldName">username</param>
             <message>username must not be null</message>
         </validator>

         <!-- Field Validator Syntax -->
         <field name="username">
             <field-validator type="required">
                   <message>username must not be null</message>
             </field-validator>
         </field>

     </validators>

Version:
$Revision: 1063 $
Author:
rainerh

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
RequiredFieldValidator()
Method Summary
 void validate(Object object)
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getMessageParameters, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setMessageParameters, setParse, setShortCircuit, setValidatorContext, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getMessageParameters, getValidatorContext, setDefaultMessage, setMessageKey, setMessageParameters, setValidatorContext, setValueStack

Constructor Detail

RequiredFieldValidator

public RequiredFieldValidator()
Method Detail

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Parameters:
object - the object to be validated.
Throws:
ValidationException - is thrown if there is validation error(s).
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequiredStringValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class RequiredStringValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.RequiredStringValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class RequiredStringValidator
extends FieldValidatorSupport

RequiredStringValidator checks that a String field is non-null and has a length > 0. (i.e. it isn't ""). The "trim" parameter determines whether it will trim the String before performing the length check. If unspecified, the String will be trimmed.

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required
  • trim - trim the field name value before validating (default is true)

     <validators>
         <!-- Plain-Validator Syntax -->
         <validator type="requiredstring">
             <param name="fieldName">username</param>
             <param name="trim">true</param>
             <message>username is required</message>
         </validator>

         <!-- Field-Validator Syntax -->
         <field name="username">
                  <field-validator type="requiredstring">
                 <param name="trim">true</param>
                 <message>username is required</message>
            </field-validator>
         </field>
     </validators>

Version:
$Date: 2006-07-10 02:30:29 +0200 (Mo, 10 Jul 2006) $ $Id: RequiredStringValidator.java 1063 2006-07-10 00:30:29Z mrdon $
Author:
rainerh

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
RequiredStringValidator()
Method Summary
boolean | getTrim()
void | setTrim(boolean trim)
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getMessageParameters, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setMessageParameters, setParse, setShortCircuit, setValidatorContext, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getMessageParameters, getValidatorContext, setDefaultMessage, setMessageKey, setMessageParameters, setValidatorContext, setValueStack

Constructor Detail

RequiredStringValidator

public RequiredStringValidator()
Method Detail

setTrim

public void setTrim(boolean trim)

getTrim

public boolean getTrim()

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Parameters:
object - the object to be validated.
Throws:
ValidationException - is thrown if there is validation error(s).
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShortRangeFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class ShortRangeFieldValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
                extended by  com.opensymphony.xwork2.validator.validators.ShortRangeFieldValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class ShortRangeFieldValidator
extends AbstractRangeValidator

Field Validator that checks if the short specified is within a certain range.

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required
  • min - the minimum value (if none is specified, it will not be checked)
  • max - the maximum value (if none is specified, it will not be checked)

              <validators>
           <!-- Plain Validator Syntax -->
           <validator type="short">
               <param name="fieldName">age</param>
               <param name="min">20</param>
               <param name="max">50</param>
               <message>Age needs to be between ${min} and ${max}</message>
           </validator>

           <!-- Field Validator Syntax -->
           <field name="age">
               <field-validator type="short">
                   <param name="min">20</param>
                   <param name="max">50</param>
                   <message>Age needs to be between ${min} and ${max}</message>
               </field-validator>
           </field>
      </validators>

Version:
$Date$

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
ShortRangeFieldValidator()
Method Summary
Short | getMax()
Comparable | getMaxComparatorValue()
Short | getMin()
Comparable | getMinComparatorValue()
void | setMax(Short max)
void | setMin(Short min)
Methods inherited from class com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
validate
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getMessageParameters, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setMessageParameters, setParse, setShortCircuit, setValidatorContext, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getMessageParameters, getValidatorContext, setDefaultMessage, setMessageKey, setMessageParameters, setValidatorContext, setValueStack

Constructor Detail

ShortRangeFieldValidator

public ShortRangeFieldValidator()
Method Detail

setMax

public void setMax(Short max)

getMax

public Short getMax()

getMaxComparatorValue

public Comparable getMaxComparatorValue()
Specified by:
getMaxComparatorValue in class AbstractRangeValidator

setMin

public void setMin(Short min)

getMin

public Short getMin()

getMinComparatorValue

public Comparable getMinComparatorValue()
Specified by:
getMinComparatorValue in class AbstractRangeValidator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StringLengthFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class StringLengthFieldValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class StringLengthFieldValidator
extends FieldValidatorSupport

StringLengthFieldValidator checks that a String field is of a certain length. If the "minLength" parameter is specified, it will make sure that the String has at least that many characters. If the "maxLength" parameter is specified, it will make sure that the String has at most that many characters. The "trim" parameter determines whether it will trim the String before performing the length check. If unspecified, the String will be trimmed.

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required
  • maxLength - The max length of the field value. Default ignore.
  • minLength - The min length of the field value. Default ignore.
  • trim - Trim the field value before evaluating its min/max length. Default true

      <validators>
           <!-- Plain Validator Syntax -->
           <validator type="stringlength">
                <param name="fieldName">myPurchaseCode</param>
                <param name="minLength">10</param>
                <param name="maxLength">10</param>
                <param name="trim">true</param>
                <message>Your purchase code needs to be 10 characters long</message>
            </validator>

            <!-- Field Validator Syntax -->
            <field name="myPurchaseCode">
                <field-validator type="stringlength">
                     <param name="minLength">10</param>
                     <param name="maxLength">10</param>
                     <param name="trim">true</param>
                     <message>Your purchase code needs to be 10 characters long</message>
                </field-validator>
            </field>
      </validators>

Version:
$Date: 2008-06-11 12:20:19 +0200 (Mi, 11 Jun 2008) $ $Id: StringLengthFieldValidator.java 1786 2008-06-11 10:20:19Z rainerh $
Author:
Jason Carreira, Mark Woon, tmjee

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
StringLengthFieldValidator()
Method Summary
int | getMaxLength()
int | getMinLength()
boolean | getTrim()
void | setMaxLength(int maxLength)
void | setMinLength(int minLength)
void | setTrim(boolean trim)
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getMessageParameters, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setMessageParameters, setParse, setShortCircuit, setValidatorContext, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getMessageParameters, getValidatorContext, setDefaultMessage, setMessageKey, setMessageParameters, setValidatorContext, setValueStack

Constructor Detail

StringLengthFieldValidator

public StringLengthFieldValidator()
Method Detail

setMaxLength

public void setMaxLength(int maxLength)

getMaxLength

public int getMaxLength()

setMinLength

public void setMinLength(int minLength)

getMinLength

public int getMinLength()

setTrim

public void setTrim(boolean trim)

getTrim

public boolean getTrim()

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Parameters:
object - the object to be validated.
Throws:
ValidationException - is thrown if there is validation error(s).
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


URLValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class URLValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.URLValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class URLValidator
extends FieldValidatorSupport

URLValidator checks that a given field is a String and a valid URL

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required

     <validators>
          <!-- Plain Validator Syntax -->
          <validator type="url">
              <param name="fieldName">myHomePage</param>
              <message>Invalid homepage url</message>
          </validator>

          <!-- Field Validator Syntax -->
          <field name="myHomepage">
              <message>Invalid homepage url</message>
          </field>
     </validators>

Version:
$Date: 2009-03-18 18:40:42 +0100 (Mi, 18 Mär 2009) $ $Revision: 1946 $
Author:
$Author: musachy $

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
URLValidator()
Method Summary
 void validate(Object object)
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getMessageParameters, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setMessageParameters, setParse, setShortCircuit, setValidatorContext, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getMessageParameters, getValidatorContext, setDefaultMessage, setMessageKey, setMessageParameters, setValidatorContext, setValueStack

Constructor Detail

URLValidator

public URLValidator()
Method Detail

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Parameters:
object - the object to be validated.
Throws:
ValidationException - is thrown if there is validation error(s).
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidatorSupport (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class ValidatorSupport

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
All Implemented Interfaces:
ShortCircuitableValidator, Validator
Direct Known Subclasses:
ExpressionValidator, FieldValidatorSupport
public abstract class ValidatorSupport
extends Object
implements Validator, ShortCircuitableValidator

Abstract implementation of the Validator interface suitable for subclassing.

Author:
Jason Carreira, tm_jee, Martin Gilday

Field Summary
protected String | defaultMessage
protected Logger | log
protected String | messageKey
Constructor Summary
ValidatorSupport()
Method Summary
protected void | addActionError(Object object)
protected void | addFieldError(String propertyName, Object object)
protected Object | conditionalParse(String expression) Parse expression passed in against value stack.
String | getDefaultMessage() Gets the default message used for validation failures
protected Object | getFieldValue(String name, Object object) Return the field value named name from object, object should have the appropriate getter/setter.
String | getMessage(Object object) Gets the validation failure message for the given object
String | getMessageKey() Gets the resource bundle key used for lookup of validation failure message
String[] | getMessageParameters() Gets the messsage parameters to be used when parsing i18n messages
boolean | getParse()
ValidatorContext | getValidatorContext() Gets the validation context used
String | getValidatorType() Gets the vaildator type used (see class javadoc).
boolean | isShortCircuit() Gets whether this field validator should short circuit the validator queue it's in if validation fails.
void | setDefaultMessage(String message) Sets the default message to use for validation failure
void | setMessageKey(String key) Sets a resource bundle key to be used for lookup of validation failure message
void | setMessageParameters(String[] messageParameters) Sets the messsage parameters to be used when parsing i18n messages
void | setParse(boolean parse)
void | setShortCircuit(boolean shortcircuit) Sets whether this field validator should short circuit the validator queue it's in if validation fails.
void | setValidatorContext(ValidatorContext validatorContext) This method will be called before validate with a non-null ValidatorContext.
void | setValidatorType(String type) Sets the validator type to use (see class javadoc).
void | setValueStack(ValueStack stack) Sets the value stack to use to resolve values and parameters
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
validate

Field Detail

log

protected final Logger log

defaultMessage

protected String defaultMessage

messageKey

protected String messageKey
Constructor Detail

ValidatorSupport

public ValidatorSupport()
Method Detail

setValueStack

public void setValueStack(ValueStack stack)
Description copied from interface: Validator
Sets the value stack to use to resolve values and parameters

Specified by:
setValueStack in interface Validator
Parameters:
stack - The value stack for the request

setDefaultMessage

public void setDefaultMessage(String message)
Description copied from interface: Validator
Sets the default message to use for validation failure

Specified by:
setDefaultMessage in interface Validator
Parameters:
message - the default message

getDefaultMessage

public String getDefaultMessage()
Description copied from interface: Validator
Gets the default message used for validation failures

Specified by:
getDefaultMessage in interface Validator
Returns:
the default message

setParse

public void setParse(boolean parse)

getParse

public boolean getParse()

getMessage

public String getMessage(Object object)
Description copied from interface: Validator
Gets the validation failure message for the given object

Specified by:
getMessage in interface Validator
Parameters:
object - object being validated (eg. a domain model object)
Returns:
the validation failure message

setMessageKey

public void setMessageKey(String key)
Description copied from interface: Validator
Sets a resource bundle key to be used for lookup of validation failure message

Specified by:
setMessageKey in interface Validator
Parameters:
key - the resource bundle key

getMessageKey

public String getMessageKey()
Description copied from interface: Validator
Gets the resource bundle key used for lookup of validation failure message

Specified by:
getMessageKey in interface Validator
Returns:
the resource bundle key

getMessageParameters

public String[] getMessageParameters()
Description copied from interface: Validator
Gets the messsage parameters to be used when parsing i18n messages

Specified by:
getMessageParameters in interface Validator
Returns:
the messsage parameters

setMessageParameters

public void setMessageParameters(String[] messageParameters)
Description copied from interface: Validator
Sets the messsage parameters to be used when parsing i18n messages

Specified by:
setMessageParameters in interface Validator
Parameters:
messageParameters - the messsage parameters

setShortCircuit

public void setShortCircuit(boolean shortcircuit)
Description copied from interface: ShortCircuitableValidator
Sets whether this field validator should short circuit the validator queue it's in if validation fails.

Specified by:
setShortCircuit in interface ShortCircuitableValidator
Parameters:
shortcircuit - true if this field validator should short circuit on failure, false otherwise

isShortCircuit

public boolean isShortCircuit()
Description copied from interface: ShortCircuitableValidator
Gets whether this field validator should short circuit the validator queue it's in if validation fails.

Specified by:
isShortCircuit in interface ShortCircuitableValidator
Returns:
true if this field validator should short circuit on failure, false otherwise

setValidatorContext

public void setValidatorContext(ValidatorContext validatorContext)
Description copied from interface: Validator
This method will be called before validate with a non-null ValidatorContext.

Specified by:
setValidatorContext in interface Validator
Parameters:
validatorContext - the validation context to use.

getValidatorContext

public ValidatorContext getValidatorContext()
Description copied from interface: Validator
Gets the validation context used

Specified by:
getValidatorContext in interface Validator
Returns:
the validation context

setValidatorType

public void setValidatorType(String type)
Description copied from interface: Validator
Sets the validator type to use (see class javadoc).

Specified by:
setValidatorType in interface Validator
Parameters:
type - the type to use.

getValidatorType

public String getValidatorType()
Description copied from interface: Validator
Gets the vaildator type used (see class javadoc).

Specified by:
getValidatorType in interface Validator
Returns:
the type used

conditionalParse

protected Object conditionalParse(String expression)
Parse expression passed in against value stack. Only parse when 'parse' param is set to true, else just returns the expression unparsed.

Parameters:
expression -
Returns:
Object

getFieldValue

protected Object getFieldValue(String name,
                               Object object)
                        throws ValidationException
Return the field value named name from object, object should have the appropriate getter/setter.

Parameters:
name -
object -
Returns:
Object as field value
Throws:
ValidationException

addActionError

protected void addActionError(Object object)

addFieldError

protected void addFieldError(String propertyName,
                             Object object)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VisitorFieldValidator (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class VisitorFieldValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.VisitorFieldValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
Direct Known Subclasses:
ConditionalVisitorFieldValidator
public class VisitorFieldValidator
extends FieldValidatorSupport

The VisitorFieldValidator allows you to forward validation to object properties of your action using the object's own validation files. This allows you to use the ModelDriven development pattern and manage your validations for your models in one place, where they belong, next to your model classes. The VisitorFieldValidator can handle either simple Object properties, Collections of Objects, or Arrays.

  • fieldName - field name if plain-validator syntax is used, not needed if field-validator syntax is used
  • context - the context of which validation should take place. Optional
  • appendPrefix - the prefix to be added to field. Optional

    <validators>
        <!-- Plain Validator Syntax -->
        <validator type="visitor">
            <param name="fieldName">user</param>
            <param name="context">myContext</param>
            <param name="appendPrefix">true</param>
        </validator>

        <!-- Field Validator Syntax -->
        <field name="user">
           <field-validator type="visitor">
              <param name="context">myContext</param>
              <param name="appendPrefix">true</param>
           </field-validator>
        </field>
    </validators>

In the example above, if the acion's getUser() method return User object, XWork will look for User-myContext-validation.xml for the validators. Since appednPrefix is true, every field name will be prefixed with 'user' such that if the actual field name for 'name' is 'user.name'

Version:
$Date: 2008-06-21 11:29:39 +0200 (Sa, 21 Jun 2008) $ $Id: VisitorFieldValidator.java 1833 2008-06-21 09:29:39Z rainerh $
Author:
Jason Carreira, Rainer Hermanns

Nested Class Summary
static class VisitorFieldValidator.AppendingValidatorContext
Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
VisitorFieldValidator()
Method Summary
String | getContext()
boolean | isAppendPrefix() Flags whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs.
void | setActionValidatorManager(ActionValidatorManager mgr)
void | setAppendPrefix(boolean appendPrefix) Sets whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs.
void | setContext(String context)
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getMessageParameters, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setMessageParameters, setParse, setShortCircuit, setValidatorContext, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getMessageParameters, getValidatorContext, setDefaultMessage, setMessageKey, setMessageParameters, setValidatorContext, setValueStack

Constructor Detail

VisitorFieldValidator

public VisitorFieldValidator()
Method Detail

setActionValidatorManager

public void setActionValidatorManager(ActionValidatorManager mgr)

setAppendPrefix

public void setAppendPrefix(boolean appendPrefix)
Sets whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs. The default is true.

isAppendPrefix

public boolean isAppendPrefix()
Flags whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs. The default is true.

setContext

public void setContext(String context)

getContext

public String getContext()

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Parameters:
object - the object to be validated.
Throws:
ValidationException - is thrown if there is validation error(s).
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VisitorFieldValidator.AppendingValidatorContext (XWork: Core 2.1.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class VisitorFieldValidator.AppendingValidatorContext

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.DelegatingValidatorContext
        extended by  com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext
All Implemented Interfaces:
LocaleProvider, TextProvider, ValidationAware, ValidatorContext
Enclosing class:
VisitorFieldValidator
public static class VisitorFieldValidator.AppendingValidatorContext
extends DelegatingValidatorContext

Constructor Summary
VisitorFieldValidator.AppendingValidatorContext(ValidatorContext parent, Object object, String field, String message)
Method Summary
void | addActionError(String anErrorMessage) Add an Action-level error message to this Action.
void | addFieldError(String fieldName, String errorMessage) Add an error message for a given field.
String | getFullFieldName(String fieldName) Translates a simple field name into a full field name in Ognl syntax
String | getFullFieldNameFromParent(String fieldName)
Methods inherited from class com.opensymphony.xwork2.validator.DelegatingValidatorContext
addActionMessage, getActionErrors, getActionMessages, getFieldErrors, getLocale, getText, getText, getText, getText, getText, getText, getText, getText, getText, getTextProvider, getTexts, getTexts, getValidationAware, hasActionErrors, hasActionMessages, hasErrors, hasFieldErrors, hasKey, makeLocaleProvider, makeTextProvider, makeValidationAware, setActionErrors, setActionMessages, setFieldErrors, setTextProvider, setValidationAware
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

VisitorFieldValidator.AppendingValidatorContext

public VisitorFieldValidator.AppendingValidatorContext(ValidatorContext parent,
                                                       Object object,
                                                       String field,
                                                       String message)
Method Detail

getFullFieldName

public String getFullFieldName(String fieldName)
Translates a simple field name into a full field name in Ognl syntax

Specified by:
getFullFieldName in interface ValidatorContext
Overrides:
getFullFieldName in class DelegatingValidatorContext
Parameters:
fieldName - field name in OGNL syntax
Returns:
field name in OGNL syntax

getFullFieldNameFromParent

public String getFullFieldNameFromParent(String fieldName)

addActionError

public void addActionError(String anErrorMessage)
Description copied from interface: ValidationAware
Add an Action-level error message to this Action.

Specified by:
addActionError in interface ValidationAware
Overrides:
addActionError in class DelegatingValidatorContext
Parameters:
anErrorMessage - the error message

addFieldError

public void addFieldError(String fieldName,
                          String errorMessage)
Description copied from interface: ValidationAware
Add an error message for a given field.

Specified by:
addFieldError in interface ValidationAware
Overrides:
addFieldError in class DelegatingValidatorContext
Parameters:
fieldName - name of field
errorMessage - the error message
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.opensymphony.xwork2.validator.validators.AbstractRangeValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.AbstractRangeValidator

Packages that use AbstractRangeValidator
com.opensymphony.xwork2.validator.validators XWork default validator classes.

Uses of AbstractRangeValidator in com.opensymphony.xwork2.validator.validators

Subclasses of AbstractRangeValidator in com.opensymphony.xwork2.validator.validators
class | DateRangeFieldValidator Field Validator that checks if the date supplied is within a specific range.
class | IntRangeFieldValidator Field Validator that checks if the integer specified is within a certain range.
class | LongRangeFieldValidator Field Validator that checks if the long specified is within a certain range.
class | ShortRangeFieldValidator Field Validator that checks if the short specified is within a certain range.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.ConditionalVisitorFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.ConditionalVisitorFieldValidator

No usage of com.opensymphony.xwork2.validator.validators.ConditionalVisitorFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.ConversionErrorFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.ConversionErrorFieldValidator

No usage of com.opensymphony.xwork2.validator.validators.ConversionErrorFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator

No usage of com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

No usage of com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.EmailValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.EmailValidator

No usage of com.opensymphony.xwork2.validator.validators.EmailValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.ExpressionValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.ExpressionValidator

No usage of com.opensymphony.xwork2.validator.validators.ExpressionValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.FieldExpressionValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.FieldExpressionValidator

No usage of com.opensymphony.xwork2.validator.validators.FieldExpressionValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.FieldValidatorSupport

Packages that use FieldValidatorSupport
com.opensymphony.xwork2.validator.validators XWork default validator classes.

Uses of FieldValidatorSupport in com.opensymphony.xwork2.validator.validators

Subclasses of FieldValidatorSupport in com.opensymphony.xwork2.validator.validators
class | AbstractRangeValidator Base class for range based validators.
class | ConditionalVisitorFieldValidator ConditionalVisitorFieldValidator <field name="colleaguePosition"> <field-validator type="fieldexpression" short-circuit="true"> reason == 'colleague' and colleaguePositionID == '_CHOOSE_' <message>You must choose a position where you worked with this person, or choose "Other..."</message> </field-validator> <field-validator type="conditionalvisitor"> reason == 'colleague' and colleaguePositionID == 'OTHER' <message/> </field-validator> </field>
class | ConversionErrorFieldValidator Field Validator that checks if a conversion error occured for this field.
class | DateRangeFieldValidator Field Validator that checks if the date supplied is within a specific range.
class | DoubleRangeFieldValidator Field Validator that checks if the double specified is within a certain range.
class | EmailValidator EmailValidator checks that a given String field, if not empty, is a valid email address.
class | FieldExpressionValidator Validates a field using an OGNL expression.
class | IntRangeFieldValidator Field Validator that checks if the integer specified is within a certain range.
class | LongRangeFieldValidator Field Validator that checks if the long specified is within a certain range.
class | RegexFieldValidator Validates a string field using a regular expression.
class | RepopulateConversionErrorFieldValidatorSupport An abstract base class that adds in the capability to populate the stack with a fake parameter map when a conversion error has occurred and the 'repopulateField' property is set to "true".
class | RequiredFieldValidator RequiredFieldValidator checks if the specified field is not null.
class | RequiredStringValidator RequiredStringValidator checks that a String field is non-null and has a length > 0.
class | ShortRangeFieldValidator Field Validator that checks if the short specified is within a certain range.
class | StringLengthFieldValidator StringLengthFieldValidator checks that a String field is of a certain length.
class | URLValidator URLValidator checks that a given field is a String and a valid URL fieldName - The field name this validator is validating.
class | VisitorFieldValidator The VisitorFieldValidator allows you to forward validation to object properties of your action using the object's own validation files.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator

No usage of com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.LongRangeFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.LongRangeFieldValidator

No usage of com.opensymphony.xwork2.validator.validators.LongRangeFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.RegexFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.RegexFieldValidator

Packages that use RegexFieldValidator
com.opensymphony.xwork2.validator.validators XWork default validator classes.

Uses of RegexFieldValidator in com.opensymphony.xwork2.validator.validators

Subclasses of RegexFieldValidator in com.opensymphony.xwork2.validator.validators
 class EmailValidator
EmailValidator checks that a given String field, if not empty, is a valid email address.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport

Packages that use RepopulateConversionErrorFieldValidatorSupport
com.opensymphony.xwork2.validator.validators XWork default validator classes.

Uses of RepopulateConversionErrorFieldValidatorSupport in com.opensymphony.xwork2.validator.validators

Subclasses of RepopulateConversionErrorFieldValidatorSupport in com.opensymphony.xwork2.validator.validators
 class ConversionErrorFieldValidator
Field Validator that checks if a conversion error occured for this field.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.RequiredFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.RequiredFieldValidator

No usage of com.opensymphony.xwork2.validator.validators.RequiredFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.RequiredStringValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.RequiredStringValidator

No usage of com.opensymphony.xwork2.validator.validators.RequiredStringValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.ShortRangeFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.ShortRangeFieldValidator

No usage of com.opensymphony.xwork2.validator.validators.ShortRangeFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator

No usage of com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.URLValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.URLValidator

No usage of com.opensymphony.xwork2.validator.validators.URLValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.ValidatorSupport (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.ValidatorSupport

Packages that use ValidatorSupport
com.opensymphony.xwork2.validator.validators XWork default validator classes.

Uses of ValidatorSupport in com.opensymphony.xwork2.validator.validators

Subclasses of ValidatorSupport in com.opensymphony.xwork2.validator.validators
class | AbstractRangeValidator Base class for range based validators.
class | ConditionalVisitorFieldValidator ConditionalVisitorFieldValidator <field name="colleaguePosition"> <field-validator type="fieldexpression" short-circuit="true"> reason == 'colleague' and colleaguePositionID == '_CHOOSE_' <message>You must choose a position where you worked with this person, or choose "Other..."</message> </field-validator> <field-validator type="conditionalvisitor"> reason == 'colleague' and colleaguePositionID == 'OTHER' <message/> </field-validator> </field>
class | ConversionErrorFieldValidator Field Validator that checks if a conversion error occured for this field.
class | DateRangeFieldValidator Field Validator that checks if the date supplied is within a specific range.
class | DoubleRangeFieldValidator Field Validator that checks if the double specified is within a certain range.
class | EmailValidator EmailValidator checks that a given String field, if not empty, is a valid email address.
class | ExpressionValidator A Non-Field Level validator that validates based on regular expression supplied.
class | FieldExpressionValidator Validates a field using an OGNL expression.
class | FieldValidatorSupport Base class for field validators.
class | IntRangeFieldValidator Field Validator that checks if the integer specified is within a certain range.
class | LongRangeFieldValidator Field Validator that checks if the long specified is within a certain range.
class | RegexFieldValidator Validates a string field using a regular expression.
class | RepopulateConversionErrorFieldValidatorSupport An abstract base class that adds in the capability to populate the stack with a fake parameter map when a conversion error has occurred and the 'repopulateField' property is set to "true".
class | RequiredFieldValidator RequiredFieldValidator checks if the specified field is not null.
class | RequiredStringValidator RequiredStringValidator checks that a String field is non-null and has a length > 0.
class | ShortRangeFieldValidator Field Validator that checks if the short specified is within a certain range.
class | StringLengthFieldValidator StringLengthFieldValidator checks that a String field is of a certain length.
class | URLValidator URLValidator checks that a given field is a String and a valid URL fieldName - The field name this validator is validating.
class | VisitorFieldValidator The VisitorFieldValidator allows you to forward validation to object properties of your action using the object's own validation files.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.VisitorFieldValidator

Packages that use VisitorFieldValidator
com.opensymphony.xwork2.validator.validators XWork default validator classes.

Uses of VisitorFieldValidator in com.opensymphony.xwork2.validator.validators

Subclasses of VisitorFieldValidator in com.opensymphony.xwork2.validator.validators
 class ConditionalVisitorFieldValidator
ConditionalVisitorFieldValidator <field name="colleaguePosition"> <field-validator type="fieldexpression" short-circuit="true"> reason == 'colleague' and colleaguePositionID == '_CHOOSE_' <message>You must choose a position where you worked with this person, or choose "Other..."</message> </field-validator> <field-validator type="conditionalvisitor"> reason == 'colleague' and colleaguePositionID == 'OTHER' <message/> </field-validator> </field>

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext (XWork: Core 2.1.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext

No usage of com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES